国家 / 地区

03-典型配置案例(AC+FIT AP)

49-H3C无线控制器IPv6源地址验证典型配置举例(V7)

本章节下载  (188.48 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202007/1313738_30005_0.htm

49-H3C无线控制器IPv6源地址验证典型配置举例(V7)

H3C 无线控制器

IPv6源地址验证典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍无线控制器IPv6源地址验证的典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解IPv6源地址验证与WLAN接入相关特性。

3  IPv6源地址验证配置举例

3.1  组网需求

图1所示,AC、AP、Host和DHCPv6 server之间均通过交换机连接,Client 1支持IPv6地址的有状态地址配置,DHCPv6 server给AP和Client 1动态分配IPv6地址,Client 2手工静态配置IPv6地址。要求:

·            客户端通过名称为service的SSID接入网络。

·            通过DHCPv6方式形成绑定表项。

·            开启IPv6源地址验证功能,AP在收到从名称为service的SSID接入的客户端报文时,转发Client 1的报文,丢弃Client 2的报文。

图1 IPv6源地址验证配置组网图

 

3.2  配置注意事项

配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

3.3  配置步骤

3.3.1  AC的配置

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IPv6地址。AC将通过该VLAN与AP建立CAPWAP隧道。

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ipv6 address 2000:10::10/64

[AC-Vlan-interface100] quit

# 创建VLAN 200,AC需要使用该VLAN转发无线客户端数据报文。

[AC] vlan 200

[AC-vlan200] quit

# 配置AC与Switch连接的GigabitEthernet1/0/1接口的属性为Trunk,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

(2)       配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSID为service。

[AC-wlan-st-1] ssid service

# 开启通过DHCPv6方式学习客户端IPv6地址功能。

[AC-wlan-st-1] client ipv6-snooping dhcpv6-learning enable

# 配置IPv6源地址验证。

[AC-wlan-st-1] ipv6 verify source

# 使能无线服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

(3)       配置AP

# 创建手工AP,名称为officeap,型号名称为WA4320i-ACN。

[AC] wlan ap officeap model WA4320i-ACN

# 设置AP的序列号为210235A1GQB147031200。

[AC-wlan-ap-officeap] serial-id 210235A1GQB147031200

# 进入AP的Radio 1视图,并将无线服务模板1绑定到Radio 1上,并只能客户端上线的VLAN为VLAN 200。

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan-id 200

# 开启Radio 1的射频功能。

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] quit

3.3.2  Switch 的配置

# 创建VLAN 100和VLAN 200,其中VLAN 100用于转发AC和AP间CAPWAP隧道内的流量,VLAN 200为无线用户接入的VLAN。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] vlan 200

[Switch-vlan200] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,当前Trunk口的PVID为100,允许VLAN 100和VLAN 200通过。

[Switch] interface GigabitEthernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface GigabitEthernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 使能PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit。

3.4  验证配置

(1)       Client 1(0024-d774-e6f4)上线,并获取到IPv6地址2000:10::2/64;

(2)       Client 2(0024-0130-696b)上线,配置静态IPv6单播地址2000:10::3/64;

(3)       从无线客户端Client 1ping同网段中的主机Host,可以ping通。

C:\Users\>ping -S 2000:10::2  2000:10::1

 

Pinging 2000:10::1 from 2000:10::2 with 32 bytes of data:

Reply from 2000:10::1 : time=22ms

Reply from 2000:10::1 : time=61ms

Reply from 2000:10::1 : time=32ms

Reply from 2000:10::1 : time=16ms

 

Ping statistics for 2000:10::1 :

    Packets: Sent = 4,Received = 4,Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 16ms,Maximum = 61ms,Average = 32ms

 

(4)       从无线客户端Client 2ping同网段中的主机Host,不能ping通。

C:\Users\>ping -S 2000:10::3 2000:10::1

 

Pinging 2000:10::1  from 2000:10::3  with 32 bytes of data:

Request timed out.

Request timed out.

Request timed out.

Request timed out.

 

Ping statistics for 2000: 10::1 :

    Packets: Sent = 4,Received = 0,Lost = 4 (100% loss),

3.5  配置文件

·            AC:

#

vlan 100

#

vlan 200

#

wlan service-template 1 clear

 ssid service

 ipv6 verify source

 client ipv6-snooping dhcpv6-learning enable

 service-template enable

#

interface Vlan-interface100

 ip address 2000:10::10/64

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

wlan ap officeap model WA4320i-ACN

 serial-id 210235A1GQB147031200

 radio 1

  service-template 1 vlan 200

  radio enable

radio 2

#

·            Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 1 100 200

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port link-mode bridge

 port access vlan 100

 poe enable

#

4  相关资料

·            《H3C无线控制器产品 配置指导》中的“AP管理配置指导”。

·            《H3C无线控制器产品 命令参考》中的“AP管理命令参考”。

·            《H3C无线控制器产品 配置指导》中的“安全配置指导”。

·            《H3C无线控制器产品 命令参考》中的“安全命令参考”。

·            《H3C无线控制器产品 配置指导》中的“网络互通配置指导”。

·            《H3C无线控制器产品 命令参考》中的“网络互通命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部