国家 / 地区

03-典型配置案例(AC+FIT AP)

41-H3C无线控制器实现Remote AP功能典型配置举例(V7)

本章节下载  (207.51 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202007/1313730_30005_0.htm

41-H3C无线控制器实现Remote AP功能典型配置举例(V7)

H3C 无线控制器

实现Remote AP功能典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍了无线控制器实现Remote AP功能典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解Remote AP相关特性。

3  配置举例

3.1  组网需求

图1所示,AC通过Switch连接AP,Switch作为DHCP服务器为AP和Client分配IP地址。要求配置Remote AP功能,当AP与AC之间的隧道断开后,AP能够继续为客户端提供服务。

图1 无线控制器实现Remote AP功能组网图

 

3.2  配置注意事项

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·            仅当客户端数据报文的转发位置在AP上时,Remote AP功能才会生效。

·            为了将AP的GigabitEthernet1/0/1接口加入本地转发的VLAN 200,需要使用文本文档编辑AP的配置文件,并将配置文件上传到AC存储介质上。

3.3  配置步骤

1. 配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址192.1.0.1/16。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# 创建VLAN 200作为客户端接入的业务VLAN,并为该接口配置IP地址192.2.0.1/16,用于和无线客户端进行通信。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.0.1 16

[AC-Vlan-interface200] quit

# 将与Switch相连的接口GigabitEthernet1/0/1的链路类型配置为Trunk,并允许VLAN 100和VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

(2)       配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSID为service。

[AC-wlan-st-1] ssid service

# 配置VLAN 200的无线客户端的数据报文转发位置在AP上。

[AC-wlan-st-1] client forwarding-location ap vlan 200

# 开启无线服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

(3)       配置AP

# 创建手工AP,名称为officeap,型号为WA4320i-ACN,并配置序列号。

[AC] wlan ap officeap model WA4320i-ACN

[AC-wlan-ap-officeap] serial-id 219801A0T78159E09083

# 进入Radio 2视图。

[AC-wlan-ap-officeap] radio 2

# 将无线服务模板1绑定到Radio 2上,并绑定VLAN 200。

[AC-wlan-ap-officeap-radio-2] service-template 1 vlan 200

# 开启Radio 2的射频功能。

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

# 开启Remote AP功能。

[AC-wlan-ap-officeap] hybrid-remote-ap enable

(4)       配置AP的配置文件

# 在AC上将配置文件apcfg.txt下发到AP。

[AC-wlan-ap-officeap] map-configuration apcfg.txt

[AC-wlan-ap-officeap] quit

2. Switch的配置

(1)       配置Switch的接口

# 创建VLAN 100及其对应接口,并为该接口配置IP地址,用于转发AC和AP间CAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.2 16

[Switch-Vlan-interface100] quit

# 创建VLAN 200及其对应接口,并为该接口配置IP地址,用于和无线客户端进行通信。

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.2 16

[Switch-Vlan-interface200] quit

# 配置Switch和AC相连的接口GigabitEthernet1/0/1为Trunk类型,并允许VLAN 100和VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch和AP相连的接口GigabitEthernet1/0/2为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,当前Trunk口的PVID为100。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/2] quit

(2)       配置DHCP服务

# 开启DHCP功能。

[Switch] dhcp enable

# 创建名为vlan100的DHCP地址池,为AP动态分配网段为192.1.0.0/16,不参与自动分配的IP地址为192.1.0.1,网关地址为192.1.0.2的IP地址。

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan100] forbidden-ip 192.1.0.1

[Switch-dhcp-pool-vlan100] gateway-list 192.1.0.2

[Switch-dhcp-pool-vlan100] quit

# 创建名为vlan200的DHCP地址池,为Client动态分配网段为192.2.0.0/16,不参与自动分配的IP地址为192.2.0.1,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为192.2.0.2。

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan200] forbidden-ip 192.2.0.1

[Switch-dhcp-pool-vlan200] gateway-list 192.2.0.2

[Switch-dhcp-pool-vlan200] dns-list 192.2.0.2

[Switch-dhcp-pool-vlan200] quit

3. apcfg.txt的配置

说明

apcfg.txt的内容,要求为文本文件,按照命令行配置的顺序编写文本文件上传至AC即可,AC与AP关联后,通过map-configuration命令下发至AP生效。从而完成对AP的配置。

 

# apcfg.txt配置文件为:

system-view

vlan 200

interface GigabitEthernet 1/0/1

port link-type trunk

port trunk permit vlan 200

3.4  验证配置

当AP与AC间的隧道断开后,客户端将保持在线状态,AP能够继续转发客户端流量。

3.5  配置文件

·            AC:

#

vlan 100

#

Vlan 200

#

wlan service-template 1

 ssid service

 client forwarding-location ap vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.0.0

#

wlan ap officeap model WA4320i-ACN

serial-id 219801A0T78159E09083

map-configuration flash:/apcfg.txt

 hybrid-remote-ap enable

 radio 1

 radio 2

  radio enable

  service-template 1 vlan 200

 gigabitethernet 1

 gigabitethernet 2

#

·            apcfg.txt

system-view

vlan 200

quit

interface GigabitEthernet 1/0/1

port link-type trunk

port trunk permit vlan 200

·            Switch

#

dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 192.1.0.2

 network 192.1.0.0 mask 255.255.0.0

 forbidden-ip 192.1.0.1

#

dhcp server ip-pool vlan200

 gateway-list 192.2.0.2

 network 192.2.0.0 mask 255.255.0.0

 dns-list 192.2.0.2

 forbidden-ip 192.2.0.1

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

port trunk permit vlan 100 200

port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“AP管理配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“AP管理命令参考”。

·            《H3C 无线控制器产品 配置指导》中的“网络互通配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“网络互通命令参考”。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部