国家 / 地区

03-典型配置案例(AC+FIT AP)

40-H3C蓝牙之心AP实现ibeacon管理的典型配置举例(V7)

本章节下载  (323.40 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202007/1313729_30005_0.htm

40-H3C蓝牙之心AP实现ibeacon管理的典型配置举例(V7)

H3C 蓝牙之心AP

实现ibeacon管理的典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍基于H3C蓝牙之心AP实现iBeacon管理的典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解物联网AP和WLAN定位特性。

3  配置举例

3.1  组网需求

图1所示,通过蓝牙之心AP来对iBeacon设备进行管理,即由AP收集BLE信息,然后提供给定位服务器进行计算,使用户获取到无线网络中iBeacon设备的电量、RSSI等信息,并由AP将来自服务器的管理指令下发给iBeacon设备。

图1 蓝牙之心AP实现iBeacon管理组网图

 

3.2  配置注意事项

配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

3.3  配置步骤

3.3.1  配置AC

(1)       配置AC接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址192.1.0.1/16。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并配置该接口通过DHCP动态获取地址。

<AC> system-view

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address dhcp-alloc

[AC-Vlan-interface200] quit

# 将与Switch相连的接口GigabitEthernet1/0/1的链路类型配置为Trunk,禁止VLAN 1报文通过,允许VLAN 100、VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

(2)       创建AP

# 创建手工AP,名称为ap1,型号为WA4320-ACN-B,并配置序列号。

[AC] wlan ap ap1 model WA4320-ACN-B

[AC-wlan-ap-ap1] serial-id 210236A35VA11A100678ACNB

(3)       配置Module

# 进入Module 1视图。

[AC-wlan-ap-ap1] module 1

# 配置模块1的类型为BLE模块,并启动模块。

[AC-wlan-ap-ap1-module-1] type ble

[AC-wlan-ap-ap1-module-1] module enable

[AC-wlan-ap-ap1-module-1] quit

(4)       配置BLE定位功能

# 开启BLE定位功能。

[AC-wlan-ap-ap1] rfid-tracking ble enable

# 配置BLE定位服务器的IP地址为192.2.0.1,端口号为1145。(本举例配置的BLE定位服务器的IP地址为iMC server通过DHCP获取到的IP地址)

[AC-wlan-ap-ap1] rfid-tracking ble engine-address 192.2.0.1 engine-port 1145

# 开启AP向定位服务器上报邻居列表功能。

[AC-wlan-ap-ap1] rfid-tracking ble report enable

# 配置AP向定位服务器上报邻居列表的时间间隔为10秒。

[AC-wlan-ap-ap1] rfid-tracking ble report interval 10

# 配置BLE缺省指令密码为明文密码AprilBrother。(请根据实际设备使用的指令密码进行配置)

[AC-wlan-ap-ap1] rfid-tracking ble command-password simple AprilBrother

[AC-wlan-ap-ap1] quit

3.3.2  配置Switch

(1)       配置Switch接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址192.1.0.2/16,用于和AC、AP通信。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.2 16

[Switch-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址192.2.0.2/24,用于转发iMC server的流量。

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.2 24

[Switch-Vlan-interface200] quit

# 将与AC相连的接口GigabitEthernet1/0/1的链路类型配置为Trunk,禁止VLAN 1报文通过,允许VLAN 100、VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# 将与iMC server相连的接口GigabitEthernet1/0/2的链路类型配置为Access,当前Access口允许VLAN 200通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 200

[Switch-GigabitEthernet1/0/2] quit

# 将与AP相连的接口GigabitEthernet1/0/3的链路类型配置为Access,当前Access口允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 100

# 开启GigabitEthernet1/0/3接口的PoE功能。

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

(2)       配置DHCP功能

# 开启DHCP功能。

[Switch] dhcp enable

# 创建DHCP地址池1,为AP动态分配网段为192.1.0.0/16,不参与自动分配的IP地址为192.1.0.1,网关地址为192.1.0.2的IP地址。

[Switch] dhcp server ip-pool 1

[Switch-dhcp-pool-1] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-1] forbidden-ip 192.1.0.1

[Switch-dhcp-pool-1] gateway-list 192.1.0.2

[Switch-dhcp-pool-1] quit

# 创建DHCP地址池2,为AC的Vlan-interface 200接口和iMC server动态分配网段为192.2.0.0/24,网关地址为192.2.0.2的IP地址。

[Switch] dhcp server ip-pool 2

[Switch-dhcp-pool-2] network 192.2.0.0 mask 255.255.255.0

[Switch-dhcp-pool-2] gateway-list 192.2.0.2

[Switch-dhcp-pool-2] quit

3.3.3  配置iMC服务器

说明

下面以iMC为例(使用iMC版本为:iMC PLAT 7.2(E0403L02)、iMC WSM 7.2(E0502L03)),说明定位服务器的基本配置。

 

# 配置位置视图

登录进入iMC管理平台,选择“业务”页签,单击导航树中的[无线业务管理/视图管理/位置视图]菜单项,进入位置配置页面。单击<增加>按钮,进入增加位置页面。

·            输入位置名:BLE(自定义);

·            其他采用默认配置,单击<确定>按钮完成操作。

图2 增加位置视图

1

 

# 添加蓝牙AP

创建好位置视图后,进入位置视图点击<增加到本位置>按钮,把蓝牙AP添加到位置视图内。

·            勾选蓝牙AP;

·            单击<确定>按钮完成操作。

图3 添加蓝牙AP

1

 

图4 选择要添加的蓝牙AP

1

 

# 增加拓扑

在位置视图页面,点击BLE位置视图的“查看拓扑”按钮来添加拓扑。

·            在拓扑配置页面点击“增加地图”按钮来增加地图。

·            增加完地图后,点击“设置比例尺”按钮来设置比例尺。

·            保存拓扑。

图5 添加拓扑

 

图6 添加地图

 

图7 添加比例尺

 

图8 保存拓扑

 

3.4  验证配置

登录进入iMC管理平台,选择“业务”页签,单击导航树中的[无线业务管理/定位管理/iBeacon列表]查看iBeacon信息,可以看到iBeacon的电量,RSSI,UUID,Major ID,Minor ID,发射功率等信息。

图9 查看iBeacon信息

1

 

3.5  配置文件

·            AC

#

vlan 100

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address dhcp-alloc

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

 undo port trunk permit vlan 1

#

wlan ap ap1 model WA4320-ACN-B

 serial-id 210236A35VA11A100678ACNB

 rfid-tracking ble command-password cipher $c$3$AAu3rmjHUmAE0W12Rk1Jco6MPJ3Iqoh+pFgqhkFihw==

 rfid-tracking ble enable

 rfid-tracking ble engine-address 192.2.0.1 engine-port 1145

 rfid-tracking ble report enable

 rfid-tracking ble report interval 10

 radio 1

 radio 2

 module 1

   type BLE

   module enable

#

·            Switch

#

dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool 1

 gateway-list 192.1.0.2

 network 192.1.0.0 mask 255.255.0.0

 forbidden-ip 192.1.0.1

#

dhcp server ip-pool 2

 gateway-list 192.2.0.2

 network 192.2.0.0 mask 255.255.255.0

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

 undo port trunk permit vlan 1

#

interface GigabitEthernet1/0/2

 port access vlan 200

#

interface GigabitEthernet1/0/3

 port access vlan 100

 poe enable

#

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“物联网配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“物联网命令参考”。

·            《H3C 无线控制器产品 配置指导》中的“WLAN高级功能配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“WLAN高级功能命令参考”。

 

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部