国家 / 地区

03-典型配置案例(AC+FIT AP)

23-H3C无线控制器IPv6本地Portal认证典型配置举例(V7)

本章节下载  (368.38 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202007/1313712_30005_0.htm

23-H3C无线控制器IPv6本地Portal认证典型配置举例(V7)

H3C 无线控制器

IPv6本地Portal认证典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍IPv6本地Portal认证的典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解Portal认证的特性。

3  配置举例

3.1  组网需求

图1所示,Switch作为DHCP和DHCPv6 server为AP和Client分配IPv4和IPv6地址。现要求:

·            AC同时承担Portal Web服务器和Portal认证服务器的职责。

·            采用RADIUS服务器作为认证/计费服务器。

·            采用直接方式的Portal认证。

图1 本地Portal认证典型配置组网图

 

3.2  配置思路

·            为了使用户可以在VLAN内的任何二层端口上访问网络资源,且移动接入端口时无须重复认证,必须开启Portal用户漫游功能。

·            短时间内Portal客户端的频繁上下线可能会造成Portal认证失败,需要关闭Portal客户端ARP表项固化功能。

·            为了使RADIUS服务器对用户授权信息进行动态修改或强制用户下线,必须开启RADIUS session control功能。

·            设备的存储介质的根目录下必须存在认证页面文件。

3.3  配置注意事项

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·            AC上配置的Portal认证服务器和Portal Web服务器的服务器类型必须与实际服务器一致。

·            设备重定向给用户的Portal Web服务器的URL默认是不携带参数,需要根据实际应用手动添加需要携带的参数信息

·            若在VLAN接口视图下开启Portal认证,只能采用集中转发;若在服务模板视图下开启Portal认证,则本地转发和集中式转发都支持(本例以无线服务模板视图下开启Portal认证为例)。

·            如果本地Portal Web服务器提供的缺省认证页面文件需要更新,需要undo default-logon-page后重新配置,否则新页面不会生效。

3.4  配置步骤

3.4.1  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IPv4和IPv6地址。AP将通过该VLAN与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.1.1 24

[AC-Vlan-interface100] ipv6 address 2001::1 64

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IPv4和IPv6地址。Client将使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.168.2.1 24

[AC-Vlan-interface200] ipv6 address 2004::1 64

[AC-Vlan-interface200] quit

# 配置AC与Switch相连的接口GigabitEthernet1/0/1的属性为Trunk,允许VLAN 1、VLAN 100和VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 1 100 200

[AC-GigabitEthernet1/0/1] quit

(2)       配置静态路由

# 配置到iMC的静态路由。

[AC] ip route-static 192.168.3.0 255.255.255.0 192.168.2.2

[AC] ipv6 route-static 2003:: 64 2004::2

(3)       配置无线服务

# 创建无线服务模板st1,并进入无线服务模板视图。

[AC] wlan service-template st1

# 配置SSID为service。

[AC-wlan-st-st1] ssid service

# 配置无线服务模板VLAN为200。

[AC-wlan-st-st1] vlan 200

# 开启通过ND方式学习客户端IPv6地址功能。

[AC-wlan-st-st1] client ipv6-snooping nd-learning enable

# 开启通过DHCPv6方式学习客户端IPv6地址功能。

[AC-wlan-st-st1] client ipv6-snooping dhcpv6-learning enable

# 使能无线服务模板。

[AC-wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

# 创建AP,配置AP名称为office,型号名称选择WA4320i-ACN,并配置序列号219801A0CNC138011454。

[AC] wlan ap office model WA4320i-ACN

[AC-wlan-ap-office] serial-id 219801A0CNC138011454

# 进入Radio 2视图。

[AC-wlan-ap-office] radio 2

# 将无线服务模板st1绑定到radio 2,并开启射频。

[AC-wlan-ap-office-radio-2] service-template st1

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

(4)       配置IPv4 RADIUS方案

# 创建名称为rs1的RADIUS方案,并进入该方案视图。

[AC] radius scheme rs1

# 配置RADIUS方案的主认证和主计费服务器及其通信密钥。

[AC-radius-rs1] primary authentication 192.168.3.2

[AC-radius-rs1] primary accounting 192.168.3.2

[AC-radius-rs1] key authentication simple radius

[AC-radius-rs1] key accounting simple radius

# 配置发送给RADIUS服务器的用户名不携带ISP域名。

[AC-radius-rs1] user-name-format without-domain

# 设置设备发送RADIUS报文使用的源IP地址为192.168.1.1。

[AC-radius-rs1] nas-ip 192.168.1.1

[AC-radius-rs1] quit

(5)       配置IPv6 RADIUS方案

# 创建名称为rs2的RADIUS方案,并进入该方案视图。

[AC] radius scheme rs2

# 配置RADIUS方案的主认证和主计费服务器及其通信密钥。

[AC-radius-rs2] primary authentication ipv6 2003::2

[AC-radius-rs2] primary accounting ipv6 2003::2

[AC-radius-rs2] key authentication simple radius

[AC-radius-rs2] key accounting simple radius

# 配置发送给RADIUS服务器的用户名不携带ISP域名。

[AC-radius-rs2] user-name-format without-domain

# 设置设备发送RADIUS报文使用的源IPv6地址为2001::1。

[AC-radius-rs2] nas-ip ipv6 2001::1

[AC-radius-rs2] quit

# 使能RADUIS session control功能。

[AC] radius session-control enable

# 开启RADIUS DAE服务,并进入RADIUS DAE服务器视图。

[AC] radius dynamic-author server

# 设置RADIUS DAE客户端的IPv4地址为192.168.3.2,与RADIUS DAE客户端交互DAE报文时使用的共享密钥为明文radius。

[AC-radius-da-server] client ip 192.168.3.2 key simple radius

# 设置RADIUS DAE客户端的IPv6地址为2003::2,与RADIUS DAE客户端交互DAE报文时使用的共享密钥为明文radius。

[AC-radius-da-server] client ipv6 2003::2 key simple radius

[AC-radius-da-server] quit

(6)       配置IPv4用户认证域

# 创建名为dm1的ISP域并进入其视图。

[AC] domain dm1

# 为Portal用户配置AAA认证方法为RADIUS。

[AC-isp-dm1] authentication portal radius-scheme rs1

# 为Portal用户配置AAA授权方法为RADIUS。

[AC-isp-dm1] authorization portal radius-scheme rs1

# 为Portal用户配置AAA计费方法为none,不计费。

[AC-isp-dm1] accounting portal none

# 指定ISP域dm1下的用户闲置切断时间为15分钟,闲置切断时间内产生的流量为1024字节。

[AC-isp-dm1] authorization-attribute idle-cut 15 1024

[AC-isp-dm1] quit

(7)       配置IPv6用户认证域

# 创建名为dm2的ISP域并进入其视图。

[AC] domain dm2

# 为Portal用户配置AAA认证方法为RADIUS。

[AC-isp-dm2] authentication portal radius-scheme rs2

# 为Portal用户配置AAA授权方法为RADIUS。

[AC-isp-dm2] authorization portal radius-scheme rs2

# 为Portal用户配置AAA计费方法为none,不计费。

[AC-isp-dm2] accounting portal none

# 指定ISP域dm2下的用户闲置切断时间为15分钟,闲置切断时间内产生的流量为1024字节。

[AC-isp-dm2] authorization-attribute idle-cut 15 1024

[AC-isp-dm2] quit

(8)       配置Portal认证

# 配置IPv4 Portal Web服务器的URL为http://192.168.2.1/portal。

[AC] portal web-server newptv4

[AC-portal-websvr-newptv4] url http://192.168.2.1/portal

# 配置设备重定向给用户的IPv4 Portal Web服务器的URL中携带参数wlanuserip。

[AC-portal-websvr-newptv4] url-parameter wlanuserip source-address

[AC-portal-websvr-newptv4] quit

# 配置IPv6 Portal Web服务器的URL为http://[2004::1]/portal。

[AC] portal web-server newptv6

[AC-portal-websvr-newptv6] url http://[2004::1]/portal

# 配置设备重定向给用户的IPv6 Portal Web服务器的URL中携带参数wlanuserip。

[AC-portal-websvr-newptv6] url-parameter wlanuserip source-address

[AC-portal-websvr-newptv6] quit

# 在无线服务模板st1上使能直接方式的Portal认证。

[AC] wlan service-template st1

[AC-wlan-st-st1] portal enable method direct

[AC–wlan-st-st1] portal ipv6 enable method direct

# 配置接入的IPv4 Portal用户使用认证域为dm1。

[AC-wlan-st-st1] portal domain dm1

# 配置接入的IPv6 Portal用户使用认证域为dm2。

[AC-wlan-st-st1] portal ipv6 domain dm2

# 在无线服务模板st1上引用IPv4 Portal Web服务器newptv4。

[AC-wlan-st-st1] portal apply web-server newptv4

# 在无线服务模板st1上引用IPv6 Portal Web服务器newptv6。

[AC–wlan-st-st1] portal ipv6 apply web-server newptv6

# 开启Portal支持双协议栈功能。

[AC-wlan-st-st1] portal dual-stack enable

[AC–wlan-st-st1] quit

# 创建本地Portal Web 服务器,进入本地Portal Web服务器视图,并指定使用HTTP协议和客户端交互认证信息。

[AC] portal local-web-server http

# 配置本地Portal Web服务器提供的缺省认证页面文件为defaultfile.zip(设备的存储介质的根目录下必须已存在该认证页面文件,否则功能不生效)。

[AC–portal-local-websvr-http] default-logon-page defaultfile.zip

[AC–portal-local-websvr-http] quit

# 开启无线Portal漫游功能。

[AC] portal roaming enable

# 关闭无线Portal客户端ARP表项固化功能。

[AC] undo portal refresh arp enable

# 开启无线Portal客户端合法性检查功能。

[AC] portal host-check enable

# 配置一条Portal免认证规则:编号为3,源接口为聚合接口1。该规则表示从AC聚合接口1上的用户不需要经过Portal认证即可以访问网络资源。

[AC] portal free-rule 3 source interface Bridge-Aggregation1

3.4.2  配置Switch

(1)       配置Switch的接口

# 创建VLAN 100,用于转发AC和AP间CAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# 创建VLAN 200,用于转发Client无线报文。

[Switch] vlan 200

[Switch-vlan200] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,允许VLAN 1、VLAN 100和VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 1 100 200

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 使能PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# 配置VLAN 1接口的IPv4地址和IPv6地址。

[Switch] interface vlan-interface 1

[Switch-Vlan-interface1] ip address 192.168.3.1 255.255.255.0

[Switch-Vlan-interface1] ipv6 address 2003::1 64

[Switch-Vlan-interface1] quit

# 配置VLAN 100接口的IPv4地址和IPv6地址。

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.168.1.2 255.255.255.0

[Switch-Vlan-interface100] ipv6 address 2001::2 64

[Switch-Vlan-interface100] quit

# 配置VLAN 200接口的IPv4地址和IPv6地址。

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.168.2.2 255.255.255.0

[Switch-Vlan-interface200] ipv6 address 2004::2 64

[Switch-Vlan-interface200] quit

(2)       配置DHCP server

# 开启DHCP server功能。

[Switch] dhcp enable

# 配置DHCP地址池100为AP分配地址范围为192.168.1.0/24,网关地址为192.168.1.1。

[Switch] dhcp server ip-pool 100

[Switch-dhcp-pool-100] network 192.168.1.0 mask 255.255.255.0

[Switch-dhcp-pool-100] gateway-list 192.168.1.1

# 配置DHCP Option43的内容为AC的十六进制IP地址。

[Switch-dhcp-pool-100] option 43 hex 8007000001c0a80101

[Switch-dhcp-pool-100] quit

# 配置DHCP地址池200为Client分配地址范围为192.168.2.0/24,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为192.168.2.2。

[Switch] dhcp server ip-pool 200

[Switch-dhcp-pool-200] network 192.168.2.0 mask 255.255.255.0

[Switch-dhcp-pool-200] gateway-list 192.168.2.2

[Switch-dhcp-pool-200] dns-list 192.168.2.2

[Switch-dhcp-pool-200] quit

(3)       配置DHCPv6 server

# 配置DHCPv6地址池1,用于为AP分配IPv6地址。

[Switch] ipv6 dhcp pool 1

[Switch-dhcp6-pool-1] network 2001::/64

# 配置Option选项,使AP获取AC的IPv6地址。

[Switch-dhcp6-pool-1] option 52 hex 20010000000000000000000000000001

[Switch-dhcp6-pool-1] quit

[Switch] ipv6 dhcp server forbidden-address 2001::1

# 配置在VLAN 100接口下引用地址池1,并配置该接口工作在DHCPv6服务器模式。

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ipv6 dhcp server apply pool 1

[Switch-Vlan-interface100] ipv6 dhcp select server

# 取消VLAN 100接口对RA消息发布的抑制。配置被管理地址的配置标志位为1,即主机通过DHCPv6服务器获取IPv6地址。配置其他信息配置标志位为1,即主机通过DHCPv6服务器获取除IPv6地址以外的其他信息。

[Switch-Vlan-interface100] ipv6 nd autoconfig managed-address-flag

[Switch-Vlan-interface100] ipv6 nd autoconfig other-flag

[Switch-Vlan-interface100] undo ipv6 nd ra halt

[Switch-Vlan-interface100] quit

# 配置DHCPv6地址池2,用于为Client分配IPv6地址。

[Switch] ipv6 dhcp pool 2

[Switch-dhcp6-pool-2] network 2004::/64

[Switch-dhcp6-pool-2] quit

[Switch] ipv6 dhcp server forbidden-address 2004::1

# 配置在VLAN 200接口下引用地址池2,并配置该接口工作在DHCPv6服务器模式。

[Switch] interface Vlan-interface 200

[Switch-Vlan-interface200] ipv6 dhcp server apply pool 2

[Switch-Vlan-interface200] ipv6 dhcp select server

# 取消VLAN 200接口下对RA消息发布的抑制。配置被管理地址的配置标志位为1,即主机通过DHCPv6服务器获取IPv6地址。配置其他信息配置标志位为1,即主机通过DHCPv6服务器获取除IPv6地址以外的其他信息。

[Switch-Vlan-interface200] ipv6 nd autoconfig managed-address-flag

[Switch-Vlan-interface200] ipv6 nd autoconfig other-flag

[Switch-Vlan-interface200] undo ipv6 nd ra halt

[Switch-Vlan-interface200] quit

3.4.3  配置RADIUS服务器

说明

下面以iMC为例(使用iMC版本为:iMC PLAT 7.1、iMC EIA 7.1、iMC EIP 7.1)说明RADIUS server的基本配置。

 

# 增加接入设备

登录进入iMC管理平台,选择“用户”页签,单击导航树中的[接入策略管理/接入设备管理/接入设备配置]菜单项,单击<增加>按钮,进入“增加接入设备”页面。

·            配置共享密钥为radius,该共享密钥与AC上配置RADIUS服务器时的密钥一致;

·            单击<手工增加>按钮,进入“手工增加接入设备”页面,填写起始IP地址为192.168.1.1,单击<确定>按钮完成操作;

·            单击<增加IPv6设备>按钮,进入“手工增加接入设备”页面,添加IPv6地址为2001::1的接入设备;

·            其他配置采用页面默认配置即可。

图2 增加接入设备

 

# 增加接入策略

选择“用户”页签,单击导航树中的[接入策略管理/接入策略管理]菜单项,单击<增加>按钮,进入“增加接入策略”页面。

·            填写接入策略名;

·            选择业务分组;

·            其它参数采用缺省值,并单击<确定>按钮完成操作。

图3 增加接入策略配置

 

# 增加接入服务

选择“用户”页签,单击导航树中的[接入策略管理/接入服务管理]菜单项,单击<增加>按钮,进入“增加接入服务”页面。

·            填写服务名;

·            缺省接入策略选择已配置好的接入策略;

·            其它参数采用缺省值,并单击<确定>按钮完成操作。

图4 增加接入服务配置

 

# 增加接入用户

选择“用户”页签,单击导航树中的[接入用户管理/接入用户]菜单项,单击<增加>按钮,进入增加接入用户页面。

·            如果用户已存在,用户姓名选择可接入的用户,如果用户不存在,则需要单击<增加用户>按钮添加新用户;

·            填写账号名;

·            设置密码;

·            选中之前配置的服务;

·            其它参数可采用缺省配置。

图5 增加接入用户

 

3.5  验证配置

# 用户通过网页方式进行Portal认证。用户在通过IPv4认证前,发起的所有Web访问均被重定向到Portal认证页面(http://192.168.2.1/portal),在通过认证后,可访问非受限的互联网资源。

通过执行以下显示命令查看AC上生成的Portal在线用户信息。

[AC] display portal user all

Total portal users: 1                                                          

Username: client                                                               

  AP name: office                                                                 

  Radio ID: 2                                                                  

  SSID: service                                                                

  Portal server: N/A                                                           

  State: Online                                                                

  VPN instance: N/A                                                             

  MAC             IP                    VLAN    Interface                      

  3829-5a40-9589  192.168.2.3           200     WLAN-BSS1/0/2                  

  Authorization information:                                                    

    DHCP IP pool: N/A                                                          

    User profile: N/A                                                          

    Session group profile: N/A                                                  

    ACL number: N/A                                                            

    Inbound CAR: N/A                                                           

    Outbound CAR: N/A

# 用户通过网页方式进行Portal认证。用户在通过IPv6认证前,发起的所有Web访问均被重定向到Portal认证页面(http://[2004::1]/portal),在通过认证后,可访问非受限的互联网资源。

通过执行以下显示命令查看AC上生成的Portal在线用户信息。

[AC] display portal user all

Total portal users: 1

Username: client

  AP name: office

  Radio ID: 2

  SSID: service

  Portal server: N/A

  State: Online

  VPN instance: N/A

  MAC             IP                    VLAN    Interface

  3829-5a40-9589  2004::E97F:BBE1:832C: 200     WLAN-BSS1/0/2

                  3D3E

  Authorization information:

    DHCP IP pool: N/A

    User profile: N/A

    Session group profile: N/A

    ACL number: N/A

    Inbound CAR: N/A

    Outbound CAR: N/A

3.6  配置文件

·            AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 client ipv6-snooping nd-learning enable

 client ipv6-snooping dhcpv6-learning enable

 portal enable method direct                                                   

 portal domain dm1                                                             

 portal apply web-server newptv4

 portal ipv6 enable method direct

 portal ipv6 domain dm2

 portal ipv6 apply web-server newptv6

 portal dual-stack enable

 service-template enable

#

interface Vlan-interface100

 ip address 192.168.1.1 255.255.255.0

 ipv6 address 2001::1/64

#

interface Vlan-interface200

 ip address 192.168.2.1 255.255.255.0 

 ipv6 address 2004::1/64                                                       

#                                                                              

interface GigabitEthernet1/0/1                                                 

 port link-mode bridge                                                         

 port link-type trunk                                                          

 port trunk permit vlan 1 100 200                                              

#                                                                              

 ip route-static 192.168.3.0 24 192.168.2.2

 ipv6 route-static 2003:: 64 2004::2                                           

#                                                                               

 radius session-control enable                                                 

#                                                                              

radius scheme rs1                                                               

 primary authentication 192.168.3.2                                        

 primary accounting 192.168.3.2                                            

 key authentication cipher $c$3$2m4BXR2X65vE59L0SyyHH0tRVpkKDgym9w==           

 key accounting cipher $c$3$4ieHsnXQVnQ7GwywFS+H0MoQdb6SEmJSRg==               

 user-name-format without-domain                                               

 nas-ip 192.168.1.1                                                            

#

radius scheme rs2                                                              

 primary authentication ipv6 2003::2                                           

 primary accounting ipv6 2003::2                                               

 key authentication cipher $c$3$8bAMsBFXCGlbmynTi08YCxotgTXYwzES0w==           

 key accounting cipher $c$3$QeTcfxJGTnPJ98PsCSbLnaZP6KAG6q42aQ==               

 user-name-format without-domain                                               

 nas-ip ipv6 2001::1

#                                                                              

radius dynamic-author server                                                   

 client ip 192.168.3.2 key cipher $c$3$l9xAYe5vBJQMTOv6quHJFXtZlti404CjBg==

 client ipv6 2003::2 key cipher $c$3$ELOjfzKgjUoRbJ/wZX0E9eVdGBFeTQzmHA==      

#                                                                              

domain dm1                                                                     

 authorization-attribute idle-cut 15 1024                                      

 authentication portal radius-scheme rs1                                       

 authorization portal radius-scheme rs1                                        

 accounting portal none                                                        

#                                                                              

domain dm2                                                                     

 authorization-attribute idle-cut 15 1024                                      

 authentication portal radius-scheme rs2                                       

 authorization portal radius-scheme rs2                                        

 accounting portal none                                                         

#

 portal host-check enable                                                      

#                                                                              

portal web-server newptv4                                                       

 url http://192.168.2.1/portal                                                 

 url-parameter wlanuserip source-address                                       

#

portal web-server newptv6                                                         

 url http://[2004::1]/portal                                                   

 url-parameter wlanuserip source-address                                       

#                                                                               

portal local-web-server http                                                   

 default-logon-page defaultfile.zip                                            

#                                                                               

wlan ap office model WA4320i-ACN                                                       

 serial-id 219801A0CNC138011454                                                

 radio 2                                                                        

  radio enable                                                                 

  service-template st1                                                         

#                                                                              

return

·            Switch:

#                                                                              

 ipv6 dhcp server forbidden-address 2001::1                                    

 ipv6 dhcp server forbidden-address 2004::1                                    

#                                                                               

vlan 1                                                                         

#                                                                              

vlan 100                                                                        

#                                                                              

vlan 200                                                                       

#                                                                               

dhcp server ip-pool 100                                                        

 gateway-list 192.168.1.1                                                      

 network 192.168.1.0 mask 255.255.255.0                                         

 option 43 hex 8007000001c0a80101                                              

#                                                                              

dhcp server ip-pool 200                                                         

 gateway-list 192.168.2.2                                                      

 network 192.168.2.0 mask 255.255.255.0                                        

dns-list 192.168.2.2

#

ipv6 dhcp pool 1                                                                

 network 2001::/64                                                             

 option 52 hex 20010000000000000000000000000001                                

#                                                                               

ipv6 dhcp pool 2                                                               

 network 2004::/64                                                             

#                                                                              

interface Vlan-interface1                                                      

 ip address 192.168.3.1 255.255.255.0

 ipv6 address 2003::1/64                                                        

#                                                                              

interface Vlan-interface100                                                    

 ip address 192.168.1.2 255.255.255.0

 ipv6 dhcp select server                                                        

 ipv6 dhcp server apply pool 1                                                 

 ipv6 address 2001::2/64                                                       

 ipv6 nd autoconfig managed-address-flag                                        

 ipv6 nd autoconfig other-flag                                                 

 undo ipv6 nd ra halt                                                          

#                                                                               

interface Vlan-interface200                                                    

 ip address 192.168.2.2 255.255.255.0

 ipv6 dhcp select server                                                       

 ipv6 dhcp server apply pool 2                                                  

 ipv6 address 2004::2/64                                                       

 ipv6 nd autoconfig managed-address-flag                                       

 ipv6 nd autoconfig other-flag                                                  

 undo ipv6 nd ra halt                                                          

#                                                                              

interface GigabitEthernet1/0/1                                                  

 port link-type trunk                                                          

 port trunk permit vlan 1 100 200                                              

#                                                                               

interface GigabitEthernet1/0/2                                                 

 port access vlan 100                                                          

 poe enable                                                                    

#                                                                              

return

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“用户接入与认证配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“用户接入与认证命令参考。

·            《H3C无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C无线控制器产品 命令参考》中的“WLAN接入命令参考”。

·            《H3C无线控制器产品 配置指导》中的“AP管理配置指导”。

·            《H3C无线控制器产品 命令参考》中的“AP管理命令参考”。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部