国家 / 地区

07-三层技术-IP路由配置举例

01-H3C_IS-IS配置举例

本章节下载  (211.63 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/CR/CR16000-F/Configure/Typical_Configuration_Example/H3C_CR16000-F_CE-R7951P01-6W100/07/202003/1276427_30005_0.htm

01-H3C_IS-IS配置举例

H3C IS-IS配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

资料版本:6W100-20200306

产品版本:Release 7951P01

 

Copyright © 2020 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍IS-IS配置举例。

2  配置前提

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解IS-IS特性。

3  IS-IS配置举例

3.1  组网需求

图1所示,某公司总部和分部使用IS-IS路由协议进行互联。公司总部内为市场部(Mkt dept.)和财务部(F&A dept.)设置了独立的网络。该公司的合作伙伴使用的是OSPF路由协议。现要求:

·     Router A和Router B性能相对较低,尽量使其处理较少的数据信息。

·     公司总部内市场部和财务部可以通信;并通过配置路由渗透功能,实现总部与分部间,市场部与分部可以正常通信,财务部与分部无法通信,且分部无法查看到财务部的路由信息。

·     将合作伙伴的OSPF路由引入公司分部的网络中,并保证市场部与合作伙伴可以通信。

·     当总部的网关设备Router C IS-IS协议进程重启时,原有的通信不中断。

图1 IS-IS配置组网图

 

 

3.2  配置思路

·     为了降低Router A和Router B运行压力,将其部署为Level-1路由器,仅处理公司总部area 10区域内的数据信息。

·     为了使公司总部内财务部和公司分部不能相互通信,且公司分部无法查看财务部的路由,需要通过在Router C上配置IS-IS路由渗透并引用地址前缀列表来实现Level-1区域只将10.100.1.0/24网段的路由信息向Level-2发布。

·     为了实现公司总部内市场部与合作伙伴的网络互通,需要在Router D的IS-IS进程中引入OSPF进程的路由,并在OSPF进程中引入IS-IS进程的路由。

·     为了保证Router C IS-IS协议进程重启时,原有的通信不中断,需要在Router C上使能IS-IS协议的GR(Graceful Restart,平滑重启)能力。

3.3  配置注意事项

在设备平滑重启过程中,请勿变更拓扑,否则可能导致路由黑洞。

3.4  配置步骤

3.4.1  Router A的配置

# 配置接口GigabitEthernet 3/1/1的IP地址。

<RouterA> system-view

[RouterA] interface gigabitethernet 3/1/1

[RouterA-GigabitEthernet3/1/1] ip address 192.168.1.1 24

[RouterA-GigabitEthernet3/1/1] quit

# 请参考以上方法配置图1中Router A的其它接口的IP地址,具体配置过程略。

# 配置IS-IS基本功能。

[RouterA] isis 1

[RouterA-isis-1] is-level level-1

[RouterA-isis-1] network-entity 10.1921.6800.1001.00

[RouterA-isis-1] quit

[RouterA] interface gigabitethernet 3/1/1

[RouterA–GigabitEthernet3/1/1] isis enable 1

[RouterA–GigabitEthernet3/1/1] quit

[RouterA] interface gigabitethernet 3/1/2

[RouterA–GigabitEthernet3/1/2] isis enable 1

[RouterA–GigabitEthernet3/1/2] quit

3.4.2  Router B的配置

# 配置接口GigabitEthernet 3/1/1的IP地址。

<RouterB> system-view

[RouterB] interface gigabitethernet 3/1/1

[RouterB-GigabitEthernet3/1/1] ip address 192.168.2.1 24

[RouterB-GigabitEthernet3/1/1] quit

# 请参考以上方法配置图1中Router B的其它接口的IP地址,具体配置过程略。

# 配置IS-IS基本功能。

[RouterB] isis 1

[RouterB-isis-1] is-level level-1

[RouterB-isis-1] network-entity 10.1921.6800.2001.00

[RouterB-isis-1] quit

[RouterB] interface gigabitethernet 3/1/1

[RouterB–GigabitEthernet3/1/1] isis enable 1

[RouterB–GigabitEthernet3/1/1] quit

[RouterB] interface gigabitethernet 3/1/2

[RouterB–GigabitEthernet3/1/2] isis enable 1

[RouterB–GigabitEthernet3/1/2] quit

3.4.3  Router C的配置

# 配置接口GigabitEthernet 3/1/1的IP地址。

<RouterC> system-view

[RouterC] interface gigabitethernet 3/1/1

[RouterC-GigabitEthernet3/1/1] ip address 192.168.1.2 24

[RouterC-GigabitEthernet3/1/1] quit

# 请参考以上方法配置图1中Router C的其它接口的IP地址,具体配置过程略。

# 配置IS-IS基本功能。

[RouterC] isis 1

[RouterC-isis-1] network-entity 10.1921.6801.0001.00

[RouterC-isis-1] quit

[RouterC] interface gigabitethernet 3/1/1

[RouterC–GigabitEthernet3/1/1] isis enable 1

[RouterC–GigabitEthernet3/1/1] quit

[RouterC] interface gigabitethernet 3/1/2

[RouterC–GigabitEthernet3/1/2] isis enable 1

[RouterC–GigabitEthernet3/1/2] quit

[RouterC] interface gigabitethernet 3/1/3

[RouterC–GigabitEthernet3/1/3] isis enable 1

[RouterC–GigabitEthernet3/1/3] quit

# 配置IS-IS路由渗透,并引用名为1的地址前缀列表,实现Level-1区域只将10.100.1.0/24网段的路由信息向Level-2发布。

[RouterC] ip prefix-list 1 permit 10.100.1.0 24

[RouterC] isis 1

[RouterC-isis-1] address-family ipv4

[RouterC-isis-1-ipv4] import-route isis level-1 into level-2 filter-policy prefix-list 1

[RouterC-isis-1-ipv4] quit

# 使能IS-IS协议的GR能力。

[RouterC-isis-1] graceful-restart

[RouterC-isis-1] quit

3.4.4  Router D的配置

# 配置接口GigabitEthernet 3/1/1的IP地址。

<RouterD> system-view

[RouterD] interface gigabitethernet 3/1/1

[RouterD-GigabitEthernet3/1/1] ip address 192.168.10.2 24

[RouterD-GigabitEthernet3/1/1] quit

# 请参考以上方法配置图1中Router D的其它接口的IP地址,具体配置过程略。

# 配置IS-IS基本功能。

[RouterD] isis 1

[RouterD-isis-1] is-level level-2

[RouterD-isis-1] network-entity 20.1921.6802.0001.00

[RouterD-isis-1] quit

[RouterD] interface gigabitethernet 3/1/1

[RouterD–GigabitEthernet3/1/1] isis enable 1

[RouterD–GigabitEthernet3/1/1] quit

[RouterD] interface gigabitethernet 3/1/2

[RouterD–GigabitEthernet3/1/2] isis enable 1

[RouterD–GigabitEthernet3/1/2] quit

# 配置OSPF基本功能。

[RouterD] ospf

[RouterD-ospf-1] area 0

[RouterD-ospf-1-area-0.0.0.0] network 192.168.20.0 0.0.0.255

[RouterD-ospf-1-area-0.0.0.0] quit

[RouterD-ospf-1] quit

# 配置IS-IS进程引入OSPF进程的路由和直连路由。

[RouterD] isis 1

[RouterD-isis-1] address-family ipv4

[RouterD-isis-1-ipv4] import-route ospf

[RouterD-isis-1-ipv4] import-route direct

[RouterD-isis-1-ipv4] quit

[RouterD-isis-1] quit

# 配置OSPF进程引入IS-IS进程的路由和直连路由。

[RouterD] ospf 1

[RouterD-ospf-1] import-route isis 1

[RouterD-ospf-1] import-route direct

3.4.5  Router E的配置

# 配置接口GigabitEthernet 3/1/1的IP地址。

<RouterE> system-view

[RouterE] interface gigabitethernet 3/1/1

[RouterE-GigabitEthernet3/1/1] ip address 192.168.20.2 24

[RouterE-GigabitEthernet3/1/1] quit

# 请参考以上方法配置图1中Router E的其它接口的IP地址,具体配置过程略。

# 配置OSPF基本功能。

[RouterE] ospf

[RouterE-ospf-1] area 0

[RouterE-ospf-1-area-0.0.0.0] network 192.168.20.0 0.0.0.255

[RouterE-ospf-1-area-0.0.0.0] network 10.200.1.0 0.0.0.255

[RouterE-ospf-1-area-0.0.0.0] quit

[RouterE-ospf-1] quit

3.5  验证配置

(1)     在Router D上查看IS-IS路由表,可以查看到市场部(10.100.1.0/24)的路由,无法查看到财务部(10.100.2.0/24)的路由,说明公司分部只能与市场部通信。

[RouterD] display isis route

 

                         Route information for IS-IS(1)

                         ------------------------------

 

                         Level-2 IPv4 Forwarding Table

                         -----------------------------

 

 IPv4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags

-------------------------------------------------------------------------------

 192.168.10.0/24      10         NULL    GE3/1/1         Direct          D/L/-

 192.168.1.0/24       20         NULL    GE3/1/1         192.168.10.1    R/-/-

 10.100.1.0/24        30         NULL    GE3/1/1         192.168.10.1    R/-/-

 192.168.2.0/24       20         NULL    GE3/1/1         192.168.10.1    R/-/-

 

      Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set

(2)     在Router C上查看IS-IS路由表,可以看到10.200.1.0/24的路由,并且Router A可以ping通10.200.1.1,说明本公司与合作伙伴可以正常通信。

# 查看Router C上的IS-IS路由表。

[RouterC] display isis route

 

                         Route information for IS-IS(1)

                         -----------------------------

 

                         Level-1 IPv4 Forwarding Table

                         -----------------------------

 

 IPv4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags

-------------------------------------------------------------------------------

 192.168.10.0/24      10         NULL    GE3/1/3         Direct          D/L/-

 192.168.1.0/24       10         NULL    GE3/1/1         Direct          D/L/-

 10.100.1.0/24        20         NULL    GE3/1/1         192.168.1.1     R/L/-

 10.100.2.0/24        20         NULL    GE3/1/2         192.168.2.1     R/-/-

 192.168.2.0/24       10         NULL    GE3/1/2         Direct          D/L/-

 

      Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set

 

                         Level-2 IPv4 Forwarding Table

                         -----------------------------

 

 IPv4 Destination     IntCost    ExtCost ExitInterface   NextHop         Flags

-------------------------------------------------------------------------------

 192.168.10.0/24      10         NULL    GE3/1/3         Direct          D/L/-

 10.200.1.0/24        10         0       GE3/1/3         192.168.10.2    R/-/-

 192.168.20.0/24      10         0       GE3/1/3         192.168.10.2    R/-/-

 192.168.1.0/24       10         NULL    GE3/1/1         Direct          D/L/-

 192.168.2.0/24       10         NULL    GE3/1/2         Direct          D/L/-

 

      Flags: D-Direct, R-Added to Rib, L-Advertised in LSPs, U-Up/Down Bit Set

# 从Router A 的GE3/1/2接口ping 10.200.1.1。

[RouterA] ping –a 10.100.1.1 10.200.1.1

Ping 10.200.1.1 (10.200.1.1): 56 data bytes, press CTRL_C to break

56 bytes from 10.200.1.1: icmp_seq=0 ttl=252 time=1.862 ms

56 bytes from 10.200.1.1: icmp_seq=1 ttl=252 time=2.969 ms

56 bytes from 10.200.1.1: icmp_seq=2 ttl=252 time=1.402 ms

56 bytes from 10.200.1.1: icmp_seq=3 ttl=252 time=1.324 ms

56 bytes from 10.200.1.1: icmp_seq=4 ttl=252 time=1.510 ms

 

--- Ping statistics for 10.200.1.1 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 1.324/1.813/2.969/0.606 ms

(3)     在Router A上持续ping Router B,期间在Router C上重启IS-IS进程,查看Router C的IS-IS协议重启时,通信是否中断。并使用display isis graceful-restart status命令,可查看Router C上IS-IS协议的GR状态。

# 在Router A上持续ping Router B。

[RouterA] ping -c 10000 10.100.2.1

Ping 10.100.2.1 (10.100.2.1): 56 data bytes, press CTRL_C to break

56 bytes from 10.100.2.1: icmp_seq=0 ttl=254 time=1.185 ms

56 bytes from 10.100.2.1: icmp_seq=1 ttl=254 time=1.087 ms

……

# 重启Router C的IS-IS进程。

<RouterC> reset isis all graceful-restart

Reset IS-IS process? [Y/N] :y

# 在Router A上查看到IS-IS协议重启时通信未发生中断。

[RouterA] ping -c 10000 10.100.2.1

Ping 10.100.2.1 (10.100.2.1): 56 data bytes, press CTRL_C to break

56 bytes from 10.100.2.1: icmp_seq=0 ttl=254 time=1.185 ms

56 bytes from 10.100.2.1: icmp_seq=1 ttl=254 time=1.087 ms

56 bytes from 10.100.2.1: icmp_seq=2 ttl=254 time=1.672 ms

56 bytes from 10.100.2.1: icmp_seq=3 ttl=254 time=1.751 ms

56 bytes from 10.100.2.1: icmp_seq=4 ttl=254 time=1.816 ms

56 bytes from 10.100.2.1: icmp_seq=5 ttl=254 time=1.814 ms

# 查看Router C上IS-IS协议的GR状态。

[RouterC] display isis graceful-restart status

 

                        Restart information for IS-IS(1)

                        --------------------------------

Restart status: COMPLETE

Restart phase: Finish

Restart t1: 3, count 10; Restart t2: 60; Restart t3: 300

SA Bit: supported

 

                          Level-1 restart information

                          ---------------------------

Total number of interfaces: 3

Number of waiting LSPs: 0

 

                          Level-2 restart information

                          ---------------------------

Total number of interfaces: 3

Number of waiting LSPs: 0

3.6  配置文件

·     Router A:

#

isis 1

 is-level level-1

 network-entity 10.1921.6800.1001.00

#

interface GigabitEthernet3/1/1

 ip address 192.168.1.1 255.255.255.0

 isis enable 1

#

interface GigabitEthernet3/1/2

 ip address 10.100.1.1 255.255.255.0

 isis enable 1

#

·     Router B:

#

isis 1

 is-level level-1

 network-entity 10.1921.6800.2001.00

#

interface GigabitEthernet3/1/1

 ip address 192.168.2.1 255.255.255.0

 isis enable 1

#

interface GigabitEthernet3/1/2

 ip address 10.100.2.1 255.255.255.0

 isis enable 1

#

·     Router C:

#

isis 1

 graceful-restart

 network-entity 10.1921.6801.0001.00

 #

 address-family ipv4 unicast

  import-route isis level-1 into level-2 filter-policy prefix-list 1

#

interface GigabitEthernet3/1/1

 ip address 192.168.1.2 255.255.255.0

 isis enable 1

#

interface GigabitEthernet3/1/2

 ip address 192.168.2.2 255.255.255.0

 isis enable 1

#

interface GigabitEthernet3/1/3

 ip address 192.168.10.1 255.255.255.0

 isis enable 1

#

 ip prefix-list 1 index 10 permit 10.100.1.0 24

#

·     Router D:

#

isis 1

 is-level level-2

 network-entity 20.1921.6802.0001.00

#

 address-family ipv4 unicast

  import-route direct

  import-route ospf 1

#

ospf 1

 import-route direct

 import-route isis 1

 area 0.0.0.0

  network 192.168.20.0 0.0.0.255

#

interface GigabitEthernet3/1/1

 ip address 192.168.10.2 255.255.255.0

 isis enable 1

#

interface GigabitEthernet3/1/2

 ip address 192.168.20.1 255.255.255.0

#

·     Router E:

#

ospf 1

 area 0.0.0.0

  network 10.200.1.0 0.0.0.255

  network 192.168.20.0 0.0.0.255

#

interface GigabitEthernet3/1/1

 ip address 192.168.20.2 255.255.255.0

#

interface GigabitEthernet3/1/2

 ip address 10.200.1.1 255.255.255.0

#

 

4  相关资料

·     H3C CR16000-F路由器  三层技术-IP路由配置指导-Release 7951P01

·     H3C CR16000-F路由器  三层技术-IP路由命令参考-Release 7951P01

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!