国家 / 地区

03-典型配置案例(AC+FIT AP)

71-H3C无线控制器无线探针典型配置举例(V7)

本章节下载  (189.76 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274650_30005_0.htm

71-H3C无线控制器无线探针典型配置举例(V7)

H3C 无线控制器

无线探针典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍了无线探针典型配置举例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WIPS特性。

3  配置举例

3.1  组网需求

图1所示,AP通过交换机与AC相连,AP1和AP2为Client提供无线服务,配置SSID为service,在Sensor上开启无线探针,Sensor快速发现并收集周围网络环境中存在的无线设备,并生成相应的表项。

图1 无线探针组网图

 

3.2  配置步骤

3.2.1  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将通过该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 112.12.1.25 16

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client使用VLAN200接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 112.13.1.25 16

[AC-Vlan-interface200] quit

# 配置AC和Switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,PVID为100。

[AC] interface gigabitethernet1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

(2)       配置DHCP server

# 开启DHCP server功能。

[AC] dhcp enable

# 配置DHCP地址池vlan100为AP分配地址范围为112.12.0.0/16,网关地址为112.12.1.25。

[AC] dhcp server ip-pool vlan100

[AC-dhcp-pool-vlan100] network 112.12.0.0 mask 255.255.0.0

[AC-dhcp-pool-vlan100] gateway-list 112.12.1.25

[AC-dhcp-pool-vlan100] quit

# 配置DHCP地址池vlan200为Client分配地址范围为112.13.0.0/16,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为112.13.1.25。

[AC] dhcp server ip-pool vlan200

[AC-dhcp-pool-vlan200] network 112.13.0.0 mask 255.255.0.0

[AC-dhcp-pool-vlan200] gateway-list 112.13.1.25

[AC-dhcp-pool-vlan200] dns-list 112.13.1.25

[AC-dhcp-pool-vlan200] quit

(3)       配置AP

# 创建无线服务模板service,并配置SSID为service,配置Client从无线服务模板service上线后会被加入VLAN 200,并开启服务模板。

[AC] wlan service-template service

[AC-wlan-st-service] ssid service

[AC-wlan-st-service] vlan 200

[AC-wlan-st-service] service-template enable

[AC-wlan-st-service] quit

# 创建手工AP,名称为ap1,选择AP型号并配置序列号,将无线服务模板绑定到射频接口。

[AC] wlan ap ap1 model WA4320i-ACN

[AC-wlan-ap-ap1] serial-id 210235A1GQC157001570

[AC-wlan-ap-ap1] radio 1

[AC-wlan-ap-ap1-radio-1] radio enable

[AC-wlan-ap-ap1-radio-1] service-template service

[AC-wlan-ap-ap1-radio-1] quit

# 创建手工AP,名称为ap2,选择AP型号并配置序列号,将无线服务模板绑定到射频接口。

[AC] wlan ap ap2 model WA4320i-ACN

[AC-wlan-ap-ap2] serial-id 210235A1GQC157001571

[AC-wlan-ap-ap2] radio 1

[AC-wlan-ap-ap2-radio-1] radio enable

[AC-wlan-ap-ap2-radio-1] service-template service

[AC-wlan-ap-ap2-radio-1] quit

# 创建手工AP,名称为sensor,选择AP型号并配置序列号,在射频接口开启无线探针。

[AC] wlan ap sensor model WA4320i-ACN

[AC-wlan-ap-sensor] serial-id 210235A1GQC157001572

[AC-wlan-ap-sensor] radio 1

[AC-wlan-ap-sensor-radio-1] radio enable

[AC-wlan-ap-sensor-radio-1] scan scan-time 100

[AC-wlan-ap-sensor-radio-1] client-proximity-sensor enable

[AC-wlan-ap-sensor-radio-1] quit

 [AC-wlan-ap-sensor] return

3.2.2  配置Switch

# 创建VLAN 100和VLAN 200,其中VLAN 100用于转发AC和AP间CAPWAP隧道内的流量,VLAN 200用于转发Client无线报文。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] vlan 200

[Switch-vlan200] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,PVID为100。

[Switch] interface gigabitethernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与Sensor相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 开启PoE接口远程供电功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# 配置Switch和AP1相连的接口GigabitEthernet1/0/3为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,当前Trunk口的PVID为100。

[Switch] interfac gigabitEthernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type trunk 

[Switch-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/3] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/3] port trunk pvid vlan 100

# 开启PoE接口远程供电功能。

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

# 配置Switch和AP2相连的接口GigabitEthernet1/0/4为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,当前Trunk口的PVID为100。

[Switch] interfac gigabitEthernet 1/0/4

[Switch-GigabitEthernet1/0/4] port link-type trunk 

[Switch-GigabitEthernet1/0/4] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/4] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/4] port trunk pvid vlan 100

# 开启PoE接口远程供电功能。

[Switch-GigabitEthernet1/0/4] poe enable

[Switch-GigabitEthernet1/0/4] quit

3.3  验证配置

(1)        查看Sensor检测到的所有无线设备的信息。

<Sysname> display client-proximity-sensor device

Total 3 detected devices

 

MAC address    Type      Duration    Sensors Channel Status

0AFB-423B-893C AP        00h 10m 46s 1       11      Active

0AFB-423B-893D AP        00h 10m 46s 1       6       Active

0AFB-423B-893E AP        00h 10m 46s 1       1       Active

3.4  配置文件

·            AC:

#

dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 112.12.1.25

 network 112.12.0.0 mask 255.255.0.0

#

dhcp server ip-pool vlan200

 gateway-list 112.13.1.25

 network 112.13.0.0 mask 255.255.0.0

 dns-list 112.13.1.25

#

wlan service-template service

 ssid service

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 112.12.1.25 255.255.0.0

#

interface Vlan-interface200

 ip address 112.13.1.25 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC157001570

 radio 1

  radio enable

  service-template service

#

wlan ap ap2 model WA4320i-ACN

 serial-id 210235A1GQC157001571

 radio 1

  radio enable

  service-template service

#

wlan ap sensor model WA4320i-ACN

 serial-id 210235A1GQC157001572

 radio 1

  radio enable

  scan scan-time 100

  client-proximity-sensor enable

#

·            Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1 

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

port link-type trunk

 undo port trunk permit vlan 1 

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

 poe enable

#

interface GigabitEthernet1/0/4

 port link-type trunk

 undo port trunk permit vlan 1 

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

 poe enable

#

4  相关资料

·            《H3C无线控制器产品 配置指导》中的“WLAN高级功能配置指导”。

·            《H3C无线控制器产品 命令参考》中的“WLAN高级功能命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!