国家 / 地区

03-典型配置案例(AC+FIT AP)

66-H3C无线控制器静态VLAN-group典型配置举例(V7)

本章节下载  (207.14 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274645_30005_0.htm

66-H3C无线控制器静态VLAN-group典型配置举例(V7)

H3C 无线控制器

静态VLAN-group典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍无线客户端通过静态VLAN-group实现AC间漫游的典型配置案例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WLAN接入和WLAN漫游的相关特性。

3  配置举例

3.1  组网需求

图1所示,在一个区域内通过部署两台AC来为用户提供无线服务,Switch作为DHCP服务器为AP和Client分配IP地址,在AC上配置vlan-group,让客户端在两台AC之间实现漫游。

图1 静态VLAN-group实现AC间漫游组网图

 

设备

接口

IP地址

设备

接口

IP地址

AC1

Vlan-int100

192.1.0.2/16

Switch

Vlan-int100

192.1.0.1/16

 

Vlan-int200

192.2.0.2/16

 

Vlan-int200

192.2.0.1/16

AC2

Vlan-int100

192.1.0.3/16

 

Vlan-int400

192.4.0.1/16

 

Vlan-int400

192.4.0.2/16

 

 

 

 

3.2  配置注意事项

·            参与漫游的AP上绑定的无线服务模板的SSID、身份认证与密钥管理的模式和加密套件必须相同。

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

3.3  配置步骤

3.3.1  配置AC 1

(1)       配置AC 1的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址192.1.0.2/16。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC1> system-view

[AC1] vlan 100

[AC1-vlan100] quit

[AC1] interface vlan-interface 100

[AC1-Vlan-interface100] ip address 192.1.0.2 16

[AC1-Vlan-interface100] quit

# 创建VLAN 200作为客户端接入的业务VLAN,并为该接口配置IP地址192.2.0.2/16,用于和无线客户端进行通信。

[AC1] vlan 200

[AC1-vlan200] quit

[AC1] interface vlan-interface 200

[AC1-Vlan-interface200] ip address 192.2.0.2 16

[AC1-Vlan-interface200] quit

# 创建VLAN 400,用于转发从AC 2漫游过来的客户端的数据。

[AC1] vlan 400

[AC1-vlan400] quit

# 将与Switch相连的接口GigabitEthernet 1/0/1的链路类型配置为Trunk,并允许VLAN 100、VLAN 200和VLAN 400通过。

[AC1] interface gigabitethernet 1/0/1

[AC1-GigabitEthernet1/0/1] port link-type trunk

[AC1-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[AC1-GigabitEthernet1/0/1] quit

# 将与AP相连的接口GigabitEthernet 1/0/2的链路类型配置为Access,当前Access口允许VLAN 100通过。

[AC1] interface gigabitethernet 1/0/2

[AC1-GigabitEthernet1/0/2] port link-type access

[AC1-GigabitEthernet1/0/2] port access vlan 100

[AC1-GigabitEthernet1/0/2] quit

(2)       配置vlan-group,给客户端分配VLAN200,400。

[AC1] vlan-group roam

[AC1-vlan-group-roam] vlan-list 200 400

(3)       配置无线接入服务

# 创建无线服务模板1并进入无线服务模板视图。

[AC1] wlan service-template 1

# 配置无线服务的SSID为service。

[AC1-wlan-st-1] ssid service

# 配置给客户端分配的VLAN为静态模式。

[AC1-wlan-st-1] client vlan-alloc static

# 开启无线服务模板。

[AC1-wlan-st-1] service-template enable

[AC1-wlan-st-1] quit

(4)       配置AP

# 创建手工AP,配置AP名称为ap1,型号为WA4320i-ACN,序列号为210235A1GQC14C000225。

[AC1] wlan ap ap1 model WA4320i-ACN

[AC1-wlan-ap-ap1] serial-id 210235A1GQC14C000225

# 进入ap1的Radio 1视图,并将无线服务模板1绑定到Radio 1上,同时指定vlan-group。

[AC1-wlan-ap-ap1] radio 1

[AC1-wlan-ap-ap1-radio-1] service-template 1 vlan-group roam

# 开启Radio 1的射频功能。

[AC1-wlan-ap-ap1-radio-1] radio enable

[AC1-wlan-ap-ap1-radio-1] quit

[AC1-wlan-ap-ap1] quit

(5)       配置漫游功能

# 创建漫游组1,并进入漫游组视图。

[AC1] wlan mobility group 1

# 配置AC加入漫游组时建立IACTP隧道的源IP地址为192.1.0.2。

[AC1-wlan-mg-1] source ip 192.1.0.2

# 添加漫游组内的AC成员,该AC成员用于建立IACTP隧道的源IP地址为192.1.0.3。

[AC1-wlan-mg-1] member ip 192.1.0.3

# 开启漫游组功能。

[AC1-wlan-mg-1] group enable

[AC1-wlan-mg-1] quit

(6)       配置缺省路由

# 配置AC 1的缺省路由,下一跳地址为192.1.0.1。

[AC1] ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

3.3.2  配置AC2

(1)       配置AC 2的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址192.1.0.3/16。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC2> system-view

[AC2] vlan 100

[AC2-vlan100] quit

[AC2] interface vlan-interface 100

[AC2-Vlan-interface100] ip address 192.1.0.3 16

[AC2-Vlan-interface100] quit

# 创建VLAN 200,用于转发从AC 1漫游过来的客户端的数据。

<AC2> system-view

[AC2] vlan 200

[AC2-vlan200] quit

# 创建VLAN 400作为客户端接入的业务VLAN,并为该接口配置IP地址192.4.0.2/16,用于和无线客户端进行通信。

[AC2] vlan 400

[AC2-vlan400] quit

[AC2] interface vlan-interface 400

[AC2-Vlan-interface400] ip address 192.4.0.2 16

[AC2-Vlan-interface400] quit

# 将与Switch相连的接口GigabitEthernet 1/0/1的接口类型为Trunk,并允许VLAN 100、VLAN 200和VLAN 400通过。

[AC2] interface gigabitethernet 1/0/1

[AC2-GigabitEthernet1/0/1] port link-type trunk

[AC2-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[AC2-GigabitEthernet1/0/1] quit

# 将与AP相连的接口GigabitEthernet 1/0/2的链路类型配置为Access,当前Access口允许VLAN 100通过。

[AC2] interface gigabitethernet 1/0/2

[AC2-GigabitEthernet1/0/2] port link-type access

[AC2-GigabitEthernet1/0/2] port access vlan 100

[AC2-GigabitEthernet1/0/2] quit

(2)       配置vlan-group,给客户端分配VLAN200,400。

[AC2] vlan-group roam

[AC2-vlan-group-roam] vlan-list 200 400

(3)       配置无线接入服务

# 创建无线服务模板1并进入无线服务模板视图。

[AC2] wlan service-template 1

# 配置无线服务的SSID为service。

[AC2-wlan-st-1] ssid service

# 配置给客户端分配的VLAN为静态模式。

[AC2-wlan-st-1] client vlan-alloc static

# 开启无线服务模板。

[AC2-wlan-st-1] service-template enable

[AC2-wlan-st-1] quit

(4)       配置AP

# 创建手工AP,配置AP名称为ap2,型号为WA4320i-ACN,序列号为210235A1GQC14C000224。

[AC2] wlan ap ap2 model WA4320i-ACN

[AC2-wlan-ap-ap2] serial-id 210235A1GQC14C000224

# 进入ap2的Radio 1视图,并将无线服务模板1绑定到Radio 1上,同时指定vlan-group。

[AC2-wlan-ap-ap2] radio 1

[AC2-wlan-ap-ap2-radio-1] service-template 1 vlan-group roam

# 开启Radio 1的射频功能。

[AC2-wlan-ap-ap2-radio-1] radio enable

[AC2-wlan-ap-ap2-radio-1] quit

[AC2-wlan-ap-ap2] quit

(5)       配置漫游功能

# 创建漫游组1,并进入到漫游组视图。

[AC2] wlan mobility group 1

# 配置AC加入漫游组时建立IACTP隧道的源IP地址为192.1.0.3。

[AC2-wlan-mg-1] source ip 192.1.0.3

# 添加漫游组内的AC成员,该AC成员用于建立IACTP隧道的源IP地址为192.1.0.2。

[AC2-wlan-mg-1] member ip 192.1.0.2

# 开启漫游组功能。

[AC2-wlan-mg-1] group enable

[AC2-wlan-mg-1] quit

(6)       配置缺省路由

# 配置AC 2的缺省路由,下一跳地址为192.1.0.1。

[AC2] ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

3.3.3  配置Switch

(1)       配置Switch的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址192.1.0.1/16,用于和AC 1、AC 2进行通信。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.1 16

[Switch-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址192.2.0.1/16,用于和AC 1侧的无线客户端进行通信。

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.1 16

[Switch-Vlan-interface200] quit

# 创建VLAN 400及其对应的VLAN接口,并为该接口配置IP地址192.4.0.1/16,用于和AC 2侧的无线客户端进行通信。

[Switch] vlan 400

[Switch-vlan400] quit

[Switch] interface vlan-interface 400

[Switch-Vlan-interface400] ip address 192.4.0.1 16

[Switch-Vlan-interface400] quit

# 将与AC 1相连的接口GigabitEthernet1/0/1的链路类型配置为Trunk,允许VLAN 100、VLAN 200和VLAN 400通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200 400

[Switch-GigabitEthernet1/0/1] quit

# 将与AC 2相连的接口GigabitEthernet1/0/2的链路类型配置为Trunk,允许VLAN 100、VLAN 200和VLAN 400通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200 400

[Switch-GigabitEthernet1/0/2] quit

(2)       配置DHCP服务器

# 开启DHCP功能。

[Switch] dhcp enable

# 创建DHCP地址池vlan100,为AP动态分配网段为192.1.0.0/16,不参与自动分配的IP地址为192.1.0.2和192.1.0.3,网关地址为192.1.0.1的IP地址。

[Switch] dhcp server ip-pool vlan100

[Switch-dhcp-pool-vlan100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan100] forbidden-ip 192.1.0.2 192.1.0.3

[Switch-dhcp-pool-vlan100] gateway-list 192.1.0.1

[Switch-dhcp-pool-vlan100] quit

# 创建DHCP地址池vlan200,为无线客户端动态分配网段为192.2.0.0/16,不参与自动分配的IP地址为192.2.0.2,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为192.2.0.1的IP地址。

[Switch] dhcp server ip-pool vlan200

[Switch-dhcp-pool-vlan200] network 192.2.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan200] forbidden-ip 192.2.0.2

[Switch-dhcp-pool-vlan200] gateway-list 192.2.0.1

[Switch-dhcp-pool-vlan200] dns-list 192.2.0.1

[Switch-dhcp-pool-vlan200] quit

# 创建DHCP地址池vlan400,为无线客户端动态分配网段为192.4.0.0/16,不参与自动分配的IP地址为192.4.0.2,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为192.4.0.1的IP地址。

[Switch] dhcp server ip-pool vlan400

[Switch-dhcp-pool-vlan400] network 192.4.0.0 mask 255.255.0.0

[Switch-dhcp-pool-vlan400] forbidden-ip 192.4.0.2

[Switch-dhcp-pool-vlan400] gateway-list 192.4.0.1

[Switch-dhcp-pool-vlan400] dns-list 192.4.0.1

[Switch-dhcp-pool-vlan400] quit

3.4  验证配置

# AC1和AC2查看客户端的VLAN和IP地址是一样的,说明漫游成功了。

# 在AC1上使用display wlan client命令可以看到Client的IP地址和VLAN。

[AC] display wlan client

Total number of clients: 1

 

MAC address    User name  AP name        RID IP address      IPv6 address   VLAN

68db-ca64-23fd N/A        ap1            1   192.2.0.3                      200

# 在AC2上使用display wlan client命令可以看到Client的IP地址和VLAN。

[AC] display wlan client

Total number of clients: 1

 

MAC address    User name  AP name        RID IP address      IPv6 address   VLAN

68db-ca64-23fd N/A        ap2            1   192.2.0.3                      200

3.5  配置文件

·            Switch

#

dhcp enable

#

vlan 100

#

vlan 200

#

vlan 400

#

dhcp server ip-pool vlan100

gateway-list 192.1.0.1

 network 192.1.0.0 mask 255.255.0.0

 forbidden-ip 192.1.0.2

 forbidden-ip 192.1.0.3

#

dhcp server ip-pool vlan200

gateway-list 192.2.0.1

 network 192.2.0.0 mask 255.255.0.0

dns-list 192.2.0.1

 forbidden-ip 192.2.0.2

#

dhcp server ip-pool vlan400

gateway-list 192.4.0.1

 network 192.4.0.0 mask 255.255.0.0

dns-list 192.4.0.1

 forbidden-ip 192.4.0.2

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.0.0

#

interface Vlan-interface400

 ip address 192.4.0.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type trunk

 port trunk permit vlan 100 200 400

#

·            AC1

#

vlan 100

#

vlan 200

#

vlan 400

#

vlan-group roam                                                                

 vlan-list 200 400                                                             

#

wlan service-template 1

 ssid service

client vlan-alloc static

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

#

ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC14C000225

 radio 1

  radio enable

  service-template 1 vlan-group roam

 radio 2

#

wlan mobility group 1

 source ip 192.1.0.2

 member ip 192.1.0.3

 group enable

·            AC2

#

vlan 100

#

vlan 200

#

vlan 400

#

vlan-group roam                                                                

 vlan-list 200 400                                                             

#

wlan service-template 1

 ssid service

client vlan-alloc static

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.3 255.255.0.0

#

interface Vlan-interface400

 ip address 192.4.0.2 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200 400

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

#

ip route-static 0.0.0.0 0.0.0.0 192.1.0.1

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC14C000225

 radio 1

  radio enable

  service-template 1 vlan-group roam

 radio 2

#

wlan mobility group 1

 source ip 192.1.0.3

 member ip 192.1.0.2

 group enable

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“用户接入与认证配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“用户接入与认证命令参考”。

·            《H3C 无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“WLAN接入命令参考”。

·            《H3C 无线控制器产品 配置指导》中的“AP管理配置指导”

·            《H3C 无线控制器产品 命令参考》中的“AP管理命令参考”

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!