国家 / 地区

03-典型配置案例(AC+FIT AP)

54-H3C无线控制器AP-Group定时下发配置典型配置举例(V7)

本章节下载  (194.52 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274633_30005_0.htm

54-H3C无线控制器AP-Group定时下发配置典型配置举例(V7)

H3C 无线控制器

AP-Group定时下发配置典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍AP-Group定时下发配置的配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WLAN接入相关特性。

3  AP-Group定时下发配置配置举例

3.1  组网需求

图1所示,集中式转发架构下,无线客户端Client通过L2 switch和AC相连,L2 switch通过PoE方式给AP供电,AC做为DHCP server为AP和Client分配IP地址。配置定时执行任务功能,每天8:00 开启AC 上ap-group 1中AP型号为WA4320i-ACN的Radio1 接口,每天20:00 关闭AC 上AP group 1 的Radio1 接口。

图1 AP-Group定时下发配置配置举例组网图

http://kms.h3c.com/uploadfile/20170327/151910807201755038514.jpg

 

3.2  配置思路

·            在AC上开启DHCP server功能,AP和无线客户端Client都能通过DHCP server自动获取IP地址。

·            在L2 switch上开启PoE功能,为AP设备供电。

3.3  配置注意事项

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·            配置L2 switch和AP相连的接口禁止VLAN 1报文通过,以防止VLAN 1内报文过多。

3.4  配置步骤

3.4.1  配置AC

(1)       配置DHCP server

# 开启DHCP server功能。

<AC> system-view

[AC] dhcp enable

# 配置DHCP地址池1为AP分配地址范围为192.168.201.0/24,网关地址为192.168.201.1。

[AC] dhcp server ip-pool 1

[AC-dhcp-pool-1] network 192.168.201.0 mask 255.255.255.0

[AC-dhcp-pool-1] gateway-list 192.168.201.1

[AC-dhcp-pool-1] quit

# 配置DHCP地址池2为Client分配地址范围为192.168.202.0/24,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为192.168.202.1。

[AC] dhcp server ip-pool 2

[AC-dhcp-pool-2] network 192.168.202.0 mask 255.255.255.0 

[AC-dhcp-pool-2] gateway-list 192.168.202.1

[AC-dhcp-pool-2] dns-list 192.168.202.1

[AC-dhcp-pool-2] quit

(2)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.201.1 255.255.255.0

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.168.202.1 24

[AC-Vlan-interface200] quit

# 配置AC和L2 switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,当前Trunk口的PVID为100。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

(3)       配置定时执行任务,关闭radio口。

[AC] scheduler job radio_disable

[AC-job-radio_disable] command 1 system-view

[AC-job-radio_disable] command 2 wlan ap-group 1

[AC-job-radio_disable] command 3 ap-model WA4620i-ACN

[AC-job-radio_disable] command 4 radio 1

[AC-job-radio_disable] command 5 radio disable

[AC-job-radio_disable] quit

(4)       配置定时执行任务,使设备在每天20:00 关闭射频接口1。

[AC] scheduler schedule stop_radio

[AC-schedule-stop_radio] job radio_disable

[AC-schedule-stop_radio] time repeating at 20:00

[AC-schedule-stop_radio] quit

(5)       配置定时执行任务,开启radio口。

[AC] scheduler job radio_enable

[AC-job-radio_enable] command 1 system-view

[AC-job-radio_enable] command 2 wlan ap-group 1

[AC-job-radio_enable] command 3 ap-model WA4320i-ACN

[AC-job-radio_enable] command 4 radio 1

[AC-job-radio_enable] command 5 radio enable

[AC-job-radio_enable] quit

(6)       配置定时执行任务,使设备在每天8:00 开启射频接口1。

[AC] scheduler schedule start_radio

[AC-schedule-start_radio] job radio_enable

[AC-schedule-start_radio] time repeating at 8:00

[AC-schedule-start_radio] quit

(7)       配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSID为service。

[AC-wlan-st-1] ssid service

# 使能服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

(8)       配置AP

# 创建手工AP,名称为officeap,型号名称为WA4320i-ACN。

[AC] wlan ap officeap model WA4320i-ACN

# 设置AP的序列号为210235A1Q2C159000018。

[AC-wlan-ap-officeap] serial-id 210235A1Q2C159000018

# 进入AP的Radio 1视图,将无线服务模板1绑定到Radio 1上,并指定客户端上线的VLAN为VLAN 200。

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan 200

# 开启Radio 1的射频功能。

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] return

3.4.2  配置L2 switch

# 创建VLAN 100、VLAN 200,其中VLAN 100用于转发AC和AP间CAPWAP隧道内的流量,VLAN 200为无线客户端接入的VLAN。

<L2 switch> system-view

[L2 switch] vlan 100

[L2 switch-vlan100] quit

[L2 switch] vlan 200

[L2 switch-vlan200] quit

# 配置L2 switch和AC相连的接口GigabitEthernet1/0/1为Trunk类型,允许VLAN 100和VLAN 200通过,当前Trunk口的PVID为100。

[L2 switch] interface gigabitEthernet 1/0/1

[L2 switch-GigabitEthernet1/0/1] port link-type trunk

[L2 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[L2 switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[L2 switch-GigabitEthernet1/0/1] quit

# 配置L2 switch和AP相连的接口GigabitEthernet1/0/2为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,当前Trunk口的PVID为100,并开启PoE远程供电功能。

[L2 switch] interfac gigabitEthernet 1/0/2

[L2 switch-GigabitEthernet1/0/2] port link-type trunk 

[L2 switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[L2 switch-GigabitEthernet1/0/2] port trunk permit vlan 100 200

[L2 switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

[L2 switch-GigabitEthernet1/0/2] poe enable

[L2 switch-GigabitEthernet1/0/2] quit

3.5  验证配置

(1)       在AC上查看AP radio 1的管理状态Admin State。

# 在AC上使用命令display wlan ap name officeap verbose查看AP radio 1的管理状态Admin State,在8:00~20:00,radio 的管理状态为UP,在其它时间radio 的管理状态为DOWN。

<Sysname> display wlan ap name officeap verbose

AP name                       : officeap

AP ID                         : 1

AP group name                 : default-group

State                         : Run

Backup type                   : Master

Online time                   : 0 days 1 hours 25 minutes 12 seconds

System uptime                 : 0 days 2 hours 22 minutes 12 seconds

Model                         : WA4320i-ACN

Region code                   : CN

Region code lock              : Disable

Serial ID                     : 219801A0CNC138011454

MAC address                   : 0AFB-423B-893C

IP address                    : 192.168.1.50

UDP control port number       : 18313

UDP data port number          : N/A

H/W version                   : Ver.C

S/W version                   : E2321

Boot version                  : 1.01

USB state                     : N/A

Power level                   : N/A

Power info                    : N/A

Description                   : wtp1

Priority                      : 4

Echo interval                 : 10 seconds

Echo count                    : 3 counts

Keepalive interval            : 10 seconds

Discovery-response wait-time  : 2 seconds  

Statistics report interval    : 50 seconds

Fragment size (data)          : 1500

Fragment size (control)       : 1450

MAC type                      : Local MAC & Split MAC

Tunnel mode                   : Local Bridging & 802.3 Frame & Native Frame

CWPCAP data-tunnel status     : Down

Discovery type                : Static Configuration

Retransmission count          : 3

Retransmission interval       : 5 seconds

Firmware upgrade              : Enabled

Sent control packets          : 1

Received control packets      : 1

Echo requests                 : 147

Lost echo responses           : 0

Average echo delay            : 3

Last reboot reason            : User soft reboot

Last reboot reason (AP check) : The radio physical status was down

Last reboot reason (AC check) : The radio physical status was down

Latest IP address             : 10.1.0.2

Current AC IP                 : 192.168.1.1

Tunnel down reason            : Request wait timer expired

Connection count              : 1

Backup IPv4                   : Not configured

Backup IPv6                   : Not configured

Ctrl-tunnel encryption        : Disabled

Ctrl-tunnel encryption state  : Not encrypted

Data-tunnel encryption        : Disabled

Data-tunnel encryption state  : Not encrypted

LED mode                      : Normal

Remote configuration          : Enabled

Radio 1:

    Basic BSSID               : 7848-59f6-3940

    Admin state               : Up

    Radio type                : 802.11ac

    Antenna type              : internal

    Client dot11ac-only       : Disabled

    Client dot11n-only        : Disabled

    Channel band-width        : 20/40/80MHz

    Active band-width         : 20/40/80MHz

    Secondary channel offset  : SCB

    Short GI for 20MHz        : Supported

    Short GI for 40MHz        : Supported

    Short GI for 80MHz        : Supported

    Short GI for 160MHz       : Not supported

    mimo                      : Not Config

    Green-Energy-Management   : Disabled

    A-MSDU                    : Enabled

    A-MPDU                    : Enabled

    LDPC                      : Not Supported

    STBC                      : Supported

    Operational VHT-MCS Set:

        Mandatory             : Not configured

        Supported             : NSS1 0,1,2,3,4,5,6,7,8,9

                                NSS2 0,1,2,3,4,5,6,7,8,9

        Multicast             : Not configured

    Operational HT MCS Set:

        Mandatory             : Not configured

        Supported             : 0, 1, 2, 3, 4, 5, 6, 7, 8, 9,

                                10, 11, 12, 13, 14, 15

        Multicast             : Not configured

    Channel                   : 44(auto)

    Channel usage(%)          : 15

    Max power                 : -102 dBm

    Operational rate:

        Mandatory             : 6, 12, 24 Mbps

        Multicast             : Auto

        Supported             : 9, 18, 36, 48, 54 Mbps

        Disabled              : Not configured

    Distance                  : 1 km

    ANI                       : Enabled

    Fragmentation threshold   : 2346 bytes

    Beacon interval           : 100 TU

    Protection threshold      : 2346 bytes

    Long retry threshold      : 4

    Short retry threshold     : 7

    Maximum rx duration       : 2000 ms

    Noise Floor               : 5 dBm

    Smart antenna             : Enabled

    Smart antenna policy      : Auto

    Protection mode           : rts-cts

    Continuous mode           : N/A

    HT protection mode        : No protection

Radio 2:

    Basic BSSID               : 7848-59f6-3950

    Admin state               : Down

    Radio type                : 802.11b

    Antenna type              : internal

    Client dot11n-only        : Disabled

    Channel band-width        : 20MHz

    Active band-width         : 20MHz

    Secondary channel offset  : SCN

    Short GI for 20MHz        : Supported

    Short GI for 40MHz        : Supported

    A-MSDU                    : Enabled

    A-MPDU                    : Enabled

    LDPC                      : Not Supported

    STBC                      : Supported

    Operational HT MCS Set:

        Mandatory             : Not configured

        Supported             : 0, 1, 2, 3, 4, 5, 6, 7, 8, 9,

                                10, 11, 12, 13, 14, 15

        Multicast             : Not configured

    Channel                   : 5(auto)

    Channel usage(%)          : 0

    Max power                 : 20 dBm

    Preamble type             : Short

    Operational rate:

        Mandatory             : 1, 2, 5.5, 11 Mbps

        Multicast             : Auto

        Supported             : 6, 9, 12, 18, 24, 36, 48, 54 Mbps

        Disabled              : Not configured

    Distance                  : 1 km

    ANI                       : Enabled

    Fragmentation threshold   : 2346 bytes

    Beacon interval           : 100 TU

    Protection threshold      : 2346 bytes

    Long retry threshold      : 4

    Short retry threshold     : 7

    Maximum rx duration       : 2000 ms

    Noise Floor               : 0 dBm

    Smart antenna             : Enabled

    Smart antenna policy      : Auto

    Protection mode           : rts-cts

    Continuous mode           : N/A

    HT protection mode        : No protection

3.6  配置文件

·            AC

#                                                                               

 dhcp enable                                                                   

#                                                                              

vlan 1                                                                          

#                                                                              

vlan 100                                                                

#                                                                              

vlan 200                                                                

#      

dhcp server ip-pool 1                                                          

 gateway-list 192.168.201.1                                                    

 network 192.168.201.0 mask 255.255.255.0                                      

#                                                                              

dhcp server ip-pool 2                                                           

 gateway-list 192.168.202.1                                                    

network 192.168.202.0 mask 255.255.255.0                                      

dns-list 192.168.202.1                                                         

#                                                                              

wlan service-template 1                                                        

 ssid service                                                                 

 service-template enable                                                       

#                                                                              

interface Vlan-interface1                                                       

#                                                                              

interface Vlan-interface100                                                    

 ip address 192.168.201.1 255.255.255.0                                         

#                                                                              

interface Vlan-interface200                                                    

 ip address 192.168.202.1 255.255.255.0                                         

#                                                                              

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                           

 undo port trunk permit vlan 1

port trunk permit vlan 100 200

port trunk pvid vlan 100                                           

#                                                                              

wlan ap officeap model WA4320i-ACN                                           

 serial-id 210235A1Q2C159000018                                                

vlan 1

 radio 1                                                                       

  radio enable                                                                  

  service-template 1 vlan 200                                                  

 radio 2  

#                                                                              

scheduler job radio_disable

 command 1 system-view

 command 2 wlan ap-group 2

 command 3 ap-model WA4620i-ACN

 command 4 radio 1

 command 5 radio disable

#

scheduler job radio_enable

 command 1 system-view

 command 2 wlan ap-group 1

 command 3 ap-model WA4320i-ACN

 command 4 radio 1

 command 5 radio enable

#

scheduler schedule start_radio

 user-role network-admin

 job radio_enable

 time repeating at 08:00

#

scheduler schedule stop_radio

 user-role network-admin

 job radio_disable

 time repeating at 20:00

#

·            L2 switch

#                                                                               

vlan 100                                                                       

#                                                                              

vlan 200                                                                        

#                                                                              

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1 100 200                                     

port trunk pvid vlan 100

#                                                                               

interface GigabitEthernet1/0/2                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1                                                 

 port trunk permit vlan 100 200                                               

 port trunk pvid vlan 100                                                      

 poe enable

#                                                                              

4  相关资料

·            《H3C无线控制器产品 配置指导》中的“网络互通配置指导”。

·            《H3C无线控制器产品 命令参考》中的“网络互通命令参考”。

·            《H3C无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C无线控制器产品 命令参考》中的“WLAN接入命令参考”。

·            《H3C无线控制器产品 配置指导》中的“AP管理配置指导”。

·            《H3C无线控制器产品 命令参考》中的“AP管理命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!