国家 / 地区

03-典型配置案例(AC+FIT AP)

51-H3C无线控制器AP License共享典型配置举例(V7)

本章节下载  (166.20 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274630_30005_0.htm

51-H3C无线控制器AP License共享典型配置举例(V7)

H3C 无线控制器

AP License共享典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍了AP License共享典型配置举例。

2  配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解AP License共享特性。

3  配置举例

3.1  组网需求

图1所示,AP通过交换机与AC1和AC2相连,AP为Client提供无线服务,配置SSID为service,在AC1和AC2上开启AP License共享功能,两台AC互为备份,当一台AC出现故障时,License也可以在备AC上继续使用。

图1 AP License共享组网图

 

3.2  配置注意事项

·     当一台AC出现故障时,License可以在备AC上继续使用的有效期为30天。

·     请确保主备两台AC的软件版本保持一致。

3.3  配置步骤

3.3.1  配置AC1

(1)     配置AC1的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将通过该IP地址与AC1建立CAPWAP隧道。

<AC1> system-view

[AC1] vlan 100

[AC1-vlan100] quit

[AC1] interface vlan-interface 100

[AC1-Vlan-interface100] ip address 112.12.1.25 16

[AC1-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client使用VLAN 200接入无线网络。

[AC1] vlan 200

[AC1-vlan200] quit

[AC1] interface vlan-interface 200

[AC1-Vlan-interface200] ip address 112.13.1.25 16

[AC1-Vlan-interface200] quit

# 配置AC1和Switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,PVID为100。

[AC1] interface gigabitethernet1/0/1

[AC1-GigabitEthernet1/0/1] port link-type trunk

[AC1-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC1-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC1-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC1-GigabitEthernet1/0/1] quit

(2)     配置AP license共享功能,配置角色为主AC

[AC1] wlan ap-license-group

[AC1-wlan-ap-license-group] local ip 112.12.1.25

[AC1-wlan-ap-license-group] member ip 112.12.1.26

[AC1-wlan-ap-license-group] ap-license-synchronization enable

[AC1-wlan-ap-license-group] quit

(3)     配置AP

# 创建无线服务模板service,并配置SSID为service,配置Client从无线服务模板service上线后会被加入VLAN 200,并开启服务模板。

[AC1] wlan service-template service

[AC1-wlan-st-service] ssid service

[AC1-wlan-st-service] vlan 200

[AC1-wlan-st-service] service-template enable

[AC1-wlan-st-service] quit

# 创建AP,将无线服务模板绑定到射频接口,具体配置步骤略。

3.3.2  配置AC2

(1)     配置AC2的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将通过该IP地址与AC2建立CAPWAP隧道。

<AC2> system-view

[AC2] vlan 100

[AC2-vlan100] quit

[AC2] interface vlan-interface 100

[AC2-Vlan-interface100] ip address 112.12.1.26 16

[AC2-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client使用VLAN 200接入无线网络。

[AC2] vlan 200

[AC2-vlan200] quit

[AC2] interface vlan-interface 200

[AC2-Vlan-interface200] ip address 112.13.1.26 16

[AC2-Vlan-interface200] quit

# 配置AC2和Switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,PVID为100。

[AC2] interface gigabitethernet1/0/1

[AC2-GigabitEthernet1/0/1] port link-type trunk

[AC2-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC2-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC2-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC2-GigabitEthernet1/0/1] quit

(2)     配置AP license共享功能,配置角色为主AC

[AC2] wlan ap-license-group

[AC2-wlan-ap-license-group] local ip 112.12.1.26

[AC2-wlan-ap-license-group] member ip 112.12.1.25

[AC2-wlan-ap-license-group] ap-license-synchronization enable

[AC2-wlan-ap-license-group] quit

(3)     配置AP

# 创建无线服务模板service,并配置SSID为service,配置Client从无线服务模板service上线后会被加入VLAN 200,并开启服务模板。

[AC2] wlan service-template service

[AC2-wlan-st-service] ssid service

[AC2-wlan-st-service] vlan 200

[AC2-wlan-st-service] service-template enable

[AC2-wlan-st-service] quit

# 创建AP,将无线服务模板绑定到射频接口,具体配置步骤略。

3.3.3  配置Switch

# 创建VLAN 100和VLAN 200,其中VLAN 100用于转发AC和AP间CAPWAP隧道内的流量,VLAN 200用于转发Client无线报文。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] vlan 200

[Switch-vlan200] quit

# 配置Switch与AC1相连的GigabitEthernet1/0/1接口的属性为Trunk,禁止VLAN 1报文通过,允许VLAN 100通过,PVID为100。

[Switch] interface gigabitethernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AC2相连的GigabitEthernet1/0/2接口的属性为Trunk,禁止VLAN 1报文通过,允许VLAN 100通过,PVID为100。

[Switch] interface gigabitethernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type trunk

[Switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/2] port trunk permit vlan 100

[Switch-GigabitEthernet1/0/2] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/2] quit

# 配置Switch与AP相连的接口属性为Access,并允许VLAN 100通过,本例仅示例1个接口的配置。

[Switch] interface gigabitethernet1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 100

# 开启PoE接口远程供电功能。

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

# 配置VLAN 100接口的IP地址。

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 112.12.1.27 16

[Switch-Vlan-interface100] quit

# 配置VLAN 200接口的IP地址。

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 112.13.1.27 16

[Switch-Vlan-interface200] quit

 # 开启DHCP功能。

[Switch] dhcp enable

# 配置DHCP地址池100,用于为AP分配IP地址。

[Switch] dhcp server ip-pool 100

[Switch-dhcp-pool-100] network 112.12.0.0 mask 255.255.0.0

[Switch-dhcp-pool-100] gateway-list 112.12.1.27

[Switch-dhcp-pool-100] quit

# 配置DHCP地址池200,用于为Client分配IP地址。为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址)。

[Switch] dhcp server ip-pool 200

[Switch-dhcp-pool-200] network 112.13.0.0 mask 255.255.255.0

[Switch-dhcp-pool-200] gateway-list 112.13.1.27

[Switch-dhcp-pool-200] dns-list 112.13.1.27

[Switch-dhcp-pool-200] quit

3.4  验证配置

(1)     在AC1可以查看AP license共享组已经建立。

<AC1> display wlan ap-license-group

Group total licenses: 32

Group used licenses: 2

AP license synchronization: Enabled

Local IP: 112.12.1.25

Local role: Master

Member information:

 IP address       Total     Used    Member role   State   Online duration

 112.12.1.26      16        0       Master        UP      10hr 22min 04sec

(2)     在AC2可以查看AP license共享组已经建立。

<AC2> display wlan ap-license-group

Group total licenses: 32

Group used licenses: 2

AP license synchronization: Enabled

Local IP: 112.12.1.26

Local role: Master

Member information:

 IP address       Total     Used    Member role   State   Online duration

 112.12.1.25      16        2       Master        UP      10hr 22min 04sec

(3)     当AC2出现故障后,AC1可以继续使用组内的License,可以查看AP license共享组总license数仍然为32。

<AC1> display wlan ap-license-group

Group total licenses: 32

Group used licenses: 2

AP license synchronization: Enabled

Local IP: 112.12.1.25

Local role: Master

Member information:

 IP address       Total     Used    Member role   State   Online duration

 112.12.1.26      16        0       Master        DOWM    00hr 00min 00sec

3.5  配置文件

·     AC1:

#

vlan 100

#

vlan 200

#

wlan service-template service

 ssid service

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 112.12.1.25 255.255.0.0

#

interface Vlan-interface200

 ip address 112.13.1.25 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

wlan ap-license-group

 local ip 112.12.1.25

 member ip 112.12.1.26

 ap-license-synchronization enable

#

·     AC2:

#

vlan 100

#

vlan 200

#

wlan service-template service

 ssid service

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 112.12.1.26 255.255.0.0

#

interface Vlan-interface200

 ip address 112.13.1.26 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

wlan ap-license-group

 local ip 112.12.1.26

 member ip 112.12.1.25

 ap-license-synchronization enable

#

·     Switch:

#

 dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 112.12.1.27

 network 112.12.0.0 mask 255.255.0.0

#

dhcp server ip-pool vlan200

gateway-list 112.13.1.27

 network 112.13.0.0 mask 255.255.255.0

 dns-list 112.13.1.27

#

interface Vlan-interface100

 ip address 112.12.1.27 255.255.0.0

#

interface Vlan-interface200

 ip address 112.13.1.27 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

undo port trunk permit vlan 1 

 port trunk permit vlan 100

 port trunk pvid vlan 100

#

4  相关资料

·     《H3C无线控制器产品 配置指导》中的“License管理配置指导”。

·     《H3C无线控制器产品 命令参考》中的“License管理命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!