国家 / 地区

03-典型配置案例(AC+FIT AP)

44-H3C无线控制器二层组播典型配置举例(V7)

本章节下载  (193.48 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274623_30005_0.htm

44-H3C无线控制器二层组播典型配置举例(V7)

H3C 无线控制器

二层组播典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍无线控制器二层组播特性的典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解二层组播特性。

3  配置举例

3.1  组网需求

图1所示,Client通过组播的方式可以访问组播源Source的资源,具体要求如下:

·            AC上开启DHCP server功能,为AP和Client分配IP地址。

·            AC上运行版本2的IGMP Snooping,并作为IGMP Snooping查询器。

·            AP提供名称为service1和service2两个无线服务,当Client进行视频点播时,能够接收到组播组224.1.1.1的组播报文,没有点播的Client不能收到任何组播报文。

·            service1和service2的数据报文使用集中转发的方式。

图1 二层组播组网图

 

3.2  配置思路

启动全局IGMP Snooping,并配置Client接入VLAN下的IGMP Snooping。

3.3  配置注意事项

配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

3.4  配置步骤

3.4.1  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 112.12.1.25 16

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 112.13.1.25 16

[AC-Vlan-interface200] quit

# 配置AC和Switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过,当前Trunk口的PVID为100。

[AC] interface gigabitethernet1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] quit

(2)       配置DHCP server

# 开启DHCP server功能。

[AC] dhcp enable

# 配置DHCP地址池vlan100为AP分配地址范围为112.12.0.0/16,网关地址为112.12.1.25。

[AC] dhcp server ip-pool vlan100

[AC-dhcp-pool-vlan100] network 112.12.0.0 mask 255.255.0.0

[AC-dhcp-pool-vlan100] gateway-list 112.12.1.25

[AC-dhcp-pool-vlan100] quit

# 配置DHCP地址池vlan200为Client分配地址范围为112.13.0.0/16,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为112.13.1.25。

[AC] dhcp server ip-pool vlan200

[AC-dhcp-pool-vlan200] network 112.13.0.0 mask 255.255.0.0

[AC-dhcp-pool-vlan200] gateway-list 112.13.1.25

[AC-dhcp-pool-vlan200] dns-list 112.13.1.25

[AC-dhcp-pool-vlan200] quit

(3)       配置AP

# 创建AP,名称为ap1,选择AP型号并配置序列号。

[AC] wlan ap ap1 model WA4320i-ACN

[AC-wlan-ap-ap1] serial-id 210235A1GQC157001570

[AC-wlan-ap-ap1] quit

(4)       配置无线服务

# 创建无线服务模板service1,并配置SSID为service1,配置Client从无线服务模板service1上线后会被加入VLAN 200,并开启服务模版。

[AC] wlan service-template service1

[AC-wlan-st-service1] ssid service1

[AC-wlan-st-service1] vlan 200

[AC-wlan-st-service1] service-template enable

[AC-wlan-st-service1] quit

# 创建无线服务模板service2,并配置SSID为service2,配置Client从无线服务模板service2上线后会被加入VLAN 200,并开启服务模版。

[AC] wlan service-template service2

[AC-wlan-st-service2] ssid service2

[AC-wlan-st-service2] vlan 200

[AC-wlan-st-service2] service-template enable

[AC-wlan-st-service2] quit

# 将无线服务模板service1和service2分别绑定到Radio 1和Radio 2接口。

[AC] wlan ap ap1

[AC-wlan-ap-ap1] radio 1

[AC-wlan-ap-ap1-radio-1] radio enable

[AC-wlan-ap-ap1-radio-1] service-template service1

[AC-wlan-ap-ap1-radio-1]quit

[AC-wlan-ap-ap1] radio 2

[AC-wlan-ap-ap1-radio-2] radio enable

[AC-wlan-ap-ap1-radio-2] service-template service2

[AC-wlan-ap-ap1-radio-2]quit

[AC-wlan-ap-ap1] quit

(5)       配置IGMP Snooping功能

# 在全局开启IGMP Snooping功能。

[AC] igmp-snooping

[AC-igmp-snooping] quit

# 在VLAN 200内使能IGMP Snooping,并使能丢弃未知组播数据报文的功能。

[AC] vlan 200

[AC-vlan200] igmp-snooping enable

[AC-vlan200] igmp-snooping drop-unknown

[AC-vlan200] quit

3.4.2  配置Switch

# 创建VLAN 100和VLAN 200,其中VLAN 100用于转发AC和AP间CAPWAP隧道内的流量,VLAN 200用于转发Client无线报文。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] vlan 200

[Switch-vlan200] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,禁止VLAN 1报文通过,允许VLAN 100通过,当前Trunk口的PVID为100。

[Switch] interface gigabitethernet1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 开启PoE接口远程供电功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

3.5  验证配置

(1)       两个Client分别连接无线网络名称为service1和service2的无线网络。在AC上执行display wlan client命令,可以看到所有连接成功的Client信息。

[AC] display wlan client service-template service1

Total number of clients: 1

 

MAC address     Username   AP name         RID  IP address      IPv6 address   VLAN

0024-d705-c600  N/A        ap1             1    112.13.1.26     N/A            200

 

[AC] display wlan client service-template service2

Total number of clients: 1

 

MAC address     Username   AP name         RID  IP address      IPv6 address   VLAN

0024-d710-18a4  N/A        ap1             2    112.13.1.27     N/A            200

(2)       当连接到service1的Client点播视频时,组播源向组播组224.1.1.1发送的组播数据, Client会申请加入该组播组,通过display igmp-snooping group命令可以查看IGMP Snooping转发表的信息。

[AC] display igmp-snooping group

Total 1 entries.

 

VLAN 200: Total 1 entries.

  (0.0.0.0, 224.1.1.1)

    Host slots (0 in total):

    Host ports (2 in total):

      WLAN-BSS1/0/1                       (00:02:45)

由此可见,连接到service1的Client所在的端口WLAN-BSS1/0/1已加入组播组224.1.1.1。

(3)       显示AC上二层组播快速转发表信息。

[AC] display l2-multicast fast-forwarding cache

Total 1 entries, 1 matched

 (1.1.1.100,224.1.1.1)

    Status      : Enable                VLAN            : 200

    Source port : 63                    Destination port: 63

    Protocol    : 17                    Flag            : 0x2

    Ingress port: GigabitEthernet1/0/1

    List of 1 egress ports:

        WLAN-BSS1/0/1

          Status: Enable                Flag: 0x10

由此可见,连接到service1的Client收到了视频流量。

(4)       接入无线服务service2的Client没有接收到视频流量。

3.6  配置文件

·            AC:

#

igmp-snooping

#

dhcp enable

#

vlan 100

#

vlan 200

#

dhcp server ip-pool vlan100

 gateway-list 112.12.1.25

 network 112.12.0.0 mask 255.255.0.0

#

dhcp server ip-pool vlan200

 gateway-list 112.13.1.25

 network 112.13.0.0 mask 255.255.0.0

 dns-list 112.13.1.25

#

vlan 200

 igmp-snooping enable

 igmp-snooping drop-unknown

#

wlan service-template service1

 ssid service1

 vlan 200

 service-template enable  

#

wlan service-template service2

 ssid service2

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 112.12.1.25 255.255.0.0

#

interface Vlan-interface200

 ip address 112.13.1.25 255.255.0.0

#

wlan ap ap1 model WA4320i-ACN

 serial-id 210235A1GQC157001570

 radio 1

  radio enable

  service-template service1

radio 2

  radio enable

  service-template service2

#

·            Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-type trunk

undo port trunk permit vlan 1 

 port trunk permit vlan 100 200

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port access vlan 100

poe enable

#

4  相关资料

·            《H3C无线控制器产品 配置指导》中的“网络互通配置指导”。

·            《H3C无线控制器产品 命令参考》中的“网络互通命令参考”。

·            《H3C无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C无线控制器产品 命令参考》中的“WLAN接入命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!