国家 / 地区

03-典型配置案例(AC+FIT AP)

38-H3C无线控制器用户数接入限制典型配置举例(V7)

本章节下载  (200.12 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274617_30005_0.htm

38-H3C无线控制器用户数接入限制典型配置举例(V7)

H3C 无线控制器

用户数接入限制典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍用户数接入限制典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解用户数接入限制特性。

3  配置举例

3.1  组网需求

图1所示,AC和AP通过三层交换机Switch连接,三层交换机Switch作为DHCP server为AP和无线客户端分配地址,无线网络采用集中式转发。完成以下需求配置:

·            通过配置射频上最大接入用户数,使AP 1仅允许一个无线客户端(Client 1)接入;

·            通过配置服务模板上最大接入用户数,使AP 2上仅允许两个无线客户端(Client 2与Client 3)接入。

图1 用户接入限制组网图

 

3.2  配置注意事项

配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

3.3  配置步骤

3.3.1  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client将使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.0.1 24

[AC-Vlan-interface200] quit

# 配置与Switch相连的接口GigabitEthernet1/0/1的属性为Trunk,允许VLAN 1、VLAN 100和VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 1 100 200

[AC-GigabitEthernet1/0/1] quit

(2)       配置无线服务模板

# 创建服务模板service,并进入无线服务模板视图。

[AC] wlan service-template service

# 配置SSID为service。

[AC-wlan-st-service] ssid service

# 配置无线服务模板VLAN为200。

[AC-wlan-st-service] vlan 200

# 配置允许关联的最大客户端数目为2。

[AC-wlan-st-service] client max-count 2

# 开启无线服务模板。

[AC-wlan-st-service] service-template enable

[AC-wlan-st-service] quit

# 创建AP,配置AP 1名称为officeap1,型号名称选择WA4320i-ACN,并配置序列号210235A1GQC158004457。

[AC] wlan ap officeap1 model WA4320i-ACN

[AC-wlan-ap-officeap1] serial-id 210235A1GQC158004457

# 进入Radio 1视图。

[AC-wlan-ap-officeap1] radio 1

# 配置Radio 1允许关联的最大客户端数目为1。

[AC-wlan-ap-officeap1-radio-1] client max-count 1

# 将无线服务模板service绑定到Radio 1,并开启射频。

[AC-wlan-ap-officeap1-radio-1] service-template service

[AC-wlan-ap-officeap1-radio-1] radio enable

[AC-wlan-ap-officeap1-radio-1] quit

[AC-wlan-ap-officeap1] quit

# 创建AP,配置AP 2名称为officeap2,型号名称选择WA4320i-ACN,并配置序列号210235A1GQC158004458。

[AC] wlan ap officeap2 model WA4320i-ACN

[AC-wlan-ap-officeap2] serial-id 210235A1GQC158004458

# 进入Radio 1视图。

[AC-wlan-ap-officeap2] radio 1

# 将无线服务模板service绑定到Radio 1,并开启射频。

[AC-wlan-ap-officeap2-radio-1] service-template service

[AC-wlan-ap-officeap2-radio-1] radio enable

[AC-wlan-ap-officeap2-radio-1] quit

[AC-wlan-ap-officeap2] quit

3.3.2  配置Switch

# 创建VLAN 100,用于转发AC和AP间CAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# 创建VLAN 200,用于转发Client无线报文。

[Switch] vlan 200

[Switch-vlan200] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,允许VLAN 1、VLAN 100和VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 1 100 200

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP 1相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 开启GigabitEthernet1/0/2接口的PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# 配置Switch与AP 2相连的GigabitEthernet1/0/3接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 100

# 开启GigabitEthernet1/0/3接口的PoE功能。

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

# 配置VLAN 100接口的IP地址。

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ip address 192.1.0.2 16

[Switch-Vlan-interface100] quit

# 配置VLAN 200接口的IP地址。

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 192.2.0.2 24

[Switch-Vlan-interface200] quit

# 开启DHCP功能。

[Switch] dhcp enable

# 配置DHCP地址池100,用于为AP分配IP地址。

[Switch] dhcp server ip-pool 100

[Switch-dhcp-pool-100] network 192.1.0.0 mask 255.255.0.0

[Switch-dhcp-pool-100] gateway-list 192.1.0.1

[Switch-dhcp-pool-100] quit

# 配置DHCP地址池200,用于为Client分配IP地址。为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址)。

[Switch] dhcp server ip-pool 200

[Switch-dhcp-pool-200] network 192.2.0.0 mask 255.255.255.0

[Switch-dhcp-pool-200] gateway-list 192.2.0.1

[Switch-dhcp-pool-200] dns-list 192.2.0.1

[Switch-dhcp-pool-200] quit

3.4  验证配置

# Client 1、Client 2、Client 3、Client 4依次尝试接入无线网络。在AC上可以通过display wlan client命令查看无线客户端的信息,从显示信息中可以看出, Client 1、Client 2与Client 3成功接入无线网络,而Client 4未能接入无线网络。

[AC] display wlan client

Total number of clients: 3

 

MAC address     Username   AP name         RID   IP address      IPv6 address   VLAN

0000-000f-1211  N/A        officeap1       1     192.2.0.3       N/A            200

0000-000f-1212  N/A        officeap2       1     192.2.0.4       N/A            200

0000-000f-1213  N/A        officeap2       1     192.2.0.5       N/A            200

3.5  配置文件

·            AC:

#

vlan 1

#

vlan 100

#

vlan 200

#

wlan service-template service

 ssid service

 vlan 200

 client max-count 2

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

wlan ap officeap1 model WA4320i-ACN

 serial-id 210235A1GQC158004457

 radio 1

  radio enable

  service-template service

  client max-count 1

#

wlan ap officeap2 model WA4320i-ACN

 serial-id 210235A1GQC158004458

 radio 1

  radio enable

  service-template service

#

·            Switch:

#

vlan 1

#

vlan 100

#

vlan 200

#

dhcp server ip-pool 100

 gateway-list 192.1.0.1

 network 192.1.0.0 mask 255.255.0.0

#

dhcp server ip-pool 200

 gateway-list 192.2.0.1

 network 192.2.0.0 mask 255.255.255.0

 dns-list 192.2.0.1

#

interface Vlan-interface100

 ip address 192.1.0.2 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access permit vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

 port link-type access

 port access permit vlan 100

 poe enable

#

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“WLAN接入命令参考”。

·            《H3C 无线控制器产品 配置指导》中的“射频资源管理配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“射频资源管理命令参考”。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!