国家 / 地区

03-典型配置案例(AC+FIT AP)

31-H3C无线控制器内网用户通过NAT地址访问外网典型配置举例(V7)

本章节下载  (195.32 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274610_30005_0.htm

31-H3C无线控制器内网用户通过NAT地址访问外网典型配置举例(V7)

H3C 无线控制器

内网用户通过NAT地址访问外网典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍内网用户通过NAT地址访问外网的典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解NAT和WLAN接入特性。

3  配置举例

3.1  组网需求

图1所示,AP和Client通过DHCP服务器获取IP地址,用于地址转换的两个公网地址为202.38.1.2、202.38.1.3。具体要求如下:

·            只允许192.168.1.0/24网段的用户访问Internet,其它网段的用户不能访问Internet。

·            在AC出接口配置动态地址转换。

图1 内网用户通过NAT访问外网组网图

 

3.2  配置注意事项

·            VLAN接口下应用NAT时,建议采用地址组(nat address-group)的形式进行动态地址转换。

·            地址组(nat address-group)中不要添加VLAN接口自己的公网IP地址。

·            如果整个AC只有VLAN接口一个公网IP地进行动态地址转换,则需要通过命令port-range配置合理的起始端口号和结束端口号,建议使用10000~65535,确保AC的业务端口号不被用于NAT转发。

3.3  配置步骤

说明

需要保证各设备间路由可达,本例路由配置略。

 

3.3.1  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.0.1 24

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client将使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.168.1.1 24

[AC-Vlan-interface200] quit

# 创建VLAN 300及其对应的VLAN接口,并为该接口配置IP地址。AC将使用该VLAN进行动态地址转换。

[AC] vlan 300

[AC-vlan300] quit

[AC] interface vlan-interface 300

[AC-Vlan-interface300] ip address 202.38.1.1 24

[AC-Vlan-interface300] quit

(2)       配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSID为service。

[AC-wlan-st-1] ssid service

# 配置无线服务模板VLAN为200。

[AC-wlan-st-1] vlan 200

# 开启无线服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

# 创建AP,配置AP名称为officeap,型号名称选择WA4320i-ACN,并配置序列号210235A1GQC152001076。

[AC] wlan ap officeap model WA4320i-ACN

[AC-wlan-ap-officeap] serial-id 210235A1GQC152001076

# 进入Radio 2视图。

[AC-wlan-ap-officeap] radio 2

# 将无线服务模板1绑定到radio 2,并开启射频。

[AC-wlan-ap-officeap-radio-2] service-template 1

[AC-wlan-ap-officeap-radio-2] radio enable

[AC-wlan-ap-officeap-radio-2] quit

[AC-wlan-ap-officeap] quit

(3)       配置动态地址转换

# 配置地址组0,包含两个外网地址202.38.1.2和202.38.1.3。

[AC] nat address-group 0

[AC-address-group-1] address 202.38.1.2 202.38.1.3

[AC-address-group-1] quit

# 配置ACL 2000,仅允许对内部网络中192.168.1.0/24网段的用户报文进行地址转换。

[AC] acl basic 2000

[AC-acl-ipv4-adv-2000] rule permit source 192.168.1.0 0.0.0.255

[AC-acl-ipv4-adv-3000] quit

# 在接口Vlan-interface300上配置出方向动态地址转换,允许使用地址组0中的地址对匹配ACL 2000的报文进行源地址转换,并在转换过程中使用端口信息。

[AC] interface vlan-interface 300

[AC-Vlan-interface300] nat outbound 2000 address-group 0

[AC-Vlan-interface300] quit

3.3.2  配置Switch

# 创建VLAN 100,用于转发AC和AP间CAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# 创建VLAN 200,用于转发Client无线报文。

[Switch] vlan 200

[Switch-vlan200] quit

# 创建VLAN 300,用于转发访问外网的流量。

[Switch] vlan 300

[Switch-vlan2] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,允许VLAN 100、VLAN 200和VLAN 300通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200 300

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 使能PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

3.4  验证配置

上述配置完成后,当192.168.1.0/24网段的用户访问Internet时,会进行动态NAT转换。在AC上使用 display nat session verbose命令,可以看到客户端访问外网时生成的NAT会话信息。

[AC] display nat session verbose

Slot 1:

Initiator:

  Source      IP/port: 192.168.1.2/1628

  Destination IP/port: 202.38.1.100/21

  DS-Lite tunnel peer: -

  VPN instance/VLAN ID/Inline ID: -/-/-

  Protocol: TCP(6)

  Inbound interface: Vlan-interface200

Responder:

  Source      IP/port: 202.38.1.100/21

  Destination IP/port: 202.38.1.2/1024

  DS-Lite tunnel peer: -

  VPN instance/VLAN ID/Inline ID: -/-/-

  Protocol: TCP(6)

  Inbound interface: Vlan-interface300

State: TCP_ESTABLISHED

Application: FTP

Start time: 2015-11-28 16:54:35  TTL: 2699s

Initiator->Responder:            1 packets          84 bytes

Responder->Initiator:            1 packets          84 bytes

 

Total sessions found: 1 s

3.5  配置文件

·            AC:

#

vlan 100

#

vlan 200

#

vlan 300

#

wlan service-template 1

 ssid service

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 192.168.0.1 255.255.255.0

#

interface Vlan-interface200

 ip address 192.168.1.1 255.255.255.0

#

interface Vlan-interface300

 ip address 202.38.1.1 255.255.255.0

 nat outbound 2000 address-group 1

#

acl basic 2000

 rule 0 permit source 192.168.1.0 0.0.0.255

#

nat address-group 0

 address 202.38.1.2 202.38.1.3

#

wlan ap officeap model WA4320i-ACN

 serial-id 210235A1GQC152001076

 radio 1

 radio 2

  radio enable

  service-template 1

#

·            Switch:

#

vlan 100

#

vlan 200

#

vlan 300

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200 300

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

poe enable

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“网络互通配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“网络互通命令参考”。

·            《H3C 无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“WLAN接入命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!