国家 / 地区

03-典型配置案例(AC+FIT AP)

29-H3C无线控制器IPv6 Portal MAC-Trigger快速认证典型配置举例(V7)

本章节下载  (532.70 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274608_30005_0.htm

29-H3C无线控制器IPv6 Portal MAC-Trigger快速认证典型配置举例(V7)

H3C 无线控制器

IPv6 Portal MAC-Trigger快速认证典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍Portal MAC-Trigger IPv6自动认证配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解AAA、Portal、WLAN特性。

3  配置举例

3.1  组网需求

图1所示,AP和Client通过DHCP和DHCPv6服务器获取IP和IPv6地址,iMC同时作为Portal认证服务器和Portal Web服务器、RADIUS服务器和MAC绑定服务器,要求:

·            Client在通过Portal认证前,只能访问Portal Web服务器;Client通过Portal认证后,可以访问外部网络。

·            在Client的流量达到1024000字节之前,允许Client访问外部网络资源,一旦流量达到1024000字节,则触发MAC快速认证。

·            用户可以在VLAN内的任何二层端口上访问网络资源,且移动接入端口时无须重复认证。

·            iMC服务器需要对用户授权信息进行动态修改或强制用户下线。

图1 Portal MAC-Trigger IPv6自动认证组网图

 

3.2  配置思路

·            为了通过MAC-Trigger实现IPv6自动认证,AC、Client和iMC需要同时配置IPv4和IPv6地址,且各设备间IPv4路由和IPv6路由都需要可达。

·            为了使用户可以在VLAN内的任何二层端口上访问网络资源,且移动接入端口时无须重复认证,必须开启Portal用户漫游功能。

·            为了使服务器对用户授权信息进行动态修改或强制用户下线,必须开启RADIUS session control功能。

·            为了将AP的GigabitEthernet1/0/1接口加入本地转发的VLAN 200,需要使用文本文档编辑AP的配置文件,并将配置文件上传到AC存储介质上。

·            为了防止用户上线过程中,动态授权信息下发失败,需要配置RADIUS DAE服务器功能。

·            为了使用户通过一次Portal认证既能访问IPv4网络也能访问IPv6网络,需要开启Portal支持双协议栈功能。

·            为了在AC上查看用户IPv6地址,需要开启通过DHCPv6方式学习客户端IPv6地址功能和通过ND方式学习客户端IPv6地址功能。

·            如果需要进行域名解析,请增加DNS相关配置,本举例略。

3.3  配置注意事项

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·            AC上配置的Portal认证服务器、Portal Web服务器和MAC绑定服务器的服务器类型必须与实际服务器一致。

·            设备重定向给用户的Portal Web服务器的URL默认是不携带参数,需要根据实际应用手动添加需要携带的参数信息

·            若在VLAN接口视图下开启Portal认证,只能采用集中转发;若在服务模板视图下开启Portal认证,则本地转发和集中式转发都支持。

·            配置用户免认证流量的阈值后,客户端不会自动弹出Portal认证页面,需要手动打开浏览器进行重定向,如果希望自动弹出Portal认证页面,请不要配置该阈值。

3.4  配置步骤

3.4.1  配置iMC

说明

下面以iMC为例(使用iMC版本为:iMC PLAT 7.1(E0303)、iMC EIA 7.1(E0304)、iMC EIP 7.1(E0304))说明RADIUS server、Portal server和MAC绑定服务器的基本配置。

 

(1)       配置RADIUS server

# 增加接入设备

登录进入iMC管理平台,选择“用户”页签,单击导航树中的[接入策略管理/接入设备管理/接入设备配置]菜单项,单击<增加>按钮,进入“增加接入设备”页面。

·            配置共享密钥为radius,该共享密钥与AC上配置RADIUS服务器时的密钥一致。

·            单击<手工增加>按钮,进入“手工增加接入设备”页面,填写起始IP地址为2.2.2.1,单击<确定>按钮完成操作。

·            单击<增加IPv6设备>按钮,进入“手工增加接入设备”页面,填写起始IP地址为2001::1,单击<确定>按钮完成操作。

·            其他配置采用页面默认配置即可。

·            单击<确定>按钮完成操作。

图2 增加IPv4接入设备

 

图3 增加IPv6接入设备

 

(2)       配置Portal server

# 配置Portal认证服务

登录进入iMC管理平台,选择“用户”页签,单击导航树中的[接入策略管理/Portal服务管理/服务器配置]菜单项,进入服务器配置页面。

·            根据实际组网情况调整以下参数,本例中使用缺省配置。

图4 Portal认证服务器配置页面

 

# 配置IP地址组。

单击导航树中的[接入策略管理/Portal服务管理/IP地址组配置]菜单项,进入Portal IP地址组配置页面,在该页面中单击<增加>按钮,进入增加IP地址组配置页面。

·            填写IP地址组名;

·            IPv6选择“是”。(仅IPv6,IPv4地址选“否”)

·            输入起始地址和终止地址,输入的地址范围中应包含用户主机的IP地址;

·            选择业务分组,本例中使用缺省的“未分组”;

·            选择IP地址组的类型为“普通”。(仅IPv4地址组配置本项)

图5 增加IPv4地址组配置页面

 

图6 增加IPv6地址组配置页面

 

# 增加Portal设备

单击导航树中的[接入策略管理/Portal服务管理/设备配置]菜单项,进入Portal设备配置页面,在该页面中单击<增加>按钮,进入增加设备信息配置页面。

·            填写设备名;

·            IPv4用户版本选择“Portal 2.0”,IPv6用户版本选择“Portal 3.0”;

·            指定IP地址为与接入用户相连的设备接口IP;

·            选择是否支持逃生心跳功能和用户心跳功能,本例中选择否。

·            输入密钥,与AC上的配置保持一致;

·            选择组网方式为直连;

·            其它参数可采用缺省配置。

图7 增加IPv4设备信息配置页面

 

图8 增加IPv6设备信息配置页面

 

# Portal设备关联IP地址组

在Portal设备配置页面中的设备信息列表中,单击NAS设备的<端口组信息管理>链接,进入端口组信息配置页面。

图9 IPv4设备信息列表

 

图10 IPv6设备信息列表

 

在端口组信息配置页面中单击<增加>按钮,进入增加端口组信息配置页面。

·            填写端口组名;

·            选择IP地址组,用户接入网络时使用的IP地址必须属于所选的IP地址组;

·            无感知认证选择“支持”;

·            其它参数可采用缺省配置。

图11 增加IPv4端口组信息配置页面

 

图12 增加IPv6端口组信息配置页面

 

# 最后单击导航树中的[接入策略管理/业务参数配置/系统配置手工生效]菜单项,使以上Portal认证服务器配置生效。

(3)       配置MAC绑定服务器

# 增加接入策略

单击导航树中的[接入策略管理/接入策略管理]菜单项,并单击<增加>按钮,进入“增加接入策略”页面。

·            填写接入策略名;

·            选择业务分组;

·            其它参数可采用缺省配置。

图13 增加接入策略配置

 

# 增加接入服务

单击导航树中的[接入策略管理/接入服务管理]菜单项,并单击<增加>按钮,进入“增加接入服务配置”页面。

·            填写服务名;

·            缺省接入策略选择已配置好的接入策略;

·            勾选“Portal无感知认证”;

·            其它参数可采用缺省配置。

图14 增加接入服务配置

 

# 增加接入用户

单击导航树中的[接入用户管理/接入用户]菜单项,并单击<增加>按钮,进入增加接入用户页面。

·            用户姓名选择已经存在的可接入的用户或单击<增加用户按钮>,增加一个新用户;

·            填写账号名;

·            设置密码;

·            设置“Portal无感知认证最大绑定数”;

·            其它参数可采用缺省配置。

图15 增加接入用户

 

# 配置系统参数

单击导航树中的[接入策略管理/业务参数配置/系统配置]菜单项,并单击[终端管理参数配置]对应的<配置>按钮,进入终端管理参数配置页面。

·            无感知认证选择“启用”;

·            “非智能终端Portal无感知认证”可根据实际需要允许或禁用,本例中为允许。

图16 配置终端管理参数

 

单击导航树中的[接入策略管理/业务参数配置/系统配置]菜单项,单击[终端老化时长]对应的<配置>按钮,然后单击<修改>,进入终端老化时长配置页面。

根据实际需要配置终端老化时间,本例中采用默认值。

图17 配置终端老化时长

 

# 最后单击导航树中的[接入策略管理/业务参数配置/系统配置手工生效]菜单项,使以上配置生效。

3.4.2  编辑AP配置文件

# 使用文本文档编辑AP的配置文件,将配置文件命名为map.txt,并将配置文件上传到AC存储介质上。配置文件内容和格式如下:

System-view

vlan 200

interface gigabitethernet1/0/1

port link-type trunk

port trunk permit vlan 200

3.4.3  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IPv6地址。AP将通过该VLAN与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 2.2.1.1 24

[AC-Vlan-interface100] ipv6 address 2001::1 64

# 取消对RA消息发布的抑制。

[AC-Vlan-interface100] undo ipv6 nd ra halt

# 设置被管理地址配置标志位为1。

[AC-Vlan-interface100] ipv6 nd autoconfig managed-address-flag

# 设置其他配置标志位为1。

[AC-Vlan-interface100] ipv6 nd autoconfig other-flag

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IPv6地址。Client将使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 2.2.2.1 24

[AC-Vlan-interface200] ipv6 address 2004::1 64

# 取消对RA消息发布的抑制。

[AC-Vlan-interface200] undo ipv6 nd ra halt

# 设置被管理地址配置标志位为1。

[AC-Vlan-interface200] ipv6 nd autoconfig managed-address-flag

# 设置其他配置标志位为1。

[AC-Vlan-interface200] ipv6 nd autoconfig other-flag

[AC-Vlan-interface200] quit

(2)       配置静态路由

# 配置到iMC服务器的静态路由。

[AC] ip route-static 192.168.0.0 255.255.0.0 2.2.2.100

[AC] ipv6 route-static 2003:: 64 2002::2

(3)       配置无线服务

# 创建无线服务模板st1,并进入无线服务模板视图。

[AC] wlan service-template st1

# 配置SSID为service。

[AC-wlan-st-st1] ssid service

# 配置无线服务模板VLAN为200。

[AC-wlan-st-st1] vlan 200

# 配置客户端数据报文转发位置为AP。

[AC–wlan-st-service1] client forwarding-location ap

[AC-wlan-st-service1] quit

# 创建AP,配置AP名称为office,型号名称选择WA4320i-ACN,并配置序列号219801A0CNC138011454。

[AC] wlan ap office model WA4320i-ACN

[AC-wlan-ap-office] serial-id 219801A0CNC138011454

# 进入Radio 2视图。

[AC-wlan-ap-office] radio 2

# 将无线服务模板st1绑定到radio 2,并开启射频。

[AC-wlan-ap-office-radio-2] service-template st1

[AC-wlan-ap-office-radio-2] radio enable

[AC-wlan-ap-office-radio-2] quit

[AC-wlan-ap-office] quit

(4)       配置IPv4 RADIUS方案

# 创建名称为rs1的RADIUS方案,并进入该方案视图。

[AC] radius scheme rs1

# 配置RADIUS方案的主认证和主计费服务器及其通信密钥。

[AC-radius-rs1] primary authentication 192.168.0.111

[AC-radius-rs1] primary accounting 192.168.0.111

[AC-radius-rs1] key authentication simple radius

[AC-radius-rs1] key accounting simple radius

# 配置发送给RADIUS服务器的用户名不携带ISP域名。

[AC-radius-rs1] user-name-format without-domain

# 设置设备发送RADIUS报文使用的源IP地址为2.2.2.1。

[AC-radius-rs1] nas-ip 2.2.2.1

[AC-radius-rs1] quit

# 使能RADUIS session control功能。

[AC] radius session-control enable

# 开启RADIUS DAE服务,并进入RADIUS DAE服务器视图。

[AC] radius dynamic-author server

# 设置RADIUS DAE客户端的IP地址为192.168.0.111,与RADIUS DAE客户端交互DAE报文时使用的共享密钥为明文radius。

[AC-radius-da-server] client ip 192.168.0.111 key simple radius

[AC-radius-da-server] quit

(5)       配置IPv6 RADIUS方案

# 创建名称为rs2的RADIUS方案,并进入该方案视图。

[AC] radius scheme rs2

# 配置RADIUS方案的主认证和主计费服务器及其通信密钥。

[AC-radius-rs2] primary authentication ipv6 2003::2

[AC-radius-rs2] primary accounting ipv6 2003::2

[AC-radius-rs2] key authentication simple radius

[AC-radius-rs2] key accounting simple radius

# 配置发送给RADIUS服务器的用户名不携带ISP域名。

[AC-radius-rs2] user-name-format without-domain

# 设置设备发送RADIUS报文使用的源IPv6地址为2004::1。

[AC-radius-rs1] nas-ip ipv6 2004::1

[AC-radius-rs2] quit

# 开启RADIUS DAE服务,并进入RADIUS DAE服务器视图。

[AC] radius dynamic-author server

# 设置RADIUS DAE客户端的IPv6地址为2003::2,与RADIUS DAE客户端交互DAE报文时使用的共享密钥为明文radius。

[AC-radius-da-server] client ipv6 2003::2 key simple radius

[AC-radius-da-server] quit

(6)       配置IPv4用户认证域

# 创建名为dm1的ISP域并进入其视图。

[AC] domain dm1

# 为Portal用户配置AAA认证方法为RADIUS。

[AC-isp-dm1] authentication portal radius-scheme rs1

# 为Portal用户配置AAA授权方法为RADIUS。

[AC-isp-dm1] authorization portal radius-scheme rs1

# 为Portal用户配置AAA计费方法为none,不计费。

[AC-isp-dm1] accounting portal none

# 指定ISP域dm1下的用户闲置切断时间为15分钟,闲置切断时间内产生的流量为1024字节。

[AC-isp-dm1] authorization-attribute idle-cut 15 1024

[AC-isp-dm1] quit

(7)       配置IPv6用户认证域

# 创建名为dm2的ISP域并进入其视图。

[AC] domain dm2

# 为Portal用户配置AAA认证方法为RADIUS。

[AC-isp-dm2] authentication portal radius-scheme rs2

# 为Portal用户配置AAA授权方法为RADIUS。

[AC-isp-dm2] authorization portal radius-scheme rs2

# 为Portal用户配置AAA计费方法为none,不计费。

[AC-isp-dm2] accounting portal none

# 指定ISP域dm2下的用户闲置切断时间为15分钟,闲置切断时间内产生的流量为1024字节。

[AC-isp-dm2] authorization-attribute idle-cut 15 1024

[AC-isp-dm2] quit

(8)       配置Portal认证

# 配置IPv4 Portal认证服务器,名称为newptv4,IP地址为192.168.0.111。

[AC] portal server newptv4

[AC-portal-server-newptv4] ip 192.168.0.111 key simple 123456

[AC-portal-server-newptv4] quit

# 配置IPv6 Portal认证服务器,名称为newptv6,IPv6地址为2003::2。

[AC] portal server newptv6

[AC-portal-server-newptv6] ipv6 2003::2 key simple 123456

[AC-portal-server-newptv6] quit

# 配置IPv4 Portal Web服务器的URL为http://192.168.0.111:8080/portal。

[AC] portal web-server newptv4

[AC-portal-websvr-newptv4] url http://192.168.0.111:8080/portal

# 配置设备重定向给用户的Portal Web服务器的URL中携带参数ssid、wlanuserip和wlanacname,其值分别为AP的SSID、用户的IP地址和AC名称(这三个参数与中国移动对接时必配)。

[AC-portal-websvr-newptv4] url-parameter ssid ssid

[AC-portal-websvr-newptv4] url-parameter wlanuserip source-address

[AC-portal-websvr-newptv4] url-parameter wlanacname value AC

[AC-portal-websvr-newptv4] quit

# 配置IPv6 Portal Web服务器的URL为http://[2003::2]:8080/portal。

[AC] portal web-server newptv6

[AC-portal-websvr-newptv6] url http://[2003::2]:8080/portal

# 配置设备重定向给用户的Portal Web服务器的URL中携带参数ssid、wlanuserip和wlanacname,其值分别为AP的SSID、用户的IP地址和AC名称(这三个参数与中国移动对接时必配)。

[AC-portal-websvr-newptv6] url-parameter ssid ssid

[AC-portal-websvr-newptv6] url-parameter wlanuserip source-address

[AC-portal-websvr-newptv6] url-parameter wlanacname value AC

[AC-portal-websvr-newptv6] quit

# 开启无线Portal漫游功能。

[AC] portal roaming enable

# 在无线服务模板st1上使能直接方式的Portal认证。

[AC] wlan service-template st1

[AC-wlan-st-st1] portal enable method direct

[AC-wlan-st-st1] portal ipv6 enable method direct

# 开启通过ND方式学习客户端IPv6地址功能。

[AC-wlan-st-st1] client ipv6-snooping nd-learning enable

# 开启通过DHCPv6方式学习客户端IPv6地址功能。

[AC-wlan-st-st1] client ipv6-snooping dhcpv6-learning enable

# 配置接入的IPv4 Portal用户使用认证域为dm1

[AC-wlan-st-st1] portal domain dm1

# 配置接入的IPv6 Portal用户使用认证域为dm2

[AC-wlan-st-st1] portal ipv6 domain dm2

# 在无线服务模板st1上引用IPv4 Portal Web服务器newptv4。

[AC-wlan-st-st1] portal apply web-server newptv4

# 在无线服务模板st1上引用IPv6 Portal Web服务器newptv6。

[AC-wlan-st-st1] portal ipv6 apply web-server newptv6

# 开启Portal支持双协议栈功能。

[AC-wlan-st-st1] portal dual-stack enable

# 设置发送给Portal认证服务器的Portal报文中的BAS-IP和BAS-IPv6属性。

[AC-wlan-st-st1] portal bas-ip 2.2.2.1

[AC-wlan-st-st1] portal bas-ipv6 2004::1

[AC-wlan-st-st1] quit

# 配置一条Portal免认证规则:编号为3,源接口为聚合接口1。该规则表示从AC聚合接口1上的用户不需要经过Portal认证即可以访问网络资源。

[AC] portal free-rule 3 source interface Bridge-Aggregation1

(9)       配置Portal基于MAC地址的快速认证

# 创建MAC绑定服务器mts,并进入MAC绑定服务器视图。

[AC] portal mac-trigger-server mts

# 配置用户免认证流量的阈值为1024000字节。

[AC-portal-mac-trigger-server-mts] free-traffic threshold 1024000

# 配置MAC绑定服务器的地址为192.168.0.111。

[AC-portal-mac-trigger-server-mts] ip 192.168.0.111

[AC-portal-mac-trigger-server-mts] quit

# 在无线服务模板上应用MAC绑定服务器mts。

[AC] wlan service-template st1

[AC-wlan-st-st1] portal apply mac-trigger-server mts

# 开启无线服务模板。

[AC-wlan-st-st1] service-template enable

[AC-wlan-st-st1] quit

3.4.4  配置Switch

# 创建VLAN 100,用于转发AC和AP间CAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# 创建VLAN 200,用于转发Client无线报文。

[Switch] vlan 200

[Switch-vlan200] quit

# 创建VLAN 2。

[Switch] vlan 2

[Switch-vlan2] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,允许VLAN 100和VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP相连的GigabitEthernet1/0/2接口属性为Access,并允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 使能PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# 配置VLAN 200接口的IP地址和IPv6地址。

[Switch] interface vlan-interface 200

[Switch-Vlan-interface200] ip address 2.2.2.100 255.255.255.0

[Switch-Vlan-interface200] ipv6 address 2002::2 64

[Switch-Vlan-interface200] quit

# 配置VLAN 2接口的IP地址和IPv6地址。

[Switch] interface vlan-interface 2

[Switch-Vlan-interface2] ip address 192.168.0.100 255.255.255.0

[Switch-Vlan-interface2] ipv6 address 2003::1 64

[Switch-Vlan-interface2] quit

3.5  验证配置

# 通过执行以下显示命令可查看MAC绑定服务器配置。

[AC] display portal mac-trigger-server name mts

Portal mac trigger server name: mts

  Version                    : 1.0

  Server type                : IMC

  IP                         : 192.168.0.111

  Port                       : 50100

  VPN instance               : Not configured

  Aging time                 : 300 seconds

  Free-traffic threshold     : 1024000 bytes

  NAS-Port-Type              : Not configured

  Binding retry times        : 3

  Binding retry interval     : 1 seconds

  Authentication timeout     : 3 minutes

  Local-binding              : Disabled

  Local-binding aging-time   : 720 minutes

  aaa-fail nobinding         : Disabled

  Excluded attribute list    : Not configured

  Cloud-binding              : Disabled

  Cloud-server URL           : Not configured

# 用户通过网页方式进行Portal认证。用户在通过认证前,发起的所有Web访问均被重定向到Portal认证页面(http://192.168.0.111:8080/portal),在通过认证后,可访问非受限的互联网资源。

用户在首次进行Portal认证时,需要手工输入用户名和密码。当用户再次上线时,将可以直接访问互联网资源,不会感知到Portal认证过程。

通过执行以下显示命令查看AC上生成的Portal在线用户信息。

[AC] display portal user all verbose

Total portal users: 1

Basic:

  AP name: office

  Radio ID: 1

  SSID: service

  Current IP address: 2.2.2.13

  Original IP address: 2.2.2.13

  Username: 4C:49:E3:F8:CC:9D

  User ID: 0x1000002d

  Access interface: WLAN-BSS1/0/17

  Service-VLAN/Customer-VLAN: 200/-

  MAC address: 4c49-e3f8-cc9d

  Authentication type: MAC-trigger

  Domain name: dm

  VPN instance: N/A

  Status: Online

  Portal server: newpt

  Vendor: Xiaomi

  Portal authentication method: Direct

AAA:

  Realtime accounting interval: 720s, retry times: 5

  Idle cut: N/A

  Session duration: 86400 sec, remaining: 86385 sec

  Remaining traffic: N/A

  Login time: 2018-08-10 17:13:58 Beijing

  Online time(hh:mm:ss): 00:00:15

  DHCP IP pool: N/A

ACL&QoS&Multicast:

  Inbound CAR: N/A

  Outbound CAR: N/A

  ACL number: N/A

  User profile: N/A

  Session group profile: N/A

  Max multicast addresses: 4

Flow statistic:

  Uplink   packets/bytes: 18/5595

  Downlink packets/bytes: 18/1971

Dual stack flow statistic:

  Ipv4 address: 2.2.2.13

          uplink   packets/bytes: 18/5595

          downlink packets/bytes: 18/1971

  Ipv6 address: 2002::2

          uplink   packets/bytes: 0/0

          downlink packets/bytes: 0/0

3.6  配置文件

·            AC:

#

vlan 100

#

vlan 200

#

wlan service-template st1

 ssid service

 vlan 200

 client forwarding-location ap

 client ipv6-snooping nd-learning enable

 client ipv6-snooping dhcpv6-learning enable

 portal enable method direct

 portal domain dm1

 portal bas-ip 2.2.2.1

 portal apply web-server newptv4

 portal apply mac-trigger-server mts

 portal ipv6 enable method direct

 portal ipv6 domain dm2

 portal bas-ipv6 2004::1

 portal ipv6 apply web-server newptv6

 portal dual-stack enable

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.1.1 255.255.255.0

 ipv6 address 2001::1/64

 ipv6 nd autoconfig managed-address-flag

 ipv6 nd autoconfig other-flag

 undo ipv6 nd ra halt

#

interface Vlan-interface200

 ip address 2.2.2.1 255.255.255.0

 ipv6 address 2004::1/64

 ipv6 nd autoconfig managed-address-flag

 ipv6 nd autoconfig other-flag

 undo ipv6 nd ra halt

#

 ip route-static 192.168.0.0 16 2.2.2.100

 ipv6 route-static 2003:: 64 2002::2

#

 radius session-control enable

#

radius scheme rs1

 primary authentication 192.168.0.111

 primary accounting 192.168.0.111

 key authentication cipher $c$3$Sqgqz7lDs4XPnethmAgyAKVlke7qwEkYbQ==

 key accounting cipher $c$3$4J/JBRGwqB4F213furJMkB6JWYXBFjWE6g==

 user-name-format without-domain

 nas-ip 2.2.2.1

#

radius scheme rs2

 primary authentication ipv6 2003::2

 primary accounting ipv6 2003::2

 key authentication cipher $c$3$ZqzlvbN5k1p/VDqt/prrN97yy0J4G2j8IQ==

 key accounting cipher $c$3$Q6Noroq7nFDkIBYIvpIZu3qQpAZzaDUYJQ==

 user-name-format without-domain

 nas-ip ipv6 2004::1

#

radius dynamic-author server

 client ip 192.168.0.111 key cipher $c$3$AkTEB7OgMYnCqsfDeplhoAgXUek/rVrLZw==

 client ipv6 2003::2 key cipher $c$3$NMxmVitbKeKG6ATH6LPUIxyHrSY5fDCvzQ==

 attribute convert Hw-Server-String to Connect-Info received

#

domain dm1

 authorization-attribute idle-cut 15 1024

 authentication portal radius-scheme rs1

 authorization portal radius-scheme rs1

 accounting portal none

#

domain dm2

 authorization-attribute idle-cut 15 1024

 authentication portal radius-scheme rs2

 authorization portal radius-scheme rs2

 accounting portal none

#

 portal free-rule 3 source interface Bridge-Aggregation1

#

 portal web-server newptv4

 url http://192.168.0.111:8080/portal

 url-parameter ssid ssid

 url-parameter wlanacname value AC

 url-parameter wlanuserip source-address

#

portal web-server newptv6

 url http://[2003::2]:8080/portal

 url-parameter ssid ssid

 url-parameter wlanacname value AC

 url-parameter wlanuserip source-address

#

portal server newptv4

 ip 192.168.0.111 key cipher $c$3$om5UnnnYF0jtLWRFaw+l+1V+47E6/lCzRg==

#

portal server newptv6                                                          

 ipv6 2003::2 key cipher $c$3$wu1Cg6I4PTcPTgPeKRF/7w9jIqIEq2xlTw==             

#

portal mac-trigger-server mts

 ip 192.168.0.111

 free-traffic threshold 1024000

#

wlan ap office model WA4320i-ACN

 serial-id 219801A0CNC138011454

 radio 1

 radio 2

  radio enable

  service-template st1

#

·            Switch:

#

vlan 2

#

vlan 100

#

vlan 200

#

interface Vlan-interface2

 ip address 192.168.0.100 255.255.255.0

 ipv6 address 2003::1 64

#

interface Vlan-interface200

 ip address 2.2.2.100 255.255.255.0

 ipv6 address 2002::2 64

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“用户接入与认证配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“用户接入与认证命令参考”。

·            《H3C 无线控制器产品 配置指导》中的“WLAN接入配置指导”

·            《H3C 无线控制器产品 命令参考》中的“WLAN接入命令参考”

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!