国家 / 地区

03-典型配置案例(AC+FIT AP)

10-H3C无线控制器WLAN负载均衡典型配置举例(V7)

本章节下载  (206.44 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274589_30005_0.htm

10-H3C无线控制器WLAN负载均衡典型配置举例(V7)

H3C 无线控制器

WLAN负载均衡典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍       WLAN负载均衡配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WLAN负载均衡特性。

3  配置举例

3.1  组网需求

图1所示,DHCP服务器为AP和无线客户端分配IP地址。AP 1和AP 2的Radio覆盖区域有重叠,为了对这两个AP上Radio的接入客户端进行负载均衡,有以下要求:

·            负载均衡的评判依据为在线客户端数量。

·            仅对AP 1的Radio 2和AP 2的Radio 2进行负载均衡。

·            当Radio上的在线客户端数量达到或超过2,并且与另一个Radio上的在线客户端数量差值达到或超过1,开始运行负载均衡。

图1 WLAN负载均衡组网图

 

3.2  配置思路

·            当使用在线客户端数量作为负载均衡的评判依据时,需要配置负载均衡模式为会话模式。

·            实现仅对AP 1的Radio 2和AP 2的Radio 2进行负载均衡,需要创建负载均衡组,并将AP 1的Radio 2和AP 2的Radio 2加入到负载均衡组中。

·            为避免AP拒绝客户端关联请求次数过多,使客户端上线时间过长,需要配置AP拒绝客户端关联请求的最大次数。

3.3  配置注意事项

·            每个AP上必须绑定相同的服务模板。

·            需要把AC接入网络的端口配置为Trunk类型,以保证可以转发不同VLAN的报文。

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

3.4  配置步骤

3.4.1  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址192.1.0.1/16。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址192.2.0.1/16。AC将使用该接口的IP地址和无线客户端进行通信。

[AC] vlan 200

[AC-vlan200] quit

[AC] interface vlan-interface 200

[AC-Vlan-interface200] ip address 192.2.0.1 16

[AC-Vlan-interface200] quit

# 将与Switch相连的接口GigabitEthernet1/0/1的链路类型配置为Trunk,允许VLAN 100和VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

(2)       配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSID为service。

[AC-wlan-st-1] ssid service

# 配置无线服务模板的VLAN为200。

[AC-wlan-st-1] vlan 200

# 开启无线服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

# 配置AP 1名称为officeap1,型号名称选择WA4320i-ACN,并配置序列号210235A1GQC152001076。

[AC] wlan ap officeap1 model WA4320i-ACN

[AC-wlan-ap-officeap1] serial-id 210235A1GQC152001076

# 将服务模板1绑定到officeap1的Radio 2口,并开启Radio 2。

[AC-wlan-ap-officeap1] radio 2

[AC-wlan-ap-officeap1-radio-2] service-template 1

[AC-wlan-ap-officeap1-radio-2] radio enable

[AC-wlan-ap-officeap1-radio-2] quit

[AC-wlan-ap-officeap1] quit

# 配置AP 2名称为officeap2,型号名称选择WA4320i-ACN,并配置序列号210235A1GQC152001078。

[AC] wlan ap officeap2 model WA4320i-ACN

[AC-wlan-ap-officeap2] serial-id 210235A1GQC152001078

# 将服务模板1绑定到officeap2的Radio 2口,并开启Radio2。

[AC-wlan-ap-officeap2] radio 2

[AC-wlan-ap-officeap2-radio-2] service-template 1

[AC-wlan-ap-officeap2-radio-2] radio enable

[AC-wlan-ap-officeap2-radio-2] quit

[AC-wlan-ap-officeap2] quit

(3)       配置负载均衡

# 配置负载均衡模式为会话模式,会话门限值为2,会话差值门限值为1。

[AC] wlan load-balance mode session 2 gap 1

# 创建负载均衡组1。

[AC] wlan load-balance-group 1

# 将AP 1的Radio 2和AP 2的Radio 2加入到负载均衡组中。

[AC-wlan-lb-group-1] ap name officeap1 radio 2

[AC-wlan-lb-group-1] ap name officeap2 radio 2

# 配置AP拒绝客户端关联请求的最大次数为5。

[AC] wlan load-balance access-denial 5

# 开启负载均衡功能。

[AC] wlan load-balance enable

3.4.2  配置Switch

# 创建VLAN 100和VLAN 200,其中VLAN 100用于转发AC和AP间CAPWAP隧道内的流量,VLAN 200用于转发Client无线报文。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] vlan 200

[Switch-vlan200] quit

# 将与AC相连的接口GigabitEthernet1/0/1的链路类型配置为Trunk,允许VLAN 100和VLAN 200通过。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/1] quit

# 将与AP 1相连的接口GigabitEthernet1/0/2的链路类型配置为Access,当前Access口允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 开启GigabitEthernet1/0/2接口的PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

# 将与AP 2相连的接口GigabitEthernet1/0/3的链路类型配置为Access,当前Access口允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/3

[Switch-GigabitEthernet1/0/3] port link-type access

[Switch-GigabitEthernet1/0/3] port access vlan 100

# 开启GigabitEthernet1/0/3接口的PoE功能。

[Switch-GigabitEthernet1/0/3] poe enable

[Switch-GigabitEthernet1/0/3] quit

# 将与DHCP server相连的接口GigabitEthernet1/0/4的链路类型配置为Trunk,允许VLAN100和VLAN 200通过。

[Switch] interface gigabitethernet 1/0/4

[Switch-GigabitEthernet1/0/4] port link-type trunk

[Switch-GigabitEthernet1/0/4] port trunk permit vlan 100 200

[Switch-GigabitEthernet1/0/4] quit

3.5  验证配置

AP 1的Radio 2上关联两个客户端,AP 2的Radio 2上没有关联客户端。当Client 3准备接入网络时,由于AP 1的Radio 2上的在线客户端数量已经达到2个,并且与AP 2的Radio 2上的在线客户端数量差值超过1,所以通过运行负载均衡,Client 3将关联到AP 2上。通过display wlan client命令可以查看到上线客户端的IP地址和关联的Radio。

[AC] display wlan client

Total number of clients: 3

 

MAC address     Username   AP name         RID  IP address      IPv6 address   VLAN

0015-005c-8b2c  N/A        officeap1       2    192.2.0.3       N/A            200

109a-dd9f-aaa2  N/A        officeap2       2    192.2.0.5       N/A            200

2c1f-2332-7f78  N/A        officeap1       2    192.2.0.4       N/A            200

3.6  配置文件

·            AC:

#

 wlan load-balance mode session 2 gap 1

 wlan load-balance enable

 wlan load-balance access-denial 5

#

vlan 100

#

vlan 200

#

wlan service-template 1

 ssid service

 vlan 200

 service-template enable

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface Vlan-interface200

 ip address 192.2.0.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 100 200

#

 

wlan ap officeap1 model WA4320i-ACN

 serial-id 210235A1GQC152001076

 radio 1

 radio 2

  service-template 1

  radio enable

#

wlan ap officeap2 model WA4320i-ACN

 serial-id 210235A1GQC152001078

 radio 1

 radio 2

  service-template 1

  radio enable

#

·            Switch:

#

vlan 100

#

vlan 200

#

interface GigabitEthernet1/0/1

 port link-mode bridge

 port link-type trunk

 port trunk permit vlan 100 200

#

interface GigabitEthernet1/0/2

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/3

 port access vlan 100

 poe enable

#

interface GigabitEthernet1/0/4

 port link-type trunk

 port trunk permit vlan 100 200

#

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“射频资源管理配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“射频资源管理命令参考”。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!