国家 / 地区

03-典型配置案例(AC+FIT AP)

09-H3C无线控制器自动AP典型配置举例(V7)

本章节下载  (159.52 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274588_30005_0.htm

09-H3C无线控制器自动AP典型配置举例(V7)

H3C 无线控制器

自动AP典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍自动AP配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解自动AP功能。

3  配置举例

3.1  组网需求

图1所示,AC作为DHCP服务器为AP分配IP地址,现要求使用自动AP功能,实现AP与AC自动关联,并且在关联后将AP转化为固化AP。

图1 自动AP配置举例组网图

 

3.2  配置步骤

3.2.1  AC的配置

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.1.0.1 16

[AC-Vlan-interface100] quit

# 将与Switch相连的接口GigabitEthernet1/0/1的链路类型配置为Trunk,禁止VLAN 1通过,允许VLAN 100通过,当前Trunk口的PVID为100。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] port trunk pvid vlan 100

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100

[AC-GigabitEthernet1/0/1] quit

(2)       配置DHCP功能

# 开启DHCP服务。

[AC] dhcp enable

# 配置DHCP地址池1为AP动态分配的网段为192.1.0.0/16,网关地址为192.1.0.1。

[AC] dhcp server ip-pool 1

[AC-dhcp-pool-1] network 192.1.0.0 16

[AC-dhcp-pool-1] gateway-list 192.1.0.1

[AC-dhcp-pool-1] quit

(3)       配置自动AP功能

# 开启自动AP功能。

[AC] wlan auto-ap enable

# 开启自动AP自动固化功能。

[AC] wlan auto-persistent enable

3.2.2  Switch的配置

# 创建VLAN 100,用于转发AC和AP间CAPWAP隧道内的流量。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

# 配置Switch与AC相连的GigabitEthernet1/0/1接口的属性为Trunk,禁止VLAN 1通过,允许VLAN 100通过,当前Trunk口的PVID为100。

[Switch] interface gigabitethernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[Switch-GigabitEthernet1/0/1] port trunk permit vlan 100

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

# 配置Switch与AP相连的GigabitEthernet1/0/2接口属性为Access,当前Access口允许VLAN 100通过。

[Switch] interface gigabitethernet 1/0/2

[Switch-GigabitEthernet1/0/2] port link-type access

[Switch-GigabitEthernet1/0/2] port access vlan 100

# 配置Switch与AP相连的GigabitEthernet1/0/2接口使能PoE功能。

[Switch-GigabitEthernet1/0/2] poe enable

[Switch-GigabitEthernet1/0/2] quit

3.3  验证配置

# 通过display wlan ap all命令可以看到AC与AP建立连接,AP的状态为Run。

[AC] display wlan ap all

Total number of APs: 1

Total number of connected APs: 1

Total number of connected manual APs: 1

Total number of connected auto APs: 0

Total number of connected common APs: 1

Total number of connected WTUs: 0

Total number of inside APs: 0

Maximum supported APs: 3072

Remaining APs: 3071

Total AP licenses: 128

Remaining AP licenses: 127

 

                                 AP information

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup

 

AP name                AP ID   State   Model             Serial ID

741f-4a35-6e00         1       R/M     WA4320-ACN-SI     219801A0T78156A00049

3.4  配置文件

·            AC

#

 dhcp enable

#

 vlan 100

#

dhcp server ip-pool 1

 gateway-list 192.1.0.1

 network 192.1.0.0 mask 255.255.0.0

#

interface Vlan-interface100

 ip address 192.1.0.1 255.255.0.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk pvid vlan 100

 port trunk permit vlan 100

#

wlan auto-ap enable

 wlan auto-persistent enable

#

·            Switch

#

vlan 100

#

interface GigabitEthernet1/0/1

 port link-type trunk

 undo port trunk permit vlan 1

 port trunk permit vlan 100

 port trunk pvid vlan 100

#

interface GigabitEthernet1/0/2

 port link-type access

 port access vlan 100

 poe enable

#

4  相关资料

·            《H3C 无线控制器产品 配置指导》中的“AP管理配置指导”。

·            《H3C 无线控制器产品 命令参考》中的“AP管理命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!