国家 / 地区

03-典型配置案例(AC+FIT AP)

03-H3C无线控制器三层注册典型配置举例(V7)

本章节下载  (207.03 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274582_30005_0.htm

03-H3C无线控制器三层注册典型配置举例(V7)

H3C 无线控制器

三层注册典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍AP与AC间通过三层网络完成注册的配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体软硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WLAN接入相关特性。

3  三层网络注册配置举例

3.1  组网需求

图1所示,集中式转发架构下,AC旁挂在L3 switch上,L3 switch做DHCP server为AP、Client和Host分配IP地址。需要实现无线客户端Client通过AP连接到AC上,并能与有线客户端Host互相访问,具体要求如下:

·            无线客户端Client通过VLAN 200接入网络,有线客户端Host通过VLAN 300接入网络;

·            AC属于VLAN 100,AP属于VLAN 400,AC和AP之间跨三层网络建立连接。

·            L2 switch 1通过PoE方式给AP供电。

图1 Fit AP通过三层网络注册到AC配置举例组网图

 

3.2  配置思路

·            在L3 switch上开启DHCP server功能,AP、无线客户端Client和有线客户端Host都能通过DHCP server自动获取IP地址。

·            在AC上配置缺省路由下一跳为L3 switch。

·            在DHCP server上配置AP通过option方式获取AC的IP地址完成三层注册。

·            在L2 switch 1上开启PoE功能,为AP设备供电。

·            在AC上配置无线服务,确保Client可以通过配置的无线服务接入网络。

3.3  配置注意事项

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·            在L2 switch 1上开启PoE功能,为AP设备供电。

·            配置L2 switch 1和AP相连的接口为Access口。

3.4  配置步骤

3.4.1  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将通过DHCP option43方式获取该IP地址与AC建立CAPWAP隧道。

<AC> system-view

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface100

[AC-Vlan-interface100] ip address 192.168.10.1 255.255.255.0

[AC-Vlan-interface100] quit

# 创建VLAN 200,AC需要使用该VLAN转发无线客户端数据报文。

[AC] vlan 200

[AC-vlan200] quit

# 配置AC和L3 switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

(2)       配置三层路由

# 配置AC缺省路由下一跳为L3 switch的IP地址为192.168.10.83。

[AC] ip route-static 0.0.0.0 0 24 192.168.10.83

(3)       配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSID为service。

[AC-wlan-st-1] ssid service

# 使能服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

(4)       配置AP

# 创建手工AP,名称为officeap,型号名称为WA4320i-ACN。

[AC] wlan ap officeap model WA4320i-ACN

# 设置AP的序列号为210235A1GQB147031200。

[AC-wlan-ap-officeap] serial-id 210235A1GQB147031200

# 进入AP的Radio 1视图,并将无线服务模板1绑定到Radio 1上,并指定客户端上线的VLAN为VLAN 200。

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan 200

# 开启Radio 1的射频功能。

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] return

3.4.2  配置L3 switch

(1)       配置L3 switch的接口

# 创建VLAN 100和VLAN 400,并配置IP地址,用于转发AC和AP间的CAPWAP隧道内的流量。

<L3 switch> system-view

[L3 switch] vlan 100

[L3 switch-vlan100] quit

[L3 switch] interface vlan-interface 100

[L3 switch-Vlan-interface100] ip address 192.168.10.83 255.255.255.0 

[L3 switch-Vlan-interface100] quit

[L3 switch] vlan 400

[L3 switch-vlan400] quit

[L3 switch] interface vlan-interface 400

[L3 switch-Vlan-interface400] ip address 192.168.40.1 255.255.255.0 

[L3 switch-Vlan-interface400] quit

# 创建VLAN 200,并为该接口配置IP地址。Client使用该VLAN接入无线网络。

[L3 switch] vlan 200

[L3 switch-vlan200] quit

[L3 switch] interface vlan-interface 200

[L3 switch-Vlan-interface200] ip address 192.168.20.1 255.255.255.0 

[L3 switch-Vlan-interface200] quit

# 创建VLAN 300,并为该接口配置IP地址。Host使用该VLAN与AC建立连接。

[L3 switch] vlan 300

[L3 switch-vlan300] quit

[L3 switch] interface vlan-interface 300

[L3 switch-Vlan-interface300] ip address 192.168.30.1 255.255.255.0 

[L3 switch-Vlan-interface300] quit

# 配置L3 switch和AC相连的接口GigabitEthernet1/0/1为Trunk类型,允许VLAN100和VLAN 200通过。

[L3 switch] interface gigabitEthernet 1/0/1

[L3 switch-GigabitEthernet1/0/1] port link-type trunk

[L3 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[L3 switch-GigabitEthernet1/0/1] quit

# 配置L3 switch和L2 switch1和相连的接口GigabitEthernet1/0/2为Trunk类型,禁止VLAN 1报文通过,允许VLAN 400通过。

[L3 switch] interface gigabitEthernet 1/0/2

[L3 switch-GigabitEthernet1/0/2] port link-type trunk 

[L3 switch-GigabitEthernet1/0/2] undo port trunk permit vlan 1

[L3 switch-GigabitEthernet1/0/2] port trunk permit vlan 400

 [L3 switch-GigabitEthernet1/0/2] quit

# 配置L3 switch和L2 switch2相连的接口GigabitEthernet1/0/3为Trunk类型,禁止VLAN 1报文通过,允许VLAN 300通过。

[L3 switch] interfac gigabitEthernet 1/0/3

[L3 switch-GigabitEthernet1/0/3] port link-type trunk

[L3 switch-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[L3 switch-GigabitEthernet1/0/3] port trunk permit vlan 300

[L3 switch-GigabitEthernet1/0/3] quit

(2)       配置DHCP server

# 开启DHCP server功能。

[L3 switch] dhcp enable

# 配置DHCP地址池1为AP分配地址范围为192.168.40.0/24,网关地址为192.168.40.1。

[L3 switch] dhcp server ip-pool 1

[L3 switch-dhcp-pool-1] network 192.168.40.0 mask 255.255.255.0

[L3 switch-dhcp-pool-1] gateway-list 192.168.40.1

# 配置DHCP Option43的内容为AC的十六进制IP地址。

[L3 switch-dhcp-pool-1] option 43 hex 8007000001c0a80a01

[L3 switch-dhcp-pool-1] quit

# 配置DHCP地址池2为Client分配地址范围为192.168.20.0/24,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为192.168.20.1。

[L3 switch] dhcp server ip-pool 2

[L3 switch-dhcp-pool-2] network 192.168.20.0 mask 255.255.255.0 

[L3 switch-dhcp-pool-2] gateway-list 192.168.20.1

[L3 switch-dhcp-pool-2] dns-list 192.168.20.1

[L3 switch-dhcp-pool-2] quit

# 配置DHCP地址池3为Host分配地址范围为192.168.30.0 /24,为Host分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置Host的DNS服务器地址),网关地址为192.168.30.1。

[L3 switch] dhcp server ip-pool 3

[L3 switch-dhcp-pool-3] network 192.168.30.0 mask 255.255.255.0

[L3 switch-dhcp-pool-3] gateway-list 192.168.30.1 

[L3 switch-dhcp-pool-3] dns-list 192.168.30.1

[L3 switch-dhcp-pool-3] quit

3.4.3  配置L2 switch 1

(1)       配置L2 switch 1的接口

# 创建VLAN 400,VLAN 400为AP接入的VLAN。

<L2 switch 1> system-view

[L2 switch 1] vlan 400

[L2 switch 1-vlan400] quit

# 配置L2 switch 1与L3 switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 400通过。

[L2 switch 1] interface gigabitEthernet 1/0/1

[L2 switch 1-GigabitEthernet1/0/1] port link-type trunk 

[L2 switch 1-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L2 switch 1-GigabitEthernet1/0/1] port trunk permit vlan 400

[L2 switch 1-GigabitEthernet1/0/1] quit

# 配置L2 switch 1与AP相连的接口GigabitEthernet1/0/2为Access类型,允许VLAN 400通过,并开启PoE远程供电功能。

[L2 switch 1] interface gigabitEthernet 1/0/2

[L2 switch 1-GigabitEthernet1/0/2] port link-type access 

[L2 switch 1-GigabitEthernet1/0/2] port access vlan 400

[L2 switch 1-GigabitEthernet1/0/2] poe enable

[L2 switch 1-GigabitEthernet1/0/2] quit

3.4.4  配置L2 switch 2

# 创建VLAN 300,VLAN 300为Host接入的VLAN。

<L2 switch 2> system-view

[L2 switch 2] vlan 300

[L2 switch 2-vlan300] quit

# 配置L2 switch 2与L3 switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 300通过。

[L2 switch 2] interface gigabitEthernet 1/0/1

[L2 switch 2-GigabitEthernet1/0/1] port link-type trunk 

[L2 switch 2-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L2 switch 2-GigabitEthernet1/0/1] port trunk permit vlan 300

[L2 switch 2-GigabitEthernet1/0/1] quit

# 配置L2 switch 2与Host相连的接口GigabitEthernet1/0/2为Access类型,允许VLAN 300通过。

[L2 switch 2] interface gigabitEthernet 1/0/2

[L2 switch 2-GigabitEthernet1/0/2] port link-type access 

[L2 switch 2-GigabitEthernet1/0/2] port access vlan 300

[L2 switch 2-GigabitEthernet1/0/2] quit

3.5  验证配置

(1)       在AC上查看到AP注册信息

# 在AC上使用命令display wlan ap all查看AP,可以看到AP的状态是R/M,表明AP已经成功注册到AC。

<AC> display wlan ap all                             

Total number of APs: 1                                                         

Total number of connected APs: 1                                               

Total number of connected manual APs: 1                                        

Total number of connected auto APs: 0

Total number of connected common APs: 1

Total number of connected WTUs: 0                                         

Total number of inside APs: 0                                        

Maximum supported APs: 3072                                                     

Remaining APs: 3071                                                            

Total AP licenses: 512                                              

Remaining AP licenses: 511                                                

                                                                               

                                 AP information                                

 State : I = Idle,      J  = Join,        JA = JoinAck,    IL = ImageLoad       

          C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup   

                                                                               

AP name                AP ID   State   Model             Serial ID             

officeap               1        R/M     WA4320i-ACN      210235A1GQB147031200 

(2)       在AC上查看Client信息

# 在AC上使用命令display wlan client查看在线Client,可以看到Client已经连接到AP的radio1。

<AC> display wlan client

Total number of clients: 1

                                                                               

MAC address    User name            AP name               R IP address      VLAN

90b9-311a-bef6 N/A                  officeap              1 192.168.20.3    200

(3)       Host与Client可以相互ping通

# Client通过DHCP server获取到IP地址192.168.20.3,在Host上ping Client的IP地址可以ping通。同理,在Client上ping Host的IP地址也能ping通,不再赘述。

C:\Users\system32>ping 192.168.20.3 -t

 

Pinging 192.168.20.3 with 32 bytes of data:

Reply from 192.168.20.3: bytes=32 time=2470ms TTL=63

Reply from 192.168.20.3: bytes=32 time=2ms TTL=63

Reply from 192.168.20.3: bytes=32 time=1427ms TTL=63

Reply from 192.168.20.3: bytes=32 time=2ms TTL=63

Reply from 192.168.20.3: bytes=32 time=86ms TTL=63

Reply from 192.168.20.3: bytes=32 time=142ms TTL=63

Reply from 192.168.20.3: bytes=32 time=561ms TTL=63

Reply from 192.168.20.3: bytes=32 time=84ms TTL=63

Reply from 192.168.20.3: bytes=32 time=465ms TTL=63

Reply from 192.168.20.3: bytes=32 time=114ms TTL=63

Reply from 192.168.20.3: bytes=32 time=124ms TTL=63

Reply from 192.168.20.3: bytes=32 time=446ms TTL=63

 

Ping statistics for 192.168.20.3:

    Packets: Sent = 12, Received = 12, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 2ms, Maximum = 2470ms, Average = 495ms

Control-C

^C

C:\Users\system32>

3.6  配置文件

·            AC

#                                                                              

vlan 100                                                                       

vlan 200  

#

vlan 300  

#

interface Vlan-interface100                                                    

 ip address 192.168.10.1 255.255.255.0                                         

#                                                                                 

wlan service-template 1                                                         

 ssid service                                                                  

 service-template enable                                                       

#                                                                              

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 port trunk permit vlan 100 200 300                                                

#                                                                              

ip route-static 192.168.40.0 24 192.168.10.83                                 

#                                                                               

wlan ap officeap model WA4320i-ACN                                             

 serial-id 210235A1GQB147031200                                                

 vlan 1                                                                         

 radio 1                                                                       

  radio enable                                                                 

  service-template 1 vlan 200                                                   

 radio 2                                                                       

#                                                                              

·            L3 switch

#                                                                              

 dhcp enable                                                                   

#                                                                              

vlan 100                                                                        

#                                                                              

vlan 200                                                                       

#                                                                               

vlan 300                                                                       

#                                                                              

vlan 400                                                                        

#                                                                              

dhcp server ip-pool 1                                                          

 gateway-list 192.168.40.1                                                     

 network 192.168.40.0 mask 255.255.255.0                                       

 option 43 hex 8007000001c0a80a01                                              

#                                                                               

dhcp server ip-pool 2                                                          

 gateway-list 192.168.20.1                                                     

 network 192.168.20.0 mask 255.255.255.0                                       

dns-list 192.168.20.1                                                          

#                                                                              

dhcp server ip-pool 3                                                           

 gateway-list 192.168.30.1                                                     

 network 192.168.30.0 mask 255.255.255.0                                       

dns-list 192.168.30.1                                                          

#                                                                              

interface Vlan-interface100                                                    

 ip address 192.168.10.83 255.255.255.0                                         

#                                                                              

interface Vlan-interface200                                                    

 ip address 192.168.20.1 255.255.255.0                                         

#                                                                              

interface Vlan-interface300                                                    

 ip address 192.168.30.1 255.255.255.0                                         

#                                                                               

interface Vlan-interface400                                                    

 ip address 192.168.40.1 255.255.255.0                                         

#                                                                               

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

port trunk permit vlan 100 200                                               

#                                                                              

interface GigabitEthernet1/0/2                                                 

port link-type trunk                                                           

 undo port trunk permit vlan 1                                                 

 port trunk permit vlan 400                                                

#                                                                               

interface GigabitEthernet1/0/3                                                 

 port link-type trunk

undo port trunk permit vlan 1

port trunk permit vlan 300                                                          

#                                                                              

·            L2 switch 1

#                                                                              

vlan 400                                                                       

#                                                                              

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1                                     

port trunk permit vlan 400

#                                                                              

interface GigabitEthernet1/0/2                                                 

 port link-type access                                                          

 port access vlan 400                                                       

 poe enable

#                                                                              

·            L2 switch 2

#                                                                              

vlan 300                                                                       

#                                                                              

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1                                     

port trunk permit vlan 300

#                                                                               

interface GigabitEthernet1/0/2                                                 

 port link-type access                                                          

 port access vlan 300                                                        

 poe enable

#                                                                              

4  相关资料

·            《H3C无线控制器产品 配置指导》中的“网络互通配置指导”。

·            《H3C无线控制器产品 命令参考》中的“网络互通命令参考”。

·            《H3C无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C无线控制器产品 命令参考》中的“WLAN接入命令参考”。

·            《H3C无线控制器产品 配置指导》中的“AP管理配置指导”。

·            《H3C无线控制器产品 命令参考》中的“AP管理命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!