国家 / 地区

03-典型配置案例(AC+FIT AP)

01-H3C无线控制器二层注册典型配置举例(V7)

本章节下载  (207.19 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/03/202002/1274580_30005_0.htm

01-H3C无线控制器二层注册典型配置举例(V7)

H3C 无线控制器

二层注册典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍AP与AC间通过二层网络完成注册的配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体软硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解DHCP、WLAN接入相关特性。

3  二层网络注册配置举例

3.1  组网需求

图1所示,集中式转发架构下,AC旁挂在L2 switch1上,L3 switch做DHCP server为AP、Client和Host分配IP地址。需要实现无线客户端Client通过AP连接到AC上,并能与有线客户端Host互相访问,具体要求如下:

·            无线客户端Client通过VLAN 200接入网络,有线客户端Host通过VLAN 300接入网络;

·            AC属于VLAN 100,AC和AP之间通过二层网络建立连接。

·            L2 switch 1通过PoE方式给AP供电。

图1 Fit AP通过二层网络注册到AC配置举例组网图

 

3.2  配置思路

·            在L3 switch上开启DHCP server功能,AP、无线客户端Client和有线客户端Host都能通过DHCP server自动获取IP地址。

·            在L2 switch 1上开启PoE功能,为AP设备供电。

·            在AC上配置无线服务,确保Client可以通过配置的无线服务接入网络,并访问Host。

3.3  配置注意事项

·            配置AP的序列号时请确保该序列号与AP唯一对应,AP的序列号可以通过AP设备背面的标签获取。

·            配置L2 switch 1和AP相连的接口为Access口,禁止VLAN 1报文通过,以防止VLAN 1内报文过多。

3.4  配置步骤

3.4.1  配置L3 switch

1. 配置L3 switch的接口

# 创建VLAN 100,并配置IP地址,用于转发AC和AP间的CAPWAP隧道内的流量。

<L3 switch> system-view

[L3 switch] vlan 100

[L3 switch-vlan100] quit

[L3 switch] interface vlan-interface 100

[L3 switch-Vlan-interface100] ip address 192.168.10.1 255.255.255.0 

[L3 switch-Vlan-interface100] quit

# 创建VLAN 200,并为该接口配置IP地址。Client使用该VLAN接入无线网络。

[L3 switch] vlan 200

[L3 switch-vlan200] quit

[L3 switch] interface vlan-interface 200

[L3 switch-Vlan-interface200] ip address 192.168.20.1 255.255.255.0 

[L3 switch-Vlan-interface200] quit

# 创建VLAN 300,并为该接口配置IP地址。Host使用该VLAN与AC建立连接。

[L3 switch] vlan 300

[L3 switch-vlan300] quit

[L3 switch] interface vlan-interface 300

[L3 switch-Vlan-interface300] ip address 192.168.30.1 255.255.255.0 

[L3 switch-Vlan-interface300] quit

# 配置L3 switch和L2 switch1相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN100和VLAN 200通过。

[L3 switch] interface gigabitEthernet 1/0/1

[L3 switch-GigabitEthernet1/0/1] port link-type trunk

[L3 switch-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L3 switch-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[L3 switch-GigabitEthernet1/0/1] quit

# 配置L3 switch和L2 switch2相连的接口GigabitEthernet1/0/3为Trunk类型,禁止VLAN 1报文通过,允许VLAN 300通过。

[L3 switch] interfac gigabitEthernet 1/0/3

[L3 switch-GigabitEthernet1/0/3] port link-type trunk

[L3 switch-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[L3 switch-GigabitEthernet1/0/3] port trunk permit vlan 300

[L3 switch-GigabitEthernet1/0/3] quit

2. 配置DHCP server

(1)       开启DHCP server功能。

# 开启DHCP server功能。

<L3 switch> system-view

[L3 switch] dhcp enable

(2)       配置DHCP地址池,为AP、无线客户端Client和有线客户端Host自动分配IP地址。

# 配置DHCP地址池1为AP分配地址范围为192.168.10.0/24,网关地址为192.168.10.1。

[L3 switch] dhcp server ip-pool 1

[L3 switch-dhcp-pool-1] network 192.168.10.0 mask 255.255.255.0

[L3 switch-dhcp-pool-1] gateway-list 192.168.10.1

# 配置DHCP地址池1中不参与自动分配的IP地址为AC的VLAN100的IP地址192.168.10.2。

[L3 switch-dhcp-pool-1] forbidden-ip 192.168.10.2

[L3 switch-dhcp-pool-1] quit

# 配置DHCP地址池2为Client分配地址范围为192.168.20.0/24,为Client分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为192.168.20.1。

[L3 switch] dhcp server ip-pool 2

[L3 switch-dhcp-pool-2] network 192.168.20.0 mask 255.255.255.0 

[L3 switch-dhcp-pool-2] gateway-list 192.168.20.1

[L3 switch-dhcp-pool-2] dns-list 192.168.20.1

[L3 switch-dhcp-pool-2] quit

# 配置DHCP地址池3为Host分配地址范围为192.168.30.0/24,为Host分配的DNS服务器地址为网关地址(实际使用过程中请根据实际网络规划配置无线客户端的DNS服务器地址),网关地址为192.168.30.1。

[L3 switch] dhcp server ip-pool 3

[L3 switch-dhcp-pool-3] network 192.168.30.0 mask 255.255.255.0

[L3 switch-dhcp-pool-3] gateway-list 192.168.30.1 

[L3 switch-dhcp-pool-3] dns-list 192.168.30.1

[L3 switch-dhcp-pool-3] quit

3.4.2  配置AC

(1)       配置AC的接口

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。AP将获取该IP地址与AC建立CAPWAP隧道。

[AC] vlan 100

[AC-vlan100] quit

[AC] interface vlan-interface 100

[AC-Vlan-interface100] ip address 192.168.10.2 255.255.255.0

[AC-Vlan-interface100] quit

# 创建VLAN 200,Client使用该VLAN接入无线网络。

[AC] vlan 200

[AC-vlan200] quit

# 配置AC和L2 switch 1相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200通过。

[AC] interface gigabitethernet 1/0/1

[AC-GigabitEthernet1/0/1] port link-type trunk

[AC-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[AC-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[AC-GigabitEthernet1/0/1] quit

(2)       配置无线服务

# 创建无线服务模板1,并进入无线服务模板视图。

[AC] wlan service-template 1

# 配置SSID为service。

[AC-wlan-st-1] ssid service

# 使能服务模板。

[AC-wlan-st-1] service-template enable

[AC-wlan-st-1] quit

(3)       配置AP

# 创建手工AP,名称为officeap,型号名称为WA4320i-ACN。

[AC] wlan ap officeap model WA4320i-ACN

# 设置AP的序列号为210235A1Q2C159000018。

[AC-wlan-ap-officeap] serial-id 210235A1Q2C159000018

# 进入AP的Radio 1视图,将无线服务模板1绑定到Radio 1上,并指定客户端上线的VLAN为VLAN 200。

[AC-wlan-ap-officeap] radio 1

[AC-wlan-ap-officeap-radio-1] service-template 1 vlan 200

# 开启Radio 1的射频功能。

[AC-wlan-ap-officeap-radio-1] radio enable

[AC-wlan-ap-officeap-radio-1] return

3.4.3  配置L2 switch 1

# 创建VLAN 100和VLAN 200,其中VLAN 100用于转发AC和AP间CAPWAP隧道内的流量,VLAN 200为无线客户端接入的VLAN。

<L2 switch 1> system-view

[L2 switch 1] vlan 100

[L2 switch 1-vlan100] quit

[L2 switch 1] vlan 200

[L2 switch 1-vlan200] quit

# 配置L2 switch 1和AC相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200 通过。

[L2 switch 1] interface gigabitEthernet 1/0/1

[L2 switch 1-GigabitEthernet1/0/1] port link-type trunk

[L2 switch 1-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L2 switch 1-GigabitEthernet1/0/1] port trunk permit vlan 100 200

[L2 switch 1-GigabitEthernet1/0/1] quit

# 配置L2 switch 1和AP相连的接口GigabitEthernet1/0/2为Access类型,允许VLAN 100通过,并开启PoE远程供电功能。

[L2 switch 1] interfac gigabitEthernet 1/0/2

[L2 switch 1-GigabitEthernet1/0/2] port link-type access 

[L2 switch 1-GigabitEthernet1/0/2] port access vlan 100

[L2 switch 1-GigabitEthernet1/0/2] poe enable

[L2 switch 1-GigabitEthernet1/0/2] quit

# 配置L2 switch 1与L3 switch相连的接口GigabitEthernet1/0/3为Trunk类型,禁止VLAN 1报文通过,允许VLAN 100和VLAN 200 通过。

[L2 switch 1] interface gigabitEthernet 1/0/3

[L2 switch 1-GigabitEthernet1/0/3] port link-type trunk 

[L2 switch 1-GigabitEthernet1/0/3] undo port trunk permit vlan 1

[L2 switch 1-GigabitEthernet1/0/3] port trunk permit vlan 100 200

[L2 switch 1-GigabitEthernet1/0/3] quit

3.4.4  配置L2 switch 2

# 创建VLAN 300,VLAN 300为Host接入的VLAN。

<L2 switch 2> system-view

[L2 switch 2] vlan 300

[L2 switch 2-vlan300] quit

# 配置L2 switch 2与L3 switch相连的接口GigabitEthernet1/0/1为Trunk类型,禁止VLAN 1报文通过,允许VLAN 300通过。

[L2 switch 2] interface gigabitEthernet 1/0/1

[L2 switch 2-GigabitEthernet1/0/1] port link-type trunk 

[L2 switch 2-GigabitEthernet1/0/1] undo port trunk permit vlan 1

[L2 switch 2-GigabitEthernet1/0/1] port trunk permit vlan 300

[L2 switch 2-GigabitEthernet1/0/1] quit

# 配置L2 switch 2与Host相连的接口GigabitEthernet1/0/2为Access类型,允许VLAN 300通过

[L2 switch 2] interface gigabitEthernet 1/0/2

[L2 switch 2-GigabitEthernet1/0/2] port link-type access 

[L2 switch 2-GigabitEthernet1/0/2] port access vlan 300

[L2 switch 2-GigabitEthernet1/0/2] quit

3.5  验证配置

(1)       在AC上查看AP注册信息

# 在AC上使用命令display wlan ap all查看AP,可以看到AP的状态是R/M,表明AP已经成功注册到AC。

<AC> display wlan ap all                             

Total number of APs: 1                                                         

Total number of connected APs: 1                                               

Total number of connected manual APs: 1                                        

Total number of connected auto APs: 0                                          

Total number of connected common APs: 1

Total number of connected WTUs: 0

Total number of inside APs: 0                                        

Maximum supported APs: 3072                                                    

Remaining APs: 3071                                                            

Total AP licenses: 512                                               

Remaining AP licenses: 511                                                         

                                                                               

                                 AP information                                 

 State : I = Idle,      J  = Join,       JA = JoinAck,    IL = ImageLoad       

         C = Config,    DC = DataCheck,  R  = Run,   M = Master,  B = Backup   

                                                                               

AP name                AP ID   State   Model             Serial ID             

officeap               1       R/M     WA4320i-ACN       210235A1Q2C159000018 

(2)       在AC上查看Client信息

# 在AC上使用命令display wlan client查看在线Client,可以看到Client已经连接到AP的radio1。

<AC> display wlan client                                                       

Total number of clients: 1                                                     

                                                                                

MAC address    User name            AP name               R IP address      VLAN

109a-dd9d-fc68 N/A                  officeap              1 192.168.20.4    200

(3)       Host与Client可以相互ping通

# Client 通过DHCP server获取到IP地址192.168.20.4,在Host上ping Client的IP地址可以ping通。同理,在Client上ping Host的IP地址也能ping通,不再赘述。

C:\Users\system32>ping 192.168.20.4 -t

 

Pinging 192.168.20.4 with 32 bytes of data:

Reply from 192.168.20.4: bytes=32 time=8ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

Reply from 192.168.20.4: bytes=32 time<1ms TTL=255

 

Ping statistics for 192.168.20.4:

    Packets: Sent = 11, Received = 11, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 8ms, Average = 0ms

Control-C

^C

C:\Users\system32>

3.6  配置文件

·            L3 switch

#                                                                              

 dhcp enable                                                                   

#                                                                              

vlan 1                                                                          

#                                                                                

vlan 100                                                                       

#                                                                               

vlan 200                                                                       

#                                                                              

vlan 300                                                                        

#                                                                             

dhcp server ip-pool 1                                                          

 gateway-list 192.168.10.1                                                      

 network 192.168.10.0 mask 255.255.255.0                                       

 static-bind ip-address 192.168.10.2 mask 255.255.255.0 hardware-address 000f-e212-3510

#                                                                               

dhcp server ip-pool 2                                                          

 gateway-list 192.168.20.1                                                     

 network 192.168.20.0 mask 255.255.255.0                                        

 dns-list 192.168.20.1                                                         

#                                                                              

dhcp server ip-pool 3                                                          

 gateway-list 192.168.30.1                                                     

 network 192.168.30.0 mask 255.255.255.0                                       

 dns-list 192.168.30.1                                                         

#                                                                                

interface Vlan-interface100                                                    

 ip address 192.168.10.1 255.255.255.0                                         

#                                                                               

interface Vlan-interface200                                                    

 ip address 192.168.20.1 255.255.255.0                                         

#                                                                               

interface Vlan-interface300                                                    

 ip address 192.168.30.1 255.255.255.0                                         

#                                                                                

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1

port trunk permit vlan 100 200                                               

#                                                                              

interface GigabitEthernet1/0/3                                                 

port link-type trunk                                                           

undo port trunk permit vlan 1

 port trunk permit vlan 300                                                  

#                                                                              

·            AC

#                                                                              

wlan service-template 1                                                        

 ssid service                                                                 

 service-template enable                                                       

#                                                                              

interface Vlan-interface1                                                      

#                                                                               

interface Vlan-interface100                                                    

 ip address 192.168.10.1 255.255.255.0                                        

#                                                                               

interface Vlan-interface200                                                    

 ip address 192.168.20.1 255.255.255.0                                        

#                                                                               

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1

port trunk permit vlan 100 200

port trunk pvid vlan 100                                           

#                                                                              

wlan ap officeap model WA4320i-ACN                                           

 serial-id 210235A1Q2C159000018                                                

vlan 1

 radio 1                                                                       

  radio enable                                                                 

  service-template 1 vlan 200                                                  

 radio 2  

#                                                                              

·            L2 switch 1

#                                                                              

vlan 100                                                                       

#                                                                              

vlan 200                                                                       

#                                                                               

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1                                     

port trunk permit vlan 100 200

#                                                                              

interface GigabitEthernet1/0/2                                                 

 port link-type access                                                          

 port access vlan 100                                                        

 poe enable

#                                                                              

interface GigabitEthernet1/0/3                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1                                     

port trunk permit vlan 100 200

#

·            L2 switch 2

#                                                                               

vlan 300                                                                       

#                                                                              

interface GigabitEthernet1/0/1                                                 

 port link-type trunk                                                          

 undo port trunk permit vlan 1                                     

port trunk permit vlan 300

#                                                                              

interface GigabitEthernet1/0/2                                                 

 port link-type access                                                          

 port access vlan 300                                                       

 poe enable

#                                                                              

4  相关资料

·            《H3C无线控制器产品 配置指导》中的“网络互通配置指导”。

·            《H3C无线控制器产品 命令参考》中的“网络互通命令参考”。

·            《H3C无线控制器产品 配置指导》中的“WLAN接入配置指导”。

·            《H3C无线控制器产品 命令参考》中的“WLAN接入命令参考”。

·            《H3C无线控制器产品 配置指导》中的“AP管理配置指导”。

·            《H3C无线控制器产品 命令参考》中的“AP管理命令参考”。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!