国家 / 地区

04-典型配置案例(FAT AP)

08-H3C无线接入点IPv6本地802.1X认证典型配置举例(V7)

本章节下载  (372.45 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/04/201911/1246518_30005_0.htm

08-H3C无线接入点IPv6本地802.1X认证典型配置举例(V7)

H3C 无线接入点

IPv6本地802.1X认证典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2017-2019新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍本地802.1X认证的典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线控制器和接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WLAN接入、WLAN用户接入认证和802.1X的相关特性。

3  配置举例

3.1  组网需求

图1所示组网,Switch作为DHCP server为AP和Client分配IP地址,要求:

·            对无线用户进行802.1X认证。

·            客户端链路层认证使用开放式系统认证。

图1 本地802.1X认证组网图

 

3.2  配置注意事项

·            本地802.1X认证不支持数据加密功能。

·            本地802.1X认证不支持EAP中继认证方式。

3.3  配置步骤

说明

在配置本实验时,请保证网络环境互通。

 

3.3.1  配置FAT AP

(1)       配置接口

# 创建VLAN 100以及对应的VLAN接口,并为该接口配置IP地址。将获取该IP地址与RADIUS服务器建立连接。

<AP> system-view

[AP] vlan 100

[AP-vlan100] quit

[AP] interface vlan-interface 100

[AP-Vlan-interface100] ipv6 address dhcp-alloc

[AP-Vlan-interface100] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。Client将使用该VLAN接入无线网络。

[AP] vlan 200

[AP-vlan200] quit

[AP] interface vlan-interface 200

(2)       配置802.1X认证方式及RADIUS方案

# 配置802.1X认证方式为EAP。

<AP> system-view

[AP] dot1x authentication-method eap

# 配置RADIUS方案,名称为imcc,主认证服务器的IP地址为2003::2,端口号为1812,配置主计费服务器的IP地址为2003::2,端口号为1813,认证密钥为明文12345678,计费密钥为明文12345678,用户名格式为without-domain。

[AP] radius scheme imcc

[AP-radius-imcc] primary authentication ipv6 2003::2 1812

[AP-radius-imcc] primary accounting ipv6 2003::2 1813

[AP-radius-imcc] key authentication simple 12345678

[AP-radius-imcc] key accounting simple 12345678

[AP-radius-imcc] user-name-format without-domain

[AP-radius-imcc] quit

(3)       配置ISP域的AAA方法

# 配置名称为imc的ISP域,并将认证、授权和计费的方式配置为使用RADIUS方案imcc。

[AP] domain imc

[AP-isp-imc] authentication lan-access radius-scheme imcc

[AP-isp-imc] authorization lan-access radius-scheme imcc

[AP-isp-imc] accounting lan-access radius-scheme imcc

[AP-isp-imc] quit

(4)       配置无线服务模板

# 配置无线服务模板名称为service,用户认证方式为802.1X,ISP域为imc,SSID为service,AKM模式为802.1X,加密套件为CCMP,安全IE为RSN。

[AP] wlan service-template service

[AP-wlan-st-service] client-security authentication-mode dot1x

[AP-wlan-st-service] dot1x domain imc

[AP-wlan-st-service] ssid service

[AP-wlan-st-service] vlan 200

[AP-wlan-st-service] akm mode dot1x

[AP-wlan-st-service] cipher-suite ccmp

[AP-wlan-st-service] security-ie rsn

# 使能无线服务模板。

[AP-wlan-st-service] service-template enable

[AP-wlan-st-service] quit

(5)       将无线服务模板绑定到WLAN-Radio 1/0/1接口上

[AP] interface wlan-radio 1/0/1

[AP-WLAN-Radio1/0/1] undo shutdown

[AP-WLAN-Radio1/0/1] service-template service

[AP-WLAN-Radio1/0/1] quit

3.3.2  配置Switch

(1)       配置Switch接口

# 创建VLAN 100,并为该接口配置IP地址,用于和FAT AP进行通信。

<Switch> system-view

[Switch] vlan 100

[Switch-vlan100] quit

[Switch] interface vlan-interface 100

[Switch-Vlan-interface100] ipv6 dhcp select server

[Switch-Vlan-interface100] ipv6 dhcp server apply pool 100

[Switch-Vlan-interface100] ipv6 address 2010::1/64

[Switch-Vlan-interface100] quit

# 创建VLAN 200作为Client接入的业务VLAN,并配置VLAN 200的接口IP地址,用于和无线Client进行通信。

[Switch] vlan 200

[Switch-vlan200] quit

[Switch] interface vlan-interface 200

[Switch-Vlan-interface100] ipv6 dhcp select server

[Switch-Vlan-interface100] ipv6 dhcp server apply pool 200

[Switch-Vlan-interface100] ipv6 address 2::1:0:0:1/96

[Switch-Vlan-interface200] quit

# 配置Switch与FAT AP连接的物理接口类型为Trunk,允许所有VLAN 通过。

[Switch] interface GigabitEthernet 1/0/1

[Switch-GigabitEthernet1/0/1] port link-type trunk

[Switch-GigabitEthernet1/0/1] port trunk permit vlan all

[Switch-GigabitEthernet1/0/1] port trunk pvid vlan 100

[Switch-GigabitEthernet1/0/1] quit

(2)       配置DHCP服务器

# 开启DHCP功能

[Switch] dhcp enable

# 创建名为vlan100的DHCP地址池,配置地址池动态分配的网段为2010::/64,网关地址为2010::1,为AP分配IP地址。

[Switch] ipv6 dhcp pool 100

[Switch-dhcp6-pool-100] network 2010::/64

[Switch-dhcp6-pool-100] gateway-list 2010::1

[Switch-dhcp6-pool-100] quit

# 创建名为vlan200的DHCP地址池,配置地址池动态分配的网段为2::1:0:0:0/96,网关地址为2::1:0:0:1,为client分配IP地址。

[Switch] ipv6 dhcp pool 200

[Switch-dhcp-pool-vlan100] network 2::1:0:0:0/96

[Switch-dhcp-pool-vlan100] gateway-list 2::1:0:0:1

[Switch-dhcp-pool-vlan100] quit

3.3.3  配置RADIUS server

说明

·         下面以iMC为例(使用iMC版本为:iMC PLAT 7.3 (E0605)、UAM 7.3 (E0512),说明RADIUS server的基本配置。

·         在服务器上已经完成证书的安装。

# 增加接入设备。

登录进入iMC管理平台,选择“用户”页签,单击导航树中的[接入策略管理/接入设备管理/接入设备配置]菜单项,进入接入设备配置页面,在该页面中单击“增加”按钮,进入增加接入设备页面。

¡  设置认证、计费共享密钥为12345678,其它保持缺省配置;

¡  选择增加IPv6设备,添加IP地址为2010::2的接入设备。

图2 增加接入设备页面

 

# 增加服务策略。

选择“用户”页签,单击导航树中的[接入策略管理/接入策略管理]菜单项,进入接入策略管理页面,在该页面中单击“增加”按钮,进入增加接入策略页面。

¡  设置接入策略名为dot1x;

¡  选择认证证书类型为EAP-PEAP认证,认证证书子类型为MS-CHAPV2认证。认证证书子类型需要与客户端的身份验证方法一致。

图3 增加服务策略页面

 

# 增加接入服务。

选择“用户”页签,单击导航栏中的[接入策略管理/接入服务管理]菜单项,进入接入服务管理页面,在该页面中单击<增加>按钮,进入增加接入服务页面。

¡  设置服务名为dot1x;

¡  设置缺省接入策略为已经创建的dot1x策略。

图4 增加接入服务页面

 

# 增加接入用户。

选择“用户”页签,单击导航树中的[接入用户管理/接入用户]菜单项,进入接入用户页面,在该页面中单击<增加>按钮,进入增加接入用户页面。

¡  添加用户user;

¡  添加帐号名为user,密码为dot1x;

¡  选中刚才配置的服务dot1x。

图5 增加接入用户页面

3.4  验证配置

# 当无线用户通过802.1X认证成功并上线之后,FAT AP上可以通过display dot1x connection命令看到上线用户的连接情况。

[AP] display dot1x connection

Total connections: 1                                                           

User MAC address                   : 68ef-4338-9513                            

AP name                            : fatap                                     

Radio ID                           : 1                                         

SSID                               : service                                   

BSSID                              : d461-fe59-4d22                            

Username                           : user                                      

Authentication domain              : imc                                       

Authentication method              : EAP                                       

Initial VLAN                       : 200                                       

Authorization VLAN                 : 200                                       

Authorization ACL number           : N/A                                       

Authorization user profile         : N/A                                       

Authorization CAR                  : N/A                                       

Termination action                 : Radius-Request                            

Session timeout period             : 86400 s                                   

Online from                        : 2018/09/16 00:16:21                       

Online duration                    : 0h 0m 26s

3.5  配置文件

·            AC:

#

vlan 100

#

vlan 200

#

wlan service-template service

 ssid service

 vlan 200

 client-security authentication-mode dot1x

 dot1x domain bbb

 service-template enable

#

interface Vlan-interface100

 ip address 2.2.2.1 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.1.1 255.255.255.0

#

domain bbb

 authentication lan-access local

 authorization lan-access local

 accounting lan-access local

#

local-user localuser class network

 password cipher $c$3$+5Yra0KsaLci/RxEa4lyYKxxiw6jwMCcOg==

 service-type lan-access

#

wlan ap office model WA4320i-ACN

 serial-id 210235A1GQC158004457

 radio 1

  radio enable

  service-template service

#

·            Switch:

#

vlan 100

#

vlan 200

#

dhcp server ip-pool 100

 network 2.2.2.0 mask 255.255.255.0

 gateway-list 2.2.2.1

#

dhcp server ip-pool 200

 network 2.2.1.0 mask 255.255.255.0

 gateway-list 2.2.1.1

#

interface Vlan-interface100

 ip address 2.2.2.100 255.255.255.0

#

interface Vlan-interface200

 ip address 2.2.1.2 255.255.255.0

#

interface GigabitEthernet1/0/1

 port link-type trunk

 port trunk permit vlan 1 100 200

#

interface GigabitEthernet1/0/2

 port link-type access

 port access permit vlan 100

 poe enable

#

4  相关资料

·            《H3C 无线接入点 配置指导》中的“安全配置指导”。

·            《H3C 无线接入点 命令参考》中的“安全命令参考”。

·            《H3C 无线接入点 配置指导》中的“WLAN配置指导”

·            《H3C 无线接入点 命令参考》中的“WLAN命令参考”

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部