国家 / 地区

04-典型配置案例(FAT AP)

05-H3C无线接入点Mesh桥接典型配置举例(V7)

本章节下载  (182.70 KB)

docurl=/cn/Service/Document_Software/Document_Center/Home/Wlan/00-Public/Trending/Wlan_OneNote/H3C_V7_OneNote/04/201911/1246515_30005_0.htm

05-H3C无线接入点Mesh桥接典型配置举例(V7)

H3C 无线接入点

Mesh桥接典型配置举例(V7)

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2017-2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



1  简介

本文档介绍了Mesh桥接典型配置举例。

2  配置前提

本文档适用于使用Comware V7软件版本的无线接入点产品,不严格与具体硬件版本对应,如果使用过程中与产品实际情况有差异,请参考相关产品手册,或以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解WLAN Mesh特性。

3  配置举例

3.1  FAT和FAT桥接典型配置举例

3.1.1  组网需求

图1所示,由FAT AP作为无线网桥连接两个局域网,实现两个局域网之间的互通。

具体要求如下:

·            AP 1和AP 2分别连接不同的局域网。

·            手工指定固定信道149,通过802.11n(5GHz)射频模式使AP 1和AP 2之间形成WDS链路。

图1 FAT和FAT桥接配置组网图

 

3.1.2  配置步骤

1. 配置AP1

(1)       配置AP1的接口

# 配置Vlan-interface 1接口的IP地址为192.168.0.1。

<AP1> system-view

[AP1] interface vlan-interface 1

[AP1-Vlan-interface1] ip address 192.168.0.1 24

[AP1-Vlan-interface1] quit

# 创建VLAN 100及其对应的VLAN接口,并为该接口配置IP地址。LAN1内的主机将使用该VLAN接口与LAN2内的主机互通。

[AP1] vlan 100

[AP1-vlan100] quit

[AP1] interface vlan-interface 100

[AP1-Vlan-interface100] ip address 192.168.1.1 24

[AP1-Vlan-interface100] quit

# 将端口GE1/0/1加入VLAN 100。

[AP1] vlan 100

[AP1-vlan100] port GigabitEthernet 1/0/1

[AP1-vlan100] quit

(2)       配置Mesh Profile

# 创建一个编号为1的Mesh Profile。

[AP1] wlan mesh-profile 1

# 配置Mesh ID为1。

[AP1-wlan-mesh-profile-1] mesh-id 1

# 配置认证模式为SAE。

[AP1-wlan-mesh-profile-1] akm mode sae

# 配置预共享密钥为12345678。

[AP1-wlan-mesh-profile-1] preshared-key pass-phrase simple 12345678

# 开启Mesh Profile。

[AP1-wlan-mesh-profile-1] mesh-profile enable

[AP1-wlan-mesh-profile-1] quit

(3)       配置射频接口

# 将Mesh Profile 1绑定到AP 1的WLAN-Radio 1/0/1接口。

[AP1] interface wlan-radio 1/0/1

[AP1-WLAN-Radio1/0/1] mesh-profile 1

# 配置射频类型为802.11n(5GHz)。

[AP1-WLAN-Radio1/0/1] type dot11an

# 配置射频工作信道为149。

[AP1-WLAN-Radio1/0/1] channel 149

# 向AP1的邻居白名单中添加AP2的MAC地址,使AP1仅与AP2建立Mesh连接,以避免环路的产生。

[AP1-WLAN-Radio1/0/1] mesh peer-mac-address d461-fe59-4d20

# 开启射频功能。

[AP1-WLAN-Radio1/0/1] undo shutdown

[AP1-WLAN-Radio1/0/1] quit

(4)       配置静态路由

# 配置静态路由。

[AP1] ip route-static 192.168.2.0 255.255.255.0 192.168.0.2

2. 配置AP2

(1)       配置AP2的接口

# 配置Vlan-interface 1接口的IP地址为192.168.0.2。

<AP2> system-view

[AP2] interface vlan-interface 1

[AP2-Vlan-interface1] ip address 192.168.0.2 24

[AP2-Vlan-interface1] quit

# 创建VLAN 200及其对应的VLAN接口,并为该接口配置IP地址。LAN2内的主机将使用该VLAN接口与LAN1内的主机互通。

[AP2] vlan 200

[AP2-vlan200] quit

[AP2] interface vlan-interface 200

[AP2-Vlan-interface200] ip address 192.168.2.1 24

[AP2-Vlan-interface200] quit

# 将端口GE1/0/1加入VLAN 200。

[AP2] vlan 200

[AP2-vlan200] port GigabitEthernet 1/0/1

[AP2-vlan200] quit

(2)       配置Mesh Profile

# 创建一个编号为1的Mesh Profile。

[AP2] wlan mesh-profile 1

# 配置Mesh ID为1。

[AP2-wlan-mesh-profile-1] mesh-id 1

# 配置认证模式为SAE。

[AP2-wlan-mesh-profile-1] akm mode sae

# 配置预共享密钥为12345678。

[AP2-wlan-mesh-profile-1] preshared-key pass-phrase simple 12345678

# 开启Mesh Profile。

[AP2-wlan-mesh-profile-1] mesh-profile enable

[AP2-wlan-mesh-profile-1] quit

(3)       配置射频接口

# 将Mesh Profile 1绑定到AP 2的WLAN-Radio 1/0/1接口。

[AP2] interface wlan-radio 1/0/1

[AP2-WLAN-Radio1/0/1] mesh-profile 1

# 配置射频类型为802.11n(5GHz)。

[AP2-WLAN-Radio1/0/1] type dot11an

# 配置射频工作信道为149。

[AP2-WLAN-Radio1/0/1] channel 149

# 向AP2的邻居白名单中添加AP1的MAC地址,使AP2仅与AP1建立Mesh连接,以避免环路的产生。

[AP2-WLAN-Radio1/0/1] mesh peer-mac-address 84d9-316b-93a0

# 开启射频功能。

[AP2-WLAN-Radio1/0/1] undo shutdown

[AP2-WLAN-Radio1/0/1] quit

(4)       配置静态路由

# 配置静态路由。

[AP2] ip route-static 192.168.1.0 255.255.255.0 192.168.0.1

3.1.3  验证配置

# 在AP 1上通过display wlan mesh-link命令可以查看到Mesh链路信息。

<AP1> display wlan mesh-link

Peer MAC       RSSI BSSID          Interface         Link state Online time   

d461-fe59-4d20 87   84d9-316b-93a0 WLAN-MeshLink51   Active     00h 00m 12s

# 在AP 2上通过display wlan mesh-link命令可以查看到Mesh链路信息。

<AP2> display wlan mesh-link

Peer MAC       RSSI BSSID          Interface         Link state Online time   

84d9-316b-93a0 84   d461-fe59-4d20 WLAN-MeshLink259  Active     00h 06m 31s

# LAN1内的主机与LAN2内的主机可以互相ping通。

3.1.4  配置文件

·            AP 1

#                                                                              

 sysname AP1                                                                     

#                                                                              

 telnet server enable                                                          

#                                                                              

 wlan mesh-profile 1                                                            

 mesh-id 1                                                                     

 akm mode sae                                                                  

 preshared-key pass-phrase cipher $c$3$vn2DU2ACd3o9CbivCPPh9issxj6Rmja5gMQA    

 mesh-profile enable                                                           

#                                                                              

vlan 1                                                                         

#                                                                              

vlan 100                                                                          

#                                                                              

interface Vlan-interface1                                                      

 ip address 192.168.0.1 255.255.255.0                                      

#                                                                              

interface Vlan-interface100                                                    

 ip address 192.168.1.1 255.255.255.0

#                                                                               

interface GigabitEthernet1/0/1                                                 

port access vlan 100

#                                                                               

interface GigabitEthernet1/0/2                                                 

#                                                                              

interface WLAN-Radio1/0/1                                                      

 mesh-profile 1                                                                

 mesh peer-mac-address d461-fe59-4d20                                          

 type dot11a                                                                   

 channel 149                                                                    

#                                                                              

interface WLAN-Radio1/0/2                                                      

 service-template 1                                                             

#                                                                              

interface WLAN-Radio1/0/3                                                      

 service-template 1                                                             

#                                                                              

 ip route-static 192.168.2.0 24 192.168.0.2

#                                                                              

return            

·            AP 2

#                                                                              

 sysname AP2                                                                     

#                                                                               

 telnet server enable                                                          

#                                                                              

 wlan mesh-profile 1                                                            

 mesh-id 1                                                                     

 akm mode sae                                                                  

 preshared-key pass-phrase cipher $c$3$vn2DU2ACd3o9CbivCPPh9issxj6Rmja5gMQA    

 mesh-profile enable                                                           

#                                                                              

vlan 1                                                                         

#                                                                               

vlan 200                                                                         

#                                                                              

interface Vlan-interface1                                                       

 ip address 192.168.0.2 255.255.255.0                                      

#                                                                              

interface Vlan-interface200                                                    

 ip address 192.168.2.1 255.255.255.0

#                                                                              

interface GigabitEthernet1/0/1                                                 

port access vlan 200

#                                                                              

interface GigabitEthernet1/0/2                                                 

#                                                                               

interface WLAN-Radio1/0/1                                                      

 mesh-profile 1                                                                

 mesh peer-mac-address 84d9-316b-93a0                                          

 type dot11a                                                                   

 channel 149                                                                   

#                                                                              

interface WLAN-Radio1/0/2                                                      

 service-template 1                                                            

#                                                                              

interface WLAN-Radio1/0/3                                                       

 service-template 1                                                            

#                                                                              

 ip route-static 192.168.1.0 24 192.168.0.1

#                                                                              

return            

3.2  FAT和FIT桥接典型配置举例

3.2.1  组网需求

图2所示,MPP通过交换机与AC连接,实现客户端能够通过MAP接入网络并访问Server服务器。

具体要求如下:

·            Server服务器连接交换机。

·            MPP和MAP之间使用射频工作模式为802.11n(5GHz),工作信道号为149来建立Mesh链路。

图2 FIT和FAT桥接配置组网图

 

3.2.2  配置步骤

1. 配置AC

(1)       配置DHCP server

# 开启DHCP server功能。

<AC> system-view

[AC] dhcp enable

# 配置DHCP地址池1为FIT AP和服务器分配地址范围为192.168.0.0/24,网关地址为192.168.0.1。

[AC] dhcp server ip-pool 1

[AC-dhcp-pool-1] network 192.168.0.0 mask 255.255.255.0

[AC-dhcp-pool-1] gateway-list 192.168.0.1

[AC-dhcp-pool-1] quit

(2)       配置AC的接口

# 配置VLAN1的IP地址为192.168.0.1,FIT AP将获取该IP地址与AC建立CAPWAP隧道。

[AC] interface vlan-interface 1

[AC-Vlan-interface1] ip address 192.168.0.1 255.255.255.0

[AC-Vlan-interface1] quit

(3)       配置Mesh Profile

# 创建一个编号为1的Mesh Profile。

<AC> system-view

[AC] wlan mesh-profile 1

# 配置Mesh ID为1。

[AC-wlan-mesh-profile-1] mesh-id 1

# 配置认证模式为SAE。

[AC-wlan-mesh-profile-1] akm mode sae

# 配置预共享密钥为12345678。

[AC-wlan-mesh-profile-1] preshared-key pass-phrase simple 12345678

# 开启Mesh Profile。

[AC-wlan-mesh-profile-1] mesh-profile enable

[AC-wlan-mesh-profile-1] quit

(4)       配置MPP

# 创建AP的模板,名称为mpp,型号名称选择WA4320,并配置AP的序列号为219801A0UEB147031200。

[AC] wlan ap mpp model WA4320

[AC-wlan-ap-mpp] serial-id 219801A0UEB147031200

# 将Mesh Profile 1绑定到mpp的Radio 1口。

[AC-wlan-ap-mpp] radio 1

[AC-wlan-ap-mpp-radio-1] mesh-profile 1

# 配置射频类型为802.11n(5GHz)。

[AC-wlan-ap-mpp-radio-1] type dot11an

# 配置射频工作信道为149。

[AC-wlan-ap-mpp-radio-1] channel 149

# 开启Radio。

[AC-wlan-ap-mpp-radio-1] radio enable

[AC-wlan-ap-mpp-radio-1] quit

# 配置MPP停止发送邻居探测请求。

[AC-wlan-ap-mpp] portal-service enable

[AC-wlan-ap-mpp] quit

(5)       配置静态路由

# 配置静态路由。

[AC]ip route-static 192.168.1.0 255.255.255.0 192.168.0.2

2. 配置FAT AP

(1)       配置Mesh Profile。

# 创建一个编号为1的Mesh Profile。

<MAP> system-view

[MAP] wlan mesh-profile 1

# 配置Mesh ID为1。

[MAP1-wlan-mesh-profile-1] mesh-id 1

# 配置认证模式为SAE。

[MAP-wlan-mesh-profile-1] akm mode sae

# 配置预共享密钥为12345678。

[MAP-wlan-mesh-profile-1] preshared-key pass-phrase simple 12345678

# 开启Mesh Profile。

[MAP-wlan-mesh-profile-1] mesh-profile enable

[MAP-wlan-mesh-profile-1] quit

(2)       配置无线服务模板service1。

# 配置无线无线服务模板service1,配置SSID为mesh-network,并使能服务模板。

[MAP] wlan service-template service1

[MAP-wlan-st-service1] ssid mesh-network

[MAP-wlan-st-service1] service-template enable

[MAP-wlan-st-service1] quit

(3)       配置射频接口

# 将Mesh Profile 1绑定到MAP的WLAN-Radio 1/0/1接口。

[MAP] interface wlan-radio 1/0/1

[MAP-WLAN-Radio1/0/1] mesh-profile 1

# 将无线服务模板service1绑定到MAP的WLAN-Radio 1/0/1接口。

[MAP-WLAN-Radio1/0/1] service-template service1

# 配置Radio接口射频类型为802.11n(5GHz)。

[MAP-WLAN-Radio1/0/1] type dot11an

# 配置射频工作信道号为149。

[MAP-WLAN-Radio1/0/1] channel 149

# 向MAP的邻居白名单中添加MPP的MAC地址,使MAP仅与MPP建立Mesh连接,以避免环路的产生。

[MAP-WLAN-Radio1/0/1] mesh peer-mac-address ac74-090a-6420

# 开启射频功能。

[MAP-WLAN-Radio1/0/1] undo shutdown

[MAP-WLAN-Radio1/0/1] quit

[MAP] quit

(4)       配置DHCP服务。

# 开启DHCP功能。

[MAP] dhcp enable

# 创建名为vlan100的DHCP地址池,为Client分配IP地址,配置地址池动态分配的网段为192.168.1.0/24,网关地址为192.168.1.1。

[MAP] dhcp server ip-pool vlan100

[MAP-dhcp-pool-vlan100] network 192.168.1.0 mask 255.255.255.0

[MAP-dhcp-pool-vlan100] gateway-list 192.168.1.1

[MAP-dhcp-pool-vlan100] quit

3.2.3  验证配置

# 完成以上配置后,在AC上可以通过display wlan mesh-link ap命令查看到MPP和MAP的Mesh链路已经成功建立。

<AC>display wlan mesh-link ap                                                 

AP name: mpp                                                                  

 Peer           Local          Status     RSSI Packets(Rx/Tx)                  

 d461-fe59-4d20 ac74-090a-6420 Forwarding 84   75/206

# 在MAP上通过display wlan mesh-link命令查看到MAP和MPP的Mesh链路已经成功建立。

<MAP> display wlan mesh-link

Peer MAC       RSSI BSSID          Interface         Link state Online time   

 ac74-090a-6420 82   d461-fe59-4d20 WLAN-MeshLink231  Active     00h 46m 53s

# Client与Server可以互相ping通。

3.2.4  配置文件

·            MAP

#                                                                               

 sysname MAP                                                                   

#                                                                              

 telnet server enable                                                           

#                                                                              

 dhcp enable                                                                   

#                                                                              

wlan mesh-profile 1                                                            

 mesh-id 1                                                                     

 akm mode sae                                                                  

 preshared-key pass-phrase cipher $c$3$MA+IbbyMk2HFZPOGPZtCOu/7tC0zlT4/9HuX    

 mesh-profile enable                                                           

#                                                                              

vlan 1                                                                          

#                                                                              

vlan 100                                                                       

#                                                                               

dhcp server ip-pool vlan100                                                    

 gateway-list 192.168.1.1                                                      

 network 192.168.1.0 mask 255.255.255.0                                         

#                                                                              

wlan service-template service1                                                 

 ssid mesh-network                                                             

 vlan 100                                                                      

 service-template enable                                                       

#                                                                               

interface NULL0                                                                

#                                                                              

interface Vlan-interface1                                                       

 ip address 192.168.0.2 255.255.255.0                                         

#                                                                              

interface Vlan-interface100                                                     

 ip address 192.168.1.1 255.255.255.0                                          

#                                                                              

interface GigabitEthernet1/0/1                                                  

#                                                                              

interface GigabitEthernet1/0/2                                                 

#                                                                               

interface WLAN-Radio1/0/1                                                      

 service-template service1                                                     

 mesh-profile 1                                                                 

 mesh peer-mac-address ac74-090a-6420                                          

 type dot11an                                                                  

 channel 149                                                                   

#                                                                               

return

·            AC

#                                                                              

 sysname AC                                                               

#                                                                              

 telnet server enable                                                          

#                                                                              

 dhcp enable                                                                    

#                                                                              

wlan mesh-profile 1                                                            

 mesh-id 1                                                                      

 akm mode sae                                                                  

 preshared-key pass-phrase cipher $c$3$L7PLM5cfBX+LuA9AXhbmYQgz0yU1pcc0y26/    

 mesh-profile enable                                                            

#                                                                              

vlan 1                                                                         

#                                                                               

dhcp server ip-pool 1                                                         

 gateway-list 192.168.0.1                                                    

 network 192.168.0.0 mask 255.255.255.0                                         

#                                                                              

interface Vlan-interface1                                                      

 ip address 192.168.0.1 255.255.255.0                                        

#                                                                               

 ip route-static 192.168.1.0 24 192.168.0.2                                   

#                                                                              

wlan ap mpp model UAP300                                                      

 serial-id 219801A15K8171E00166                                                

 radio 1                                                                       

  type dot11an                                                                  

  channel 149                                                                  

  radio enable                                                                 

  mesh-profile 1                                                                

  mesh peer-mac-address d461-fe59-4d20                                         

#                                                                              

return

4  相关资料

·            《H3C 无线接入点 命令参考》中的“WLAN Mesh命令参考”。

·            《H3C 无线接入点 配置指导》中的“WLAN Mesh配置指导”。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部