国家 / 地区

03-二层技术-以太网交换命令参考

09-VLAN命令

本章节下载  (205.52 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S12500/S12500X-AF/Command/Command_Manual/H3C_S12500X-AF_CR(R26xx)-6W102/03/201907/1216846_30005_0.htm

09-VLAN命令


1 VLAN

1.1  VLAN配置命令

1.1.1  bandwidth

bandwidth命令用来配置VLAN接口的期望带宽。

undo bandwidth命令用来恢复缺省情况。

【命令】

bandwidth bandwidth-value

undo bandwidth

【缺省情况】

接口的期望带宽=接口的波特率÷1000(kbps)。

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【参数】

bandwidth-value:表示接口的期望带宽,取值范围为1~400000000,单位为kbps。

【使用指导】

期望带宽供业务模块使用,不会对接口实际带宽造成影响。

【举例】

# 配置VLAN接口1的期望带宽为10000kbps。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] bandwidth 10000

1.1.2  default

default命令用来恢复VLAN接口的缺省配置。

【命令】

default

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【使用指导】

注意

接口下的某些配置取消后,会对现有功能产生影响,建议您在执行该命令前,完全了解其对网络产生的影响。

 

您可以在执行default命令后通过display this命令确认执行效果。对于未能成功恢复缺省的配置,建议您查阅相关功能的命令手册,手工执行恢复该配置缺省情况的命令。如果操作仍然不能成功,您可以通过设备的提示信息定位原因。

【举例】

# 将VLAN接口1恢复为缺省配置。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] default

1.1.3  description

description命令用来配置VLAN或VLAN接口的描述信息。

undo description命令用来恢复缺省情况。

【命令】

description text

undo description

【缺省情况】

VLAN的描述信息为“VLAN vlan-id”,其中vlan-id为该VLAN的四位数编号,如果该VLAN的编号不足四位,则会在编号前增加0,补齐四位。例如,VLAN 100的描述信息为“VLAN 0100”;VLAN接口的描述信息为该VLAN接口的接口名,如“Vlan-interface1 Interface”。

【视图】

VLAN视图

VLAN接口视图

【缺省用户角色】

network-admin

【参数】

text:VLAN或VLAN接口的描述信息,为1~255个字符的字符串,区分大小写。

【使用指导】

用户可以根据功能或者连接情况为VLAN或VLAN接口配置特定的描述信息,以便记忆和管理VLAN或VLAN接口。

【举例】

# 将VLAN 2的描述信息配置为sales-private。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] description sales-private

# 将VLAN接口2的描述信息配置为linktoPC56。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description linktoPC56

【相关命令】

·              display interface vlan-interface

·              display vlan

1.1.4  display interface vlan-interface

display interface vlan-interface命令用来显示VLAN接口的相关信息。

【命令】

display interface vlan-interface [ interface-number ] [ brief [ description | down ] ]

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【参数】

vlan-interface interface-number:VLAN接口的编号,显示指定VLAN接口的信息。不指定interface-number时,将显示已创建的所有VLAN接口的信息。

brief:显示接口的概要信息。不指定该参数时,将显示接口的详细信息。

description:用来显示用户配置的接口的全部描述信息。如果不指定该description参数,只显示描述信息中的前27个字符。

down:显示当前物理状态为down的接口的信息以及down的原因。不指定该参数时,将不会根据接口物理状态来过滤显示信息。

【举例】

# 显示VLAN-interface 10的相关信息。

<Sysname> display interface vlan-interface 10

Vlan-interface10

Current state: UP

Line protocol state: UP

Description: Vlan-interface10 Interface

Bandwidth: 100000 kbps

Maximum transmission unit: 1500

Internet Address is 192.168.1.54/24 Primary

IP packet frame type: Ethernet II, hardware address: 0023-89b6-d613

IPv6 packet frame type: Ethernet II, hardware address: 0023-89b6-d613

Last clearing of counters: Never

# 显示VLAN-interface 2的概要信息。

<Sysname> display interface vlan-interface 2 brief

Brief information on interfaces in route mode:

Link: ADM - administratively down; Stby - standby

Protocol: (s) - spoofing

Interface            Link Protocol Primary IP         Description

Vlan2                DOWN DOWN     --

表1-1 display interface vlan-interface命令显示信息描述表

字段

描述

Vlan-interface2

VLAN接口名

Current state

VLAN接口的物理状态,状态可能为:

·       Administratively DOWN:表示该VLAN接口已经通过shutdown命令被关闭,即管理状态为关闭

·       DOWN:表示该VLAN接口的管理状态为开启,但物理状态为关闭,即该接口对应的VLAN内没有处于UP状态的物理端口(可能因为没有物理连线或者线路故障)

·       UP:该端口的管理状态和物理状态均为开启

Line protocol state

VLAN接口的链路层协议状态,状态可能为:

·       DOWN:该VLAN接口的协议状态为关闭

·       UP:该VLAN接口的协议状态为开启

Description

VLAN接口的描述信息

Bandwidth

VLAN接口的期望带宽

Maximum transmission unit

VLAN接口允许通过的MTU

Internet protocol processing : Disabled

该接口还不具有处理IP报文的能力,当没有为该接口配置IP地址时会显示该信息

Internet Address

该接口的主IP地址

IP packet frame type

IPv4发送帧格式

hardware address

VLAN接口对应的MAC地址

IPv6 packet frame type

IPv6发送帧格式

Last clearing of counters

最近一次使用reset counters interface vlan-interface命令清除接口下的统计信息的时间。如果从设备启动一直没有执行reset counters interface vlan-interface命令清除过该接口下的统计信息,则显示Never

Brief information on interfaces in route mode

三层模式下(route)的接口的概要信息,即三层接口的概要信息

Link: ADM - administratively down; Stby - standby

·       如果某接口的Link属性值为“ADM”,则表示该接口被管理员通过shutdown命令关闭,需要在该接口下执行undo shutdown命令才能恢复端口本身的物理状态

·       如果某接口的Link属性值为“Stby”,则表示该接口是一个处于Standby状态的备份接口,使用display interface-backup state命令可以查看该备份接口对应的主接口

Protocol: (s) - spoofing

如果某接口的Protocol属性值中带有“(s)”字符串,则表示该接口的数据链路层协议状态显示为UP,但实际可能没有对应的链路,或者对应的链路不是永久存在而是按需建立的

Interface

接口名称缩写

Link

接口物理连接状态,取值为:

·       UP:表示接口物理上是连通的

·       DOWN:表示接口物理上是不通的

·       ADM:表示接口被管理员通过shutdown命令关闭,需要执行undo shutdown命令才能恢复接口本身的物理状态

·       Stby:表示该接口是一个处于Standby状态的备份接口

Protocol

接口数据链路层协议状态,取值为:

·       UP:表示接口的数据链路层协议状态为开启

·       DOWN:表示接口的数据链路层协议状态为关闭

·       UP(s):表示接口的数据链路层协议状态显示为UP,但实际可能没有对应的链路,或者对应的链路不是永久存在而是按需建立的

Primary IP

接口主IP地址

 

【相关命令】

·              reset counters interface vlan-interface

1.1.5  display vlan

display vlan命令用来显示VLAN的相关信息。

【命令】

display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | reserved | static ]

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【参数】

vlan-id1:显示指定VLAN的信息。vlan-id1为VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:显示ID在指定范围内的VLAN的信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094。vlan-id2的值要大于或等于vlan-id1的值。

all:显示除保留VLAN外的其他VLAN的信息。

dynamic:显示系统动态创建的VLAN的数量和编号。动态VLAN是指通过RADIUS服务器下发的VLAN。

reserved:显示系统保留VLAN的信息。保留VLAN是设备根据功能实现的需要预留的VLAN。保留VLAN由协议模块来指定,为协议模块服务,用户不能对保留VLAN进行任何操作。

static:显示系统静态创建的VLAN的数量和VLAN编号。静态VLAN是指通过命令行手工创建的VLAN。

【举例】

# 显示VLAN 2的信息。

<Sysname> display vlan 2

 VLAN ID: 2

 VLAN type: Static

 Route interface: Not configured

 Description: VLAN 0002

 Name: VLAN 0002

 Tagged ports:   None

 Untagged ports:

    HundredGigE1/0/1  HundredGigE1/0/2  HundredGigE1/0/3

# 显示VLAN 3的信息。

<Sysname> display vlan 3

 VLAN ID: 3

 VLAN type: static

 Route interface: Configured

 IPv4 address: 1.1.1.1

 IPv4 subnet mask: 255.255.255.0

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged ports:   None

 Untagged ports: None

表1-2 display vlan命令显示信息描述表

字段

解释

VLAN ID

VLAN的编号

VLAN type

VLAN的类型:

·       Static:静态VLAN

·       Dynamic:动态VLAN

Route interface

设备上是否创建了对应的VLAN接口:

·       Not configured:未创建

·       Configured:已创建

Description

VLAN的描述信息

Name

VLAN的名称

IP address

VLAN接口的主用IP地址,如果VLAN接口没有配置IP地址,则不显示该字段,如果VLAN接口上还配置了从IP地址,可以使用display interface vlan-interface或者在VLAN接口视图下使用display this命令查看

Subnet mask

VLAN接口的主用IP地址的子网掩码,如果VLAN接口没有配置IP地址,则不显示该字段

Tagged ports

该VLAN报文从哪些端口发送时需要携带Tag标记

Untagged ports

该VLAN报文从哪些端口发送时不需要携带Tag标记

 

【相关命令】

·              vlan

1.1.6  display vlan brief

display vlan brief命令用来显示设备上所有已创建VLAN的概要信息。

【命令】

display vlan brief

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【举例】

# 显示设备上所有已创建VLAN的概要信息。

<Sysname> display vlan brief

Brief information about all VLANs:

Supported Minimum VLAN ID: 1

Supported Maximum VLAN ID: 4094

Default VLAN ID: 1

VLAN ID   Name                             Port

1         VLAN 0001                        GE1/0/1  GE1/0/2  GE1/0/3  GE1/0/4

                                           GE1/0/5  GE1/0/6  GE1/0/7  GE1/0/8

                                           GE1/0/9  GE1/0/10  GE1/0/11

                                           GE1/0/12  GE1/0/13  GE1/0/14

                                           GE1/0/15  GE1/0/16  GE1/0/17

                                           GE1/0/18  GE1/0/19  GE1/0/20

                                           GE1/0/21  GE1/0/22  GE1/0/23

                                           GE1/0/24  GE1/0/25  GE1/0/26

                                           GE1/0/27  GE1/0/28  GE1/0/29

                                           GE1/0/30  GE1/0/31  GE1/0/32

                                           GE1/0/33  GE1/0/34  GE1/0/35

                                           GE1/0/36  GE1/0/37  GE1/0/38

                                           GE1/0/39  GE1/0/40  GE1/0/41

                                           GE1/0/42  GE1/0/43  GE1/0/44

                                           GE1/0/45  GE1/0/46  GE1/0/47

                                           GE1/0/48

2         VLAN 0002

3         VLAN 0003

表1-3 display vlan brief命令显示信息描述表

字段

描述

Brief information about all VLANs:

所有VLAN的概要信息

Supported Minimum VLAN ID

系统支持的最小VLAN ID

Supported Maximum VLAN ID

系统支持的最大VLAN ID

Default VLAN ID

缺省VLAN ID

VLAN ID

VLAN的编号

Name

VLAN的名称

Port

允许该VLAN报文通过的端口

 

1.1.7  interface vlan-interface

interface vlan-interface命令用来创建VLAN接口并进入VLAN接口视图。如果该VLAN接口已经存在,则直接进入VLAN接口视图。

undo interface vlan-interface命令用来删除指定的VLAN接口。

【命令】

interface vlan-interface interface-number

undo interface vlan-interface interface-number

【缺省情况】

不存在VLAN接口。

【视图】

系统视图

【缺省用户角色】

network-admin

【参数】

interface-number:VLAN接口的编号,取值范围为1~4094。

【使用指导】

在创建VLAN接口之前,对应的VLAN必须已经存在,否则将不能创建指定的VLAN接口。

【举例】

# 创建VLAN接口2并进入视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2]

【相关命令】

·              display interface vlan-interface

1.1.8  mac-address

mac-address命令用来配置VLAN接口的MAC地址。

undo mac-address命令用来恢复缺省情况。

【命令】

mac-address mac-address

undo mac-address

【缺省情况】

未配置VLAN接口的MAC地址

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【参数】

mac-address:MAC地址,形式为H-H-H。

【举例】

# 配置VLAN接口2的MAC地址为0001-0001-0001。

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] mac-address 1-1-1

1.1.9  mtu

mtu命令用来配置VLAN接口的MTU值。

undo mtu命令用来恢复缺省情况。

【命令】

mtu size

undo mtu

【缺省情况】

VLAN接口的MTU值为1500字节。

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【参数】

size:表示接口允许通过的MTU(Maximum Transmission Unit,最大传输单元)值的大小,取值范围为46~9008,单位为字节。

【使用指导】

如果当前接口同时配置mtuip mtu命令,则设备会以ip mtu命令配置的接口MTU值对报文进行分片,不会再按照mtu命令配置的MTU值对报文进行分片。有关ip mtu命令的详细介绍,请参见“三层技术-IP业务命令参考”中的“IP性能优化”。

【举例】

# 配置VLAN接口1的MTU值为1492字节。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] mtu 1492

【相关命令】

·              display interface vlan-interface

1.1.10  name

name命令用来指定当前VLAN的名称。

undo name命令用来恢复缺省情况。

【命令】

name text

undo name

【缺省情况】

VLAN的名称为“VLAN vlan-id”,其中vlan-id为该VLAN的四位数编号,如果该VLAN的编号不足四位,则会在编号前增加0,补齐四位。例如,VLAN 100的名称为“VLAN 0100”。

【视图】

VLAN视图

【缺省用户角色】

network-admin

【参数】

text:VLAN名称,为1~32个字符的描述信息,区分大小写。

【使用指导】

当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。

【举例】

# 指定VLAN 2的名称为“test vlan”。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] name test vlan

【相关命令】

·              display vlan

1.1.11  reset counters interface vlan-interface

reset counters interface vlan-interface命令用来清除VLAN接口的统计信息。

【命令】

reset counters interface vlan-interface [ interface-number ]

【视图】

用户视图

【缺省用户角色】

network-admin

【参数】

vlan-interface interface-number:VLAN接口的编号,清除指定VLAN接口的统计信息。不指定interface-number时,则清除所有VLAN接口的统计信息。

【使用指导】

在某些情况下,需要统计一定时间内某接口的流量,这就需要在统计开始前清除该接口原有的统计信息,重新进行统计。

【举例】

# 清除VLAN接口2的统计信息。

<Sysname> reset counters interface vlan-interface 2

【相关命令】

·              display interface vlan-interface

1.1.12  service

service命令用来配置处理当前接口流量的slot。

undo service命令用来恢复缺省情况。

【命令】

(独立运行模式)

service slot slot-number

undo service slot

(IRF模式)

service chassis chassis-number slot slot-number

undo service chassis

【缺省情况】

未配置处理当前接口流量的slot,业务处理在接收报文的slot上进行。

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【参数】

slot slot-number:指定单板所在的槽位号。slot-number表示单板所在的槽位号。(独立运行模式)

chassis chassis-number slot slot-number:指定成员设备上的指定单板。chassis-number表示设备在IRF中的成员编号,slot-number表示单板所在的槽位号。(IRF模式)

【使用指导】

当要求同一个VLAN接口的流量必须在同一个slot上进行处理,此时可以在VLAN接口下通过service命令配置处理当前接口流量的slot。

执行本命令前,需要确保指定的slot可用。如果指定的slot不可用,流量不会被处理;如果该slot恢复可用,则流量可以继续在指定slot上进行处理。

【举例】

# 配置在指定slot上处理VLAN接口2的流量。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] service slot 2

1.1.13  shutdown

shutdown命令用来手工关闭VLAN接口。

undo shutdown命令用来手工开启VLAN接口。

【命令】

shutdown

undo shutdown

【缺省情况】

VLAN接口处于关闭状态。

【视图】

VLAN接口视图

【缺省用户角色】

network-admin

【使用指导】

如果手工打开VLAN接口,此时VLAN接口状态受VLAN中端口状态的影响,即:

·              当VLAN中所有以太网端口状态均为down时,VLAN接口为down状态,即关闭状态。

·              当VLAN中有一个或一个以上的以太网端口处于up状态时,则VLAN接口处于up状态。

如果未手工打开VLAN接口,则VLAN接口的状态始终为down(Administratively),不受VLAN中端口状态的影响。

配置VLAN接口参数前,为了避免配置过程中对网络造成影响,建议先使用shutdown命令手工关闭接口,之后再配置参数。配置完成后,使用undo shutdown命令取消手工关闭接口,使配置的参数生效。

当VLAN接口出现故障时,可以使用shutdown命令手工关闭接口,然后再使用undo shutdown命令取消手工关闭接口,这样有可能使接口恢复正常。

关闭和打开VLAN接口对于属于这个VLAN的任何一个以太网端口本身都不起作用,以太网端口的状态不随VLAN接口状态的改变而改变。

【举例】

# 将VLAN接口2关闭后再重新打开。

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] shutdown

[Sysname-Vlan-interface2] undo shutdown

1.1.14  vlan

vlan vlan-id命令用来创建VLAN,并进入VLAN视图。如果指定的VLAN已存在,则直接进入该VLAN的视图。

vlan vlan-id1 to vlan-id2命令用来批量创建vlan-id1vlan-id2之间的所有VLAN,保留VLAN除外。

vlan all命令用来批量创建VLAN 1~4094。

undo vlan命令用来删除VLAN。

【命令】

vlan { vlan-id1 [ to vlan-id2 ] | all }

undo vlan { vlan-id1 [ to vlan-id2 ] | all }

【缺省情况】

系统只有一个缺省VLAN(VLAN 1)。

【视图】

系统视图

【缺省用户角色】

network-admin

【参数】

vlan-id1:VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为VLAN的编号,取值范围为1~4094。vlan-id2的值要大于或等于vlan-id1的值。

all:除保留VLAN外的其他VLAN,当设备允许创建的最大VLAN数小于4094时,不支持该参数。

【使用指导】

用户不能创建和删除缺省VLAN(VLAN 1)和保留VLAN。

动态学习到的VLAN,以及被其他应用锁定不让删除的VLAN,都不能使用undo vlan命令直接删除。只有将相关配置删除之后,才能删除相应的VLAN。

【举例】

# 创建VLAN 2,并进入该VLAN视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2]

# 批量创建VLAN 4~100。

<Sysname> system-view

[Sysname] vlan 4 to 100

【相关命令】

·              display vlan

1.2  基于端口的VLAN配置命令

1.2.1  display port

display port命令用来显示设备上存在的Hybrid或Trunk端口。

【命令】

display port { hybrid | trunk }

【视图】

任意视图

【缺省用户角色】

network-admin

network-operator

【参数】

hybrid:显示设备当前存在的Hybrid端口。

trunk:显示设备当前存在的Trunk端口。

【举例】

# 显示当前设备存在的Hybrid端口。

<Sysname> display port hybrid

Interface            PVID  VLAN Passing

HGE1/0/1             100   Tagged:  1000, 1002, 1500, 1600-1611, 2000,

                                    2555-2558, 3000, 4000

                           Untagged:1, 10, 15, 18, 20-30, 44, 55, 67, 100,

                                    150-160, 200, 255, 286, 300-302

# 显示当前设备存在的Trunk端口。

<Sysname> display port trunk

Interface            PVID  VLAN Passing

HGE1/0/2             2     1-4, 6-100, 145, 177, 189-200, 244, 289, 400,

                           555, 600-611, 1000, 2006-2008

表1-4 display port命令显示信息描述表

字段

描述

Interface

接口名称

PVID

该端口的缺省VLAN ID

VLAN Passing

表示该端口实际通过的VLAN(该VLAN已经创建,并且接口允许其通过)

Tagged

表示哪些VLAN的报文通过该端口时必须携带VLAN Tag

Untagged

表示哪些VLAN的报文通过该端口时必须去掉VLAN Tag

 

1.2.2  port

port命令用来向VLAN中添加一个或一组Access端口。

undo port命令用来从VLAN中删除一个或一组Access端口。

【命令】

port interface-list

undo port interface-list

【缺省情况】

系统将所有端口都加入到VLAN 1。

【视图】

VLAN视图

【缺省用户角色】

network-admin

【参数】

interface-list:以太网接口列表。表示方式为interface-list = { interface-type interface-number1 [ to interface-type interface-number2 ] }&<1-10>,其中interface-type interface-number为端口类型和端口编号,interface-number2的值要大于或等于interface-number1的值,&<1-10>表示前面的参数最多可以输入10次。

【使用指导】

通过本命令只能将Access端口加入到VLAN中,不能将Trunk和Hybrid端口加入到VLAN中。

设备上的所有端口的缺省链路类型都是Access类型,但用户可以自行切换端口类型,具体配置可参考命令port link-type

【举例】

# 向VLAN2中添加端口HundredGigE1/0/1~HundredGigE1/0/3。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] port hundredgige 1/0/1 to hundredgige 1/0/3

【相关命令】

·              display vlan

1.2.3  port access vlan

port access vlan命令用来将Access端口加入到指定的VLAN中。

undo port access vlan命令用来恢复缺省情况。

【命令】

port access vlan vlan-id

undo port access vlan

【缺省情况】

所有Access端口都属于VLAN 1。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id:指定的VLAN编号,取值范围为1~4094。

【使用指导】

在将Access端口加入到指定VLAN之前,该VLAN必须已经存在。

【举例】

# 将HundredGigE1/0/1端口加入到VLAN 3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface hundredgige 1/0/1

[Sysname-HundredGigE1/0/1] port access vlan 3

1.2.4  port hybrid pvid

port hybrid pvid命令用来配置Hybrid端口的缺省VLAN。

undo port hybrid pvid命令用来配置Hybrid端口的缺省VLAN为1。

【命令】

port hybrid pvid vlan vlan-id

undo port hybrid pvid

【缺省情况】

Hybrid端口的缺省VLAN为该端口在链路类型为Access时的所属VLAN。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id:指定接口的缺省的VLAN ID,取值范围为1~4094。

【使用指导】

对Hybrid端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即可以使用已经不存在的VLAN作为缺省VLAN。

建议本机Hybrid端口的缺省VLAN和相连的对端交换机的Hybrid端口的缺省VLAN保持一致。

配置缺省VLAN后,必须使用port hybrid vlan命令配置端口允许缺省VLAN的报文通过,该端口才能转发缺省VLAN的报文。

【举例】

# 配置端口HundredGigE1/0/1(Hybrid类型)的缺省VLAN为100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface hundredgige 1/0/1

[Sysname-HundredGigE1/0/1] port link-type hybrid

[Sysname-HundredGigE1/0/1] port hybrid pvid vlan 100

[Sysname-HundredGigE1/0/1] port hybrid vlan 100 untagged

【相关命令】

·              port hybrid vlan

·              port link-type

1.2.5  port hybrid vlan

port hybrid vlan命令用来允许指定的VLAN通过当前Hybrid端口。

undo port hybrid vlan命令用来禁止指定的VLAN通过当前Hybrid端口。

【命令】

port hybrid vlan vlan-id-list { tagged | untagged }

undo port hybrid vlan vlan-id-list

【缺省情况】

Hybrid端口只允许该端口在链路类型为Access时的所属VLAN的报文以Untagged方式通过。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id-list:VLAN列表,Hybrid端口允许通过的VLAN范围。表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>vlan-id取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值,&<1-10>表示前面的参数最多可以重复输入10次。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

tagged:该端口在转发指定的VLAN报文时将携带VLAN Tag。

untagged:该端口在转发指定的VLAN报文时将去掉VLAN Tag。

【使用指导】

Hybrid端口允许多个VLAN通过。如果多次使用port hybrid vlan命令,那么Hybrid端口上允许通过的VLAN是这些vlan-id-list的合集。

【举例】

# 配置端口HundredGigE1/0/1为Hybrid端口,允许VLAN 2、4、50~VLAN 100通过,并且发送这些VLAN的报文时携带VLAN Tag。

<Sysname> system-view

[Sysname] interface hundredgige 1/0/1

[Sysname-HundredGigE1/0/1] port link-type hybrid

[Sysname-HundredGigE1/0/1] port hybrid vlan 2 4 50 to 100 tagged

【相关命令】

·              port link-type

1.2.6  port link-type

port link-type命令用来配置端口的链路类型。

undo port link-type命令用来恢复缺省情况。

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【缺省情况】

所有端口的链路类型均为Access类型。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

access:配置端口的链路类型为Access类型。

hybrid:配置端口的链路类型为Hybrid类型。

trunk:配置端口的链路类型为Trunk类型。

【使用指导】

Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再配置为其他类型端口。

【举例】

# 配置端口HundredGigE1/0/1配置为Trunk端口。

<Sysname> system-view

[Sysname] interface hundredgige 1/0/1

[Sysname-HundredGigE1/0/1] port link-type trunk

1.2.7  port trunk permit vlan

port trunk permit vlan命令用来允许指定的VLAN通过当前Trunk端口。

undo port trunk permit vlan命令用来禁止指定的VLAN通过当前Trunk端口。

【命令】

port trunk permit vlan { vlan-id-list | all }

undo port trunk permit vlan { vlan-id-list | all }

【缺省情况】

Trunk端口只允许VLAN 1的报文通过。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id-list:VLAN列表,Trunk端口允许通过的VLAN范围。表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>vlan-id取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值,&<1-10>表示前面的参数最多可以重复输入10次。

all:表示允许所有VLAN通过该Trunk端口。建议用户谨慎使用port trunk permit vlan all命令,以防止未授权VLAN的用户通过该端口访问受限资源。

【使用指导】

Trunk端口可以允许多个VLAN通过。如果多次执行port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan-id-list的集合。

Trunk端口发送出去的报文,只有缺省VLAN的报文不带VLAN Tag,其他VLAN的报文均会保留VLAN Tag。

【举例】

# 配置端口HundredGigE1/0/1为Trunk端口,允许VLAN 2、4、50~100通过。

<Sysname> system-view

[Sysname] interface hundredgige 1/0/1

[Sysname-HundredGigE1/0/1] port link-type trunk

[Sysname-HundredGigE1/0/1] port trunk permit vlan 2 4 50 to 100

【相关命令】

·              port link-type

1.2.8  port trunk pvid

port trunk pvid命令用来配置Trunk端口的缺省VLAN。

undo port trunk pvid命令用来恢复缺省情况。

【命令】

port trunk pvid vlan vlan-id

undo port trunk pvid

【缺省情况】

Trunk端口的缺省VLAN为VLAN 1。

【视图】

二层以太网接口视图

二层聚合接口视图

【缺省用户角色】

network-admin

【参数】

vlan-id:指定接口的缺省VLAN ID,取值范围为1~4094。

【使用指导】

对Trunk端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即使用已经不存在的VLAN作为缺省VLAN。

本端设备Trunk端口的缺省VLAN ID和相连的对端设备的Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

配置缺省VLAN后,必须使用port trunk permit vlan命令配置端口允许缺省VLAN的报文通过,该端口才能转发缺省VLAN的报文。

【举例】

# 配置端口HundredGigE1/0/1(Trunk类型)的缺省VLAN为VLAN 100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] interface hundredgige 1/0/1

[Sysname-HundredGigE1/0/1] port link-type trunk

[Sysname-HundredGigE1/0/1] port trunk pvid vlan 100

[Sysname-HundredGigE1/0/1] port trunk permit vlan 100

【相关命令】

·              port link-type

·              port trunk permit vlan

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!

联系我们 联系我们
联系我们
回到顶部 回到顶部