选择区域语言: EN CN HK

04-二层技术-广域网接入配置指导

04-帧中继配置

本章节下载  (630.17 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_900/Configure/Operation_Manual/H3C_MSR_CG(V5)-R2511P07-V1.14/04/201808/1106855_30005_0.htm

04-帧中继配置

  录

1 帧中继

1.1 帧中继简介

1.1.1 帧中继协议概述

1.1.2 帧中继接口类型

1.1.3 虚电路

1.1.4 DLCI

1.1.5 帧中继地址映射

1.1.6 帧中继LMI协议

1.1.7 帧中继应用

1.2 帧中继配置任务简介

1.3 配置帧中继DTE侧

1.3.1 帧中继DTE侧基本配置

1.3.2 配置帧中继地址映射

1.3.3 配置帧中继本地虚电路

1.3.4 配置帧中继子接口

1.3.5 配置Annex G数据互通

1.3.6 配置重标记DE标志位

1.3.7 配置帧中继分片

1.4 配置帧中继DCE侧

1.4.1 帧中继DCE侧基本配置

1.4.2 配置帧中继地址映射

1.4.3 配置帧中继本地虚电路

1.4.4 配置帧中继子接口

1.4.5 配置帧中继交换

1.4.6 配置在IP网上承载帧中继

1.4.7 配置Annex G数据互通

1.4.8 配置重标记DE标志位

1.4.9 配置帧中继分片

1.5 开启Trap功能

1.6 帧中继显示和维护

1.7 帧中继典型配置举例

1.7.1 通过帧中继网络互连局域网(IPv4)

1.7.2 通过帧中继网络互连局域网(IPv6)

1.7.3 通过专线互连局域网

1.7.4 通过Annex G DLCI互连局域网

1.8 帧中继常见配置错误举例

1.8.1 物理层处于down状态

1.8.2 物理层已经处于up状态,但链路层协议处于down状态

1.8.3 链路层up,但是ping不通对

2 帧中继压缩

2.1 帧中继压缩简介

2.1.1 FRF.9(FRF.9 stac压缩)

2.1.2 FRF.20(FRF.20 IPHC)

2.2 配置帧中继压缩

2.2.1 配置帧中继FRF.9 stac压缩

2.2.2 配置帧中继FRF.20 IP头压缩

2.3 帧中继压缩显示和维护

2.4 帧中继压缩典型配置举例

2.4.1 帧中继FRF.9 stac压缩配置举例

2.4.2 帧中继FRF.20 IP头压缩配置举例

3 多链路帧中继

3.1 多链路帧中继简介

3.2 配置多链路帧中继

3.2.1 配置MFR捆绑

3.2.2 配置捆绑链路

3.3 多链路帧中继显示和维护

3.4 多链路帧中继典型配置举例

3.4.1 多链路帧中继直连配置举例

3.4.2 多链路帧中继交换配置举例

4 PPPoFR

4.1 PPPoFR简介

4.2 配置PPPoFR

4.3 PPPoFR显示和维护

4.4 PPPoFR典型配置举例

5 MPoFR

5.1 MPoFR简介

5.2 配置MPoFR

5.3 MPoFR典型配置举例

5.3.1 MPoFR典型配置举例

 


1 帧中继

1.1  帧中继简介

1.1.1  帧中继协议概述

FR(Frame Relay,帧中继)协议是一种简化的X.25广域网协议,是一种统计复用的协议,它能够在单一物理传输线路上提供多条虚电路。每条虚电路用DLCI(Data Link Connection Identifier,数据链路连接标识符)来标识。每条虚电路通过LMI(Local Management Interface,本地管理接口)协议检测和维护虚电路的状态。

1.1.2  帧中继接口类型

帧中继网络提供了用户设备(如路由器和主机等)之间进行数据通信的能力。帧中继设备和封装帧中继协议的接口根据在网络中的作用不同,可以分为下列四种:

·              DTE:用户设备被称作DTE(Data Terminal Equipment,数据终端设备);

·              DCE:为用户设备提供接入的设备,属于网络设备,被称为DCE(Data Circuit-terminating Equipment,数据电路终接设备);

·              UNI:DTE和DCE之间的接口被称为UNI(User Network Interface,用户网络接口);

·              NNI:网络与网络之间的接口被称为NNI(Network-to-Network Interface,网间网接口)。

在实际应用中,DTE接口只能和DCE接口连接,NNI接口只能和NNI接口连接。如果把设备用做帧中继交换机,帧中继接口类型应该为NNI或DCE。

图1-1所示,两台DTE设备(Router A和Router D)通过帧中继网络实现互连,Router B和Router C用来代表一个简单的帧中继交换网。可以看出,DTE和DCE只是在UNI处才进行区分;对于两台DTE之间建立的虚电路,不同虚电路段可以对应不同的DLCI。

图1-1 帧中继网络接口类型

 

1.1.3  虚电路

虚电路VC(Virtual Circuit)是建立在两台网络设备之间共享网络的逻辑电路。根据建立方式的不同,可以将虚电路分为两种类型:

·              PVC(Permanent Virtual Circuit,永久虚电路):手工设置产生的虚电路。

·              SVC(Switched Virtual Circuit,交换虚电路):通过协议协商自动创建和删除的虚电路。

目前在帧中继中使用最多的方式是永久虚电路方式。

对于DTE侧设备,永久虚电路的状态完全由DCE侧设备决定;对于DCE侧设备,永久虚电路的状态由网络来决定。在两台网络设备直接连接的情况下,DCE侧设备的虚电路状态是由设备管理员来设置的。

永久虚电路方式需要检测虚电路是否可用。LMI协议就是用来检测虚电路是否可用的。

1.1.4  DLCI

DLCI用于标识不同的虚电路,DLCI只在本地接口和与之直接相连的对端接口有效,只具有本地意义,不具有全局有效性。在帧中继网络中,不同的物理接口上相同的DLCI并不表示是同一个虚电路。

帧中继网络用户接口上最多支持1024条虚电路,其中,用户可用的DLCI范围是16~1007。由于帧中继虚电路是面向连接的,本地不同的DLCI连接到不同的对端设备,因此可以认为本地DLCI就是对端设备的“帧中继地址”。

1.1.5  帧中继地址映射

帧中继地址映射是把对端设备的协议地址与对端设备的帧中继地址(本地的DLCI)关联起来,使高层协议能通过对端设备的协议地址寻址到对端设备。

帧中继主要用来承载IP协议,在发送IP报文时,根据路由表只能知道报文的下一跳地址,发送前必须由该地址确定它对应的DLCI。这个过程可以通过查找帧中继地址映射表来完成,地址映射表中存放的是下一跳IP地址和与其对应的DLCI的映射关系(MAP)。

地址映射表可以由手工配置,也可以由InARP(Inverse Address Resolution Protocol,逆向地址解析协议)动态维护。

InARP的工作机制如下:

·              每当发现一条新的虚电路时,如果本地接口上已经配置了协议地址,InARP就在该虚电路上发送InARP请求报文给对端。该请求报文包含有本地的协议地址。对端设备收到该请求时,可以获得本地的协议地址,从而生成地址映射,并发送InARP响应报文进行响应,这样本地同样生成地址映射。

·              如果已经手工配置了静态MAP或已经建立了动态MAP,则无论该静态MAP中的对端地址正确与否,都不会在该虚电路上发送InARP请求报文给对端,只有在没有MAP的情况下才会向对端发送InARP请求报文。

在IPv6下,地址映射由IND(inverse Neighbor Discovery,逆向邻居发现协议)动态维护。IND的工作机制与inARP基本相同。

1.1.6  帧中继LMI协议

LMI协议通过状态请求报文(Status Enquiry)和状态报文(Status)维护帧中继的链路状态和PVC状态。包括:通知PVC的增加、探测PVC的删除、监控PVC状态的变更、验证链路的完整性。

系统支持三种LMI协议:

·              ITU-T的Q.933附录A

·              ANSI的T1.617附录D

·              非标准兼容协议

为了保证正常通信,DTE侧和DCE侧需要采用相同的LMI协议。

LMI协议的基本工作方式是:DTE设备每隔一定的时间间隔发送一个状态请求报文去查询虚电路的状态,DCE设备收到状态请求报文后,立即用状态报文通知DTE当前接口上所有虚电路的状态。

以上过程中用到的一些参数定义如表1-1所示。用户可以对这些参数进行配置,达到优化设备运行的目的。

表1-1 帧中继协议参数含义

设备角色

参数含义

取值范围

缺省值

DTE

请求PVC状态的计数器(N391)

1~255

6

错误门限(N392)

1~10

3

事件计数器(N393)

1~10

4

用户侧轮询定时器(T391),当为0时,表示禁止LMI协议

0~32767(单位:秒)

10(单位:秒)

DCE

错误门限(N392)

1~10

3

事件计数器(N393)

1~10

4

网络侧轮询定时器(T392)

5~30(单位:秒)

15(单位:秒)

 

这些参数由Q.933的附录A规定,各参数的含义如下。

1. 与DTE相关的参数含义

·              N391:用来定义链路完整性验证报文和链路状态查询报文的发送比例,即(链路完整性验证报文数:链路状态查询报文数) = (N391-1:1)。

·              N392:表示在被观察的事件总数中发生错误的门限。

·              N393:表示被观察的事件总数。

·              T391:这是一个时间变量,它定义了DTE设备发送状态请求报文的时间间隔。

DTE设备每隔一定的时间间隔(由T391决定)要发送一个状态请求报文(状态请求报文有两种类型:链路完整性验证报文和链路状态查询报文)去查询链路状态,DCE设备收到该报文后应立即发送状态响应报文。如果DTE设备在规定的时间内没有收到响应,就记录该错误。如果错误次数超过门限,DTE设备就认为物理通路不可用,所有的虚电路都不可用(上面N392、N393两个参数一起定义了“错误门限”。即:如果DTE设备发送N393个状态请求报文中,发生错误数达到N392,DTE设备就认为错误次数达到门限)。

2. 与DCE相关的参数含义

·              N392、N393两个参数的含义与DTE中的含义相似,区别在于:DCE设备要求DTE设备发送状态请求报文的固定时间间隔由T392决定,不同于DTE由T391决定,若DCE在T392时间间隔内没有收到DTE的状态请求报文,则记录错误数。

·              T392:这是一个时间变量,它定义了DCE设备等待一个状态请求报文的最长时间。

1.1.7  帧中继应用

帧中继比较典型的应用之一是帧中继接入。帧中继接入即作为用户端承载上层报文,接入到帧中继网络中。

帧中继网络可以是公用网络或者是某一企业的私有网络,如图1-2所示。帧中继网络也可以是直接连接,如图1-3所示。

图1-2 通过帧中继网络互连局域网

 

图1-3 通过专线互连局域网

 

1.2  帧中继配置任务简介

表1-2 帧中继配置任务简介

配置任务

说明

详细配置

配置帧中继DTE侧

帧中继DTE侧基本配置

必选

1.3.1 

配置帧中继地址映射

必选

1.3.2 

配置帧中继本地虚电路

必选

1.3.3 

配置帧中继子接口

可选

1.3.4 

配置Annex G数据互通

可选

1.3.5 

配置重标记DE标志位

可选

1.3.6 

配置帧中继分片

可选

1.3.7 

配置帧中继DCE侧

帧中继DCE侧基本配置

必选

1.4.1 

配置帧中继地址映射

必选

1.4.2 

配置帧中继本地虚电路

必选

1.4.3 

配置帧中继子接口

可选

1.4.4 

配置帧中继交换

可选

1.4.5 

配置在IP网上承载帧中继

可选

1.4.6 

配置Annex G数据互通

可选

1.4.7 

配置重标记DE标志位

可选

1.4.8 

配置帧中继分片

可选

1.4.9 

开启Trap功能

可选

1.4.9 

 

·          帧中继网络NNI接口的配置和DCE侧的配置基本相同,只是二者的接口类型不同,一个为NNI,一个为DCE。NNI接口的具体配置请参见“1.4  配置帧中继DCE侧”。

·          如果一端设置为NNI接口,则通信的另一端也必须设置为NNI接口。

 

1.3  配置帧中继DTE

1.3.1  帧中继DTE侧基本配置

表1-3 帧中继DTE侧基本配置

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置接口封装的链路层协议为帧中继

link-protocol fr [ ietf | nonstandard ]

必选

缺省情况下,接口的链路层协议封装为PPP

配置帧中继接口类型为DTE

fr interface-type dte

可选

缺省情况下,帧中继接口类型为DTE

配置帧中继LMI协议类型

fr lmi type { ansi | nonstandard | q933a } [ bi-direction ]

可选

缺省情况下,接口的LMI协议类型为q933a

参数bi-direction的支持情况和设备的型号有关,请以设备的实际情况为准

配置DTE侧N391参数

fr lmi n391dte n391-value

可选

缺省情况下,该参数的值为6

配置DTE侧N392参数

fr lmi n392dte n392-value

可选

缺省情况下,该参数值为3

配置DTE侧N393参数

fr lmi n393dte n393-value

可选

缺省情况下,该参数值为4

配置DTE侧T391参数

timer hold seconds

可选

缺省情况下,该参数为10秒

 

1.3.2  配置帧中继地址映射

帧中继地址映射可以通过下面两种方式建立:

·              静态配置:手工建立对端IP地址与本地DLCI的映射关系。当网络拓扑比较稳定,短时间内不会有变化或新的用户加入,可以使用静态配置。一方面,它可以保障映射链路不发生变化,使网络链路连接比较稳定,另一方面,它可以防止其他未知用户的攻击,提高网络安全性。

·              动态建立:运行InARP或IND后,可以动态地建立对端IP地址与本地DLCI的映射关系。适用于对端设备也支持InARP或IND且网络较复杂的情况。

1. 配置IPv4帧中继地址映射

表1-4 静态配置IPv4帧中继地址映射

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

增加一条IPv4静态地址映射

fr map ip { ip-address [ mask ] | default } dlci-number [ broadcast | [ ietf | nonstandard ] ] * [ compression { frf9 | iphc connections number } ]

必选

缺省情况下,系统没有IPv4静态地址映射

 

表1-5 动态建立IPv4帧中继地址映射

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

使能帧中继InARP以建立IPv4动态地址映射

fr inarp [ ip [ dlci-number ] ]

可选

缺省情况下,系统使能InARP

 

·          当接口配置IPv4静态地址映射时,可以不为接口配置DLCI。

·          不能在点到点子接口上配置IPv4静态地址映射。

 

2. 配置IPv6帧中继地址映射

表1-6 静态配置IPv6帧中继地址映射

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

增加一条IPv6静态地址映射

fr map ipv6 { ipv6-address | default } dlci-number [ broadcast ] [ {compression frf9}  ]

必选

缺省情况下,系统没有IPv6静态地址映射

 

表1-7 动态建立IPv6帧中继地址映射

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

使能帧中继IND以建立IPv6动态地址映射

fr ipv6 ind [ dlci-number ]

必选

缺省情况下,系统不使能IND

设置IPv6下IND使能后IND报文的发送周期

ipv6 ind holdtime time-value

可选

缺省情况下为30秒

设置IPv6下IND报文发送无回应后再次发送的时间间隔

ipv6 ind solicitation retrans-timer time-value

可选

缺省情况下为1秒

 

说明

·          当接口配置IPv6静态地址映射时,可以不为接口配置DLCI。

·          不能在点到点子接口上配置IPv6静态地址映射。

·          IPv6情况下不支持nonstandard方式。

 

1.3.3  配置帧中继本地虚电路

当帧中继接口类型是DCE或NNI时,必须为接口(不论是主接口还是子接口)手工配置虚电路。当帧中继接口类型是DTE时,如果接口是主接口,则系统会根据对端设备自动确定本端的虚电路,也可以手工配置虚电路;如果是子接口,则必须手工为接口配置虚电路。如果要在DTE侧手工配置虚电路,则配置的虚电路号必须与相连的DCE侧保持一致。

虚电路号在一个物理接口上是唯一的。

表1-8 配置帧中继本地虚电路

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

在接口上配置虚电路

fr dlci dlci-number

必选

缺省情况下,接口上没有配置虚电路

 

如果DCE侧的DLCI值被改变,在不影响业务的前提下,可以重启两端设备的接口,或者在两端的设备上分别执行命令reset fr inarp清除逆向地址解析协议建立的地址映射信息(IPv6下则执行命令reset fr ind),保证DTE能重新尽快学习到正确的地址映射信息。

 

1.3.4  配置帧中继子接口

1. 帧中继子接口简介

帧中继有两种类型的接口:主接口和子接口。其中子接口是一个逻辑结构,可以配置协议地址和虚电路等,一个物理接口可以有多个子接口。虽然子接口是逻辑结构,并不实际存在,但对于网络层而言,子接口和主接口是没有区别的,都可以配置虚电路与远端设备相连。

帧中继的子接口又可以分为两种类型:点到点(point-to-point)子接口和点到多点(point-to-multipoint)子接口。点到点子接口用于连接单个远端目标,点到多点子接口用于连接多个远端目标。点到多点子接口在一个子接口上配置多条虚电路,每条虚电路都和它相连的远端网络地址建立一个地址映射,这样不同的虚电路就可以到达不同的远端而不会混淆。

地址映射的建立可以用手工配置的方法,也可以利用逆向地址解析协议或逆向邻居发现协议来动态建立。点到点子接口和点到多点子接口配置虚电路以及地址映射的方法是不同的:

·              点到点(point-to-point)子接口:对点到点子接口而言,因为只有唯一的一个对端地址,所以在给子接口配置一条PVC时实际已经确定了对端地址,不必配置动态或静态地址映射。

·              点到多点(point-to-multipoint)子接口:对点到多点子接口,对端地址与本地DLCI映射可以通过配置静态地址映射或者通过逆向地址解析协议来确定(InARP或IND在主接口上配置即可)。如果要建立静态地址映射,则应该对每一条虚电路建立静态地址映射关系。

2. 配置帧中继子接口

表1-9 配置帧中继子接口

操作

命令

说明

进入系统视图

system-view

-

创建子接口并进入子接口视图

interface interface-type interface-number.subnumber [ p2mp | p2p ]

必选

缺省情况下,帧中继子接口类型为p2mp

配置帧中继子接口的虚电路

请参见“1.3.3  配置帧中继本地虚电路

必选

帧中继子接口必须手工配置虚电路,且传输设备两端要保持一致

建立地址映射

请参见“1.3.2  配置帧中继地址映射

可选

对于点到多点子接口需要配置该项

 

1.3.5  配置Annex G数据互通

ANSI T1.617 Annex G协议规定了使用帧中继DLCI传输X.25分组的方式。利用X.25完整的确认重传和流控机制,Annex G DLCI可以提供可靠的传输业务;也可以使用Annex G DLCI通过帧中继网络互联X.25网络。Annex G也是由原有的X.25网络向帧中继网络过渡的一种手段,有效地保护了用户已有的投资。

1. 配置Annex G DLCI

表1-10 配置Annex G DLCI

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置接口封装的链路层协议为帧中继

link-protocol fr [ ietf | nonstandard ]

必选

缺省情况下,接口封装的链路层协议为PPP

创建虚电路并进入接口DLCI视图

fr dlci dlci-number

必选

缺省情况下,接口上没有配置虚电路

把帧中继DLCI配置为Annex G DLCI

annexg { dce | dte }

必选

 

·          因为Annex G DLCI不支持InARP协议,所以必须为目的IP地址配置静态的帧中继地址映射。

·          配置Annex G DLCI时,必须明确配置为DCE或DTE,而且两端的配置必须对应,也就是说一端如果配置为DTE,则另一端必须配置为DCE。

 

2. 配置Annex G DLCI的X.25属性

表1-11 配置Annex G DLCI的X.25属性

操作

命令

说明

进入系统视图

system-view

-

创建X.25 Template并进入X.25 Template视图

x25 template name

必选

配置X.25属性

相关内容请参见“二层技术-广域网接入配置指导”中的“LAPB和X.25”

可选

配置LAPB属性

相关内容请参见“二层技术-广域网接入配置指导”中的“LAPB和X.25”

可选

退回系统视图

quit

-

进入接口视图

interface interface-type  interface-number

-

创建虚电路并进入接口DLCI视图

fr dlci dlci-number

必选

缺省情况下,接口上没有配置虚电路

在DLCI中应用X.25 Template

x25-template name

可选

缺省情况下,DLCI不应用X.25 Template

 

·          需要正确理解在帧中继接口配置模式下配置的帧中继地址映射和在X.25 Template配置模式下配置的X.25地址映射之间的区别:前者给出了到达目的IP地址的报文需要从指定的DLCI发出;而后者给出了到达目的IP地址的报文需要向指定的X.25地址发起X.25呼叫。这两种地址映射都被配置了,IP数据报文才能正确地在Annex G DLCI上收发。

·          在X.25 Template下配置的LAPB/X.25属性与在X.25接口下配置比较类似,为了保证X.25呼叫能正确建立,两端路由器配置应当保持一致。

 

1.3.6  配置重标记DE标志位

FR报文中的DE标志位(Discard Eligibility bit)表示帧的丢弃优先级,取值为0或1。当网络发生拥塞时,优先丢弃DE标志位为1的帧,以防止网络过载。

用户可以通过设置FR报文DE标志位的值,来重新定义FR报文的丢弃优先级。

表1-12 配置重标记DE标志位

操作

命令

说明

进入系统视图

system-view

-

定义类

定义一个类并进入类视图

traffic classifier tcl-name [ operator { and | or } ]

-

定义匹配数据包的规则

if-match [ not ] match-criteria

必选

退出类视图

quit

-

定义重标记DE标志位的流行为

定义一个流行为并进入流行为视图

traffic behavior behavior-name

-

重标记DE标志位的值

remark fr-de fr-de-value

必选

退出流行为视图

quit

-

定义策略

定义策略并进入策略视图

qos policy policy-name

-

在策略中为类指定采用的流行为

classifier tcl-name behavior behavior-name

必选

退出策略视图

quit

-

将策略和帧中继类关联

进入帧中继类视图

fr class class-name

-

应用策略

apply policy policy-name outbound

必选

退出帧中继类视图

quit

-

将帧中继类和帧中继接口或虚电路关联

将帧中继类同帧中继接口相关联

进入帧中继接口视图

interface interface-type interface-number

二者必选其一或全选

缺省情况下,没有帧中继类同帧中继接口或虚电路相关联

将帧中继类同帧中继接口相关联

fr-class class-name

将帧中继类同帧中继虚电路相关联

进入帧中继接口视图

interface interface-type interface-number

进入帧中继虚电路视图

fr dlci dlci

将帧中继类同帧中继虚电路相关联

fr-class class-name

 

·          关于类、流行为、策略的详细介绍和相关配置,请参见“ACL和QoS配置指导”中的“QoS”。

·          关于帧中继类的详细介绍和相关配置,请参见“ACL和QoS配置指导”中的“帧中继QoS”。

 

1.3.7  配置帧中继分片

设备支持帧中继论坛FRF.12标准的end-to-end分片功能。

在低速帧中继线路上,大数据报文将会造成传输时延的增大。帧中继分片特性可以将大的帧中继报文分割成几个小报文,从而可以保证在低速线路上数据也可以被低延迟的发送。

当语音与数据同传时,大数据报文的发送将长时间占用带宽,会造成语音报文被延时甚至丢弃,影响语音质量。配置帧中继分片的目的是尽量减少语音的延时,保证语音的实时性。配置分片后大的数据报文将被拆分为较小的数据分片,语音报文与拆分后的分片交替发送,保证语音报文及时均匀地得到处理,降低时延。

表1-13 配置帧中继分片

操作

命令

 

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

使能接口的FRF.12分片功能

fr fragment [ fragment-size ] end-to-end

必选

缺省情况下,接口的FRF.12分片功能处于关闭状态

 

说明

l   接口的FRF.12分片功能和帧中继流量整形功能(fr traffic-shaping命令)不能同时进行配置。关于帧中继流量整形功能的详细介绍,请参见“ACL和QoS配置指导”中的“帧中继QoS”。

l   MFR接口上不支持FRF.12的分片。

 

1.4  配置帧中继DCE

1.4.1  帧中继DCE侧基本配置

表1-14 帧中继DCE侧基本配置

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置接口封装的链路层协议为帧中继

link-protocol fr [ ietf | nonstandard ]

必选

缺省情况下,接口封装的链路层协议为PPP

配置帧中继接口类型为DCE或者NNI

fr interface-type { dce | nni }

必选

缺省情况下,帧中继接口类型为DTE

配置帧中继LMI协议类型

fr lmi type { ansi | nonstandard | q933a }

可选

缺省情况下,接口的LMI协议类型为q933a

配置DCE侧N392参数

fr lmi n392dce n392-value

可选

缺省情况下,该参数值为3

配置DCE侧N393参数

fr lmi n393dce n393-value

可选

缺省情况下,该参数值为4

配置DCE侧T392参数

fr lmi t392dce t392-value

可选

缺省情况下,该参数值为15秒

 

1.4.2  配置帧中继地址映射

请参见“1.3.2  配置帧中继地址映射”。

1.4.3  配置帧中继本地虚电路

请参见“1.3.3  配置帧中继本地虚电路”。

1.4.4  配置帧中继子接口

请参见“1.3.4  配置帧中继子接口”。

1.4.5  配置帧中继交换

当设备作为帧中继交换机工作时,或需要在设备上实现帧中继网络中的数据交换时,需要在设备上使能帧中继交换功能。

配置帧中继交换有两种方法:在接口视图下配置用于帧中继交换的静态路由或者在系统视图下配置用于帧中继交换的PVC,两者的配置效果是一样的。

用于帧中继交换功能的接口的类型必须配置为NNI或DCE,否则帧中继交换功能将不起作用。

 

表1-15 配置帧中继交换

操作

命令

说明

进入系统视图

system-view

-

使能帧中继交换功能

fr switching

必选

进入接口视图

interface interface-type interface-number

-

设置担负帧中继交换功能的帧中继接口类型为NNI或DCE

fr interface-type { dce | nni }

必选

缺省情况下,系统不进行帧中继交换,帧中继接口类型为DTE

如果配置帧中继接口类型为DTE,则帧中继交换功能不起作用

配置帧中继交换(帧中继静态路由与帧中继交换PVC二者必选其一)

在接口视图下配置用于帧中继交换的静态路由

fr dlci-switch in-dlci interface interface-type interface-number dlci out-dlci

必选

缺省情况下,没有配置帧中继交换的静态路由

·          帧中继交换静态路由是为当前接口指定报文转发的出接口及虚电路号,从而配置一条报文转发路由

·          必须在用于帧中继交换的两个接口上分别配置静态路由,帧中继交换功能才能起作用

·          用于配置帧中继交换的in-dlciout-dlci必须已经在相应的接口上配置

在系统视图下配置用于帧中继交换的虚电路

quit

-

fr switch name interface interface-type interface-number dlci dlci1 interface interface-type interface-number dlci dlci2

必选

帧中继交换PVC是在设备的任意两个接口之间创建报文转发路由

fr switch name

可选

进入帧中继交换PVC的视图

undo shutdown

可选

使能当前的交换PVC

 

1.4.6  配置在IP网上承载帧中继

由于IP网络的应用越来越广泛,实际应用时,经常需要通过IP网络承载帧中继数据(Frame Relay over IP),实现帧中继网络的互联。Frame Relay over IP是在两端的帧中继网络之间建立GRE(Generic Routing Encapsulation,通用路由封装)隧道,通过GRE隧道传送帧中继报文。在建立了GRE的Tunnel接口后,可以指定帧中继交换使用Tunnel接口,从而实现在IP网络上承载帧中继报文。如图1-4所示。

图1-4 Frame Relay over IP典型应用图

 

GRE隧道上传送的帧中继报文分为四种:

·              封装了IP头的FR数据报文

·              InARP报文

·              IND报文

·              用于协商GRE隧道上虚电路状态的LMI报文

配置在IP网上承载帧中继有两种方法:在接口视图下配置用于帧中继交换的静态路由或者在系统视图下配置用于帧中继交换的PVC,两者的配置效果是一样的。

用于帧中继交换功能的接口的类型必须配置为NNI或DCE,否则帧中继交换功能将不起作用。

 

表1-16 配置在IP网上承载帧中继

操作

命令

说明

进入系统视图

system-view

-

请在系统视图下创建Tunnel接口,并在Tunnel接口视图下进行相应配置

关于Tunnel接口的具体配置请参见“三层技术-IP业务配置指导”中的“GRE”

必选

退回系统视图

quit

-

使能帧中继交换功能

fr switching

必选

进入接口视图

interface interface-type interface-number

-

设置担负帧中继交换功能的帧中继接口类型为NNI或DCE

fr interface-type { dce | nni }

必选

缺省情况下,系统不进行帧中继交换,帧中继接口类型为DTE

如果配置帧中继接口类型为DTE,则帧中继交换功能不起作用

配置帧中继交换(帧中继静态路由与帧中继交换PVC二者必选其一)

在接口视图下配置用于帧中继交换的静态路由

fr dlci-switch in-dlci interface tunnel interface-number dlci out-dlci

必选

缺省情况下,没有配置帧中继交换静态路由

只需要在用于帧中继交换的帧中继接口上配置静态路由即可,不需要在Tunnel接口上配置静态路由

在系统视图下配置用于帧中继交换的虚电路

quit

-

fr switch name interface interface-type interface-number dlci dlci1 interface tunnel interface-number dlci dlci2

必选

缺省情况下,没有创建帧中继交换PVC

fr switch name

可选

undo shutdown

可选

在创建了帧中继PVC后,缺省的PVC状态为up

 

注意

·          在配置IP网上承载帧中继时,需要首先创建Tunnel接口,并对Tunnel接口进行配置。在建立了GRE的Tunnel接口后,可以指定帧中继交换使用该Tunnel接口,从而实现在IP网络上承载帧中继报文。

·          用户需要在GRE两端的帧中继接口视图或多链路帧中继(Multilink Frame Relay,MFR)接口视图下配置帧中继交换的静态路由,或者在系统视图下配置帧中继交换的PVC。在配置了帧中继路由后,在路由器的帧中继路由表中会添加两条路由:一条入接口为Tunnel接口,出接口为帧中继接口;另一条入接口为帧中继接口,出接口为Tunnel接口。在Tunnel接口上会生成一条DLCI编号为out-dlci的虚电路,这条虚电路的状态决定以上路由的状态。

·          GRE两端的Tunnel接口上的DLCI编号(out-dlci)必须相同。

 

1.4.7  配置Annex G数据互通

请参见“1.3.5  配置Annex G数据互通”。

1.4.8  配置重标记DE标志位

请参见“1.3.6  配置重标记DE标志”。

1.4.9  配置帧中继分片

请参见“1.3.7  配置帧中继分片”。

1.5  开启Trap功能

开启帧中继的Trap功能后,会生成级别为notifications的Trap报文,用于报告帧中继的重要事件。生成的Trap报文将被发送到设备的信息中心,通过设置信息中心的参数,最终决定Trap报文的输出规则(即是否允许输出以及输出方向)。(有关信息中心参数的配置请参见“网络管理和监控配置指导”中的“信息中心”。)

表1-17 开启Trap功能

操作

命令

说明

进入系统视图

system-view

-

开启帧中继的Trap功能

snmp-agent trap enable fr

可选

缺省情况下,帧中继的Trap功能处于开启状态

 

snmp-agent trap enable fr命令的详细介绍请参见“网络管理和监控命令参考/SNMP”中的snmp-agent trap enable命令。

 

1.6  帧中继显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后帧中继的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除所有自动建立的帧中继地址映射信息。

表1-18 帧中继显示和维护

操作

命令

显示各接口的帧中继协议状态

display fr interface [ interface-type { interface-number | interface-number.subnumber } ] [ | { begin | exclude | include } regular-expression ]

显示IPv4协议地址与帧中继地址映射表的信息

display fr map-info [ interface interface-type { interface-number | interface-number.subnumber } ] [ | { begin | exclude | include } regular-expression ]

显示IPv6协议地址与帧中继地址映射表的信息

display fr ipv6 map-info { static | dynamic | all } [ interface interface-type { interface-number | interface-number.subnumber } ] [ | { begin | exclude | include } regular-expression ]

显示帧中继LMI类型报文的收发统计

display fr lmi-info [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

显示帧中继数据收发统计信息

display fr statistics [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

显示帧中继永久虚电路表

display fr pvc-info [ interface interface-type { interface-number | interface-number.subnumber } ] [ dlci-number ] [ | { begin | exclude | include } regular-expression ]

显示帧中继逆向地址解析协议报文统计信息

display fr inarp-info [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

查看配置的帧中继交换的信息

display fr dlci-switch [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

显示X.25 template配置属性信息

display x25 template [ name ] [ | { begin | exclude | include } regular-expression ]

清除所有由inARP自动建立的帧中继地址映射

reset fr inarp

清除所有由IND自动建立的帧中继地址映射

reset fr ind

清除帧中继PVC统计信息

reset fr pvc interface serial interface-number [ dlci dlci-number ]

 

1.7  帧中继典型配置举例

1.7.1  通过帧中继网络互连局域网(IPv4)

1. 组网需求

通过公用帧中继网络互连局域网,在这种方式下,路由器只能作为用户设备工作在帧中继的DTE方式。

2. 组网图

图1-5 通过帧中继网络互连局域网

 

3. 配置步骤

(1)      配置Router A

# 配置接口IP地址。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 202.38.163.251 255.255.255.0

# 配置接口封装为帧中继。

[RouterA-Serial2/0] link-protocol fr

[RouterA-Serial2/0] fr interface-type dte

# 如果对端路由器支持逆向地址解析功能,则配置动态地址映射。

[RouterA-Serial2/0] fr inarp

# 否则配置静态地址映射。

[RouterA-Serial2/0] fr map ip 202.38.163.252 50

[RouterA-Serial2/0] fr map ip 202.38.163.253 60

(2)      配置Router B

# 配置接口IP地址。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 202.38.163.252 255.255.255.0

# 配置接口封装为帧中继。

[RouterB-Serial2/0] link-protocol fr

[RouterB-Serial2/0] fr interface-type dte

# 如果对端路由器支持逆向地址解析功能,则配置动态地址映射。

[RouterB-Serial2/0] fr inarp

# 否则配置静态地址映射。

[RouterB-Serial2/0] fr map ip 202.38.163.251 70

(3)      配置Router C

# 配置接口IP地址。

<RouterC> system-view

[RouterC] interface serial 2/0

[RouterC-Serial2/0] ip address 202.38.163.253 255.255.255.0

# 配置接口封装为帧中继。

[RouterC-Serial2/0] link-protocol fr

[RouterC-Serial2/0] fr interface-type dte

# 如果对端路由器支持逆向地址解析功能,则配置动态地址映射。

[RouterC-Serial2/0] fr inarp

# 否则配置静态地址映射。

[RouterC-Serial2/0] fr map ip 202.38.163.251 80

1.7.2  通过帧中继网络互连局域网(IPv6)

1. 组网需求

通过公用帧中继网络互连局域网,在这种方式下,路由器只能作为用户设备工作在帧中继的DTE方式。

2. 组网图

图1-6 通过帧中继网络互连局域网

 

3. 配置步骤

(1)      配置Router A

# 配置接口IP地址。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ipv6 address 100::1/64

# 配置接口封装为帧中继。

[RouterA-Serial2/0] link-protocol fr

[RouterA-Serial2/0] fr interface-type dte

# 如果对端路由器支持逆向邻居发现功能,则配置动态地址映射。

[RouterA-Serial2/0] fr ipv6 ind

# 否则配置静态地址映射。

[RouterA-Serial2/0] fr map ipv6 100::2 50

[RouterA-Serial2/0] fr map ipv6 100::3 60

(2)      配置Router B

# 配置接口IP地址。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ipv6 address 100::2/64

# 配置接口封装为帧中继。

[RouterB-Serial2/0] link-protocol fr

[RouterB-Serial2/0] fr interface-type dte

# 如果对端路由器支持逆向地址解析功能,则配置动态地址映射。

[RouterB-Serial2/0] fr ipv6 ind

# 否则配置静态地址映射。

[RouterB-Serial2/0] fr map ipv6 100::1 70

(3)      配置Router C

# 配置接口IP地址。

<RouterC> system-view

[RouterC] interface serial 2/0

[RouterC-Serial2/0] ipv6 address 100::3/64

# 配置接口封装为帧中继。

[RouterC-Serial2/0] link-protocol fr

[RouterC-Serial2/0] fr interface-type dte

# 如果对端路由器支持逆向地址解析功能,则配置动态地址映射。

[RouterC-Serial2/0] fr ipv6 ind

# 否则配置静态地址映射。

[RouterC-Serial2/0] fr map ipv6 100::1 80

1.7.3  通过专线互连局域网

1. 组网需求

两台路由器通过串口直连,Router A工作在帧中继的DCE方式,Router B工作在帧中继的DTE方式。

2. 组网图

图1-7 通过专线互连局域网

 

3. 配置步骤

方法一:采用主接口方式

(1)      配置Router A

# 配置接口IP地址。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 202.38.163.251 255.255.255.0

# 配置接口的链路层协议为帧中继,工作在DCE方式。

[RouterA-Serial2/0] link-protocol fr

[RouterA-Serial2/0] fr interface-type dce

# 配置本地虚电路。

[RouterA-Serial2/0] fr dlci 100

(2)      配置Router B

# 配置接口IP地址。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 202.38.163.252 255.255.255.0

# 配置接口的链路层协议为帧中继。

[RouterB-Serial2/0] link-protocol fr

[RouterB-Serial2/0] fr interface-type dte

方法二:采用子接口方式

(1)      配置Router A

# 配置接口的链路层协议为帧中继,接口类型为DCE。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol fr

[RouterA-Serial2/0] fr interface-type dce

[RouterA-Serial2/0] quit

# 配置子接口IP地址及本地虚电路。

[RouterA] interface serial 2/0.1 p2p

[RouterA-Serial2/0.1] ip address 202.38.163.251 255.255.255.0

[RouterA-Serial2/0.1] fr dlci 100

(2)      配置Router B

# 配置接口的链路层协议为帧中继,接口类型为缺省的DTE。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol fr

[RouterB-Serial2/0] quit

# 配置子接口IP地址及本地虚电路。

[RouterB] interface serial 2/0.1 p2p

[RouterB-Serial2/0.1] ip address 202.38.163.252 255.255.255.0

[RouterB-Serial2/0.1] fr dlci 100

1.7.4  通过Annex G DLCI互连局域网

1. 组网需求

两台路由器Router A和Router B通过串口直连,要求使用帧中继DLCI传输X.25分组。Router A工作在帧中继的DCE方式,Router B工作在帧中继的DTE方式。

2. 组网图

图1-8 通过Annex G DLCI互连局域网

 

3. 配置步骤

(1)      配置Router A

# 创建一个X.25 Template。

<RouterA> system-view

[RouterA] x25 template vofr

# 配置本端X.25地址。

[RouterA-x25-vofr] x25 x121-address 10094

# 配置到达目地IP地址的X.25地址映射。

[RouterA-x25-vofr] x25 map ip 202.38.163.252 x121-address 20094

[RouterA-x25-vofr] quit

# 配置本端接口IP地址。

[RouterA] interface serial 2/0

[RouterA–Serial2/0] ip address 202.38.163.251 255.255.255.0

# 配置接口封装为帧中继。

[RouterA–Serial2/0] link-protocol fr

[RouterA–Serial2/0] fr interface-type dce

# 配置帧中继DLCI。

[RouterA–Serial2/0] fr dlci 100

# 配置DLCI为Annex G DLCI。

[RouterA-fr-dlci-Serial2/0-100] annexg dce

# 为DLCI指定X.25 Template。

[RouterA-fr-dlci-Serial2/0-100] x25-template vofr

[RouterA-fr-dlci-Serial2/0-100] quit

# 配置到达目的IP地址的帧中继地址映射。

[RouterA–Serial2/0] fr map ip 202.38.163.252 100

(2)      配置Router B

# 创建一个X.25 Template。

<RouterB> system-view

[RouterB] x25 template vofr

# 配置本端X.25地址。

[RouterB-x25-vofr] x25 x121-address 20094

# 配置到达目地IP地址的X.25地址映射。

[RouterB-x25-vofr] x25 map ip 202.38.163.251 x121-address 10094

[RouterB-x25-vofr] quit

# 配置本端接口IP地址。

[RouterB] interface serial 2/0

[RouterB–Serial2/0] ip address 202.38.163.252 255.255.255.0

# 配置接口封装为帧中继。

[RouterB–Serial2/0] link-protocol fr

[RouterB–Serial2/0] fr interface-type dte

# 配置帧中继DLCI。

[RouterB–Serial2/0] fr dlci 100

# 配置DLCI为Annex G DLCI。

[RouterB-fr-dlci-Serial2/0-100] annexg dte

# 为DLCI指定X.25 Template。

[RouterB-fr-dlci-Serial2/0-100] x25-template vofr

[RouterB-fr-dlci-Serial2/0-100] quit

# 配置到达目的IP地址的帧中继地址映射。

[RouterB–Serial2/0] fr map ip 202.38.163.251 100

1.8  帧中继常见配置错误举例

1.8.1  物理层处于down状态

1. 故障现象

物理层处于down状态。

2. 故障排除

·              检查物理线路是否正常。

·              检查对端设备是否正常运行。

1.8.2  物理层已经处于up状态,但链路层协议处于down状态

1. 故障现象

物理层已经处于up状态,但链路层协议处于down状态。

2. 故障排除

·              确认本地设备和对端设备是否都封装了帧中继协议。

·              如果两台设备直连,确认本地设备和对端设备是否配置成一端是帧中继DTE接口类型,一端是帧中继DCE接口类型。

·              确认两端配置的LMI协议类型是否相同。

·              如果以上检查都已经通过,可以打开帧中继LMI消息的监视开关(命令debugging fr lmi),看状态请求报文与状态报文是否一一对应。如果不一一对应,说明物理层数据收发不正确,请检查物理层的问题。

1.8.3  链路层up,但是ping不通对方

1. 故障现象

链路层协议处于up状态,但不能ping通对方。

2. 故障排除

·              确认两端设备是否都为对端配置(或产生)了正确的地址映射。

·              如果两端的IP地址不在同一个子网段,确认路由表是否有到达对端的路由。


2 帧中继压缩

2.1  帧中继压缩简介

帧中继压缩技术可以对帧中继报文进行压缩,从而能够节约网络带宽,降低网络负载,提高数据在帧中继网络上的传输效率。

设备支持FRF.9(FRF.9 stac压缩)功能和FRF.20(FRF.20 IPHC)功能。

2.1.1  FRF.9(FRF.9 stac压缩)

FRF.9把报文分为控制报文和数据报文两类。控制报文用于配置了压缩协议的DLCI两端的状态协商,协商成功后才能交换FRF.9数据报文。如果FRF.9控制报文发送超过10次,仍无法协商成功,将停止协商,压缩配置不起作用。

FRF.9只压缩数据报文和逆向地址解析协议报文,不压缩LMI报文。

FRF.9 stac压缩适用于低速链路。

2.1.2  FRF.20(FRF.20 IPHC)

帧中继IPHC(IP Header Compression,IP报文头压缩)技术可以对帧中继承载的IP报文进行头部压缩(包括RTP/TCP头压缩),主要用于语音报文的传送(语音报文属于RTP),从而能够节约网络带宽,降低网络负载,提高数据在帧中继网络上的传输效率。

FRF.20把报文分为控制报文和数据报文两类。控制报文用于配置了压缩协议的端口两端的状态协商,协商成功后才能交换FRF.20数据报文。如果FRF.20控制报文发送超过10次,仍无法协商成功,将停止协商,压缩配置不起作用。

FRF.20只压缩RTP报文和TCP ACK报文。

2.2  配置帧中继压缩

2.2.1  配置帧中继FRF.9 stac压缩

帧中继主接口是点到多点接口,而帧中继子接口则包括两种:点到点接口、点到多点接口。根据接口类型的不同,帧中继FRF.9 stac压缩的配置也不同:

·              如果子接口类型为点到点,则直接在子接口视图下配置命令fr compression frf9,启动FRF.9 stac压缩功能;

·              对于点到多点的帧中继接口或者子接口,是否进行帧中继压缩是在创建静态地址映射时配置的。

表2-1 配置帧中继FRF.9 stac压缩

操作

命令

说明

进入系统视图

system-view

-

进入帧中继主接口或者子接口视图

interface interface-type interface-number

interface serial interface-number.subnumber

-

配置帧中继FRF.9 stac压缩(根据接口类型选择其一)

当子接口类型为点到点,允许子接口进行FRF.9 stac压缩

fr compression frf9

可选

在缺省情况下,不允许接口进行FRF.9 stac压缩

当接口类型为点到多点时,在增加静态地址映射时配置允许FRF.9 stac压缩

fr map ip { ip-address [ mask ] | default } dlci-number [ broadcast | [ ietf | nonstandard ] ] * compression frf9

可选

 

说明

·          通信设备两端必须同时配置帧中继FRF.9 stac压缩,帧中继FRF.9 stac压缩功能才能生效。

·          只能在点到点类型的帧中继子接口下配置fr compression frf9命令,且报文封装类型必须是IETF。在配置fr compression frf9命令前,必须先配置子接口的DLCI。

·          配置和删除帧中继FRF.9 stac压缩功能后,需要shutdown/undo shutdown主接口,才能使配置生效。

·          FRF.9 stac压缩有一个同步的过程。压缩时如果报文乱序,通常会压缩不成功。

 

2.2.2  配置帧中继FRF.20 IP头压缩

帧中继特性提供IP头压缩功能,包括RTP/TCP头压缩。既可以在接口指定IP头压缩功能,也可以在配置静态地址映射时指定IP头压缩功能。

表2-2 配置帧中继FRF.20 IP头压缩

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置帧中继FRF.20 IP头压缩(两者选择其一)

允许接口进行IP头压缩,并提供IP头压缩功能选项

fr compression iphc

可选

缺省情况下,不允许接口进行FRF.20 IP头压缩

fr iphc { nonstandard | rtp-connections number1 | tcp-connections number2 | tcp-include }

可选

缺省情况下,不提供FRF.20 IP头压缩

增加一条静态地址映射时指定IP头压缩

fr map ip { ip-address [ mask ] | default } dlci-number [ broadcast | [ ietf | nonstandard ] ] * compression iphc connections number

可选

缺省情况下,系统没有配置静态地址映射

 

2.3  帧中继压缩显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后帧中继压缩的运行情况,通过查看显示信息验证配置的效果。

表2-3 帧中继压缩显示和维护

操作

命令

查看帧中继FRF.9压缩的统计信息

display fr compress [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

显示帧中继FRF.20压缩的统计信息

display fr iphc [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

 

2.4  帧中继压缩典型配置举例

2.4.1  帧中继FRF.9 stac压缩配置举例

1. 组网需求

Router A和Router B通过帧中继网络相连,在它们之间启用帧中继压缩功能(FRF.9)。

2. 组网图

图2-1 配置帧中继FRF.9 stac压缩组网图

 

3. 配置步骤

(1)      配置Router A

# 配置接口封装为帧中继。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol fr

# 配置接口的IP地址。

[RouterA-Serial2/0] ip address 10.110.40.1 255.255.255.0

# 配置接口工作在DTE方式。

[RouterA-Serial2/0] fr interface-type dte

# 使能帧中继FRF.9压缩。

[RouterA-Serial2/0] fr map ip 10.110.40.2 100 compression frf9

(2)      配置Router B

# 配置接口封装为帧中继。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol fr

# 配置接口的IP地址。

[RouterB-Serial2/0] ip address 10.110.40.2 255.255.255.0

# 配置接口工作在DTE方式。

[RouterB-Serial2/0] fr interface-type dte

# 使能帧中继FRF.9压缩。

[RouterB-Serial2/0] fr map ip 10.110.40.1 100 compression frf9

(3)      检验配置结果

# 从Router A上ping Router B。

<RouterA> ping 10.110.40.2

  PING 10.110.40.2: 56  data bytes, press CTRL_C to break

    Reply from 10.110.40.2: bytes=56 Sequence=1 ttl=255 time=13 ms

    Reply from 10.110.40.2: bytes=56 Sequence=2 ttl=255 time=12 ms

    Reply from 10.110.40.2: bytes=56 Sequence=3 ttl=255 time=12 ms

    Reply from 10.110.40.2: bytes=56 Sequence=4 ttl=255 time=12 ms

    Reply from 10.110.40.2: bytes=56 Sequence=5 ttl=255 time=12 ms

 

  --- 10.110.40.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 12/12/13 ms

# 在Router A上查看压缩报文的信息。

<RouterA> display fr compress

Serial2/0

 -DLCI:100

    enable frame-relay compression

    uncompressed bytes send/receive : 595/595

    compressed bytes send/receive : 159/157

    1 min  avg ratio send/receive :  0.000/0.000

    5 min  avg ratio send/receive :  0.267/0.264

2.4.2  帧中继FRF.20 IP头压缩配置举例

1. 组网需求

Router A、Router B和Router C通过帧中继链路相连,在Router B和Router C之间启用帧中继压缩功能(FRF.20 IP)。

2. 组网图

图2-2 配置帧中继FRF.20 IP头压缩组网图

 

3. 配置步骤

(1)      配置Router A

# 配置接口封装为帧中继。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol fr

# 配置接口的IP地址。

[RouterA-Serial2/0] ip address 10.1.1.1 24

# 配置接口工作在DTE方式。

[RouterA-Serial2/0] fr interface-type dte

[RouterA-Serial2/0] quit

# 配置一条静态路由,目的IP地址是12.1.1.2/24,下一跳IP地址为10.1.1.2。

[RouterA] ip route-static 12.1.1.2 24 10.1.1.2

(2)      配置Router B

# 配置Serial2/0接口封装为帧中继。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol fr

# 配置Serial2/0接口的IP地址。

[RouterB-Serial2/0] ip address 10.1.1.2 24

# 配置Serial2/0接口工作在DCE方式。

[RouterB-Serial2/0] fr interface-type dce

# 配置帧中继DLCI。

[RouterB-Serial2/0] fr dlci 100

[RouterB-fr-dlci-Serial2/0-100] quit

[RouterB-Serial2/0] quit

# 配置Serial2/1接口封装为帧中继。

[RouterB] interface serial 2/1

[RouterB-Serial2/1] link-protocol fr

# 配置Serial2/1接口的IP地址。

[RouterB-Serial2/1] ip address 12.1.1.1 24

# 配置Serial2/1接口工作在DCE方式。

[RouterB-Serial2/1] fr interface-type dce

# 配置帧中继DLCI。

[RouterB-Serial2/1] fr dlci 100

[RouterB-fr-dlci-Serial2/1-100] quit

# 在Serial2/1接口使能FRF.20压缩功能,并配置进行RTP压缩时包含TCP头压缩。

[RouterB-Serial2/1] fr compression iphc

[RouterB-Serial2/1] fr iphc tcp-include

(3)      配置Router C

# 配置接口封装为帧中继。

<RouterC> system-view

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol fr

# 配置接口的IP地址。

[RouterC-Serial2/0] ip address 12.1.1.2 24

# 配置接口工作在DTE方式。

[RouterC-Serial2/0] fr interface-type dte

# 使能FRF.20压缩功能,并配置进行RTP压缩时包含TCP头压缩。

[RouterB-Serial2/0] fr compression iphc

[RouterB-Serial2/0] fr iphc tcp-include

[RouterC-Serial2/0] quit

# 配置一条静态路由,目的IP地址是10.1.1.1/24,下一跳IP地址为12.1.1.1。

[RouterC] ip route-static 10.1.1.1 24 12.1.1.1

(4)      检验配置结果

# 在Router A上Telnet登录Router C。

<RouterA> telnet 12.1.1.2

Trying 12.1.1.2 ...

Press CTRL+K to abort

Connected to 12.1.1.2 ...

******************************************************************************

* Copyright (c) 2004-2009 Hangzhou H3C Tech. Co., Ltd. All rights reserved.  *

* Without the owner's prior written consent,                                 *

* no decompiling or reverse-engineering shall be allowed.                    *

******************************************************************************

# 在Router B上查看压缩报文的信息。

<RouterB> display fr iphc

Serial2/1 -DLCI:100

  RTP header compression information:

    Compression:

        Total packets:               0 , Packets compressed:               0

        Link searches:               0 , Search missed     :               0

        Bytes saved  :               0 , Bytes sent        :               0

    Decompression:

        Total packets:               0 , Packets compressed:               0

        Errors       :               0

    Compression-connections: 16 , Decompression-connections: 16

 

  Information of TCP header compression:

    Compression:

        Total packets:              31 , Packets compressed:              28

        Link searches:               0 , Search Missed     :               2

        Bytes saved  :             976 , Bytes sent        :             314

    Decompression:

        Total packets:               0 , Packets compressed:               0

        Errors       :               0

    Compression-connections: 16 , Decompression-connections: 16

 


3 多链路帧中继

3.1  多链路帧中继简介

多链路帧中继(Multilink Frame Relay,MFR)是为帧中继用户提供的一种性价比比较高的带宽解决方案,它基于帧中继论坛的FRF.16协议,实现在DTE/DCE接口下的多链路帧中继功能。

多链路帧中继特性提供一种逻辑接口:MFR接口。它由多个帧中继物理链路捆绑而成,每个MFR接口下还可以配置子接口,从而可以在帧中继网络上提供高速率、大带宽的链路。

配置MFR接口时,为使捆绑后的接口带宽最大,建议对同一个MFR接口捆绑速率一致的物理接口,以减少管理开销。

1. Bundle和Bundle link

捆绑(bundle)和捆绑链路(bundle link)是多链路帧中继的两个基本概念。

一个MFR接口对应一个捆绑,一个捆绑中可以包含多个捆绑链路,一个捆绑链路对应着一个物理接口。捆绑对它的捆绑链路进行管理。二者的关系如图3-1所示。

图3-1 Bundle和Bundle link示意图

 

对于实际的物理层可见的是捆绑链路;对于实际的数据链路层可见的是捆绑。

2. MFR接口和物理接口

MFR接口是逻辑接口,多个物理接口可以捆绑成一个MFR接口。一个MFR接口对应一个捆绑,一个物理接口对应一个捆绑链路。对捆绑和捆绑链路的配置实际就是对MFR接口和物理接口的配置。

MFR接口的功能和配置与普通意义上的FR接口相同,也支持DTE、DCE接口类型,并支持QoS队列机制。当物理接口捆绑进MFR接口后,它原来配置的网络层和帧中继链路层参数将不再起作用,而是使用此MFR接口的参数。

3.2  配置多链路帧中继

3.2.1  配置MFR捆绑

表3-1 配置MFR捆绑

操作

命令

说明

 

进入系统视图

system-view

-

 

创建MFR接口并进入该MFR接口视图

interface mfr { interface-number | interface-number.subnumber [ p2mp | p2p ] }

必选

缺省情况下,没有创建MFR接口或子接口

在创建MFR子接口之前,MFR主接口必须已经存在,否则无法创建成功

 

设置捆绑标识符

mfr bundle-name [ name ]

可选

缺省情况下,捆绑标识符是“MFR帧中继捆绑编号”,例如:MFR4

需要注意的是,设置标识符时不允许出现“MFR数字”形式

 

使能MFR分片功能

mfr fragment

可选

缺省情况下,禁止多链路帧中继捆绑的分片功能

 

设置MFR滑动窗口的尺寸

mfr window-size number

可选

缺省情况下,滑动窗口尺寸等于MFR捆绑的物理接口数

 

设置捆绑链路允许的最大分片

mfr fragment-size bytes

可选

缺省情况下,最大分片是300字节

 

配置MFR接口的期望带宽

bandwidth bandwidth-value

可选

配置MFR接口的其它参数

请参见“1.2  帧中继配置任务简介

可选

fr interface-type命令只能用于MFR主接口,不能用于MFR子接口

fr inarp命令只能用于MFR主接口,不能用于MFR子接口

 

 

3.2.2  配置捆绑链路

表3-2 配置捆绑链路

操作

命令

说明

进入系统视图

system-view

-

进入帧中继接口视图

interface interface-type interface-number

-

将当前接口配置为一个多链路帧中继捆绑的捆绑链路,并将其捆绑到指定的MFR接口

link-protocol fr mfr interface-number

必选

缺省情况下,接口不与任何MFR接口捆绑

设置捆绑链路标识符名称

mfr link-name [ name ]

可选

缺省情况下,捆绑链路标识符是当前接口的名称

设置捆绑链路的hello消息发送周期

mfr timer hello seconds

可选

缺省情况下,捆绑链路的hello消息发送周期为10秒

设置捆绑链路重发hello消息前等待hello应答消息的时间

mfr timer ack seconds

可选

缺省情况下,重发hello消息前等待hello应答消息的时间为4秒

设置捆绑链路最多可重发hello消息的次数

mfr retry number

可选

缺省情况下,最多可重发hello消息2次

 

3.3  多链路帧中继显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后多链路帧中继的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除MFR接口的统计信息。

表3-3 多链路帧中继显示和维护

配置

命令

查看MFR接口的配置和状态信息

display interface mfr { interface-number | interface-number.subnumber } [ brief ] [ | { begin | exclude | include } regular-expression ]

display interface [ mfr ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

查看多链路帧中继捆绑和捆绑链路的配置和统计信息

display mfr [ interface interface-type interface-number | verbose ] [ | { begin | exclude | include } regular-expression ]

清除MFR接口的统计信息

reset counters interface [ mfr [ interface-number | interface-number.subnumber ] ]

 

3.4  多链路帧中继典型配置举例

3.4.1  多链路帧中继直连配置举例

1. 组网需求

路由器Router A和Router B通过串口Serial2/0和Serial2/1直连,使用多链路帧中继协议将两个串口捆绑以提供更大的带宽。

2. 组网图

图3-2 多链路帧中继直连组网图

 

3. 配置步骤

(1)      配置路由器Router A

# 创建并配置MFR接口4。

<RouterA> system-view

[RouterA] interface mfr 4

[RouterA-MFR4] ip address 10.140.10.1 255.255.255.0

[RouterA-MFR4] fr interface-type dte

[RouterA-MFR4] fr map ip 10.140.10.2 100

[RouterA-MFR4] quit

# 将接口Serial2/0和Serial2/1捆绑至MFR4。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol fr mfr 4

[RouterA-Serial2/0] quit

[RouterA] interface serial 2/1

[RouterA-Serial2/1] link-protocol fr mfr 4

(2)      配置路由器Router B

# 创建并配置MFR接口4。

<RouterB> system-view

[RouterB] interface mfr 4

[RouterB-MFR4] ip address 10.140.10.2 255.255.255.0

[RouterB-MFR4] fr interface-type dce

[RouterB-MFR4] fr dlci 100

[RouterB-fr-dlci-MFR4-100] quit

[RouterB-MFR4] fr map ip 10.140.10.1 100

[RouterB-MFR4] quit

# 将接口Serial2/0和Serial2/1捆绑至MFR4。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol fr mfr 4

[RouterB-Serial2/0] quit

[RouterB] interface serial 2/1

[RouterB-Serial2/1] link-protocol fr mfr 4

3.4.2  多链路帧中继交换配置举例

1. 组网需求

路由器Router A和Router C通过MFR连接到Router B,Router B使能多链路帧中继交换。

2. 组网图

图3-3 多链路帧中继交换组网图

 

3. 配置步骤

(1)      配置Router A

# 配置MFR1接口。

<RouterA> system-view

[RouterA] interface mfr 1

[RouterA-MFR1] ip address 1.1.1.1 255.0.0.0

[RouterA-MFR1] quit

# 将接口Serial2/0和Serial2/1添加到MFR1接口。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol fr mfr 1

[RouterA-Serial2/0] quit

[RouterA] interface serial 2/1

[RouterA-Serial2/1] link-protocol fr mfr 1

[RouterA-Serial2/1] quit

(2)      配置Router B

# 使能帧中继交换功能。

<RouterB> system-view

[RouterB] fr switching

# 配置MFR1接口。

[RouterB] interface mfr 1

[RouterB-MFR1] fr interface-type dce

[RouterB-MFR1] fr dlci 100

[RouterB-fr-dlci-MFR1-100] quit

[RouterB-MFR1] quit

# 配置MFR2接口。

[RouterB] interface mfr 2

[RouterB-MFR2] fr interface-type dce

[RouterB-MFR2] fr dlci 200

[RouterB-fr-dlci-MFR2-200] quit

[RouterB-MFR2] quit

# 将接口Serial2/0和Serial2/1添加到MFR1接口。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol fr mfr 1

[RouterB] quit

[RouterB] interface serial 2/1

[RouterB-Serial2/1] link-protocol fr mfr 1

[RouterB-Serial2/1] quit

# 将接口Serial2/2和Serial2/3添加到MFR2接口。

[RouterB] interface serial 2/2

[RouterB-Serial2/2] link-protocol fr mfr 2

[RouterB-Serial2/2] li quit

[RouterB] interface serial 2/3

[RouterB-Serial2/3] link-protocol fr mfr 2

[RouterB-Serial2/3] quit

# 配置帧中继交换静态路由。

[RouterB] fr switch pvc1 interface mfr 1 dlci 100 interface mfr 2 dlci 200

(3)      配置Router C

# 配置MFR2接口。

<RouterC> system-view

[RouterC] interface mfr 2

[RouterC-MFR2] ip address 1.1.1.2 255.0.0.0

[RouterC-MFR2] quit

# 将接口Serial2/0和Serial2/1添加到MFR2接口。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol fr mfr 2

[RouterC-Serial2/0] quit

[RouterC] interface serial 2/1

[RouterC-Serial2/1] link-protocol fr mfr 2

 


4 PPPoFR

4.1  PPPoFR简介

PPPoFR(PPP over Frame Relay)提供了帧中继站点间利用PPP特性(诸如LCP、NCP、验证、MP分片等)的一种方法,PPPoFR允许路由器在帧中继网上建立一个端到端的PPP会话。

4.2  配置PPPoFR

表4-1 配置PPPoFR

操作

命令

说明

进入系统视图

system-view

-

创建虚拟模板接口并进入虚拟模板接口视图

interface virtual-template interface-number

-

为接口配置IP地址

ip address ip-address { mask-length | mask }

必选

退回系统视图

quit

-

进入相应的帧中继接口视图

interface interface-type interface-number

-

配置接口封装的链路层协议为帧中继

link-protocol fr [ ietf | nonstandard ]

必选

配置一条帧中继DLCI

fr dlci dlci-number

必选(DTE侧可以不配置)

退回帧中继接口视图

quit

-

把帧中继DLCI映射到PPP

fr map ppp dlci-number  interface virtual-template interface-number

必选

 

对于Virtual-Template接口,如果配置静态路由,请指定下一跳而不要指定出接口。如果必须指定出接口的话,请保证Virtual-Template下绑定的物理接口有效,从而保证报文能够正常传输。

 

4.3  PPPoFR显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后PPPoFR的运行情况,通过查看显示信息验证配置的效果。

表4-2 PPPoFR显示和维护

操作

命令

显示PPPoFR MAP及其状态

display fr map-info pppofr  [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

 

4.4  PPPoFR典型配置举例

1. 组网需求

Router A和Router B通过帧中继网络相连,在它们之间启用PPPoFR功能。

2. 组网图

图4-1 配置PPPoFR组网图

 

3. 配置步骤

(1)      配置Router A

# 创建并配置虚拟模板接口Virtual-Template 1。

<RouterA> system-view

[RouterA] interface virtual-template 1

[RouterA-Virtual-Template1] ip address 10.1.1.2 255.0.0.0

[RouterA-Virtual-Template1] quit

# 配置接口Serial2/0。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol fr

# 在接口Serial2/0上创建PPP映射。

[RouterA-Serial2/0] fr map ppp 16 interface virtual-template 1

(2)      配置Router B

# 创建并配置虚拟模板接口Virtual-Template1。

<RouterB> system-view

[RouterB] interface virtual-template 1

[RouterB-Virtual-Template1] ip address 10.1.1.1 255.0.0.0

[RouterB-Virtual-Template1] quit

# 配置接口Serial2/0。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol fr

[RouterB-Serial2/0] fr interface-type dce

# 创建DLCI 16。

[RouterB-Serial2/0] fr dlci 16

[RouterB-fr-dlci-Serial2/0-16] quit

# 在接口Serial2/0上创建PPP映射。

[RouterB-Serial2/0] fr map ppp 16 interface virtual-template 1

 


5 MPoFR

5.1  MPoFR简介

MPoFR(Multilink PPP over Frame Relay)实际上就是PPPoFR利用MP分片的一种情形,使得在帧中继站点间能够承载MP分片。

配置MPoFR,需要分别在两个(或者多个)虚拟模板上配置好PPPoFR(注意不需要在虚拟模板上配置IP地址),然后将这些虚拟模板绑定到另外一个配置了PPP MP的虚拟模板上。

5.2  配置MPoFR

表5-1 配置MPoFR

操作

命令

说明

进入系统视图

system-view

-

创建一个PPP MP的虚拟模板接口

interface virtual-template interface-number-mp

-

配置本接口的可用带宽

qos max-bandwidth bandwidth

可选

缺省情况下,虚拟模板接口的可用带宽为64kbps

配置本接口的IP地址

ip address ip-address { mask-length | mask }

必选

退回到系统视图

quit

-

在两个(或者多个)虚拟模板上配置好PPPoFR,并且绑定到配置了PPP MP的虚拟模板接口上

创建虚拟模板接口并进入虚拟模板接口视图

interface virtual-template interface-number

-

在虚拟模板接口上配置MP

ppp mp virtual-template interface-number-mp

必选

退回系统视图

quit

-

进入相应的帧中继接口视图

interface interface-type interface-number

-

配置接口链路层协议为帧中继

link-protocol fr [ ietf | nonstandard ]

必选

配置一条帧中继DLCI

fr dlci dlci-number

必选(DTE侧可以不配置)

退回帧中继接口视图

quit

-

把帧中继DLCI映射到PPP

fr map ppp dlci-number  interface virtual-template interface-number

必选

退回系统视图

quit

-

 

·          为保证VT(Virtual-Template,虚拟模板)接口上报文传输质量,可在VT接口上配置队列无关的QoS特性,在FR接口上配置队列相关的QoS特性。详细内容请参见“ACL和QoS配置指导”中的“拥塞管理”。

·          对于VT接口,如果配置静态路由,请指定下一跳而不要指定出接口。如果必须指定出接口的话,请保证VT接口下绑定的物理接口有效,从而保证报文能够正常传输。

·          MP的相关配置请参见“二层技术-广域网接入配置指导”中的“PPP和MP”。

 

5.3  MPoFR典型配置举例

5.3.1  MPoFR典型配置举例

1. 组网需求

ATM骨干网以FR作为接入网,支撑多种业务传输。在FR链路的单条虚电路上可同时传输多种业务数据。

组网如图5-1所示,Router A的Serial2/0的带宽为64K,Host A向Host C发送一条数据业务流1,Host B向Host D发送一条数据业务流2,同时Telephone之间还存在一条语音业务流。

Router B的Serial2/0的带宽为64K,Host C向Host A发送一条数据业务流3,Host D向Host B发送一条数据业务流4,同时Telephone之间还存在一条语音业务流。

为了保证语音质量,需对数据报文进行分片处理,以减小语音延迟抖动。这里采用MPoFR,用MP将数据报文分片。

2. 组网图

图5-1 MPoFR应用于复杂业务的配置举例

 

3. 配置步骤

本例只配置了与MPoFR相关的配置,各项业务及路由等其它配置请用户自行配置。

 

(1)      配置路由器Router A

 # 创建并配置虚拟模板接口Virtual-Template1。

<RouterA> system-view

[RouterA] interface virtual-template 1

[RouterA-Virtual-Template1] ppp mp virtual-template 3

[RouterA-Virtual-Template1] quit

# 创建并配置虚拟模板接口Virtual-Template2。

[RouterA] interface virtual-template 2

[RouterA-Virtual-Template2] ppp mp virtual-template 3

[RouterA-Virtual-Template2] quit

# 创建并配置虚拟模板接口Virtual-Template3。

[RouterA] interface virtual-template 3

[RouterA-Virtual-Template3] ppp mp lfi

[RouterA-Virtual-Template3] qos max-bandwidth 64

[RouterA-Virtual-Template3] ip address 1.1.6.1 255.255.255.0

# 在接口下为指定的DLCI映射PPP虚拟模板。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] fr dlci 100

[RouterA-fr-dlci-Serial2/0-100] quit

[RouterA-Serial2/0] fr map ppp 100 interface virtual-template 1

[RouterA-Serial2/0] fr dlci 200

[RouterA-fr-dlci-Serial2/0-200] quit

[RouterA-Serial2/0] fr map ppp 200 interface virtual-template 2

(2)      配置路由器Router B

 # 创建并配置虚拟模板接口Virtual-Template1。

<RouterB> system-view

[RouterB] interface virtual-template 1

[RouterB-Virtual-Template1] ppp mp virtual-template 3

[RouterB-Virtual-Template1] quit

# 创建并配置虚拟模板接口Virtual-Template2。

[RouterB] interface virtual-template 2

[RouterB-Virtual-Template2] ppp mp virtual-template 3

[RouterB-Virtual-Template2] quit

# 创建并配置虚拟模板接口Virtual-Template3。

[RouterB] interface virtual-template 3

[RouterB-Virtual-Template3] ppp mp lfi

[RouterB-Virtual-Template3] qos max-bandwidth 64

[RouterB-Virtual-Template3] ip address 1.1.6.2 255.255.255.0

# 在接口下为指定的DLCI映射PPP虚拟模板。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] fr dlci 100

[Router-fr-dlci-Serial2/0-100] quit

[RouterB-Serial2/0] fr map ppp 100 interface virtual-template 1

[RouterB-Serial2/0] fr dlci 200

[Router-fr-dlci-Serial2/0-200] quit

[RouterB-Serial2/0] fr map ppp 200 interface virtual-template 2

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!