国家 / 地区

04-二层技术-广域网接入配置指导

11-网桥配置

本章节下载  (474.19 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Operation_Manual/H3C_MSR_CG(V5)-R2516-V1.16/04/201807/1094065_30005_0.htm

11-网桥配置


1 网桥

MSR系列路由器各款型对于本节所描述的特性支持情况有所不同,详细差异信息如下:

·     目前设备只支持透明网桥,本文只介绍透明网桥。

·     不支持VLAN透明网桥功能,支持在以太网中的VLAN透传。

·     对于MIM-16FSW/DMIM-24FSW/FIC-16FSW/DFIC-24FSW接口卡,在配置了VLAN接口加入网桥组后,不能配置VLAN内丢弃未知组播报文的功能。

 

1.1  网桥简介

网桥(Bridge)是一种存储转发设备,用来在数据链路层连接局域网,并在局域网之间传递数据。在一些小型网络尤其是分布比较分散的网络中,使用网桥可以减少网络维护的成本,并且网络终端用户不需要对设备进行特别地设置。

在实际应用中,主要有四种类型的网桥:透明网桥、源地址路由网桥、转换网桥和源地址路由-转换网桥。目前,设备仅支持透明网桥。

透明网桥(Transparent Bridging)用于连接物理介质类型相同的局域网,它主要应用在以太网环境中。透明网桥通常都保存一张网桥表,该网桥表记录目的MAC地址与接口之间的对应关系。

设备支持的透明网桥具有如下特性:

·     支持以太网上的网桥功能

·     支持在PPP和HDLC链路上的网桥功能

·     支持X.25链路上的网桥功能

·     支持帧中继链路上的网桥功能

·     支持VLAN透明网桥功能

·     同时支持路由和网桥功能

1.1.1  网桥的主要功能

1. 获取地址表

网桥依据网桥表进行转发,网桥表由MAC地址和接口两部分组成。网桥与物理网段相连时,会监测该物理网段上的所有以太网帧,一旦监测到某个接口上节点发来的以太网帧,就提取出该帧的源MAC地址,并将该MAC地址与接收该帧的接口之间的对应关系加入到网桥地址表中。

图1-1所示:Host A、B、C和D分布在两个局域网中,Host A与网桥接口1相连,Host B与网桥接口1相连。某一时刻,当Host A向Host B发送以太网帧时,网桥接口1和Host B都将收到这个帧。

图1-1 Host A将信息传递至Ethernet 1上的Host B

 

网桥收到这个以太网帧后,就知道Host A是与网桥接口1相连的(因为从接口1收到了该帧),于是Host A的MAC地址与网桥接口1之间的对应关系就被加入到网桥表中。如图1-2所示:

图1-2 网桥得知Host A与接口1相连

 

当Host B对Host A的以太网帧作出响应后,网桥也能监测到Host B回应的以太网帧,并知道Host B也是与网桥接口1相连的(因为从接口1收到了该帧),于是Host B的MAC地址与网桥接口1之间的对应关系也被加入到网桥表中。如图1-3所示:

图1-3 网桥得知Host B也与接口1相连

 

最后,所有MAC地址与网桥接口的对应关系都会被网桥获取(假设所有的Host都在使用中)。如图1-4所示:

图1-4 最后的网桥地址表

 

2. 转发和过滤

网桥将根据下列三种情况对数据帧作出转发或不转发(即过滤)帧的决定:

·     若Host A向Host C发送以太网帧,网桥通过查找网桥表知道Host C与网桥接口2对应,就将该帧从接口2转发。如图1-5所示:

图1-5 转发

 

·     若Host A向Host B发送以太网帧,因Host B与Host A在同一个物理网段上,网桥对此帧进行过滤,不转发该帧。如图1-6所示:

图1-6 过滤(不转发)

 

·     若Host A向Host C发送以太网帧,而在网桥地址表中未找到关于Host C的MAC地址与接口的对应关系,网桥就会向除接收该帧的接口以外的其它接口进行转发。如图1-7所示:

图1-7 网桥表中未找到匹配MAC地址的情况

 

当网桥在某接口接收到广播帧或多播帧时,向其它接口进行转发。

 

1.2  网桥配置任务简介

表1-1 网桥配置任务简介

配置任务

说明

详细配置

配置网桥基本功能

必选

1.3 

配置网桥地址表

可选

1.4 

配置网桥路由功能

可选

1.5 

配置网桥透传VLAN ID功能

可选

1.6 

 

1.3  配置网桥基本功能

·     配置ATM透明桥时,需要在PVC上配置允许收发桥报文。

·     配置PPP透明桥时,需要在接口上配置接口封装的链路层协议为PPP。

·     配置MP透明桥时,需要在接口上配置接口封装的链路层协议为PPP,并创建虚拟模板接口,将物理接口与虚拟模板接口关联。

·     配置帧中继透明桥时,需要在接口上配置接口封装的链路层协议为帧中继,配置帧中继的接口类型(可选,缺省情况为DTE),配置虚电路。在建立帧中继透明桥时,需要配置桥地址到DLCI(Data Link Connection Identifier,数据链路连接标识符)地址的映射。

·     配置X.25透明桥时,需要在接口上配置接口的链路层协议为X.25,同时设置接口的工作模式及其数据报格式。在建立X.25透明桥时,需要配置桥地址到X.25的协议地址X.121地址的映射。

·     配置HDLC透明桥时,需要在接口上配置接口封装的链路层协议为HDLC。

·     配置VLAN透明桥时,需要配置以太网子接口的封装格式和相关联的VLAN ID。建立VLAN透明桥时,将已经配置好VLAN的以太网子接口加入网桥组。

 

表1-2 配置网桥基本功能

操作

命令

说明

进入系统视图

system-view

-

使能网桥功能

bridge enable

必选

缺省情况下,禁用网桥功能

使能网桥组

bridge bridge-set enable

必选

缺省情况下,未使能网桥组

进入接口视图

interface interface-type interface-number

-

配置将接口加入网桥组

bridge-set bridge-set

必选

缺省情况下,接口未加入到任何网桥组中

配置一条转发到网桥的帧中继映射

fr map bridge dlci broadcast

可选

配置帧中继透明桥

配置一条转发到网桥的X.25映射

x25 map bridge x121-address x.121-address broadcast

可选

配置X.25透明桥

配置PVC允许收发桥报文

interface atm { interface-number | interface-number.subnumber }

可选

配置ATM透明桥配置该命令时,如果同时配置map bridge virtual-ethernetmap bridge-group,则map bridge virtual-ethernet生效,map bridge-group失效。

pvc { pvc-name [ vpi/vci ] | vpi/vci }

map bridge-group broadcast

 

ATM的相关配置请参见“二层技术-广域网接入配置指导”中的“ATM”。

1.4  配置网桥地址表

一般情况下,网桥地址表根据该网桥获取的MAC地址和接口的对应关系动态生成。但管理员也可以手工配置一些静态地址表项,并且永远不会老化。

动态地址表的老化时间是指该表项从地址表中删除之前的生存时间,动态地址表项在地址表中保持的时间超过老化时间后,系统就将该表项从网桥地址表中删除。

表1-3 配置网桥地址表

操作

命令

说明

进入系统视图

system-view

-

打开动态地址学习功能

bridge bridge-set learning

可选

缺省情况下,动态地址学习功能打开,允许所有网桥组向动态地址表中添加动态地址表项

配置静态地址表项

bridge bridge-set mac-address mac-address { deny | permit } [ dlsw | interface interface-type interface-number ]

可选

缺省情况下,没有配置静态地址表项

配置动态地址表的老化时间

bridge aging-time seconds

可选

缺省情况下,动态地址表的老化时间为300秒

 

1.5  配置网桥路由功能

网桥路由功能提供了一种结合路由和桥接的转发方法。对于指定的协议数据,如果是在网桥端口之间进行通讯,则进行桥接转发;如果是需要与非网桥组内的网络进行通讯,则可以进行网络协议的路由转发。当集成的路由和桥接功能没有激活时,所有的协议数据只能够进行桥接处理。当集成的路由和桥接功能被使能后,就可以指定某种协议的报文既可以做桥接,又可以进行路由处理,通过命令配置进行灵活的切换。

bridge-template接口是一个虚拟的选路接口,可以配置各种网络层的属性。对于每个网桥组来说,只能有一个bridge-template接口。bridge-template接口的编号是它所代表的网桥组的编号。

缺省情况下,如果已经有以太网接口加入bridge-template接口对应的网桥组,bridge-template接口将借用网桥组中任意以太网接口的MAC地址。如果没有以太网接口加入bridge-template接口对应的网桥组,bridge-template接口将使用系统默认的MAC地址(前5字节由设备决定,以设备的实际情况为准;后1字节为接口对应的网桥组号)。

当在两台或两台以上设备上启用网桥组号相同的网桥组,并创建相应的bridge-template接口,且均没有以太网接口加入网桥组,则这些bridge-template接口将使用完全相同的默认MAC地址。造成MAC地址冲突,此时可以在不同bridge-template接口上配置不同的MAC地址。

表1-4 配置网桥路由功能

操作

命令

说明

进入系统视图

system-view

-

使能网桥路由功能

bridge routing-enable

必选

缺省情况下,禁用网桥的路由功能

配置网桥组对网络层协议的路由或桥接功能

bridge bridge-set routing { ip | ipx }

可选

缺省情况下,禁止网桥组对指定协议的路由功能

bridge bridge-set bridging { ip | ipx | others }

可选

缺省情况下,使能所有协议的桥接功能

创建bridge-template接口,并进入bridge-template接口视图,将指定的网桥组连接到路由的网络中

interface bridge-template bridge-set

必选

缺省情况下,未配置bridge-template接口

配置接口的描述字符串

description text

可选

缺省情况下,接口的描述字符串为“该接口的接口名 Interface”

配置接口的IP地址

ip address ip-address { mask | mask-length } [ sub ]

必选

缺省情况下,没有为接口配置IP地址

配置接口的MAC地址

mac-address mac-address

可选

缺省情况下,如果已经有以太网接口加入bridge-template接口对应的网桥组,bridge-template接口将借用网桥组中随机以太网接口的MAC地址。如果没有以太网接口加入bridge-template接口对应的网桥组,bridge-template接口将使用系统默认的MAC地址

配置接口的期望带宽

bandwidth bandwidth-value

可选

恢复接口的缺省配置

default

可选

打开接口

undo shutdown

可选

缺省情况下,接口为打开状态

 

1.6  配置网桥透传VLAN ID功能

当两端Trunk接口之间需要穿越以太网连接时,配置网桥透传VLAN ID功能将使所经过以太网中的设备对输入报文VLAN ID不作任何操作。这样相当于将两台设备的Trunk接口直接相连,避免在穿越的过程遇到不支持VLAN ID传递时将VLAN ID丢弃的情况发生。

表1-5 配置网桥透传VLAN ID功能

操作

命令

说明

进入系统视图

system-view

-

使能网桥功能

bridge enable

必选

缺省情况下,禁用网桥功能

使能网桥组

bridge bridge-set enable

必选

缺省情况下,未使能网桥组

进入接口视图

interface interface-type interface-number

-

配置将接口加入网桥组

bridge-set bridge-set

必选

缺省情况下,接口未加入到任何网桥组中

配置网桥透传VLAN ID功能

bridge vlanid-transparent-transmit enable

必选

缺省情况下,VLAN ID透传功能处于关闭状态

 

·     在子接口不建议使用该功能。

·     该功能对于DLSw不支持。

·     VLAN接口不支持此功能。

·     在接口上配置VLAN ID透传功能前,必须将该接口加入到桥组中,否则系统将提示用户该接口没有被加入到桥组中。

 

1.7  网桥显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示网桥配置后的运行情况,通过查看显示信息验证配置的效果。

在用户视图下,执行reset命令可以清除相关信息。

表1-6 网桥显示和维护

操作

命令

显示网桥组信息

display bridge information [ bridge-set bridge-set ] [ | { begin | exclude | include } regular-expression ]

显示bridge-template接口的状态

display interface bridge-template interface-number [ brief ] [ | { begin | exclude | include } regular-expression ]

display interface [ bridge-template ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

显示MAC地址转发表的信息

display bridge address-table [ bridge-set bridge-set | dlsw | interface interface-type interface-number | mac mac-address] [ dynamic | static ] [ | { begin | exclude | include } regular-expression ]

显示网桥组中接口的流量统计信息

display bridge traffic [ bridge-set bridge-set | dlsw | interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

清除动态MAC地址转发表项

reset bridge address-table [ bridge-set bridge-set | dlsw | interface interface-type interface-number ]

清除网桥组中接口的流量统计信息

reset bridge traffic [ bridge-set bridge-set | dlsw | interface interface-type interface-number ]

清除bridge-template接口的统计信息

reset counters interface [ bridge-template [ interface-number ] ]

 

1.8  透明网桥典型配置举例

1.8.1  ATM透明网桥举例

1. 组网需求

图1-8所示Router A与Router B通过ATM接口直连环境下,这两台路由器分别配置透明网桥功能,并实现路由器两边LAN 1和LAN 2能够互相访问。

2. 组网图

图1-8 ATM透明网桥组网图

 

3. 配置步骤

配置Router A

[RouterA] bridge enable

[RouterA] bridge 1 enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] bridge-set 1

[RouterA-Ethernet1/1] interface atm 5/0

[RouterA-Atm5/0] pvc 32/50

[RouterA-atm-pvc-Atm5/0-32/50] map bridge-group broadcast

[RouterA-atm-pvc-Atm5/0-32/50] quit

[RouterA-Atm5/0] bridge-set 1

配置Router B

[RouterB] bridge enable

[RouterB ]bridge 1 enable

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] bridge-set 1

[RouterB-Ethernet1/1] interface atm 5/0

[RouterB-Atm5/0] pvc 32/50

[RouterB-atm-pvc-Atm5/0-32/50] map bridge-group broadcast

[RouterB-atm-pvc-Atm5/0-32/50] quit

[RouterB-Atm5/0] bridge-set 1

1.8.2  PPP透明网桥举例

1. 组网需求

图1-9所示Router A和Router B之间通过PPP相连环境下,这两台路由器分别配置透明网桥功能,并实现路由器两边所在不同网段的LAN 1和LAN 2能够互相访问。

2. 组网图

图1-9 配置PPP透明网桥组网图

 

3. 配置步骤

配置Router A

<RouterA> system-view

[RouterA] bridge enable

[RouterA] bridge 1 enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] bridge-set 1

[RouterA-Ethernet1/1] quit

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol ppp

[RouterA-Serial2/0] bridge-set 1

配置Router B

<RouterB> system-view

[RouterB] bridge enable

[RouterB] bridge 1 enable

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] bridge-set 1

[RouterB-Ethernet1/1] quit

[RouterB] interface Serial 2/0

[RouterB-Serial2/0] link-protocol ppp

[RouterB-Serial2/0] bridge-set 1

1.8.3  MP透明网桥配置举例

1. 组网需求

图1-10所示Router A和Router B之间通过MP捆绑相连环境下,这两台路由器分别配置透明网桥功能,并实现路由器两边所在不同网段的LAN 1和LAN 2能够互相访问。

1. 组网图

图1-10 配置MP透明网桥组网图

 

2. 配置步骤

配置Router A

<RouterA> system-view

[RouterA] bridge enable

[RouterA] bridge 1 enable

[RouterA] interface virtual-template 1

[RouterA-Virtual-Template1] bridge-set 1

[RouterA-Virtual-Template1] quit

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] bridge-set 1

[RouterA-Ethernet1/1] quit

[RouterA] interface serial 2/1

[RouterA-Serial2/1] link-protocol ppp

[RouterA-Serial2/1] ppp mp virtual-template 1

[RouterA-Serial2/1] quit

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol ppp

[RouterA-Serial2/0] ppp mp virtual-template 1

配置Router B

<RouterB> system-view

[RouterB] bridge enable

[RouterB] bridge 1 enable

[RouterB] interface virtual-template 1

[RouterB-Virtual-Template1] bridge-set 1

[RouterB-Virtual-Template1] quit

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] bridge-set 1

[RouterB-Ethernet1/1] quit

[RouterB] interface serial 2/1

[RouterB-Serial2/1] link-protocol ppp

[RouterB-Serial2/1] ppp mp virtual-template 1

[RouterB-Serial2/1] quit

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol ppp

[RouterB-Serial2/0] ppp mp virtual-template 1

1.8.4  帧中继透明网桥举例

1. 组网需求

图1-11所示Router A和Router B之间通过帧中继相连环境下,这两台路由器分别配置透明网桥功能,并实现路由器两边所在不同网段的LAN 1和LAN 2能够互相访问。

2. 组网图

图1-11 配置帧中继透明网桥组网图

 

3. 配置步骤

配置Router A

<RouterA> system-view

[RouterA] bridge enable

[RouterA] bridge 1 enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] bridge-set 1

[RouterA-Ethernet1/1] quit

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol fr

[RouterA-Serial2/0] fr interface-type dce

[RouterA-Serial2/0] fr dlci 50

[RouterA-Serial2/0] bridge-set 1

[RouterA-Serial2/0] fr map bridge 50 broadcast

配置Router B

<RouterB> system-view

[RouterB] bridge enable

[RouterB] bridge 1 enable

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] bridge-set 1

[RouterB-Ethernet1/1] quit

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol fr

[RouterB-Serial2/0] fr interface-type dte

[RouterB-Serial2/0] bridge-set 1

[RouterB-Serial2/0] fr map bridge 50 broadcast

1.8.5  X.25透明网桥举例

1. 组网需求

图1-12所示Router A和Router B之间通过X.25相连环境下,这两台路由器分别配置透明网桥功能,并实现路由器两边所在不同网段的LAN 1和LAN 2能够互相访问。

2. 组网图

图1-12 配置X.25透明网桥组网图

 

3. 配置步骤

配置Router A

<RouterA> system-view

[RouterA] bridge enable

[RouterA] bridge 1 enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] bridge-set 1

[RouterA-Ethernet1/1] quit

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dce

[RouterA-Serial2/0] x25 x121-address 100

[RouterA-Serial2/0] x25 map bridge x121-address 200 broadcast

[RouterA-Serial2/0] bridge-set 1

配置Router B

<RouterB> system-view

[RouterB] bridge enable

[RouterB] bridge 1 enable

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] bridge-set 1

[RouterB-Ethernet1/1] quit

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25

[RouterB-Serial2/0] x25 x121-address 200

[RouterB-Serial2/0] x25 map bridge x121-address 100 broadcast

[RouterB-Serial2/0] bridge-set 1

1.8.6  HDLC透明网桥举例

1. 组网需求

图1-13所示Router A和Router B之间通过HDLC相连环境下,这两台路由器分别配置透明网桥功能,并实现路由器两边所在不同网段的LAN 1和LAN 2能够互相访问。

2. 组网图

图1-13 配置HDLC透明网桥组网图

 

3. 配置步骤

配置Router A

<RouterA> system-view

[RouterA] bridge enable

[RouterA] bridge 1 enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] bridge-set 1

[RouterA-Ethernet1/1] quit

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol hdlc

[RouterA-Serial2/0] bridge-set 1

配置Router B

<RouterB> system-view

[RouterB] bridge enable

[RouterB] bridge 1 enable

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] bridge-set 1

[RouterB-Ethernet1/1] quit

[RouterB] interface Serial 2/0

[RouterB-Serial2/0] link-protocol hdlc

[RouterB-Serial2/0] bridge-set 1

1.8.7  帧中继子接口支持网桥举例

1. 组网需求

图1-14所示Router A和Router B用一条帧中继链路互连,在帧中继子接口Serial2/0.1和Serial2/0.2上使能网桥功能,使得Host A和Host B可以通过bridge-set 1互通,Host C和Host D可以通过bridge-set 2互通。

此例中Router B为DCE设备。

1. 组网图

图1-14 配置帧中继子接口支持网桥组网图

 

2. 配置步骤

配置Router A

<RouterA> system-view

[RouterA] bridge enable

[RouterA] bridge 1 enable

[RouterA] bridge 2 enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] bridge-set 1

[RouterA-Ethernet1/1] quit

[RouterA] interface ethernet 1/2

[RouterA-Ethernet1/2] bridge-set 2

[RouterA-Ethernet1/2] quit

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol fr

[RouterA-Serial2/0] quit

[RouterA] interface serial 2/0.1

[RouterA-Serial2/0.1] fr map bridge 50 broadcast

[RouterA-Serial2/0.1] bridge-set 1

[RouterA-Serial2/0.1] quit

[RouterA] interface serial 2/0.2

[RouterA-Serial2/0.2] fr map bridge 60 broadcast

[RouterA-Serial2/0.2] bridge-set 2

配置Router B

<RouterB> system-view

[RouterB] bridge enable

[RouterB] bridge 1 enable

[RouterB] bridge 2 enable

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] bridge-set 1

[RouterB-Ethernet1/1] quit

[RouterB] interface ethernet 1/2

[RouterB-Ethernet1/2] bridge-set 2

[RouterB-Ethernet1/2] quit

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol fr

[RouterB-Serial2/0] fr interface-type dce

[RouterB-Serial2/0] quit

[RouterB] interface serial 2/0.1

[RouterB-Serial2/0.1] fr dlci 50

[RouterB-Serial2/0.1] fr map bridge 50 broadcast

[RouterB-Serial2/0.1] bridge-set 1

[RouterB-Serial2/0.1] quit

[RouterB] interface serial 2/0.2

[RouterB-Serial2/0.2] fr dlci 60

[RouterB-Serial2/0.2] fr map bridge 60 broadcast

[RouterB-Serial2/0.2] bridge-set 2

本例也可以直接配置为点对点(p2p)类型的帧中继子接口,点对点的帧中继子接口下不用配置fr map命令,但需要在DCE和DTE两侧同时配置相同的fr dlci,这样也可以实现帧中继网桥功能。相关内容可参见“二层技术-广域网接入配置指导”中的“帧中继”。

 

1.8.8  同时支持路由和桥接举例

1. 组网需求

图1-15所示利用一台路由器通过以太网接口连接三台设备,通过配置同时支持路由和桥接功能,使得通过网桥组中的每个接口都可以选路。

2. 组网图

图1-15 配置同时支持路由和桥接组网图

 

3. 配置步骤

<Router> system-view

[Router] bridge enable

[Router] bridge routing-enable

[Router] bridge 1 enable

[Router] bridge 1 routing ip

[Router] interface ethernet 1/1

[Router-Ethernet1/1] bridge-set 1

[Router-Ethernet1/1] quit

[Router] interface ethernet 1/2

[Router-Ethernet1/2] bridge-set 1

[Router-Ethernet1/2] quit

[Router] interface bridge-template 1

[Router-Bridge-template1] ip address 1.1.1.1 255.255.0.0

[Router-Bridge-template1] quit

[Router] interface ethernet 1/3

[Router-Ethernet1/3] ip address 2.1.1.1 255.255.0.0

1.8.9  拨号接口支持网桥转发举例

1. 组网需求

图1-16所示Router A和Router B用通过ISDN链路互连,并且在两台路由器分别配置透明网桥功能,实现路由器两边所在不同网段的LAN 1和LAN 2能够互相访问。

2. 组网图

图1-16 配置拨号接口支持网桥转发组网图

 

3. 配置步骤

配置Router A

# 在全局下使能网桥。

[RouterA] bridge enable

[RouterA] bridge 1 enable

# 配置拨号访问控制列表。

[RouterA] dialer-rule 1 bridge permit

# 在ISDN BRI接口上配置拨号。

[RouterA] interface bri2/0

[RouterA-Bri2/0] link-protocol ppp

[RouterA-Bri2/0] dialer enable-circular

[RouterA-Bri2/0] dialer-group 1

[RouterA-Bri2/0] dialer circular-group 2

[RouterA-Bri2/0] quit

# 将Dialer口加入网桥组。

[RouterA] interface dialer2

[RouterA-Dialer2] link-protocol ppp

[RouterA-Dialer2] bridge-set 1

[RouterA-Dialer2] dialer enable-circular

[RouterA-Dialer2] dialer-group 1

[RouterA-Dialer2] dialer number 660208

[RouterA-Dialer2] quit

# 将以太网接口加入网桥组。

[RouterA] interface ethernet1/1

[RouterA-Ethernet1/1] bridge-set 1

配置Router B

# 在全局下使能网桥。

[RouterB] bridge enable

[RouterB] bridge 1 enable

# 配置拨号访问控制列表。

[RouterB] dialer-rule 1 bridge permit

# 在ISDN BRI接口上配置拨号。

[RouterB] interface bri2/0

[RouterB-Bri2/0] link-protocol ppp

[RouterB-Bri2/0] dialer enable-circular

[RouterB-Bri2/0] dialer-group 1

[RouterB-Bri2/0] dialer circular-group 2

[RouterB-Bri2/0] quit

# 将Dialer口加入网桥组。

[RouterB] interface dialer2

[RouteBr-Dialer2] link-protocol ppp

[RouterB-Dialer2] bridge-set 1

[RouterB-Dialer2] dialer enable-circular

[RouterB-Dialer2] dialer-group 1

[RouterB-Dialer2] dialer number 660206

[RouterB-Dialer2] quit

# 将以太网接口加入网桥组。

[RouterB] interface ethernet1/1

[RouterB-Ethernet1/1] bridge-set 1

1.8.10  VLAN ID透传配置举例

1. 组网需求

图1-17所示,两个办公区分别连到交换机Switch A和Switch B上,然后通过路由器进行桥接。Switch A和Switch B的TRUNK口配置了相同的VLAN ID。如果两台路由器的以太网接口和ATM5/0接口都使能了VLAN ID透传功能,这样两个办公区同一个VLAN内的设备可以互通。

2. 组网图

图1-17 配置VLAN ID透传组网图

 

3. 配置步骤

配置Router A

# 使能桥接功能。

<RouterA> system-view

[RouterA] bridge enable

[RouterA] bridge 2 enable

# 把接口加入桥组,并使能VLAN ID透传功能。

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] bridge-set 2

[RouterA-Ethernet1/1] bridge vlanid-transparent-transmit enable

[RouterA-Ethernet1/1] quit

[RouterA] interface atm 5/0

[RouterA-Atm5/0] bridge-set 2

[RouterA-Atm5/0] bridge vlanid-transparent-transmit enable

[RouterA-Atm5/0] pvc to_r2 1/100

[RouterA-Atm5/0-1/100-to_r2] map bridge-group broadcast

配置路由器Router B

# 使能桥接功能。

<RouterB> system-view

[RouterB] bridge enable

[RouterB] bridge 2 enable

# 把接口加入桥组,并使能VLAN ID透传功能。

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] bridge-set 2

[RouterB-Ethernet1/1] bridge vlanid-transparent-transmit enable

[RouterB-Ethernet1/1] quit

[RouterB] interface atm 5/0

[RouterB-Atm5/0] bridge-set 2

[RouterB-Atm5/0] bridge vlanid-transparent-transmit enable

[RouterB-Atm5/0] pvc to_r1 1/100

[RouterB-Atm5/0-1/100-to_r1] map bridge-group broadcast

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!