国家 / 地区

04-二层技术-广域网接入配置指导

05-DCC配置

本章节下载  (1014.31 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Operation_Manual/H3C_MSR_CG(V5)-R2516-V1.16/04/201807/1094059_30005_0.htm

05-DCC配置


1 DCC

1.1  DCC简介

1.1.1  DCC介绍

DCC(Dial Control Center,拨号控制中心)是指路由器之间通过公用交换网(PSTN和ISDN)进行互连时所采用的路由技术,可以提供按需拨号服务。

所谓“按需拨号”是指:跨公用交换网相连的路由器之间不预先建立连接,当它们之间有数据需要传送时才以拨号的方式建立连接,即启动DCC拨号流程建立连接并传送信息,当链路再次空闲时,DCC会自动断开连接。

由于某些场合下,路由器之间仅在有数据需要传送时才建立连接并通信,传送的信息具有时间不相关性、突发性、总体数据量小等特点,DCC恰好为此种应用提供了灵活、经济、高效的解决方案。

实际应用中,DCC一般以备份形式为干线通讯提供保障,在干线因为线路或其它原因出现故障而不能正常通信时,提供替代的辅助通路,确保业务正常进行。

1.1.2  DCC的配置方式

系统提供了两种DCC配置方式:轮询DCC(Circular DCC,C-DCC)和共享DCC(Resource-Shared DCC,RS-DCC)方式。

两种方式具有各自不同的特点,适用于不同的应用需求,在应用时呼叫双方可以根据需要灵活选用配置方法,例如一端采用轮询DCC,另一端采用共享DCC。

DCC配置中使用的术语介绍如下:

·     物理接口:实际存在的物理接口,如Serial、BRI、Async等接口。

·     Dialer接口:为了配置DCC参数而设置的逻辑接口。物理接口可以通过绑定到Dialer接口而继承配置信息。

·     拨号接口:是对拨号连接接口的泛称。可以是Dialer接口,也可以是捆绑到Dialer接口的物理接口,或者是直接配置DCC参数的物理接口。

 

1. 轮询DCC

轮询DCC具有功能强大、应用广泛的优势,但是相对缺乏伸缩性、扩展性。具体来说,轮询DCC有以下特点:

·     一个逻辑拨号(Dialer)接口可以有多个物理接口为它服务,而任意一个物理接口只能属于一个Dialer接口,即一个物理接口只能服务于一种拨号服务;

·     物理接口既可以借助拨号循环组(Dialer Circular Group)绑定到Dialer接口来继承DCC参数,又可以直接配置DCC参数;

·     服务于同一个Dialer Circular Group的所有物理接口都继承同一个Dialer接口的属性;

·     一个Dialer接口可以通过配置多个dialer route命令对应多个呼叫目的地址,也可以配置dialer number命令对应单个呼叫目的地址。

此外,由于ISDN BRI接口中所有B通道都会继承该物理接口的相同配置信息,并且Dialer Route会随着网络规模的增大和支持协议的增多而逐渐复杂化,因此轮询DCC应用就受限于目的站呼叫设置与物理接口配置之间的静态绑定。

轮询DCC的物理接口和Dialer接口对应示意图

图1-1 轮询DCC的物理接口和Dialer接口对应

 

从上图可以看出,如果使用Dialer接口,同一物理接口仅能属于一个Dialer接口,每个Dialer接口可以对应多个目的地址;每个Dialer接口可以包含多个物理接口。另外,物理接口也可以不属于任何Dialer接口,而直接映射到一个或多个目的地址。

例如,物理接口Serial2/1、BRI1/1和Serial2/2都属于Dialer2接口,Dialer2接口上存在不同的拨号串对应不同目的地址的映射。

2. 共享DCC

由于实现了逻辑配置和物理配置的相互分离,共享DCC比轮询DCC简单,并具有良好的灵活性。具体来说,共享DCC有以下特点:

·     将物理接口的配置与呼叫的逻辑配置分开进行,再将两者动态的捆绑起来,从而实现相同物理接口为多种不同拨号应用服务;

·     一个Dialer接口只对应一个呼叫目的地址,由命令dialer number来指定;

·     每个逻辑拨号(Dialer)接口可以有多个物理接口为它提供服务,同时任意一个物理接口也可服务于多个Dialer接口;

·     共享DCC使用共享属性集(RS-DCC set)来描述拨号属性,去往同一个目的网络的所有呼叫使用同一个共享属性集(包括Dialer接口、Dialer bundle和物理接口等参数);

·     在物理接口上不能直接配置共享DCC参数,物理接口必须通过绑定到Dialer接口才能实现共享DCC拨号功能。

共享DCC的物理接口、Dialer bundle和Dialer接口对应示意图

图1-2 共享DCC的物理接口、Dialer bundle和Dialer接口对应

 

从上图可以看出,在共享DCC方式,同一物理接口可以属于多个Dialer bundle,并进而服务于多个Dialer接口。每个Dialer接口只能使用一个Dialer bundle,同时也只能设置一个拨号串。物理接口可以设置对应不同的Dialer接口且具有不同的优先级。

其中,Dialer2使用Dialer bundle2,物理接口BRI1/0、BRI1/1和Serial2/1属于Dialer bundle2,每个物理接口具有不同的优先级。假设在Dialer bundle2中BRI1/0的优先级是100,BRI1/1的优先级是50,Serial2/1的优先级是75,由于BRI1/0的优先级高于BRI1/1和Serial2/1的优先级,当Dialer2从Dialer bundle2中选择一个物理接口时,会优先使用BRI1/0接口。

1.1.3  系统提供的DCC特性

1. 基本DCC特性

系统为用户提供了灵活、完善的拨号解决方案,包括以下基本特性:

·     支持包括同/异步串口、AUX接口、ISDN BRI或PRI接口、AM接口等在内的各种拨号接口,可以根据实际组网需求和网络拓扑情况灵活组合使用;

·     在拨号接口(物理接口或Dialer接口)上支持链路层协议PPP;

·     在拨号接口上支持IP协议;

·     在拨号接口上支持RIP、OSPF等动态路由协议;

·     提供灵活的拨号接口备份方式;

·     通过User-interface提供对Modem的控制功能,可以管理控制多种Modem设备。

2. 使用DCC实现回呼(Callback)

回呼(Callback)是指“接受呼叫方”反方向呼叫“发送呼叫方”,其中,发送呼叫方作为Client端,接受呼叫方作为Server端。由Client端首先发起呼叫,Server端确认该呼叫是否需要进行回呼,若需要回呼,Server端则立即挂断该次呼入连接,并向Client端重新发起呼叫。

使用DCC回呼带来的好处是:

·     增强安全性:回呼处理中,Server端根据本端配置的呼叫号码呼叫Client端,从而可避免因用户名和口令泄密而导致的不安全性;

·     改变话费承担方,当两个方向的呼叫费率不同时可以节省话费;

·     合并话费清单,便于结算。

目前,系统提供PPP回呼、ISDN主叫识别回呼。其中PPP回呼遵照RFC1570规定,支持Client端和Server端都有固定网络层地址、Client端接受动态分配的网络地址等情况。

1.1.4  DCC配置前的准备

1. 确定DCC应用的拓扑结构

·     哪些路由器将要提供DCC功能,这些提供DCC功能的路由器之间关系如何?

·     路由器的哪些接口提供DCC功能,提供DCC功能的接口发挥什么作用?

·     采用何种传输介质,即使用PSTN还是ISDN?

2. DCC配置前的准备数据

·     确定使用的接口类型(如同/异步串口、ISDN BRI或PRI接口、AUX接口),并配置接口基本物理参数;

·     配置拨号接口使用的链路层封装模式(如PPP);

·     配置拨号接口支持的路由协议(如RIP、OSPF等);

·     配置拨号接口使用的网络协议(如IP);

·     选择DCC配置方法(轮询DCC、共享DCC)。

3. DCC功能本身的参数配置

根据选定的DCC配置方法逐步配置基本DCC功能参数(轮询DCC或共享DCC),实现最初步的DCC拨号功能。

如果有特殊应用需求,则在完成基本DCC配置的基础上,增加配置MP捆绑、PPP回呼、ISDN主叫识别回呼、ISDN专线、自动拨号、拨号串循环备份功能,也可以根据拨号链路的实际情况适当调整DCC拨号接口的属性参数。

1.2  DCC配置任务简介

表1-1 DCC配置任务简介

配置任务

说明

详细配置

DCC基本配置

必选

1.1.1 

轮询DCC呼叫的配置

必选

根据实际情况,配置轮询DCC或者共享DCC,二者选择其一

1.2.2 

共享DCC呼叫的配置

1.2.3 

DCC呼叫MP捆绑的配置

可选

1.2.4 

PPP回呼的配置

可选

1.2.5 

ISDN主叫识别回呼的配置

可选

1.2.6 

DCC特殊功能的配置

ISDN专线配置

可选

1.2.7 

自动拨号配置

拨号串循环备份配置

DCC重叠接收功能配置

DCC拨号接口属性参数配置

可选

1.2.8 

配置通过DCC实现动态路由备份

可选

1.2.9 

配置系统进行流量统计的间隔时间

可选

1.2.10 

 

1.1.1  DCC基本配置

1. 配置DCC的基本功能

无论使用轮询DCC还是共享DCC配置按需拨号功能,都需要首先完成DCC基本配置。

表1-2 配置DCC的基本功能

操作

命令

说明

配置物理接口的模式

对于同/异步串口,如果连接异步Modem则首先需要配置物理接口为异步协议方式,同时在对应的user-interface上使能modem拨号方式;如果连接同步Modem则需配置物理接口为同步方式;如果接口为ISDN BRI或PRI接口则略过此步骤。详细配置内容请参见“接口管理配置指导”中的“WAN接口”和“二层技术-广域网接入配置指导”中的“Modem管理”

可选

缺省情况下,同/异步串口工作在同步方式,异步串口工作在协议方式

配置拨号接口链路层协议、网络协议及路由协议

请在拨号接口(物理接口或Dialer接口)视图下封装链路层协议(使用命令link-protocol,Dialer接口的链路层协议只能配置为PPP),并配置拨号接口IP地址(使用命令ip address),在系统视图下进行其它配置。当拨号接口的链路层协议为PPP时,还可以配置PAP或者CHAP验证。详细配置内容请参见“二层技术-广域网接入配置指导”、“三层技术-IP业务配置指导”和“三层技术-IP路由配置指导”

必选

配置DCC拨号控制列表与拨号接口关联

请参见“2. 配置DCC拨号控制列表与拨号接口关联

必选

 

当接口的链路层协议为PPP时,PPP的相关配置命令请按如下原则配置:

·     对于轮询DCC,请在Dialer接口下配置PPP的相关命令。

·     对于共享DCC,如果是主叫端,请在Dialer接口下配置PPP的相关命令,但我们建议用户在物理拨号接口下也配置相同的PPP相关命令,以确保PPP链路参数协商的可靠性;如果是被叫端,请在物理拨号接口下配置PPP相关命令。

2. 配置DCC拨号控制列表与拨号接口关联

通过配置拨号控制列表,可以过滤流经拨号接口的各种报文。根据报文是否符合拨号ACL控制列表的允许(permit)或拒绝(deny)条件,报文分为两类:

·     符合拨号ACL控制列表permit条件的报文或者不符合拨号ACL控制列表deny条件的报文,如果相应链路已经建立,DCC将通过该链路发出报文,并清零Idle超时定时器;如果链路没有建立则发出新呼叫。

·     不符合拨号ACL控制列表permit条件的报文或者符合拨号ACL控制列表deny条件的报文,如果相应的链路已经建立,DCC将通过此链路发出报文,但是不清零Idle超时定时器;如果相应链路没有建立,则不发出呼叫并丢弃此报文。

要想使DCC正常发送报文,必须配置DCC拨号控制列表,并将对应接口(如物理接口、Dialer接口)通过dialer-group命令与拨号控制列表关联起来,如果缺少此项配置则DCC无法正常发送报文。DCC拨号控制列表既可以直接配置数据报文的过滤条件,也可以引入访问控制列表中的过滤规则。

表1-3 配置DCC拨号控制列表与拨号接口关联

操作

命令

说明

进入系统视图

system-view

-

配置某个拨号访问组对应的拨号访问控制列表,指定引发DCC呼叫的条件

dialer-rule group-number { protocol-name { deny | permit } | acl { acl-number | name acl-name } }

必选

进入相应的拨号接口视图(物理接口或Dialer接口)

interface interface-type interface-number

-

配置该拨号接口关联的拨号访问组,将该接口与指定的拨号控制列表关联起来

dialer-group group-number

必选

 

必须确保命令dialer-rule中的参数group-number和命令dialer-group中的参数group-number保持一致。

 

1.2.2  配置轮询DCC呼叫

当使用轮询DCC方法来配置按需拨号时,每个物理接口上既可以直接配置DCC参数,又可以借助拨号循环组(Dialer Circular Group)绑定到Dialer接口来继承DCC参数。其中,物理接口上直接配置DCC参数仅适用于单个接口向一个(或多个)对端发起呼叫,而Dialer Circular Group可适用于多个接口向单个(或多个)对端发起呼叫,当然也可用于单个接口向外发起呼叫。

Dialer Circular Group将一个逻辑拨号接口(Dialer)与一组物理接口对应起来,对这个Dialer接口的DCC呼叫配置将会自动地被该Dialer Circular Group中的所有物理接口继承。在配置完成Dialer Circular Group的相关参数后,如果逻辑拨号接口对应多个目的地,则通过Dialer Circular Group中的任一物理接口都可以呼叫设定好的任意一个目的地。

根据网络拓扑结构及DCC拨号需求的不同,如一个接口既发出呼叫又接收呼叫、多个接口既发出呼叫又接收呼叫等情况,可以灵活组合使用以下介绍的轮询DCC配置中的一种或几种。

应用轮询DCC方法配置按需拨号时,拨号双方可选配置PAP或CHAP认证,但是如果一方配置认证则另一方也必须配置。在具体组网应用中,出于确保拨号身份的安全性,推荐配置认证,配置方法请参见“二层技术-广域网接入配置指导”中的“PPP”,同时注意以下约束:

·     在发送端,如果物理接口直接使能DCC,则直接在物理接口上配置PAP或CHAP认证;如果通过Dialer Circular Group使能DCC,则在Dialer接口上配置PAP或CHAP认证。

·     在接收端配置PAP或CHAP认证时,建议在物理接口和Dialer接口上都配置。因为当物理接口接收到DCC呼叫请求时,首先进行PPP协商并认证拨入用户的合法性,然后再将呼叫转交给上层DCC模块进行处理。

 

表1-4 配置轮询DCC呼叫

操作

命令

说明

配置一个接口向一个对端发起呼叫

请参见 1.1.1  1. 配置一个接口向一个对端发起呼叫

可选

配置一个接口从一个对端接收呼叫

请参见1.2.2  2. 配置一个接口从一个对端接收呼叫

可选

配置一个接口向多个对端发起呼叫

请参见1.2.2  3. 配置一个接口向多个对端发起呼叫

可选

配置一个接口从多个对端接收呼叫

请参见1.2.2  4. 配置一个接口从多个对端接收呼叫

可选

配置多个接口向一个或多个对端发起呼叫

请参见1.2.2  5. 配置多个接口向一个或多个对端发起呼叫

可选

配置多个接口从一个或多个对端接收呼叫

请参见1.2.2  6. 配置多个接口从一个或多个对端接收呼叫

可选

 

1. 配置一个接口向一个对端发起呼叫

本端一个接口向单个对端发起呼叫的示意图如下(反色图元代表和本项组网不相关的其它路由器):

图1-3 一个接口向一个对端发起呼叫

 

如上图所示,本端单接口Interface0(简写为if0)向对端单接口if1发起DCC呼叫。由于是向单个对端发起呼叫,因此可使用dialer number命令或dialer route命令配置拨号串;由于是从本端单个接口发起呼叫,因此可选用Dialer Circular Group配置DCC。可选配置PAP或CHAP认证。

完成DCC基本配置后进行如下配置。

表1-5 配置一个接口向一个对端发起呼叫

操作

命令

说明

进入系统视图

system-view

-

进入相应的拨号接口视图(物理接口或Dialer接口)

interface interface-type interface-number

-

使能轮询DCC

dialer enable-circular

必选

缺省情况下,接口禁止轮询DCC

配置呼叫一个对端的拨号串(任选一种配置方法)

dialer number dial-number

必选

dialer route protocol next-hop-address  [ mask network-mask-length ] [ user hostname | broadcast ] * dial-number [ autodial | interface interface-type interface-number ] *

 

2. 配置一个接口从一个对端接收呼叫

本端一个接口从单个对端接收呼叫的示意图如下(反色图元代表和本项组网不相关的其它路由器):

图1-4 一个接口从一个对端接收呼叫

 

如上图所示,本端单接口interface0(简写为if0)从对端单接口if1接收DCC呼叫。由于本端为单个接口,因此可选用Dialer Circular Group配置DCC。可选配置PAP或CHAP认证。

完成DCC基本配置后进行如下配置。

表1-6 配置一个接口从一个对端接收呼叫

操作

命令

说明

进入系统视图

system-view

-

进入相应的拨号接口视图(物理接口或Dialer接口)

interface interface-type interface-number

-

使能轮询DCC

dialer enable-circular

必选

缺省情况下,接口禁止轮询DCC

配置一个接口从一个对端接收呼叫

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] *

可选

如果被叫方配置了dialer route ip  next-hop-address user hostname命令,被叫方会用这个配置中的next-hop-addresshostname验证主叫方的IP地址和验证用户名是否合法

 

3. 配置一个接口向多个对端发起呼叫

本端一个接口向多个对端发起呼叫的示意图如下(反色图元代表和本项组网不相关的其它路由器):

图1-5 一个接口向多个对端发起呼叫

 

如上图所示,本端单接口interface0(简写为if0)向多个对端接口if1、if2、if3发起DCC呼叫。由于向多个对端发起呼叫,因此必须使用dialer route命令配置拨号串和目的地址;由于从本端单个接口发起呼叫,因此可选用Dialer Circular Group配置DCC。可选配置PAP或CHAP认证。

完成DCC基本配置后进行如下配置。

表1-7 配置一个接口向多个对端发起呼叫

操作

命令

说明

进入系统视图

system-view

-

进入相应的拨号接口视图(物理接口或Dialer接口)

interface interface-type interface-number

-

使能轮询DCC

dialer enable-circular

必选

缺省情况下,接口禁止轮询DCC

配置呼叫多个对端的目的地址及拨号串(该命令需要配置多次)

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] * dial-number  [ autodial | interface interface-type interface-number ] *

必选

 

4. 配置一个接口从多个对端接收呼叫

本端一个接口从多个对端接收呼叫的示意图如下(反色图元代表和本项组网不相关的其它路由器):

图1-6 一个接口从多个对端接收呼叫

 

如上图所示,本端单接口interface0(简写为if0)从多个对端接口if1、if2、if3接收DCC呼叫。由于本端为单个接口,因此可选使用Dialer Circular Group配置DCC。可选配置PAP或CHAP认证。

完成DCC基本配置后进行如下配置。

表1-8 配置本端一个接口从多个对端接收呼叫

操作

命令

说明

进入系统视图

system-view

-

进入相应的拨号接口视图(物理接口或Dialer接口)

interface interface-type interface-number

-

使能轮询DCC

dialer enable-circular

必选

缺省情况下,接口禁止轮询DCC

配置本端一个接口从多个对端接收呼叫(该命令需要配置多次)

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] *

可选

如果被叫方配置了dialer route ip  next-hop-address user hostname命令,被叫方会用这个配置中的next-hop-addresshostname验证主叫方的IP地址、验证用户名是否合法

 

5. 配置多个接口向一个或多个对端发起呼叫

本端多个接口向一个或多个对端发送呼叫的示意图如下(反色图元代表和本项组网不相关的其它路由器):

图1-7 多个接口向一个或多个对端发起呼叫

 

如上图所示,本端多接口interface0(简写为if0)、if1和if2向一个或多个对端接口if1、if2、if3发起DCC呼叫。当向一个对端发起呼叫时,可以使用命令dialer number配置拨号串;当向多个对端发起呼叫时,需要使用dialer route命令配置拨号串和目的地址;由于从多个接口发起呼叫,因此必须使用Dialer Circular Group配置DCC。可选配置PAP或CHAP认证。

在拨号过程中,Dialer Circular Group中的物理接口不使用自己的IP地址,而是继承Dialer接口的IP地址。ISDN BRI或PRI接口本身可以看作是其下属B通道的Dialer Circular Group,同时,它也可作为其它Dialer Circular Group中的物理接口。

完成DCC基本配置后进行如下配置。

表1-9 本端多个接口向一个或多个对端发起呼叫

操作

命令

说明

进入系统视图

system-view

-

创建Dialer接口,并进入Dialer接口视图

interface dialer number

-

使能轮询DCC

dialer enable-circular

必选

缺省情况下,接口禁止轮询DCC

配置呼叫一个或多个对端的目的地址及拨号串(如果需要呼叫多个对端,则该命令需要配置多次)

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] * dial-number  [ autodial | interface interface-type interface-number ] *

必选

如果呼叫一个对端,也可以使用命令dialer number dial-number配置

退回到系统视图

quit

-

进入相应的物理接口视图

interface interface-type interface-number

-

将物理接口加入指定的Dialer Circular Group中(该Dialer Circular Group的序号number是用interface dialer命令定义的)

dialer circular-group number

必选

配置物理接口在Dialer Circular Group中的优先级

dialer priority priority

可选

缺省情况下,优先级为1

 

必须确保命令dialer circular-group中的参数number和命令interface dialer中的参数number保持一致。

 

6. 配置多个接口从一个或多个对端接收呼叫

本端多个接口从一个或多个对端接收呼叫的示意图如下(反色图元代表和本项组网不相关的其它路由器):

图1-8 多个接口从一个或多个对端接收呼叫

 

如上图所示,本端多接口interface0(简写为if0)、if1和if2从一个或多个对端接口if1、if2、if3、if4接收DCC呼叫。由于本端为多个接口,因此必须使用Dialer Circular Group配置DCC。可选配置PAP或CHAP认证。

完成DCC基本配置后进行如下配置。

表1-10 配置本端多个接口从一个或多个对端接收呼叫

操作

命令

说明

进入系统视图

system-view

-

创建Dialer接口,并进入Dialer接口视图

interface dialer number

-

使能轮询DCC

dialer enable-circular

必选

缺省情况下,接口禁止轮询DCC

配置接收一个或多个对端的呼叫(如果需要接收多个对端的呼叫,则该命令需要配置多次)

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] *

可选

如果被叫方配置了dialer route ip  next-hop-address user hostname命令,被叫方会用这个配置中的next-hop-addresshostname验证主叫方的IP地址和验证用户名是否合法

退回到系统视图

quit

-

进入相应的物理接口视图

interface interface-type interface-number

-

将物理接口加入指定的Dialer Circular Group中(该Dialer Circular Group的序号number是用interface dialer命令定义的)

dialer circular-group number

必选

配置物理接口在Dialer Circular Group中的优先级

dialer priority priority

可选

缺省情况下,优先级为1

 

必须确保命令dialer circular-group中的参数number和命令interface dialer中的参数number保持一致。

 

1.2.3  配置共享DCC呼叫

当使用共享DCC方法来配置按需拨号时,需要借助共享属性集来进行配置,可以实现物理接口配置与呼叫的逻辑配置分离,也可以让每个呼叫的逻辑和物理配置动态结合起来。每个共享属性集包含一个Dialer接口、该Dialer接口的属性、一个Dialer bundle,具体如下:

·     每个Dialer接口中仅可以定义一个拨号串,该拨号串具备自己的拨号属性集,从而使用该拨号串的所有呼叫都使用相同的DCC属性参数(如拨号速率等)。

·     每个Dialer接口只能使用一个Dialer bundle,每个Dialer bundle中可以包含多个不同优先级别的物理端口,而每个物理端口也可以属于多个不同的Dialer bundle。对于ISDN BRI和PRI接口,能够通过Dialer bundle设置使用B通道的数目。

·     去往相同目的网段的所有呼叫使用相同的共享属性集。

由于共享DCC配置将物理接口和呼叫的逻辑配置分开进行,因此适于更多的网络拓扑结构及DCC拨号需求,尤其适用于不同端口集合呼叫多个对端的情况。

图1-9 共享DCC呼叫多个接口向多个对端发起呼叫

 

如上图所示,呼叫不同对端使用不同的Dialer接口(一个Dialer接口仅指向一个对端),通过将物理接口灵活的放入各Dialer接口的Dialer bundle中,实现物理接口按照不同的拨号需求进行呼叫。

当使用共享属性集配置共享DCC时,物理接口上仅需要配置链路层封装模式及该物理接口所属的Dialer bundle编号。

·     在共享DCC中,由于共享属性集不会将自己的属性信息应用到dialer bundle中的物理接口(例如不将PPP认证命令应用到物理接口上),即物理接口不从共享属性集继承认证属性信息,因此必须在接收端物理接口上配置认证相关信息。

·     在共享DCC中,认证必须配置(包括dialer user配置和PPP认证),需要在dialer接口和物理接口同时配置认证。因为共享DCC需要从物理接口进行PPP协商,并把协商出的对端用户名传给DCC,DCC根据对端用户名确定使用哪个dialer接口,并把dialer接口的地址返回给PPP,由PPP应用dialer接口的配置进行IPCP协商。

 

表1-11 配置共享DCC呼叫

操作

命令

说明

使能共享DCC

请参见“1.1.1  1. 使能共享DCC

必选

配置Dialer接口的拨号串

请参见“1.2.3  2. 配置Dialer接口拨号串

必选

创建Dialer bundle包含的物理接口

请参见“1.2.3  3. 创建Dialer bundle包含的物理接口

必选

配置共享DCC拨号认证

请参见“1.2.3  4. 配置共享DCC拨号认证

必选

 

1. 使能共享DCC

表1-12 使能共享DCC

操作

命令

说明

进入系统视图

system-view

-

创建Dialer接口,并进入Dialer接口视图

interface dialer number

-

设定对端用户名。当Dialer接口封装PPP时,利用PPP验证得到的对端用户名决定接收呼叫时的Dialer接口

dialer user username

必选

使能共享DCC,创建Dialer接口使用的Dialer bundle

dialer bundle number

必选

 

2. 配置Dialer接口的拨号串

使用共享DCC实现按需拨号时,由于物理接口随着拨号串的不同而具有不同属性,因此必须在Dialer接口上配置DCC参数,并且只能使用dialer number命令配置呼叫对端的拨号串。一个Dialer接口只能配置一个拨号串。

表1-13 配置Dialer接口的拨号串

操作

命令

说明

进入系统视图

system-view

-

进入Dialer接口视图

interface dialer number

-

配置呼叫一个对端的拨号串

dialer number dial-number

必选

 

3. 创建Dialer bundle包含的物理接口

使用共享DCC实现按需拨号时,系统从Dialer bundle中按照优先级选择物理接口发起拨号呼叫,因此需要创建该Dialer bundle包含的物理接口。

表1-14 创建Dialer bundle包含的物理接口

操作

命令

说明

进入系统视图

system-view

-

进入物理接口的视图

interface interface-type interface-number

-

配置物理接口从属于某个Dialer bundle

dialer bundle-member number [ priority priority ]

必选

缺省情况下,物理接口不属于任何一个Dialer bundle;当设置物理接口属于某个Dialer bundle时,priority缺省为1

 

4. 配置共享DCC拨号认证

使用共享DCC实现按需拨号时,由于物理接口和Dialer接口之间灵活的对应关系,被叫端需要通过认证过程来识别不同的主叫端,因此必须配置PAP或CHAP拨号认证。

表1-15 配置共享DCC拨号认证

操作

命令

说明

进入系统视图

system-view

-

进入Dialer接口视图

interface dialer number

-

配置对端用户名

dialer user username

必选

配置链路层协议为PPP,并且配置PPP认证(PAP认证或者CHAP认证)的相关内容

请参见“二层技术-广域网接入配置指导”中的“PPP”

必选

 

·     在发送端和接收端,建议在物理接口和Dialer接口上都配置PAP或CHAP认证命令。

·     当Dialer接口封装PPP时,需要使用dialer user命令配置对端用户名,用该对端用户名与利用PPP验证得到的对端用户名进行比较,以决定接收呼叫的Dialer接口。

 

1.2.4  DCC呼叫MP捆绑的配置

1. DCC呼叫MP捆绑的简介

在DCC应用中,可以配置链路的负载阈值。当负载阈值范围是1~99之间时,MP捆绑根据实际流量百分比适当调节分配的带宽,即如果一条链路的实际流量与带宽的比例超过设定的负载阈值,则系统会自动启用第二条链路,并将两条链路进行MP捆绑;当两条链路的流量与带宽的比例超过设定的负载阈值,系统会启动第三条链路并进行MP捆绑,……依此类推,从而确保DCC链路具有合理的负载流量。相反,若N条(N为大于2的整数)链路的流量与N-1条链路带宽的比例小于设定的负载阈值时,系统自动关闭一条链路,……依此类推,从而确保DCC链路的利用率保持在合理范围。

当负载阈值为0时,在链路由于自动拨号或者报文触发拨号而开始呼叫的时候,将自动启动所有可用的链路进行呼叫,而不依靠流量检测决定呼叫策略,对于已经呼叫建立的链路也不会因为超时而主动拆链。

·     最大捆绑链路数

在DCC中必须借助Dialer接口来实现MP捆绑。在Dialer接口上配置ppp mpdialer threshold命令后,当Dialer接口中的某个物理接口上的流量与带宽的比例超过负载阈值时,DCC会启用该Dialer接口中的另一个物理接口,并对这些链路进行MP捆绑。如果物理接口为ISDN BRI或PRI接口,则DCC会从该物理接口中选择空闲B通道进行MP捆绑。当拨起的链路数达到max-bind-num时,PPP MP捆绑的链路数达到上限,此时将停止启动新的链路。

·     最小捆绑链路数

在拨号使用中,有时需要能够同时使用多条链路来承载业务,因此需要一次报文触发能够呼起多条链路以保证需要的最小带宽,此时可以配置ppp mp min-bind命令。配置ppp mp min-bind命令时,路由器首先拨起第一条链路,在链路UP后检测捆绑的链路数是否达到min-bind-num,如果没有达到,则再拨起一条链路,……依此类推,直至达到最小捆绑链路数为止。

请注意dialer threshold/ppp mp max-bind/ppp mp min-bind命令只能在Dialer接口上进行配置,其它PPP的相关配置命令请按如下原则配置:

·     对于轮询DCC,请在Dialer接口下配置PPP的相关命令。

·     对于共享DCC,如果是主叫端,请在Dialer接口下配置PPP的相关命令,但我们建议用户在物理拨号接口下也配置相同的PPP相关命令,以确保PPP链路参数协商的可靠性;如果是被叫端,请在物理拨号接口下配置PPP相关命令。

2. 配置DCC呼叫的MP捆绑

表1-16 配置DCC呼叫的MP捆绑

操作

命令

说明

进入系统视图

system-view

-

进入Dialer接口视图

interface dialer number

-

封装接口的链路层协议为PPP

link-protocol ppp

必选

配置MP捆绑

ppp mp

必选

缺省情况下,未配置MP捆绑

设置MP捆绑的负载阈值

dialer threshold traffic-percentage [ in-out | in | out ]

必选

若配置dialer threshold 0 则会拨起所有可用链路

配置MP最大捆绑链路数

ppp mp max-bind max-bind-num

可选

缺省情况下,最大捆绑链路数为16

配置MP最小捆绑链路数

ppp mp min-bind min-bind-num

可选

缺省情况下,最小捆绑链路数为0,即MP拨号将依赖流量检测

 

·     建议用户在Dialer接口及物理拨号接口下同时配置ppp相关命令,这样可以确保协商成功。

·     当配置了ppp mp min-bind命令的时候,MP拨号将不依赖流量检测,但对于已经呼叫建立的链路会因为超时而主动拆链。

·     当ppp mp min-binddialer thresholdppp mp max-bind三条命令同时配置时,首先拨起min-bind-num条链路,如此时流量仍超过traffic-percentage,则继续拨起下一条空闲链路,直至捆绑链路数达到max-bind-num或流量低于traffic-percentage为止。

·     dialer threshold命令仅在主叫端配置即可。

·     若配置了dialer threshold 0,则DCC会拨起所有可用链路,且dialer timer idle命令在配置了dialer threshold 0之后将会失效。

 

1.2.5  PPP回呼的配置

在PPP回呼的配置中,需要配置一端为Client端,同时配置另一端为Server端,其中发送呼叫方作为Client端,接受呼叫方作为Server端。由Client端首先发起呼叫,Server端确认该呼叫是否进行回呼,若需要回呼,Server端则立即挂断该次呼入连接,并根据用户名或回呼字符串等信息向Client端再次发起呼叫。

·     在完成基本的轮询DCC配置或共享DCC配置的基础上,再进行以下PPP回呼的配置。

·     实现PPP回呼必须配置认证。在Client端和Server端,建议物理接口和Dialer接口上都配置PAP或CHAP认证命令。

·     由于在接口上配置动态路由备份时,只允许从动态路由备份组开始拨号,此时该接口上不接受入呼叫和其他情况的出呼叫,因此配置回呼时不能同时在接口上配置动态路由备份组。

 

1. 使用轮询DCC配置PPP回呼

轮询DCC实现PPP回呼的Client端配置

路由器作为Client端可以向对端(具备PPP回呼Server功能的路由器、Windows NT Server)发起呼叫,并可以正常接收对端的回呼。

表1-17 轮询DCC实现PPP回呼的Client端配置

操作

命令

说明

进入系统视图

system-view

-

进入相应的拨号接口视图(物理接口或Dialer接口)

interface interface-type interface-number

-

封装接口的链路层协议为PPP

link-protocol ppp

必选

根据双方的验证方式进行验证参数的配置

请参见“二层技术-广域网接入配置指导”中的“PPP”

必选

配置本端为PPP回呼的Client端

ppp callback client

必选

配置Windows NT Server回呼路由器时所需要的拨号串

ppp callback ntstring dial-number

可选

当路由器作为PPP回呼的Client端呼叫作为PPP回呼Server端的Windows NT Server时,如果Windows NT Server需要路由器发送回呼号码,则需要配置此命令

配置下次呼叫发起前的链路断开时间(建议值15秒)

dialer timer enable seconds

可选

 

缺省情况下,系统未启动回呼功能,未配置Windows NT Server回呼拨号串。

轮询DCC实现PPP回呼的Server端配置

Server端既可以根据dialer route命令中配置的网络地址进行回呼(必须配置PPP认证),也可以根据PPP用户的回呼号码进行回呼,因此需要使用dialer callback-center命令配置回呼的方式。

Server端在接收到回呼呼叫时,为了认证该呼叫用户是否是合法的回呼用户,需要在dialer route命令中配置允许回呼的Client端用户名。

表1-18 轮询DCC实现PPP回呼的Server端配置

操作

命令

说明

进入系统视图

system-view

-

进入相应的拨号接口视图(物理接口或Dialer接口)

interface interface-type interface-number

-

配置本端为PPP回呼的Server端

ppp callback server

必选

配置PPP回呼的参照依据

dialer callback-center [ user | dial-number ] *

必选

配置允许回呼的Client端用户名,用于验证对端是否是合法的回呼用户

dialer route protocol next-hop-address [ mask network-mask-length ] user hostname [ broadcast ] [ dial-number [ autodial | interface interface-type interface-number ] * ]

必选

退回到系统视图

quit

-

根据回呼方式的不同进行不同的配置(二者选择其一即可)

如果回呼方式是dial-number,则需要根据PPP认证中接收的对端用户名确定回呼的拨号串:首先,创建本地用户,进入本地用户视图,然后配置回呼用户及回呼号码

local-user user-name

service-type ppp

authorization-attribute callback-number callback-number

必选

如果回呼方式是user,则需要根据dialer route命令中配置的拨号串进行回呼

dialer route protocol next-hop-address [ mask network-mask-length ] user hostname [ broadcast ] dial-number [ autodial | interface interface-type interface-number ] *

 

缺省情况下,系统未启动回呼功能。当启动回呼功能后,Server端缺省会根据dialer route命令中配置的用户名进行回呼。

·     当Client端采用动态分配的网络地址时,Server端将无法使用dialer route命令配置和网络地址关联的回呼拨号串,只能使用authorization-attribute callback-number命令配置和回呼用户名关联的回呼拨号串,从而确定回呼依据。

·     为了使Server端有足够的时间进行回呼,Client端下次呼叫发起前的链路断开时间应至少比Server端的长10秒。建议Server端下次呼叫发起前的链路断开时间使用默认值5秒,Client端配置为15秒。

 

2. 使用共享DCC配置PPP回呼

共享DCC实现PPP回呼的Client端配置

路由器作为Client端可以向对端(具备PPP回呼Server功能的路由器、Windows NT Server)发起呼叫,并可以正常接收对端的回呼。

使用共享DCC实现PPP回呼,Client端PPP认证配置与轮询DCC的对应配置完全相同(请参见轮询DCC的PPP回呼Client端配置),区别仅在于Client端必须使用dialer number命令配置呼叫拨号串。

表1-19 共享DCC实现PPP回呼的Client端配置

操作

命令

说明

进入系统视图

system-view

-

进入Dialer接口视图

interface dialer number

-

封装接口的链路层协议为PPP

link-protocol ppp

必选

根据双方的验证方式进行验证参数的配置

请参见“二层技术-广域网接入配置指导”中的“PPP”

必选

配置本端为PPP回呼的Client端

ppp callback client

必选

配置Windows NT Server回呼路由器时所需要的拨号串

ppp callback ntstring dial-number

可选

当路由器作为PPP回呼的Client端呼叫作为PPP回呼Server端的Windows NT Server时,如果Windows NT Server需要路由器发送回呼号码,则需要配置此命令

配置下次呼叫发起前的链路断开时间(建议值15秒)

dialer timer enable seconds

可选

 

共享DCC实现PPP回呼的Server端配置

使用共享DCC实现PPP回呼,Server端PPP认证配置与轮询DCC的对应配置完全相同(请参见轮询DCC的PPP回呼Server端配置),区别仅在于Server端设置的PPP回呼的参照依据只能是dial-number,即只能根据authorization-attribute callback-number命令中配置的拨号串进行回呼。

表1-20 共享DCC实现PPP回呼的Server端配置

操作

命令

说明

进入系统视图

system-view

-

进入Dialer接口视图

interface dialer number

-

配置本端为PPP回呼的Server端

ppp callback server

必选

配置PPP回呼的参照依据

dialer callback-center dial-number

必选

退回到系统视图

quit

-

根据PPP认证中接收的对端用户名确定回呼的拨号串:首先,创建本地用户,进入本地用户视图,然后配置回呼用户及回呼号码

local-user user-name

service-type ppp

authorization-attribute callback-number callback-number

必选

 

为了使Server端有足够的时间进行回呼,Client端下次呼叫发起前的链路断开时间应至少比Server端的长10秒。建议Server端下次呼叫发起前的链路断开时间使用默认值5秒,Client端配置为15秒。

 

1.2.6  ISDN主叫识别回呼的配置

在ISDN环境中,利用ISDN主叫识别功能实现DCC回呼,不需要进行认证等配置。

1. ISDN主叫识别回呼的特点

ISDN主叫识别回呼应用中,当Server端收到一个呼叫时,会根据呼入号码与本端dialer call-in命令的匹配情况,分为三种处理方式:

·     拒绝该呼入:配置了dialer call-in命令,但呼入号码和所有dialer call-in命令都不匹配。

·     接受该呼入:没有配置dialer call-in命令,或呼入号码与一个没有“callback”关键字的dialer call-in命令相匹配。

·     回呼:配置了dialer call-in命令,且呼入号码与某个包含“callback”关键字的dialer call-in命令相匹配。

呼入号码与dialer call-in命令的匹配规则采用右端匹配(其中“*”字符代表任意字符)。若呼入号码与多个dialer call-in命令匹配,则按照以下原则确定选择结果:

·     首要原则:优先选择“*”符号较少的。

·     次要原则:优先选择最先找到的。

确定Server端与拨入呼叫相关的dialer call-in

·     在轮询DCC中,Server端接收到拨入呼叫时,会在物理接口或所属Dialer接口配置的dialer call-in中查找与呼入号码相匹配的dialer call-in

·     在共享DCC中,Server端接收到拨入呼叫时,会在所属Dialer接口配置的dialer call-in中查找与呼入号码相匹配的dialer call-in

2. 使用轮询DCC配置ISDN主叫识别回呼

轮询DCC实现ISDN主叫识别回呼的Client端配置

表1-21 轮询DCC实现ISDN主叫识别回呼的Client端配置

操作

命令

说明

进入系统视图

system-view

-

进入拨号接口(物理接口或Dialer接口)视图

interface interface-type interface-number

-

配置呼叫一个(或多个)对端的目的地址及拨号串

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] * dial-number  [ autodial | interface interface-type interface-number ] *

必选

配置下次呼叫发起前的链路断开时间(建议值15秒)

dialer timer enable seconds

可选

 

轮询DCC实现ISDN主叫识别回呼的Server端配置

表1-22 轮询DCC实现ISDN主叫识别回呼的Server端配置

操作

命令

说明

进入系统视图

system-view

-

进入拨号接口(物理接口或Dialer接口)视图

interface interface-type interface-number

-

配置按照ISDN主叫识别号码进行ISDN回呼

dialer call-in remote-number [ callback ]

必选

配置呼叫一个(或多个)对端的目的地址及拨号串

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] * dial-number  [ autodial | interface interface-type interface-number ] *

必选

当配置的呼叫对端的目的地址只有一个时,也可以使用该命令

dialer number dial-number

可选

 

·     在Server端拨号接口(物理接口或Dialer接口)上需要配置与拨入呼叫串完全一致的dialer route或者dialer number命令,即remote-numberdial-number一致。

·     为了使Server端有足够的时间进行回呼,Client端下次呼叫发起前的链路断开时间应至少比Server端的长10秒。建议Server端下次呼叫发起前的链路断开时间使用默认值5秒,Client端配置为15秒。

 

3. 使用共享DCC配置ISDN主叫识别回呼

共享DCC实现ISDN主叫识别回呼的Client端配置

表1-23 共享DCC实现ISDN主叫识别回呼的Client端配置

操作

命令

说明

进入系统视图

system-view

-

进入Dialer接口视图

interface dialer interface-number

-

配置呼叫一个对端的拨号串

dialer number dial-number

必选

配置下次呼叫发起前的链路断开时间(建议值15秒)

dialer timer enable seconds

可选

 

共享DCC实现ISDN主叫识别回呼的Server端配置

请在拨号接口(Dialer接口)视图下进行下列配置。

表1-24 共享DCC实现ISDN主叫识别回呼的Server端配置

操作

命令

说明

进入系统视图

system-view

-

进入Dialer接口视图

interface dialer interface-number

-

配置按照ISDN主叫识别号码进行ISDN回呼

dialer call-in remote-number [ callback ]

必选

配置呼叫一个对端的拨号串

dialer number dial-number

必选

 

·     在Server端拨号接口(Dialer接口)上需要配置dialer number命令,不要求与拨入呼叫串完全一致。

·     为了使Server端有足够的时间进行回呼,Client端下次呼叫发起前的链路断开时间应至少比Server端的长10秒。建议Server端下次呼叫发起前的链路断开时间使用默认值5秒,Client端配置为15秒。

 

1.2.7  DCC特殊功能的配置

1. ISDN专线配置

该功能只能与轮询DCC结合使用,并且必须在完成轮询DCC配置的基础上进行。ISDN专线应用通过建立ISDN的MP半永久连接来实现,要求电信局PBX交换机上配有专线并连接对端设备。

表1-25 ISDN专线配置

操作

命令

说明

进入系统视图

system-view

-

进入物理接口视图

interface interface-type interface-number

-

配置用于ISDN专线连接的B通道

dialer isdn-leased number

必选

缺省情况下,未配置ISDN专线连接的B通道

 

ISDN BRI接口不仅支持64k专线,还支持128k专线,相关内容请参见“二层技术-广域网接入配置指导”中的“ISDN”。

2. 自动拨号配置

该功能只能和轮询DCC结合使用。所谓自动拨号是指:在路由器启动后,DCC将自动尝试拨号连接对端,无需通过数据报文进行触发。若无法与对端正常建立拨号连接,则每隔一段时间DCC将再次自动尝试建立拨号连接。与数据触发的非自动拨号DCC相比,该连接建立后不会因超时而自动挂断(即dialer timer idle命令对自动拨号不起作用)。

表1-26 自动拨号配置

操作

命令

说明

进入系统视图

system-view

-

进入拨号接口(物理接口或Dialer接口)视图

interface interface-type  interface-number

-

配置自动呼叫一个(或多个)对端的目的地址及拨号串

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] * dial-number  autodial [ interface interface-type interface-number ]

必选

缺省情况下,未配置自动拨号功能

设置自动拨号的时间间隔

dialer timer autodial seconds

可选

当启动自动拨号功能后,自动拨号时间间隔缺省为300秒

 

3. 拨号串循环备份配置

该功能仅能与轮询DCC结合使用。使用轮询DCC配置同一个目的网络层地址时,可配置多条dialer route命令分别对应不同的拨号串,从而dialer route命令之间形成拨号串备份,即如果使用当前拨号串无法呼通对端,则下次呼叫时自动选择包含下一个拨号串的dialer route进行拨号。

表1-27 拨号串循环备份配置

操作

命令

说明

进入系统视图

system-view

-

进入拨号接口(物理接口或Dialer接口)视图

interface interface-type interface-number

-

对应同一个next-hop-address,配置多个拨号串以达到拨号串备份的功能(该命令需配置多次)

dialer route protocol next-hop-address [ mask network-mask-length ] [ user hostname | broadcast ] * dial-number [ autodial | interface interface-type interface-number ] *

必选

 

4. DCC重叠接收功能配置

缺省情况下,DCC工作在非重叠接收模式,即DCC被叫方收到一个号码后立即开始建立DCC连接,而不需等待被叫号码接收完整。当配置DCC工作在重叠接收模式后,DCC被叫方只有在被叫号码接收完整后才开始建立DCC连接。

只有在ISDN物理接口上配置DCC功能时,才需要配置DCC重叠接收功能。

表1-28 DCC重叠接收功能配置

操作

命令

说明

进入系统视图

system-view

-

进入拨号接口(ISDN物理接口)视图

interface interface-type interface-number

-

配置DCC工作在重叠接收模式

dialer overlap-receiving

必选

缺省情况下,DCC工作在非重叠接收模式

 

通常情况下,不需要配置本功能,但在北美市场,为了和某些设备互通,需要配置本功能。

 

1.2.8  DCC拨号接口属性参数配置

轮询DCC和共享DCC还具备一些可选参数,通过灵活配置这些参数可以提高按需拨号的效率,从而满足多方面需求。

1. DCC拨号接口属性参数介绍

DCC拨号接口属性参数配置包括:

·     链路空闲时间

当一条链路建立后,用户设置的链路空闲时间会起作用。当链路空闲超过了指定时间后,DCC将断开链路。

·     下次呼叫发起前的链路断开时间

当DCC呼叫链路因故障或挂断等原因导致进入断开状态,必须经过指定时间后才能建立新的拨号连接(即进行下一次呼叫的间隔时间),从而避免对端PBX设备过载。

·     接口竞争时的链路空闲时间

当DCC开始发起新呼叫时,若所有通道都被占满则进入“竞争”状态。通常一条链路建立后Idle超时定时器将起作用。但若同时刻去往另一目的地址的呼叫发生,则会引起竞争,此时DCC使用Compete-idle超时定时器取代Idle超时定时器,即链路空闲时间达到Compete-idle超时定时器的规定后将自动断开。

·     呼叫建立超时时间

和某些对端建立DCC呼叫时,从呼叫发起到连接建立的时间长短不一,为了有效控制发起呼叫到呼叫连接建立之间允许等待的时间,可以配置Wait-carrier定时器,规定若在指定时间内呼叫仍未建立,则DCC将终止该呼叫。

·     拨号接口缓冲队列长度

没有为拨号接口配置缓冲队列的情况下,当拨号接口收到一个报文时,如果此时连接还没有成功建立,则这个报文将会被丢弃。如果为拨号接口配置了缓冲队列,则在连接成功建立之前报文将被缓存而不是被丢弃,待连接成功后再发送。

2. 配置DCC拨号接口属性参数

表1-29 配置DCC拨号接口属性参数

操作

命令

说明

 

进入系统视图

system-view

-

 

进入拨号接口(物理接口或Dialer接口)视图

interface interface-type interface-number

-

 

配置链路空闲时间

dialer timer idle seconds

可选

缺省情况下,链路空闲时间为120秒

 

配置下次呼叫发起前的链路断开时间

dialer timer enable seconds

可选

缺省情况下,链路断开时间为5秒

 

配置接口竞争时的链路空闲时间

dialer timer compete seconds

可选

缺省情况下,忙接口的空闲时间为20秒

 

配置呼叫建立超时时间间隔

dialer timer wait-carrier seconds

可选

缺省情况下,呼叫建立超时时间间隔为60秒

 

配置拨号接口缓冲队列长度

dialer queue-length packets

可选

缺省情况下,不对报文进行缓存

 

配置接口的期望带宽

bandwidth bandwidth-value

可选

 

1.2.9  配置通过DCC实现动态路由备份

目前只有Dailer接口、PRI接口、BRI接口、Serial接口(工作在异步方式)、AM接口、AUX接口和Async接口等拨号接口支持动态路由备份功能。

 

1. 动态路由备份简介

动态路由备份通过DCC来动态维护拨号链路,即基于路由进行的拨号备份。

动态路由备份很好地集成了备份和路由功能,提供了可靠的连接和规范的按需拨号服务。

动态路由备份的特点

动态路由备份主要是针对动态路由协议产生的路由进行备份,也可以对静态路由和直连路由进行备份。

动态路由备份不对特定接口或特定链路进行备份,适用于多接口和多路由器的情况。

动态路由备份的主链路断开时备份链路将自动启动,不会导致拨号延迟(该延迟未包括路由收敛时间)。

动态路由备份不依赖于具体的路由协议,可以和RIP-1、RIP-2、OSPF、IS-IS、BGP等路由协议配合工作。但有些路由协议(如BGP)默认使用优选路由,当到达被监控网段的主链路故障中断,启用备份链路之后,备份链路通过BGP协议学习到达被监控网段的路由;当主链路再次启用后,主链路通过BGP协议学到的路由和备份链路学到的路由相比可能不是最优路由,因此继续使用从备份链路学到的路由,导致动态路由监控失败,备份链路在主链路恢复时无法挂断。

对于BGP协议,需要使用下面的方法来解决这种问题:

·     备份链路的IP地址要大于主链路的IP地址;

·     配置负载分担,即让同一路由可以通过多条链路学到。

动态路由备份的实现步骤

通过配置要监控的网段,可以实现在主链路故障时启动备份链路。动态路由备份监控路由、启动备份链路的顺序如下:

·     系统监控到达需监控网段是否存在路由更新,并检查到达需监控网段是否存在至少一条有效路由;

·     如果存在至少一条到达需监控网段的路由,并且这条路由从其他接口(未启动动态路由备份功能的接口)出发,则认为主链路接通;

·     如果不存在有效路由,则认为主链路关闭并且不可用,拨号启动备份链路;

·     备份链路启动后,拨号链路承载通信数据。在此过程中,系统会定时检查主链路的状态。

·     当主链路恢复后,根据用户的配置可以选择直接挂断备份链路,也可以等待定时器超时后再挂断备份链路。

2. 创建动态路由备份组

创建动态路由备份组有两种方法:

创建多个动态路由备份组,每个备份组监控不同的网段,各监控网段之间为“或”的关系,即当到达其中某一个网段不存在有效路由时,就试图拨通备份链路。对于每个动态路由备份组,在拨号接口都独立的拨通或挂断一条链路。

创建一个动态路由备份组,该备份组监控多个网段,各监控网段之间为“与”的关系,即当到达所有被监控网段都不存在有效路由时,才试图拨通备份链路。拨通备份链路时依次查找各监控网段在拨号接口是否配有dialer route,当配置多个时,用查到的第一个dialer route拨号,且只能拨通一条链路。

表1-30 创建动态路由备份组

操作

命令

说明

进入系统视图

system-view

-

创建动态路由备份组,并将被监控网段加入该备份组

standby routing-rule group-number ip ip-address { mask | mask-length }

必选

缺省情况下,没有创建动态路由备份组

 

standby routing-rule里的IP地址应与相对应的dialer route命令中的IP地址完全一致。

 

3. 在备份接口上启用动态路由备份功能

启用动态路由备份功能之前,必须确保备份接口上已经配置了基本DCC功能。

表1-31 在备份接口上启用动态路由备份功能

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

启用动态路由备份功能

standby routing-group group-number

必选

缺省情况下,禁用动态路由备份功能

 

4. 配置断开备份链路的延迟时间

在主链路接通后,为了防止路由振荡,可以经过指定延迟时间再断开备份链路。

表1-32 配置延迟断开备份链路的时间

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置断开备份链路的延迟时间

standby timer routing-disable seconds

可选

缺省情况下,断开备份接口的延迟时间为20秒

 

5. 配置动态路由备份功能在系统启动后多久可以生效

支持本特性的设备,一般情况下,请使用缺省情况。

 

系统启动后会进行配置恢复,配置恢复过程中由于主接口状态为down,因此主接口上的路由不可达,导致备份链路被进行呼叫。配置恢复后,所有接口的状态变为up,备份链路被呼叫成功。然后由于主接口路由恢复,备份链路再次被禁用,状态变为down。为了避免系统启动后的短时间内备份链路up/down切换一次,可以配置在系统启动指定时间后动态路由备份功能才生效,在这段时间内不对备份链路进行呼叫。

表1-33 配置动态路由备份功能在系统启动后多久可以生效

操作

命令

说明

进入系统视图

system-view

-

配置动态路由备份功能在系统启动后多久可以生效

dialer timer warmup seconds

可选

缺省情况下,动态路由备份功能在系统启动30秒后生效

 

1.2.10  配置系统进行流量统计的间隔时间

表1-34 配置系统进行流量统计的间隔时间

操作

命令

说明

进入系统视图

system-view

-

配置DCC进行流量统计的间隔时间

dialer flow-interval interval

可选

缺省情况下,DCC进行流量统计的间隔时间为20秒

 

1.3  DCC显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示DCC配置后的运行情况,通过查看显示信息验证配置的效果。

在任意视图下执行dialer disconnect命令可以拆除拨号链路。

在用户视图下执行reset命令可以清除Dialer接口的统计信息。

表1-35 DCC显示和维护

操作

命令

显示拨号接口信息

display dialer [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

显示Dialer接口的信息

display interface dialer number [ brief ] [ | { begin | exclude | include } regular-expression ]

display interface [ dialer ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

拆除拨号链路

dialer disconnect [ interface interface-type interface-number ]

清除Dialer接口的统计信息

reset counters interface [ dialer [ number ] ]

 

1.4  DCC典型配置举例

1.4.1  轮询DCC应用

1. 组网需求

路由器Router A、Router B和Router C地址在同一网段,其中Router A地址为100.1.1.1/24,Router B地址为100.1.1.2/24,Router C地址为100.1.1.3/24。路由器Router A通过多个接口与Router B、Router C之间可以互相呼叫,而Router B和Router C之间不能互相呼叫。

要求使用轮询DCC完成上述功能。

2. 组网图

图1-10 轮询DCC应用组网图

 

3. 配置步骤

配置Router A

# 配置拨号访问组1以及对应的拨号访问控制条件。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 配置Dialer0接口IP地址,将拨号访问组1与接口关联,启动轮询DCC,分别配置到达Router B和Router C的拨号串。

[RouterA] interface dialer 0

[RouterA-Dialer0] dialer enable-circular

[RouterA-Dialer0] ip address 100.1.1.1 255.255.255.0

[RouterA-Dialer0] dialer-group 1

[RouterA-Dialer0] dialer route ip 100.1.1.2 8810052

[RouterA-Dialer0] dialer route ip 100.1.1.3 8810063

[RouterA-Dialer0] quit

# 配置Serial2/0接口工作在异步协议方式以及使用的Dialer Circular Group组。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] physical-mode async

[RouterA-Serial2/0] async mode protocol

[RouterA-Serial2/0] dialer circular-group 0

[RouterA-Serial2/0] quit

# 配置Serial2/1接口工作在异步协议方式以及使用的Dialer Circular Group组。

[RouterA] interface serial 2/1

[RouterA-Serial2/1] physical-mode async

[RouterA-Serial2/1] async mode protocol

[RouterA-Serial2/1] dialer circular-group 0

[RouterA-Serial2/1] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterA] user-interface tty1

[RouterA-ui-tty1] modem both

[RouterA-ui-tty1] quit

[RouterA] user-interface tty2

[RouterA-ui-tty2] modem both

配置Router B

# 配置拨号访问组1以及对应的访问控制条件。

<RouterB> system-view

[RouterB] dialer-rule 1 ip permit

# 配置Serial2/0接口工作在异步拨号方式。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] physical-mode async

[RouterB-Serial2/0] async mode protocol

# 配置Serial2/0接口IP地址,启动轮询DCC,配置到达对端的两个拨号串。

[RouterB-Serial2/0] ip address 100.1.1.2 255.255.255.0

[RouterB-Serial2/0] dialer enable-circular

[RouterB-Serial2/0] dialer-group 1

[RouterB-Serial2/0] dialer route ip 100.1.1.1 8810048

[RouterB-Serial2/0] dialer route ip 100.1.1.1 8810049

[RouterB-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterB] user-interface tty1

[RouterB-ui-tty1] modem both

配置Router C

# 配置拨号访问组1以及对应的拨号访问控制条件。

<RouterC> system-view

[RouterC] dialer-rule 1 ip permit

# 配置Serial2/0接口工作在异步拨号方式。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] physical-mode async

[RouterC-Serial2/0] async mode protocol

# 配置Serial2/0接口的IP地址,启动轮询DCC,配置到达对端的两个拨号串。

[RouterC-Serial2/0] ip address 100.1.1.3 255.255.255.0

[RouterC-Serial2/0] dialer enable-circular

[RouterC-Serial2/0] dialer-group 1

[RouterC-Serial2/0] dialer route ip 100.1.1.1 8810048

[RouterC-Serial2/0] dialer route ip 100.1.1.1 8810049

[RouterC-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterC] user-interface tty1

[RouterC-ui-tty1] modem both

1.4.2  共享DCC应用

1. 组网需求

路由器Router A通过多个接口与Router B、Router C之间可以互相呼叫,而Router B和Router C之间不能互相呼叫。

如下图所示,Router A、Router B地址在同一网段,Router A和Router C地址也在同一网段,其中Router A的Dialer0接口地址为100.1.1.1/24,Dialer1接口地址为122.1.1.1/24,Router B的Dialer0接口地址为100.1.1.2/24,Router C的Dialer0接口地址为122.1.1.2/24。

要求使用共享DCC完成上述功能。

2. 组网图

图1-11 共享DCC应用组网图

 

3. 配置步骤

配置Router A

# 配置拨号访问组1以及对应的拨号访问控制条件,配置PPP验证的本地用户userb和userc。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

[RouterA] local-user userb

[RouterA-luser-userb] password simple userb

[RouterA-luser-userb] service-type ppp

[RouterA-luser-userb] quit

[RouterA] local-user userc

[RouterA-luser-userc] password simple userc

[RouterA-luser-userc] service-type ppp

[RouterA-luser-userc] quit

# 配置Dialer0接口的IP地址,启动共享DCC,配置允许拨入的对端用户名。

[RouterA] interface dialer 0

[RouterA-Dialer0] ip address 100.1.1.1 255.255.255.0

[RouterA-Dialer0] dialer user userb

[RouterA-Dialer0] dialer bundle 1

# 配置PPP认证信息以及到达对端的拨号串(本端采用PAP验证对端)。

[RouterA-Dialer0] dialer-group 1

[RouterA-Dialer0] ppp authentication-mode pap

[RouterA-Dialer0] ppp pap local-user usera password simple usera

[RouterA-Dialer0] dialer number 8810052

[RouterA-Dialer0] quit

#配置Dialer1接口的IP地址,启动共享DCC,配置允许拨入的对端用户名。

[RouterA] interface dialer 1

[RouterA-Dialer1] ip address 122.1.1.1 255.255.255.0

[RouterA-Dialer1] dialer user userc

[RouterA-Dialer1] dialer bundle 2

# 配置PPP认证信息以及到达对端的拨号串(本端采用PAP验证对端)。

[RouterA-Dialer1] dialer-group 1

[RouterA-Dialer1] ppp authentication-mode pap

[RouterA-Dialer1] ppp pap local-user usera password simple usera

[RouterA-Dialer1] dialer number 8810063

[RouterA-Dialer1] quit

# 配置Serial2/0接口工作在异步协议方式,配置PPP认证信息,配置该接口属于Dialer bundle1和Dialer bundle2。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] physical-mode async

[RouterA-Serial2/0] async mode protocol

[RouterA-Serial2/0] dialer bundle-member 1

[RouterA-Serial2/0] dialer bundle-member 2

[RouterA-Serial2/0] link-protocol ppp

[RouterA-Serial2/0] ppp authentication-mode pap

[RouterA-Serial2/0] ppp pap local-user usera password simple usera

[RouterA-Serial2/0] quit

# 配置Serial2/1接口工作在异步协议方式,配置PPP认证信息,配置该接口属于Dialer bundle1和Dialer bundle2。

[RouterA] interface serial 2/1

[RouterA-Serial2/1] physical-mode async

[RouterA-Serial2/1] async mode protocol

[RouterA-Serial2/1] dialer bundle-member 1

[RouterA-Serial2/1] dialer bundle-member 2

[RouterA-Serial2/1] link-protocol ppp

[RouterA-Serial2/1] ppp authentication-mode pap

[RouterA-Serial2/1] ppp pap local-user usera password simple usera

[RouterA-Serial2/1] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterA] user-interface tty1

[RouterA-ui-tty1] modem both

[RouterA-ui-tty1] quit

[RouterA] user-interface tty2

[RouterA-ui-tty2] modem both

配置Router B

# 配置拨号访问组2以及对应的拨号访问控制条件,配置PPP验证的本地用户usera。

<RouterB> system-view

[RouterB] dialer-rule 2 ip permit

[RouterB] local-user usera

[RouterB-luser-usera] password simple usera

[RouterB-luser-usera] service-type ppp

[RouterB-luser-usera] quit

# 配置Dialer0接口的IP地址,启动共享DCC,配置Dialer0接口允许拨入的用户以及到达对端的拨号串。

[RouterB] interface dialer 0

[RouterB-Dialer0] ip address 100.1.1.2 255.255.255.0

[RouterB-Dialer0] dialer user usera

[RouterB-Dialer0] dialer bundle 1

[RouterB-Dialer0] dialer number 8810048

# 配置PPP认证信息(本端采用PAP验证对端)。

[RouterB-Dialer0] dialer-group 2

[RouterB-Dialer0] ppp authentication-mode pap

[RouterB-Dialer0] ppp pap local-user userb password simple userb

[RouterB-Dialer0] quit

# 配置Serial2/0接口异步协议方式,配置PPP认证信息,配置该接口属于Dialer bundle1。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] physical-mode async

[RouterB-Serial2/0] async mode protocol

[RouterB-Serial2/0] dialer bundle-member 1

[RouterB-Serial2/0] link-protocol ppp

[RouterB-Serial2/0] ppp authentication-mode pap

[RouterB-Serial2/0] ppp pap local-user userb password simple userb

[RouterB-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterB] user-interface tty1

[RouterB-ui-tty1] modem both

配置Router C

# 配置拨号访问组1以及对应的拨号访问控制条件,配置PPP验证的本地用户usera。

<RouterC> system-view

[RouterC] dialer-rule 1 ip permit

[RouterC] local-user usera

[RouterC-luser-usera] password simple usera

[RouterC-luser-usera] service-type ppp

[RouterC-luser-usera] quit

# 配置Dialer0接口的IP地址,启动共享DCC,配置Dialer0接口允许拨入的用户以及到达对端的拨号串。

[RouterC] interface dialer 0

[RouterC-Dialer0] ip address 122.1.1.2 255.255.255.0

[RouterC-Dialer0] dialer user usera

[RouterC-Dialer0] dialer bundle 1

[RouterC-Dialer0] dialer number 8810049

# 配置PPP认证信息(本端采用PAP验证对端)。

[RouterC-Dialer0] dialer-group 1

[RouterC-Dialer0] ppp authentication-mode pap

[RouterC-Dialer0] ppp pap local-user userc password simple userc

[RouterC-Dialer0] quit

# 配置Serial2/0接口工作在异步协议方式,配置PPP认证信息,配置该接口属于Dialer bundle1。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] physical-mode async

[RouterC-Serial2/0] async mode protocol

[RouterC-Serial2/0] dialer bundle-member 1

[RouterC-Serial2/0] link-protocol ppp

[RouterC-Serial2/0] ppp authentication-mode pap

[RouterC-Serial2/0] ppp pap local-user userc password simple userc

[RouterC-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterC] user-interface tty1

[RouterC-ui-tty1] modem both

1.4.3  基于ISDN的DCC应用

1. 组网需求

路由器Router A通过多个接口与Router B、Router C之间可以互相呼叫,而Router B和Router C之间不能互相呼叫。

如下图所示,使用轮询DCC时,路由器Router A、Router B和Router C地址在同一网段,其中Router A地址为100.1.1.1/24,Router B地址为100.1.1.2/24,Router C地址为100.1.1.3/24;使用共享DCC时,Router A、Router B地址在同一网段,Router A和Router C地址也在同一网段,其中Router A的Dialer0接口地址为100.1.1.1/24,Dialer1接口地址为122.1.1.1/24,Router B的Dialer0接口地址为100.1.1.2/24,Router C的Dialer0接口地址为122.1.1.2/24。

2. 组网图

图1-12 基于ISDN的DCC应用组网图(轮询DCC方式)

 

图1-13 基于ISDN的DCC应用组网图(共享DCC方式)

 

3. 配置步骤

方案一:使用轮询DCC方法通过ISDN BRI或PRI接口建立连接,在物理接口上配置DCC参数。

配置Router A

# 配置拨号访问组1以及对应的拨号访问控制条件。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 配置BRI1/0接口的IP地址,启动轮询DCC,配置到达对端的拨号串。

[RouterA] interface bri 1/0

[RouterA-Bri1/0] ip address 100.1.1.1 255.255.255.0

[RouterA-Bri1/0] dialer enable-circular

[RouterA-Bri1/0] dialer-group 1

[RouterA-Bri1/0] dialer route ip 100.1.1.2 8810052

[RouterA-Bri1/0] dialer route ip 100.1.1.3 8810063

配置Router B

# 配置拨号访问组2以及对应的拨号访问控制条件。

<RouterB> system-view

[RouterB] dialer-rule 2 ip permit

# 配置BRI1/0接口的IP地址,启动轮询DCC,配置到达对端的拨号串。

[RouterB] interface bri 1/0

[RouterB-Bri1/0] ip address 100.1.1.2 255.255.255.0

[RouterB-Bri1/0] dialer enable-circular

[RouterB-Bri1/0] dialer-group 2

[RouterB-Bri1/0] dialer route ip 100.1.1.1 8810048

配置Router C

# 配置拨号访问组1以及对应的拨号访问控制条件。

<RouterC> system-view

[RouterC] dialer-rule 1 ip permit

# 配置BRI1/0接口的IP地址,启动轮询DCC,配置到达对端的拨号串。

[RouterC] interface bri 1/0

[RouterC-Bri1/0] ip address 100.1.1.3 255.255.255.0

[RouterC-Bri1/0] dialer enable-circular

[RouterC-Bri1/0] dialer-group 1

[RouterC-Bri1/0] dialer route ip 100.1.1.1 8810048

方案二:使用共享DCC方法通过ISDN BRI或PRI接口建立连接,在Dialer接口上配置DCC参数。

配置Router A

# 配置拨号访问组1以及对应的拨号访问控制条件,配置PPP验证的本地用户userb和userc。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

[RouterA] local-user userb

[RouterA-luser-userb] password simple userb

[RouterA-luser-userb] service-type ppp

[RouterA-luser-userb] quit

[RouterA] local-user userc

[RouterA-luser-userc] password simple userc

[RouterA-luser-userc] service-type ppp

[RouterA-luser-userc] quit

# 配置Dialer0接口的IP地址,启动共享DCC,配置Dialer0接口允许拨入的用户。

[RouterA] interface dialer 0

[RouterA-Dialer0] ip address 100.1.1.1 255.255.255.0

[RouterA-Dialer0] dialer user userb

[RouterA-Dialer0] dialer bundle 1

# 配置Dialer0接口的PPP认证信息以及到达对端的拨号串。

[RouterA-Dialer0] dialer-group 1

[RouterA-Dialer0] ppp authentication-mode pap

[RouterA-Dialer0] ppp pap local-user usera password simple usera

[RouterA-Dialer0] dialer number 8810052

[RouterA-Dialer0] quit

# 配置Dialer1接口的IP地址,启动共享DCC,配置Dialer1接口允许拨入的用户。

[RouterA] interface dialer 1

[RouterA-Dialer1] ip address 122.1.1.1 255.255.255.0

[RouterA-Dialer1] dialer user userc

[RouterA-Dialer1] dialer bundle 2

# 配置Dialer1接口的PPP认证信息以及到达对端的拨号串。

[RouterA-Dialer1] dialer-group 1

[RouterA-Dialer1] ppp authentication-mode pap

[RouterA-Dialer1] ppp pap local-user usera password simple usera

[RouterA-Dialer1] dialer number 8810063

[RouterA-Dialer1] quit

# 配置BRI1/0接口的PPP认证信息以及所属的Dialer bundle。

[RouterA] interface bri 1/0

[RouterA-Bri1/0] dialer bundle-member 1

[RouterA-Bri1/0] dialer bundle-member 2

[RouterA-Bri1/0] link-protocol ppp

[RouterA-Bri1/0] ppp authentication-mode pap

[RouterA-Bri1/0] ppp pap local-user usera password simple usera

配置Router B

# 配置拨号访问组2以及对应的拨号访问控制条件,配置PPP验证的本地用户usera。

<RouterB> system-view

[RouterB] dialer-rule 2 ip permit

[RouterB] local-user usera

[RouterB-luser-usera] password simple usera

[RouterB-luser-usera] service-type ppp

[RouterB-luser-usera] quit

# 配置Dialer0接口的IP地址,启动共享DCC,配置接口允许拨入的用户。

[RouterB] interface dialer 0

[RouterB-Dialer0] ip address 100.1.1.2 255.255.255.0

[RouterB-Dialer0] dialer user usera

[RouterB-Dialer0] dialer bundle 1

# 配置Dialer0接口的PPP认证信息以及到达对端的拨号串。

[RouterB-Dialer0] dialer-group 2

[RouterB-Dialer0] ppp authentication-mode pap

[RouterB-Dialer0] dialer number 8810048

[RouterB-Dialer0] ppp pap local-user userb password simple userb

[RouterB-Dialer0] quit

# 配置BRI1/0接口的PPP认证信息以及所属的Dialer bundle。

[RouterB] interface bri 1/0

[RouterB-Bri1/0] dialer bundle-member 1

[RouterB-Bri1/0] link-protocol ppp

[RouterB-Bri1/0] ppp authentication-mode pap

[RouterB-Bri1/0] ppp pap local-user usera password simple usera

配置Router C

# 配置拨号访问组2以及对应的拨号访问控制条件,配置PPP验证的本地用户usera。

<RouterC> system-view

[RouterC] dialer-rule 1 ip permit

[RouterC] local-user usera

[RouterC-luser-usera] password simple usera

[RouterC-luser-usera] service-type ppp

[RouterC-luser-usera] quit

# 配置Dialer0接口的IP地址,启动共享DCC,配置接口允许拨入的用户。

[RouterC] interface dialer 0

[RouterC-Dialer0] ip address 122.1.1.2 255.255.255.0

[RouterC-Dialer0] dialer user usera

[RouterC-Dialer0] dialer bundle 1

# 配置Dialer0接口的PPP认证信息以及到达对端的拨号串。

[RouterC-Dialer0] dialer-group 1

[RouterC-Dialer0] dialer number 8810048

[RouterC-Dialer0] ppp authentication-mode pap

[RouterC-Dialer0] ppp pap local-user userc password simple userc

[RouterC-Dialer0] quit

# 配置BRI1/0接口的PPP认证信息以及所属的Dialer bundle。

[RouterC] interface bri 1/0

[RouterC-Bri1/0] dialer bundle-member 1

[RouterC-Bri1/0] link-protocol ppp

[RouterC-Bri1/0] ppp authentication-mode pap

[RouterC-Bri1/0] ppp pap local-user usera password simple usera

1.4.4  提供MP捆绑功能的DCC应用

1. 组网需求

本地路由器通过两个ISDN BRI接口和远端连接,要求通过设定流量负载阈值来控制接口的流量分配,从而根据实际流量进行带宽分配,并规定允许的最大带宽。

如下图所示,Router A和Router B之间利用ISDN BRI和PRI接口通过ISDN网络进行连接,要求Router A以共享DCC方式呼叫Router B,Router B以轮询DCC方式呼叫Router A。其中,Router A地址为100.1.1.1/24,Router B地址为100.1.1.2/24。

2. 组网图

图1-14 提供MP捆绑功能的DCC应用组网图

 

3. 配置步骤

配置Router A

# 配置拨号访问组1以及对应的拨号访问控制条件,配置PPP验证的本地用户userb,配置DCC进行流量统计的间隔时间为3秒。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

[RouterA] local-user userb

[RouterA-luser-userb] password simple userb

[RouterA-luser-userb] service-type ppp

[RouterA-luser-userb] quit

[RouterA] dialer flow-interval 3

# 配置Dialer0接口的IP地址,启动共享DCC,配置MP捆绑的相关信息。

[RouterA] interface dialer 0

[RouterA-Dialer0] ip address 100.1.1.1 255.255.255.0

[RouterA-Dialer0] dialer bundle 1

[RouterA-Dialer0] ppp mp

[RouterA-Dialer0] dialer threshold 50

# 配置Dialer0接口允许拨入的用户,PPP认证信息,以及到达对端的拨号串。

[RouterA-Dialer0] dialer user userb

[RouterA-Dialer0] dialer-group 1

[RouterA-Dialer0] ppp authentication-mode pap

[RouterA-Dialer0] ppp pap local-user usera password simple usera

[RouterA-Dialer0] dialer number 8810052

[RouterA-Dialer0] quit

# 配置BRI1/1接口的PPP认证信息、所属的Dialer bundle。

[RouterA] interface bri 1/1

[RouterA-Bri1/1] dialer bundle-member 1

[RouterA-Bri1/1] ppp mp

[RouterA-Bri1/1] link-protocol ppp

[RouterA-Bri1/1] ppp authentication-mode pap

[RouterA-Bri1/1] ppp pap local-user usera password simple usera

# 配置BRI1/0接口PPP认证信息、所属的Dialer bundle。

[RouterA-Bri1/0] interface bri 1/0

[RouterA-Bri1/0] dialer bundle-member 1

[RouterA-Bri1/0] ppp mp

[RouterA-Bri1/0] link-protocol ppp

[RouterA-Bri1/0] ppp authentication-mode pap

[RouterA-Bri1/0] ppp pap local-user usera password simple usera

配置Router B

# 配置拨号访问组2以及对应的拨号访问控制条件,配置PPP验证的本地用户usera,配置DCC进行流量统计的间隔时间为3秒。

<RouterB> system-view

[RouterB] dialer-rule 2 ip permit

[RouterB] local-user usera

[RouterB-luser-usera] password simple usera

[RouterB-luser-usera] service-type ppp

[RouterB-luser-usera] quit

[RouterB] dialer flow-interval 3

# 配置Dialer0接口的IP地址、到达对端的拨号串、MP捆绑、PPP认证信息。

[RouterB] interface dialer 0

[RouterB-Dialer0] ip address 100.1.1.2 255.255.255.0

[RouterB-Dialer0] dialer enable-circular

[RouterB-Dialer0] dialer-group 2

[RouterB-Dialer0] dialer route ip 100.1.1.1 8810048

[RouterB-Dialer0] dialer route ip 100.1.1.1 8810049

[RouterB-Dialer0] ppp mp

[RouterB-Dialer0] ppp authentication-mode pap

[RouterB-Dialer0] ppp pap local-user userb password simple userb

[RouterB-Dialer0] quit

# 配置CE1/PRI接口E1 2/0,使其工作在PRI方式。

[RouterB] controller e1 2/0

[RouterB-E1 2/0] pri-set

[RouterB-E1 2/0] quit

# 在CE1/PRI接口E1 2/0生成的接口Serial2/0:15上启动轮询DCC、与Dialer0关联。

[RouterB] interface serial 2/0:15

[RouterB-Serial2/0:15] dialer enable-circular

[RouterB-Serial2/0:15] dialer circular-group 0

1.4.5  路由器回呼路由器的DCC应用(PPP方式)

1. 组网需求

两台路由器在PSTN网络中通过串口实现PPP回呼。

如下图所示,Router A和Router B利用串口通过PSTN网络连接,采用轮询DCC配置方法。规定Router A为回呼Client端,Router B为回呼Server端。Router A的IP地址为100.1.1.1/24,Router B的IP地址为100.1.1.2/24。

2. 组网图

图1-15 路由器回呼路由器的DCC组网图

 

3. 配置步骤

方案一:使用轮询DCC方法实现PPP回呼,Server端按照dialer route命令配置的用户名来选择回呼Client端。

配置Router A

# 配置拨号访问组1以及对应的拨号访问控制条件。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 配置接口Serial2/0的IP地址、物理层参数以及轮询DCC参数。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 100.1.1.1 255.255.255.0

[RouterA-Serial2/0] physical-mode async

[RouterA-Serial2/0] async mode protocol

[RouterA-Serial2/0] dialer enable-circular

[RouterA-Serial2/0] dialer-group 1

[RouterA-Serial2/0] dialer route ip 100.1.1.2 8810052

[RouterA-Serial2/0] link-protocol ppp

[RouterA-Serial2/0] ppp pap local-user usera password simple usera

# 配置接口Serial2/0作为回呼Client端。

[RouterA-Serial2/0] ppp callback client

[RouterA-Serial2/0] dialer timer enable 15

[RouterA-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterA] user-interface tty1

[RouterA-ui-tty1] modem both

配置Router B

# 配置拨号访问组2以及对应的拨号访问控制条件,配置PPP验证的本地用户名usera。

<RouterB> system-view

[RouterB] dialer-rule 2 ip permit

[RouterB] local-user usera

[RouterB-luser-usera] password simple usera

[RouterB-luser-usera] service-type ppp

[RouterB-luser-usera] quit

# 配置接口Serial2/0的IP地址、物理层参数以及轮询DCC参数。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 100.1.1.2 255.255.255.0

[RouterB-Serial2/0] physical-mode async

[RouterB-Serial2/0] async mode protocol

[RouterB-Serial2/0] dialer enable-circular

[RouterB-Serial2/0] dialer-group 2

[RouterB-Serial2/0] link-protocol ppp

[RouterB-Serial2/0] ppp authentication-mode pap

# 配置本端作为回呼Server,回呼方式为user,根据dialer route命令中配置的用户名对应的拨号串进行回呼。

[RouterB-Serial2/0] dialer callback-center user

[RouterB-Serial2/0] dialer route ip 100.1.1.1 user usera 8810048

[RouterB-Serial2/0] ppp callback server

[RouterB-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterB] user-interface tty2

[RouterB-ui-tty2] modem both

方案二:使用轮询DCC方法实现PPP回呼,Server端根据PPP认证中接收的对端用户名查找本地用户表确定回呼的拨号串。

配置Router A

# 配置拨号访问组1以及对应的拨号访问控制条件。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 配置接口Serial2/0的IP地址、物理层参数以及轮询DCC参数。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 100.1.1.1 255.255.255.0

[RouterA-Serial2/0] physical-mode async

[RouterA-Serial2/0] async mode protocol

[RouterA-Serial2/0] dialer enable-circular

[RouterA-Serial2/0] dialer-group 1

[RouterA-Serial2/0] dialer route ip 100.1.1.2 8810052

[RouterA-Serial2/0] link-protocol ppp

[RouterA-Serial2/0] ppp pap local-user usera password simple usera

# 配置接口Serial2/0作为回呼Client端。

[RouterA-Serial2/0] ppp callback client

[RouterA-Serial2/0] dialer timer enable 15

[RouterA-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterA] user-interface tty1

[RouterA-ui-tty1] modem both

配置Router B

# 配置拨号访问组2及对应的拨号访问控制条件,配置PPP验证的本地用户名usera以及对应的拨号串。

<RouterB> system-view

[RouterB] dialer-rule 2 ip permit

[RouterB] local-user usera

[RouterB-luser-usera] password simple usera

[RouterB-luser-usera] service-type ppp

[RouterB-luser-usera] authorization-attribute callback-number 8810048

[RouterB-luser-usera] quit

# 配置接口Serial2/0的IP地址、物理层参数以及轮询DCC参数。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 100.1.1.2 255.255.255.0

[RouterB-Serial2/0] physical-mode async

[RouterB-Serial2/0] async mode protocol

[RouterB-Serial2/0] dialer enable-circular

[RouterB-Serial2/0] dialer-group 2

[RouterB-Serial2/0] dialer route ip 100.1.1.1 user usera 8810048

# 配置本端作为回呼Server,回呼方式为dial-number,根据PPP认证中接收的对端用户名查找本地用户表确定回呼的拨号串。

[RouterB-Serial2/0] dialer callback-center dial-number

[RouterB-Serial2/0] link-protocol ppp

[RouterB-Serial2/0] ppp authentication-mode pap

[RouterB-Serial2/0] ppp callback server

[RouterB-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterB] user-interface tty2

[RouterB-ui-tty2] modem both

1.4.6  路由器回呼路由器的DCC应用(ISDN方式)

1. 组网需求

两台路由器在ISDN网络中利用ISDN主叫识别技术实现ISDN回呼。

如下图所示,Router A和Router B之间利用ISDN BRI接口通过ISDN网络进行连接,采用轮询DCC配置方法。规定Router A为回呼Client端,Router B为回呼Server端。Router A的IP地址为100.1.1.1/24,Router B的IP地址为100.1.1.2/24。

2. 组网图

图1-16 ISDN主叫识别回呼组网图

 

3. 配置步骤

配置Router A

# 配置拨号访问组1及对应的拨号访问控制条件。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 配置接口BRI1/0的IP地址以及轮询DCC参数,配置到达RouterB的拨号串。

[RouterA] interface bri 1/0

[RouterA-Bri1/0] ip address 100.1.1.1 255.255.255.0

[RouterA-Bri1/0] dialer enable-circular

[RouterA-Bri1/0] dialer-group 1

[RouterA-Bri1/0] dialer route ip 100.1.1.2 8810052

[RouterA-Bri1/0] dialer timer enable 15

配置Router B

# 配置拨号访问组2及对应的拨号访问控制条件。

<RouterB> system-view

[RouterB] dialer-rule 2 ip permit

# 配置接口BRI1/0的IP地址以及轮询DCC参数,配置到达RouterA的拨号串。

[RouterB] interface bri 1/0

[RouterB-Bri1/0] ip address 100.1.1.2 255.255.255.0

[RouterB-Bri1/0] dialer enable-circular

[RouterB-Bri1/0] dialer-group 2

[RouterB-Bri1/0] dialer route ip 100.1.1.1 8810048

# 当本端识别出ISDN主叫号码为8810048时进行回呼。

[RouterB-Bri1/0] dialer call-in 8810048 callback

1.4.7  路由器回呼PC机的DCC应用

1. 组网需求

Router和PC机在PSTN网络中通过串口实现PPP回呼。如下图所示,PC机借助Modem与路由器Router在PSTN网络中连接,采用轮询DCC配置方法。规定PC机为回呼Client端,Router为回呼Server端,根据dialer route命令配置进行回呼。Router地址为100.1.1.1/24,PC机接受由Router分配的地址。

2. 组网图

图1-17 路由器回呼PC机的DCC组网图

 

3. 配置步骤

配置PC机(以Windows XP为例)

在Windows XP系统的PC上建立一个拨号网络连接,该连接具有“呼叫回拨”的能力。

步骤1     配置PC机连接的Modem为“自动应答方式”,然后打开[开始/程序/附件/通讯/网络连接],在“网络连接”窗口中,单击[创建一个新的连接];

步骤2     或者右键单击网上邻居,选择“属性”,打开“网络连接”对话框,单击[新建一个连接],出现新建连接向导对话框。

步骤3     单击“下一步”,出现“网络连接类型”对话框,选择第一项“连接到Internet”。

步骤4     单击“下一步”,进入“您想怎样连接到Internet”对话框,选择第二项“手动设置我的连接”。

步骤5     单击“下一步”,进入“Internet连接”对话框,选择“用拨号调制解调器连接”。单击“下一步”,进入“连接名”对话框,设置该连接的连接名。单击“下一步”,进入“要拨的电话号码”,设置拨叫回呼Server端的电话号码。单击“下一步”,进入“Internet帐户信息”,设置连接到Server端进行PPP验证时的用户名和密码。

步骤6     单击“下一步”,进入“完成新建连接向导”对话框,完成该连接的创建。

步骤7     在“网络连接”对话框中,在刚才新创建的连接上单击右键,选择“属性”,打开连接属性对话框,选择“网络”选项。在“我正在呼叫的拨号服务器类型”下拉框中选择“PPP”,单击“设置”按钮,进行如下操作:

·     选择[启用LCP扩展]选项

·     取消[启用软件压缩]选项

·     取消[为单链路连接协商多重链接]选项

·     其他设置为缺省值

单击“确认”按钮,完成设置。

步骤8     返回“网络连接”对话框,选中刚才新创建的连接,选择[高级/拨号首选项]菜单,打开“拨号首选项”对话框,选择“回拨”选项卡。如果选择“不回拨”,当Client端向Server端拨号验证身份后,Server端将不回拨,保持现有连接,Client端机可以直接访问局域网或者通过局域网访问互联网。如果选择“当服务器提供回拨时在拨号期间询问我”(需要用户输入一个回拨号码),或者选择“总是按以下号码回拨”(设置一个固定的回拨号码),Server端将使用用户输入的回拨号码或者设置好的回拨号码回拨Client端。

配置Router

# 配置拨号访问组1及对应的拨号访问控制条件,配置PPP验证使用的本地用户userpc。

<Router> system-view

[Router] dialer-rule 1 ip permit

[Router] local-user userpc

[Router-luser-userc] password simple userpc

[Router-luser-userc] service-type ppp

[Router-luser-userc] quit

# 配置接口Serial2/0的物理层参数以及IP地址。

[Router] interface serial 2/0

[Router-Serial2/0] ip address 100.1.1.1 255.255.255.0

[Router-Serial2/0] physical-mode async

[Router-Serial2/0] async mode protocol

# 配置接口Serial2/0的链路层协议为PPP,配置PPP的相关参数。

[Router-Serial2/0] link-protocol ppp

[Router-Serial2/0] ppp authentication-mode pap

[Router-Serial2/0] ppp pap local-user Router password simple Router

# 配置接口Serial2/0为对端分配IP地址。

[Router-Serial2/0] remote address 100.1.1.2

# 配置接口Serial2/0作为PPP回呼的Server端,回呼方式为user,根据dialer route命令中配置的用户名对应的拨号串进行回呼。

[Router-Serial2/0] ppp callback server

[Router-Serial2/0] dialer callback-center user

# 配置接口Serial2/0启动轮询DCC,并且配置轮询DCC参数。

[Router-Serial2/0] dialer enable-circular

[Router-Serial2/0] dialer-group 1

[Router-Serial2/0] dialer route ip 100.1.1.2 user userpc 8810048

[Router-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[Router] user-interface tty1

[Router-ui-tty1] modem both

1.4.8  NT服务器回呼路由器的DCC应用

1. 组网需求

Router和NT服务器在PSTN网络中通过串口实现PPP回呼。

如下图所示,Router与NT服务器借助Modem在PSTN网络中连接,采用轮询DCC配置方法。规定Router为回呼Client端,NT服务器为回呼Server端,根据dialer route命令配置进行回呼。NT服务器地址为100.1.1.254/24,Router地址接受由NT服务器分配的地址。

2. 组网图

图1-18 NT服务器回呼路由器的DCC组网图

 

3. 配置步骤

配置Router

# 配置拨号访问组1及对应的拨号访问控制条件,配置PPP验证使用的本地用户usernt。

<Router> system-view

[Router] dialer-rule 1 ip permit

[Router] local-user usernt

[Router-luser-userc] password simple usernt

[Router-luser-userc] service-type ppp

[Router-luser-userc] quit

# 配置接口Serial2/0的物理层参数。

[Router] interface serial 2/0

[Router-Serial2/0] physical-mode async

[Router-Serial2/0] async mode protocol

# 配置接口Serial2/0的链路层协议为PPP以及PPP的相关参数。

[Router-Serial2/0] link-protocol ppp

[Router-Serial2/0] ppp authentication-mode pap

[Router-Serial2/0] ppp pap local-user Router password simple Router

# 配置接口Serial2/0的IP地址可协商属性。

[Router-Serial2/0] ip address ppp-negotiate

# 配置接口Serial2/0作为PPP回呼的Client端。

[Router-Serial2/0] ppp callback client

[Router-Serial2/0] dialer timer enable 15

# 配置接口Serial2/0启动轮询DCC,并且配置轮询DCC参数。

[Router-Serial2/0] dialer enable-circular

[Router-Serial2/0] dialer-group 1

[Router-Serial2/0] dialer route ip 100.1.1.254 8810052

[Router-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[Router] user-interface tty1

[Router-ui-tty1] modem both

配置NT服务器:

Server端可以用Windows 2000或Windows XP,因为微软只在Windows 2000以后的操作系统中才加入了网络服务的模块,而在以前的(如Windows 98)操作系统中没有该模块。

Server端设置(以Windows XP为例)的目的是建立一个拨号网络连接,其连接具有“呼叫回拨”的能力。

步骤1     右键单击“网上邻居”,选择[属性]菜单项,然后单击“新建一个连接”,用户将看到“新建连接向导”对话框。

步骤2     单击“下一步”,用户将看到“网络连接类型”对话框,选择第四项“设置高级连接”。

步骤3     单击“下一步”,进入“高级连接选项”对话框,选择第一项“接受传入的连接”。

步骤4     单击“下一步”,进入“传入的虚拟专用网(VPN)连接”对话框,如果此服务器连接在Internet上,那么它可以提供给客户机连接Internet的请求,此时选择“允许虚拟专用连接”,否则选择“不允许虚拟专用连接”。

步骤5     单击“下一步”,进入“用户权限”对话框,在此对话框中设置允许呼叫回拨的客户机的用户名及口令。单击“添加”按钮,进入“新用户”对话框,输入需要的用户名和口令后然后单击“确定”。用户将在对话框中看到新添加的用户名。然后,单击新建的用户名,单击“属性”,用户将看到“常规”项和“回拨”项,“常规”内为用户已经设置的用户名及密码,不需要改动,下面来设置“回拨”项。

步骤6     选择“不允许回拨”,当客户机向服务器拨号时,验证身份后,服务器将不回拨,保持现有连接,客户机可以直接访问局域网以及通过局域网访问互联网。

步骤7     选择“允许呼叫方设置回拨号码”,那么当客户机向服务器拨号时,验证身份后,服务器将自动断开连接,等待几秒后自动向客户机所在的电话拨号。选择此种方式则需要在路由器上配置ppp callback ntstring dial-number命令。“不允许回拨”选项与“允许呼叫方设置回拨号码”选项效果上是没有区别的,惟一的区别就在于电话费,若选择第一项,电话费将由客户机端电话支付,若选择第二项,电话费将由服务器端电话支付。

步骤8     选择第三项“总是使用下面的回拨号码”,设置一个固定的回拨号码。

步骤9     单击“下一步”,进入“网络软件”窗口,设置网络组件。对于网络协议使用默认即可。

步骤10 单击“下一步”,进入“完成新建连接向导”窗口,完成该连接的创建。

1.4.9  拨号串循环备份并提供Internet接入服务的DCC应用

1. 组网需求

在PSTN网络中,拨号侧Router A通过配置dialer route命令实现拨号串循环备份;接入侧Router B使用异步串口提供DCC拨号的接入服务,并采用PAP认证方式验证拨号侧的合法性。在ISDN网络中,使用单一串拨号,采用CHAP认证,其它配置与PSTN侧相似。

如下图所示,Router B和Router D提供接入服务器功能,拨号侧路由器Router A和Router C接受对端分配的协商地址。可供分配的地址池地址为100.1.1.1/24~100.1.1.16/24,Router B和Router D的地址为100.1.1.254/24,从电信局得到的PSTN拨号串资源为8810048~8810055,ISDN拨号串为8810048,共服务于16个上网用户。

2. 组网图

图1-19 拨号串循环备份及提供接入服务的DCC组网图(PSTN方式)

 

图1-20 拨号串循环备份及提供接入服务的DCC组网图(ISDN方式)

 

3. 配置步骤

方案一:拨号侧Router A配置拨号串循环备份;接入侧Router B配置使用轮询DCC方法通过8异步串口建立连接,在Dialer接口上配置DCC参数。

配置Router A

# 配置拨号访问组1及对应的拨号访问控制条件,配置PPP验证使用的本地用户userb。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

[RouterA] local-user userb

[RouterA-luser-userb] password simple userb

[RouterA-luser-userb] service-type ppp

[RouterA-luser-userb] quit

# 配置接口Serial2/0的物理层参数以及IP地址可协商属性。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] physical-mode async

[RouterA-Serial2/0] async mode protocol

[RouterA-Serial2/0] ip address ppp-negotiate

# 配置接口Serial2/0的链路层协议为PPP,配置PPP认证的相关参数。

[RouterA-Serial2/0] link-protocol ppp

[RouterA-Serial2/0] ppp authentication-mode pap

[RouterA-Serial2/0] ppp pap local-user user1 password simple user1

# 配置接口Serial2/0启动轮询DCC,并且配置轮询DCC参数以及到达RouterB的9个拨号串,实现拨号串循环备份。

[RouterA-Serial2/0] dialer enable-circular

[RouterA-Serial2/0] dialer-group 1

[RouterA-Serial2/0] dialer route ip 100.1.1.254 8810048

[RouterA-Serial2/0] dialer route ip 100.1.1.254 8810049

……

[RouterA-Serial2/0] dialer route ip 100.1.1.254 8810055

[RouterA-Serial2/0] quit

# 配置User-interface,允许Modem呼入和呼出。

[RouterA] user-interface tty1

[RouterA-ui-tty1] modem both

配置RouterB

# 配置拨号访问组2及对应的拨号访问控制条件,配置PPP验证使用的本地用户user1、user2、user3、……、user16。

<RouterB> system-view

[RouterB] dialer-rule 2 ip permit

[RouterB] local-user user1

[RouterB-luser-user1] password simple user1

[RouterB-luser-user1] service-type ppp

[RouterB-luser-user1] quit

[RouterB] local-user user2

[RouterB-luser-user2] password simple user2

[RouterB-luser-user2] service-type ppp

[RouterB-luser-user2] quit

……

[RouterB] local-user user16

[RouterB-luser-user16] password simple user16

[RouterB-luser-user16] service-type ppp

[RouterB-luser-user16] quit

# 配置拨号接口Dialer0的IP地址,并且将为PPP对端分配IP地址。

[RouterB] interface dialer 0

[RouterB-Dialer0] link-protocol ppp

[RouterB-Dialer0] ppp authentication-mode pap

[RouterB-Dialer0] ppp pap local-user userb password simple userb

[RouterB-Dialer0] ip address 100.1.1.254 255.255.255.0

[RouterB-Dialer0] remote address pool 1

# 配置拨号接口Dialer0启动轮询DCC,并且配置轮询DCC参数。

[RouterB-Dialer0] dialer enable-circular

[RouterB-Dialer0] dialer-group 2

[RouterB-Dialer0] quit

# 配置接口Async1/0的物理层以及链路层参数。

[RouterB] interface async 1/0

[RouterB-Async1/0] async mode protocol

[RouterB-Async1/0] dialer circular-group 0

[RouterB-Async1/0] link-protocol ppp

[RouterB-Async1/0] ppp authentication-mode pap

[RouterB-Async1/0] ppp pap local-user userb password simple userb

[RouterB-Async1/0] quit

# 配置接口Async1/1~Async1/7的物理层以及链路层参数,配置方法同配置接口Async1/0。

……

[RouterB-Async1/7] quit

# 配置接口Async1/0~接口Async1/7对应的User-interface tty1~tty7,允许Modem呼入和呼出。

[RouterB] user-interface tty1

[RouterB-ui-tty1] modem both

[RouterB-ui-tty1] quit

[RouterB] user-interface tty2

[RouterB-ui-tty2] modem both

……

[RouterB-ui-tty8] quit

# 配置为PPP对端分配IP地址时使用的地址池。

[RouterB] domain system

[RouterB-isp-system] ip pool 1 100.1.1.1 100.1.1.16

[RouterB-isp-system] quit

配置用户PC

在Windows XP系统的PC上建立一个拨号网络连接。

步骤1     配置PC机连接的Modem为“自动应答方式”,然后打开[开始/程序/附件/通讯/拨号网络],在“拨号网络”窗口中,单击[建立新连接]。

步骤2     右键单击网上邻居,选择“属性”,打开“网络连接”对话框,单击新建一个连接,出现新建连接向导对话框。

步骤3     单击“下一步”,出现“网络连接类型”对话框,选择第一项“连接到Internet”。

步骤4     单击“下一步”,进入“您想怎样连接到Internet”对话框,选择第二项“手动设置我的连接”。

步骤5     单击“下一步”,进入“Internet连接”对话框,选择“用拨号调制解调器连接”。单击“下一步”,进入“连接名”对话框,设置该连接的连接名。单击“下一步”,进入“要拨的电话号码”,设置拨叫回呼Server端的电话号码。单击“下一步”,进入“Internet帐户信息”,设置连接到Server端进行PPP验证时的用户名和密码(用户名user16,口令user16)。

步骤6     单击“下一步”,进入“完成新建连接向导”对话框,完成该连接的创建。

步骤7     在“网络连接”对话框中,在刚才新创建的连接上单击右键,选择“属性”,打开连接属性对话框,选择“网络”选项。在“我正在呼叫的拨号服务器类型”下拉框中选择“PPP”,单击“设置”按钮,进行如下操作:

·     选择[启用LCP扩展]选项

·     取消[启用软件压缩]选项

·     取消[为单链路连接协商多重链接]选项

·     其他设置为缺省值

单击“确认”按钮,完成设置。返回“网络连接”对话框,选中刚才新创建的连接,选择[高级/拨号首选项]菜单,打开“拨号首选项”对话框,选择“回拨”选项卡,设置为“不回拨”。

双击刚才新创建的连接,就可以开始拨号了。

方案二:拨号侧Router C使用单一拨号串;接入侧Router D使用轮询DCC方法通过ISDN PRI接口建立连接,在Dialer接口上配置DCC参数。

配置Router C

# 配置拨号访问组1及对应的拨号访问控制条件,配置PPP验证使用的本地用户userd。

<RouterC> system-view

[RouterC] dialer-rule 1 ip permit

[RouterC] local-user userd

[RouterC-luser-userd] password simple user1

[RouterC-luser-userd] service-type ppp

[RouterC-luser-userd] quit

# 配置接口BRI1/0的物理层参数以及IP地址可协商属性。

[RouterC] interface bri 1/0

[RouterC-Bri1/0] ip address ppp-negotiate

# 配置接口BRI1/0的链路层协议为PPP,配置PPP CHAP认证的相关参数。

[RouterC-Bri1/0] link-protocol ppp

[RouterC-Bri1/0] ppp authentication-mode chap

[RouterC-Bri1/0] ppp chap user user1

# 配置接口BRI1/0启动轮询DCC,并且配置轮询DCC参数以及到达RouterD的拨号串。

[RouterC-Bri1/0] dialer enable-circular

[RouterC-Bri1/0] dialer-group 1

[RouterC-Bri1/0] dialer route ip 100.1.1.254 8810048

配置Router D

# 配置拨号访问组2及对应的拨号访问控制条件,配置PPP CHAP验证使用的本地用户user1、user2、user3、……、user16。

<RouterD> system-view

[RouterD] dialer-rule 2 ip permit

[RouterD] local-user user1

[RouterD-luser-user1] password simple user1

[RouterD-luser-user1] service-type ppp

[RouterD-luser-user1] quit

[RouterD] local-user user2

[RouterD-luser-user2] password simple user1

[RouterD-luser-user2] service-type ppp

[RouterD-luser-user2] quit

……

[RouterD] local-user user16

[RouterD-luser-user16] password simple user1

[RouterD-luser-user16] service-type ppp

[RouterD-luser-user16] quit

# 配置CE1/PRI接口2/0,使其工作在PRI方式。

[RouterD] controller e1 2/0

[RouterD-E1 2/0] pri-set

[RouterD-E1 2/0] quit

# 在CE1/PRI接口2/0生成的接口Serial2/0:15上启动轮询DCC。

[RouterD-E1 2/0] interface serial 2/0:15

[RouterD-Serial2/0:15] dialer enable-circular

[RouterD-Serial2/0:15] dialer-group 2

# 配置接口Serial2/0:15的IP地址。

[RouterD-Serial2/0:15] ip address 100.1.1.254 255.255.255.0

# 配置接口Serial2/0:15的链路层协议为PPP,并且配置PPP的相关参数。

[RouterD-Serial2/0:15] link-protocol ppp

[RouterD-Serial2/0:15] ppp authentication-mode chap

[RouterD-Serial2/0:15] ppp chap user userd

[RouterD-Serial2/0:15] remote address pool 1

[RouterD-Serial2/0:15] quit

# 配置为PPP对端分配IP地址时使用的地址池。

[RouterD] domain system

[RouterD-isp-system] ip pool 1 100.1.1.1 100.1.1.16

[RouterD-isp-system] quit

1.4.10  动态路由备份配置举例一

1. 组网需求

·     Router B通过串口分别与Router A和Router C相连,运行X.25协议。

·     Router A和Router C分别通过ISDN的BRI接口与ISDN交换网相连,可以互相拨号呼叫,Router C的电话号码为8810052。

·     串口使用10.0.0.0/8网段,BRI接口使用20.0.0.0/8网段。

·     Router A作为动态路由备份的主控设备,监控Router C上的30.0.0.0/8网段。

2. 组网图

图1-21 动态路由备份配置举例一组网图

 

3. 配置步骤

配置Router A

# 配置拨号访问控制列表。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 配置BRI3/0接口拨号参数。

[RouterA] interface bri 3/0

[RouterA-Bri3/0] ip address 20.0.0.1 8

[RouterA-Bri3/0] dialer enable-circular

[RouterA-Bri3/0] dialer-group 1

[RouterA-Bri3/0] dialer route ip 30.0.0.1 8810052

[RouterA-Bri3/0] quit

# 配置Serial2/0,运行X.25协议。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte ietf

[RouterA-Serial2/0] x25 x121-address 10

[RouterA-Serial2/0] x25 map ip 10.0.0.2 x121-address 15 broadcast

[RouterA-Serial2/0] ip address 10.0.0.1 8

[RouterA-Serial2/0] quit

# 配置动态路由协议RIP。

[RouterA] rip

[RouterA-rip-1] network 10.0.0.0

[RouterA-rip-1] network 20.0.0.0

[RouterA-rip-1] import-route direct

[RouterA-rip-1] quit

# 创建动态备份路由组。

[RouterA] standby routing-rule 1 ip 30.0.0.1 32

# 配置拨号接口上的路由使用优先级比串口的低。

[RouterA] interface bri 3/0

[RouterA-Bri3/0] rip metricin 2

# 启用动态路由备份功能。

[RouterA-Bri3/0] standby routing-group 1

配置Router B

# 配置X.25交换使能。

<RouterB> system-view

[RouterB] x25 switching

# 配置X.25交换接口。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dce ietf

[RouterB-Serial2/0] quit

[RouterB] interface serial 2/1

[RouterB-Serial2/1] link-protocol x25 dce ietf

[RouterB-Serial2/1] quit

# 配置X.25交换信息。

[RouterB] x25 switch svc 10 interface serial 2/0

[RouterB] x25 switch svc 15 interface serial 2/1

配置Router C

# 配置拨号访问控制列表。

<RouterC> system-view

[RouterC] dialer-rule 1 ip permit

# 配置BRI3/0接口拨号参数。

[RouterC] interface bri 3/0

[RouterC-Bri3/0] ip address 20.0.0.2 8

[RouterC-Bri3/0] dialer enable-circular

[RouterC-Bri3/0] dialer-group 1

[RouterC-Bri3/0] quit

# 配置Serial2/1,运行X.25协议。

[RouterC] interface serial 2/1

[RouterC-Serial2/1] link-protocol x25 dte ietf

[RouterC-Serial2/1] x25 x121-address 15

[RouterC-Serial2/1] x25 map ip 10.0.0.1 x121-address 10 broadcast

[RouterC-Serial2/1] ip address 10.0.0.2 8

[RouterC-Serial2/1] quit

# 配置LoopBack1接口。

[RouterC] interface loopback 1

[RouterC-Loopback1] ip address 30.0.0.1 32

[RouterC-Loopback1] quit

# 配置动态路由协议RIP。

[RouterC] rip

[RouterC-rip-1] network 10.0.0.0

[RouterC-rip-1] network 20.0.0.0

[RouterC-rip-1] network 30.0.0.0

[RouterC-rip-1] import-route direct

1.4.11  动态路由备份配置举例二

1. 组网需求

·     Router A与Router B通过一个串口直接相连,且同时通过ISDN BRI接口与ISDN交换网相连,可以互相拨号呼叫,Router B的电话号码为8810052。

·     串口使用10.0.0.0/8网段,BRI接口使用20.0.0.0/8网段。

·     Router A作为动态路由备份主控设备,监控Router B上的40.0.0.0/8网段。

2. 组网图

图1-22 动态路由备份配置举例二组网图

 

3. 配置步骤

配置Router A

# 配置拨号访问控制列表。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 配置BRI3/0接口拨号参数。

[RouterA] interface bri 3/0

[RouterA-Bri3/0] ip address 20.0.0.1 8

[RouterA-Bri3/0] dialer enable-circular

[RouterA-Bri3/0] dialer-group 1

[RouterA-Bri3/0] dialer route ip 40.0.0.1 8810052

[RouterA-Bri3/0] quit

# 配置Serial2/0。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 10.0.0.1 8

[RouterA-Serial2/0] quit

# 配置动态路由协议OSPF。

[RouterA] ospf

[RouterA-ospf-1] area 0

[RouterA-ospf-1-area-0.0.0.0] network 10.0.0.0 0.255.255.255

[RouterA-ospf-1-area-0.0.0.0] network 20.0.0.0 0.255.255.255

[RouterA-ospf-1-area-0.0.0.0] import-route direct

[RouterA-ospf-1-area-0.0.0.0] quit

[RouterA-ospf-1] quit

# 创建动态备份路由组。

[RouterA] standby routing-rule 1 ip 40.0.0.1 32

# 配置拨号接口上的路由使用优先级比串口的低。

[RouterA] interface bri3/0

[RouterA-Bri3/0] ospf cost 2000

[RouterA-Bri3/0] ospf network-type broadcast

# 启用动态路由备份功能。

[RouterA-Bri3/0] standby routing-group 1

配置Router B

# 配置拨号访问控制列表。

<RouterB> system-view

[RouterB] dialer-rule 1 ip permit

# 配置BRI3/0接口拨号参数。

[RouterB] interface bri 3/0

[RouterB-Bri3/0] ip address 20.0.0.2 8

[RouterB-Bri3/0] dialer enable-circular

[RouterB-Bri3/0] dialer-group 1

[RouterB-Bri3/0] quit

# 配置Serial2/0。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 10.0.0.2 8

[RouterB-Serial2/0] quit

# 配置Loopback1接口。

[RouterB] interface loopback 1

[RouterB-Loopback1] ip address 40.0.0.1 32

[RouterB-Loopback1] quit

# 配置动态路由协议OSPF。

[RouterB] ospf

[RouterB-ospf-1] area 0

[RouterB-ospf-1-area-0.0.0.0] network 10.0.0.0 0.255.255.255

[RouterB-ospf-1-area-0.0.0.0] network 20.0.0.0 0.255.255.255

[RouterB-ospf-1-area-0.0.0.0] network 40.0.0.0 0.0.0.0

[RouterB-ospf-1-area-0.0.0.0] import-route direct

1.4.12  动态路由备份配置举例三

1. 组网需求

·     Router A和Router B通过X.25网络相连。

·     Router A和Router B分别通过捆绑了两个B信道的ISDN BRI接口与ISDN交换网相连,它们之间通过共享DCC可以互相拨号呼叫。Router A的电话号码为8810010,Router B的电话号码为8810052。

·     Router A作为动态路由备份的主控设备,监控Router B上的30.0.0.0/8网段。

·     正常时候X.25链路作为Router A与Router B之间的主用链路;当到达Router B的30.0.0.0/8网段的路由断掉时(如X.25网络出现故障),Router A自动拨起ISDN BRI线路。

2. 组网图

图1-23 动态路由备份配置举例三组网图

 

3. 配置步骤

配置Router A

# 配置拨号访问控制列表及本地用户数据库。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

[RouterA] local-user userb

[RouterA-luser-userb] password simple userb

[RouterA-luser-userb] service-type ppp

[RouterA-luser-userb] quit

# 创建动态路由备份组。

[RouterA] standby routing-rule 1 ip 30.0.0.1 32

# 在Dialer0口上配置共享DCC。

[RouterA] interface dialer 0

[RouterA-Dialer0] link-protocol ppp

[RouterA-Dialer0] ip address 20.0.0.1 24

[RouterA-Dialer0] dialer user userb

[RouterA-Dialer0] dialer-group 1

[RouterA-Dialer0] dialer bundle 1

[RouterA-Dialer0] dialer number 8810052

[RouterA-Dialer0] ppp authentication-mode pap

[RouterA-Dialer0] ppp pap local-user usera password simple usera

[RouterA-Dialer0] standby routing-group 1

[RouterA-Dialer0] quit

# 将BRI3/0接口与Dialer0捆绑。

[RouterA] interface bri 3/0

[RouterA-Bri3/0] dialer bundle-member 1

[RouterA-Bri3/0] ppp authentication-mode pap

[RouterA-Bri3/0] ppp pap local-user usera password simple usera

[RouterA-Bri3/0] quit

# 配置Serial2/0,运行X.25协议。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte ietf

[RouterA-Serial2/0] x25 x121-address 10

[RouterA-Serial2/0] x25 map ip 10.0.0.2 x121-address 20 broadcast

[RouterA-Serial2/0] ip address 10.0.0.1 8

[RouterA-Serial2/0] quit

# 配置动态路由协议RIP。

[RouterA] rip

[RouterA-rip-1] network 10.0.0.0

[RouterA-rip-1] network 20.0.0.0

[RouterA-rip-1] import-route direct

[RouterA-rip-1] quit

# 配置拨号接口上的路由使用优先级比串口的低。

[RouterA] interface bri 3/0

[RouterA-Bri3/0] rip metricin 2

配置Router B

# 配置拨号访问控制列表及本地用户数据库。

<RouterB> system-view

[RouterB] dialer-rule 1 ip permit

[RouterB] local-user usera

[RouterB-luser-usera] password simple usera

[RouterB-luser-usera] service-type ppp

[RouterB-luser-usera] quit

# 在Dialer0口上配置共享DCC。

[RouterB] interface dialer 0

[RouterB-Dialer0] link-protocol ppp

[RouterB-Dialer0] ip address 20.0.0.2 24

[RouterB-Dialer0] dialer user usera

[RouterB-Dialer0] dialer-group 1

[RouterB-Dialer0] dialer bundle 1

[RouterB-Dialer0] dialer number 8810010

[RouterB-Dialer0] ppp authentication-mode pap

[RouterB-Dialer0] ppp pap local-user userb password simple userb

[RouterB-Dialer0] quit

# 配置BRI3/0接口拨号参数。

[RouterB] interface bri 3/0

[RouterB-Bri3/0] dialer bundle-member 1

[RouterB-Bri3/0] ppp authentication-mode pap

[RouterB-Bri3/0] ppp pap local-user userb password simple userb

[RouterB-Bri3/0] quit

# 配置Serial2/0,运行X.25协议。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dte ietf

[RouterB-Serial2/0] x25 x121-address 20

[RouterB-Serial2/0] x25 map ip 10.0.0.1 x121-address 10 broadcast

[RouterB-Serial2/0] ip address 10.0.0.2 8

[RouterB-Serial2/0] quit

# 配置LoopBack1接口。

[RouterB] interface loopback 1

[RouterB-Loopback1] ip address 30.0.0.1 32

[RouterB-Loopback1] quit

# 配置动态路由协议RIP。

[RouterB] rip

[RouterB-rip-1] network 10.0.0.0

[RouterB-rip-1] network 20.0.0.0

[RouterB-rip-1] network 30.0.0.0

[RouterB-rip-1] import-route direct

1.4.13  通过一个动态路由备份组监控多个网段

1. 组网需求

·     Router A与Router B通过FR网络相连,且同时通过ISDN交换网相连,可以互相拨号呼叫。Router A的电话号码为660330,Router B的电话号码为660220。

·     Router A作为动态路由备份的主控设备,监控Router B上的10.0.0.1/8、11.0.0.1/8、12.0.0.1/8三个网段。

·     正常情况下FR链路作为Router A与Router B之间的主用链路;当到达所有被监控网段的有效路由都不存在时(即各监控网段之间为“与”的关系),Router A拨通备份链路。

2. 组网图

图1-24 通过一个动态路由备份组监控多个网段组网图

 

本组网图是一个简单的示例,实际应用中被监控网段可能分布在多台设备上。

 

3. 配置步骤

配置Router A

# 配置拨号访问控制列表。

<RouterA> system-view

[RouterA] dialer-rule 1 ip permit

# 创建动态路由备份组,该备份组共监控三个网段。

[RouterA] standby routing-rule 1 ip 10.0.0.0 255.0.0.0

[RouterA] standby routing-rule 1 ip 11.0.0.0 255.0.0.0

[RouterA] standby routing-rule 1 ip 12.0.0.0 255.0.0.0

# 将CE1接口捆绑为pri-set。

[RouterA] controller e1 2/1

[RouterA-E1 2/1] pri-set

[RouterA-E1 2/1] quit

# 将接口Serial2/0配置为FR接口。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 1.0.0.1 255.0.0.0

[RouterA-Serial2/0] link-protocol fr

[RouterA-Serial2/0] fr interface-type dte

[RouterA-Serial2/0] fr inarp

[RouterA-Serial2/0] fr map ip 1.0.0.2 100

[RouterA-Serial2/0] quit

# 在PRI接口上配置轮询DCC。

[RouterA] interface serial 2/1:15

[RouterA-Serial2/1:15] ip address 2.0.0.1 255.0.0.0

[RouterA-Serial2/1:15] dialer enable-circular

[RouterA-Serial2/1:15] dialer-group 1

[RouterA-Serial2/1:15] dialer route ip 10.0.0.0 mask 8 660220

[RouterA-Serial2/1:15] standby routing-group 1

[RouterA-Serial2/1:15] quit

# 配置动态路由协议RIP。

[RouterA] rip

[RouterA-rip-1] network 1.0.0.0

[RouterA-rip-1] network 2.0.0.0

[RouterA-rip-1] import-route direct

# 配置拨号接口上的路由使用优先级比串口的低。

[RouterA] interface serial 2/1:15

[RouterA-Serial2/1:15] rip metricin 2

配置Router B

# 配置拨号访问控制列表。

[RouterB] system

[RouterB] dialer-rule 1 ip permit

# 将CE1接口捆绑为pri-set。

[RouterB] controller e1 2/1

[RouterB-E1 2/1] pri-set

[RouterB-E1 2/1] quit

# 将串口Serial2/0配置为FR接口。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 1.0.0.2 255.0.0.0

[RouterB-Serial2/0] link-protocol fr

[RouterB-Serial2/0] fr interface-type dte

[RouterB-Serial2/0] fr inarp

[RouterB-Serial2/0] fr map ip 1.0.0.1 200

[RouterB-Serial2/0] quit

# 在PRI接口上配置轮询DCC。

[RouterB] interface serial 2/1:15

[RouterB-Serial2/1:15] ip address 2.0.0.2 255.0.0.0

[RouterB-Serial2/1:15] dialer enable-circular

[RouterB-Serial2/1:15] dialer-group 1

[RouterB-Serial2/1:15] dialer route ip 2.0.0.1 mask 8 660330

[RouterB-Serial2/1:15] quit

# 配置以太网接口。

[RouterB] interface ethernet 1/0

[RouterB-Ethernet1/0] ip address 10.0.0.1 255.0.0.0

[RouterB-Ethernet1/0] quit

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ip address 11.0.0.1 255.0.0.0

[RouterB-Ethernet1/1] quit

[RouterB] interface ethernet 1/2

[RouterB-Ethernet1/2] ip address 12.0.0.1 255.0.0.0

[RouterB-Ethernet1/2] quit

# 配置动态路由协议RIP。

[RouterB] rip

[RouterB-rip-1] network 1.0.0.0

[RouterB-rip-1] network 2.0.0.0

[RouterB-rip-1] network 10.0.0.0

[RouterB-rip-1] network 11.0.0.0

[RouterB-rip-1] network 12.0.0.0

[RouterB-rip-1] import-route direct

1.5  DCC常见故障的诊断与排除

1.5.1  无法建立DCC拨号连接

1. 故障现象

从路由器向外发送数据时,Modem不拨号,无法建立DCC拨号连接。

2. 故障排除

可以按照如下步骤进行。

·     检查Modem连线是否正确,电话线连接是否正确,Modem初始化过程是否正确;

·     对同/异步串口,检查接口是否配置为异步、拨号方式;

·     检查拨号接口上是否使能DCC;

·     检查是否配置与数据包对应的dialer routedialer number命令;

1.5.2  Modem已经接通,但是无法ping通对方

1. 故障现象

Modem接通后,无法ping通对方。

2. 故障排除

可以按照如下步骤进行:

·     检查本端和对端配置封装协议是否一致,配置的PPP认证参数是否正确;

·     使用debugging ppp all命令打开PPP调试开关,观察PPP协商过程,确保PPP协商参数正确;

·     检查是否在拨号接口(物理接口或Dialer接口)上正确配置IP地址;

·     检查是否在拨号接口上使能DCC;

·     检查dialer-groupdialer-rule命令是否配置,是否配置正确,确保配置dialer-rule允许报文通过,并且两条命令存在相关联;

·     使用debugging dialer eventdebugging dialer packet命令打开DCC调试开关,根据输出信息进行定位。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!