国家 / 地区

03-二层技术-以太网交换配置指导

08-VLAN终结配置

本章节下载  (185.64 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Operation_Manual/H3C_MSR_CG(V5)-R2516-V1.16/03/201807/1094052_30005_0.htm

08-VLAN终结配置


1 VLAN终结

1.1  VLAN终结简介

VLAN终结是指对接收到的报文,按照报文携带的VLAN Tag信息匹配对应的接口后,去除报文VLAN Tag,再将报文进行三层转发或交由其它业务处理。转发出去的报文是否带有VLAN Tag由出接口决定,对从配置了VLAN终结的接口发送的报文,按照该接口上的终结配置,将相应的VLAN Tag添加到报文中后发送该报文。

1.1.1  VLAN终结的分类

根据对所终结的报文的不同处理方式,VLAN终结分为以下两种:

·     Dot1q终结:用来终结带有一层及以上VLAN Tag的报文(要求最外层VLAN ID必须匹配配置值),从配置了Dot1q终结的接口发送的报文,都添加一层VLAN Tag。

·     QinQ终结:用来终结带有两层及以上VLAN Tag的报文(要求最外两层VLAN ID必须匹配配置值),从配置了QinQ终结的接口发送的报文,都添加两层VLAN Tag。

MSR系列路由器仅支持Dot1q终结。

 

1.1.2  VLAN终结的应用场景

划分VLAN后,不同VLAN间的主机不能直接通信,使用三层路由技术可以实现所有VLAN间报文的互通。此时如果要对互通的VLAN范围做限制,即要求只有指定的部分VLAN间可以互通,可以借助VLAN终结功能来实现。目前可以通过三层以太网子接口实现指定VLAN间的互通。

下图中,Host A属于VLAN 2,Host B属于VLAN 3,将Host A的网关地址指定为1.1.1.1/24,Host B的网关地址指定为1.1.2.1/24,就可以通过三层以太网子接口来实现Host A和Host B的三层报文互通了。

图1-1 VLAN终结用于不同VLAN之间互通

 

1.2  VLAN终结配置任务简介

表1-1 VLAN终结配置任务简介

配置任务

详细配置

配置明确的Dot1q终结

1.3 

配置VLAN Tag的TPID值

1.4 

 

1.3  配置明确的Dot1q终结

明确的Dot1q终结:只能终结一个VLAN的报文。能接收的VLAN报文的VLAN ID必须是指定值,其它VLAN报文则不允许通过该子接口;发送报文时,会给报文添加一层VLAN Tag,VLAN ID字段填上指定值。

表1-2 配置明确的Dot1q终结

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

三层以太网子接口视图

interface interface-type interface-number.subnumber

四者必选其一

三层聚合子接口视图

interface route-aggregation interface-number.subnumber

三层虚拟以太网子接口视图

interface virtual-ethernet interface-number.subnumber

VE-L3VPN-Access子接口视图

interface ve-l3vpn-access interface-number.subnumber

使能子接口的Dot1q终结功能,并指定当前子接口能够终结的Dot1q报文的VLAN ID

vlan-type dot1q vid vlan-id

必选

 

1.4  配置VLAN Tag的TPID值

如果要在三层以太网子接口/三层聚合子接口/三层虚拟以太网子接口/VE-L3VPN-Access子接口上使用VLAN终结功能,可以通过以下配置指定接口接收和发送报文的最外层VLAN Tag的TPID值。在配置TPID值后,当接收报文时,只有报文最外层VLAN Tag的TPID值为0x8100或者指定值的报文才会作为VLAN报文来处理;发送报文时,会给报文最外层VLAN Tag的TPID值填入指定值,如果报文带有两层及以上VLAN Tag,则给报文其它层VLAN Tag的TPID值都填入0x8100。

表1-1 配置VLAN Tag的TPID值

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

三层以太网接口视图

interface interface-type interface-number

四者必选其一

在接口视图下配置,命令会对该接口的所有子接口生效

三层聚合接口视图

interface route-aggregation interface-number

三层虚拟以太网接口视图

interface virtual-ethernet interface-number

L3VPN接入接口视图

Interface ve-l3vpn-access interface-number

配置当前接口接收和发送的报文最外层VLAN Tag的TPID值

dot1q ethernet-type hex-value

可选

缺省情况下,当前接口接收和发送的报文最外层VLAN Tag的TPID值均为0x8100

 

1.5  明确的Dot1q终结配置举例

1. 组网需求

如下图所示,Host A、Host B和Switch A相连,Host C、Host D和Switch B相连。Host A和Host C属于VLAN 10,Host B和Host D属于VLAN 20,路由器子接口Ethernet1/1.10、Ethernet1/1.20、Ethernet2/1.10、Ethernet2/1.20的IP地址分别为1.0.0.1/8、2.0.0.1/8、3.0.0.1/8和4.0.0.1/8。要求实现:

·     Host A和Host B之间、Host C和Host D之间能够互相通信,即同一交换机、不同VLAN之间能够互相通信;

·     Host A和Host C之间、Host B和Host D之间能够互相通信,即不同交换机、同一VLAN之间能够互相通信;

·     Host A和Host D之间、Host B和Host C之间能够互相通信,即不同交换机、不同VLAN之间能够互相通信。

2. 组网图

图1-2 配置以太网子接口组网图

 

3. 配置步骤

本配置中vlan-type dot1q vid命令必须配置,因为以太网子接口只有在关联了VLAN后才能被激活,正常的收发报文。

 

(1)     Host A、Host B、Host C、Host D的配置

将Host A的IP地址指定为1.1.1.1/8,网关地址指定为1.0.0.1/8。

将Host B的IP地址指定为2.2.2.2/8,网关地址指定为2.0.0.1/8。

将Host C的IP地址指定为3.3.3.3/8,网关地址指定为3.0.0.1/8。

将Host D的IP地址指定为4.4.4.4/8,网关地址指定为4.0.0.1/8。

(2)     L2 Switch A、L2 Switch B的配置

下面以L2 Switch A的配置步骤为例,L2 Switch B的配置与L2 Switch A的配置相同,不再赘述。

# 向VLAN 10中加入端口Ethernet1/2。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 10

[L2_SwitchA-vlan10] port ethernet 1/2

[L2_SwitchA-vlan10] quit

# 向VLAN 20中加入端口Ethernet1/3。

[L2_SwitchA] vlan 20

[L2_SwitchA-vlan20] port ethernet 1/3

[L2_SwitchA-vlan20] quit

# 配置端口Ethernet1/1的链路类型为Trunk类型,并允许VLAN 10和VLAN 20通过。

[L2_SwitchA] interface ethernet 1/1

[L2_SwitchA-Ethernet1/1] port link-type trunk

[L2_SwitchA-Ethernet1/1] port trunk permit vlan 10 20

 Please wait... Done.

(3)     对Router的配置

# 创建以太网子接口Ethernet1/1.10、Ethernet1/1.20、Ethernet2/1.10和Ethernet2/1.20,分别为其配置IP地址,配置Ethernet1/1.10和Ethernet2/1.10用来终结VLAN 10的报文,配置Ethernet1/1.20和Ethernet2/1.20用来终结VLAN 20的报文。

<Router> system-view

[Router] interface ethernet 1/1.10

[Router-Ethernet1/1.10] ip address 1.0.0.1 255.0.0.0

[Router-Ethernet1/1.10] vlan-type dot1q vid 10

[Router-Ethernet1/1.10] quit

[Router] interface ethernet 1/1.20

[Router-Ethernet1/1.20] ip address 2.0.0.1 255.0.0.0

[Router-Ethernet1/1.20] vlan-type dot1q vid 20

[Router-Ethernet1/1.20] quit

[Router] interface ethernet 2/1.10

[Router-Ethernet2/1.10] ip address 3.0.0.1 255.0.0.0

[Router-Ethernet2/1.10] vlan-type dot1q vid 10

[Router-Ethernet2/1.10] quit

[Router] interface ethernet 2/1.20

[Router-Ethernet2/1.20] ip address 4.0.0.1 255.0.0.0

[Router-Ethernet2/1.20] vlan-type dot1q vid 20

[Router-Ethernet2/1.20] quit

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!