国家 / 地区

03-二层技术-以太网交换配置指导

04-以太网链路聚合配置

本章节下载  (412.52 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Operation_Manual/H3C_MSR_CG(V5)-R2516-V1.16/03/201807/1094048_30005_0.htm

04-以太网链路聚合配置


1 以太网链路聚合

1.1  以太网链路聚合简介

以太网链路聚合简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效地提高链路的可靠性。

图1-1所示,Device A与Device B之间通过三条以太网物理链路相连,将这三条链路捆绑在一起,就成为了一条逻辑链路Link aggregation 1,这条逻辑链路的带宽等于原先三条以太网物理链路的带宽总和,从而达到了增加链路带宽的目的;同时,这三条以太网物理链路相互备份,有效地提高了链路的可靠性。

图1-1 链路聚合示意图

 

1.1.1  基本概念

1. 聚合组、成员端口和聚合接口

将多个以太网接口捆绑在一起所形成的组合称为聚合组,而这些被捆绑在一起的以太网接口就称为该聚合组的成员端口。每个聚合组唯一对应着一个逻辑接口,我们称之为聚合接口。聚合组/聚合接口可以分为以下两种类型:

·     二层聚合组/二层聚合接口:二层聚合组的成员端口全部为二层以太网接口,其对应的聚合接口称为二层聚合(Bridge-aggregation Interface,BAGG)接口。

·     三层聚合组/三层聚合接口:三层聚合组的成员端口全部为三层以太网接口,其对应的聚合接口称为三层聚合(Route-aggregation,RAGG)接口。在创建了三层聚合接口之后,还可继续创建该三层聚合接口的子接口(简称三层聚合子接口)。三层聚合子接口也是一种逻辑接口,工作在网络层,主要用来在三层聚合接口上支持收发携带VLAN Tag的报文。

·     聚合组与聚合接口的编号是一一对应的,譬如聚合组1对应于聚合接口1。

·     聚合接口的速率和双工模式取决于对应聚合组内的选中端口(请参见“1.1  2. 成员端口的状态”):聚合接口的速率等于所有选中端口的速率之和,聚合接口的双工模式则与选中端口的双工模式相同。

 

2. 成员端口的状态

聚合组内的成员端口具有以下两种状态:

·     选中(Selected)状态:此状态下的成员端口可以参与用户数据的转发,处于此状态的成员端口简称为“选中端口”。

·     非选中(Unselected)状态:此状态下的成员端口不能参与用户数据的转发,处于此状态的成员端口简称为“非选中端口”。

说明

·     在选中端口失效后,其它非选中端口可能成为选中端口,参与用户数据的转发。

·     三层聚合组仅支持1个选中端口。

 

3. 操作Key

操作Key是系统在进行链路聚合时用来表征成员端口聚合能力的一个数值,它是根据成员端口上的一些信息(包括该端口的速率、双工模式等)的组合自动计算生成的,这个信息组合中任何一项的变化都会引起操作Key的重新计算。在同一聚合组中,所有的选中端口都必须具有相同的操作Key。

4. 配置分类

根据对成员端口状态的影响不同,我们可以将成员端口上的配置分为以下三类:

(1)     端口属性类配置:包含速率、双工模式和链路状态(up/down)这三项配置内容,是成员端口上最基础的配置内容。

(2)     第二类配置:包含的配置内容如表1-1所示。在聚合组中,只有与对应聚合接口的第二类配置完全相同的成员端口才能够成为选中端口。

表1-1 第二类配置的内容

配置项

内容

端口隔离

端口是否加入隔离组、端口所属的端口隔离组

VLAN配置

端口上允许通过的VLAN、端口缺省VLAN ID、端口的链路类型(即Trunk、Hybrid、Access类型)、VLAN报文是否带Tag配置

MAC地址学习配置

是否具有MAC地址学习功能、端口是否具有最大学习MAC地址个数的限制、MAC地址表满后是否继续转发

 

·     在聚合接口上所作的第二类配置,将被自动同步到对应聚合组内的所有成员端口上。当聚合接口被删除后,这些配置仍将保留在这些成员端口上。

·     由于成员端口上第二类配置的改变可能导致其选中/非选中状态发生变化,进而对业务产生影响,因此当在成员端口上进行此类配置时,系统将给出提示信息,由用户来决定是否继续执行该配置。

 

(3)     第一类配置:是相对于第二类配置而言的,包含的配置内容有GVRP、生成树等。在聚合组中,即使某成员端口与对应聚合接口的第一类配置存在不同,也不会影响该成员端口成为选中端口。

在成员端口上所作的第一类配置,只有当该成员端口退出聚合组后才能生效。

 

5. 参考端口

参考端口从成员端口中选出(选举过程请参加“1.1.4  1. 选择参考端口”或“1.1.4  1. 选择参考端口”),其端口属性类配置和第二类配置将作为同一聚合组内的其它成员端口的参照,以确定这些成员端口的状态。

6. 聚合模式

根据成员端口上是否启用了LACP协议,可以将链路聚合分为静态聚合和动态聚合两种模式,它们各自的特点如表1-2所示。

表1-2 不同聚合模式的特点

聚合模式

成员端口是否开启LACP协议

优点

缺点

静态聚合模式

一旦配置好后,端口的选中/非选中状态就不会受网络环境的影响,比较稳定

不能根据对端的状态调整端口的选中/非选中状态,不够灵活

动态聚合模式

能够根据对端和本端的信息调整端口的选中/非选中状态,比较灵活

端口的选中/非选中状态容易受网络环境的影响,不够稳定

 

处于静态聚合模式和动态聚合模式下的聚合组分别称为静态聚合组和动态聚合组,动态聚合组内的选中端口以及处于up状态、与对应聚合接口的第二类配置相同的非选中端口均可以收发LACPDU(Link Aggregation Control Protocol Data Unit,链路聚合控制协议数据单元)。

1.1.2  LACP协议

基于IEEE802.3ad标准的LACP(Link Aggregation Control Protocol,链路聚合控制协议)协议是一种实现链路动态聚合的协议,运行该协议的设备之间通过互发LACPDU来交互链路聚合的相关信息。

1. LACP协议的功能

利用LACPDU的基本字段可以实现LACP协议的基本功能,基本字段包含以下信息:系统LACP优先级、系统MAC地址、端口聚合优先级、端口编号和操作Key。

动态聚合组内的成员端口会自动使能LACP协议,并通过发送LACPDU向对端通告本端的上述信息。当对端收到该LACPDU后,将其中的信息与本端其它成员端口收到的信息进行比较,以选择能够处于选中状态的成员端口,使双方可以对各自接口的选中/非选中状态达成一致,从而决定哪些链路可以加入聚合组以及某链路何时可以加入聚合组。

2. LACP优先级

根据作用的不同,可以将LACP优先级分为系统LACP优先级和端口聚合优先级两类,如表1-3所示。

表1-3 LACP优先级的分类

类别

说明

比较标准

系统LACP优先级

系统LACP优先级用于区分两端设备优先级的高低。要想使两端设备的选中端口一致,可以使一端具有较高的优先级,另一端则根据优先级较高的一端来选择本端的选中端口

优先级数值越小,优先级越高

端口聚合优先级

端口聚合优先级用于区分各成员端口成为选中端口的优先程度

 

3. LACP超时时间

LACP超时时间是指成员端口等待接收LACPDU的超时时间。在三倍LACP超时时间之后,如果本端成员端口仍未收到来自对端的LACPDU,则认为对端成员端口已失效。LACP超时时间只有短超时(1秒)和长超时(30秒)两种取值。

1.1.3  静态聚合模式

在静态聚合模式下,聚合组内的成员端口上不启用LACP协议,其端口状态通过手工进行维护。静态聚合模式的工作机制如下:

1. 选择参考端口

当聚合组内有处于up状态的端口时,先比较端口的聚合优先级,优先级数值最小的端口作为参考端口;如果优先级相同,再按照端口的全双工/高速率->全双工/低速率->半双工/高速率->半双工/低速率的优先次序,选择优先次序最高、且第二类配置与对应聚合接口相同的端口作为该组的参考端口;如果优先次序也相同,则选择端口号最小的端口作为参考端口。

2. 确定成员端口的状态

静态聚合组内成员端口状态的确定流程如图1-2所示。

图1-2 静态聚合组内成员端口状态的确定流程

 

·     静态聚合组内选中端口的最大数量为8个。

·     当一个成员端口的端口属性类配置或第二类配置改变时,其所在静态聚合组内各成员端口的选中/非选中状态可能会发生改变。

·     当静态聚合组内选中端口的数量已达到上限时,后加入的成员端口即使满足成为选中端口的所有条件,也不会立刻成为选中端口。这样能够尽量维持当前选中端口上的流量不中断,但是由于设备重启时会重新计算选中端口,因此可能导致设备重启前、后各成员端口的选中/非选中状态不一致。

 

1.1.4  动态聚合模式

在动态聚合模式下,聚合组内的成员端口上均启用LACP协议,其端口状态通过该协议自动进行维护。动态聚合模式的工作机制如下:

1. 选择参考端口

(1)     首先,从聚合链路的两端选出设备ID(由系统的LACP优先级和系统的MAC地址共同构成)较小的一端:先比较两端的系统LACP优先级,优先级数值越小其设备ID越小;如果优先级相同再比较其系统MAC地址,MAC地址越小其设备ID越小。

(2)     其次,对于设备ID较小的一端,再比较其聚合组内各成员端口的端口ID(由端口的聚合优先级和端口的编号共同构成):先比较端口的聚合优先级,优先级数值越小其端口ID越小;如果优先级相同再比较其端口号,端口号越小其端口ID越小。端口ID最小的端口作为参考端口。

2. 确定成员端口的状态

在设备ID较小的一端,动态聚合组内成员端口状态的确定流程如图1-3所示。

图1-3 动态聚合组内成员端口状态的确定流程

 

与此同时,设备ID较大的一端也会随着对端成员端口状态的变化,随时调整本端各成员端口的状态,以确保聚合链路两端成员端口状态的一致。

·     动态聚合组内选中端口的最大数量为8个。

·     当动态聚合组内同时存在全双工端口和半双工端口时,全双工端口将优先成为选中端口;只有当所有全双工端口都无法成为选中端口,或动态聚合组内只有半双工端口时,才允许从半双工端口中选出一个成为选中端口,且只有一个半双工端口可成为选中端口。

·     当一个成员端口的端口属性类配置或第二类配置改变时,其所在动态聚合组内各成员端口的选中/非选中状态可能会发生改变。

·     当本端端口的选中/非选中状态发生改变时,其对端端口的选中/非选中状态也将随之改变。

·     当动态聚合组内选中端口的数量已达到上限时,后加入的成员端口一旦满足成为选中端口的所有条件,就会立刻取代已不满足条件的端口成为选中端口。

 

1.2  以太网链路聚合配置任务简介

表1-4 以太网链路聚合配置任务简介

配置任务

说明

详细配置

配置聚合组

配置静态聚合组

二者必选其一

1.3.1 

配置动态聚合组

1.3.2 

聚合接口相关配置

配置聚合接口的描述信息

可选

1.4.1 

配置三层聚合接口MTU

可选

1.4.2 

开启聚合接口链路状态变化Trap功能

可选

1.4.3 

配置聚合接口的期望带宽

可选

1.4.4 

关闭聚合接口

可选

1.4.5 

恢复聚合接口的缺省配置

可选

1.4.6 

 

1.3  配置聚合组

请根据需要聚合的以太网接口类型来配置相应类型的聚合组:当需要聚合的是二层以太网接口时,请配置二层聚合组;当需要聚合的是三层以太网接口时,请配置三层聚合组。聚合链路的两端应配置相同的聚合模式。

·     配置或使能了下列功能的端口将不能加入二层聚合组:MAC地址认证(请参见“安全配置指导/MAC地址认证”)、端口安全模式(请参见“安全配置指导/端口安全”)、报文过滤功能(请参见“安全配置指导/防火墙”)、以太网帧过滤功能(请参见“安全配置指导/防火墙”)、IP Source Guard功能(请参见“安全配置指导/IP Source Guard”)、802.1X功能(请参见“安全配置指导/802.1X”)以及Portal免认证规则源接口(请参见“安全配置指导/Portal”)。

·     配置或使能了下列功能的接口将不能加入三层聚合组:IP地址(请参见“三层技术-IP业务配置指导/IP地址”)、DHCP客户端(请参见“三层技术-IP业务配置指导/DHCP”)、VRRP功能(请参见“可靠性配置指导/VRRP”)和Portal功能(请参见“安全配置指导/Portal”)。

·     建议不要将镜像反射端口加入聚合组,有关反射端口的详细介绍请参见“网络管理和监控配置指导”中的“端口镜像”。

 

用户删除聚合接口时,系统将自动删除对应的聚合组,且该聚合组内的所有成员端口将全部离开该聚合组。

 

1.3.1  配置静态聚合组

对于静态聚合模式,用户需要保证在同一链路两端端口的选中/非选中状态的一致性,否则聚合功能无法正常使用。

 

1. 配置二层静态聚合组

表1-5 配置二层静态聚合组

操作

命令

说明

进入系统视图

system-view

-

创建二层聚合接口,并进入二层聚合接口视图

interface bridge-aggregation interface-number

必选

创建二层聚合接口后,系统将自动生成同编号的二层聚合组,且该聚合组缺省工作在静态聚合模式下

退回系统视图

quit

-

进入二层以太网接口视图

interface interface-type interface-number

必选

多次执行此步骤可将多个二层以太网接口加入聚合组

将二层以太网接口加入聚合组

port link-aggregation group number

配置端口的聚合优先级

link-aggregation port-priority port-priority

可选

缺省情况下,端口的聚合优先级为32768

当静态聚合组中可以选中的备选端口数大于最大选中端口数时,改变端口的聚合优先级,将会影响到静态聚合组成员端口的选中/非选中状态

 

MSR系列路由器各款型对于本节所描述的特性支持情况有所不同,详细差异信息如下:

型号

特性

描述

MSR800

二层静态聚合组

支持

MSR 900

不支持

MSR900-E

支持

MSR 930

支持

MSR 20-1X

不支持

MSR 20

不支持

MSR 30

支持

MSR 50

支持

MSR 2600

支持

MSR3600-51F

支持

 

2. 配置三层静态聚合组

表1-6 配置三层静态聚合组

操作

命令

说明

进入系统视图

system-view

-

创建三层聚合接口,并进入三层聚合接口视图

interface route-aggregation interface-number

必选

创建三层聚合接口后,系统将自动生成同编号的三层聚合组,且该聚合组缺省工作在静态聚合模式下

退回系统视图

quit

-

进入三层以太网接口视图

interface interface-type interface-number

必选

多次执行此步骤可将多个三层以太网接口加入聚合组

将三层以太网接口加入聚合组

port link-aggregation group number

配置端口的聚合优先级

link-aggregation port-priority port-priority

可选

缺省情况下,端口的聚合优先级为32768

当静态聚合组中可以选中的备选端口数大于最大选中端口数时,改变端口的聚合优先级,将会影响到静态聚合组成员端口的选中/非选中状态

 

1.3.2  配置动态聚合组

对于动态聚合模式,聚合链路两端的设备会自动协商同一链路两端的端口在各自聚合组内的选中/非选中状态,用户只需保证本端聚合在一起的端口的对端也同样聚合在一起,聚合功能即可正常使用。

 

1. 配置二层动态聚合组

表1-7 配置二层动态聚合组

操作

命令

说明

进入系统视图

system-view

-

配置系统的LACP优先级

lacp system-priority system-priority

可选

缺省情况下,系统的LACP优先级为32768

改变系统的LACP优先级,将会影响到动态聚合组成员端口的选中/非选中状态

创建二层聚合接口,并进入二层聚合接口视图

interface bridge-aggregation interface-number

必选

创建二层聚合接口后,系统将自动生成同编号的二层聚合组,且该聚合组缺省工作在静态聚合模式下

配置聚合组工作在动态聚合模式下

link-aggregation mode dynamic

必选

缺省情况下,聚合组工作在静态聚合模式下

退回系统视图

quit

-

进入二层以太网接口视图

interface interface-type interface-number

必选

多次执行此步骤可将多个二层以太网接口加入聚合组

将二层以太网接口加入聚合组

port link-aggregation group number

配置端口的聚合优先级

link-aggregation port-priority port-priority

可选

缺省情况下,端口的聚合优先级为32768

当动态聚合组中可以选中的备选端口数大于最大选中端口数时,改变端口的聚合优先级,将会影响到动态聚合组成员端口的选中/非选中状态

配置端口的LACP超时时间为短超时(即1秒)

lacp period short

可选

缺省情况下,端口的LACP超时时间为长超时(即30秒)

 

MSR系列路由器各款型对于本节所描述的特性支持情况有所不同,详细差异信息如下:

型号

特性

描述

MSR800

二层动态聚合组

支持

MSR 900

不支持

MSR900-E

支持

MSR 930

支持

MSR 20-1X

不支持

MSR 20

不支持

MSR 30

支持

MSR 50

支持

MSR 2600

支持

MSR3600-51F

支持

 

2. 配置三层动态聚合组

表1-8 配置三层动态聚合组

操作

命令

说明

进入系统视图

system-view

-

配置系统的LACP优先级

lacp system-priority system-priority

可选

缺省情况下,系统的LACP优先级为32768

改变系统的LACP优先级,将会影响到动态聚合组成员的选中/非选中状态

创建三层聚合接口,并进入三层聚合接口视图

interface route-aggregation interface-number

必选

创建三层聚合接口后,系统将自动生成同编号的三层聚合组,且该聚合组缺省工作在静态聚合模式下

配置聚合组工作在动态聚合模式下

link-aggregation mode dynamic

必选

缺省情况下,聚合组工作在静态聚合模式下

退回系统视图

quit

-

进入三层以太网接口视图

interface interface-type interface-number

必选

多次执行此步骤可将多个三层以太网接口加入聚合组

将三层以太网接口加入聚合组

port link-aggregation group number

配置端口的聚合优先级

link-aggregation port-priority port-priority

可选

缺省情况下,端口的聚合优先级为32768

当动态聚合组中可以选中的备选端口数大于最大选中端口数时,改变端口的聚合优先级,将会影响到动态聚合组成员的选中/非选中状态

配置端口的LACP超时时间为短超时(即1秒)

lacp period short

可选

缺省情况下,端口的LACP超时时间为长超时(即30秒)

 

1.4  聚合接口相关配置

本节对能够在聚合接口上进行的部分配置进行介绍。除本节所介绍的以外,能够在二层/三层以太网接口上进行的配置大多数也能在二层/三层聚合接口上进行,具体配置请参见相关的配置手册。

1.4.1  配置聚合接口的描述信息

通过在接口上配置描述信息,可以方便网络管理员根据这些信息来区分各接口的作用。

表1-9 配置聚合接口的描述信息

操作

命令

说明

进入系统视图

system-view

-

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

配置当前接口的描述信息

description text

可选

缺省情况下,接口的描述信息为“接口名 Interface”

 

1.4.2  配置三层聚合接口MTU

MTU(Maximum Transmission Unit,最大传输单元)参数会影响IP报文的分片与重组,可以通过下面的配置来改变MTU值。

表1-1 配置三层聚合接口MTU

操作

命令

说明

进入系统视图

system-view

-

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

-

配置三层聚合接口/子接口的MTU值

mtu size

可选

缺省情况下,三层聚合接口/子接口的MTU值为1500字节

 

1.4.3  开启聚合接口链路状态变化Trap功能

在聚合接口上开启了接口链路状态变化Trap功能后,可以使聚合接口在链路状态发生改变时生成并发送端口Link up和Link down的Trap报文。有关Trap的详细介绍,请参见“网络管理和监控配置指导”中的“SNMP”。

表1-10 开启聚合接口状态变化Trap功能

操作

命令

说明

进入系统视图

system-view

-

开启全局接口链路状态变化Trap功能

snmp-agent trap enable [ standard [ linkdown | linkup ] * ]

可选

缺省情况下,全局接口链路状态变化Trap功能处于开启状态

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

开启接口链路状态变化Trap功能

enable snmp trap updown

可选

缺省情况下,接口链路状态变化Trap功能处于开启状态

 

1.4.4  配置聚合接口的期望带宽

表1-11 配置聚合接口的期望带宽

操作

命令

说明

进入系统视图

system-view

-

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

配置当前接口的期望带宽

bandwidth bandwidth-value

必选

 

1.4.5  关闭聚合接口

对聚合接口的开启/关闭操作,将会影响聚合接口对应的聚合组内成员端口的选中/非选中状态和链路状态:

·     关闭聚合接口时,将使对应聚合组内所有处于选中状态的成员端口都变为非选中端口,且所有成员端口的链路状态都将变为down。

·     开启聚合接口时,系统将重新计算对应聚合组内成员端口的选中/非选中状态,且所有成员端口的链路状态都将变为up。

表1-12 关闭聚合接口

操作

命令

说明

进入系统视图

system-view

-

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

关闭当前接口

shutdown

必选

缺省情况下,聚合接口/子接口处于开启状态

 

说明

由于三层聚合子接口不存在对应的聚合组,所以关闭三层聚合子接口对聚合组没有影响。

 

1.4.6  恢复聚合接口的缺省配置

通过执行本操作可以将接口下的所有配置都恢复为缺省配置。

表1-13 恢复聚合接口的缺省配置

操作

命令

说明

进入系统视图

system-view

-

进入聚合接口视图

进入二层聚合接口视图

interface bridge-aggregation interface-number

二者必选其一

进入三层聚合接口/子接口视图

interface route-aggregation { interface-number | interface-number.subnumber }

恢复当前接口的缺省配置

default

必选

 

1.5  以太网链路聚合显示与维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后以太网链路聚合的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除端口的LACP和聚合接口上的统计信息。

表1-14 以太网链路聚合显示与维护

操作

命令

显示聚合接口的相关信息

display interface [ bridge-aggregation | route-aggregation ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

display interface { bridge-aggregation | route-aggregation } interface-number [ brief ] [ | { begin | exclude | include } regular-expression ]

显示本端系统的设备ID

display lacp system-id [ | { begin | exclude | include } regular-expression ]

显示成员端口上链路聚合的详细信息

display link-aggregation member-port [ interface-list ] [ | { begin | exclude | include } regular-expression ]

显示所有聚合组的摘要信息

display link-aggregation summary [ | { begin | exclude | include } regular-expression ]

显示指定聚合组的详细信息

display link-aggregation verbose [ { bridge-aggregation | route-aggregation } [ interface-number ] ] [ | { begin | exclude | include } regular-expression ]

清除成员端口上的LACP统计信息

reset lacp statistics [ interface interface-list ]

清除聚合接口上的统计信息

reset counters interface [ { bridge-aggregation | route-aggregation } [ interface-number ] ]

 

1.6  以太网链路聚合典型配置举例

在聚合组中,只有端口属性类配置(请参见“1.1  4. 配置分类”)和第二类配置(请参见“1.1  4. 配置分类”)都与参考端口(请参见“1.1  5. 参考端口”)相同的成员端口才可以成为选中端口。因此,用户需通过配置使各成员端口的上述配置与参考端口保持一致,而除此以外的其它配置则只需在聚合接口上进行,不必再在成员端口上重复配置。

 

1.6.1  二层静态聚合配置举例

1. 组网需求

·     Router A与Router B通过各自的二层以太网接口Ethernet1/1~Ethernet1/3相互连接。

·     在Router A和Router B上分别配置二层静态链路聚合组,并使两端的VLAN 10和VLAN 20之间分别互通。

2. 组网图

图1-4 二层静态聚合配置组网图

 

 

3. 配置步骤

(1)     配置Router A

# 创建VLAN 10,并将端口Ethernet1/4加入到该VLAN中。

<RouterA> system-view

[RouterA] vlan 10

[RouterA-vlan10] port ethernet 1/4

[RouterA-vlan10] quit

# 创建VLAN 20,并将端口Ethernet1/5加入到该VLAN中。

[RouterA] vlan 20

[RouterA-vlan20] port ethernet 1/5

[RouterA-vlan20] quit

# 创建二层聚合接口1。

[RouterA] interface bridge-aggregation 1

[RouterA-Bridge-Aggregation1] quit

# 分别将端口Ethernet1/1至Ethernet1/3加入到聚合组1中。

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] port link-aggregation group 1

[RouterA-Ethernet1/1] quit

[RouterA] interface ethernet 1/2

[RouterA-Ethernet1/2] port link-aggregation group 1

[RouterA-Ethernet1/2] quit

[RouterA] interface ethernet 1/3

[RouterA-Ethernet1/3] port link-aggregation group 1

[RouterA-Ethernet1/3] quit

# 配置二层聚合接口1为Trunk端口,并允许VLAN 10和20的报文通过。

[RouterA] interface bridge-aggregation 1

[RouterA-Bridge-Aggregation1] port link-type trunk

[RouterA-Bridge-Aggregation1] port trunk permit vlan 10 20

 Please wait... Done.

 Configuring Ethernet1/1... Done.

 Configuring Ethernet1/2... Done.

 Configuring Ethernet1/3... Done.

[RouterA-Bridge-Aggregation1] quit

(2)     配置Router B

Router B的配置与Router A相似,配置过程略。

(3)     检验配置效果

# 查看Router A上所有聚合组的摘要信息。

[RouterA] display link-aggregation summary

 

Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 000f-e2ff-0001

 

AGG         AGG       Partner ID               Select Unselect   Share

Interface   Mode                               Ports  Ports      Type

-------------------------------------------------------------------------------

BAGG1       S         none                     3      0          NonS

以上信息表明,聚合组1为二层静态聚合组,包含有三个选中端口。

1.6.2  二层动态聚合配置举例

1. 组网需求

·     Router A与Router B通过各自的二层以太网接口Ethernet1/1~Ethernet1/3相互连接。

·     在Router A和Router B上分别配置二层动态链路聚合组,并使两端的VLAN 10和VLAN 20之间分别互通。

2. 组网图

图1-5 二层动态聚合配置组网图

 

3. 配置步骤

(1)     配置Router A

# 创建VLAN 10,并将端口Ethernet1/4加入到该VLAN中。

<RouterA> system-view

[RouterA] vlan 10

[RouterA-vlan10] port ethernet 1/4

[RouterA-vlan10] quit

# 创建VLAN 20,并将端口Ethernet1/5加入到该VLAN中。

[RouterA] vlan 20

[RouterA-vlan20] port ethernet 1/5

[RouterA-vlan20] quit

# 创建二层聚合接口1,并配置该接口为动态聚合模式。

[RouterA] interface bridge-aggregation 1

[RouterA-Bridge-Aggregation1] link-aggregation mode dynamic

# 分别将端口Ethernet1/1至Ethernet1/3加入到聚合组1中。

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] port link-aggregation group 1

[RouterA-Ethernet1/1] quit

[RouterA] interface ethernet 1/2

[RouterA-Ethernet1/2] port link-aggregation group 1

[RouterA-Ethernet1/2] quit

[RouterA] interface ethernet 1/3

[RouterA-Ethernet1/3] port link-aggregation group 1

[RouterA-Ethernet1/3] quit

# 配置二层聚合接口1为Trunk端口,并允许VLAN 10和20的报文通过。

[RouterA] interface bridge-aggregation 1

[RouterA-Bridge-Aggregation1] port link-type trunk

[RouterA-Bridge-Aggregation1] port trunk permit vlan 10 20

 Please wait... Done.

 Configuring Ethernet1/1... Done.

 Configuring Ethernet1/2... Done.

 Configuring Ethernet1/3... Done.

[RouterA-Bridge-Aggregation1] quit

(2)     配置Router B

Router B的配置与Router A相似,配置过程略。

(3)     检验配置效果

# 查看Router A上所有聚合组的摘要信息。

[RouterA] display link-aggregation summary

 

Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 000f-e2ff-0001

 

AGG         AGG       Partner ID               Select Unselect   Share

Interface   Mode                               Ports  Ports      Type

-------------------------------------------------------------------------------

BAGG1       D         0x8000, 000f-e2ff-0002   3      0          NonS

以上信息表明,聚合组1为二层动态聚合组,包含有三个选中端口。

1.1.2  三层静态聚合配置举例

1. 组网需求

·     Router A与Router B通过各自的三层以太网接口Ethernet1/1~Ethernet1/3相互连接。

·     在Router A和Router B上分别配置三层静态链路聚合组,并为对应的三层聚合接口配置IP地址和子网掩码。

2. 组网图

图1-1 三层静态聚合配置组网图

 

3. 配置步骤

(1)     配置Router A

# 创建三层聚合接口1,并为该接口配置IP地址和子网掩码。

<RouterA> system-view

[RouterA] interface route-aggregation 1

[RouterA-Route-Aggregation1] ip address 192.168.1.1 24

[RouterA-Route-Aggregation1] quit

# 分别将接口Ethernet1/1至Ethernet1/3加入到聚合组1中。

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] port link-aggregation group 1

[RouterA-Ethernet1/1] quit

[RouterA] interface ethernet 1/2

[RouterA-Ethernet1/2] port link-aggregation group 1

[RouterA-Ethernet1/2] quit

[RouterA] interface ethernet 1/3

[RouterA-Ethernet1/3] port link-aggregation group 1

[RouterA-Ethernet1/3] quit

(2)     配置Router B

Router B的配置与Router A相似,配置过程略。

(3)     检验配置效果

# 查看Router A上所有聚合组的摘要信息。

[RouterA] display link-aggregation summary

 

Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 000f-e2ff-0001

 

AGG         AGG       Partner ID               Select Unselect   Share

Interface   Mode                               Ports  Ports      Type

-------------------------------------------------------------------------------

RAGG1       S         none                     1      2          NonS

以上信息表明,聚合组1为三层静态聚合组,包含有一个选中端口、两个未选中端口。

1.1.3  三层动态聚合配置举例

1. 组网需求

·     Router A与Router B通过各自的三层以太网接口Ethernet1/1~Ethernet1/3相互连接。

·     在Router A和Router B上分别配置三层动态链路聚合组,并为对应的三层聚合接口配置IP地址和子网掩码。

2. 组网图

图1-2 三层动态聚合配置组网图

 

3. 配置步骤

(1)     配置Router A

# 创建三层聚合接口1,配置该接口为动态聚合模式,并为其配置IP地址和子网掩码。

<RouterA> system-view

[RouterA] interface route-aggregation 1

[RouterA-Route-Aggregation1] link-aggregation mode dynamic

[RouterA-Route-Aggregation1] ip address 192.168.1.1 24

[RouterA-Route-Aggregation1] quit

# 分别将接口Ethernet1/1至Ethernet1/3加入到聚合组1中。

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] port link-aggregation group 1

[RouterA-Ethernet1/1] quit

[RouterA] interface ethernet 1/2

[RouterA-Ethernet1/2] port link-aggregation group 1

[RouterA-Ethernet1/2] quit

[RouterA] interface ethernet 1/3

[RouterA-Ethernet1/3] port link-aggregation group 1

[RouterA-Ethernet1/3] quit

(2)     配置Router B

Router B的配置与Router A相似,配置过程略。

(3)     检验配置效果

# 查看Router A上所有聚合组的摘要信息。

[RouterA] display link-aggregation summary

 

Aggregation Interface Type:

BAGG -- Bridge-Aggregation, RAGG -- Route-Aggregation

Aggregation Mode: S -- Static, D -- Dynamic

Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing

Actor System ID: 0x8000, 000f-e2ff-0001

 

AGG         AGG       Partner ID               Select Unselect   Share

Interface   Mode                               Ports  Ports      Type

-------------------------------------------------------------------------------

RAGG1       D         0x8000, 000f-e2ff-0002   1      2          NonS

以上信息表明,聚合组1为三层动态聚合组,包含有一个选中端口、两个未选中端口。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!