国家 / 地区

10-网络管理和监控配置指导

11-镜像配置

本章节下载  (514.25 KB)

docurl=/cn/Service/Document_Software/Document_Center/Switches/Catalog/S5150/S5150-EI/Configure/Operation_Manual/H3C_S5150-EI_CG-Release_510x-6W101/10/201801/1055401_30005_0.htm

11-镜像配置


1 端口镜像

1.1  端口镜像简介

端口镜像通过将指定端口的报文复制到与数据监测设备相连的端口,使用户可以利用数据监测设备分析这些复制过来的报文,以进行网络监控和故障排除。

1.1.1  基本概念

1. 镜像源

镜像源是指被监控的对象,该对象为端口,我们将之称为源端口。经由被监控的对象收发的报文会被复制一份到与数据监测设备相连的端口,用户就可以对这些报文(称为镜像报文)进行监控和分析了。镜像源所在的设备就称为源设备。

2. 镜像目的

镜像目的是指镜像报文所要到达的目的地,即与数据监测设备相连的那个端口,我们称之为目的端口,目的端口所在的设备就称为目的设备。目的端口会将镜像报文转发给与之相连的数据监测设备。

由于一个目的端口可以同时监控多个镜像源,因此在某些组网环境下,目的端口可能收到对同一报文的多份拷贝。例如,目的端口Port 1同时监控同一台设备上的源端口Port 2和Port 3收发的报文,如果某报文从Port 2进入该设备后又从Port 3发送出去,那么该报文将被复制两次给Port 1。

3. 镜像方向

镜像方向是指在镜像源上可复制哪些方向的报文:

·     入方向:是指仅复制镜像源收到的报文。

·     出方向:是指仅复制镜像源发出的报文。

·     双向:是指对镜像源收到和发出的报文都进行复制。

说明

如果对端口入方向的报文进行镜像,则镜像后的报文携带VLAN Tag的情况与原始报文保持一致;如果对端口出方向的报文进行镜像,则镜像后的报文始终携带报文在从源端口发送前所属VLAN的VLAN Tag。

 

4. 镜像组

镜像组是一个逻辑上的概念,镜像源和镜像目的都要属于某一个镜像组。根据具体的实现方式不同,镜像组可分为本地镜像组、远程源镜像组和远程目的镜像组三类,有关这三类镜像组的具体介绍,请参见“1.1.2  端口镜像的分类和实现方式”。

5. 反射端口、出端口和远程镜像VLAN

反射端口、出端口和远程镜像VLAN都是在二层远程端口镜像的实现过程中用到的概念。远程镜像VLAN是将镜像报文从源设备传送至目的设备的专用VLAN;反射端口和出端口都位于源设备上,都用来将镜像报文发送到远程镜像VLAN中。有关反射端口、出端口、远程镜像VLAN和二层远程端口镜像的具体介绍,请参见“1.1.2  端口镜像的分类和实现方式”。

说明

在实现端口镜像的设备上,将除源端口、目的端口、反射端口、出端口外的其他端口统称为普通端口。

 

1.1.2  端口镜像的分类和实现方式

根据镜像源与镜像目的是否位于同一台设备上,可以将端口镜像分为本地端口镜像和远程端口镜像两大类。

1. 本地端口镜像

当源设备与数据监测设备直接相连时,源设备可以同时作为目的设备,即由本设备将镜像报文转发至数据检测设备,这种方式实现的端口镜像称为本地端口镜像。对于本地端口镜像,镜像源和镜像目的属于同一台设备上的同一个镜像组,该镜像组称为本地镜像组。

图1-1 本地端口镜像示意图

图1-1所示,现在需要设备将进入端口Ten-GigabitEthernet1/0/1的报文复制一份,从端口Ten-GigabitEthernet1/0/2将报文转发给数据监测设备。为满足该需求,可以配置本地镜像组,其中源端口为Ten-GigabitEthernet1/0/1,镜像方向为入方向,目的端口为Ten-GigabitEthernet1/0/2。

2. 远程端口镜像

当源设备与数据监测设备不直接相连时,与数据监测设备直接相连的设备作为目的设备,源设备需要将镜像报文复制一份至目的设备,然后由目的设备将镜像报文转发至数据监测设备,这种方式实现的端口镜像称为远程端口镜像。对于远程端口镜像,镜像源和镜像目的分属于不同设备上的不同镜像组:镜像源所在的镜像组称为远程源镜像组,镜像目的所在的镜像组称为远程目的镜像组,而位于源设备与目的设备之间的设备则统称为中间设备。

由于源设备与目的设备之间通过二层网络进行连接,因此远程端口镜像又称为二层远程端口镜像。

二层远程端口镜像的实现方式包括:反射端口方式和出端口方式。

·     反射端口方式:源设备将进入源端口的报文复制一份给反射端口,再由该端口将镜像报文在远程镜像VLAN中广播,最终镜像报文经由中间设备转发至目的设备。目的设备收到该报文后判别其VLAN ID,若与远程镜像VLAN的VLAN ID相同,就将镜像报文通过目的端口转发给数据监测设备。过程如下图所示。

图1-2 二层远程端口镜像(反射端口方式)示意图

·     出端口方式:源设备将进入源端口的报文复制一份给出端口,该端口将镜像报文转发给中间设备,再由中间设备在远程镜像VLAN中广播,最终到达目的设备。目的设备收到该报文后判别其VLAN ID,若与远程镜像VLAN的VLAN ID相同,就将镜像报文通过目的端口转发给数据监测设备。过程如下图所示。

图1-3 二层远程端口镜像(出端口方式)示意图

说明

对于反射端口方式,由于镜像报文将被源设备的反射端口在远程镜像VLAN中广播,因此通过将源设备上的非源端口加入远程镜像VLAN,也可实现本地端口镜像的功能;而对于出端口方式则无此实现。

 

提示

·     为确保源设备与目的设备之间的镜像报文可以二层转发,中间设备连接到源设备和目的设备方向的端口上需允许远程镜像VLAN通过。

·     在一个镜像组中对同一个端口收发的报文进行双向镜像时,需要在源设备、中间设备和目的设备上关闭远程镜像VLAN的MAC地址学习功能,以保证镜像功能的正常进行。关于MAC地址学习功能的详细介绍,请参见“二层技术-以太网交换配置指导”中的“MAC地址表”。

 

1.2  配置本地端口镜像

1.2.1  配置任务简介

在完成源端口和目的端口的配置之后,本地镜像组才能生效。

表1-1 本地端口镜像配置任务简介

配置任务

说明

详细配置

创建本地镜像组

必选

1.2.2 

配置源端口

必选

1.2.3 

配置目的端口

必选

1.2.4 

 

1.2.2  创建本地镜像组

表1-2 创建本地镜像组

操作

命令

说明

进入系统视图

system-view

-

创建本地镜像组

mirroring-group group-id local

缺省情况下,未创建本地镜像组

 

1.2.3  配置源端口

可以在系统视图下为指定镜像组配置源端口,也可以在接口视图下将当前接口配置为指定镜像组的源端口,二者的配置效果相同。

二层聚合接口不支持镜像。

一个端口可被多个镜像组用作源端口。

源端口不能再被用作本镜像组或其他镜像组的反射端口、出端口或目的端口。

一个端口作为单向源端口最多可以加入两个镜像组(一个镜像组镜像源端口的入方向报文,另一个镜像组镜像源端口的出方向报文),作为双向源端口最多可以加入一个镜像组。

设备仅支持配置一个对源端口的出方向、或双向进行镜像的镜像组。

1. 在系统视图下配置源端口

表1-3 在系统视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置源端口

mirroring-group group-id mirroring-port interface-list { both | inbound | outbound }

缺省情况下,未为本地镜像组配置源端口

 

2. 在接口视图下配置源端口

表1-4 在接口视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置当前端口为本地镜像组的源端口

mirroring-group group-id mirroring-port { both | inbound | outbound }

缺省情况下,未配置当前端口为本地镜像组的源端口

 

1.2.4  配置目的端口

可以在系统视图下为指定镜像组配置目的端口,也可以在接口视图下将当前接口配置为指定镜像组的目的端口,二者的配置效果相同。

请不要在目的端口上使能生成树协议,否则会影响镜像功能的正常使用。

从目的端口发出的报文包括镜像报文和其他端口正常转发来的报文。为了保证数据监测设备只对镜像报文进行分析,请将目的端口只用于端口镜像,不作其他用途。

1. 在系统视图下配置目的端口

表1-5 在系统视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

为本地镜像组配置目的端口

mirroring-group group-id monitor-port interface-type interface-number

缺省情况下,未为本地镜像组配置目的端口

 

2. 在接口视图下配置目的端口

表1-6 在接口视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置本端口为本地镜像组的目的端口

mirroring-group group-id monitor-port

缺省情况下,未配置当前端口为本地镜像组的目的端口

 

1.3  配置二层远程端口镜像

1.3.1  配置任务简介

二层远程端口镜像的配置需要分别在源设备和目的设备上进行;如果存在中间设备,则需要在中间设备上允许远程镜像VLAN通过,以确保源设备与目的设备之间的二层网络畅通。

二层远程端口镜像的配置方式包括:反射端口方式和出端口方式。反射端口和出端口的配置区别在于前者不必加入远程镜像VLAN中,而后者则必须加入到远程镜像VLAN中。

在镜像报文从源设备到达目的设备的过程中,请确保其VLAN ID不被修改或删除,否则二层远程镜像功能将失效。

在配置二层远程端口镜像时不建议启用MVRP(Multiple VLAN Registration Protocol,多VLAN注册协议)功能,否则MVRP可能将远程镜像VLAN注册到不需要监控的端口上,导致目的端口收到很多不必要的报文。有关MVRP的详细介绍,请参见“二层技术-以太网交换配置指导”中的“MVRP”。

建议用户先配目的设备,再配中间设备,最后配源设备,以保证镜像流量的正常转发。

1. 反射端口方式

首先在目的设备上为远程目的镜像组配置远程镜像VLAN和目的端口,然后在源设备上为远程源镜像组配置源端口、反射端口和远程镜像VLAN。

表1-7 二层远程端口镜像配置任务简介(反射端口方式)

配置任务

说明

详细配置

配置远程目的镜像组

创建远程目的镜像组

必选

1.3.2  1.

配置目的端口

必选

1.3.2  2.

配置远程镜像VLAN

必选

1.3.2  3.

将目的端口加入远程镜像VLAN

必选

1.3.2  4.

配置远程源镜像组

创建远程源镜像组

必选

1.3.3  1.

配置源端口

必选

1.3.3  2.

配置反射端口

必选

1.3.3  3.

配置远程镜像VLAN

必选

1.3.3  5.

 

2. 出端口方式

首先在目的设备上为远程目的镜像组配置远程镜像VLAN和目的端口,然后在源设备上为远程源镜像组配置源端口、出端口和远程镜像VLAN。

表1-8 二层远程端口镜像配置任务简介(出端口方式)

配置任务

说明

详细配置

配置远程目的镜像组

创建远程目的镜像组

必选

1.3.2  1.

配置目的端口

必选

1.3.2  2.

配置远程镜像VLAN

必选

1.3.2  3.

将目的端口加入远程镜像VLAN

必选

1.3.2  4.

配置远程源镜像组

创建远程源镜像组

必选

1.3.3  1.

配置源端口

必选

1.3.3  2.

配置出端口

必选

1.3.3  4.

配置远程镜像VLAN

必选

1.3.3  5.

 

1.3.2  配置远程目的镜像组

请在目的设备上进行如下配置。

1. 创建远程目的镜像组

表1-9 创建远程目的镜像组

操作

命令

说明

进入系统视图

system-view

-

创建远程目的镜像组

mirroring-group group-id remote-destination

缺省情况下,未创建远程目的镜像组

 

2. 配置目的端口

可以在系统视图下为指定镜像组配置目的端口,也可以在接口视图下将当前接口配置为指定镜像组的目的端口,二者的配置效果相同。

请不要在目的端口上使能生成树协议,否则会影响镜像功能的正常使用。

设备不支持将二层聚合接口配置为二层远程端口镜像的目的端口

从目的端口发出的报文包括镜像报文和其他端口正常转发来的报文。为了保证数据监测设备只对镜像报文进行分析,请将目的端口只用于端口镜像,不作其他用途。

同一个目的端口不能配置在两个镜像组内。

(1)     在系统视图下配置目的端口

表1-10 在系统视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

为远程目的镜像组配置目的端口

mirroring-group group-id monitor-port interface-type interface-number

缺省情况下,未为远程镜像组配置目的端口

 

(2)     在接口视图下配置目的端口

表1-11 在接口视图下配置目的端口

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置本端口为远程目的镜像组的目的端口

mirroring-group group-id monitor-port

缺省情况下,未配置当前端口为远程镜像组的目的端口

 

3. 配置远程镜像VLAN

在配置远程镜像VLAN之前,需配置远程镜像VLAN所使用的静态VLAN。

当一个VLAN已被指定为远程镜像VLAN后,请不要将该VLAN再作其他用途。

源设备和目的设备上的远程镜像组必须使用相同的远程镜像VLAN。

表1-12 配置远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

为远程目的镜像组配置远程镜像VLAN

mirroring-group group-id remote-probe vlan vlan-id

缺省情况下,未为远程镜像组配置远程镜像VLAN

 

4. 将目的端口加入远程镜像VLAN

表1-13 将目的端口加入远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

进入目的接口视图

interface interface-type interface-number

-

将目的端口加入远程镜像VLAN

目的端口为Access端口

port access vlan vlan-id

三者选其一

目的端口为Trunk端口

port trunk permit vlan vlan-id

目的端口为Hybrid端口

port hybrid vlan vlan-id { tagged | untagged }

 

说明

有关port access vlanport trunk permit vlanport hybrid vlan命令的详细介绍,请参见“二层技术-以太网交换命令参考”中的“VLAN”。

 

1.3.3  配置远程源镜像组

请在源设备上进行如下配置。

1. 创建远程源镜像组

表1-14 创建远程源镜像组

操作

命令

说明

进入系统视图

system-view

-

创建远程源镜像组

mirroring-group group-id remote-source

缺省情况下,未创建远程源镜像组

 

2. 配置源端口

可以在系统视图下为指定镜像组配置源端口,也可以在接口视图下将当前接口配置为指定镜像组的源端口,二者的配置效果相同。

不能将源端口加入到远程镜像VLAN中,否则会影响镜像功能的正常使用。

一个端口可被多个镜像组用作源端口。

源端口不能再被用作本镜像组或其他镜像组的反射端口、出端口或目的端口。

一个端口作为单向源端口最多可以加入两个镜像组(一个镜像组镜像源端口的入方向报文,另一个镜像组镜像源端口的出方向报文),作为双向源端口最多可以加入一个镜像组。

设备仅支持配置一个对源端口的出方向、或双向进行镜像的镜像组。

设备不支持将二层聚合接口配置为二层远程端口镜像的源端口。

(1)     在系统视图下配置源端口

表1-15 在系统视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置源端口

mirroring-group group-id mirroring-port interface-list { both | inbound | outbound }

缺省情况下,未为远程镜像组配置源端口

 

(2)     在接口视图下配置源端口

表1-16 在接口视图下配置源端口

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置本端口为远程源镜像组的源端口

mirroring-group group-id mirroring-port { both | inbound | outbound }

缺省情况下,未配置当前端口为远程镜像组的源端口

 

3. 配置反射端口

可以在系统视图下为指定镜像组配置反射端口,也可以在接口视图下将当前接口配置为指定镜像组的反射端口,二者的配置效果相同。

建议选择设备上未被使用的端口作为反射端口,并不要在该端口上连接网线,否则会影响镜像功能的正常使用。

在将端口配置为反射端口时,该端口上已存在的所有配置都将被清除;在配置为反射端口后,该端口上不能再配置其他业务。

一个镜像组内只能配置一个反射端口。

只有当端口的双工模式、端口速率和MDI属性值均为缺省值时,才能将其配置为反射端口。当端口已配置为反射端口后,不能再修改其双工模式、端口速率和MDI属性值,即这些属性只能取缺省值。

(1)     在系统视图下配置反射端口

表1-17 在系统视图下配置反射端口

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置反射端口

mirroring-group group-id reflector-port interface-type interface-number

缺省情况下,未为远程源镜像组配置反射端口

 

(2)     在接口视图下配置反射端口

表1-18 在接口视图下配置反射端口

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置本端口为远程源镜像组的反射端口

mirroring-group group-id reflector-port

缺省情况下,未配置本端口为远程源镜像组的反射端口

 

4. 配置出端口

可以在系统视图下为指定镜像组配置出端口,也可以在接口视图下将当前接口配置为指定镜像组的出端口,二者的配置效果相同。

请不要在出端口上配置下列功能:生成树协议、802.1X、IGMP Snooping、静态ARP和MAC地址学习,否则会影响镜像功能的正常使用。

出端口不能是现有镜像组的成员端口。

一个镜像组内只能配置一个出端口。

(1)     在系统视图下配置出端口

表1-19 在系统视图下配置出端口

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置出端口

mirroring-group group-id monitor-egress interface-type interface-number

缺省情况下,未为远程源镜像组配置出端口

 

(2)     在接口视图下配置出端口

表1-20 在接口视图下配置出端口

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置本端口为远程源镜像组的出端口

mirroring-group group-id monitor-egress

缺省情况下,未配置本端口为远程源镜像组的出端口

 

5. 配置远程镜像VLAN

在配置远程镜像VLAN之前,需配置远程镜像VLAN所使用的静态VLAN。

当一个VLAN已被指定为远程镜像VLAN后,请不要将该VLAN再作其他用途。

源设备和目的设备上的远程镜像组必须使用相同的远程镜像VLAN。

表1-21 配置远程镜像VLAN

操作

命令

说明

进入系统视图

system-view

-

为远程源镜像组配置远程镜像VLAN

mirroring-group group-id remote-probe vlan vlan-id

缺省情况下,未为镜像组配置远程镜像VLAN

 

1.4  利用远程镜像VLAN实现本地镜像支持多目的端口

传统的本地镜像配置方式仅支持在一个镜像组中指定一个镜像目的端口,如果用户需要将一份监测数据同时发送到多个目的端口,可以利用远程镜像VLAN的原理来实现。

在二层远程端口镜像中,会使用到远程镜像VLAN,镜像报文在远程镜像VLAN中以广播的方式发送。因此,可以利用远程镜像VLAN的原理,在本地设备上创建远程源镜像组,并指定远程镜像VLAN,同时将本设备上连接数据检测设备的多个端口加入该VLAN。完成以上配置后,镜像报文在远程镜像VLAN中广播时便可以从这些端口中发送出去,实现将镜像报文输出至多个端口的需求。

表1-22 利用远程镜像VLAN实现本地镜像支持多目的端口配置

操作

命令

说明

进入系统视图

system-view

-

创建远程源镜像组

mirroring-group group-id remote-source

缺省情况下,不存在任何镜像组

为远程源镜像组配置源端口

在系统视图下配置

mirroring-group group-id mirroring-port mirroring-port-list { both | inbound | outbound }

两种方式必选其一

缺省情况下,镜像组没有源端口

在接口视图下配置

interface interface-type interface-number

mirroring-group group-id mirroring-port { both | inbound | outbound }

quit

-

为远程源镜像组配置反射端口

mirroring-group group-id reflector-port reflector-port

缺省情况下,镜像组没有反射端口

创建远程镜像VLAN并进入VLAN视图

vlan vlan-id

缺省情况下,镜像组没有远程镜像VLAN

将镜像目的端口加入远程镜像VLAN

port interface-list

缺省情况下,新建VLAN中不包含任何端口

退出至系统视图

quit

-

为远程源镜像组配置远程镜像VLAN

mirroring-group group-id remote-probe vlan vlan-id

缺省情况下,镜像组没有远程镜像VLAN

 

说明

·     建议选择设备上未被使用的端口作为反射端口,并不要在该端口上连接网线,否则会影响镜像功能的正常使用。

·     端口配置为反射口时,该端口上已存在的所有配置都将被清除;在被配置为反射口后,该端口上不能再配置其他业务功能。

·     请不要将源端口加入到远程镜像VLAN中,否则会影响镜像功能的正常使用。

·     一个VLAN只能作为一个远程源镜像组的远程镜像VLAN,且建议该VLAN只用于端口镜像,请不要在该VLAN上配置其他业务功能或创建对应的VLAN接口。

·     远程镜像VLAN必须为静态VLAN,且在被配置成远程镜像VLAN后,该VLAN不能直接删除,必须先删除远程镜像VLAN的配置才能够删除这个VLAN。

 

1.5  端口镜像显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后镜像组的运行情况,通过查看显示信息验证配置的效果。

表1-23 端口镜像显示和维护

操作

命令

显示镜像组的配置信息

display mirroring-group { group-id | all | local | remote-destination | remote-source }

 

1.6  端口镜像典型配置举例

1.6.1  本地端口镜像配置举例

1. 组网需求

Device通过端口Ten-GigabitEthernet1/0/1和Ten-GigabitEthernet1/0/2分别连接市场部和技术部,并通过端口Ten-GigabitEthernet1/0/3连接Server。

通过配置源端口方式的本地端口镜像,使Server可以监控所有进、出市场部和技术部的报文。

2. 组网图

图1-4 本地端口镜像配置组网图

3. 配置步骤

# 创建本地镜像组1。

<Device> system-view

[Device] mirroring-group 1 local

# 配置本地镜像组1的源端口为Ten-GigabitEthernet1/0/1和Ten-GigabitEthernet1/0/2,对源端口收发的报文都进行镜像,目的端口为Ten-GigabitEthernet1/0/3。

[Device] mirroring-group 1 mirroring-port ten-gigabitethernet 1/0/1 ten-gigabitethernet 1/0/2 both

[Device] mirroring-group 1 monitor-port ten-gigabitethernet 1/0/3

# 在目的端口Ten-GigabitEthernet1/0/3上关闭生成树协议。

[Device] interface ten-gigabitethernet 1/0/3

[Device-Ten-GigabitEthernet1/0/3] undo stp enable

[Device-Ten-GigabitEthernet1/0/3] quit

4. 验证配置

# 显示所有镜像组的配置信息。

[Device] display mirroring-group all

Mirroring group 1:

    Type: Local

    Status: Active

    Mirroring port:

        Ten-GigabitEthernet1/0/1  Both

        Ten-GigabitEthernet1/0/2  Both

    Monitor port: Ten-GigabitEthernet1/0/3

配置完成后,用户可以通过Server监控所有进、出市场部和技术部的报文。

1.6.2  二层远程端口镜像配置举例(反射端口方式)

1. 组网需求

在一个二层网络中,Device A、Device B、Device C及Server如下图所示连接。其中,Device A通过端口Ten-GigabitEthernet1/0/1连接市场部。

通过配置二层远程端口镜像,使Server可以监控所有进、出市场部的报文。

2. 组网图

3. 配置步骤

(1)     配置Device C

# 配置端口Ten-GigabitEthernet1/0/1为Trunk口,并允许VLAN 2的报文通过。

<DeviceC> system-view

[DeviceC] interface ten-gigabitethernet 1/0/1

[DeviceC-Ten-GigabitEthernet1/0/1] port link-type trunk

[DeviceC-Ten-GigabitEthernet1/0/1] port trunk permit vlan 2

[DeviceC-Ten-GigabitEthernet1/0/1] quit

# 创建远程目的镜像组2。

[DeviceC] mirroring-group 2 remote-destination

# 创建VLAN 2作为远程镜像VLAN。

[DeviceC] vlan 2

# 关闭VLAN 2的MAC地址学习功能。

[DeviceC-vlan2] undo mac-address mac-learning enable

[DeviceC-vlan2] quit

# 配置远程目的镜像组2的远程镜像VLAN为VLAN 2,目的端口为Ten-GigabitEthernet1/0/2,在该端口上关闭生成树协议并将其加入VLAN 2。

[DeviceC] mirroring-group 2 remote-probe vlan 2

[DeviceC] interface ten-gigabitethernet 1/0/2

[DeviceC-Ten-GigabitEthernet1/0/2] mirroring-group 2 monitor-port

[DeviceC-Ten-GigabitEthernet1/0/2] undo stp enable

[DeviceC-Ten-GigabitEthernet1/0/2] port access vlan 2

[DeviceC-Ten-GigabitEthernet1/0/2] quit

(2)     配置Device B

# 创建VLAN 2作为远程镜像VLAN。

<DeviceB> system-view

[DeviceB] vlan 2

# 关闭VLAN 2的MAC地址学习功能。

[DeviceB-vlan2] undo mac-address mac-learning enable

[DeviceB-vlan2] quit

# 配置端口Ten-GigabitEthernet1/0/1为Trunk口,并允许VLAN 2的报文通过。

[DeviceB] interface ten-gigabitethernet 1/0/1

[DeviceB-Ten-GigabitEthernet1/0/1] port link-type trunk

[DeviceB-Ten-GigabitEthernet1/0/1] port trunk permit vlan 2

[DeviceB-Ten-GigabitEthernet1/0/1] quit

# 配置端口Ten-GigabitEthernet1/0/2为Trunk口,并允许VLAN 2的报文通过。

[DeviceB] interface ten-gigabitethernet 1/0/2

[DeviceB-Ten-GigabitEthernet1/0/2] port link-type trunk

[DeviceB-Ten-GigabitEthernet1/0/2] port trunk permit vlan 2

[DeviceB-Ten-GigabitEthernet1/0/2] quit

(3)     配置Device A

# 创建远程源镜像组1。

<DeviceA> system-view

[DeviceA] mirroring-group 1 remote-source

# 创建VLAN 2作为远程镜像VLAN。

[DeviceA] vlan 2

# 关闭VLAN 2的MAC地址学习功能。

[DeviceA-vlan2] undo mac-address mac-learning enable

[DeviceA-vlan2] quit

# 配置远程源镜像组1的远程镜像VLAN为VLAN 2,源端口为Ten-GigabitEthernet1/0/1,反射端口为Ten-GigabitEthernet1/0/3。

[DeviceA] mirroring-group 1 remote-probe vlan 2

[DeviceA] mirroring-group 1 mirroring-port ten-gigabitethernet 1/0/1 both

[DeviceA] mirroring-group 1 reflector-port ten-gigabitethernet 1/0/3

This operation may delete all settings made on the interface. Continue? [Y/N]: y

# 配置端口Ten-GigabitEthernet1/0/2为Trunk口,并允许VLAN 2的报文通过。

[DeviceA] interface ten-gigabitethernet 1/0/2

[DeviceA-Ten-GigabitEthernet1/0/2] port link-type trunk

[DeviceA-Ten-GigabitEthernet1/0/2] port trunk permit vlan 2

[DeviceA-Ten-GigabitEthernet1/0/2] quit

4. 验证配置

# 显示Device C上所有镜像组的配置信息。

[DeviceC] display mirroring-group all

Mirroring group 2:

    Type: Remote destination

    Status: Active

    Monitor port: Ten-GigabitEthernet1/0/2

    Remote probe VLAN: 2

# 显示Device A上所有镜像组的配置信息。

[DeviceA] display mirroring-group all

Mirroring group 1:

    Type: Remote source

    Status: Active

    Mirroring port:

        Ten-GigabitEthernet1/0/1  Both

    Reflector port: Ten-GigabitEthernet1/0/3

    Remote probe VLAN: 2

配置完成后,用户可以通过Server监控所有进、出市场部的报文。

1.6.3  二层远程端口镜像配置举例(出端口方式)

1. 组网需求

在一个二层网络中,Device A、Device B、Device C及Server如下图所示连接。其中,Device A通过端口Ten-GigabitEthernet1/0/1连接市场部。

通过配置二层远程端口镜像,使Server可以监控所有进、出市场部的报文。

2. 组网图

图1-5 二层远程端口镜像配置组网图

3. 配置步骤

(1)     配置Device C

# 配置端口Ten-GigabitEthernet1/0/1为Trunk口,并允许VLAN 2的报文通过。

<DeviceC> system-view

[DeviceC] interface ten-gigabitethernet 1/0/1

[DeviceC-Ten-GigabitEthernet1/0/1] port link-type trunk

[DeviceC-Ten-GigabitEthernet1/0/1] port trunk permit vlan 2

[DeviceC-Ten-GigabitEthernet1/0/1] quit

# 创建远程目的镜像组2。

[DeviceC] mirroring-group 2 remote-destination

# 创建VLAN 2作为远程镜像VLAN。

[DeviceC] vlan 2

# 关闭VLAN 2的MAC地址学习功能。

[DeviceC-vlan2] undo mac-address mac-learning enable

[DeviceC-vlan2] quit

# 配置远程目的镜像组2的远程镜像VLAN为VLAN 2,目的端口为Ten-GigabitEthernet1/0/2,在该端口上关闭生成树协议并将其加入VLAN 2。

[DeviceC] mirroring-group 2 remote-probe vlan 2

[DeviceC] interface ten-gigabitethernet 1/0/2

[DeviceC-Ten-GigabitEthernet1/0/2] mirroring-group 2 monitor-port

[DeviceC-Ten-GigabitEthernet1/0/2] undo stp enable

[DeviceC-Ten-GigabitEthernet1/0/2] port access vlan 2

[DeviceC-Ten-GigabitEthernet1/0/2] quit

(2)     配置Device B

# 创建VLAN 2作为远程镜像VLAN。

<DeviceB> system-view

[DeviceB] vlan 2

# 关闭VLAN 2的MAC地址学习功能。

[DeviceB-vlan2] undo mac-address mac-learning enable

[DeviceB-vlan2] quit

# 配置端口Ten-GigabitEthernet1/0/1为Trunk口,并允许VLAN 2的报文通过。

[DeviceB] interface ten-gigabitethernet 1/0/1

[DeviceB-Ten-GigabitEthernet1/0/1] port link-type trunk

[DeviceB-Ten-GigabitEthernet1/0/1] port trunk permit vlan 2

[DeviceB-Ten-GigabitEthernet1/0/1] quit

# 配置端口Ten-GigabitEthernet1/0/2为Trunk口,并允许VLAN 2的报文通过。

[DeviceB] interface ten-gigabitethernet 1/0/2

[DeviceB-Ten-GigabitEthernet1/0/2] port link-type trunk

[DeviceB-Ten-GigabitEthernet1/0/2] port trunk permit vlan 2

[DeviceB-Ten-GigabitEthernet1/0/2] quit

(3)     配置Device A

# 创建远程源镜像组1。

<DeviceA> system-view

[DeviceA] mirroring-group 1 remote-source

# 创建VLAN 2作为远程镜像VLAN。

[DeviceA] vlan 2

# 关闭VLAN 2的MAC地址学习功能。

[DeviceA-vlan2] undo mac-address mac-learning enable

[DeviceA-vlan2] quit

# 配置远程源镜像组1的远程镜像VLAN为VLAN 2,源端口为Ten-GigabitEthernet1/0/1,出端口为Ten-GigabitEthernet1/0/2。

[DeviceA] mirroring-group 1 remote-probe vlan 2

[DeviceA] mirroring-group 1 mirroring-port ten-gigabitethernet 1/0/1 both

[DeviceA] mirroring-group 1 monitor-egress ten-gigabitethernet 1/0/2

# 配置端口Ten-GigabitEthernet1/0/2为Trunk口,允许VLAN 2的报文通过,并在该端口上关闭生成树协议。

[DeviceA] interface ten-gigabitethernet 1/0/2

[DeviceA-Ten-GigabitEthernet1/0/2] port link-type trunk

[DeviceA-Ten-GigabitEthernet1/0/2] port trunk permit vlan 2

[DeviceA-Ten-GigabitEthernet1/0/2] undo stp enable

[DeviceA-Ten-GigabitEthernet1/0/2] quit

4. 验证配置

# 显示Device C上所有镜像组的配置信息。

[DeviceC] display mirroring-group all

Mirroring group 2:

    Type: Remote destination

    Status: Active

    Monitor port: Ten-GigabitEthernet1/0/2

    Remote probe VLAN: 2

# 显示Device A上所有镜像组的配置信息。

[DeviceA] display mirroring-group all

Mirroring group 1:

    Type: Remote source

    Status: Active

    Mirroring port:

        Ten-GigabitEthernet1/0/1  Both

    Monitor egress port: Gigabitethernet1/0/2

    Remote probe VLAN: 2

配置完成后,用户可以通过Server监控所有进、出市场部的报文。

1.6.4  利用远程镜像VLAN实现本地镜像支持多目的端口配置举例

1. 组网需求

三个部门A、B、C分别使用Ten-GigabitEthernet1/0/1~Ten-GigabitEthernet1/0/3端口接入Device,现要求通过镜像功能,使数据检测设备ServerA和ServerB都能够对三个部门发送和接收的报文进行镜像。

2. 组网图

图1-6 利用远程镜像VLAN实现本地镜像支持多目的端口组网图

 

3. 配置步骤

# 创建远程源镜像组1。

<Device> system-view

[Device] mirroring-group 1 remote-source

# 将接入部门A、B、C的三个端口配置为远程源镜像组1的源端口。

[Device] mirroring-group 1 mirroring-port ten-gigabitethernet 1/0/1 to ten-gigabitethernet 1/0/3 both

# 将设备上任意未使用的端口(此处以Ten-GigabitEthernet1/0/6为例)配置为镜像组1的反射口。

[Device] mirroring-group 1 reflector-port ten-gigabitethernet 1/0/6

This operation may delete all settings made on the interface. Continue? [Y/N]:y

# 创建VLAN10作为镜像组1的远程镜像VLAN,并将接入数据检测设备的端口加入VLAN10。

[Device] vlan 10

[Device-vlan10] port ten-gigabitethernet 1/0/4 to ten-gigabitethernet 1/0/5

[Device-vlan10] quit

# 配置VLAN10作为镜像组1的远程镜像VLAN。

[Device] mirroring-group 1 remote-probe vlan 10

 


2 流镜像

2.1  流镜像简介

流镜像是指将指定报文复制到指定目的地,以便于对报文进行分析和监控。流镜像通过QoS策略来实现,即使用流分类技术为待镜像报文定义匹配条件,再通过配置流行为将符合条件的报文镜像至指定目的地。其优势在于用户通过流分类技术可以灵活地配置匹配条件,从而对报文进行精细区分,并将区分后的报文复制到目的地进行分析。有关QoS策略、流分类和流行为的详细介绍,请参见“ACL和QoS配置指导”中的“QoS配置方式”。

根据报文镜像的目的地不同,流行为可分为以下类型:

·     流镜像到接口:将符合条件的报文复制一份到指定接口,利用数据检测设备分析接口收到的报文。

·     流镜像到CPU:将符合条件的报文复制一份到CPU(这里的CPU是指报文进入的成员设备上的CPU),通过CPU分析报文的内容,或者将特定的协议报文上送。

2.2  流镜像配置任务简介

表2-1 流镜像配置任务简介

配置任务

说明

详细配置

配置报文匹配规则

必选

用来匹配待镜像的报文

2.3.1 

配置流行为

必选

用来指定将报文镜像到哪里(即报文的目的地址)

2.3.2 

配置QoS策略

必选

为流分类指定采用的流行为,即指定哪些报文需要镜像到哪里

2.3.3 

应用QoS策略

基于接口应用

四者至少选其一

指定对来自哪个端口、VLAN等的流量进行镜像

2.3.4  1.

基于VLAN应用

2.3.4  2.

基于全局应用

2.3.4  3.

基于控制平面应用

2.3.4  4.

 

2.3  配置流镜像

mirror-to命令外的其他配置命令及相关显示命令的详细介绍,请参见“ACL和QoS命令参考”中的“QoS策略”。

2.3.1  配置报文匹配规则

表2-2 配置报文匹配规则

操作

命令

说明

进入系统视图

system-view

-

定义流分类,并进入流分类视图

traffic classifier classifier-name [ operator { and | or } ]

缺省情况下,未定义流分类

配置报文匹配规则

if-match match-criteria

缺省情况下,未配置报文匹配规则

 

2.3.2  配置流行为

表2-3 配置流行为

操作

命令

说明

进入系统视图

system-view

-

定义流行为,并进入流行为视图

traffic behavior behavior-name

缺省情况下,不存在流行为

配置流镜像到接口

mirror-to interface interface-type interface-number

缺省情况下,未配置流镜像到接口

同一流行为中多次执行该命令,仅第一次执行的命令生效

配置流镜像到CPU

mirror-to cpu

缺省情况下,未配置流镜像到CPU

 

说明

·     在完成上述配置后,在任意视图display traffic behavior命令可以显示用流行的配置信息,通过查示信息验证配置的效果。

·     同一流行为中,如果同时存在流镜像和非流镜像动作,QoS策略应用后,只有流镜像动作生效。

 

2.3.3  配置QoS策略

表2-4 配置QoS策略

操作

命令

说明

进入系统视图

system-view

-

定义QoS策略,并进入QoS策略视图

qos policy policy-name

缺省情况下,未定义QoS策略

为流分类指定采用的流行为

classifier classifier-name behavior behavior-name

缺省情况下,未为流分类指定流行为

 

说明

在完成上述配置后,在任意视图下执行display qos policy命令可以显示用户定义策略的配置信息,通过查看显示信息验证配置的效果。

 

2.3.4  应用QoS策略

1. 基于接口应用

将QoS策略应用到某接口,可以对该接口指定方向上的流量进行镜像。一个QoS策略可以应用于多个接口,而接口在每个方向上只能应用一个QoS策略。

设备不支持对聚合口出方向的报文进行流镜像。

表2-5 基于接口应用

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

应用QoS策略到接口

qos apply policy policy-name { inbound | outbound }

-

 

2. 基于VLAN应用

将QoS策略应用到某VLAN,可以对该VLAN内各端口指定方向上的流量进行镜像。

表2-6 基于VLAN应用

操作

命令

说明

进入系统视图

system-view

-

应用QoS策略到指定VLAN

qos vlan-policy policy-name vlan vlan-id-list { inbound | outbound }

-

 

3. 基于全局应用

将QoS策略应用到全局,可以对设备各端口指定方向上的流量进行镜像。

表2-7 基于全局应用

操作

命令

说明

进入系统视图

system-view

-

应用QoS策略到全局

qos apply policy policy-name global { inbound | outbound }

-

 

4. 基于控制平面应用

将QoS策略应用到控制平面,可以对控制平面各端口指定方向上的流量进行镜像。

表2-8 基于控制平面应用

操作

命令

说明

进入系统视图

system-view

-

进入控制平面视图

control-plane slot slot-number

-

应用QoS策略到控制平面

qos apply policy policy-name inbound

-

 

2.4  流镜像典型配置举例

1. 组网需求

某公司内的各部门之间使用不同网段的IP地址,其中市场部和技术部分别使用192.168.1.0/24和192.168.2.0/24网段,该公司的工作时间为每周工作日的8点到18点。

通过配置流镜像,使Server可以监控技术部访问互联网的WWW流量,以及技术部在工作时间发往市场部的IP流量。

2. 组网图

图2-1 流镜像典型配置组网图

3. 配置步骤

# 定义工作时间:创建名为work的时间段,其时间范围为每周工作日的8点到18点。

<Device> system-view

[Device] time-range work 8:00 to 18:00 working-day

# 创建一个编号为3000的IPv4高级ACL,并定义如下规则:匹配技术部访问WWW的报文,以及在工作时间由技术部发往市场部的IP报文。

[Device] acl advanced 3000

[Device-acl-ipv4-adv-3000] rule permit tcp source 192.168.2.0 0.0.0.255 destination-port eq www

[Device-acl-ipv4-adv-3000] rule permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255 time-range work

[Device-acl-ipv4-adv-3000] quit

# 创建流分类tech_c,并配置报文匹配规则为ACL 3000。

[Device] traffic classifier tech_c

[Device-classifier-tech_c] if-match acl 3000

[Device-classifier-tech_c] quit

# 创建流行为tech_b,并配置流镜像到接口Ten-GigabitEthernet1/0/3。

[Device] traffic behavior tech_b

[Device-behavior-tech_b] mirror-to interface ten-gigabitethernet 1/0/3

[Device-behavior-tech_b] quit

# 创建QoS策略tech_p,在策略中为流分类tech_c指定采用流行为tech_b。

[Device] qos policy tech_p

[Device-qospolicy-tech_p] classifier tech_c behavior tech_b

[Device-qospolicy-tech_p] quit

# 将QoS策略tech_p应用到接口Ten-GigabitEthernet1/0/4的入方向上。

[Device] interface ten-gigabitethernet 1/0/4

[Device-Ten-GigabitEthernet1/0/4] qos apply policy tech_p inbound

[Device-Ten-GigabitEthernet1/0/4] quit

4. 验证配置

配置完成后,用户可以通过Server监控技术部访问互联网的WWW流量,以及技术部在工作时间发往市场部的IP流量。

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!