选择区域语言: EN CN HK

09-MPLS配置指导

09-MPLS L2VPN配置

本章节下载  (695.76 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/SR_Router/SR6600-X/Configure/Operation_Manual/H3C_SR6600_SR6600-X_CG-R7612-6W100/09/201709/1030315_30005_0.htm

09-MPLS L2VPN配置


1 MPLS L2VPN

MPLS L2VPN既可以提供点到点的连接,也可以提供多点间的连接。本章只介绍提供点到点连接的MPLS L2VPN技术。提供多点间连接的MPLS L2VPN技术,请参见“MPLS配置指导”中的“VPLS”。

1.1  MPLS L2VPN简介

MPLS L2VPN是基于MPLS的二层VPN(Virtual Private Network,虚拟专用网络)技术,是PWE3(Pseudo Wire Emulation Edge-to-Edge,边缘到边缘的伪线仿真)的一种实现方式。MPLS L2VPN将用户的二层数据(如以太网数据帧、ATM信元等)封装成可以在IP或MPLS网络中传送的分组,通过IP路径或MPLS隧道转发封装后的分组,接收端解封装分组后恢复原来的二层数据,从而实现用户二层数据跨越MPLS或IP网络透明地传送。从用户的角度来看,MPLS或IP网络是一个二层交换网络,可以在用户网络的不同站点(Site)间建立二层连接。

利用MPLS L2VPN,运营商可以在统一的MPLS或IP骨干网上为不同的数据链路层提供VPN服务,包括Ethernet、VLAN、PPP、ATM、Frame Relay等,使得数据链路层业务可以穿越MPLS或IP骨干网传送。以Ethernet类型的用户网络为例,通过MPLS L2VPN连接的Ethernet节点感知不到MPLS或IP骨干网的存在,就好像节点之间直接通过以太网相连。

1.1.1  基本概念

·     CE(Customer Edge,用户网络边缘)设备

直接与服务提供商网络相连的用户网络侧设备。

·     PE(Provider Edge,服务提供商网络边缘)设备

与CE相连的服务提供商网络侧设备。PE主要负责VPN业务的接入,完成报文从用户网络到公网隧道、从公网隧道到用户网络的映射与转发。

·     AC(Attachment Circuit,接入电路)

连接CE和PE的物理电路或虚拟电路,例如Frame Relay的DLCI、ATM的VPI/VCI、Ethernet接口、VLAN、物理接口上的PPP连接。

·     PW(Pseudowire,伪线)

两个PE之间的虚拟双向连接。MPLS PW由一对方向相反的单向LSP构成。

·     公网隧道(Tunnel)

穿越IP或MPLS骨干网、用来承载PW的隧道。一条公网隧道可以承载多条PW,公网隧道可以是LSP、MPLS TE、GRE隧道等。

·     交叉连接(Cross connect)

由两条物理电路或虚拟电路串连而成的一条连接,从一条物理、虚拟电路收到的报文直接交换到另一条物理、虚拟电路转发。交叉连接包括三种方式:AC到AC交叉连接、AC到PW交叉连接、PW到PW交叉连接。

·     Site ID

用户网络站点在VPN内的唯一标识。不同VPN内站点的Site ID可以相同。

·     RD(Route Distinguisher,路由标识符)

RD用来区分不同VPN内Site ID相同的站点。在Site ID前增加RD,通过RD+Site ID可以唯一标识网络中的一个站点。

·     标签块

标签块是一组标签的集合,包含以下参数:

¡     LB(Label Base,初始标签):标签块的标签初始值。该值为PE设备自动选取,不可手动修改。

¡     LR(Label Range,标签范围):标签块包含的标签数目。LB和LR确定了标签块中包含哪些标签。例如,LB为1000、LR为5,则该标签块包含的标签为1000~1004。

¡     LO(Label-block Offset,标签块偏移):VPN网络中站点的数量增加,原有的标签块大小无法满足要求时,PE无需撤销原有的标签块,只要在原有标签块的基础上再分配一个新的标签块就可以扩大标签范围,满足扩展需要。在这种情况下,PE通过LO来标识某个标签块在所有为站点分配的标签块中的位置,并根据LO来判断从哪个标签块中分配标签。LO的取值为之前分配的所有标签块大小的总合。例如,PE为站点分配的第一个标签块的LR为10、LO为0,则第二个标签块的LO为10;如果第二个标签块的LR为20,则第三个标签块的LO为30。

标签块通过LB/LO/LR来表示,即LB为1000、LO为10、LR为5的标签块可以表示为1000/10/5。

假设,某个VPN网络中原有站点数量为10,PE为其分配第一个标签块LB1/0/10。站点数量增加到25时,PE可以保留分配的第一个标签块,并补充分配第二个标签块LB2/10/15,从而满足VPN网络扩展的要求。其中,LB1和LB2为PE随机选取的初始标签值。

·     VPN target

MPLS L2VPN使用BGP扩展团体属性——VPN Target(也称为Route Target)来控制BGP L2VPN信息的发布。

PE上的VPN target属性分为以下两种,每一种都可以包括多个属性值:

¡     Export target属性:本地PE在通过BGP的Update消息将L2VPN信息(如本地Site ID、RD、标签块等)发送给远端PE时,将Update消息中携带的VPN target属性设置为Export target。

¡     Import target属性:PE收到其它PE发布的Update消息时,将消息中携带的VPN target属性与本地配置的Import target属性进行比较,只有二者中存在相同的属性值时,才会接收该消息中的L2VPN信息。

也就是说,VPN target属性定义了本地发送的L2VPN信息可以为哪些PE所接收,PE可以接收哪些远端PE发送来的L2VPN信息。

1.1.2  基本网络架构

MPLS L2VPN的组网架构分为远程连接和本地交换两种。

1. 远程连接组网架构

图1-1所示,MPLS L2VPN的远程连接组网是指通过穿越IP或MPLS骨干网络的PW连接两端的用户网络。

图1-1 远程连接组网

 

2. 本地交换组网架构

图1-2所示,本地交换是MPLS L2VPN提供的一种比较特殊的连接,它是指将同一个用户网络两个站点的CE连接到同一个PE上,两个CE直接通过PE进行用户报文的交换。

图1-2 本地交换组网图

 

1.1.3  远程连接的配置方法和工作原理

要想通过MPLS L2VPN的远程连接转发报文,需要完成以下工作:

·     建立公网隧道,公网隧道用来承载PE之间的一条或多条PW。

·     建立用来传送特定用户网络报文的PW,PW标签标识了报文所属的用户网络。

·     建立用来连接CE和PE的AC,AC的报文匹配规则(显式配置或隐含的规则)决定了从CE接收到的哪些报文属于一个特定的用户网络。

·     将AC和PW关联,以便PE确定从AC接收到的报文向哪条PW转发,从PW接收到的报文向哪条AC转发。

完成上述配置后,PE从AC接收到用户网络的报文后,根据AC关联的PW为报文封装PW标签,并通过公网隧道将报文转发给远端PE;远端PE从公网隧道接收到报文后,根据PW标签判断报文所属的PW,并将还原后的原始报文转发给与该PW关联的AC。

1. 建立公网隧道

公网隧道用来承载PW,可以是LSP隧道、MPLS TE隧道和GRE隧道等。不同隧道的建立方式不同,详细介绍请参见相关手册。

当两个PE之间存在多条公网隧道时,可以通过配置隧道策略,确定如何选择隧道。隧道策略的详细介绍,请参见“MPLS配置指导”中的“隧道策略”。

说明

如果PW建立在LSP或MPLS TE隧道之上,则PW上传送的报文将包括两层标签:内层标签为PW标签,用来决定报文所属的PW,从而将报文转发给正确的CE;外层标签为公网LSP或MPLS TE隧道标签,用来保证报文在MPLS网络正确传送。

 

2. 建立PW

建立PW是指两端的PE设备分别为对方分配PW标签,以便建立方向相反的一对单向LSP。

PW的建立方式有以下几种:

·     静态方式

静态方式建立PW是指在两端的PE上分别手工指定远端PE地址、PW的入标签、出标签等信息,以便建立PW。采用静态方式建立的PW,称为静态PW。

采用此方式时,不需要使用PW信令协议传递PW标签等信息,消耗的网络资源比较少,但是需要手工在两端PE上配置入标签和出标签,配置比较复杂。

·     LDP方式

LDP方式建立PW是指在两端的PE上分别手工指定远端PE地址后,通过LDP协议向该远端PE通告本端PE为PW分配的PW标签等信息,以便建立PW。采用LDP方式建立的PW,称为LDP PW。

为了在PE之间交换PW和PW标签的绑定关系,LDP定义了一种新的FEC类型——PW ID FEC。该FEC通过PW ID和PW type来标识一条PW。其中,PW ID为PW在两个PE之间的标识;PW type表明PW上传送数据的封装类型,如ATM、帧中继、Ethernet、VLAN等。

PE发送标签映射消息时,在消息中携带PW ID FEC及相应的PW标签,就可以将PE为该PW分配的PW标签通告给远端PE。两端PE均收到对端通告的PW标签后,便成功在这两个PE之间建立起一条PW。

与静态方式相比,LDP方式配置比较简单,但是消耗的网络资源比较多。

·     BGP方式

BGP方式建立PW是指通过BGP协议通告本端PE分配的PW标签块等信息,以便远端PE自动发现该PE,并与其建立PW。采用BGP方式建立的PW,称为BGP PW。

采用BGP方式建立PW的过程为:PE将自己分配的标签块通过扩展的BGP Update消息通告给同一个VPN内的所有PE,每个PE都根据其他PE通告的标签块计算PW出标签、根据自己分配的标签块计算PW入标签。两端PE分别计算出PW入标签和PW出标签后,便在二者之间建立了BGP PW。

BGP方式具有如下特点:

¡     无需手工指定远端PE的地址,在通过BGP发布标签块信息的同时可以自动发现远端PE,简化了配置。

¡     通过发布标签块信息可以实现一次为多个PW分配标签,减少了VPN部署和扩容时的配置工作量,但是耗费的标签资源较多。

·     CCC方式

CCC(Circuit Cross Connect,电路交叉连接)方式建立PW是指通过在PE设备上手工指定入标签和出标签而建立一条静态连接。CCC方式建立的PW称为CCC PW,或CCC远程连接。

CCC远程连接不需要公网隧道来承载,它通过在PE之间的P设备上配置两条方向相反的静态LSP,来实现报文跨越公网传送。通过CCC远程连接转发二层用户报文时,只需为用户报文封装一层标签。

CCC远程连接对P设备上LSP的使用是独占性的。P设备上的LSP只用于传递这个CCC远程连接的数据,不能用于其他连接,也不能用于MPLS L3VPN。

3. 建立AC

AC是CE与PE之间的物理电路或虚拟电路,它可以是以太网链路、用DLCI标识的帧中继虚电路等。建立AC就是在PE和CE上配置链路层协议,以便在PE和CE之间建立链路层连接,如PPP连接。

AC在PE上的表现形式有如下两种:

·     三层物理接口或三层虚拟接口:用来做端口透传,即物理接口或虚拟接口(如三层虚拟以太网接口)上接收到的所有报文都关联到同一条PW。这种方式称为端口模式,如以太网端口透传、ATM信元端口透传、Frame Relay端口透传。

·     三层子接口:将子接口对应的链路(如VLAN、ATM VPC、ATM VCC、Frame Relay的DLCI)上接收到的报文关联到同一条PW。采用这种方式时,VLAN在接口范围内唯一,而不是整设备范围内唯一。

说明

VLAN整设备范围内唯一是指不区分接口,无论从哪个接口接收到的报文,只要Tag相同就关联到同一条PW;VLAN接口范围内唯一是指从不同接口接收到的带有相同Tag的报文,可以关联到不同的PW。

 

4. 将AC和PW关联

通过命令行将AC连接对应的三层物理接口、三层子接口与PW关联,即可实现从该AC接收到的报文通过关联的PW转发,从关联的PW上接收到的报文通过该AC转发。

1.1.4  本地交换的配置方法和工作原理

要想实现报文的本地交换,需要完成以下工作:

(1)     在同一台PE上建立两条AC

两个CE连接到同一个PE时,在PE和两个CE之间配置链路层协议,以便PE与两个CE分别建立AC连接。详细介绍请参见“1.1.3  3. 建立AC”。

(2)     将两个AC关联

通过命令行将两条AC连接对应的三层物理接口、三层子接口关联,即可实现从一个AC接收到的报文被转发到与其关联的另一个AC。

1.1.5  PW数据封装类型

MPLS L2VPN可以在PW上传递不同数据链路层协议的二层用户报文。为二层报文封装PW标签前,PE对不同链路层协议的二层报文的处理方式有所不同。PW数据封装类型(PW type)用来标识PE对二层报文的处理方式。PW数据封装类型与AC的链路类型(PE—CE之间的链路类型)密切相关,其对应关系如表1-1所示。

表1-1 AC链路类型及PW数据封装类型对应关系表

AC链路类型

PW数据封装类型

以太网

Ethernet

VLAN

PPP

PPP

HDLC

HDLC

 

1. Ethernet over MPLS

Ethernet over MPLS是指利用MPLS L2VPN连接以太网,通过PW在MPLS骨干网上传送Ethernet报文。

Ethernet over MPLS对应的PW数据封装类型有两种:

·     Ethernet数据封装类型下,PW上传输的帧不能带服务提供商网络为了区分用户而要求用户添加的P-Tag,该Tag又称为服务定界符。对于CE侧的报文,如果PE从CE收到带有P-Tag的报文,则将其去除后再添加PW标签和公网隧道标签转发;如果从CE收到不带P-Tag的报文,则直接添加PW标签和公网隧道标签后转发。对于PE发送给CE的报文,如果ac interface命令配置的接入模式为VLAN,则添加P-Tag后转发给CE;如果配置的接入模式为Ethernet,则不添加P-Tag,直接转发给CE;不允许重写或去除已经存在的任何Tag。

·     VLAN数据封装类型下,PW上传输的帧必须带P-Tag。对于CE侧的报文,PE从CE收到带有P-Tag的报文后,如果远端PE不要求Ingress改写P-Tag,则保留P-Tag,如果远端PE要求Ingress改写P-Tag,则将P-Tag改写为远端PE期望的VLAN Tag(Tag可能是值为0的空Tag),再添加PW标签和公网隧道标签后转发;从CE收到不带P-Tag的报文后,如果远端PE不要求Ingress改写P-Tag,则添加值为0的空P-Tag,如果远端PE要求Ingress改写P-Tag,则添加一个远端PE期望的VLAN Tag(Tag可能是值为0的空Tag)后,再添加PW标签和公网隧道标签后转发。对于PE发送给CE的报文,如果ac interface命令配置的接入模式为VLAN,转发给CE时重写或保留P-Tag;如果配置的接入模式为Ethernet,则去除P-Tag后转发给CE。

Ethernet over MPLS有如下几种方式:

·     端口模式

通过命令行将三层以太网接口与PW关联。这样,从该接口收到的所有报文都通过关联的PW传送到远端PE。缺省情况下,端口模式中PW的数据封装类型为Ethernet。

图1-3 Ethernet的端口模式

 

·     VLAN模式

通过命令行将三层以太网子接口与PW关联。这样,接收到的所有属于特定VLAN的报文都通过关联的PW传送到远端PE,远端PE可以根据连接的用户网络的需要修改VLAN tag。缺省情况下,VLAN模式中PW的数据封装类型为VLAN。

2. PPP/HDLC over MPLS

PPP/HDLC over MPLS是指利用MPLS L2VPN连接PPP或HDLC网络,通过PW在MPLS骨干网上传送PPP或HDLC报文。

PPP over MPLS对应的PW数据封装类型为PPP;HDLC over MPLS对应的PW数据封装类型为HDLC。

PPP/HDLC over MPLS只支持端口模式,即通过命令行将配置了PPP或HDLC封装的三层接口与PW关联。PE从三层接口接收到PPP/HDLC报文后,查找与该接口关联的PW,对PPP/HDLC报文进行封装后,通过该PW将封装后的报文传递给远端PE;远端PE去掉外层封装,还原出PPP/HDLC报文,并将其转发给用户网络。

1.1.6  控制字功能

控制字字段位于MPLS标签栈和二层数据之间,用来携带额外的二层数据帧的控制信息,如序列号等。控制字具有如下功能:

·     避免报文乱序:在多路径转发的情况下,报文有可能产生乱序,此时可以通过控制字的序列号字段对报文进行排序重组。

·     传送特定二层数据帧的标记:如帧中继的FECN(Forward Explicit Congestion Notification,前向显式拥塞通知)比特和BECN(Backward Explicit Congestion Notification,后向显式拥塞通知)比特等。

·     指示净载荷长度:如果PW上传送报文的净载荷长度小于64字节,则需要对报文进行填充,以避免报文发送失败。此时,通过控制字的载荷长度字段可以确定原始载荷的长度,以便从填充后的报文中正确获取原始的报文载荷。

对于某些PW数据封装类型(如帧中继DLCI类型、ATM AAL5 SDU VCC类型),PW上传递的报文必须携带控制字字段,不能通过配置来控制。对于某些PW数据封装类型(如Ethernet、VLAN),控制字字段是可选的,由两端的配置共同决定是否携带控制字:如果两端PE上都使能了控制字功能,则报文中携带控制字字段;否则,报文中不携带控制字字段。

1.1.7  异构网络互连(Interworking)

CE接入PE的链路类型多种多样,如ATM、FR、HDLC、Ethernet、PPP等。不同接入链路类型的CE之间可以通过MPLS L2VPN网络互相通信,即MPLS L2VPN可以连接异构的网络。

目前,本地交换、静态PW、LDP PW和CCC远程连接可以连接异构的网络。

说明

MPLS L2VPN连接异构网络有两种方式:Ethernet interworking和IP interworking。目前,设备只支持IP interworking方式,本文只介绍这种方式。

 

图1-4 MPLS L2VPN连接异构网络示意图

 

图1-4所示,以Ethernet和PPP链路类型为例,MPLS L2VPN连接异构网络的报文转发过程为:

(1)     CE 1将目的地址为CE 2的以太网数据帧发送给PE 1。

(2)     PE 1判断接收到的以太网数据帧内封装的是否为IP报文。若是,则删除以太网头、添加PW标签V和隧道标识T后,将报文沿隧道转发给远端PE 2。否则,丢弃该报文。

(3)     PE 2根据PW标签V获取报文的出接口,弹出PW标签后为报文添加PPP头,将PPP数据帧发送给CE 2。

MPLS L2VPN连接异构网络时,链路层协商报文不会在网络中传递,CE之间无法直接建立二层连接。因此,PE需要与接入的CE建立二层连接,例如,PPP链路中PE需要与CE进行PPP协商,以建立PPP连接。

1.1.8  PW冗余保护

如果两个CE之间只存在一条PW,则当PE节点、PE与CE之间的链路、或PE之间的PW出现故障时,CE之间将无法通信。PW冗余保护功能通过部署主备两条PW,实现当主PW出现故障后,将流量立即切换到备份PW,使得流量转发得以继续。目前,只有静态PW和LDP PW支持PW冗余保护功能。

图1-5所示,在两个CE之间建立两条PW链路,正常情况下,CE使用主PW与远端CE通信;当PE 1检测出到PE 2的PW不可用(可能是PE 2节点故障,也可能是PW故障,或PE 2与CE 2之间的链路故障),PE 1将启用备份PW,通过备份PW将CE 1的报文转发给PE 3,再由PE 3转发给CE 2。CE 2接收到报文后,通过更新MAC地址表项等方式将发送给CE 1的报文切换到备份PW转发,从而保证通信不会中断。

图1-5 MPLS L2VPN的PW冗余保护

 

MPLS L2VPN根据控制平面的LDP会话状态,或者数据平面连通性检测结果等来判断当前使用的PW是否可以继续使用。在当前使用的PW不可用的情况下,将流量切换到备用的另一条PW上。在以下情况下,将启用备份PW:

·     承载主PW的公网隧道被拆除或通过BFD等检测机制检测到公网隧道出现故障,导致主PW的状态变为down;

·     控制平面拆除主PW(如主PW两端PE之间的LDP会话down导致主PW被删除),或利用BFD等链路检测机制检测到主PW故障;

·     执行命令手工切换主备PW。

控制平面和数据平面的介绍,请参见“MPLS配置指导”中的“MPLS基础”。

1.1.9  多段PW

多段PW是指将两条或多条静态PW或LDP PW串连(concatenated)起来,形成一条端到端的PW。通过在同一个交叉连接下创建两条PW,可以实现将该交叉连接下的两条PW串连。PE从一条PW接收到报文后,剥离报文的隧道标识和PW标签,封装上与该PW串连的另一条PW的PW标签,并通过承载该PW的公网隧道转发该报文,从而实现报文在两条PW之间的转发。目前,只有静态PW和LDP PW支持多段PW功能。

图1-6所示,通过在PE 2上将PW 1和PW 2串连、在PE 3上将PW 2和PW 3串连,可以建立从PE 1到PE 4的端到端PW,实现报文沿着PW 1、PW 2和PW 3形成的多段PW在PE 1和PE 4之间转发。

图1-6 多段PW示意图

 

多段PW分为:

·     域内多段PW:即在一个自治系统内部署多段PW。

·     域间多段PW:即跨越自治系统部署多段PW。

1. 域内多段PW

在一个自治系统内部署多段PW,可以实现两个PE之间不存在端到端公网隧道的情况下,在这两个PE之间建立端到端PW。

图1-7所示,PE 1和PE 4之间没有建立公网隧道,PE 1和PE 2、PE 2和PE 4之间已经建立了公网隧道。通过在PE 1与PE 2、PE 2与PE 4之间分别建立一条PW(PW 1和PW 2),在PE 2上将这两条PW串连,可以实现在PE 1和PE 4之间建立一条由两段PW组成的端到端域内多段PW。

通过建立域内多段PW可以充分利用已有的公网隧道,减少端到端公网隧道数量。

图1-7 域内多段PW

 

2. 域间多段PW

域间多段PW可以提供穿越多个自治系统的端到端PW,可以作为跨自治系统的Option B解决方案。如图1-8所示,在PE 1与ASBR 1、ASBR 1与ASBR 2、ASBR 2与PE 2之间分别建立PW 1、PW 2和PW 3,在ASBR 1上将PW 1与PW 2串连,在ASBR 2上将PW 2与PW 3串连后,即可建立从PE 1到PE 2的跨域PW,实现报文的跨域传送。

图1-8 域间多段PW

 

1.1.10  PW连通校验VCCV

VCCV(Virtual Circuit Connectivity Verification,虚电路连通性验证)是L2VPN的一种OAM功能,用于确认PW数据平面的连通性。VCCV有两种方式:

·     按需方式:执行ping mpls pw命令手工触发PW检测。

·     自动方式:配置通过BFD或Raw-BFD检测PW后,系统主动完成PW检测。

VCCV的详细介绍,请参见“MPLS配置指导”中的“MPLS OAM”。

1.2  MPLS L2VPN配置任务简介

在MPLS L2VPN组网中,需要进行以下配置:

·     配置IGP(Interior Gateway Protocol,内部网关协议),实现骨干网的IP连通性。

·     配置MPLS基本功能、LDP、GRE或MPLS TE等,在骨干网上建立公网隧道。

·     在两端的PE设备上配置MPLS L2VPN,如建立PW、将AC与PW关联。

本文只介绍PE设备上的MPLS L2VPN相关配置。

在不同的场景下,MPLS L2VPN的配置有所不同:

·     远程连接:在该场景下,需要配置AC、在交叉连接视图/自动发现交叉连接视图下配置PW、在交叉连接视图/自动发现交叉连接视图下配置AC与该交叉连接关联,以便关联同一交叉连接视图/自动发现交叉连接视图下的AC和PW。

·     本地交换:在该场景下,需要配置AC、在交叉连接视图下配置两条AC分别与该交叉连接关联,以便关联同一交叉连接视图下的两条AC。

·     多段PW:在该场景下,需要在交叉连接视图下配置两条PW,以便将这两条PW串连起来。

表1-2 MPLS L2VPN配置任务简介

操作

说明

详细配置

开启L2VPN功能

必选

1.3 

配置AC

配置多段PW时,无需进行本配置

1.4 

配置交叉连接

必选

1.5 

配置PW

配置PW模板

可选

1.6.1 

配置静态PW

根据MPLS L2VPN的实现方式,选择相应的配置方法

配置本地交换时,无需进行本配置

1.6.2 

配置LDP PW

1.6.3 

配置BGP PW

1.6.4 

配置CCC远程连接

1.6.5 

配置AC与交叉连接关联

配置多段PW时,无需进行本配置

1.7 

配置PW冗余保护

可选

1.8 

配置异构网络互连

可选

1.9 

开启L2VPN告警功能

可选

1.10 

 

1.3  开启L2VPN功能

执行本配置前,需要先通过mpls lsr-id命令配置本节点的LSR ID,并在PE连接公网的接口上通过mpls enable命令使能该接口的MPLS能力。mpls lsr-id命令和mpls enable命令的详细介绍,请参见“MPLS命令参考”中的“MPLS基础”。

表1-3 开启L2VPN功能

操作

命令

说明

进入系统视图

system-view

-

开启L2VPN功能

l2vpn enable

缺省情况下,L2VPN功能处于关闭状态

 

1.4  配置AC

1.4.1  配置AC侧接口

AC侧接口指的是PE上连接CE的接口。配置MPLS L2VPN时,需要配置AC侧接口,以便在PE和CE之间建立二层链路。

由于PE从AC侧接口接收到的报文直接通过关联的PW转发,无需进行网络层处理,因此AC侧接口上不需要配置IP地址。

1. 封装类型为Ethernet或VLAN时的接口配置

AC侧接口为三层以太网接口(包括三层以太网接口、三层虚拟以太网接口、VE-L2VPN接口)时,PW数据封装类型和AC接入模式缺省均为Ethernet;AC侧接口为三层以太网子接口时,PW数据封装类型和AC接入模式缺省均为VLAN。

PW数据封装类型和AC接入模式决定了报文转发过程中PE对报文中VLAN Tag的处理方式。两端设备上配置的PW数据封装类型和AC接入模式需要匹配,以便正确处理报文中的VLAN Tag。

表1-4 封装类型为Ethernet或VLAN时的接口配置

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

(可选)配置缺省下一跳的IP地址或MAC地址

default-nexthop { ip ip-address | mac { mac-address | broadcast } }

MPLS L2VPN支持连接异构网络时,必选;其他情况下,无需执行本命令

缺省情况下,未指定缺省下一跳信息

 

2. 封装类型为PPP时的接口配置

表1-5 封装类型为PPP时的接口配置

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface { serial | pos } number

-

配置接口的链路协议类型

link-protocol ppp

缺省情况下,接口的链路协议类型为PPP

(可选)配置IPCP无地址协商

ppp ipcp ignore local-ip

MPLS L2VPN支持异构网络时,二者可选其一;其他情况下,无需执行本命令

缺省情况下,不支持IPCP无地址协商,未指定IPCP代理IP地址

(可选)指定IPCP代理IP地址

ppp ipcp proxy ip-address

 

3. 封装类型为HDLC时的接口配置

表1-6 封装类型为HDLC时的接口配置

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface { serial | pos } number

-

配置接口的链路协议类型

link-protocol hdlc

缺省情况下,接口的链路协议类型为PPP

 

1.5  配置交叉连接

表1-7 配置交叉连接

操作

命令

说明

进入系统视图

system-view

-

创建一个交叉连接组,并进入交叉连接组视图

xconnect-group group-name

缺省情况下,不存在交叉连接组

(可选)配置交叉连接组的描述信息

description text

缺省情况下,未配置交叉连接组的描述信息

(可选)开启当前的交叉连接组

undo shutdown

缺省情况下,交叉连接组处于开启状态

创建一个交叉连接,并进入交叉连接视图

connection connection-name

缺省情况下,不存在L2VPN交叉连接

配置PW的MTU值

mtu size

缺省情况下,PW的MTU值为1500字节

如果采用LDP信令协议建立PW,则要求PW两端的PE上为PW配置相同的MTU值。否则,PW无法up

 

1.6  配置PW

1.6.1  配置PW模板

在PW模板中可以指定PW的属性,如PW的数据封装类型、是否使用控制字等。具有相同属性的PW可以通过引用相同的PW模板,实现对PW属性的配置,从而简化配置。

表1-8 配置PW模板

操作

命令

说明

进入系统视图

system-view

-

创建PW模板,并进入PW模板视图

pw-class class-name

缺省情况下,不存在PW模板

(可选)开启控制字功能

control-word enable

缺省情况下,控制字功能处于关闭状态

(可选)PW数据封装类型

pw-type { ethernet | vlan }

缺省情况下,PW数据封装类型为VLAN

(可选)配置对PW上传送的报文进行排序处理

sequencing both

缺省情况下,PW上传送的报文不进行排序处理

 

1.6.2  配置静态PW

表1-9 配置静态PW

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

进入交叉连接视图

connection connection-name

-

配置静态PW,并进入交叉连接PW视图

peer ip-address pw-id pw-id in-label label-value out-label label-value [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

缺省情况下,不存在静态PW

配置PW的期望带宽

bandwidth bandwidth-value

缺省情况下,期望带宽为10000000kbps

 

1.6.3  配置LDP PW

在配置LDP PW之前,需要在PE上使能全局和接口的MPLS LDP能力,详细配置方法请参见“MPLS配置指导”中的“LDP”。

表1-10 配置LDP PW

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

进入交叉连接视图

connection connection-name

-

配置LDP PW,并进入交叉连接PW视图

peer ip-address pw-id pw-id [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

缺省情况下,不存在LDP PW

配置PW的期望带宽

bandwidth bandwidth-value

缺省情况下,PW的期望带宽为10000000kbps

 

说明

创建PW后,本端PE会自动使用Targeted hello来发现远端PE,以建立LDP会话,并在这个会话上交换PW ID FEC与PW标签的映射。

 

1.6.4  配置BGP PW

配置BGP PW时,需要在PE上进行以下配置:

·     配置BGP发布MPLS L2VPN标签块信息

·     建立BGP PW

1. 配置BGP发布MPLS L2VPN标签块信息

建立BGP PW时,需要在PE设备上进行BGP相关配置,以便PE通过BGP发布MPLS L2VPN的标签块信息。

下表中peer as-numberpeer enablepeer allow-as-looppeer reflect-clientreflect between-clientsreflector cluster-id命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

表1-11 配置BGP发布MPLS L2VPN标签块信息

操作

命令

说明

进入系统视图

system-view

-

启动BGP实例,并进入BGP实例视图

bgp as-number [ instance instance-name ]

缺省情况下,系统没有运行BGP

将远端PE配置为对等体

peer { group-name | ip-address [ mask-length ] } as-number as-number

缺省情况下,不存在BGP对等体

创建BGP L2VPN地址族,并进入BGP L2VPN地址族视图

address-family l2vpn

缺省情况下,不存在BGP L2VPN地址族

使能本地路由器与指定对等体/对等体组交换BGP L2VPN信息的能力

peer { group-name | ip-address [ mask-length ] } enable

缺省情况下,本地路由器不能与对等体/对等体组交换BGP L2VPN信息

开启本地路由器与指定对等体/对等体组交换MPLS L2VPN标签块信息的能力

peer { group-name | ip-address [ mask-length ] } signaling [ non-standard ]

缺省情况下,本地路由器具有与BGP L2VPN对等体/对等体组交换标签块信息的能力,并且采用RFC 4761中定义的MP_REACH_NLRI格式交换标签块信息

(可选)配置对于从对等体/对等体组接收的BGP消息,允许本地AS号在该消息的AS_PATH属性中出现,并配置允许出现的次数

peer { group-name | ip-address [ mask-length ] } allow-as-loop [ number ]

缺省情况下,不允许本地AS号在接收消息的AS_PATH属性中出现

(可选)开启BGP L2VPN信息的VPN-Target过滤功能

policy vpn-target

缺省情况下,BGP L2VPN信息的VPN-Target过滤功能处于开启状态

(可选)配置本机作为路由反射器,对等体/对等体组作为路由反射器的客户机

peer { group-name | ip-address [ mask-length ] } reflect-client

缺省情况下,没有配置路由反射器及其客户机

(可选)允许路由反射器在客户机之间反射L2VPN信息

reflect between-clients

缺省情况下,允许路由反射器在客户机之间反射L2VPN信息

(可选)配置路由反射器的集群ID

reflector cluster-id { cluster-id | ip-address }

缺省情况下,每个路由反射器都使用自己的Router ID作为集群ID

(可选)创建路由反射器的反射策略

rr-filter ext-comm-list-number

缺省情况下,路由反射器不会对反射的L2VPN信息进行过滤

(可选)返回用户视图

return

-

(可选)手工对L2VPN地址族下的BGP会话进行软复位

refresh bgp [ instance instance-name ] { ip-address [ mask-length ] | all | external | group group-name | internal } { export | import } l2vpn

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”

(可选)复位L2VPN地址族下的BGP会话

reset bgp [ instance instance-name ] { as-number | ip-address [ mask-length ] | all | external | group group-name | internal } l2vpn

本命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”

 

2. 建立BGP PW

表1-12 建立BGP PW

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

指定交叉连接组采用BGP方式自动发现邻居、建立PW,并进入交叉连接组自动发现视图

auto-discovery bgp

缺省情况下,交叉连接组不会采用BGP方式自动发现邻居并建立PW

为当前交叉连接组的BGP方式配置RD

route-distinguisher route-distinguisher

缺省情况下,未指定交叉连接组BGP方式的RD

为当前交叉连接组的BGP方式配置Route Target属性

vpn-target vpn-target&<1-8> [ both | export-extcommunity | import-extcommunity ]

缺省情况下,未指定交叉连接组BGP方式的Route Target属性

(可选)指定引用的PW模板

pw-class class-name

缺省情况下,未引用PW模板

(可选)配置PW的MTU值

mtu size

缺省情况下,PW的MTU值为1500字节

创建本地站点,并进入站点视图

site site-id [ range range-value ] [ default-offset defalut-offset ]

缺省情况下,不存在本地站点

创建交叉连接,并进入自动发现交叉连接视图

connection remote-site-id remote-site-id

缺省情况下,不存在交叉连接

执行本命令创建交叉连接后,将同时创建连接当前站点和指定远端站点的一条PW,该PW与该交叉连接关联

(可选)指定引用的隧道策略

tunnel-policy tunnel-policy-name

缺省情况下,未引用隧道策略

 

1.6.5  配置CCC远程连接

配置CCC远程连接时,需要在PE和P上分别进行如下配置:

·     在两端PE上分别通过ccc命令指定入标签和出标签等。

·     在PE之间的所有P设备上执行static-lsp transit命令为两个数据传输方向分别配置一条静态LSP,专门用于传输CCC远程连接的数据。static-lsp transit命令的详细介绍,请参见“MPLS命令参考”中的“静态LSP”。

创建CCC远程连接时,需要确保:

·     为某一台设备指定的出标签必须与为其下一跳指定的入标签相同。

·     两端PE上CCC远程连接的封装类型、控制字功能等配置保持一致,否则可能会导致报文转发失败。

表1-13 配置CCC远程连接

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

进入交叉连接视图

connection connection-name

-

创建一条CCC远程连接

ccc in-label in-label-value out-label out-label-value { nexthop nexthop | out-interface interface-type interface-number } [ pw-class class-name ]

缺省情况下,不存在CCC远程连接

只有出接口连接的链路是点到点链路时,才能够使用out-interface参数指定出接口。如果出接口连接的链路不是点到点链路,如出接口类型为三层以太网接口、VLAN接口或三层聚合接口,则必须使用nexthop参数指定下一跳IP地址

 

1.7  配置AC与交叉连接关联

提示

本配置与以太网链路聚合功能互斥。三层以太网接口加入聚合组后,不能再将该接口与交叉连接关联;反之亦然。

 

配置AC与交叉连接关联的方法与AC在PE上的表现形式有关:AC为三层接口时,需要配置AC侧三层接口与交叉连接关联。

配置AC与交叉连接关联时,可以指定AC与Track项联动。仅当关联的Track项中至少有一个状态为positive时,AC的状态才会up,否则,AC的状态为down。

在L2VPN接入L3VPN或IP骨干网组网中,由于VE-L2VPN接口为虚拟接口,链路故障时接口不会down。通过将AC与Track项关联,利用Track项监测PE-agg连接L3VPN或IP骨干网的链路状态,可以实现该链路故障时,将VE-L2VPN接口置为down状态,从而使得与AC关联的PW转变为down状态。如果在L2VPN网络中存在主备PW,则流量可以切换到备份PW。L2VPN接入L3VPN或IP骨干网的详细介绍,请参见“MPLS配置指导”中的“L2VPN接入L3VPN或IP骨干网”。

1.7.1  配置AC侧三层接口与交叉连接关联

配置AC侧三层接口与交叉连接关联后,从接口接收到的报文将通过关联该交叉连接的PW或另一条AC转发。

表1-14 配置AC侧三层接口与非BGP方式交叉连接关联

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

进入交叉连接视图

connection connection-name

-

将AC侧接口与交叉连接关联

ac interface interface-type interface-number [ track track-entry-number&<1-3> ]

缺省情况下,接口没有与交叉连接关联

 

表1-15 配置AC侧三层接口与BGP方式交叉连接关联

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

进入交叉连接组自动发现视图

auto-discovery bgp

-

进入站点视图

site site-id [ range range-value ] [ default-offset defalut-offset-value ]

-

进入自动发现交叉连接视图

connection remote-site-id remote-site-id

-

将AC侧接口与交叉连接关联

ac interface interface-type interface-number [ track track-entry-number&<1-3> ]

缺省情况下,接口没有与交叉连接关联

 

1.8  配置PW冗余保护

PW冗余保护的配置包括以下几部分:

·     为主PW创建备份PW。

·     配置PW冗余保护倒换的回切模式,即主PW恢复后,流量是否从备份PW回切到主PW;以及回切模式下的回切等待时间,即主PW恢复后,流量从备份PW回切到主PW的等待时间。

·     手工将指定PW的流量倒换到它的冗余备份PW上,以方便管理员对网络流量进行管理。

1.8.1  配置静态PW的冗余保护

表1-16 配置静态PW的冗余保护

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

 

进入交叉连接视图

connection connection-name

-

 

(可选)配置PW冗余保护倒换的回切模式,以及回切等待时间

revertive { wtr wtr-time | never }

缺省情况下,回切模式为可回切,回切等待时间为0

配置PW冗余保护的双收功能

protection dual-receive

缺省情况下,未配置PW冗余保护的双收功能,即配置PW冗余保护时,仅主PW能发送和接收报文,备份PW不能发送和接收报文

进入交叉连接PW视图

peer ip-address pw-id pw-id [ in-label label-value out-label label-value ] [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

-

配置备份的静态PW,并进入交叉连接备份PW视图

backup-peer ip-address pw-id pw-id in-label label-value out-label label-value [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

缺省情况下,不存在备份的静态PW

返回用户视图

return

-

将指定PW的流量手工倒换到它的冗余备份PW上

l2vpn switchover peer ip-address pw-id pw-id

-

 

1.8.2  配置LDP PW的冗余保护

表1-17 配置LDP PW的冗余保护

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

 

进入交叉连接视图

connection connection-name

-

 

(可选)配置PW冗余保护倒换的回切模式,以及回切等待时间

revertive { wtr wtr-time | never }

缺省情况下,回切模式为可回切,回切等待时间为0

配置PW冗余保护的双收功能

protection dual-receive

缺省情况下,未配置PW冗余保护的双收功能,即配置PW冗余保护时,仅主PW能发送和接收报文,备份PW不能发送和接收报文

进入交叉连接PW视图

peer ip-address pw-id pw-id [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

-

配置备份的LDP PW,并进入交叉连接备份PW视图

backup-peer ip-address pw-id pw-id [ pw-class class-name | tunnel-policy tunnel-policy-name ] *

缺省情况下,不存在备份的LDP PW

返回用户视图

return

-

将指定PW的流量手工倒换到它的冗余备份PW上

l2vpn switchover peer ip-address pw-id pw-id

-

 

1.9  配置异构网络互连

异构网络互连功能对链路层协议及PE配置具有如下要求:

(1)     CE接入PE的链路类型为Ethernet或VLAN时

·     PE和CE所在的以太网或VLAN网络内只能存在PE和CE两台三层设备。

·     PE连接CE的接口上需要通过default-nexthop命令配置缺省下一跳信息,以便PE正确地为发送给CE的报文封装链路层头。缺省下一跳信息为单播MAC地址(CE的MAC地址)或广播MAC地址时,PE发送给CE的报文将以该MAC地址作为目的MAC地址;缺省下一跳信息为IP地址(CE的IP地址)时,PE通过免费ARP将IP地址解析为MAC地址,解析到的MAC地址将作为PE发送给CE报文的目的MAC地址。

·     PE上使能交叉连接的异构互连功能后,对于CE发送的所有ARP请求,PE都会自动采用自己的MAC地址进行应答。因此,在PE上关闭交叉连接的异构互连功能时,需要通过reset arp命令清除CE上的ARP表项,以便CE能学到新的ARP表项,避免流量被错误地丢弃。

(2)     CE接入PE的链路类型为PPP时

PE连接CE的接口没有配置IP地址时,PE上需要配置ppp ipcp ignore local-ip,以支持IPCP无地址协商;或配置ppp ipcp proxy,以使用指定的IP地址与CE进行IPCP协商。如果PE连接CE的接口上配置了IP地址,则不需要配置ppp ipcp ignore local-ipppp ipcp proxy

表1-18 配置异构网络互连

操作

命令

说明

进入系统视图

system-view

-

进入交叉连接组视图

xconnect-group group-name

-

 

进入交叉连接视图

connection connection-name

-

 

开启交叉连接的异构互连功能

interworking ipv4

缺省情况下,交叉连接的异构互连功能处于关闭状态,即交叉连接不支持异构互连

 

1.10  开启L2VPN告警功能

开启L2VPN告警功能后,当PW的up-down状态发生变化、PW删除或主备PW切换时会产生告警信息。生成的告警信息将发送到设备的SNMP模块,通过设置SNMP中告警信息的发送参数,来决定告警信息输出的相关属性。

有关告警信息的详细介绍,请参见“网络管理和监控配置指导”中的“SNMP”。

表1-19 开启L2VPN告警功能

操作

命令

说明

进入系统视图

system-view

-

开启L2VPN告警功能

snmp-agent trap enable l2vpn [ pw-delete | pw-switch | pw-up-down ] *

缺省情况下,L2VPN告警功能处于关闭状态

 

1.11  MPLS L2VPN显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后MPLS L2VPN的运行情况,通过查看显示信息验证配置的效果。

在用户视图下,执行reset命令可以复位BGP会话。

display bgp group l2vpndisplay bgp peer l2vpndisplay bgp update-group l2vpnreset bgp l2vpn命令的详细介绍,请参见“三层技术-IP路由命令参考”中的“BGP”。

表1-20 MPLS L2VPN显示和维护

操作

命令

显示LDP协议通告的PW标签相关信息

display l2vpn ldp [ peer ip-address [ pw-id pw-id ] | xconnect-group group-name ] [ verbose ]

显示交叉连接的转发信息(独立运行模式)

display l2vpn forwarding { ac | pw } [ xconnect-group group-name ] [ slot slot-number ] [ verbose ]

显示交叉连接的转发信息(IRF模式)

display l2vpn forwarding { ac | pw } [ xconnect-group group-name ] [ chassis chassis-number slot slot-number ] [ verbose ]

显示与交叉连接关联的三层接口的L2VPN信息

display l2vpn interface [ xconnect-group group-name | interface-type interface-number ] [ verbose ]

显示L2VPN的PW信息

display l2vpn pw [ xconnect-group group-name ] [ protocol { bgp | ldp | static } ] [ verbose ]

显示PW模板的信息

display l2vpn pw-class [ class-name ]

显示交叉连接组的信息

display l2vpn xconnect-group [ name group-name ] [ verbose ]

显示MPLS L2VPN的标签块信息

display l2vpn bgp [ peer ip-address | local ] [ xconnect-group group-name ] [ verbose ]

显示BGP L2VPN对等体组的信息

display bgp [ instance instance-name ] group l2vpn [ group-name group-name ]

显示BGP协议的MPLS L2VPN标签块信息

display bgp [ instance instance-name ] l2vpn signaling [ peer ip-address { advertised | received } [ statistics ] | route-distinguisher route-distinguisher [ site-id site-id [ label-offset label-offset [ advertise-info ] ] ] | statistics ]

显示BGP L2VPN对等体的信息

display bgp [ instance instance-name ] peer l2vpn [ ip-address mask-length | group-name group-name log-info | ip-address { log-info | verbose } | verbose ]

显示BGP L2VPN地址族下打包组的相关信息

display bgp [ instance instance-name ] update-group l2vpn [ ip-address ]

复位L2VPN地址族下的BGP会话

reset bgp [ instance instance-name ] { as-number | ip-address [ mask-length ] | all | external | group group-name | internal } l2vpn

 

1.12  MPLS L2VPN典型配置举例

1.12.1  本地交换配置举例

1. 组网需求

用户网络有两个站点,站点CE分别为CE 1和CE 2,站点CE通过以太网接口接入PE。

通过在骨干网的PE上配置本地交换,实现站点1和站点2之间的互联。

2. 组网图

图1-9 本地交换配置组网图

 

 

3. 配置步骤

(1)     配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 2/1/1

[CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet2/1/1] quit

(3)     配置PE

# 开启L2VPN功能。

<PE> system-view

[PE] l2vpn enable

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为vpn1的交叉连接,并将接口GigabitEthernet2/1/1和接口GigabitEthernet2/1/2关联,用来实现报文在这两个站点之间的本地交换。

[PE] xconnect-group vpn1

[PE-xcg-vpn1] connection vpn1

[PE-xcg-vpn1-vpn1] ac interface gigabitethernet 2/1/1

[PE-xcg-vpn1-vpn1] ac interface gigabitethernet 2/1/2

[PE-xcg-vpn1-vpn1] quit

4. 验证配置

# 在PE上查看AC转发表项,可以看到两条AC表项。

[PE] display l2vpn forwarding ac

Total number of cross-connections: 1

Total number of ACs: 2

 

AC                               Xconnect-group Name             Link ID

GE2/1/1                          vpn1                            0

GE2/1/2                          vpn1                            1

# CE 1与CE 2之间能够ping通。

1.12.2  本地交换IP异构配置举例

1. 组网需求

用户网络有两个站点,站点CE分别为CE 1和CE 2。CE 1与PE之间通过以太网接口相连。CE 2与PE之间通过Serial接口相连,链路层封装PPP。

通过在骨干网的PE上配置本地交换和异构网络互连,实现CE 1的接口GigabitEthernet2/1/1与CE 2的接口Serial2/1/0本地异构互联。

2. 组网图

图1-10 本地交换IP异构配置组网图

 

 

3. 配置步骤

(1)     配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 10.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置CE 2

<CE2> system-view

[CE2] interface serial 2/1/0

[CE2-Serial2/1/0] link-protocol ppp

[CE2-Serial2/1/0] ip address 10.1.1.2 24

[CE2-Serial2/1/0] quit

(3)     配置PE

# 开启L2VPN功能。

<PE> system-view

[PE] l2vpn enable

# 在接入CE 1的接口GigabitEthernet2/1/1上配置缺省下一跳的IP地址为10.1.1.1。此接口不需配置IP地址。

[PE] interface gigabitethernet 2/1/1

[PE-GigabitEthernet2/1/1] default-nexthop ip 10.1.1.1

[PE-GigabitEthernet2/1/1] quit

# 在接入CE2的接口Serial2/1/0上配置IPCP代理IP地址为远端CE 1的IP地址。此接口不需配置IP地址。

[PE] interface serial 2/1/0

[PE-Serial2/1/0] link-protocol ppp

[PE-Serial2/1/0] ppp ipcp proxy 10.1.1.1

[PE-Serial2/1/0] quit

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为vpn1的交叉连接,使能该交叉连接的异构互连功能,并将接口GigabitEthernet2/1/1和接口Serial2/1/0关联,以实现报文在这两个接口之间的本地交换。

[PE] xconnect-group vpn1

[PE-xcg-vpn1] connection vpn1

[PE-xcg-vpn1-vpn1] interworking ipv4

[PE-xcg-vpn1-vpn1] ac interface gigabitethernet 2/1/1

[PE-xcg-vpn1-vpn1] ac interface serial 2/1/0

[PE-xcg-vpn1-vpn1] quit

[PE-xcg-vpn1] quit

4. 验证配置

# 在PE上查看AC转发表项,可以看到两条AC表项。

[PE] display l2vpn forwarding ac

Total number of cross-connections: 1

Total number of ACs: 2

 

AC                               Xconnect-group Name             Link ID

GE2/1/1                          vpn1                            0

Ser2/1/0                         vpn1                            1

# CE 1与CE 2之间能够ping通。

1.12.3  静态PW配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立静态PW,实现站点1与站点2互联,站点1和站点2通过以太网接口的方式接入PE。

2. 组网图

图1-11 静态PW配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE2/1/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

 

GE2/1/1

10.1.1.2/24

 

GE2/1/1

-

 

GE2/1/2

10.2.2.2/24

 

GE2/1/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

GE2/1/1

100.1.1.2/24

 

GE2/1/1

-

 

 

 

 

GE2/1/2

10.2.2.1/24

 

3. 配置步骤

(1)     配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE1] interface gigabitethernet 2/1/2

[PE1-GigabitEthernet2/1/2] ip address 10.1.1.1 24

[PE1-GigabitEthernet2/1/2] mpls enable

[PE1-GigabitEthernet2/1/2] mpls ldp enable

[PE1-GigabitEthernet2/1/2] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为svc的交叉连接,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建静态PW,以便将AC和PW关联。

[PE1] xconnect-group vpna

[PE1-xcg-vpna] connection svc

[PE1-xcg-vpna-svc] ac interface gigabitethernet 2/1/1

[PE1-xcg-vpna-svc] peer 192.3.3.3 pw-id 3 in-label 100 out-label 200

[PE1-xcg-vpna-svc-192.3.3.3-3] quit

[PE1-xcg-vpna-svc] quit

[PE1-xcg-vpna] quit

(3)     配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 全局使能LDP。

[P] mpls ldp

[P-ldp] quit

# 配置连接PE 1的接口GigabitEthernet2/1/1,在此接口上使能LDP。

[P] interface gigabitethernet 2/1/1

[P-GigabitEthernet2/1/1] ip address 10.1.1.2 24

[P-GigabitEthernet2/1/1] mpls enable

[P-GigabitEthernet2/1/1] mpls ldp enable

[P-GigabitEthernet2/1/1] quit

# 配置连接PE 2的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[P] interface gigabitethernet 2/1/2

[P-GigabitEthernet2/1/2] ip address 10.2.2.2 24

[P-GigabitEthernet2/1/2] mpls enable

[P-GigabitEthernet2/1/2] mpls ldp enable

[P-GigabitEthernet2/1/2] quit

# 在P上运行OSPF,用于建立LSP。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE2] interface gigabitethernet 2/1/2

[PE2-GigabitEthernet2/1/2] ip address 10.2.2.1 24

[PE2-GigabitEthernet2/1/2] mpls enable

[PE2-GigabitEthernet2/1/2] mpls ldp enable

[PE2-GigabitEthernet2/1/2] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.1 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为svc的交叉连接,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建静态PW,以便将AC和PW关联。

[PE2] xconnect-group vpna

[PE2-xcg-vpna] connection svc

[PE2-xcg-vpna-svc] ac interface gigabitethernet 2/1/1

[PE2-xcg-vpna-svc] peer 192.2.2.2 pw-id 3 in-label 200 out-label 100

[PE2-xcg-vpna-svc-192.2.2.2-3] quit

[PE2-xcg-vpna-svc] quit

[PE2-xcg-vpna] quit

(5)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 2/1/1

[CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet2/1/1] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条静态PW。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.3.3.3       3                 100/200         Static M     0          Up

# 在PE 2上也可以看到静态PW的信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.2.2.2       3                 200/100         Static M     0          Up

# CE 1与CE 2之间能够ping通。

1.12.4  LDP PW配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立LDP PW,实现站点1与站点2互联,站点1和站点2通过以太网接口的方式接入PE 1和PE 2。

2. 组网图

图1-12 LDP PW配置组网图

 

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE2/1/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

 

GE2/1/1

10.1.1.2/24

 

GE2/1/1

-

 

GE2/1/2

10.2.2.2/24

 

GE2/1/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

GE2/1/1

100.1.1.2/24

 

GE2/1/1

-

 

 

 

 

GE2/1/2

10.2.2.1/24

 

3. 配置步骤

(1)     配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE1] interface gigabitethernet 2/1/2

[PE1-GigabitEthernet2/1/2] ip address 10.1.1.1 24

[PE1-GigabitEthernet2/1/2] mpls enable

[PE1-GigabitEthernet2/1/2] mpls ldp enable

[PE1-GigabitEthernet2/1/2] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为ldp的交叉连接,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建LDP PW,以便将AC和PW关联。

[PE1] xconnect-group vpna

[PE1-xcg-vpna] connection ldp

[PE1-xcg-vpna-ldp] ac interface gigabitethernet 2/1/1

[PE1-xcg-vpna-ldp] peer 192.3.3.3 pw-id 3

[PE1-xcg-vpna-ldp-192.3.3.3-3] quit

[PE1-xcg-vpna-ldp] quit

[PE1-xcg-vpna] quit

(3)     配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 全局使能LDP。

[P] mpls ldp

[P-ldp] quit

# 配置连接PE 1的接口GigabitEthernet2/1/1,在此接口上使能LDP。

[P] interface gigabitethernet 2/1/1

[P-GigabitEthernet2/1/1] ip address 10.1.1.2 24

[P-GigabitEthernet2/1/1] mpls enable

[P-GigabitEthernet2/1/1] mpls ldp enable

[P-GigabitEthernet2/1/1] quit

# 配置连接PE 2的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[P] interface gigabitethernet 2/1/2

[P-GigabitEthernet2/1/2] ip address 10.2.2.2 24

[P-GigabitEthernet2/1/2] mpls enable

[P-GigabitEthernet2/1/2] mpls ldp enable

[P-GigabitEthernet2/1/2] quit

# 在P上运行OSPF,用于建立LSP。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE2] interface gigabitethernet 2/1/2

[PE2-GigabitEthernet2/1/2] ip address 10.2.2.1 24

[PE2-GigabitEthernet2/1/2] mpls enable

[PE2-GigabitEthernet2/1/2] mpls ldp enable

[PE2-GigabitEthernet2/1/2] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为ldp的交叉连接,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建LDP PW,以便将AC和PW关联。

[PE2] xconnect-group vpna

[PE2-xcg-vpna] connection ldp

[PE2-xcg-vpna-ldp] ac interface gigabitethernet 2/1/1

[PE2-xcg-vpna-ldp] peer 192.2.2.2 pw-id 3

[PE2-xcg-vpna-ldp-192.2.2.2-3] quit

[PE2-xcg-vpna-ldp] quit

[PE2-xcg-vpna] quit

(5)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 2/1/1

[CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet2/1/1] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条LDP PW。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.3.3.3       3                 1279/1279       LDP    M     1          Up

# 在PE 2上也可以看到LDP PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.2.2.2       3                 1279/1279       LDP    M     1          Up

# CE 1与CE 2之间能够ping通。

1.12.5  LDP方式IP异构连接配置举例

1. 组网需求

用户网络有若干个站点,CE 1与PE 1之间通过以太网接口相连。CE 2与PE 2之间通过Serial接口相连,链路层封装PPP。通过在骨干网上建立LDP PW,并配置异构网络互连,实现CE 1的接口GigabitEthernet2/1/1与CE 2的接口Serial2/1/0异构互联。

2. 组网图

图1-13 LDP方式IP异构配置组网图

 

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE2/1/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

 

GE2/1/1

10.1.1.2/24

 

GE2/1/1

-

 

GE2/1/2

10.2.2.2/24

 

GE2/1/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

Ser2/1/0

100.1.1.2/24

 

Ser2/1/0

-

 

 

 

 

GE2/1/1

10.2.2.1/24

 

3. 配置步骤

(1)     配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 在接入CE 1的接口GigabitEthernet2/1/1上配置缺省下一跳的IP地址为100.1.1.1。此接口不需配置IP地址。

[PE1] interface gigabitethernet 2/1/1

[PE1-GigabitEthernet2/1/1] default-nexthop ip 100.1.1.1

[PE1-GigabitEthernet2/1/1] quit

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE1] interface gigabitethernet 2/1/2

[PE1-GigabitEthernet2/1/2] ip address 10.1.1.1 24

[PE1-GigabitEthernet2/1/2] mpls enable

[PE1-GigabitEthernet2/1/2] mpls ldp enable

[PE1-GigabitEthernet2/1/2] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为ldp的交叉连接,使能该交叉连接的异构互连功能,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建LDP PW,以便将AC和PW关联。

[PE1] xconnect-group vpna

[PE1-xcg-vpna] connection ldp

[PE1-xcg-vpna-ldp] interworking ipv4

[PE1-xcg-vpna-ldp] ac interface gigabitethernet 2/1/1

[PE1-xcg-vpna-ldp] peer 192.3.3.3 pw-id 3

[PE1-xcg-vpna-ldp-192.3.3.3-3] quit

[PE1-xcg-vpna-ldp] quit

[PE1-xcg-vpna] quit

(3)     配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 全局使能LDP。

[P] mpls ldp

[P-ldp] quit

# 配置连接PE 1的接口GigabitEthernet2/1/1,在此接口上使能LDP。

[P] interface gigabitethernet 2/1/1

[P-GigabitEthernet2/1/1] ip address 10.1.1.2 24

[P-GigabitEthernet2/1/1] mpls enable

[P-GigabitEthernet2/1/1] mpls ldp enable

[P-GigabitEthernet2/1/1] quit

# 配置连接PE 2的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[P] interface gigabitethernet 2/1/2

[P-GigabitEthernet2/1/2] ip address 10.2.2.2 24

[P-GigabitEthernet2/1/2] mpls enable

[P-GigabitEthernet2/1/2] mpls ldp enable

[P-GigabitEthernet2/1/2] quit

# 在P上运行OSPF,用于建立LSP。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接P的接口GigabitEthernet2/1/1,在此接口上使能LDP。

[PE2] interface gigabitethernet 2/1/1

[PE2-GigabitEthernet2/1/1] ip address 10.2.2.1 24

[PE2-GigabitEthernet2/1/1] mpls enable

[PE2-GigabitEthernet2/1/1] mpls ldp enable

[PE2-GigabitEthernet2/1/1] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 在接入CE 2的接口Serial2/1/0上配置IPCP代理IP地址为远端CE 1的IP地址。此接口不需配置IP地址。

[PE2] interface serial 2/1/0

[PE2-Serial2/1/0] link-protocol ppp

[PE2-Serial2/1/0] ppp ipcp proxy 100.1.1.1

[PE2-Serial2/1/0] quit

# 创建交叉连接组vpna,在该交叉连接组内创建名称为ldp的交叉连接,使能该交叉连接的异构互连功能,将接口Serial2/1/0与此交叉连接关联,并在交叉连接内创建LDP PW,以便将AC和PW关联。

[PE2] xconnect-group vpna

[PE2-xcg-vpna] connection ldp

[PE2-xcg-vpna-ldp] interworking ipv4

[PE2-xcg-vpna-ldp] ac interface serial 2/1/0

[PE2-xcg-vpna-ldp] peer 192.2.2.2 pw-id 3

[PE2-xcg-vpna-ldp-192.2.2.2-3] quit

[PE2-xcg-vpna-ldp] quit

[PE2-xcg-vpna] quit

(5)     配置CE 2

<CE2> system-view

[CE2] interface serial 2/1/0

[CE2-Serial2/1/0] link-protocol ppp

[CE2-Serial2/1/0] ip address 100.1.1.2 24

[CE2-Serial2/1/0] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条LDP PW。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.3.3.3       3                 1279/1279       LDP    M     1          Up

# 在PE 2上也可以看到LDP PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpna

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.2.2.2       3                 1279/1279       LDP    M     1          Up

# CE 1与CE 2之间能够ping通。

1.12.6  BGP PW配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立BGP PW,实现站点1与站点2互联,站点1和站点2通过以太网接口的方式接入PE 1和PE 2。

2. 组网图

图1-14 BGP PW配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE2/1/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

GE2/1/1

10.1.1.2/24

GE2/1/1

-

GE2/1/2

10.2.2.2/24

GE2/1/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

GE2/1/1

100.1.1.2/24

GE2/1/1

-

GE2/1/2

10.2.2.1/24

 

3. 配置步骤

(1)     配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE1] interface gigabitethernet 2/1/2

[PE1-GigabitEthernet2/1/2] ip address 10.1.1.1 24

[PE1-GigabitEthernet2/1/2] mpls enable

[PE1-GigabitEthernet2/1/2] mpls ldp enable

[PE1-GigabitEthernet2/1/2] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在PE 1和PE 2之间建立IBGP连接,并配置在二者之间通过BGP发布L2VPN信息。

[PE1] bgp 100

[PE1-bgp-default] peer 192.3.3.3 as-number 100

[PE1-bgp-default] peer 192.3.3.3 connect-interface loopback 0

[PE1-bgp-default] address-family l2vpn

[PE1-bgp-default-l2vpn] peer 192.3.3.3 enable

[PE1-bgp-default-l2vpn] quit

[PE1-bgp-default] quit

# 创建交叉连接组vpnb,在该交叉连接组内创建本地站点1,在本地站点1和远端站点2之间建立BGP PW,并将接口GigabitEthernet2/1/1与此PW关联。

[PE1] xconnect-group vpnb

[PE1-xcg-vpnb] auto-discovery bgp

[PE1-xcg-vpnb-auto] route-distinguisher 2:2

[PE1-xcg-vpnb-auto] vpn-target 2:2 export-extcommunity

[PE1-xcg-vpnb-auto] vpn-target 2:2 import-extcommunity

[PE1-xcg-vpnb-auto] site 1 range 10 default-offset 0

[PE1-xcg-vpnb-auto-1] connection remote-site-id 2

[PE1-xcg-vpnb-auto-1-2] ac interface gigabitethernet 2/1/1

[PE1-xcg-vpnb-auto-1-2] return

(3)     配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 全局使能LDP。

[P] mpls ldp

[P-ldp] quit

# 配置连接PE 1的接口GigabitEthernet2/1/1,在此接口上使能LDP。

[P] interface gigabitethernet 2/1/1

[P-GigabitEthernet2/1/1] ip address 10.1.1.2 24

[P-GigabitEthernet2/1/1] mpls enable

[P-GigabitEthernet2/1/1] mpls ldp enable

[P-GigabitEthernet2/1/1] quit

# 配置连接PE 2的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[P] interface gigabitethernet 2/1/2

[P-GigabitEthernet2/1/2] ip address 10.2.2.2 24

[P-GigabitEthernet2/1/2] mpls enable

[P-GigabitEthernet2/1/2] mpls ldp enable

[P-GigabitEthernet2/1/2] quit

# 在P上运行OSPF,用于建立LSP。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE2] interface gigabitethernet 2/1/2

[PE2-GigabitEthernet2/1/2] ip address 10.2.2.1 24

[PE2-GigabitEthernet2/1/2] mpls enable

[PE2-GigabitEthernet2/1/2] mpls ldp enable

[PE2-GigabitEthernet2/1/2] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 在PE 1和PE 2之间建立IBGP连接,并配置在二者之间通过BGP发布L2VPN信息。

[PE2] bgp 100

[PE2-bgp-default] peer 192.2.2.2 as-number 100

[PE2-bgp-default] peer 192.2.2.2 connect-interface loopback 0

[PE2-bgp-default] address-family l2vpn

[PE2-bgp-default-l2vpn] peer 192.2.2.2 enable

[PE2-bgp-default-l2vpn] quit

[PE2-bgp-default] quit

# 创建交叉连接组vpnb,在该交叉连接组内创建本地站点2,在本地站点2和远端站点1之间建立BGP PW,并将接口GigabitEthernet2/1/1与此PW关联。

[PE2] xconnect-group vpnb

[PE2-xcg-vpnb] auto-discovery bgp

[PE2-xcg-vpnb-auto] route-distinguisher 2:2

[PE2-xcg-vpnb-auto] vpn-target 2:2 export-extcommunity

[PE2-xcg-vpnb-auto] vpn-target 2:2 import-extcommunity

[PE2-xcg-vpnb-auto] site 2 range 10 default-offset 0

[PE2-xcg-vpnb-auto-2] connection remote-site-id 1

[PE2-xcg-vpnb-auto-2-1] ac interface gigabitethernet 2/1/1

[PE2-xcg-vpnb-auto-2-1] return

(5)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 2/1/1

[CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet2/1/1] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条BGP PW。

<PE1> display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpnb

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

192.3.3.3       2                 1036/1025       BGP     M     1        Up

# 在PE 2上也可以看到PW信息。

<PE2> display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpnb

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

192.2.2.2       1                 1025/1036       BGP     M     1        Up

# CE 1与CE 2之间能够ping通。

1.12.7  CCC远程连接配置举例

1. 组网需求

用户网络有若干个站点,希望通过在骨干网上建立CCC远程连接,实现站点1与站点2互联,站点1和站点2通过以太网接口的方式接入PE 1和PE 2。

2. 组网图

图1-15 CCC远程连接配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE2/1/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

GE2/1/1

10.1.1.2/24

GE2/1/1

-

GE2/1/2

10.2.2.2/24

GE2/1/2

10.1.1.1/24

PE 2

Loop0

192.3.3.3/32

CE 2

GE2/1/1

100.1.1.2/24

GE2/1/1

-

GE2/1/2

10.2.2.1/24

 

3. 配置步骤

(1)      配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能MPLS。

[PE1] interface gigabitethernet 2/1/2

[PE1-GigabitEthernet2/1/2] ip address 10.1.1.1 24

[PE1-GigabitEthernet2/1/2] mpls enable

[PE1-GigabitEthernet2/1/2] quit

# 在PE 1上运行OSPF,用于发布路由。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 创建交叉连接组ccc,在该交叉连接组内创建CCC远程连接(入标签为101、出标签为201、下一跳地址为10.1.1.2),并将接口GigabitEthernet2/1/1与此CCC远程连接关联。

[PE1] xconnect-group ccc

[PE1-xcg-ccc] connection ccc

[PE1-xcg-ccc-ccc] ccc in-label 101 out-label 201 nexthop 10.1.1.2

[PE1-xcg-ccc-ccc] ac interface gigabitethernet 2/1/1

[PE1-xcg-ccc-ccc] quit

[PE1-xcg-ccc] quit

(3)     配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 配置连接PE 1的接口GigabitEthernet2/1/1,在此接口上使能MPLS。

[P] interface gigabitethernet 2/1/1

[P-GigabitEthernet2/1/1] ip address 10.1.1.2 24

[P-GigabitEthernet2/1/1] mpls enable

[P-GigabitEthernet2/1/1] quit

# 配置连接PE 2的接口GigabitEthernet2/1/2,在此接口上使能MPLS。

[P] interface gigabitethernet 2/1/2

[P-GigabitEthernet2/1/2] ip address 10.2.2.2 24

[P-GigabitEthernet2/1/2] mpls enable

[P-GigabitEthernet2/1/2] quit

# 配置一条静态LSP用于转发由PE 1去往PE 2的报文。

[P] static-lsp transit pe1-pe2 in-label 201 nexthop 10.2.2.1 out-label 202

# 配置另一条静态LSP用于转发由PE 2去往PE 1的报文。

[P] static-lsp transit pe2-pe1 in-label 102 nexthop 10.1.1.1 out-label 101

# 在P上运行OSPF,用于发布路由。

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.2.2 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

(4)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 配置连接P的接口GigabitEthernet2/1/2,在此接口上使能MPLS。

[PE2] interface gigabitethernet 2/1/2

[PE2-GigabitEthernet2/1/2] ip address 10.2.2.1 24

[PE2-GigabitEthernet2/1/2] mpls enable

[PE2-GigabitEthernet2/1/2] quit

# 在PE 2上运行OSPF,用于发布路由。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 创建交叉连接组ccc,在该交叉连接组内创建CCC远程连接(入标签为202、出标签为102、下一跳地址为10.2.2.2),并将接口GigabitEthernet2/1/1与此CCC远程连接关联。

[PE2] xconnect-group ccc

[PE2-xcg-ccc] connection ccc

[PE2-xcg-ccc-ccc] ccc in-label 202 out-label 102 nexthop 10.2.2.2

[PE2-xcg-ccc-ccc] ac interface gigabitethernet 2/1/1

[PE2-xcg-ccc-ccc] quit

[PE2-xcg-ccc] quit

(5)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 2/1/1

[CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet2/1/1] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到建立了一条PW连接。PW ID/Rmt Site字段为“-”,Protoc字段为“Static”,表示该PW连接为CCC远程连接。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: ccc

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

10.1.1.2        -                 101/201         Static  M     0        Up

# 在PE 2上也可以看到PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: ccc

Peer            PW ID/Rmt Site    In/Out Label    Proto   Flag  Link ID  State

10.2.2.2        -                 202/102         Static  M     0        Up

# CE 1与CE 2之间能够ping通。

1.12.8  域内多段PW配置举例

1. 组网需求

图1-16中,PE 1和P、P和PE 2之间分别建立了一条MPLS TE隧道,但是在PE 1和PE 2之间未建立MPLS TE隧道。通过配置域内多段PW:P与PE 1之间建立LDP PW、P与PE 2之间建立静态PW、在P上将两条PW关联,可以实现在PE 1和PE 2之间不存在公网隧道的情况下间接在PE 1和PE 2之间建立连接,确保CE 1和CE 2的二层报文跨越骨干网传送。

2. 组网图

图1-16 域内多段PW配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE2/1/1

100.1.1.1/24

P

Loop0

192.4.4.4/32

PE 1

Loop0

192.2.2.2/32

 

GE2/1/1

23.1.1.2/24

 

GE2/1/2

23.1.1.1/24

 

GE2/1/2

26.2.2.2/24

CE 2

GE2/1/1

100.1.1.2/24

PE 2

Loop0

192.3.3.3/32

 

 

 

 

GE2/1/2

26.2.2.1/24

 

3. 配置步骤

(1)     配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.2.2.2 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置MPLS TE,以便在PE 1和P之间建立MPLS TE隧道。详细配置过程,请参见“MPLS配置指导”中的“MPLS TE”。

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为ldp的交叉连接,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建LDP PW,以实现AC和PW关联。

[PE1] xconnect-group vpn1

[PE1-xcg-vpn1] connection ldp

[PE1-xcg-vpn1-ldp] ac interface gigabitethernet 2/1/1

[PE1-xcg-vpn1-ldp] peer 192.4.4.4 pw-id 1000

[PE1-xcg-vpn1-ldp-192.4.4.4-1000] quit

[PE1-xcg-vpn1-ldp] quit

[PE1-xcg-vpn1] quit

(3)     配置P

# 配置LSR ID。

<P> system-view

[P] interface loopback 0

[P-LoopBack0] ip address 192.4.4.4 32

[P-LoopBack0] quit

[P] mpls lsr-id 192.4.4.4

# 开启L2VPN功能。

[P] l2vpn enable

# 全局使能LDP。

[P] mpls ldp

[P-ldp] quit

# 创建PW模版,配置PW数据封装类型为Ethernet。

[P] pw-class pwa

[P-pw-pwa] pw-type ethernet

[P-pw-pwa] quit

# 配置MPLS TE,以便在PE 1和P、P和PE 2之间建立MPLS TE隧道。详细配置过程,请参见“MPLS配置指导”中的“MPLS TE”。

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为ldpsvc的交叉连接,在交叉连接内创建一条LDP PW和一条静态PW,将这两条PW关联,以便建立多段PW。

[P] xconnect-group vpn1

[P-xcg-vpn1] connection ldpsvc

[P-xcg-vpn1-ldpsvc] peer 192.2.2.2 pw-id 1000 pw-class pwa

[P-xcg-vpn1-ldpsvc-192.2.2.2-1000] quit

[P-xcg-vpn1-ldpsvc] peer 192.3.3.3 pw-id 1000 in-label 100 out-label 200 pw-class pwa

[P-xcg-vpn1-ldpsvc-192.3.3.3-1000] quit

[P-xcg-vpn1-ldpsvc] quit

[P-xcg-vpn1] quit

(4)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.3.3.3 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[PE2] l2vpn enable

# 配置MPLS TE,以便在P和PE 2之间建立MPLS TE隧道。详细配置过程,请参见“MPLS配置指导”中的“MPLS TE”。

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为svc的交叉连接,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建静态PW,以实现AC和PW关联。

[PE2] xconnect-group vpn1

[PE2-xcg-vpn1] connection svc

[PE2-xcg-vpn1-svc] ac interface gigabitethernet 2/1/1

[PE2-xcg-vpn1-svc] peer 192.4.4.4 pw-id 1000 in-label 200 out-label 100

[PE2-xcg-vpn1-svc-192.4.4.4-1000] quit

[PE2-xcg-vpn1-svc] quit

[PE2-xcg-vpn1] quit

(5)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 2/1/1

[CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet2/1/1] quit

4. 验证配置

# 在P上查看PW信息,可以看到建立了两条PW连接,构成了多段PW。

[P] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 2

2 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.2.2.2       1000              1279/1150       LDP    M     0          Up

192.3.3.3       1000       100/200         Static M     1          Up

# 在PE 1上也可以看到PW信息。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.4.4.4       1000              1150/1279       LDP    M     1          Up

# 在PE 2上也可以看到PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.4.4.4       1000              200/100         Static M     1          Up

# CE 1与CE 2之间能够ping通。

1.12.9  域间多段PW配置举例

1. 组网需求

PE 1和ASBR 1属于AS 100,PE 2和ASBR 2属于AS 200。采用多段PW功能作为跨域Option B的解决方案,跨越AS域在PE 1和PE 2之间建立连接,实现CE 1和CE 2的二层报文跨越骨干网传递。具体需求如下:

·     PE 1和ASBR 1、PE 2和ASBR 2之间分别建立LDP PW,并通过LDP建立承载该PW的公网隧道。

·     ASBR 1和ASBR 2之间建立LDP PW,并在二者之间通过BGP发布带标签的IPv4路由,以通过BGP建立承载该PW的公网隧道。

·     在ASBR 1和ASBR 2上分别将两条隧道关联,以便建立多段PW。

2. 组网图

图1-17 域间多段PW配置组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE2/1/1

100.1.1.1/24

ASBR 1

Loop0

192.2.2.2/32

PE 1

Loop0

192.1.1.1/32

 

GE2/1/2

23.1.1.2/24

 

GE2/1/2

23.1.1.1/24

 

GE2/1/1

26.2.2.2/24

PE 2

Loop0

192.4.4.4/32

ASBR 2

Loop0

192.3.3.3/32

 

GE2/1/2

22.2.2.1/24

 

GE2/1/1

26.2.2.3/24

CE 2

GE2/1/1

100.1.1.2/24

 

GE2/1/2

22.2.2.3/24

 

3. 配置步骤

(1)     配置CE 1

<CE1> system-view

[CE1] interface gigabitethernet 2/1/1

[CE1-GigabitEthernet2/1/1] ip address 100.1.1.1 24

[CE1-GigabitEthernet2/1/1] quit

(2)     配置PE 1

# 配置LSR ID。

<PE1> system-view

[PE1] interface loopback 0

[PE1-LoopBack0] ip address 192.1.1.1 32

[PE1-LoopBack0] quit

[PE1] mpls lsr-id 192.1.1.1

# 开启L2VPN功能。

[PE1] l2vpn enable

# 全局使能LDP。

[PE1] mpls ldp

[PE1-ldp] quit

# 配置连接ASBR1的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE1] interface gigabitethernet 2/1/2

[PE1-GigabitEthernet2/1/2] ip address 23.1.1.1 24

[PE1-GigabitEthernet2/1/2] mpls enable

[PE1-GigabitEthernet2/1/2] mpls ldp enable

[PE1-GigabitEthernet2/1/2] quit

# 在PE 1上运行OSPF,用于建立LSP。

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 23.1.1.1 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] network 192.1.1.1 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为ldp的交叉连接,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建LDP PW,以实现AC和PW关联。

[PE1] xconnect-group vpn1

[PE1-xcg-vpn1] connection ldp

[PE1-xcg-vpn1-ldp] ac interface gigabitethernet 2/1/1

[PE1-xcg-vpn1-ldp] peer 192.2.2.2 pw-id 1000

[PE1-xcg-vpn1-ldp-192.2.2.2-1000] quit

[PE1-xcg-vpn1-ldp] quit

[PE1-xcg-vpn1] quit

(3)     配置ASBR 1

# 配置LSR ID。

<ASBR1> system-view

[ASBR1] interface loopback 0

[ASBR1-LoopBack0] ip address 192.2.2.2 32

[ASBR1-LoopBack0] quit

[ASBR1] mpls lsr-id 192.2.2.2

# 开启L2VPN功能。

[ASBR1] l2vpn enable

# 全局使能LDP。

[ASBR1] mpls ldp

[ASBR1-ldp] quit

# 配置连接PE 1的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[ASBR1] interface gigabitethernet 2/1/2

[ASBR1-GigabitEthernet2/1/2] ip address 23.1.1.2 24

[ASBR1-GigabitEthernet2/1/2] mpls enable

[ASBR1-GigabitEthernet2/1/2] mpls ldp enable

[ASBR1-GigabitEthernet2/1/2] quit

# 配置连接ASBR 2的接口GigabitEthernet2/1/1,在此接口上使能MPLS。

[ASBR1] interface gigabitethernet 2/1/1

[ASBR1-GigabitEthernet2/1/1] ip address 26.2.2.2 24

[ASBR1-GigabitEthernet2/1/1] mpls enable

[ASBR1-GigabitEthernet2/1/1] quit

# 在ASBR 1上运行OSPF,用于建立域内LSP。

[ASBR1] ospf

[ASBR1-ospf-1] area 0

[ASBR1-ospf-1-area-0.0.0.0] network 23.1.1.2 0.0.0.255

[ASBR1-ospf-1-area-0.0.0.0] network 192.2.2.2 0.0.0.0

[ASBR1-ospf-1-area-0.0.0.0] quit

[ASBR1-ospf-1] quit

# 在ASBR 1上配置BGP发布带标签的单播路由。

[ASBR1] bgp 100

[ASBR1-bgp-default] peer 26.2.2.3 as-number 200

[ASBR1-bgp-default] address-family ipv4 unicast

[ASBR1-bgp-default-ipv4] import-route direct

[ASBR1-bgp-default-ipv4] peer 26.2.2.3 enable

[ASBR1-bgp-default-ipv4] peer 26.2.2.3 route-policy policy1 export

[ASBR1-bgp-default-ipv4] peer 26.2.2.3 label-route-capability

[ASBR1-bgp-default-ipv4] quit

[ASBR1-bgp-default] quit

[ASBR1] route-policy policy1 permit node 1

[ASBR1-route-policy-policy1-1] apply mpls-label

[ASBR1-route-policy-policy1-1] quit

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为ldp的交叉连接,在交叉连接内创建两条LDP PW,将这两条PW关联,以便建立多段PW。

[ASBR1] xconnect-group vpn1

[ASBR1-xcg-vpn1] connection ldp

[ASBR1-xcg-vpn1-ldp] peer 192.1.1.1 pw-id 1000

[ASBR1-xcg-vpn1-ldp-192.1.1.1-1000] quit

[ASBR1-xcg-vpn1-ldp] peer 192.3.3.3 pw-id 1000

[ASBR1-xcg-vpn1-ldp-192.3.3.3-1000] quit

[ASBR1-xcg-vpn1-ldp] quit

[ASBR1-xcg-vpn1] quit

(4)     配置ASBR 2

# 配置LSR ID。

<ASBR2> system-view

[ASBR2] interface loopback 0

[ASBR2-LoopBack0] ip address 192.3.3.3 32

[ASBR2-LoopBack0] quit

[ASBR2] mpls lsr-id 192.3.3.3

# 开启L2VPN功能。

[ASBR2] l2vpn enable

# 全局使能LDP。

[ASBR2] mpls ldp

[ASBR2-ldp] quit

# 配置连接PE 2的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[ASBR2] interface gigabitethernet 2/1/2

[ASBR2-GigabitEthernet2/1/2] ip address 22.2.2.3 24

[ASBR2-GigabitEthernet2/1/2] mpls enable

[ASBR2-GigabitEthernet2/1/2] mpls ldp enable

[ASBR2-GigabitEthernet2/1/2] quit

# 配置连接ASBR 1的接口GigabitEthernet2/1/1,在此接口上使能MPLS。

[ASBR2] interface gigabitethernet 2/1/1

[ASBR2-GigabitEthernet2/1/1] ip address 26.2.2.3 24

[ASBR2-GigabitEthernet2/1/1] mpls enable

[ASBR2-GigabitEthernet2/1/1] quit

# 在ASBR 2上运行OSPF,用于建立域内LSP。

[ASBR2] ospf

[ASBR2-ospf-1] area 0

[ASBR2-ospf-1-area-0.0.0.0] network 22.2.2.3 0.0.0.255

[ASBR2-ospf-1-area-0.0.0.0] network 192.3.3.3 0.0.0.0

[ASBR2-ospf-1-area-0.0.0.0] quit

[ASBR2-ospf-1] quit

# 在ASBR 2上配置BGP发布带标签的单播路由。

[ASBR2] bgp 200

[ASBR2-bgp-default] peer 26.2.2.2 as-number 100

[ASBR2-bgp-default] address-family ipv4 unicast

[ASBR2-bgp-default-ipv4] import-route direct

[ASBR2-bgp-default-ipv4] peer 26.2.2.2 enable

[ASBR2-bgp-default-ipv4] peer 26.2.2.2 route-policy policy1 export

[ASBR2-bgp-default-ipv4] peer 26.2.2.2 label-route-capability

[ASBR2-bgp-default-ipv4] quit

[ASBR2-bgp-default] quit

[ASBR2] route-policy policy1 permit node 1

[ASBR2-route-policy-policy1-1] apply mpls-label

[ASBR2-route-policy-policy1-1] quit

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为ldp的交叉连接,在交叉连接内创建两条LDP PW,将这两条PW关联,以便建立多段PW。

[ASBR2] xconnect-group vpn1

[ASBR2-xcg-vpn1] connection ldp

[ASBR2-xcg-vpn1-ldp] peer 192.2.2.2 pw-id 1000

[ASBR2-xcg-vpn1-ldp-192.2.2.2-1000] quit

[ASBR2-xcg-vpn1-ldp] peer 192.4.4.4 pw-id 1000

[ASBR2-xcg-vpn1-ldp-192.4.4.4-1000] quit

[ASBR2-xcg-vpn1-ldp] quit

[ASBR2-xcg-vpn1] quit

(5)     配置PE 2

# 配置LSR ID。

<PE2> system-view

[PE2] interface loopback 0

[PE2-LoopBack0] ip address 192.4.4.4 32

[PE2-LoopBack0] quit

[PE2] mpls lsr-id 192.4.4.4

# 开启L2VPN功能。

[PE2] l2vpn enable

# 全局使能LDP。

[PE2] mpls ldp

[PE2-ldp] quit

# 配置连接ASBR 2的接口GigabitEthernet2/1/2,在此接口上使能LDP。

[PE2] interface gigabitethernet 2/1/2

[PE2-GigabitEthernet2/1/2] ip address 22.2.2.1 24

[PE2-GigabitEthernet2/1/2] mpls enable

[PE2-GigabitEthernet2/1/2] mpls ldp enable

[PE2-GigabitEthernet2/1/2] quit

# 在PE 2上运行OSPF,用于建立LSP。

[PE2] ospf

[PE2-ospf-1] area 0

[PE2-ospf-1-area-0.0.0.0] network 192.4.4.4 0.0.0.0

[PE2-ospf-1-area-0.0.0.0] network 22.2.2.1 0.0.0.255

[PE2-ospf-1-area-0.0.0.0] quit

[PE2-ospf-1] quit

# 创建交叉连接组vpn1,在该交叉连接组内创建名称为ldp的交叉连接,将接口GigabitEthernet2/1/1与此交叉连接关联,并在交叉连接内创建LDP PW,以实现AC和PW关联。

[PE2] xconnect-group vpn1

[PE2-xcg-vpn1] connection ldp

[PE2-xcg-vpn1-ldp] ac interface gigabitethernet 2/1/1

[PE2-xcg-vpn1-ldp] peer 192.3.3.3 pw-id 1000

[PE2-xcg-vpn1-ldp-192.3.3.3-1000] quit

[PE2-xcg-vpn1-ldp] quit

[PE2-xcg-vpn1] quit

(6)     配置CE 2

<CE2> system-view

[CE2] interface gigabitethernet 2/1/1

[CE2-GigabitEthernet2/1/1] ip address 100.1.1.2 24

[CE2-GigabitEthernet2/1/1] quit

4. 验证配置

# 在PE 1上查看PW信息,可以看到已经建立了LDP PW。

[PE1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.2.2.2       1000              1151/1279       LDP    M     1          Up

# 在ASBR 1上查看PW信息,可以看到建立了两条PW连接,构成了多段PW。

[ASBR1] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 2

2 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.1.1.1       1000              1279/1151       LDP    M     0          Up

192.3.3.3       1000              1278/1151       LDP    M     1          Up

# 在ASBR 2上查看PW信息,可以看到建立了两条PW连接,构成了多段PW。

[ASBR2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 2

2 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.2.2.2       1000              1151/1278       LDP    M     0          Up

192.4.4.4       1000              1150/1279       LDP    M     1          Up

# 在PE 2上也可以看到PW信息。

[PE2] display l2vpn pw

Flags: M - main, B - backup, BY - bypass, H - hub link, S - spoke link, N - no split horizon

Total number of PWs: 1

1 up, 0 blocked, 0 down, 0 defect, 0 idle, 0 duplicate

 

Xconnect-group Name: vpn1

Peer            PW ID/Rmt Site    In/Out Label    Proto  Flag  Link ID    State

192.3.3.3       1000              1279/1150       LDP    M     1          Up

# CE 1与CE 2之间能够ping通。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!