选择区域语言: EN CN HK

04-二层技术-以太网交换配置指导

04-VLAN终结配置

本章节下载  (381.71 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/SR_Router/SR6600-X/Configure/Operation_Manual/H3C_SR6600_SR6600-X_CG-R7612-6W100/04/201709/1030175_30005_0.htm

04-VLAN终结配置


1 VLAN终结

1.1  VLAN终结简介

VLAN终结是指对接收到的报文,按照报文携带的VLAN Tag信息匹配对应的接口后,去除报文VLAN Tag,再将报文进行三层转发或交由其他业务处理。转发出去的报文是否带有VLAN Tag由出接口决定,对从配置了VLAN终结的接口发送的报文,按照该接口上的终结配置,将相应的VLAN Tag添加到报文中后发送该报文。

1.1.1  VLAN终结分类

根据对所终结的报文的不同处理方式,VLAN终结分为以下四种:

·     Dot1q终结:用来终结带有一层及以上VLAN Tag的报文(要求最外层VLAN ID必须匹配配置值),从配置了Dot1q终结的接口发送的报文,都添加一层VLAN Tag。

·     QinQ终结:用来终结带有两层及以上VLAN Tag的报文(要求最外两层VLAN ID必须匹配配置值),从配置了QinQ终结的接口发送的报文,都添加两层VLAN Tag。

·     Untagged终结:用来终结收到的不带VLAN Tag的报文,从配置了Untagged终结的接口发送的报文,都不添加VLAN Tag。

·     Default终结:用来终结同一主接口上其他子接口上无法处理的报文,从配置了Default终结的接口发送的报文,都不添加VLAN Tag。

说明

为便于描述,本特性部分内容对带有两层及以上VLAN Tag的报文,将其最外两层VLAN Tag按从外层到内层的方向,分别用第一层VLAN Tag、第二层VLAN Tag表示,对VLAN ID的描述类似。

 

1.1.2  VLAN终结应用场景

1. 指定VLAN间的互通

划分VLAN后,不同VLAN间的主机不能直接通信,使用三层路由技术可以实现所有VLAN间报文的互通。此时如果要对互通的VLAN范围做限制,即要求只有指定的部分VLAN间可以互通,可以借助VLAN终结功能来实现。目前可以通过子接口实现指定VLAN间的互通。

如下图所示,Host A属于VLAN 2,Host B属于VLAN 3,将Host A的网关地址指定为1.1.1.1/24,Host B的网关地址指定为1.1.2.1/24,就可以通过在三层以太网子接口GigabitEthernet2/1/1.1和GigabitEthernet2/1/2.1上配置VLAN终结来实现Host A和Host B之间的互通了。

图1-1 VLAN终结用于不同VLAN之间互通

 

2. 局域网和广域网的互联

局域网内的报文大多数都带有VLAN Tag,但一些广域网协议并不能识别VLAN报文,比如FR和PPP等,这种情况下,如果局域网的VLAN报文要转发到广域网,需要在本地记录并去掉报文的VLAN信息后再转发,可以借助VLAN终结功能来实现。目前可以通过子接口实现局域网和广域网的互联。

如下图所示,用户网络的私网VLAN为Customer VLAN,运营商为用户网络分配的公网VLAN为Service VLAN。当用户网内Customer VLAN的报文进入运营商网络时,报文外面就会被封装上Service VLAN的VLAN Tag。在运营商网基于Service VLAN进行转发。如果报文要发往外部WAN,则需要在出口网关(Device)上对该报文进行VLAN终结处理,去掉两层VLAN Tag,再通过同/异步串口Serial2/1/0发送到WAN。

图1-2 VLAN终结用于LAN和WAN的互联

1.2  VLAN终结配置限制和指导

·     如果要在开启了Portal认证功能的接口上更改VLAN终结方式(例如从Dot1q终结更改为QinQ终结),必须先把该接口的在线Portal用户全部下线,否则会导致这些在线Portal用户无法正常下线也无法重新认证上线。有关Portal的介绍,请参见“安全配置指导”中的“Portal”。

·     设备上存在FIP-680单板时,不支持VLAN 4094。

·     主接口本身不能对VLAN报文做终结处理,在主接口创建子接口后,由子接口来处理。

·     子接口(例如三层以太网子接口/三层聚合子接口)可以终结匹配最外层VLAN ID的报文或匹配最外两层VLAN ID的报文。

·     在三层以太网子接口/三层聚合子接口视图下修改已有的VLAN终结配置后,该子接口会down/up一次,设备ARP表中与该子接口相关的动态表项也会被全部删除。

·     配置VLAN终结后,设备对收到的报文按照如下优先级顺序匹配接口:

¡     配置QinQ终结的子接口

¡     配置带loose属性的QinQ终结的子接口

¡     配置Dot1q终结或者缺省支持Dot1q终结的子接口

¡     配置带loose属性的Dot1q终结的子接口

¡     配置Untagged终结的子接口

¡     配置Default终结的子接口

¡     主接口

需要注意的是:当主接口的某个子接口配置了Default终结时,报文只能由主接口下的子接口处理,而不会匹配到主接口。

1.3  VLAN终结配置任务简介

表1-1 VLAN终结配置任务简介

配置任务

说明

详细配置

配置Dot1q终结

配置明确的Dot1q终结

请根据设备的支持情况选择一种方式

1.4.1 

配置模糊的Dot1q终结

1.4.2 

配置QinQ终结

配置明确的QinQ终结

1.5.1 

配置模糊的QinQ终结

1.5.2 

配置Untagged终结

1.6 

配置Default终结

1.7 

配置VLAN终结支持广播/组播

可选

1.8 

配置VLAN Tag的TPID值

可选

1.9 

 

1.4  配置Dot1q终结

根据每个子接口所能终结的VLAN报文中最外层VLAN ID范围的不同,Dot1q终结分为:

·     明确的Dot1q终结:只允许接收最外层VLAN ID为指定值的VLAN报文,其他VLAN报文则不允许通过该子接口。收到报文后,将报文最外层VLAN Tag剥离。发送报文时,给报文添加一层VLAN Tag,VLAN ID为指定值。

·     模糊的Dot1q终结:只允许接收最外层VLAN ID在指定范围内的VLAN报文,不属于该范围的VLAN报文则不允许通过该子接口。收到报文后,将报文最外层VLAN Tag剥离。发送报文时,会给报文添加一层VLAN Tag,VLAN ID字段取值为:对于PPPoE报文,通过查找PPPoE会话表项获取相应的VLAN ID;对于DHCP Relay转发的DHCP Server端报文,通过查找DHCP会话表项获取相应的VLAN ID;对于MPLS和其他IPv4报文,通过查找ARP表项获取相应的VLAN ID。

1.4.1  配置明确的Dot1q终结

表1-2 配置明确的Dot1q终结

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

·     三层以太网子接口视图:
interface
interface-type interface-number.subnumber

·     三层聚合子接口视图:
interface route-aggregation
interface-number.subnumber

·     L2VE子接口视图:
interface ve-l2vpn
interface-number.subnumber

·     L3VE子接口视图:
interface ve-l3vpn
interface-number.subnumber

-

开启当前接口的Dot1q终结功能,并指定当前子接口能够终结的VLAN报文最外层VLAN ID

vlan-type dot1q vid vlan-id [ loose ]

缺省情况下,未开启当前接口的Dot1q终结功能

 

1.4.2  配置模糊的Dot1q终结

表1-3 配置模糊的Dot1q终结

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

·     三层以太网子接口视图:
interface
interface-type interface-number.subnumber

·     三层聚合子接口视图:
interface route-aggregation
interface-number.subnumber

·     L2VE子接口视图:
interface ve-l2vpn
interface-number.subnumber

·     L3VE子接口视图:
interface ve-l3vpn
interface-number.subnumber

-

开启当前接口的Dot1q终结功能,并指定当前子接口能够终结的VLAN报文的最外层VLAN ID范围

vlan-type dot1q vid vlan-id-list [ loose ]

缺省情况下,未开启当前接口的Dot1q终结功能

 

1.5  配置QinQ终结

根据每个接口所能终结的VLAN报文的最外两层VLAN ID范围的不同,QinQ终结分为:

·     明确的QinQ终结:只允许接收最外两层VLAN ID均为指定值的报文,其他VLAN报文则不允许通过该接口。收到报文后,将报文最外两层VLAN Tag剥离。发送报文时,会给报文添加两层VLAN Tag,两层VLAN ID均为指定值。

·     模糊的QinQ终结:只允许接收最外两层VLAN ID均在指定范围内的报文,不属于该范围的VLAN报文则不允许通过该接口。收到报文后,将报文最外两层VLAN Tag剥离。发送报文时,会给报文添加两层VLAN Tag。添加VLAN Tag后,报文的最外两层VLAN ID取值为:对于PPPoE报文,通过查找PPPoE会话表项获取相应的VLAN ID;对于DHCP Relay转发的DHCP Server端报文,通过查找DHCP中继用户地址表项获取相应的VLAN ID;对于MPLS和其他IPv4报文,通过查找ARP表项获取相应的VLAN ID。

1.5.1  配置明确的QinQ终结

表1-4 配置明确的QinQ终结

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

·     三层以太网子接口视图:
interface
interface-type interface-number.subnumber

·     三层聚合子接口视图:
interface route-aggregation
interface-number.subnumber

·     L3VE子接口视图:
interface ve-l3vpn
interface-number.subnumber

-

开启当前接口的QinQ终结功能,并指定当前接口可以终结的VLAN报文的最外两层VLAN ID

vlan-type dot1q vid vlan-id second-dot1q vlan-id [ loose ]

缺省情况下,未开启当前接口的QinQ终结功能

 

1.5.2  配置模糊的QinQ终结

配置模糊的QinQ终结时,需要注意:

·     在同一主接口的不同子接口下配置QinQ终结功能时,如果指定的第一层VLAN ID相同,则第二层VLAN ID必须不同;如果指定的第一层VLAN ID不同,则第二层VLAN ID可以相同。

·     不同主接口下的子接口可以终结的VLAN报文可以相同也可以不同。

·     在同一子接口下多次执行vlan-type dot1q vid second-dot1q命令时,如果新配置中的第一层VLAN ID和当前生效配置中的第一层VLAN ID相等,则最终生效的第二层VLAN ID是多次配置的集合;如果新配置中的第一层VLAN ID和当前生效配置中的第一层VLAN ID不相等,则必须先删除旧的配置才能执行新的配置。

表1-5 配置模糊的QinQ终结

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

·     三层以太网子接口视图:
interface
interface-type interface-number.subnumber

·     三层聚合子接口视图:
interface route-aggregation
interface-number.subnumber

·     L3VE子接口视图:
interface ve-l3vpn
interface-number.subnumber

-

开启当前接口的QinQ终结功能,并指定当前接口可以终结的VLAN报文的最外两层VLAN ID

vlan-type dot1q vid vlan-id-list second-dot1q { vlan-id-list | any } [ loose ]

缺省情况下,未开启当前接口的QinQ终结功能

 

1.6  配置Untagged终结

表1-6 配置Untagged终结

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

·     三层以太网子接口视图:
interface
interface-type interface-number.subnumber

·     三层聚合子接口视图:
interface route-aggregation
interface-number.subnumber

·     L3VE子接口视图:
interface ve-l3vpn
interface-number.subnumber

-

开启当前接口的Untagged终结功能,使当前接口可以处理不带VLAN Tag的报文

vlan-type dot1q untagged

缺省情况下,未开启当前接口的Untagged终结功能

 

1.7  配置Default终结

表1-7 配置Default终结

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

·     三层以太网子接口视图:
interface
interface-type interface-number.subnumber

·     三层聚合子接口视图:
interface route-aggregation
interface-number.subnumber

·     L3VE子接口视图:
interface ve-l3vpn
interface-number.subnumber

-

开启当前接口的Default终结功能,使当前接口可以处理其他子接口都无法处理的报文

vlan-type dot1q default

缺省情况下,未开启当前接口的Default终结功能

 

1.8  配置VLAN终结支持广播/组播

当接口下配置了模糊的Dot1q终结或者模糊的QinQ终结功能后,不允许发送广播、组播报文。只有配置了VLAN终结支持广播/组播功能,这些接口才能发送广播/组播报文。

IPv6网络中,当接口下配置了模糊的Dot1q终结或者模糊的QinQ终结功能后,建议配置vlan-termination broadcast ra命令,以允许接口遍历模糊终结的范围发送RA(Router Advertisement,路由器通告消息)组播报文,其他类型的广播/组播报文则不允许发送。该命令与vlan-termination broadcast enable命令相比,能有效减少设备CPU负担。

表1-8 配置VLAN终结支持广播/组播

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

·     三层以太网子接口视图:
interface
interface-type interface-number.subnumber

·     三层聚合子接口视图:
interface route-aggregation
interface-number.subnumber

·     L3VE子接口视图:
interface ve-l3vpn
interface-number.subnumber

-

配置允许当前接口发送广播/组播报文

·     允许接口发送广播和组播报文
vlan-termination broadcast enable

·     允许接口发送RA组播报文(IPv6环境)
vlan-termination broadcast ra

二者选其一

缺省情况下,当前接口配置了模糊的Dot1q终结或者模糊的QinQ终结功能后,不允许发送广播、组播报文

 

1.9  配置VLAN Tag的TPID值

在子接口上使用VLAN终结功能时,可以通过以下配置指定接口接收和发送报文的最外层VLAN Tag的TPID值。在配置TPID值后,当接收报文时,只有报文最外层VLAN Tag的TPID值为0x8100或者指定值的报文才会作为VLAN报文来处理;发送报文时,会给报文最外层VLAN Tag的TPID值填入指定值,如果报文带有两层及以上VLAN Tag,则给报文其他层VLAN Tag的TPID值都填入0x8100。

表1-9 配置VLAN Tag的TPID值

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

·     三层以太网接口视图:
interface
interface-type interface-number

·     三层聚合接口视图:
interface route-aggregation
interface-number

·     L3VE接口视图:
interface ve-l3vpn
interface-number.subnumber

在三层以太网接口、三层聚合接口或L3VE视图下配置,会对相应接口的所有子接口生效

配置当前接口接收和发送的报文最外层VLAN Tag的TPID值

dot1q ethernet-type hex-value

缺省情况下,当前接口接收和发送的报文最外层VLAN Tag的TPID值均为0x8100

 

1.10  VLAN终结配置举例

1.10.1  明确的Dot1q终结配置举例

1. 组网需求

如下图所示,Host A、Host B和Switch A相连,Host C、Host D和Switch B相连。Host A和Host C属于VLAN 10,Host B和Host D属于VLAN 20。Device子接口GigabitEthernet2/1/1.10、GigabitEthernet2/1/1.20、GigabitEthernet2/1/2.10、GigabitEthernet2/1/2.20的IP地址分别为1.0.0.1/8、2.0.0.1/8、3.0.0.1/8和4.0.0.1/8。要求实现:

·     Host A和Host B之间、Host C和Host D之间能够互相通信,即同一交换机、不同VLAN之间能够互相通信;

·     Host A和Host C之间、Host B和Host D之间能够互相通信,即不同交换机、同一VLAN之间能够互相通信;

·     Host A和Host D之间、Host B和Host C之间能够互相通信,即不同交换机、不同VLAN之间能够互相通信。

2. 组网图

图1-3 明确的Dot1q终结配置组网图

 

3. 配置步骤

(1)     Host A、Host B、Host C、Host D的配置

将Host A的IP地址指定为1.1.1.1/8,网关地址指定为1.0.0.1/8。

将Host B的IP地址指定为2.2.2.2/8,网关地址指定为2.0.0.1/8。

将Host C的IP地址指定为3.3.3.3/8,网关地址指定为3.0.0.1/8。

将Host D的IP地址指定为4.4.4.4/8,网关地址指定为4.0.0.1/8。

(2)     L2 Switch A、L2 Switch B的配置

下面以L2 Switch A的配置步骤为例,L2 Switch B的配置与L2 Switch A的配置相同,不再赘述。

# 向VLAN 10中加入端口GigabitEthernet2/1/2。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 10

[L2_SwitchA-vlan10] port gigabitethernet 2/1/2

[L2_SwitchA-vlan10] quit

# 向VLAN 20中加入端口GigabitEthernet2/1/3。

[L2_SwitchA] vlan 20

[L2_SwitchA-vlan20] port gigabitethernet 2/1/3

[L2_SwitchA-vlan20] quit

# 配置端口GigabitEthernet2/1/1的链路类型为Trunk类型,并允许VLAN 10和VLAN 20通过。

[L2_SwitchA] interface gigabitethernet 2/1/1

[L2_SwitchA-GigabitEthernet2/1/1] port link-type trunk

[L2_SwitchA-GigabitEthernet2/1/1] port trunk permit vlan 10 20

(3)     Device的配置

# 创建以太网子接口GigabitEthernet2/1/1.10、GigabitEthernet2/1/1.20、GigabitEthernet2/1/2.10和GigabitEthernet2/1/2.20,分别为其配置IP地址,配置GigabitEthernet2/1/1.10和GigabitEthernet2/1/2.10用来终结VLAN 10的报文,配置GigabitEthernet2/1/1.20和GigabitEthernet2/1/2.20用来终结VLAN 20的报文。

<Device> system-view

[Device] interface gigabitethernet 2/1/1.10

[Device-GigabitEthernet2/1/1.10] ip address 1.0.0.1 255.0.0.0

[Device-GigabitEthernet2/1/1.10] vlan-type dot1q vid 10

[Device-GigabitEthernet2/1/1.10] quit

[Device] interface gigabitethernet 2/1/1.20

[Device-GigabitEthernet2/1/1.20] ip address 2.0.0.1 255.0.0.0

[Device-GigabitEthernet2/1/1.20] vlan-type dot1q vid 20

[Device-GigabitEthernet2/1/1.20] quit

[Device] interface gigabitethernet 2/1/2.10

[Device-GigabitEthernet2/1/2.10] ip address 3.0.0.1 255.0.0.0

[Device-GigabitEthernet2/1/2.10] vlan-type dot1q vid 10

[Device-GigabitEthernet2/1/2.10] quit

[Device] interface gigabitethernet 2/1/2.20

[Device-GigabitEthernet2/1/2.20] ip address 4.0.0.1 255.0.0.0

[Device-GigabitEthernet2/1/2.20] vlan-type dot1q vid 20

[Device-GigabitEthernet2/1/2.20] quit

4. 验证配置

配置完成后,Host A、Host B、Host C、Host D可以相互ping通。

1.10.2  模糊的Dot1q终结配置举例

1. 组网需求

如下图所示,Host A、Host B、Host C和Switch A相连,Server group和Switch B相连。Host A、Host B、Host C分别属于VLAN 11、VLAN 12、VLAN 13;这些Host需要与Server group互相通信。

2. 组网图

图1-4 模糊的Dot1q终结配置组网图

 

3. 配置步骤

(1)     Host A、Host B、Host C的配置

将Host A的IP地址指定为1.1.1.1/24,Host B的IP地址为1.1.1.2/24,Host C的IP地址为1.1.1.3/24,网关地址均指定为1.1.1.11/24。

(2)     L2 Switch A的配置

# 向VLAN 11中加入端口GigabitEthernet2/1/1。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 11

[L2_SwitchA-vlan11] port gigabitethernet 2/1/1

[L2_SwitchA-vlan11] quit

# 向VLAN 12中加入端口GigabitEthernet2/1/2。

[L2_SwitchA] vlan 12

[L2_SwitchA-vlan12] port gigabitethernet 2/1/2

[L2_SwitchA-vlan12] quit

# 向VLAN 13中加入端口GigabitEthernet2/1/3。

[L2_SwitchA] vlan 13

[L2_SwitchA-vlan13] port gigabitethernet 2/1/3

[L2_SwitchA-vlan13] quit

# 配置端口GigabitEthernet2/1/7的链路类型为Trunk类型,并允许VLAN 11~13通过。

[L2_SwitchA] interface gigabitethernet 2/1/7

[L2_SwitchA-GigabitEthernet2/1/7] port link-type trunk

[L2_SwitchA-GigabitEthernet2/1/7] port trunk permit vlan 11 to 13

(3)     Device的配置

# 创建以太网子接口GigabitEthernet2/1/1.10,为其配置IP地址,开启Dot1q终结功能,指定终结最外层VLAN ID在范围11~13内的报文,并允许该子接口发送广播、组播报文。

<Device> system-view

[Device] interface gigabitethernet 2/1/1.10

[Device-GigabitEthernet2/1/1.10] ip address 1.1.1.11 255.255.255.0

[Device-GigabitEthernet2/1/1.10] vlan-type dot1q vid 11 to 13

[Device-GigabitEthernet2/1/1.10] vlan-termination broadcast enable

[Device-GigabitEthernet2/1/1.10] quit

# 配置以太网接口GigabitEthernet2/1/2的 IP地址。

[Device] interface gigabitethernet 2/1/2

[Device-GigabitEthernet2/1/2] ip address 1.1.2.11 255.255.255.0

(4)     L2 Switch B的配置

L2 Switch B采用出厂配置即可。

(5)     Server group的配置

将Server group里所有设备的IP地址配置在1.1.2.0/24网段,网关地址指定为1.1.2.11/24即可。

4. 验证配置

配置完成后, Host A、Host B、Host C可以与Server group相互ping通。

1.10.3  Dot1q终结支持PPPoE Server配置举例

1. 组网需求

如下图所示,Host A、Host B、Host C和Switch 相连,分别属于VLAN 11、VLAN 12、VLAN 13,这些Host需要使用拨号方式访问Internet。

2. 组网图

图1-5 Dot1q终结支持PPPoE Server配置组网图

 

3. 配置步骤

关于VLAN和Dot1q终结的配置步骤请参见“1.10.2  模糊的Dot1q终结配置举例”,另外Router作为网络中的PPPoE server,需要在GigabitEthernet2/1/1.10上进行PPPoE相关参数的配置,详情请参见“二层技术-广域网接入配置指导”中的“PPPoE”。

1.10.4  明确的QinQ终结配置举例

1. 组网需求

如下图所示,Host A和L2 Switch A相连,属于VLAN 11;Host B和L2 Switch C相连,L2 Switch C只支持一层VLAN标签;L2 Switch B上开启了QinQ功能,它会给收到的内层VLAN ID为11的报文外面添加一层VLAN ID为100的VLAN Tag后再转发出去。现需要实现Host A与Host B之间能够互相通信。

2. 组网图

图1-6 明确的QinQ终结配置组网图

 

3. 配置步骤

(1)     Host A、Host B的配置

将Host A的IP地址指定为1.1.1.1/24,网关地址指定为1.1.1.11/24;Host B的IP地址为1.1.2.1/24,网关地址指定为1.1.2.11/24。

(2)     L2 Switch A的配置

# 向VLAN 11中加入端口GigabitEthernet2/1/2。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 11

[L2_SwitchA-vlan11] port gigabitethernet 2/1/2

[L2_SwitchA-vlan11] quit

# 配置端口GigabitEthernet2/1/1的链路类型为Trunk类型,并允许VLAN 11通过。

[L2_SwitchA] interface gigabitethernet 2/1/1

[L2_SwitchA-GigabitEthernet2/1/1] port link-type trunk

[L2_SwitchA-GigabitEthernet2/1/1] port trunk permit vlan 11

(3)     L2 Switch B的配置

# 配置端口GigabitEthernet2/1/2的链路类型为Trunk类型,并允许VLAN 11、VLAN 100通过。

<L2_SwitchB> system-view

[L2_SwitchB] interface gigabitethernet 2/1/2

[L2_SwitchB-GigabitEthernet2/1/2] port link-type trunk

[L2_SwitchB-GigabitEthernet2/1/2] port trunk permit vlan 11 100

# 配置端口GigabitEthernet2/1/2的缺省VLAN为VLAN 100。

[L2_SwitchB-GigabitEthernet2/1/2] port trunk pvid vlan 100

# 在端口GigabitEthernet2/1/2上开启QinQ功能。

[L2_SwitchB-GigabitEthernet2/1/2] qinq enable

[L2_SwitchB-GigabitEthernet2/1/2] quit

# 配置端口GigabitEthernet2/1/1的链路类型为Trunk类型,并允许VLAN 100通过。

[L2_SwitchB] interface gigabitethernet 2/1/1

[L2_SwitchB-GigabitEthernet2/1/1] port link-type trunk

[L2_SwitchB-GigabitEthernet2/1/1] port trunk permit vlan 100

(4)     Router的配置

# 创建并进入以太网子接口GigabitEthernet2/1/1.10,为其配置IP地址,开启QinQ终结功能,并指明当前接口可以终结的VLAN报文的最外两层VLAN ID。

<Router> system-view

[Router] interface gigabitethernet 2/1/1.10

[Router-GigabitEthernet2/1/1.10] ip address 1.1.1.11 255.255.255.0

[Router-GigabitEthernet2/1/1.10] vlan-type dot1q vid 100 second-dot1q 11

[Router-GigabitEthernet2/1/1.10] quit

# 配置端口GigabitEthernet2/1/2的IP地址。

[Router] interface gigabitethernet 2/1/2

[Router-GigabitEthernet2/1/2] ip address 1.1.2.11 255.255.255.0

(5)     L2 Switch C的配置

L2 Switch C用出厂配置即可。

4. 验证配置

配置完成后,Host A、Host B可以相互ping通。

1.10.5  模糊的QinQ终结配置举例

1. 组网需求

如下图所示,Host A、Host B、Host C和L2 Switch A相连,分别属于VLAN 11、VLAN 12和VLAN 13;Server群和L2 Switch C相连;L2 Switch B上开启了QinQ功能。Host A、Host B、Host C需要与Server群互相通信。

2. 组网图

图1-7 模糊的QinQ终结配置组网图

 

3. 配置步骤

(1)     Host A、Host B、Host C的配置

将Host A的IP地址指定为1.1.1.1/24,Host B的IP地址为1.1.1.2/24,Host C的IP地址为1.1.1.3/24,网关地址均指定为1.1.1.11/24。

(2)     L2 Switch A的配置

# 向VLAN 11中加入端口GigabitEthernet2/1/1。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 11

[L2_SwitchA-vlan11] port gigabitethernet 2/1/1

[L2_SwitchA-vlan11] quit

# 向VLAN 12中加入端口GigabitEthernet2/1/2。

[L2_SwitchA] vlan 12

[L2_SwitchA-vlan12] port gigabitethernet 2/1/2

[L2_SwitchA-vlan12] quit

# 向VLAN 13中加入端口GigabitEthernet2/1/3。

[L2_SwitchA] vlan 13

[L2_SwitchA-vlan13] port gigabitethernet 2/1/3

[L2_SwitchA-vlan13] quit

# 配置端口GigabitEthernet2/1/7的链路类型为Trunk类型,并允许VLAN 11~13通过。

[L2_SwitchA] interface gigabitethernet 2/1/7

[L2_SwitchA-GigabitEthernet2/1/7] port link-type trunk

[L2_SwitchA-GigabitEthernet2/1/7] port trunk permit vlan 11 to 13

(3)     L2 Switch B的配置

# 配置端口GigabitEthernet2/1/2的链路类型为Trunk类型,并允许VLAN 11~13、100通过。

<L2_SwitchB> system-view

[L2_SwitchB] interface gigabitethernet 2/1/2

[L2_SwitchB-GigabitEthernet2/1/2] port link-type trunk

[L2_SwitchB-GigabitEthernet2/1/2] port trunk permit vlan 11 to 13 100

# 配置端口GigabitEthernet2/1/2的缺省VLAN为VLAN 100。

[L2_SwitchB-GigabitEthernet2/1/2] port trunk pvid vlan 100

# 在端口GigabitEthernet2/1/2上开启QinQ功能。

[L2_SwitchB-GigabitEthernet2/1/2] qinq enable

[L2_SwitchB-GigabitEthernet2/1/2] quit

# 配置端口GigabitEthernet2/1/1的链路类型为Trunk类型,并允许VLAN 100通过。

[L2_SwitchB] interface gigabitethernet 2/1/1

[L2_SwitchB-GigabitEthernet2/1/1] port link-type trunk

[L2_SwitchB-GigabitEthernet2/1/1] port trunk permit vlan 100

(4)     Router的配置

# 创建以太网子接口GigabitEthernet2/1/1.10,为其配置IP地址,当收到第一层VLAN ID为100,第二层VLAN ID为11、12或13的QinQ报文时,对该报文进行VLAN终结处理。并配置允许该子接口发送广播、组播报文。

<Router> system-view

[Router] interface gigabitethernet 2/1/1.10

[Router-GigabitEthernet2/1/1.10] ip address 1.1.1.11 255.255.255.0

[Router-GigabitEthernet2/1/1.10] vlan-type dot1q vid 100 second-dot1q 11 to 13

[Device-GigabitEthernet2/1/1.10] vlan-termination broadcast enable

[Router-GigabitEthernet2/1/1.10] quit

# 配置端口GigabitEthernet2/1/2的IP地址。

[Router] interface gigabitethernet 2/1/2

[Router-GigabitEthernet2/1/2] ip address 1.1.2.11 255.255.255.0

(5)     L2 Switch C的配置

L2 Switch C采用出厂配置即可。

(6)     Server group的配置

将Server group里所有设备的IP地址配置在1.1.2.0/24网段,网关地址指定为1.1.2.11/24即可。

4. 验证配置

配置完成后,Host A、Host B、Host C可以与Server group相互ping通。

1.10.6  QinQ终结支持PPPoE Server配置举例

1. 组网需求

如下图所示,Host A、Host B、Host C和L2 Switch A相连,分别属于VLAN 11、VLAN12和VLAN 13;L2 Switch B上开启了QinQ功能。Host A、Host B、Host C需要通过拨号方式访问Internet。

2. 组网图

图1-8 QinQ终结支持PPPoE Server配置组网图

 

3. 配置步骤

关于VLAN和QinQ终结的配置步骤请参见“1.10.5  模糊的QinQ终结配置举例”,另外Router作为网络中的PPPoE server,需要在GigabitEthernet2/1/1.10上进行PPPoE相关参数的配置,详情请参见“二层技术-广域网接入配置指导”中的“PPPoE”。

1.10.7  QinQ终结支持DHCP中继配置举例

1. 组网需求

·     Provider A、Provider B作为运营商网络设备。

·     DHCP client A和DHCP client B作为用户网络设备。

·     Provider A作为DHCP中继,Provider B作为DHCP server。

·     Provider A和Provider B之间通过三层接口连接。

希望配置完成后达到下列要求:

·     DHCP中继接收到的客户端发送的报文包括两层Tag,在DHCP中继上实现QinQ终结,即去掉报文中的两层Tag后,通过运营商网络将报文转发给DHCP server。

·     DHCP client A和DHCP client B可以经过运营商网络从DHCP server申请到IP地址和网络配置参数。

2. 组网图

图1-9 QinQ终结支持DHCP中继配置组网图

 

3. 配置步骤

(1)     DHCP中继Provider A的配置

# 开启DHCP服务。

<ProviderA> system-view

[ProviderA] dhcp enable

# 创建路由子接口GigabitEthernet2/1/1.100。

[ProviderA] interface gigabitethernet 2/1/1.100

# 配置子接口GigabitEthernet2/1/1.100能够终结的VLAN报文的第一层VLAN ID为100、第二层VLAN ID为10或20。

[ProviderA-GigabitEthernet2/1/1.100] vlan-type dot1q vid 100 second-dot1q 10 20

# 配置允许子接口GigabitEthernet2/1/1.100发送广播、组播报文。

[ProviderA-GigabitEthernet2/1/1.100] vlan-termination broadcast enable

# 配置子接口GigabitEthernet2/1/1.100工作在DHCP中继模式,并指定DHCP服务器的地址。

[ProviderA-GigabitEthernet2/1/1.100] dhcp select relay

[ProviderA-GigabitEthernet2/1/1.100] dhcp relay server-address 10.2.1.1

# 配置子接口GigabitEthernet2/1/1.100的IP地址。

[ProviderA-GigabitEthernet2/1/1.100] ip address 192.168.1.1 24

[ProviderA-GigabitEthernet2/1/1.100] quit

# 启用DHCP中继的用户地址表项记录功能。

[ProviderA] dhcp relay client-information record

# 配置与DHCP服务器连接接口的IP地址。

[ProviderA] interface serial 3/1/0

[ProviderA-Serial3/1/0] ip address 10.1.1.1 24

[ProviderA-Serial3/1/0] quit

# 配置到DHCP服务器的静态路由。

[ProviderA] ip route-static 10.2.1.1 24 10.1.1.1

(2)     DHCP服务器Provider B的配置

# 配置DHCP服务器的IP地址。

<ProviderB> system-view

[ProviderB] interface serial 3/1/0

[ProviderB-Serial3/1/0] ip address 10.2.1.1 24

[ProviderB-Serial3/1/0] quit

# 开启DHCP服务。

[ProviderB] dhcp enable

# 配置DHCP服务器地址池。

[ProviderB] dhcp server ip-pool 1

[ProviderB-dhcp-pool-1] network 192.168.1.0 24

[ProviderB-dhcp-pool-1] gateway-list 192.168.1.1

[ProviderB-dhcp-pool-1] quit

# 配置到DHCP中继路由子接口的静态路由。

[ProviderB] ip route-static 192.168.1.1 24 10.1.1.1

(3)     Switch A的配置

# 配置QinQ上行端口GigabitEthernet2/1/1为Trunk类型,并允许VLAN 100通过。

<SwitchA> system-view

[SwitchA] interface gigabitethernet 2/1/1

[SwitchA-GigabitEthernet2/1/1] port link-type trunk

[SwitchA-GigabitEthernet2/1/1] port trunk permit vlan 100

[SwitchA-GigabitEthernet2/1/1] quit

# 配置QinQ下行端口GigabitEthernet2/1/2为Trunk类型,并允许VLAN 10、100通过。

[SwitchA] interface gigabitethernet 2/1/2

[SwitchA-GigabitEthernet2/1/2] port link-type trunk

[SwitchA-GigabitEthernet2/1/2] port trunk permit vlan 10 100

# 配置端口GigabitEthernet2/1/2的缺省VLAN为VLAN 100。

[SwitchA-GigabitEthernet2/1/2] port trunk pvid vlan 100

# 开启端口GigabitEthernet2/1/2的QinQ功能。

[SwitchA-GigabitEthernet2/1/2] qinq enable

[SwitchA-GigabitEthernet2/1/2] quit

# 配置QinQ下行端口GigabitEthernet2/1/3为Trunk类型,并允许VLAN 20、100通过。

[SwitchA] interface gigabitethernet 2/1/3

[SwitchA-GigabitEthernet2/1/3] port link-type trunk

[SwitchA-GigabitEthernet2/1/3] port trunk permit vlan 20 100

# 配置端口GigabitEthernet2/1/3的缺省VLAN为VLAN 100。

[SwitchA-GigabitEthernet2/1/3] port trunk pvid vlan 100

# 开启端口GigabitEthernet2/1/3的QinQ功能。

[SwitchA-GigabitEthernet2/1/3] qinq enable

[SwitchA-GigabitEthernet2/1/3] quit

# 下行端口GigabitEthernet2/1/2和GigabitEthernet2/1/3加入VLAN 100。

[SwitchA] vlan 100

[SwitchA-vlan100] port gigabitethernet 2/1/2

[SwitchA-vlan100] port gigabitethernet 2/1/3

(4)     Switch B的配置

# 配置端口GigabitEthernet2/1/2加入VLAN 10。

<SwitchB> system-view

[SwitchB] vlan 10

[SwitchB-vlan10] port gigabitethernet 2/1/2

[SwitchB-vlan10] quit

# 配置端口GigabitEthernet2/1/1为Trunk类型,并允许VLAN 10的报文通过。

[SwitchB] interface gigabitethernet 2/1/1

[SwitchB-GigabitEthernet2/1/1] port link-type trunk

[SwitchB-GigabitEthernet2/1/1] port trunk permit vlan 10

(5)     Switch C的配置

# 配置端口GigabitEthernet2/1/2加入VLAN 20。

<SwitchC> system-view

[SwitchC] vlan 20

[SwitchC-vlan20] port gigabitethernet 2/1/2

[SwitchC-vlan20] quit

# 配置端口GigabitEthernet2/1/1为Trunk类型,并允许VLAN 20的报文通过。

[SwitchC] interface gigabitethernet 2/1/1

[SwitchC-GigabitEthernet2/1/1] port link-type trunk

[SwitchC-GigabitEthernet2/1/1] port trunk permit vlan 20

4. 验证配置

DHCP client A和DHCP client B可以从DHCP server申请到IP地址和网络配置参数。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!