国家 / 地区

03-二层技术-以太网交换命令参考

06-VLAN命令

本章节下载  (340.95 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/SR_Router/SR6600/Command/Command_Manual/H3C_SR6600_SR6600-X_CR(V5)-R3303(V1.23)/03/201702/973814_30005_0.htm

06-VLAN命令


1 VLAN

说明

本节命令仅在SAP板工作在二层模式时支持。

 

1.1  VLAN配置命令

1.1.1  bandwidth

【命令】

bandwidth bandwidth-value

undo bandwidth

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

bandwidth-value:表示VLAN接口的期望带宽,取值范围为1~4294967295,单位为kbit/s。

【描述】

bandwidth命令用来配置VLAN接口的期望带宽。undo bandwidth命令用来恢复缺省值。

VLAN接口的期望带宽可以通过第三方软件查询MIB节点ifspeed的值来获取。

期望带宽供网管监控VLAN接口带宽使用,不会对VLAN接口实际带宽造成影响。

【举例】

# 配置VLAN接口1的期望带宽为10000kbit/s。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] bandwidth 10000

1.1.2  description

【命令】

description text

undo description

【视图】

VLAN视图/VLAN接口视图

【缺省级别】

2:系统级

【参数】

text:VLAN或VLAN接口的描述字符串,可以包含字母(区分大小写)、数字、特殊字符(包括~ ! @ # $ % ^ & * ( ) - _ + = { } [ ] | \ : ; " ' < > , . /)、空格以及符合unicode编码规范的其他文字和符号。

VLAN和VLAN接口的描述信息的取值范围分别为:

·     VLAN的描述信息为1~32个字符的字符串。

·     VLAN接口的描述信息为1~240个字符的字符串。

说明

·     一个英文字符占用一个字符长度,一个unicode编码的字符占用两个字符长度,用户可以在描述字符串中混合输入英文字符和unicode字符,但字符串总长度不能超过规定的长度范围。

·     如果用户在设置描述字符时需要使用unicode编码的某种文字或符号,则必须具有相应的输入法软件,并使用支持该字符的远程登录软件登录到设备上进行配置。

·     一个unicode编码的字符占用两个字符长度,所以当所配置的描述信息长度达到或超过终端软件最大列宽时,终端软件会进行自动换行,此时可能导致unicode字符被截断,终端软件会在换行处之后显示乱码。

 

【描述】

description命令用来配置当前VLAN或VLAN接口的描述信息。undo description命令用来恢复缺省情况。

缺省情况下,VLAN的描述信息为“VLAN vlan-id”,其中vlan-id为该VLAN的编号。例如,VLAN 100的描述信息为“VLAN 0100”;VLAN接口的描述信息为该VLAN接口的接口名,如“Vlan-interface1 Interface”。

需要注意的是,当设备上配置的VLAN较多时,用户可以根据功能或者连接情况为VLAN或VLAN接口设置特定的描述信息,以便记忆和管理VLAN或VLAN接口。

相关配置可参考命令display interface vlan-interfacedisplay vlan

【举例】

# 将VLAN 2的描述信息配置为sales-private。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] description sales-private

# 将VLAN接口2的描述信息配置为linktoPC56。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description linktoPC56

1.1.3  display interface vlan-interface

【命令】

display interface [ vlan-interface ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

display interface vlan-interface vlan-interface-id [ brief [ description ] ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-interface-id:VLAN接口的编号。

brief:显示接口的概要信息。不指定该参数时,将显示接口的详细信息。

description:用来显示用户配置的接口的全部描述信息。如果某接口的描述信息超过27个字符,不指定该参数时,只显示描述信息中的前27个字符,超出部分不显示;指定该参数时,可以显示全部描述信息。

down:显示当前状态为down的接口的信息以及down的原因。不指定该参数时,将不会根据接口状态来过滤显示信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display interface vlan-interface命令用来显示VLAN接口的相关信息。

需要注意的是:

·     如果不指定vlan-interface参数,将显示设备支持的所有接口的相关信息。

·     如果指定vlan-interface参数,不指定vlan-interface-id参数,将显示所有已创建的VLAN接口的相关信息。

相关配置可参考命令reset counters interface vlan-interface

【举例】

# 显示VLAN接口10的相关信息。

<Sysname> display interface vlan-interface 10

Vlan-interface10 current state: UP

Line protocol current state: UP

Description: Vlan-interface10 Interface

The Maximum Transmit Unit is 1500

Internet Address is 192.168.1.54/24 Primary

Internet Address is 6.4.4.4/24 Sub

IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 0023-89b6-d613

IPv6 Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 0023-89b6-d613

Output queue: Strict-priority queue

Last clearing of counters:  Never

# 显示VLAN接口2的概要信息。

<Sysname> display interface vlan-interface 2 brief

The brief information of interface(s) under route mode:

Link: ADM - administratively down; Stby - standby

Protocol: (s) - spoofing

Interface            Link Protocol Main IP         Description

Vlan2                DOWN DOWN     --

# 显示所有状态为down的VLAN接口的概要信息。

<Sysname> display interface vlan-interface brief down

The brief information of interface(s) under route mode:

Link: ADM - administratively down; Stby - standby

Interface            Link Cause

Vlan2                DOWN Not connected

表1-1 display interface vlan-interface命令显示信息描述表

字段

描述

Vlan-interface2 current state

VLAN接口的物理状态,状态可能为:

·     DOWN ( Administratively ):表示该VLAN接口已经通过shutdown命令被关闭,即管理状态为关闭

·     DOWN:表示该VLAN接口的管理状态为开启,但物理状态为关闭,即该接口对应的VLAN内没有处于up状态的物理端口(可能因为没有物理连线或者线路故障)

·     UP:该端口的管理状态和物理状态均为开启

Line protocol current state

VLAN接口的链路层协议状态,状态可能为:

·     DOWN:该VLAN接口的协议状态为关闭

·     UP:该VLAN接口的协议状态为开启

Description

VLAN接口的字符串描述

The Maximum Transmit Unit

VLAN接口允许通过的最大传输单元(MTU)

Internet protocol processing : disabled

该接口还不具有处理IP报文的能力(当没有为该接口配置IP地址时会显示该信息)

Internet Address is 192.168.1.54/24 Primary

该接口的主IP地址为192.168.1.54/24(只有为该接口配置主IP地址后才会显示该信息)

Internet Address is 6.4.4.4/24 Sub

该接口的从IP地址为6.4.4.4/24(只有为该接口配置从IP地址后才会显示该信息)

IP Packet Frame Type

IPv4发送帧格式

Hardware address

VLAN接口对应的MAC地址

IPv6 Packet Frame Type

IPv6发送帧格式

Output queue

出口队列类型

Last clearing of counters

最近一次使用reset counters interface vlan-interface命令清除接口下的统计信息的时间(如果从设备启动一直没有执行reset counters interface vlan-interface命令清除过该接口下的统计信息,则显示Nerver)

The brief information of interface(s) under route mode:

三层模式下(route)的接口的概要信息,即三层接口的概要信息

Link: ADM - administratively down; Stby - standby

·     如果某接口的Link属性值为“ADM”,则表示该接口被管理员手工关闭了,需要在该接口下执行undo shutdown命令才能恢复端口本身的物理状态

·     如果某接口的Link属性值为“Stby”,则表示该接口是一个备份接口,使用display standby state命令可以查看该备份接口对应的主接口

Protocol: (s) - spoofing

如果某接口的Protocol属性值中带有“(s)”字符串,则表示该接口的网络层协议状态显示是UP的,但实际可能没有对应的链路,或者所对应的链路不是永久存在而是按需建立

Interface

接口名称缩写

Link

接口物理连接状态,取值可能为:

·     UP:表示本链路物理上是连通的

·     ADM:表示本链路被手工关闭了,需要执行undo shutdown命令才能恢复真实的物理状态

Protocol

接口协议连接状态,取值为UP(s)

Main IP

接口主IP地址

Description

接口的描述信息

Cause

接口物理连接状态为DOWN的原因

·     取值为Administratively时表示本链路被手工关闭了,需要执行undo shutdown命令才能恢复真实的物理状态

·     取值为Not connected时表示本链路没有物理连接

 

1.1.4  display vlan

【命令】

display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | reserved | static ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-id1:显示指定VLAN的信息。vlan-id1为指定VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:显示ID在指定范围内的VLAN的信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094。vlan-id2的值要大于或等于vlan-id1的值。

all:显示除保留VLAN外的其它VLAN的信息。

dynamic:显示系统动态创建的VLAN的数量和编号。动态VLAN是指通过GVRP协议生成或通过Radius服务器下发的VLAN。

reserved:显示系统保留VLAN的信息。保留VLAN是设备根据功能实现的需要预留的VLAN。保留VLAN由协议模块来指定,为协议模块服务,用户不能对保留VLAN进行任何操作。

static:显示系统静态创建的VLAN的数量和VLAN编号。静态VLAN是指通过命令行手工创建的VLAN。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display vlan命令用来显示VLAN的相关信息。

相关配置可参考命令vlan

【举例】

# 显示VLAN 2的信息。

<Sysname> display vlan 2

 VLAN ID: 2

 VLAN Type: static

 Route interface: not configured

 Description: VLAN 0002

 Name: VLAN 0002

 Tagged   Ports: none

 Untagged Ports: 

    GigabitEthernet4/0/1  GigabitEthernet4/0/2  GigabitEthernet4/0/3

# 显示VLAN 3的信息。

<Sysname> display vlan 3

 VLAN ID: 3

 VLAN Type: static

 Route Interface: configured

 IP Address: 1.1.1.1

 Subnet Mask: 255.255.255.0

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged   Ports: none

 Untagged Ports: none

表1-2 display vlan命令显示信息描述表

字段

解释

VLAN ID

VLAN的编号

VLAN Type

VLAN的类型:static表示静态VLAN;dynamic表示动态VLAN

Route interface

设备上是否创建了对应的VLAN接口:not configured(没有创建)/configured(创建了)

Description

VLAN的描述信息

Name

VLAN的名称

IP Address

VLAN接口的主用IP地址(如果VLAN接口没有配置IP地址,则不显示该字段),如果VLAN接口上还配置了从IP地址,可以使用display interface vlan-interface或者在VLAN接口视图下使用display this命令查看

Subnet Mask

VLAN接口的主用IP地址的子网掩码(如果VLAN接口没有配置IP地址,则不显示该字段)

Tagged Ports

该VLAN报文从哪些端口发送时需要携带Tag标记

Untagged Ports

该VLAN报文从哪些端口发送时不需要携带Tag标记

 

1.1.5  interface vlan-interface

【命令】

interface vlan-interface vlan-interface-id

undo interface vlan-interface vlan-interface-id

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-interface-id:VLAN接口的编号,取值范围为1~4094。

【描述】

interface vlan-interface命令用来创建VLAN接口并进入VLAN接口视图。如果该VLAN接口已经存在,则直接进入VLAN接口视图。undo interface vlan-interface命令用来删除指定的VLAN接口。

需要注意的是:

·     在创建VLAN接口之前,对应的VLAN必须已经存在。否则将不能创建指定的VLAN接口。

·     用户可以在VLAN接口视图下使用ip address命令配置IP地址,使得设备具有三层路由功能。

相关配置可参考命令display interface vlan-interface

【举例】

# 创建VLAN接口2并进入视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2]

1.1.6  ip address

【命令】

ip address ip-address { mask | mask-length } [ sub ]

undo ip address [ ip-address { mask | mask-length } [ sub ] ]

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

ip-address:VLAN接口的IP地址,为点分十进制格式。

mask:子网掩码,为点分十进制格式。

mask-length:子网掩码长度,即子网掩码中“1”的个数,取值范围为0~32。

sub:表示该地址为VLAN接口的从IP地址。

【描述】

ip address命令用来给VLAN接口指定IP地址和掩码。undo ip address命令用来删除VLAN接口的IP地址和掩码。

缺省情况下,没有配置VLAN接口的IP地址。

一般情况下,一个接口配置一个IP地址即可,但为了使设备的一个VLAN可以与多个子网相连,VLAN接口可以配置多个IP地址,其中一个为主IP地址,其余为从IP地址。主从地址的配置关系为:

·     当配置主IP地址时,如果接口上已经有主IP地址,则原主IP地址被新配置的地址取代。

·     undo ip address命令不带任何参数表示删除该接口的所有IP地址。

·     undo ip address ip-address { mask | mask-length }表示删除主IP地址。

·     undo ip address ip-address { mask | mask-length } sub表示删除从IP地址。

·     在删除主IP地址之前必须先删除从IP地址。

相关配置可参考“三层技术-IP业务命令参考/IP地址”中的命令display ip interface

【举例】

# 指定VLAN接口1的IP地址为1.1.0.1,子网掩码为255.255.255.0。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] ip address 1.1.0.1 255.255.255.0

1.1.7  mtu

【命令】

mtu size

undo mtu

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

size:表示接口允许通过的MTU(Maximum Transmission Unit,最大传输单元)值的大小,单位为字节。设备支持的取值范围为46~2000。

【描述】

mtu命令用来配置VLAN接口的MTU值。undo mtu命令用来恢复缺省情况。

缺省情况下,VLAN接口的MTU值为1500字节。

相关配置可参考命令display interface vlan-interface

【举例】

# 配置VLAN接口1的MTU值为1492字节。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] mtu 1492

1.1.8  name

【命令】

name text

undo name

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

text:VLAN名称,为1~32个字符的描述信息,可以包含字母(区分大小写)、数字、特殊字符(包括~ ! @ # $ % ^ & * ( ) - _ + = { } [ ] | \ : ; " ' < > , . /)、空格以及符合unicode编码规范的其它文字和符号。

【描述】

name命令用来指定当前VLAN的名称。当设备上配置了802.1X或MAC地址认证功能后,可以通过Radius服务器来对认证通过的端口下发VLAN。某些服务器可以向设备发送需要下发的VLAN编号或者VLAN名称,当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。undo name命令用来恢复缺省情况。

缺省情况下,VLAN的名称为“VLAN vlan-id”,其中vlan-id为该VLAN的编号。例如,VLAN 100的名称为“VLAN 0100”。

需要注意的是,当设备上配置了802.1X或MAC地址认证功能后,可以通过RADIUS服务器来对认证通过的端口下发VLAN。某些服务器可以向设备发送需要下发的VLAN编号或者VLAN名称,当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。

相关配置可参考命令display vlan

【举例】

# 指定VLAN 2的名称为“Test VLAN”。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] name Test VLAN

1.1.9  reset counters interface vlan-interface

【命令】

reset counters interface vlan-interface [ vlan-interface-id ]

【视图】

用户视图

【缺省级别】

2:系统级

【参数】

vlan-interface-id:VLAN接口的编号。

【描述】

reset counters interface vlan-interface命令用来清除VLAN接口的统计信息。

在某些情况下,需要统计一定时间内某接口的流量,这就需要在统计开始前清除该接口原有的统计信息,重新进行统计。

需要注意的是:

·     如果不指定vlan-interface-id,则清除所有VLAN接口的统计信息。

·     如果指定vlan-interface-id,则清除指定VLAN接口的统计信息。

相关配置可参考命令display interface vlan-interface

【举例】

# 清除VLAN接口2的统计信息。

<Sysname> reset counters interface vlan-interface 2

1.1.10  shutdown

【命令】

shutdown

undo shutdown

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

【描述】

shutdown命令用来手工关闭VLAN接口。undo shutdown命令用来取消手工关闭VLAN接口。

缺省情况下,未手工关闭VLAN接口。此时VLAN接口状态受VLAN中端口状态的影响,即:当VLAN中所有以太网端口状态均为down时,VLAN接口为down状态,即关闭状态;当VLAN中有一个或一个以上的以太网端口处于up状态时,则VLAN接口处于up状态。

需要注意的是:

·     如果手工关闭VLAN接口,则VLAN接口的状态始终为down(Administratively),不受VLAN中端口状态的影响。

·     配置VLAN接口参数前,为了避免配置过程中对网络造成影响,建议先使用shutdown命令手工关闭接口,之后再配置参数。配置完成后,使用undo shutdown命令取消手工关闭接口,使配置的参数生效。

·     当VLAN接口出现故障时,可以使用shutdown命令手工关闭接口,然后再使用undo shutdown命令取消手工关闭接口,这样有可能使接口恢复正常。

·     关闭和打开VLAN接口对于属于这个VLAN的任何一个以太网端口本身都不起作用,以太网端口的状态不随VLAN接口状态的改变而改变。

【举例】

# 将VLAN接口2关闭后再重新打开。

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] shutdown

[Sysname-Vlan-interface2] undo shutdown

1.1.11  vlan

【命令】

vlan { vlan-id1 [ to vlan-id2 ] | all }

undo vlan { vlan-id1 [ to vlan-id2 ] | all }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-id1:VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为VLAN的编号,取值范围为1~4094。vlan-id2的值要大于或等于vlan-id1的值。

all:除保留VLAN外的其它VLAN。

【描述】

vlan vlan-id命令用来创建VLAN并进入VLAN视图。如果指定的VLAN已创建,则该命令直接用来进入该VLAN的视图。vlan vlan-id1 to vlan-id2命令用来批量创建vlan-id1vlan-id2之间的所有VLAN,保留VLAN除外。vlan all命令用来批量创建VLAN 1~VLAN 4094。undo vlan命令用来删除VLAN。

缺省情况下,系统只有一个缺省VLAN(VLAN 1)。

需要注意的是:

·     VLAN1为系统缺省VLAN,用户不能创建和删除。

·     保留VLAN是系统为实现特定功能预留的VLAN,用户也不能手工创建和删除。

·     对于协议保留的VLAN、Voice VLAN、管理VLAN、动态学习到的VLAN、配置有QoS策略的VLAN、SmartLink功能的控制VLAN、RRPP的控制VLAN以及镜像VLAN等,都不能使用undo vlan命令直接删除。只有将相关配置删除之后,才能删除相应的VLAN。

相关配置可参考命令display vlan

【举例】

# 创建进入VLAN2,并进入该VLAN视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2]

# 批量创建VLAN4~VLAN100。

<Sysname> system-view

[Sysname] vlan 4 to 100

Please wait............. Done.

1.2  基于端口的VLAN配置命令

1.2.1  display port

【命令】

display port { hybrid | trunk } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

hybrid:显示系统当前存在的Hybrid端口。

trunk:显示系统当前存在的Trunk端口。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display port命令用来显示设备上当前存在的Hybrid或Trunk端口。显示的信息包括端口对应的端口名、缺省VLAN ID和允许通过的VLAN ID。

【举例】

# 显示当前系统存在的Hybrid端口。

<Sysname> display port hybrid

Interface                          PVID  VLAN passing

GigabitEthernet4/0/4               100   Tagged:  1000, 1002, 1500, 1600-1611, 2000,

                                    2555-2558, 3000, 4000

                                         Untagged:1, 10, 15, 18, 20-30, 44, 55, 67, 100,

                                                  150-160, 200, 255, 286, 300-302

# 显示当前系统存在的Trunk端口。

<Sysname> display port trunk

Interface                          PVID  VLAN passing

GigabitEthernet4/0/8               2     1-4, 6-100, 145, 177, 189-200, 244, 289, 400,

                           555, 600-611, 1000, 2006-2008

表1-3 display port命令显示信息描述表

字段

描述

Interface

接口名称

PVID

该端口的缺省VLAN ID

VLAN passing

表示哪些VLAN的报文允许通过该端口

Tagged

表示哪些VLAN的报文通过该端口时必须携带VLAN Tag

Untagged

表示哪些VLAN的报文通过该端口时必须去掉VLAN Tag

 

1.2.2  port

【命令】

port interface-list

undo port interface-list

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

interface-list:接口列表,表示方式为interface-list = { interface-type interface-number1 [ to interface-type interface-numbe2r ] }&<1-10>。其中interface-type interface-number为指定接口类型和接口编号。&<1-10>表示前面的参数最多可以输入10次。

【描述】

port命令用来向当前VLAN中添加一个或一组Access端口。undo port命令用来从当前VLAN中删除一个或一组Access端口。

缺省情况下,系统将所有端口都加入到VLAN1。

需要注意的是:

·     通过本命令只能将Access端口加入到VLAN中,不能将Trunk和Hybrid端口加入到VLAN中。

·     设备上的所有端口的缺省链路类型都是Access类型,但用户可以自行切换端口类型,具体配置可参考命令port link-type

·     不支持二层聚合接口添加到当前VLAN。

相关配置可参考命令display vlan

【举例】

# 向VLAN2中加入从GigabitEthernet4/0/1到GigabitEthernet4/0/3的以太网端口。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] port GigabitEthernet 4/0/1 to GigabitEthernet 4/0/3

1.2.3  port access vlan

【命令】

port access vlan vlan-id

undo port access vlan

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定的VLAN编号,取值范围为1~4094。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

【描述】

port access vlan命令用来将当前Access端口加入到指定的VLAN中。undo port access vlan命令用来恢复缺省情况。

缺省情况下,所有Access端口均属于且只属于VLAN1。

需要注意的是:

·     以太网接口视图下的配置只对当前接口生效。

·     端口组视图下的配置将对端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

【举例】

# 将GigabitEthernet4/0/1端口加入到VLAN3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] port access vlan 3

# 将二层聚合接口1以及其对应的成员端口加入到VLAN3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port access vlan 3

1.2.4  port hybrid pvid

【命令】

port hybrid pvid vlan vlan-id

undo port hybrid pvid

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省的VLAN ID,取值范围为1~4094。

【描述】

port hybrid pvid命令用来设置Hybrid端口的缺省VLAN。undo port hybrid pvid命令用来恢复缺省情况。

缺省情况下,Hybrid端口的缺省VLAN为VLAN1。

需要注意的是:

·     对Hybrid端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即可以使用已经不存在的VLAN作为缺省VLAN。

·     建议本机Hybrid端口的缺省VLAN和相连的对端设备的Hybrid端口的缺省VLAN保持一致。

·     配置缺省VLAN后,必须使用port hybrid vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

·     在以太网接口视图下的配置只对当前接口生效;

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-typeport hybrid vlan

【举例】

# 配置端口GigabitEthernet4/0/1(Hybrid类型)的缺省VLAN设置为VLAN 100。

<Sysname> system-view

[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] port link-type hybrid

[Sysname-GigabitEthernet4/0/1] port hybrid pvid vlan 100

# 将二层聚合接口1(Hybrid类型)以及其对应的成员端口的缺省VLAN设为100。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid pvid vlan 100

1.2.5  port hybrid vlan

【命令】

port hybrid vlan vlan-list { tagged | untagged }

undo port hybrid vlan vlan-list

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-list:VLAN列表,Hybrid端口允许通过的VLAN范围。表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>。其中,vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。&<1-10>表示前面的参数最多可以重复输入10次。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

tagged:该端口在转发指定的VLAN报文时将保留VLAN Tag。

untagged:该端口在转发指定的VLAN报文时将去掉VLAN Tag。

【描述】

port hybrid vlan命令用来允许指定的VLAN通过当前Hybrid端口。undo port hybrid vlan命令用来禁止指定的VLAN通过当前Hybrid端口。

缺省情况下,Hybrid端口只允许VLAN1的报文以untagged方式通过,即VLAN1的报文从该端口发送出去后不携带VLAN Tag。

需要注意的是:

·     Hybrid端口允许多个VLAN通过。如果多次使用port hybrid vlan命令,那么Hybrid端口上允许通过的VLAN是这些vlan-list的合集。

·     以太网接口视图下的该配置只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-type

【举例】

# 配置端口GigabitEthernet4/0/1(Hybrid类型)允许VLAN2、VLAN4、VLAN50~VLAN100通过(假设指定的VLAN都已经创建),并且发送这些VLAN的报文时保留VLAN Tag。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] port link-type hybrid

[Sysname-GigabitEthernet4/0/1] port hybrid vlan 2 4 50 to 100 tagged

# 配置端口组2内的Hybrid端口允许VLAN2通过,并且发送这些VLAN的报文时不带VLAN Tag。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] port-group manual 2

[Sysname-port-group-manual-2] group-member GigabitEthernet 4/0/1 to GigabitEthernet 4/0/6

[Sysname-port-group-manual-2] port link-type hybrid

[Sysname-port-group-manual-2] port hybrid vlan 2 untagged

 Configuring GigabitEthernet4/0/1... Done.

 Configuring GigabitEthernet4/0/2... Done.

 Configuring GigabitEthernet4/0/3... Done.

 Configuring GigabitEthernet4/0/4... Done.

 Configuring GigabitEthernet4/0/5... Done.

 Configuring GigabitEthernet4/0/6... Done.

# 将二层聚合接口1(Hybrid类型)以及其对应的成员端口允许VLAN 2通过,并且发送这些VLAN的报文时不带VLAN Tag。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid vlan 2 untagged

 Please wait... Done.

 Configuring GigabitEthernet4/0/1... Done.

 Configuring GigabitEthernet4/0/2... Done.

 Configuring GigabitEthernet4/0/3... Done.

接口GigabitEthernet4/0/1、GigabitEthernet4/0/2和GigabitEthernet4/0/3是二层聚合接口1对应的成员端口。

1.2.6  port link-type

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

access:设置端口的链路类型为Access类型。

hybrid:设置端口的链路类型为Hybrid类型。

trunk:设置端口的链路类型为Trunk类型。

【描述】

port link-type命令用来设置当前端口的链路类型。undo port link-type命令用来恢复缺省情况。

缺省情况下,所有端口的链路类型均为Access类型。

需要注意的是:

·     Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其它类型端口。

·     当使用port link-type命令修改接口的链路类型后,该接口下的loopback-detection action配置会自动恢复到缺省情况。

·     以太网接口视图下的该配置只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

【举例】

# 将以太网端口GigabitEthernet4/0/1设置为Trunk类型端口

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] port link-type trunk

# 将手工端口组group1内的所有端口都设置为Hybrid端口。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group manual group1] group-member GigabitEthernet 4/0/1

[Sysname-port-group manual group1] group-member GigabitEthernet 4/0/2

[Sysname-port-group manual group1] port link-type hybrid

# 将二层聚合接口1以及其对应的成员端口的链路类型设置为Hybrid。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

1.2.7  port trunk permit vlan

【命令】

port trunk permit vlan { vlan-list | all }

undo port trunk permit vlan { vlan-list | all }

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-list:VLAN列表,Trunk端口允许通过的VLAN范围。表示方式为vlan-list = { vlan-id1 [ to vlan-id2 ] }& <1-10>。其中,vlan-id1vlan-id2为指定VLAN的编号,vlan-id取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。&<1-10>表示前面的参数最多可以重复输入10次。

all:表示允许所有VLAN通过该Trunk端口,建议用户谨慎使用port trunk permit all命令,以防止未授权VLAN的用户通过该端口访问受限资源。

【描述】

port trunk permit vlan命令用来允许指定的VLAN通过当前Trunk端口。undo port trunk permit vlan命令用来禁止指定的VLAN通过当前Trunk端口。

缺省情况下,Trunk端口只允许VLAN1的报文通过。

需要注意的是:

·     Trunk端口可以允许多个VLAN通过。如果多次执行用port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan-list的集合。

·     当执行port trunk permit vlan all命令时,若存在Super VLAN或Voice VLAN模式的VLAN时,系统会提示部分VLAN因为与其已有配置冲突而不能配置,但并不会给出具体的VLAN ID和配置冲突的原因,此时可通过display this命令确认最终的执行结果。

·     Trunk端口发送出去的报文,只有缺省VLAN的报文不带VLAN Tag,其他VLAN的报文均会保留VLAN Tag。

·     以太网接口视图下的配置只对当前接口生效;

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

相关配置可参考命令port link-type

【举例】

# 配置端口GigabitEthernet4/0/1(Trunk类型)允许VLAN 2、4、50~100通过。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] port link-type trunk

[Sysname-GigabitEthernet4/0/1] port trunk permit vlan 2 4 50 to 100

Please wait........... Done.

# 将二层聚合接口1(Trunk类型)允许VLAN 2通过。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type trunk

[Sysname-Bridge-Aggregation1] port trunk permit vlan 2

 Please wait... Done.

 Configuring GigabitEthernet4/0/1... Done.

 Configuring GigabitEthernet4/0/2... Done.

 Configuring GigabitEthernet4/0/3... Done.

接口GigabitEthernet4/0/1、GigabitEthernet4/0/2和GigabitEthernet4/0/3是二层聚合接口1的成员端口。

1.2.8  port trunk pvid

【命令】

port trunk pvid vlan vlan-id

undo port trunk pvid

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省VLAN ID,取值范围为1~4094。

【描述】

port trunk pvid命令用来设置Trunk端口的缺省VLAN。undo port trunk pvid命令用来恢复缺省情况。

缺省情况下,Trunk端口的缺省VLAN为VLAN1。

需要注意的是:

·     对Trunk端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即使用已经不存在的VLAN作为缺省VLAN。

·     以太网接口视图下的配置只对当前接口生效。

·     端口组视图下的配置对当前端口组中的所有端口生效。

·     二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

·     本端设备Trunk端口的缺省VLAN ID和相连的对端设备的Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

·     配置缺省VLAN后,必须使用port trunk permit vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

相关配置可参考命令port link-typeport trunk permit vlan

【举例】

# 配置端口GigabitEthernet4/0/1(Trunk类型)的缺省VLAN设置为VLAN 100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] port link-type trunk

[Sysname-GigabitEthernet4/0/1] port trunk pvid vlan 100

[Sysname-GigabitEthernet4/0/1] port trunk permit vlan 100

# 将二层聚合接口1(Trunk类型)的缺省VLAN设置为VLAN 100,并允许VLAN 100通过。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type trunk

[Sysname-Bridge-Aggregation1] port trunk pvid vlan 100

[Sysname-Bridge-Aggregation1] port trunk permit vlan 100

1.3  基于MAC的VLAN配置命令

1.3.1  display mac-vlan

【命令】

display mac-vlan { all | dynamic | mac-address mac-address [ mask mac-mask ] | static | vlan vlan-id } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

all:显示MAC-VLAN表的所有表项。

dynamic:显示动态配置的MAC-VLAN表项。

mac-address mac-address:按MAC显示MAC-VLAN表项。

mask mac-mask:显示指定范围的MAC-VLAN表项。

static:显示静态配置的MAC-VLAN表项。

vlan vlan-id:显示指定VLAN的MAC-VLAN表项。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display mac-vlan命令用来显示MAC-VLAN表项。

指定mac-address参数但不带mask参数,则显示单个MAC VLAN表项。

【举例】

# 显示MAC-VLAN表的所有表项。

<Sysname> display mac-vlan all

The following MAC-VLAN address exist:

S: Static   D: Dynamic

MAC ADDR           MASK                    VLAN ID   PRIO    STATE

-------------------------------------------------------------------

0008-0001-0000     FFFF-FF00-0000          5         3       S

0002-0001-0000     FFFF-FFFF-FFFF          5         3       S&D

 

Total MAC VLAN address count:2

表1-4 display mac-vlan命令显示信息描述表

字段

描述

The following MAC-VLAN address exist:

目前设备上存在以下MAC VLAN配置

S: Static

以下显示信息中,S表示静态配置的MAC VLAN

D: Dynamic

以下显示信息中,D表示动态配置的MAC VLAN

MAC ADDR

配置的MAC-VLAN的MAC地址

MASK

配置的MAC-VLAN的MAC地址对应的掩码

VLAN ID

用户配置的MAC地址所对应的VLAN

PRIO

用户配置的MAC地址所对应的802.1P优先级

STATE

该表项的属性,MAC-VLAN表中的表项有三种属性:

·     S表示该表项是通过用户静态配置生成的

·     D表示该表项是通过认证功能自动生成的

·     S&D表示该表项由静态和动态同时配置的

 

1.3.2  display mac-vlan interface

【命令】

display mac-vlan interface [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display mac-vlan interface命令用来显示所有使能了MAC-VLAN功能的接口。

相关配置可参考命令mac-vlan enable

【举例】

# 显示所有使能了MAC-VLAN功能的接口。

<Sysname> display mac-vlan interface

MAC VLAN is enabled on following ports:

---------------------------------------

 GigabitEthernet4/0/1  GigabitEthernet4/0/2  GigabitEthernet4/0/3

1.3.3  mac-vlan enable

【命令】

mac-vlan enable

undo mac-vlan enable

【视图】

二层以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

mac-vlan enable命令用来使能端口基于MAC地址划分VLAN的功能。undo mac-vlan enable 命令用来恢复缺省情况。

缺省情况下,没有使能端口基于MAC地址划分VLAN的功能。

需要注意的是,该命令只能在Hybrid端口配置。

【举例】

# 使能端口GigabitEthernet4/0/1的MAC VLAN功能。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname–GigabitEthernet4/0/1] mac-vlan enable

1.3.4  mac-vlan mac-address

【命令】

mac-vlan mac-address mac-address [ mask mac-mask ] vlan vlan-id [ priority pri ]

undo mac-vlan { all | mac-address mac-address [ mask mac-mask ] | vlan vlan-id }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

mac-address mac-address:指定MAC地址。

mask mac-mask:指定MAC地址的掩码,二进制时高位必须为连续1。缺省值为全F。

vlan vlan-id:指定VLAN编号,取值为1~4094。

priority pri:指定MAC地址对应VLAN的802.1p优先级,取值为0~7,缺省值为0。

all:删除所有的静态MAC-VLAN表项。

【描述】

mac-vlan mac-address命令用来配置MAC地址所对应的VLAN以及其优先级。undo mac-vlan命令用来删除MAC地址与VLAN的关联。

设备维护两张MAC-VLAN表,一种是通过指定mask参数配置的MAC-VLAN表,该表里的表项描述的是一类MAC地址和VLAN、优先级之间的关系;一种是不指定mask参数直接配置的MAC-VLAN表,该表里的表项描述的是单个MAC地址和VLAN、优先级之间的关系。根据用户的配置,系统将自动往这两个表里添加/删除表项。

【举例】

# 配置单个MAC地址(0-1-1)与VLAN 100的关联,并指定优先级为7。

<Sysname> system-view

[Sysname] mac-vlan mac-address 0-1-1 vlan 100 priority 7

# 配置将MAC地址前6位为121122的用户与VLAN 100关联,优先级为4。

<Sysname> system-view

[Sysname] mac-vlan mac-address 1211-2222-3333 mask ffff-ff00-0000 vlan 100 priority 4

1.3.5  vlan precedence

【命令】

vlan precedence { mac-vlan | ip-subnet-vlan }

undo vlan precedence

【视图】

二层以太网接口视图/端口组视图

【缺省级别】

2:系统级

【参数】

mac-vlan:表示优先根据单个MAC地址来匹配VLAN。

ip-subnet-vlan:表示优先根据IP子网设置来匹配VLAN。

【描述】

vlan precedence命令用来配置当前端口VLAN匹配优先级。undo vlan precedence命令用来恢复缺省情况。

缺省情况下,对于基于单个MAC的VLAN表项和基于IP子网的VLAN,优先根据单个MAC地址来匹配VLAN。

需要注意的是,该配置只对基于单个MAC的VLAN表项和基于IP子网的VLAN有效。如果端口下同时使能了MAC VLAN和IP子网VLAN,则当端口收到报文后,会根据vlan precedence命令的配置情况来决定是优先匹配单个MAC-VLAN表还是优先匹配IP子网-VLAN表。

【举例】

# 配置优先根据单个MAC地址来匹配VLAN。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] vlan precedence mac-vlan

1.4  基于协议的VLAN配置命令

1.4.1  display protocol-vlan interface

【命令】

display protocol-vlan interface { interface-type interface-number1 [ to interface-type interface-number2 ] | all } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

interface-type interface-number1:需要显示的接口的类型和编号。

interface-type interface-number1 to interface-type interface-number2:需要显示的接口的类型和范围。

all:显示所有端口的协议VLAN的相关信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display protocol-vlan interface命令用于显示端口上已配置的协议VLAN的相关信息。

【举例】

# 显示端口GigabitEthernet4/0/1上已配置的协议VLAN的相关信息。

<Sysname> display protocol-vlan interface GigabitEthernet 4/0/1

 Interface: GigabitEthernet4/0/1

   VLAN ID   Protocol Index      Protocol Type

 ======================================================

       2          0               ipv6

       3          0               ipv4

表1-5 display protocol-vlan interface命令显示信息描述表

字段

描述

Interface

当前查看的端口

VLAN ID

与该端口绑定的协议VLAN的编号

Protocol Index

协议模板索引号

Protocol Type

该协议模板所指定的协议类型

 

1.4.2  display protocol-vlan vlan

【命令】

display protocol-vlan vlan { vlan-id1 [ to vlan-id2 ] | all } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

vlan-id1:显示指定协议VLAN的相关信息,vlan-id1表示VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:显示指定VLAN范围内协议VLAN的相关信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。

all:显示所有协议VLAN的相关信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display protocol-vlan vlan命令用于显示VLAN上所配置的协议及协议的索引。

相关配置可参考命令display vlan

【举例】

# 显示系统当前所有协议VLAN的协议信息及协议的索引。

<Sysname> display protocol-vlan vlan all

 VLAN ID:2

    Protocol Index      Protocol Type

 ======================================================

          0              ipv4

          3              ipv6

 VLAN ID:3

    Protocol Index      Protocol Type

 ======================================================

          0              ipv4

          1              ipv6

表1-1  display protocol-vlan vlan命令显示信息描述表

字段

描述

VLAN ID

与该端口绑定的协议VLAN的编号

Protocol Index

协议模板索引号

Protocol Type

该协议模板所指定的协议类型

 

1.4.3  port hybrid protocol-vlan

【命令】

port hybrid protocol-vlan vlan vlan-id { protocol-index [ to protocol-end ] | all }

undo port hybrid protocol-vlan { vlan vlan-id { protocol-index [ to protocol-end ] | all } | all }

【视图】

以太网接口视图/端口组视图

【缺省级别】

2:系统级

【参数】

vlan vlan-id:VLAN的编号,取值范围为1~4094。

protocol-index:已创建的协议VLAN的协议索引。设备支持的取值范围为0~15,创建协议VLAN时由用户手工指定或者系统自动分配。可以通过display protocol-vlan vlan all命令来查看协议索引。

to protocol-end:协议索引终止值,设备支持的取值范围,不小于protocol-index

all:与vlan-id绑定的所有协议。

【描述】

port hybrid protocol-vlan命令用来配置Hybrid端口与基于协议的VLAN关联。undo port hybrid protocol-vlan命令用于取消Hybrid端口与基于协议的VLAN关联。

需要注意的是:

·     以太网接口视图下的配置都只对当前端口生效;端口组视图下的配置对当前端口组中的所有端口生效。

·     执行该命令前必须先进行以下配置,否则将执行失败:创建VLAN,并与协议关联;将端口类型配置为Hybrid类型;配置端口允许协议VLAN的报文通过。

相关配置可参考命令display protocol-vlan interface

【举例】

# 把端口GigabitEthernet4/0/1(Hybrid类型)与协议VLAN2中的协议0(IPv4协议)相关联。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] protocol-vlan ipv4

[Sysname-vlan2] quit

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] port link-type hybrid

[Sysname-GigabitEthernet4/0/1] port hybrid vlan 2 untagged

 Please wait... Done

[Sysname-GigabitEthernet4/0/1] port hybrid protocol-vlan vlan 2 0

1.4.4  protocol-vlan

【命令】

protocol-vlan [ protocol-index ] { at | ipv4 | ipv6 | ipx { ethernetii | llc | raw | snap } | mode { ethernetii etype etype-id | llc { dsap dsap-id [ ssap ssap-id ] | ssap ssap-id } | snap etype etype-id } }

undo protocol-vlan { protocol-index [ to protocol-end ] | all }

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

at:表示基于AT(AppleTalk,Apple计算机网络协议)协议的VLAN。

ipv4:表示基于IPv4协议的VLAN。

ipv6:表示基于IPv6协议的VLAN。

ipx:表示基于IPX协议的VLAN。可包括ethernetiillcrawsnap四种封装类型。

mode:表示配置自定义协议模板,可包括ethernetiillcsnap三种封装类型。

ethernetii etype etype-id:匹配Ethernet II封装格式及相应的协议类型值。etype-id表示入报文的协议类型值,取值范围为0x0600~0xFFFF(不包括0x0800、0x809B、0x8137和0x86DD)。

llc:匹配LLC封装格式的报文。

dsap dsap-id:目的服务接入点,取值范围为0x 00~0xFF。

ssap ssap-id:源服务接入点,取值范围为0x 00~0xFF。

snap etype etype-id:表示匹配SNAP封装格式的报文。其中,etype-id表示入报文的以太网类型,取值范围为0x0600~0x FFFF(不包括0x8137)。

protocol-index:协议索引,用来标志与当前VLAN绑定的协议模版。设备支持的取值范围为0~15,如果不指定该参数,则系统会自动分配一个索引值。

to protocol-end:协议索引终止值,必须大于等于协议索引初始值。

all:与当前VLAN绑定的所有协议。

【描述】

protocol-vlan命令用来配置基于协议的VLAN,并指定协议模板。undo protocol-vlan命令用于取消配置的协议模板。

缺省情况下,没有配置任何协议模板。

需要注意的是:

·     使用mode ethernetii etype关键字进行配置时,不允许将etype-id的值配置为0x0800、0x809B、0x8137或0x86DD,因为上述取值分别与IPv4、AppleTalk、IPX和IPv6协议模板相同。

·     使用mode llc关键字进行配置时,dsap-idssap-id的值不能同时为0xE0(代表IPX报文的LLC封装格式)或者同时为0xFF(代表IPX报文的raw封装格式),否则系统将提示出错;如果只配置了dsap-idssap-id中的一个,系统会将另一参数的值自动设置为0xAA。

·     使用mode snap etype关键字进行配置时,不允许将etype-id的值配置为0x8137,因为该值与IPX协议协议模板相同。当etype-id的值取0x0800、0x809B或0x86DD时,其对应的三层协议分别为IPv4、AppleTalk和IPv6。

相关配置可参考命令display protocol-vlan vlan

【举例】

# 配置VLAN3为协议VLAN,将IPv4协议报文划分到VLAN3中传输。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] protocol-vlan ipv4

注意

由于IP协议与ARP协议关系密切,建议用户将IPv4协议和ARP协议绑定到同一VLAN,并且关联到相同的端口,避免因ARP报文与IP报文未划分到同一VLAN,而造成无法正常通信的情况。

 

# 为VLAN3配置ARP协议模板(ARP协议的协议代码为0x0806),将ARP协议报文划分到VLAN3中传输。

·     当使用以太网封装时,请按下面的命令进行配置。

[Sysname-vlan3] protocol-vlan mode ethernetii etype 0806

·     当使用802.3封装格式时,请按下面的命令进行配置

[Sysname-vlan3] protocol-vlan mode snap etype 0806

1.5  基于IP子网的VLAN配置命令

1.5.1  display ip-subnet-vlan interface

【命令】

display ip-subnet-vlan interface { interface-list | all } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

 interface-list:需要显示的以太网端口列表,表示方式为interface-list={ interface-type interface-number1 [ to interface-type interface-number2 ] }&<1-10>。其中,interface-type interface-number为指定接口类型和接口编号。&<1-10>表示前面的参数最多可以输入10次。

all:显示所有配置了基于子网VLAN的端口的IP子网信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display ip-subnet-vlan interface命令用于显示指定端口上所配置的IP子网VLAN信息以及IP子网的索引。

【举例】

# 显示端口GigabitEthernet4/0/1上所配置的IP子网VLAN信息及IP子网的索引。

<Sysname> system-view

[Sysname] display ip-subnet-vlan interface GigabitEthernet 4/0/1

Interface: GigabitEthernet4/0/1

  VLAN ID   Subnet-Index    IP ADDRESS        NET MASK

  =======================================================

     3           0         192.168.1.0    255.255.255.0

表1-6 display ip-subnet-vlan interface命令显示信息描述表

字段

描述

Interface

当前查看的端口

VLAN ID

子网VLAN的编号

Subnet-Index

IP子网的索引

IP ADDRESS

IP子网的地址(可以是IP地址或网络地址)

NET MASK

IP子网的掩码

 

1.5.2  display ip-subnet-vlan vlan

【命令】

display ip-subnet-vlan vlan { vlan-id1 [ to vlan-id2 ] | all } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

vlan-id1: VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094,vlan-id2的值要大于或等于vlan-id1的值。

all:显示所有VLAN的IP子网信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display ip-subnet-vlan vlan命令用于显示指定VLAN上配置的IP子网VLAN信息及IP子网的索引。

相关配置可参考命令display vlan

【举例】

# 显示当前系统中所有IP子网VLAN信息以及IP子网的索引。

<Sysname> display ip-subnet-vlan vlan all

VLAN ID:  3

 Subnet Index      IP Address      Subnet Mask

 ====================================================

       0          192.168.1.0    255.255.255.0

表1-7 display ip-subnet-vlan vlan命令显示信息描述表

字段

描述

VLAN ID

子网VLAN的编号

Subnet Index

IP子网的索引

IP Address

IP子网的地址(可以是IP地址或网络地址)

Subnet Mask

IP子网的掩码

 

1.5.3  ip-subnet-vlan

【命令】

ip-subnet-vlan [ ip-subnet-index ] ip ip-address [ mask ]

undo ip-subnet-vlan { ip-subnet-index [ to ip-subnet-end ] | all }

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

ip-subnet-index:IP子网索引值,取值范围为0~11。子网索引可以由用户指定,也可由系统根据IP子网或IP地址与VLAN关联的先后顺序自动编号产生。

ip ip-address [ mask ]:作为子网VLAN划分依据的源IP地址或网络地址,ip-address表示源IP地址或网络地址,采用点分十进制格式;mask表示子网掩码,采用点分十进制格式,缺省值为255.255.255.0。

to:IP子网索引的范围。

ip-subnet-end:IP子网索引的终止值,取值范围为0~11,其值必须大于等于ip-subnet-index的值。

all:取消所有VLAN与指定的IP子网或IP地址的关联。

【描述】

ip-subnet-vlan命令用来配置当前VLAN与指定的IP子网或IP地址关联。undo ip-subnet-vlan命令用于取消该关联。

需要注意的是,配置的IP网段或IP地址不能是组播网段或组播地址。

相关配置可参考命令display ip-subnet-vlan vlan

【举例】

# 将VLAN 3配置为基于IP子网的VLAN,与192.168.1.0/24网段进行关联,使得源地址为该网段的报文可以分发到VLAN 3中传输。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] ip-subnet-vlan ip 192.168.1.0 255.255.255.0

1.5.4  port hybrid ip-subnet-vlan

【命令】

port hybrid ip-subnet-vlan vlan vlan-id

undo port hybrid ip-subnet-vlan { vlan vlan-id | all }

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan vlan-id:VLAN的编号,取值范围为1~4094。

all:所有VLAN。

【描述】

port hybrid ip-subnet-vlan命令用来设置当前以太网端口和指定的基于IP子网的VLAN相关联。undo port hybrid ip-subnet-vlan命令用于取消端口与基于IP子网VLAN的关联。

端口和基于IP子网的VLAN关联后,端口收到untagged报文后会跟据报文的源IP地址去判断该地址是否属于某个子网的地址,如果属于,则将相应的VLAN标签添加到报文头中。

需要注意的是:

·     以太网接口视图下的配置都只对当前端口生效;端口组视图下的配置对当前端口组中的所有端口生效;二层聚合接口视图下的配置对当前二层聚合接口及其所有成员端口都生效,若配置某成员端口时失败,系统会自动跳过该成员端口继续配置其它成员端口,若配置二层聚合接口时失败,则不再配置其成员端口。

·     端口必须是Hybrid类型。端口在与基于IP子网的VLAN进行关联之前,必须已经允许该VLAN通过,否则不允许进行关联。

相关配置可参考命令display ip-subnet-vlan interface

【举例】

# 将端口GigabitEthernet4/0/1与IP子网VLAN3相关联。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] ip-subnet-vlan ip 192.168.1.0 255.255.255.0

[Sysname-vlan3] quit

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] port link-type hybrid

[Sysname-GigabitEthernet4/0/1] port hybrid vlan 3 untagged

 Please wait... Done.

[Sysname-GigabitEthernet4/0/1] port hybrid ip-subnet-vlan vlan 3

# 把二层聚合接口1(Hybrid类型)与协议VLAN2中的协议0相关联。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] ip-subnet-vlan ip 192.168.1.0 255.255.255.0

[Sysname-vlan3] quit

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid vlan 3 untagged

 Please wait... Done

 Configuring GigabitEthernet4/0/1... Done.

 Configuring GigabitEthernet4/0/2... Done.

 Configuring GigabitEthernet4/0/3... Done.

[Sysname-Bridge-Aggregation1] port hybrid ip-subnet-vlan vlan 3

接口GigabitEthernet4/0/1、GigabitEthernet4/0/2和GigabitEthernet4/0/3是二层聚合接口1的成员端口。

 


2 Super VLAN

说明

Super VLAN仅在SAP板工作在二层模式时支持。

 

2.1  Super VLAN配置命令

2.1.1  display supervlan

【命令】

display supervlan [ supervlan-id ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

supervlan-id:Super VLAN的编号,取值范围为1~4094。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display supervlan命令用来显示Super VLAN和Sub VLAN的映射关系,以及标识Super VLAN和Sub VLAN映射关系的端口。

相关配置可参考命令supervlansubvlan

【举例】

# 显示Super VLAN和Sub VLAN的映射关系。

<Sysname> display supervlan 2

 Supervlan ID :  2

 Subvlan ID :  3-5

 

 VLAN ID: 2

 VLAN Type: static

 It is a Super VLAN.

 Route Interface: configured

 IP Address: 10.153.17.41

 Subnet Mask: 255.255.252.0

 Description: VLAN 0002

 Name: VLAN 0002

 Tagged   Ports: none

 Untagged Ports: none

 

 VLAN ID: 3

 VLAN Type: static

 It is a Sub VLAN.

 Route Interface: configured

 IP Address: 10.153.17.41

 Subnet Mask: 255.255.252.0

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged   Ports: none

 Untagged Ports:

             GigabitEthernet4/0/3

 

 VLAN ID: 4

 VLAN Type: static

 It is a Sub VLAN.

 Route Interface: configured

 IP Address: 10.153.17.41

 Subnet Mask: 255.255.252.0

 Description: VLAN 0004

 Name: VLAN 0004

 Tagged   Ports: none

 Untagged Ports:

             GigabitEthernet4/0/4

 

 VLAN ID: 5

 VLAN Type: static

 It is a Sub VLAN.

 Route Interface: configured

 IP Address: 10.153.17.41

 Subnet Mask: 255.255.252.0

 Description: VLAN 0005

 Name: VLAN 0005

 Tagged   Ports: none

 Untagged Ports:

             GigabitEthernet4/0/5 

表2-1 display supervlan命令显示信息描述表

字段

描述

Supervlan ID

Super VLAN的编号

Subvlan ID

Sub VLAN的编号

VLAN ID

VLAN编号

VLAN Type

VLAN类型(静态VLAN、动态VLAN等)

It is a Super VLAN

当前VLAN是Super VLAN

It is a Sub VLAN

当前VLAN是Sub VLAN

Route Interface

VLAN是否配置了VLAN接口:not configured(没有配置)/configured(配置了)(Sub VLAN的此字段值同Super VLAN)

IP Address

VLAN接口的IP地址(Sub VLAN的此字段值同Super VLAN,如果Super VLAN没有配置VLAN接口,则不显示该字段)

Subnet Mask

VLAN接口的子网掩码(Sub VLAN的此字段值同Super VLAN,如果Super VLAN没有配置VLAN接口,则不显示该字段)

Description

VLAN的描述

Name

VLAN的名称

Tagged   Ports

标识该VLAN报文在哪些端口上需要打Tag标记

Untagged Ports

标识该VLAN报文在哪些端口上不需要打Tag标记

 

2.1.2  subvlan

【命令】

subvlan vlan-list

undo subvlan [ vlan-list ]

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

vlan-list:Sub VLAN列表,表示方式为vlan-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>。其中,vlan-id表示Sub VLAN的VLAN ID,取值范围为1~4094。&<1-10>表示前面的参数最多可以重复输入10次。

【描述】

subvlan命令用来建立Super VLAN和Sub VLAN间的映射关系。当前VLAN为Super VLAN,vlan-list参数里指定的VLAN为Sub VLAN。undo subvlan命令用来取消Sub VLAN和Super VLAN间的映射关系。

需要注意的是:

·     配置Super VLAN中包含的Sub VLAN前,Sub VLAN必须已经创建。

·     在建立了Sub VLAN和Super VLAN的映射关系后,仍可以向Sub VLAN中添加和删除接口。

·     undo subvlan命令如果不带参数的话,就解除所有Sub VLAN和指定Super VLAN之间的映射关系;如果带有参数的话就解除参数指定的Sub VLAN和当前Super VLAN之间的映射关系。

相关配置可参考命令display supervlan

【举例】

# 将Super VLAN10和Sub VLAN3、4、5、9对应起来。

<Sysname> system-view

[Sysname] vlan 10

[Sysname-vlan10] subvlan 3 to 5 9

2.1.3  supervlan

【命令】

supervlan

undo supervlan

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

【描述】

supervlan命令用来设置当前VLAN的类型为Super VLAN。undo supervlan命令用来取消一个VLAN的Super VLAN类型的设置。

需要注意的是:

·     如果某个VLAN被指定为Super VLAN,则该VLAN不能被指定为某个端口的Guest VLAN;同样,如果某个VLAN被指定为某个端口的Guest VLAN,则该VLAN不能被指定为Super VLAN。关于Guest VLAN的相关内容请参见“安全配置指导”中的“802.1X”。

·     在Super VLAN下可以配置二层组播功能,但是该配置将不会生效。

·     在Super VLAN对应的VLAN接口下可以配置DHCP、三层组播、动态路由、NAT等功能,但是只有DHCP的配置生效,其它配置将不会生效。

·     在Super VLAN对应的VLAN接口下配置VRRP功能后,会对网络性能造成影响,建议不要这样配置。

相关配置可参考命令display supervlan

【举例】

# 将VLAN2配置为Super VLAN。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] supervlan

 


3 Voice VLAN

说明

Voice VLAN仅在SAP板工作在二层模式时支持。

 

3.1  Voice VLAN配置命令

3.1.1  display voice vlan oui

【命令】

display voice vlan oui [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display voice vlan oui命令用来显示Voice VLAN当前支持的OUI地址、OUI地址掩码和描述信息。

相关配置可参考命令voice vlan mac-address

说明

通常意义下,OUI地址指的是MAC地址的前24位(二进制),是IEEE为不同设备供应商分配的一个全球唯一的标识符。本文中的OUI有别于通常意义的OUI地址,它是设备判断收到的报文是否为语音报文的依据,是voice vlan mac-address命令中的mac-addressoui-mask参数相与的结果。

 

【举例】

# 显示Voice VLAN的OUI地址、OUI地址掩码和描述信息。

<Sysname> display voice vlan oui

Oui Address     Mask            Description

0001-e300-0000  ffff-ff00-0000  Siemens phone

0003-6b00-0000  ffff-ff00-0000  Cisco phone

0004-0d00-0000  ffff-ff00-0000  Avaya phone

00d0-1e00-0000  ffff-ff00-0000  Pingtel phone

0060-b900-0000  ffff-ff00-0000  Philips/NEC phone

00e0-7500-0000  ffff-ff00-0000  Polycom phone

00e0-bb00-0000  ffff-ff00-0000  3com phone

表3-1 display voice vlan oui命令显示信息描述表

字段

描述

Oui Address

设备当前允许通过的OUI地址

Mask

设备当前允许通过的OUI地址的掩码

Description

设备当前允许通过的OUI地址的描述

 

3.1.2  display voice vlan state

【命令】

display voice vlan state [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display voice vlan state命令用来显示Voice VLAN的配置信息。

相关配置可参考命令voice vlan enable、voice vlan qosvoice vlan qos trust

【举例】

# 显示Voice VLAN的配置信息。

<Sysname> display voice vlan state

 Maximum of Voice VLANs: 128

 Current Voice VLANs: 2

 Voice VLAN security mode: Security

 Voice VLAN aging time: 1440 minutes

 Voice VLAN enabled port and its mode:

 PORT                        VLAN        MODE        COS        DSCP

 --------------------------------------------------------------------

GigabitEthernet4/0/1          2           AUTO        6          46

GigabitEthernet4/0/2          3           AUTO        6          46

表3-2 display voice vlan state命令显示信息描述表

字段

描述

Maximum of Voice VLANs

系统支持Voice VLAN的最大数量

Current Voice VLANs

已创建Voice VLAN的数量

Voice VLAN security mode

Voice VLAN的安全模式的开启状态:Security表示当前使用的是安全模式;Normal表示当前使用的是普通模式

Voice VLAN aging time

Voice VLAN的老化时间

Voice VLAN enabled port and its mode

当前使能了Voice VLAN的端口及其工作模式

PORT

当前使能了Voice VLAN的端口编号

VLAN

端口使能的Voice VLAN ID

MODE

端口Voice VLAN的工作模式:MANUAL表示手工模式;AUTO表示自动模式

COS

服务级别

DSCP

差分服务编码点优先级

 

3.1.3  voice vlan aging

【命令】

voice vlan aging minutes

undo voice vlan aging

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

minutes:Voice VLAN的老化时间,取值范围为5~43200,单位为分钟。

【描述】

voice vlan aging命令用来设置Voice VLAN的老化时间。undo voice vlan aging命令用来恢复缺省情况。

缺省情况下,Voice VLAN的老化时间为1440分钟。

在自动模式下,系统会根据收到的语音报文的源MAC地址,来决定是否把该报文的入端口加入Voice VLAN。在将入端口加入Voice VLAN后,系统会同时启动老化定时器。经过老化时间后,如果设备没有从该端口收到任何语音报文,老化时间到达后系统会自动把该端口从Voice VLAN中删除。该老化时间只对Voice VLAN工作在自动模式的端口有效,对Voice VLAN工作在手工模式的端口无效。

相关配置可参考命令display voice vlan state

【举例】

# 将Voice VLAN的老化时间配置为100分钟。

<Sysname> system-view

[Sysname] voice vlan aging 100

3.1.4  voice vlan enable

【命令】

voice vlan vlan-id enable

undo voice vlan [ vlan-id ] enable

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定Voice VLAN编号,取值范围为2~4094。

【描述】

voice vlan vlan-id enable命令用来使能以太网接口的Voice VLAN功能。undo voice vlan enable命令用来关闭以太网接口的Voice VLAN功能。

缺省情况下,接口没有使能Voice VLAN功能。

需要注意的是,当端口的Voice VLAN工作在自动模式时,只有Trunk或者Hybrid类型接口支持使能Voice VLAN功能。

【举例】

# 使能端口GigabitEthernet4/0/1的Voice VLAN功能。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] voice vlan 2 enable

3.1.5  voice vlan mac-address

【命令】

voice vlan mac-address mac-address mask oui-mask [ description text ]

undo voice vlan mac-address oui

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

mac-address:语音报文的源MAC地址,格式为H-H-H,如:1234-1234-1234。

mask oui-mask:OUI地址的有效长度,用掩码表示,格式为H-H-H。由连续的1和连续的0组成,表示OUI地址的匹配长度。如:FFFF-0000-0000,如果要过滤某个设备厂商的语音设备,可以设置为FFFF-FF00-0000。

description text:OUI地址的描述字符串,长度为1~30,区分大小写。

oui:指定要删除的OUI地址,格式为H-H-H,如1234-1200-0000。OUI地址不能是广播地址或者组播地址,也不能是全0的地址。OUI地址是mac-addressoui-mask参数相与的结果。可以通过display voice vlan oui命令查看当前系统支持的OUI地址的信息。

【描述】

voice vlan mac-address命令用来设置允许指定OUI地址的报文通过Voice VLAN。undo voice vlan mac-address命令用来取消指定OUI地址的报文通过Voice VLAN。

缺省情况下,系统已配置有OUI地址,如表3-3所示。该地址可以手工删除,删除之后也可再次手工添加。

表3-3 缺省的OUI地址

序号

OUI地址

生产厂商

1

0001-E300-0000

Siemens phone

2

0003-6B00-0000

Cisco phone

3

0004-0D00-0000

Avaya phone

4

00D0-1E00-0000

Pingtel phone

5

0060-B900-0000

Philips/NEC phone

6

00E0-7500-0000

Polycom phone

7

00E0-BB00-0000

3Com phone

 

需要注意的是,系统最多支持配置16个OUI地址。

相关配置可参考命令display voice vlan oui

【举例】

# 设置允许来自IP电话PhoneA(MAC地址为1234-1234-1234)的语音流通过Voice VLAN。

<Sysname> system-view

[Sysname] voice vlan mac-address 1234-1234-1234 mask ffff-ff00-0000 description PhoneA

3.1.6  voice vlan mode auto

【命令】

voice vlan mode auto

undo voice vlan mode auto

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

voice vlan mode auto命令用来配置端口的Voice VLAN的工作模式为自动模式。undo voice vlan mode auto命令用来配置端口的Voice VLAN的工作模式为手工模式。

缺省情况下,端口的Voice VLAN的工作模式为自动模式。

需要注意的是:

·     各个端口Voice VLAN的工作模式相互独立,不同的端口可以设置成不同的模式。

·     当端口使能了Voice VLAN并工作在手工模式时,必须手工将端口加入Voice VLAN,才能保证Voice VLAN功能生效。

【举例】

# 将端口GigabitEthernet4/0/1的Voice VLAN的工作模式设置为手工模式。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] undo voice vlan mode auto

3.1.7  voice vlan qos

【命令】

voice vlan qos cos-value dscp-value

undo voice vlan qos

【视图】

接口视图

【缺省级别】

2:系统级

【参数】

cos-value:设置语音报文服务等级CoS值,缺省值为6。

dscp-value:设置语音报文差分服务编码点优先级DSCP值,缺省值为46。

【描述】

voice vlan qos命令用来将Voice VLAN内语音报文的CoS和DSCP修改为指定值。undo voice vlan qos命令用来恢复缺省情况。

缺省情况下,接口会将Voice VLAN内语音报文的CoS值修改为6,DSCP值修改为46。

需要注意的是:

·     在Voice VLAN使能的情况下,不允许配置/修改语音报文的QoS优先级。必须禁用Voice VLAN后,才能配置/修改。

·     如果对于同一接口多次执行voice vlan qosvoice vlan qos trust命令,最后配置的值生效。

相关配置可参考命令voice vlan qos trust

【举例】

# 配置以太网接口GigabitEthernet4/0/1收到Voice VLAN内的语音报文时,将报文的CoS值修改为5,DSCP值修改为45。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] voice vlan qos 5 45

3.1.8  voice vlan qos trust

【命令】

voice vlan qos trust

undo voice vlan qos

【视图】

接口视图

【缺省级别】

2:系统级

【参数】

【描述】

voice vlan qos trust命令用来配置接口信任语音报文的优先级,即接口不会修改Voice VLAN内语音报文自带的CoS和DSCP值。undo voice vlan qos命令用来恢复缺省情况。

缺省情况下,接口会将Voice VLAN内语音报文的CoS值修改为6,DSCP值修改为46。

需要注意的是:

·     在Voice VLAN使能的情况下,不允许配置/修改语音报文的QoS优先级。必须禁用Voice VLAN后,才能配置/修改。

·     如果对于同一接口多次执行voice vlan qosvoice vlan qos trust命令,最后配置的值生效。

相关配置可参考命令voice vlan qos

【举例】

# 配置以太网接口GigabitEthernet4/0/1信任语音报文的优先级。语音报文进入设备后,CoS和DSCP值保持不变。

<Sysname> system-view

[Sysname] interface GigabitEthernet 4/0/1

[Sysname-GigabitEthernet4/0/1] voice vlan qos trust

3.1.9  voice vlan security enable

【命令】

voice vlan security enable

undo voice vlan security enable

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

【描述】

voice vlan security enable命令用来使能Voice VLAN的安全模式。undo voice vlan security enable命令用来关闭Voice VLAN的安全模式。

缺省情况下,Voice VLAN工作在安全模式。

在安全模式下,Voice VLAN中只能有语音流量。用户设置Voice VLAN为安全模式以后,该VLAN的报文都经过过滤,设备会根据报文的源MAC地址是否匹配OUI地址来过滤所有非语音流量,增加安全性保证语音流的优先级,保证通话质量。在普通模式下,Voice VLAN中允许有业务流量和语音流量并存。

缺省情况下,Voice VLAN工作在安全模式。

【举例】

# 关闭Voice VLAN的安全模式。

<Sysname> system-view

[Sysname] undo voice vlan security enable

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!