国家 / 地区

09-MPLS配置指导

11-L2VPN接入L3VPN或IP骨干网配置

本章节下载  (274.83 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/SR_Router/SR6600-X/Configure/Operation_Manual/H3C_SR6600_SR6600-X_CG(V7)-6W102/09/201512/903412_30005_0.htm

11-L2VPN接入L3VPN或IP骨干网配置


1 L2VPN接入L3VPN或IP骨干网

提供点到点连接的MPLS L2VPN技术和提供多点间连接的VPLS技术均支持L2VPN接入L3VPN或IP骨干网功能。MPLS L2VPN的详细介绍,请参见“MPLS配置指导”中的“MPLS L2VPN”;VPLS的详细介绍,请参见“MPLS配置指导”中的“VPLS”;MPLS L3VPN的详细介绍,请参见“MPLS配置指导”中的“MPLS L3VPN”。

本文中除特殊说明外,MPLS L2VPN均指提供点到点连接的MPLS L2VPN技术和提供多点间连接的VPLS技术的统称。

1.1  L2VPN接入L3VPN或IP骨干网简介

MPLS L2VPN提供了基于MPLS网络的二层VPN服务,用来在MPLS网络上透明传输用户二层数据。MPLS L2VPN网络对用户来说是透明的,通过MPLS L2VPN隧道连接的用户可以看作是通过物理线路直接相连。

MPLS L2VPN可以作为接入网将用户接入到MPLS L3VPN或IP骨干网。MPLS L2VPN作为接入网具有如下优势:

·     MPLS L2VPN对于用户是透明的,可以看作是用户以直连方式直接接入骨干网。

·     用户及用户业务的识别只需在MPLS L2VPN网络的边缘设备PE上进行,MPLS L2VPN网络中的P设备只需根据标签转发报文,从而简化了接入网中P设备的处理。P设备可以是较低端的设备,降低了组网成本。

·     MPLS L2VPN支持多种用户接入方式(如以太网、ATM、帧中继接入),并支持连接异构网络,因此组网方式更加灵活。

·     用户无法直接接入运营商提供的MPLS L3VPN网络时,通过在用户网络和MPLS L3VPN网络之间部署MPLS L2VPN,可以实现为用户网络提供MPLS L3VPN服务。

L2VPN接入L3VPN或IP骨干网的实现方式有两种:传统组网方式和改进组网方式。

1.1.1  传统的L2VPN接入L3VPN或IP骨干网组网方式

图1-1 传统的L2VPN接入L3VPN或IP骨干网组网图

 

图1-1所示,PE 1和PE 2为MPLS L2VPN网络的PE设备,PE 1连接VPN 1的用户站点Site 1,PE 2连接MPLS L3VPN网络或IP骨干网络的PE设备PE 3。PE 3同时作为MPLS L3VPN网络的PE设备和MPLS L2VPN网络的CE设备。在传统组网方式中,VPN 1内用户通过MPLS L2VPN接入MPLS L3VPN或IP骨干网的方法为:

(1)     用户通过PE 1接入MPLS L2VPN。

(2)     PE 1与PE 2之间建立PW连接,通过该PW透明地传递用户的二层报文。

(3)     PE 2作为MPLS L2VPN的终结点,终结MPLS L2VPN报文,即删除报文中的MPLS标签,还原原始的二层报文,并将该报文发送给与其相连的CE设备,即PE 3。

(4)     PE 3同时作为MPLS L2VPN网络的CE设备和MPLS L3VPN或IP骨干网的接入点。PE 3接收到PE 2的二层报文后,查找路由,并通过MPLS L3VPN或IP骨干网将报文转发给目的用户。

1.1.2  改进的L2VPN接入L3VPN或IP骨干网组网方式

在传统的组网方式中,MPLS L2VPN和MPLS L3VPN(或IP骨干网)的连接处,需要部署两台设备,分别用来终结MPLS L2VPN和接入MPLS L3VPN(或IP骨干网)。在改进组网方式中,由一台设备实现该功能,从而减少网络中部署的设备数量,降低组网成本和网络部署的复杂度。

图1-2 改进的L2VPN接入L3VPN或IP骨干网组网图

 

图1-2所示,连接MPLS L2VPN和MPLS L3VPN(或IP骨干网)的设备PE-agg(PE Aggregation,聚合PE)上实现了图1-1中PE 2和PE 3的功能,既可以用来终结MPLS L2VPN,也可以用来接入骨干网。PE-agg通过以下方法实现上述功能:

·     PE-agg上创建一个用于终结MPLS L2VPN报文的VE(Virtual Ethernet,虚拟以太网)接口,即VE-L2VPN(简称L2VE)接口。该接口的功能和配置,与MPLS L2VPN网络中PE连接CE的接口(即图1-1中的接口Terminating int)类似。

·     PE-agg上创建一个用于将报文接入骨干网的VE接口,即VE-L3VPN(简称L3VE)接口。该接口的功能和配置,与骨干网中PE连接CE的接口(即图1-1中的接口Access int)类似。该接口的IP地址需要与CE 1的IP地址在同一个网段。MPLS L3VPN作为骨干网时,L3VE接口上需要绑定VPN实例,以便通过私网路由转发用户报文。

·     L2VE接口将还原的原始二层报文直接转交给相同接口编号的L3VE接口。与图1-1中Terminating int和Access int通过橙色的物理线路连接类似,相同接口编号的L2VE和L3VE接口就好像是通过物理线路直接相连。

说明

PE-agg通过L2VE接口和L3VE接口实现MPLS L2VPN和骨干网的连接,可以认为MPLS L2VPN连接骨干网的链路层类型是Ethernet或VLAN,如果用户接入MPLS L2VPN的链路类型不是Ethernet或VLAN,则需要在用户接入的PE设备(PE 1)和PE-agg的L2VE接口上配置MPLS L2VPN连接异构网络。

 

1.2  配置传统的L2VPN接入L3VPN或IP骨干网组网方式

图1-1为例,传统的L2VPN接入L3VPN或IP骨干网组网方式的配置方法为:

·     配置MPLS L2VPN。其中,PE 1和PE 2为MPLS L2VPN网络的PE设备,CE 1和PE 3为MPLS L2VPN网络的CE设备。MPLS L2VPN配置的详细介绍,请参见“MPLS配置指导”中的“MPLS L2VPN”和“VPLS”。

·     配置MPLS L3VPN或IP骨干网。其中,PE 3和PE 4为MPLS L3VPN或IP网络的PE设备,CE 1和CE 2为MPLS L3VPN或IP网络的CE设备。MPLS L3VPN配置的详细介绍,请参见“MPLS配置指导”中的“MPLS L3VPN”。

1.3  配置改进的L2VPN接入L3VPN或IP骨干网组网方式

图1-2所示,改进的L2VPN接入L3VPN或IP骨干网组网方式中,PE 1、PE 4、CE 1和CE 2的配置方法与传统组网方式相同。PE-agg集合了PE 2和PE 3的功能,配置方法为:

·     创建相同编号的L2VE接口和L3VE接口。

·     配置MPLS L2VPN功能:详细介绍请参见“MPLS配置指导”中的“MPLS L2VPN”和“VPLS”。

·     配置MPLS L3VPN功能或IP路由:MPLS L3VPN配置的详细介绍,请参见“MPLS配置指导”中的“MPLS L3VPN”。

1.3.1  配置L2VE接口

表1-1 配置L2VE接口

操作

命令

说明

进入系统视图

system-view

-

创建一个L2VE接口,并进入L2VE接口视图

interface ve-l2vpn interface-number

缺省情况下,设备上不存在任何L2VE接口

设备上最多可以创建8192个L2VE接口

(可选)配置接口的描述信息

description text

缺省情况下,接口的描述信息为“接口名 Interface”,例如:VE-L2VPN100 Interface

(可选)配置接口的MTU

mtu mtu-value

缺省情况下,接口的MTU为1500

(可选)配置接口的期望带宽

bandwidth bandwidth-value

缺省情况接口的期望带宽为100000kbps

(可选)恢复当前接口的缺省配置

default

-

(可选)开启当前接口

undo shutdown

缺省情况下,接口处于开启状态

 

1.3.2  配置L3VE接口

表1-2 配置L3VE接口

操作

命令

说明

进入系统视图

system-view

-

创建一个L3VE接口,并进入L3VE接口视图

interface ve-l3vpn interface-number

缺省情况下,设备上不存在任何L3VE接口

设备上最多可以创建8192个L3VE接口

(可选)退回系统视图

quit

只有创建L3VE接口的子接口时,需要执行本命令

(可选)创建L3VE接口的子接口,并进入L3VE子接口视图

interface ve-l3vpn interface-number.subnumber

缺省情况下,设备上不存在任何L3VE子接口

当接入MPLS L3VPN或IP骨干网的报文带有VLAN Tag时,需要创建L3VE接口的子接口,以便终结报文中的VLAN Tag

VLAN终结的详细介绍,请参见“二层技术-以太网交换配置指导”中的“VLAN终结”

一个L3VE接口上可以创建1024个子接口

(可选)配置接口的描述信息

description text

缺省情况下,接口的描述信息为“接口名 Interface”,例如:VE-L3VPN100 Interface

(可选)配置接口的MTU

mtu mtu-value

缺省情况下,接口的MTU为1500

(可选)设置接口的期望带宽

bandwidth bandwidth-value

缺省情况下,接口的期望带宽为100000kbps

(可选)恢复当前接口的缺省配置

default

-

(可选)开启当前接口

undo shutdown

缺省情况下,接口处于开启状态

 

1.4  L2VPN接入L3VPN或IP骨干网显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示L2VE接口和L3VE接口的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除接口的统计信息。

表1-3 L2VPN接入L3VPN或IP骨干网显示和维护

操作

命令

显示L2VE接口或L3VE接口的相关信息

display interface [ ve-l2vpn [ interface-number ] | ve-l3vpn [ interface-number | interface-number.subnumber ] ] [ brief [ description | down ] ]

清除接口的统计信息

reset counters interface [ ve-l2vpn [ interface-number ] | ve-l3vpn [ interface-number | interface-number.subnumber ] ]

 

1.5  改进的L2VPN接入L3VPN或IP骨干网组网方式典型配置举例

1.5.1  LDP方式异构MPLS L2VPN接入MPLS L3VPN配置举例

说明

本例中的MPLS L2VPN特指点到点的MPLS L2VPN。

 

1. 组网需求

·     MPLS L3VPN网络作为骨干网,通过BGP发布VPN路由,并根据MPLS标签在骨干网上转发VPN报文。

·     CE 1和CE 2属于VPN 1。VPN 1的VPN Target属性为111:1,RD为200:1。

·     CE 1通过链路层封装协议为PPP的POS接口接入MPLS L2VPN,在PE 1和PE-agg之间建立LDP方式的PW,以便CE 1通过MPLS L2VPN接入MPLS L3VPN。由于CE 1接入MPLS L2VPN的链路类型不是Ethernet或VLAN,因此,需要在PE 1的接口POS2/1/0和PE-agg的L2VE接口上配置MPLS L2VPN连接异构网络。

·     CE 2通过以太网接口直接接入MPLS L3VPN。

·     CE 1与PE-agg之间、CE 2与PE 2之间配置EBGP交换VPN路由信息。

·     PE-agg与PE 2之间配置IS-IS实现PE之间的互通、并配置MP-IBGP交换VPN路由信息。

·     PE 1、P、PE-agg之间配置OSPF实现PE之间的互通。

2. 组网图

图1-3 LDP方式异构MPLS L2VPN接入MPLS L3VPN组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

S2/0

100.1.1.1/24

PE-agg

Loop0

3.3.3.9/32

PE 1

Loop0

1.1.1.9/32

 

POS2/1/0

10.2.2.2/24

 

POS2/1/0

10.2.1.1/24

 

POS2/1/1

10.3.3.1/24

P

Loop0

2.2.2.9/32

 

VE-L3VPN1

100.1.1.2/24

 

POS2/1/0

10.2.1.2/24

PE 2

Loop0

4.4.4.9/32

 

POS2/1/1

10.2.2.1/24

 

POS2/1/0

10.3.3.2/24

CE 2

GE2/0/1

100.2.1.2/24

 

GE2/0/1

100.2.1.1/24

 

3. 配置步骤

(1)     按照图1-3配置各设备接口的IP地址,包括物理接口和Loopback接口,具体配置过程略。

(2)     在PE-agg上创建相同接口编号的接口VE-L2VPN 1和VE-L3VPN 1。

# 创建接口VE-L2VPN 1。

<PEagg> system-view

[PEagg] interface ve-l2vpn 1

[PEagg-VE-L2VPN1] quit

# 创建接口VE-L3VPN 1。

[PEagg] interface ve-l3vpn 1

[PEagg-VE-L3VPN1] quit

(3)     配置MPLS L2VPN功能

·     在PE 1、PPE-agg上配置OSPF,发布接口地址对应的路由

# 在PE 1上配置OSPF。

<PE1> system-view

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在P上配置OSPF。

<P> system-view

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0

[P-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

# 在PE-agg上配置OSPF。

[PEagg] ospf

[PEagg-ospf-1] area 0

[PEagg-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0

[PEagg-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PEagg-ospf-1-area-0.0.0.0] quit

[PEagg-ospf-1] quit

·     在PE 1、P、PE-agg上配置MPLS基本功能和MPLS LDP

# 配置PE 1。

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] lsp-trigger all

[PE1-ldp] quit

[PE1] interface pos 2/1/0

[PE1-Pos2/1/0] mpls enable

[PE1-Pos2/1/0] mpls ldp enable

[PE1-Pos2/1/0] quit

# 配置P。

[P] mpls lsr-id 2.2.2.9

[P] mpls ldp

[P-ldp] lsp-trigger all

[P-ldp] quit

[P] interface pos 2/1/0

[P-Pos2/1/0] mpls enable

[P-Pos2/1/0] mpls ldp enable

[P-Pos2/1/0] quit

[P] interface pos 2/1/1

[P-Pos2/1/1] mpls enable

[P-Pos2/1/1] mpls ldp enable

[P-Pos2/1/1] quit

# 配置PE-agg。

[PEagg] mpls lsr-id 3.3.3.9

[PEagg] mpls ldp

[PEagg-ldp] lsp-trigger all

[PEagg-ldp] quit

[PEagg] interface pos 2/1/0

[PEagg-Pos2/1/0] mpls enable

[PEagg-Pos2/1/0] mpls ldp enable

[PEagg-Pos2/1/0] quit

·     在PE 1和PE-agg上使能L2VPN

# 配置PE 1。

[PE1] l2vpn enable

# 配置PE-agg。

[PEagg] l2vpn enable

·     配置PE与CE连接的接口,创建连接异构网络的PW,并将接口(AC)与PW关联

# 在PE 1连接CE 1的接口POS2/1/0上配置PPP支持IPCP无地址协商。在交叉连接组内创建连接异构网络的PW,并将接口POS2/1/0与该PW关联。

[PE1] interface pos 2/1/0

[PE1-Pos2/1/0] link-protocol ppp

[PE1-Pos2/1/0] ppp ipcp ignore local-ip

[PE1-Pos2/1/0] quit

[PE1] xconnect-group 1

[PE1-xcg-1] connection 1

[PE1-xcg-1-1] ac interface pos 2/1/0

[PE1-xcg-1-1] interworking ipv4

[PE1-xcg-1-1] peer 3.3.3.9 pw-id 101

[PE1-xcg-1-1-3.3.3.9-101] quit

# 在PE-agg的L2VE接口上配置缺省下一跳的IP地址为100.1.1.2。在交叉连接组内创建连接异构网络的PW,并将L2VE接口与该PW关联。

[PEagg] interface ve-l2vpn 1

[PEagg-VE-L2VPN1] default-nexthop ip 100.1.1.2

[PEagg-VE-L2VPN1] quit

[PEagg] xconnect-group 1

[PEagg-xcg-1] connection 1

[PEagg-xcg-1-1] ac interface ve-l2vpn 1

[PEagg-xcg-1-1] interworking ipv4

[PEagg-xcg-1-1] peer 1.1.1.9 pw-id 101

[PEagg-xcg-1-1-1.1.1.9-101] quit

·     配置CE 1上的接口

# 配置CE 1连接PE 1的接口POS 2/1/0。

<CE1> system-view

[CE1] interface pos 2/1/0

[CE1-Pos2/1/0] link-protocol ppp

[CE1-Pos2/1/0] ip address 100.1.1.1 24

(4)     配置MPLS L3VPN功能

·     在PE-agg和PE 2上配置IS-IS,发布接口地址对应的路由

# 配置PE-agg。

[PEagg] isis 1

[PEagg-isis-1] network-entity 10.0000.0000.0001.00

[PEagg-isis-1] quit

[PEagg] interface pos 2/1/1

[PEagg-Pos2/1/1] isis enable 1

[PEagg-Pos2/1/1] quit

[PEagg] interface loopback 0

[PEagg-LoopBack0] isis enable 1

[PEagg-LoopBack0] quit

# 配置PE 2。

[PE2] isis 1

[PE2-isis-1] network-entity 10.0000.0000.0002.00

[PE2-isis-1] quit

[PE2] interface pos 2/1/0

[PE2-Pos2/1/0] isis enable 1

[PE2-Pos2/1/0] quit

[PE2] interface loopback 0

[PE2-LoopBack0] isis enable 1

[PE2-LoopBack0] quit

·     在PE-agg和PE 2上配置MPLS基本功能和MPLS LDP

# 配置PE-agg。

[PEagg] interface pos 2/1/1

[PEagg-Pos2/1/1] mpls enable

[PEagg-Pos2/1/1] mpls ldp enable

[PEagg-Pos2/1/1] quit

# 配置PE 2。

[PE2] mpls lsr-id 4.4.4.9

[PE2] mpls ldp

[PE2-ldp] lsp-trigger all

[PE2-ldp] quit

[PE2] interface pos 2/1/0

[PE2-Pos2/1/0] mpls enable

[PE2-Pos2/1/0] mpls ldp enable

[PE2-Pos2/1/0] quit

·     在PE-agg和PE 2上创建VPN实例VPN1,并在CE接入的接口上绑定该VPN实例

# 配置PE-agg。

[PEagg] ip vpn-instance VPN1

[PEagg-vpn-instance-VPN1] route-distinguisher 200:1

[PEagg-vpn-instance-VPN1] vpn-target 111:1 both

[PEagg-vpn-instance-VPN1] quit

[PEagg] interface ve-l3vpn 1

[PEagg-VE-L3VPN1] ip binding vpn-instance VPN1

[PEagg-VE-L3VPN1] ip address 100.1.1.2 24

# 配置PE 2。

[PE2] ip vpn-instance VPN1

[PE2-vpn-instance-VPN1] route-distinguisher 200:1

[PE2-vpn-instance-VPN1] vpn-target 111:1 both

[PE2-vpn-instance-VPN1] quit

[PE2] interface gigabitethernet 2/0/1

[PE2-GigabitEthernet2/0/1] ip binding vpn-instance VPN1

[PE2-GigabitEthernet2/0/1] ip address 100.2.1.1 24

[PE2-GigabitEthernet2/0/1] quit

·     在PE与CE之间建立EBGP对等体关系,引入VPN路由

# 配置CE 1,其对等体为PE-agg。

<CE1> system-view

[CE1] bgp 65010

[CE1-bgp] peer 100.1.1.2 as-number 100

[CE1-bgp] address-family ipv4

[CE1-bgp-ipv4] peer 100.1.1.2 enable

[CE1-bgp-ipv4] import-route direct

[CE1-bgp-ipv4] quit

[CE1-bgp] quit

# 配置PE-agg,其对等体为CE 1。

[PEagg] bgp 100

[PEagg-bgp] ip vpn-instance VPN1

[PEagg-bgp-VPN1] peer 100.1.1.1 as-number 65010

[PEagg-bgp-VPN1] address-family ipv4

[PEagg-bgp-ipv4-VPN1] peer 100.1.1.1 enable

[PEagg-bgp-ipv4-VPN1] import-route direct

[PEagg-bgp-ipv4-VPN1] quit

[PEagg-bgp-VPN1] quit

[PEagg-bgp] quit

# 配置CE 2,其对等体为PE 2。

[CE2] bgp 65020

[CE2-bgp] peer 100.2.1.1 as-number 100

[CE2-bgp] address-family ipv4

[CE2-bgp-ipv4] peer 100.2.1.1 enable

[CE2-bgp-ipv4] import-route direct

[CE2-bgp-ipv4] quit

[CE2-bgp] quit

# 配置PE 2,其对等体为CE 2。

[PE2] bgp 100

[PE2-bgp] ip vpn-instance VPN1

[PE2-bgp-VPN1] peer 100.2.1.2 as-number 65020

[PE2-bgp-VPN1] address-family ipv4

[PE2-bgp-ipv4-VPN1] peer 100.2.1.2 enable

[PE2-bgp-ipv4-VPN1] import-route direct

[PE2-bgp-ipv4-VPN1] quit

[PE2-bgp-VPN1] quit

[PE2-bgp] quit

·     在PE-agg与PE 2之间建立MP-IBGP对等体关系

# 配置PE-agg。

[PEagg] bgp 100

[PEagg-bgp] peer 4.4.4.9 as-number 100

[PEagg-bgp] peer 4.4.4.9 connect-interface loopback 0

[PEagg-bgp] address-family vpnv4

[PEagg-bgp-vpnv4] peer 4.4.4.9 enable

[PEagg-bgp-vpnv4] quit

[PEagg-bgp] quit

# 配置PE 2。

[PE2] bgp 100

[PE2-bgp] peer 3.3.3.9 as-number 100

[PE2-bgp] peer 3.3.3.9 connect-interface loopback 0

[PE2-bgp] address-family vpnv4

[PE2-bgp-vpnv4] peer 3.3.3.9 enable

[PE2-bgp-vpnv4] quit

[PE2-bgp] quit

(5)     由于不同类型接口的缺省MTU值不同,为了避免对报文进行分片,将各设备上POS接口的MTU值配置为以太网接口的缺省MTU值1500

# 以PE 1为例,说明配置POS接口的MTU配置方法。其他设备上的配置与其类似,配置过程省略。

[PE1] interface pos 2/1/0

[PE1-Pos2/1/0] mtu 1500

[PE1-Pos2/1/0] shutdown

[PE1-Pos2/1/0] undo shutdown

4. 验证配置

# CE1与CE2之间能够互通,以CE1为例。

<CE1> ping 100.2.1.2

Ping 100.2.1.2 (100.2.1.2): 56 data bytes, press CTRL_C to break

56 bytes from 100.2.1.2: icmp_seq=0 ttl=128 time=1.073 ms

56 bytes from 100.2.1.2: icmp_seq=1 ttl=128 time=1.428 ms

56 bytes from 100.2.1.2: icmp_seq=2 ttl=128 time=19.367 ms

56 bytes from 100.2.1.2: icmp_seq=3 ttl=128 time=1.013 ms

56 bytes from 100.2.1.2: icmp_seq=4 ttl=128 time=0.684 ms

 

--- Ping statistics for 100.2.1.2 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 0.684/4.713/19.367/7.331 ms

1.5.2  LDP方式VPLS接入IP骨干网配置举例

1. 组网需求

·     IP网络作为骨干网,转发用户的报文。

·     CE 1通过以太网接口接入VPLS网络,在PE 1和PE-agg之间建立LDP方式的PW,以便CE 1通过PW接入IP骨干网。

·     CE 2通过以太网接口直接接入IP骨干网。

·     IP骨干网中通过OSPF进程2发布路由信息。

2. 组网图

图1-4 LDP方式VPLS接入IP骨干网组网图

设备

接口

IP地址

设备

接口

IP地址

CE 1

GE2/0/1

100.1.1.1/24

PE-agg

Loop0

3.3.3.9/32

PE 1

Loop0

1.1.1.9/32

 

POS2/1/0

10.2.2.2/24

 

POS2/1/0

10.2.1.1/24

 

POS2/1/1

10.3.3.1/24

P

Loop0

2.2.2.9/32

 

VE-L3VPN1

100.1.1.2/24

 

POS2/1/0

10.2.1.2/24

PE 2

POS2/1/0

10.3.3.2/24

 

POS2/1/1

10.2.2.1/24

 

GE2/0/1

100.2.1.1/24

CE 2

GE2/0/1

100.2.1.2/24

 

 

 

 

3. 配置步骤

(1)     按照图1-4配置各设备接口的IP地址,包括物理接口和Loopback接口,具体配置过程略。

(2)     在PE-agg上创建相同接口编号的接口VE-L2VPN 1和VE-L3VPN 1。

# 创建接口VE-L2VPN 1。

<PEagg> system-view

[PEagg] interface ve-l2vpn 1

[PEagg-VE-L2VPN1] quit

# 创建接口VE-L3VPN 1,并配置接口的IP地址。

[PEagg] interface ve-l3vpn 1

[PEagg-VE-L3VPN1] ip address 100.1.1.2 24

[PEagg-VE-L3VPN1] quit

(3)     配置MPLS L2VPN功能

·     在PE 1、PPE-agg上配置OSPF,发布接口地址对应的路由

# 在PE 1上配置OSPF。

<PE1> system-view

[PE1] ospf

[PE1-ospf-1] area 0

[PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0

[PE1-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255

[PE1-ospf-1-area-0.0.0.0] quit

[PE1-ospf-1] quit

# 在P上配置OSPF。

<P> system-view

[P] ospf

[P-ospf-1] area 0

[P-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0

[P-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[P-ospf-1-area-0.0.0.0] network 10.2.1.0 0.0.0.255

[P-ospf-1-area-0.0.0.0] quit

[P-ospf-1] quit

# 在PE-agg上配置OSPF。

[PEagg] ospf

[PEagg-ospf-1] area 0

[PEagg-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0

[PEagg-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255

[PEagg-ospf-1-area-0.0.0.0] quit

[PEagg-ospf-1] quit

·     在PE 1、P、PE-agg上配置MPLS基本功能和MPLS LDP

# 配置PE 1。

[PE1] mpls lsr-id 1.1.1.9

[PE1] mpls ldp

[PE1-ldp] lsp-trigger all

[PE1-ldp] quit

[PE1] interface pos 2/1/0

[PE1-Pos2/1/0] mpls enable

[PE1-Pos2/1/0] mpls ldp enable

[PE1-Pos2/1/0] quit

# 配置P。

[P] mpls lsr-id 2.2.2.9

[P] mpls ldp

[P-ldp] lsp-trigger all

[P-ldp] quit

[P] interface pos 2/1/0

[P-Pos2/1/0] mpls enable

[P-Pos2/1/0] mpls ldp enable

[P-Pos2/1/0] quit

[P] interface pos 2/1/1

[P-Pos2/1/1] mpls enable

[P-Pos2/1/1] mpls ldp enable

[P-Pos2/1/1] quit

# 配置PE-agg。

[PEagg] mpls lsr-id 3.3.3.9

[PEagg] mpls ldp

[PEagg-ldp] lsp-trigger all

[PEagg-ldp] quit

[PEagg] interface pos 2/1/0

[PEagg-Pos2/1/0] mpls enable

[PEagg-Pos2/1/0] mpls ldp enable

[PEagg-Pos2/1/0] quit

·     在PE 1和PE-agg上使能L2VPN

# 配置PE 1。

[PE1] l2vpn enable

# 配置PE-agg。

[PEagg] l2vpn enable

·     在PE 1和PE-agg上创建VPLS实例

# 在PE 1上创建LDP方式的VPLS实例vpna,创建对等体地址为3.3.3.9、PW ID为500的PW。

[PE1] vsi vpna

[PE1-vsi-vpna] pwsignal ldp

[PE1-vsi-vpna-ldp] peer 3.3.3.9 pw-id 500

[PE1-vsi-vpna-ldp-3.3.3.9-500] quit

[PE1-vsi-vpna-ldp] quit

[PE1-vsi-vpna] quit

# 在PE-agg上创建LDP方式的VPLS实例vpna,创建对等体地址为1.1.1.9、PW ID为500的PW。

[PEagg] vsi vpna

[PEagg-vsi-vpna] pwsignal ldp

[PEagg-vsi-vpna-ldp] peer 1.1.1.9 pw-id 500

[PEagg-vsi-vpna-ldp-1.1.1.9-500] quit

[PEagg-vsi-vpna-ldp] quit

[PEagg-vsi-vpna] quit

·     在PE连接CE的接口上绑定VPLS实例

# 在PE 1连接CE 1的接口GigabitEthernet2/0/1上绑定VPLS实例vpna。

[PE1] interface gigabitethernet 2/0/1

[PE1-GigabitEthernet2/0/1] xconnect vsi vpna

# 在PE-agg的L2VE接口上绑定VPLS实例vpna。

[PEagg] interface ve-l2vpn 1

[PEagg-VE-L2VPN1] xconnect vsi vpna

(4)     IP骨干网中的设备通过OSPF进程2发布路由

# 在CE 1上配置通过OSPF进程2发布路由。

[CE1] ospf 2

[CE1-ospf-2] area 0

[CE1-ospf-2-area-0.0.0.0] network 100.1.1.0 0.0.0.255

[CE1-ospf-2-area-0.0.0.0] quit

[CE1-ospf-2] quit

# 在PE-agg上配置通过OSPF进程2发布路由。

[PEagg] ospf 2

[PEagg-ospf-2] area 0

[PEagg-ospf-2-area-0.0.0.0] network 100.1.1.0 0.0.0.255

[PEagg-ospf-2-area-0.0.0.0] network 10.3.3.0 0.0.0.255

[PEagg-ospf-2-area-0.0.0.0] quit

[PEagg-ospf-2] quit

# 在PE 2上配置通过OSPF进程2发布路由。

<PE2> system-view

[PE2] ospf 2

[PE2-ospf-2] area 0

[PE2-ospf-2-area-0.0.0.0] network 100.2.1.0 0.0.0.255

[PE2-ospf-2-area-0.0.0.0] network 10.3.3.0 0.0.0.255

[PE2-ospf-2-area-0.0.0.0] quit

[PE2-ospf-2] quit

# 在CE 2上配置通过OSPF进程2发布路由。

<CE2> system-view

[CE2] ospf 2

[CE2-ospf-2] area 0

[CE2-ospf-2-area-0.0.0.0] network 100.2.1.0 0.0.0.255

[CE2-ospf-2-area-0.0.0.0] quit

[CE2-ospf-2] quit

(5)     由于不同类型接口的缺省MTU值不同,为了避免对报文进行分片,将各设备上POS接口的MTU值配置为以太网接口的缺省MTU值1500

# 以PE 1为例,说明配置POS接口的MTU配置方法。其他设备上的配置与其类似,配置过程省略。

[PE1] int pos 2/1/0

[PE1-Pos2/1/0] mtu 1500

[PE1-Pos2/1/0] shutdown

[PE1-Pos2/1/0] undo shutdown

4. 验证配置

# CE1与CE2之间能够互通,以CE1为例。

<CE1> ping 100.2.1.2

Ping 100.2.1.2 (100.2.1.2): 56 data bytes, press CTRL_C to break

56 bytes from 100.2.1.2: icmp_seq=0 ttl=128 time=1.073 ms

56 bytes from 100.2.1.2: icmp_seq=1 ttl=128 time=1.428 ms

56 bytes from 100.2.1.2: icmp_seq=2 ttl=128 time=19.367 ms

56 bytes from 100.2.1.2: icmp_seq=3 ttl=128 time=1.013 ms

56 bytes from 100.2.1.2: icmp_seq=4 ttl=128 time=0.684 ms

 

--- Ping statistics for 100.2.1.2 ---

5 packet(s) transmitted, 5 packet(s) received, 0.0% packet loss

round-trip min/avg/max/std-dev = 0.684/4.713/19.367/7.331 ms

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!