选择区域语言: EN CN HK

03-二层技术-以太网交换配置指导

08-VLAN终结配置

本章节下载  (161.28 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Operation_Manual/H3C_MSR_CG-Release_2104(V1.10)/03/201311/803331_30005_0.htm

08-VLAN终结配置


1 VLAN终结配置

1.1  VLAN终结简介

1.1.1  VLAN终结概述

VLAN终结的实质就是:

l              对收到的VLAN报文,去除VLAN Tag后进行三层转发或其他处理。转发出去的报文是否带有Tag由出接口决定。

l              对将发送的报文,将相应的VLAN信息添加到报文中再发送。

1.1.2  VLAN终结的应用场景

VLAN终结主要应用于以下情况:

l              不同VLAN间的互通。VLAN因为能够隔离用户二层报文在网络中得到了广泛的应用。它将一个物理的LAN在逻辑上划分成多个广播域(对应多个VLAN),VLAN内的主机可以直接互相通信,而VLAN间的主机二层不能互相通信。要实现不同VLAN之间报文的互通必须借用三层路由技术,目前有两种方法:一种是在三层交换机上通过VLAN接口来实现;另一种是在路由器上通过三层以太网接口来实现。但传统的三层以太网接口不支持VLAN报文,当它收到VLAN报文时,会将VLAN报文当成是非法报文而丢弃。为了实现VLAN间的互通,我们在三层以太网接口上开发了三层以太网子接口,通过在子接口上配置VLAN终结功能来实现VLAN间的互通。
图1-1所示,Host A属于VLAN 2,Host B属于VLAN 3,将Host A的网关地址指定为1.1.1.1/24,Host B的网关地址指定为1.1.2.1/24,就可以通过Router的三层以太网子接口Ethernet1/1.2和Ethernet1/2.3来实现Host A和Host B的三层报文互通了。

图1-1 VLAN终结用于不同VLAN之间互通

 

l              用于实现局域网和广域网的互联。局域网内的报文大多数都带有VLAN Tag,但一些广域网协议并不识别VLAN报文,比如ATM、FR和PPP等,这种情况下,如果要局域网的VLAN报文转发到广域网,需要在本地记录报文的VLAN信息,去掉该信息后再转发。
图1-2所示,用户的报文发送到L2 Switch A时,会被封装上一层VLAN Tag(User VLAN),报文发送到L2 Switch B时,会再被封装上一层VLAN Tag(Nested VLAN),在网络提供者的LAN内,基于Nested VLAN进行转发,如果报文要发往外部WAN,则需要在出口网关(Device)上对QinQ报文进行终结处理,再通过同异步串口Serial 5/1发送到WAN。

图1-2 VLAN终结用于LAN和WAN的互联

 

1.1.3  VLAN终结的分类

根据VLAN报文携带Tag的层数可以将VLAN报文分为Dot1q报文(带有一层VLAN Tag,即802.1q报文)和QinQ报文(带有两层VLAN Tag)。相应的VLAN终结也分为两种:

l              Dot1q终结:用来终结Dot1q报文。该方式在收到Dot1q报文时,会将报文里的VLAN Tag去掉之后再继续处理。

l              QinQ终结:用来终结QinQ报文。该方式在收到QinQ报文时,会将报文里的内、外层VLAN Tag都去掉之后再继续处理。

l    主接口本身不能处理VLAN报文,在主接口创建子接口后,由子接口来处理。

l    子接口只能接收VLAN报文,发送的也都是带VLAN Tag的报文。

l    系统目前仅支持Dot1q终结。

 

1.2  VLAN终结配置任务简介

表1-1 VLAN终结配置任务简介

配置任务

说明

详细配置

配置Dot1q终结

配置明确的Dot1q终结

请根据设备的支持情况选择一种方式

1.3.1 

 

1.3  配置Dot1q终结

根据每个子接口所能终结的VLAN报文中VLAN ID范围的不同,Dot1q终结又分为:

l              明确的Dot1q终结:只能终结一个VLAN的报文。能接收的VLAN报文的VLAN ID必须是指定值,其它VLAN报文则不允许通过该子接口;发送报文时,会给报文添加一层VLAN Tag,VLAN ID字段填上指定值。

l              模糊的Dot1q终结:可以终结多个VLAN的报文。能接收的VLAN报文的VLAN ID只需要在指定的范围内,不属于该范围的VLAN报文则不允许通过该子接口;发送报文时,会给报文添加一层VLAN Tag,VLAN ID字段填上指定值:对于IPv4/MPLS报文,通过查找ARP表项获取相应的VLAN ID;对于PPPoE报文,通过查找PPPoE会话表项获取相应的VLAN ID;对于DHCP Relay报文,通过查找DHCP会话表项获取相应的VLAN ID。

系统目前仅支持明确的Dot1q终结。

 

1.3.1  配置明确的Dot1q终结

表1-2 配置明确的Dot1q终结

操作

命令

说明

进入系统视图

system-view

-

三层以太网子接口视图

interface interface-type interface-number.subnumber

必选

使能子接口的Dot1q终结功能,并指定当前子接口能够终结的Dot1q报文的VLAN ID

vlan-type dot1q vid vlan-id

可选

 

1.3.2  明确的Dot1q终结配置举例

1. 组网需求

如下图所示,Host A、Host B和Switch A相连,Host C、Host D和Switch B相连。Host A和Host C属于VLAN 10,Host B和Host D属于VLAN 20,要求实现:

l              路由器子接口Ethernet1/1.10、Ethernet1/1.20、Ethernet2/1.10、Ethernet2/1.20的IP地址分别为1.0.0.1/8、2.0.0.1/8、3.0.0.1/8和4.0.0.1/8;

l              Host A和Host B之间、Host C和Host D之间能够互相通信,即同一交换机、不同VLAN之间能够互相通信;

l              Host A和Host C之间、Host B和Host D之间能够互相通信,即不同交换机、同一VLAN之间能够互相通信;

l              Host A和Host D之间、Host B和Host C之间能够互相通信,即不同交换机、不同VLAN之间能够互相通信。

2. 组网图

图1-3 配置以太网子接口组网图

 

3. 配置步骤

本配置中vlan-type dot1q vid命令必须配置,因为以太网子接口只有在关联了VLAN后才能被激活,正常的收发报文。

 

(1)        Host A、Host B、Host C、Host D的配置

将Host A的IP地址指定为1.1.1.1/8,网关地址指定为1.0.0.1/8。

将Host B的IP地址指定为2.2.2.2/8,网关地址指定为2.0.0.1/8。

将Host C的IP地址指定为3.3.3.3/8,网关地址指定为3.0.0.1/8。

将Host D的IP地址指定为4.4.4.4/8,网关地址指定为4.0.0.1/8。

(2)        L2 Switch A、L2 Switch B的配置

下面以L2 Switch A的配置步骤为例,L2 Switch B的配置与L2 Switch A的配置相同,不再赘述。

<L2_SwitchA> system-view

[L2_SwitchA] vlan 10

[L2_SwitchA-vlan10] port ethernet 1/2

[L2_SwitchA-vlan10] quit

[L2_SwitchA] vlan 20

[L2_SwitchA-vlan20] port ethernet 1/3

[L2_SwitchA-vlan20] quit

[L2_SwitchA] interface ethernet 1/1

[L2_SwitchA-Ethernet1/1] port link-type trunk

[L2_SwitchA-Ethernet1/1] port trunk permit vlan 10 20

 Please wait... Done.

(3)        Router的配置

# 创建并进入以太网子接口Ethernet1/1.10、Ethernet1/1.20、Ethernet2/1.10和Ethernet2/1.20,为其配置IP地址,Ethernet1/1.10和Ethernet2/1.10用来终结VLAN 10的报文,Ethernet1/1.20和Ethernet2/1.20用来终结VLAN 20的报文。

<Router> system-view

[Router] interface ethernet 1/1.10

[Router-Ethernet1/1.10] ip address 1.0.0.1 255.0.0.0

[Router-Ethernet1/1.10] vlan-type dot1q vid 10

[Router-Ethernet1/1.10] quit

[Router] interface ethernet 1/1.20

[Router-Ethernet1/1.20] ip address 2.0.0.1 255.0.0.0

[Router-Ethernet1/1.20] vlan-type dot1q vid 20

[Router-Ethernet1/1.20] quit

[Router] interface ethernet 2/1.10

[Router-Ethernet2/1.10] ip address 3.0.0.1 255.0.0.0

[Router-Ethernet2/1.10] vlan-type dot1q vid 10

[Router-Ethernet2/1.10] quit

[Router] interface ethernet 2/1.20

[Router-Ethernet2/1.20] ip address 4.0.0.1 255.0.0.0

[Router-Ethernet2/1.20] vlan-type dot1q vid 20

[Router-Ethernet2/1.20] quit

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!