选择区域语言: EN CN HK

08-IP组播配置指导

04-组播路由与转发配置

本章节下载  (428.42 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Operation_Manual/H3C_MSR_CG-R2207(V1.11)/08/201212/768445_30005_0.htm

04-组播路由与转发配置

  录

1 组播路由与转发配置........................................................................................................................ 1-1

1.1 组播路由与转发简介................................................................................................................. 1-1

1.1.1 RPF检查机制................................................................................................................ 1-1

1.1.2 组播静态路由................................................................................................................. 1-3

1.1.3 GRE隧道在组播转发中的应用......................................................................................... 1-5

1.1.4 组播路径跟踪................................................................................................................. 1-5

1.2 组播路由与转发配置任务简介.................................................................................................... 1-6

1.3 使能IP组播路由...................................................................................................................... 1-7

1.4 配置组播路由与转发................................................................................................................. 1-7

1.4.1 配置准备........................................................................................................................ 1-7

1.4.2 配置组播静态路由........................................................................................................... 1-8

1.4.3 配置组播路由策略........................................................................................................... 1-8

1.4.4 配置组播转发范围........................................................................................................... 1-9

1.4.5 配置组播转发表容量...................................................................................................... 1-10

1.4.6 跟踪组播数据的传输路径............................................................................................... 1-11

1.5 组播路由与转发显示和维护...................................................................................................... 1-11

1.6 组播路由与转发典型配置举例.................................................................................................. 1-12

1.6.1 改变RPF路由配置举例................................................................................................. 1-12

1.6.2 衔接RPF路由配置举例................................................................................................. 1-14

1.6.3 利用GRE隧道实现组播转发配置举例............................................................................. 1-16

1.7 常见配置错误举例................................................................................................................... 1-20

1.7.1 组播静态路由失败......................................................................................................... 1-20

1.7.2 组播数据无法到达接收者............................................................................................... 1-20

 


1 组播路由与转发配置

1.1  组播路由与转发简介

在组播实现中,组播路由和转发分为三种表:

l              每个组播路由协议都有一个协议自身的路由表,如PIM路由表(PIM Routing-Table);

l              各组播路由协议的组播路由信息经过综合形成一个总的组播路由表(Multicast Routing-Table);

l              组播转发表(Multicast Forwarding-Table)直接用于控制组播数据包的转发。

组播路由表由一组(S,G)表项组成,其中(S,G)表示由源S向组播组G发送组播数据的路由信息。如果路由器支持多种组播路由协议,则其组播路由表中将包括由多种协议生成的组播路由。路由器根据组播路由和转发策略,从组播路由表中选出最优的组播路由,并下发到组播转发表中。

1.1.1  RPF检查机制

组播路由协议依赖于现有的单播路由信息、MBGP路由或组播静态路由来创建组播路由表项。组播路由协议在创建组播路由表项时,运用了RPF(Reverse Path Forwarding,逆向路径转发)检查机制,以确保组播数据能够沿正确的路径传输,同时还能避免由于各种原因而造成的环路。

1. RPF检查过程

执行RPF检查的依据是单播路由、MBGP路由或组播静态路由:

l              单播路由表中汇集了到达各个目的网段的最短路径;

l              MBGP路由表直接提供组播路由信息;

l              组播静态路由表中列出了用户通过手工静态配置指定的RPF路由信息。

在执行RPF检查时,同时查找单播路由表、MBGP路由表和组播静态路由表,具体过程如下:

(1)        首先,分别从单播路由表、MBGP路由表和组播静态路由表中各选出一条最优路由:

l              以“报文源”的IP地址为目的地址查找单播路由表,自动选取一条最优单播路由。对应表项中的出接口为RPF接口,下一跳为RPF邻居。路由器认为来自RPF邻居且由该RPF接口收到的组播报文所经历的路径是从源S到本地的最短路径。

l              以“报文源”的IP地址为目的地址查找MBGP路由表,自动选取一条最优MBGP路由。对应表项中的出接口为RPF接口,下一跳为RPF邻居。

l              以“报文源”的IP地址为指定源地址查找组播静态路由表,自动选取一条最优组播静态路由。对应表项明确指定了RPF接口和RPF邻居。

(2)        然后,从这三条最优路由中选择一条作为RPF路由:

l              如果配置了按照最长匹配选择路由,则从这三条路由中选出最长匹配的那条路由;如果这三条路由的掩码一样,则选择其中优先级最高的那条路由;如果它们的优先级也相同,则按照组播静态路由、MBGP路由、单播路由的顺序进行选择。

l              如果没有配置按照最长匹配选择路由,则从这三条路由中选出优先级最高的那条路由;如果它们的优先级相同,则按照组播静态路由、MBGP路由、单播路由的顺序进行选择。

根据组播报文传输的具体情况不同,“报文源”所代表的具体含义也不同:

l          如果当前报文沿从组播源到接收者或RP(Rendezvous Point,汇集点)的SPT(Shortest Path Tree,最短路径树)进行传输,则以组播源为“报文源”进行RPF检查;

l          如果当前报文沿从RP到接收者的RPT(Rendezvous Point Tree,共享树)进行传输,或者沿从组播源到RP的组播源侧RPT进行传输,则都以RP为“报文源”进行RPF检查;

l          如果当前报文为BSR(BootStrap Router,自举路由器)报文,沿从BSR到各路由器的路径进行传输,则以BSR为“报文源”进行RPF检查。

有关SPT、RPT、组播源侧RPT、RP和BSR的详细介绍,请参见“IP组播配置指导”中的“PIM”。

 

2. RPF检查在组播转发中的应用

对每一个收到的组播数据报文都进行RPF检查会给路由器带来较大负担,而利用组播转发表可以解决这个问题。在建立组播路由和转发表时,会把组播数据报文(S,G)的RPF接口记录为(S,G)表项的入接口。当路由器收到组播数据报文(S,G)后,查找组播转发表:

(1)        如果组播转发表中不存在(S,G)表项,则对该报文执行RPF检查,将其RPF接口作为入接口,结合相关路由信息创建相应的表项,并下发到组播转发表中:

l              若该报文实际到达的接口正是其RPF接口,则RPF检查通过,向所有的出接口转发该报文;

l              若该报文实际到达的接口不是其RPF接口,则RPF检查失败,丢弃该报文。

(2)        如果组播转发表中已存在(S,G)表项,且该报文实际到达的接口与入接口相匹配,则向所有的出接口转发该报文。

(3)        如果组播转发表中已存在(S,G)表项,但该报文实际到达的接口与入接口不匹配,则对此报文执行RPF检查:

l              若其RPF接口与入接口一致,则说明(S,G)表项正确,丢弃这个来自错误路径的报文;

l              若其RPF接口与入接口不符,则说明(S,G)表项已过时,于是把入接口更新为RPF接口。如果该报文实际到达的接口正是其RPF接口,则向所有的出接口转发该报文,否则将其丢弃。

图1-1所示,假设网络中单播路由畅通,未配置MBGP,Router C上也未配置组播静态路由。组播报文(S,G)沿从组播源(Source)到接收者(Receiver)的SPT进行传输。假定Router C上的组播转发表中已存在(S,G)表项,其记录的入接口为POS5/1。

图1-1 RPF检查过程

 

l              如果该组播报文从接口POS5/1到达Router C,与(S,G)表项的入接口相匹配,则向所有的出接口转发该报文。

l              如果该组播报文从接口POS5/0到达Router C,与(S,G)表项的入接口不匹配,则对其执行RPF检查:通过查找单播路由表发现到达Source的出接口(即RPF接口)是POS5/1,与(S,G)表项的入接口一致。这说明(S,G)表项是正确的,该报文来自错误的路径,RPF检查失败,于是丢弃该报文。

1.1.2  组播静态路由

组播静态路由是RPF检查的重要依据之一。根据具体应用环境的不同,组播静态路由有以下两种主要用途:

1. 改变RPF路由

通常,组播的网络拓扑结构与单播相同,组播数据的传输路径也与单播相同。可以通过配置组播静态路由以改变RPF路由,从而为组播数据创建一条与单播不同的传输路径。

图1-2 改变RPF路由示意图

 

图1-2所示,当网络中没有配置组播静态路由时,Router C到组播源(Source)的RPF邻居为Router A,从Source发出的组播信息沿Router A—Router C的路径传输,与单播路径一致;当在Router C上配置了组播静态路由,指定从Router C到Source的RPF邻居为Router B之后,从Source发出的组播信息将改变传输路径,沿Router A—Router B—Router C的新路径传输。

2. 衔接RPF路由

当网络中的单播路由被阻断时,由于没有RPF路由而无法进行包括组播数据在内的数据转发。可以通过配置组播静态路由以生成RPF路由,从而创建组播路由表项以指导组播数据的转发。

图1-3 衔接RPF路由示意图

 

图1-3所示,RIP域与OSPF域之间实行单播路由隔离。当网络中没有配置组播静态路由时,OSPF域内的接收者(Receiver)不能收到RIP域内的组播源(Source)所发出的组播信息;当在Router C和Router D上均配置了组播静态路由,分别指定从Router C到Source的RPF邻居为Router B、从Router D到Source的RPF邻居为Router C之后,Receiver便能收到Source发出的组播信息了。

l          组播静态路由的作用只在于影响RPF检查,而不能用于指导组播数据转发,故又称为RPF静态路由;

l          组播静态路由仅在所配置的组播路由器上生效,不会以任何方式被广播或者引入给其它路由器。

 

1.1.3  GRE隧道在组播转发中的应用

网络中可能存在不支持组播协议的路由器。从组播源(Source)发出的组播数据沿组播路由器逐跳转发,当下一跳路由器不支持组播协议时,组播转发路径将被阻断。此时,通过在处于单播网段两端的组播路由器之间建立GRE(Generic Routing Encapsulation,通用路由封装)隧道,可以实现跨越单播网段的组播数据交换。有关GRE隧道的详细介绍,请参见“三层技术-IP业务配置指导”中的“GRE”。

图1-4 使用隧道方式传送组播数据

 

图1-4所示,在Router A和Router B之间建立起GRE隧道。Router A将组播数据包封装在单播IP报文中,经由单播路由器转发,传送到隧道另一端的Router B。然后,Router B将单播IP报文头剥掉,继续进行组播传输。

如果在隧道的两端配置了单播静态路由,则任意单播数据包都可以通过该隧道传输。为了将该隧道专用于组播数据包的传输,可以在隧道两端只配置组播静态路由,从而使单播数据包的传输不能再使用此隧道。

1.1.4  组播路径跟踪

Multicast traceroute(组播路径跟踪)用来跟踪组播数据从第一跳到最后一跳路由器所经过的路径。

1. Multicast traceroute基本概念

(1)        最后一跳路由器(Last-hop Router):如果某路由器有一个接口的IP地址与指定地址在同一个网段内,具备组播功能,且能够向该网段转发特定组播源发来的组播流,则称该路由器为最后一跳路由器。

(2)        第一跳路由器(First-hop Router):与组播源直连的路由器。

(3)        查询器(Querier):触发组播路径跟踪的路由器。

2. Multicast traceroute报文简介

Multicast traceroute报文是一种特殊的IGMP报文,与普通IGMP报文的区别在于其类型字段为0x1F/0x1E,且其目的IP地址为单播地址。Multicast traceroute报文分为以下三种类型:

l              Query报文:类型字段为0x1F

l              Request报文:类型字段为0x1F

l              Response报文:类型字段为0x1E

3. Multicast traceroute执行步骤

(1)        查询器向最后一跳路由器发送Query报文;

(2)        最后一跳路由器在收到的Query报文后加上本地响应数据块转换成Request报文,查找到上游邻居后向其单播发送该Request报文;

(3)        最后一跳路由器到组播源之间的每一跳都在Request报文之后附加一个响应数据块,并向其上游邻居单播转发;

(4)        第一跳路由器在收到Request报文后,将其报文类型改为Response报文,向查询器单播发送完整的报文。

1.2  组播路由与转发配置任务简介

表1-1 组播路由与转发配置任务简介

配置任务

说明

详细配置

使能IP组播路由

必选

1.3 

配置组播路由与转发

配置组播静态路由

可选

1.4.2 

配置组播路由策略

可选

1.4.3 

配置组播转发范围

可选

1.4.4 

配置组播转发表容量

可选

1.4.5 

跟踪组播数据的传输路径

可选

1.4.6 

 

IP组播不支持从IP地址网段应用。也就是说,当为接口配置了从IP地址后,组播数据并不能通过从IP地址所属的网段进行路由和转发,而只能通过主IP地址进行路由和转发。有关主、从IP地址的详细介绍,请参见“三层技术-IP业务配置指导”中的“IP地址”。

 

1.3  使能IP组播路由

在配置各项三层组播功能之前,必须首先使能IP组播路由。

1. 使能公网实例中的IP组播路由

表1-2 使能公网实例中的IP组播路由

操作

命令

说明

进入系统视图

system-view

-

使能IP组播路由

multicast routing-enable

必选

缺省情况下,IP组播路由处于关闭状态

 

2. 使能VPN实例中的IP组播路由

表1-3 使能VPN实例中的IP组播路由

操作

命令

说明

进入系统视图

system-view

-

创建VPN实例,并进入VPN实例视图

ip vpn-instance vpn-instance-name

-

配置VPN实例的RD

route-distinguisher route-distinguisher

必选

缺省情况下,VPN实例没有RD

使能IP组播路由

multicast routing-enable

必选

缺省情况下,IP组播路由处于关闭状态

 

有关ip vpn-instanceroute-distinguisher命令的详细介绍,请参见“MPLS命令参考”中的“MPLS L3VPN”。

 

1.4  配置组播路由与转发

1.4.1  配置准备

在配置组播路由与转发之前,需完成以下任务:

l              配置任一单播路由协议,实现域内网络层互通

l              配置PIM-DM(或PIM-SM)

在配置组播路由与转发之前,需准备以下数据:

l              组播转发的最小TTL值

l              单条组播转发表项的最大下行节点数目

l              组播转发表的最大表项数

1.4.2  配置组播静态路由

通过配置组播静态路由,可以为来自特定组播源的组播报文指定RPF接口或RPF邻居。

表1-4 配置组播静态路由

操作

命令

说明

进入系统视图

system-view

-

配置组播静态路由

ip rpf-route-static [ vpn-instance vpn-instance-name ] source-address { mask | mask-length } [ protocol [ process-id ] ] [ route-policy policy-name ] { rpf-nbr-address | interface-type interface-number } [ preference preference ] [ order order-number ]

必选

缺省情况下,没有配置组播静态路由

删除所有组播静态路由

delete ip rpf-route-static [ vpn-instance vpn-instance-name ]

可选

 

在配置组播静态路由时,若RPF邻居的接口类型是三层以太网接口、Loopback接口或VLAN接口时,则不能用指定接口(interface-type interface-number)的方式来指定RPF邻居,而只能用指定地址(rpf-nbr-address)的方式。

 

1.4.3  配置组播路由策略

可以配置组播路由器按照最长匹配原则来选择RPF路由,有关RPF路由选择的详细介绍,请参见“1.1.1  1. RPF检查过程”一节。此外,通过配置根据组播源或组播源组进行组播流量的负载分担,还可以优化存在多条组播数据流时的网络流量。

1. 配置公网实例中的组播路由策略

表1-5 配置公网实例中的组播路由策略

操作

命令

说明

进入系统视图

system-view

-

配置按照最长匹配选择RPF路由

multicast longest-match

可选

缺省情况下,选择优先级最高的路由作为RPF路由

配置对组播流量进行负载分担

multicast load-splitting { source | source-group }

可选

缺省情况下,不对组播流量进行负载分担

 

2. 配置VPN实例中的组播路由策略

表1-6 配置VPN实例中的组播路由策略

操作

命令

说明

进入系统视图

system-view

-

进入VPN实例视图

ip vpn-instance vpn-instance-name

-

配置按照最长匹配选择RPF路由

multicast longest-match

可选

缺省情况下,选择优先级最高的路由作为RPF路由

配置对组播流量进行负载分担

multicast load-splitting { source | source-group }

可选

缺省情况下,不对组播流量进行负载分担

 

1.4.4  配置组播转发范围

组播信息在网络中的转发并不是漫无边际的,每个组播组对应的组播信息都必须在确定的范围内传递。目前定义组播转发范围的方式有以下两种:

l              确定充当组播转发边界的接口,以形成一个封闭的组播转发区域;

l              确定组播转发的最小TTL(Time to Live,生存时间)值,以确定组播报文被转发的距离。

可以在所有支持组播转发的接口上配置针对某个组播组的转发边界。组播转发边界为指定范围的组播组划定了边界条件,如果组播报文的目的地址与边界条件匹配,就停止转发。当在一个接口上配置了组播转发边界后,将不能从该接口转发组播报文(包括本机发出的组播报文),也不能从该接口接收组播报文。

组播转发的最小TTL值可以配置在所有支持组播转发的接口上。当要将一个组播报文(包括本机发出的组播报文)从某接口转发出去时,对接口上所配置的最小TTL值进行检查:

l              若报文的TTL值(该值已在本路由器内被减1)大于或等于接口上所配置的最小TTL值,则转发该报文;

l              若报文的TTL值小于接口上所配置的最小TTL值,则丢弃该报文。

表1-7 配置组播转发范围

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置组播转发边界

multicast boundary group-address { mask | mask-length }

必选

缺省情况下,没有配置组播转发边界

配置组播转发的最小TTL值

multicast minimum-ttl ttl-value

可选

缺省情况下,组播转发的最小TTL值为1

 

1.4.5  配置组播转发表容量

路由器为每个收到的组播数据报文都维护相应的转发表项。但是,组播转发表项过多可能会耗尽路由器内存,从而导致路由器性能下降。用户可以根据实际组网情况和业务性能要求对组播转发表中的表项数量进行限制。如果组播转发表最大表项数的配置值小于当前值,则超出数目的表项并不会立刻被删除,而必须由组播路由协议来删除,同时也无法添加新的组播转发表项。

路由器为每个下行节点复制一份组播数据报文并发送出去,每个下行节点就形成组播分发树的一条分支。用户可以根据实际组网情况和业务性能要求对组播转发表中单条表项的下行节点数目(即出接口数目)进行限制,以缓解路由器的复制压力。如果单条组播转发表项的最大下行节点数目的配置值小于当前值,则超出数目的下行节点并不会被立刻删除,而必须由组播路由协议来删除,同时新增的下行节点将无法添加到该表项中。

1. 配置公网实例中的组播转发表容量

表1-8 配置公网实例中的组播转发表容量

操作

命令

说明

进入系统视图

system-view

-

配置组播转发表的最大表项数

multicast forwarding-table route-limit limit

可选

缺省情况下,组播转发表的最大表项数为系统所允许的最大值,该值随设备的不同而有所差别,请参见命令手册中的详细说明

配置单条组播转发表项的最大下行节点数目

multicast forwarding-table downstream-limit limit

可选

缺省情况下,单条组播转发表项的最大下行节点数目为128

 

2. 配置VPN实例中的组播转发表容量

表1-9 配置VPN实例中的组播转发表容量

操作

命令

说明

进入系统视图

system-view

-

进入VPN实例视图

ip vpn-instance vpn-instance-name

-

配置组播转发表的最大表项数

multicast forwarding-table route-limit limit

可选

缺省情况下,组播转发表的最大表项数为系统所允许的最大值,该值随设备的不同而有所差别,请参见命令手册中的详细说明

配置单条组播转发表项的最大下行节点数目

multicast forwarding-table downstream-limit limit

可选

缺省情况下,单条组播转发表项的最大下行节点数目为128

 

1.4.6  跟踪组播数据的传输路径

可在任意视图下执行mtracert命令来跟踪组播数据从第一跳到最后一跳路由器所经过的路径。

表1-10 跟踪组播数据的传输路径

操作

命令

说明

跟踪组播数据的传输路径

mtracert source-address [ [ last-hop-router-address ] group-address ]

必选

可在任意视图下执行

 

1.5  组播路由与转发显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后组播路由与转发的信息,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除组播路由与转发的统计信息。

表1-11 组播路由与转发显示和维护

操作

命令

查看组播边界信息

display multicast [ all-instance | vpn-instance vpn-instance-name ] boundary [ group-address [ mask | mask-length ] ] [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

查看组播转发表信息

display multicast [ all-instance | vpn-instance vpn-instance-name ] forwarding-table [ source-address [ mask { mask | mask-length } ] | group-address [ mask { mask | mask-length } ] | incoming-interface { interface-type interface-number | register } | outgoing-interface { { exclude | include | match } { interface-type interface-number | register } } | statistics ] * [ port-info ] [ | { begin | exclude | include } regular-expression ]

查看组播转发表的DF信息

display multicast [ all-instance | vpn-instance vpn-instance-name ] forwarding-table df-info [ rp-address ] [ | { begin | exclude | include } regular-expression ]

查看组播路由表信息

display multicast [ all-instance | vpn-instance vpn-instance-name ] routing-table [ source-address [ mask { mask | mask-length } ] | group-address [ mask { mask | mask-length } ] | incoming-interface { interface-type interface-number | register } | outgoing-interface { { exclude | include | match } { interface-type interface-number | register } } ] * [ | { begin | exclude | include } regular-expression ]

查看组播静态路由信息

display multicast routing-table [ all-instance | vpn-instance vpn-instance-name ] static [ source-address { mask-length | mask } ] [ | { begin | exclude | include } regular-expression ]

查看组播源的RPF信息

display multicast [ all-instance | vpn-instance vpn-instance-name ] rpf-info source-address [ group-address ] [ | { begin | exclude | include } regular-expression ]

查看组播转发的最小TTL值

display multicast [ all-instance | vpn-instance vpn-instance-name ] minimum-ttl [ interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

清除组播转发表中的转发项

reset multicast [ all-instance | vpn-instance vpn-instance-name ] forwarding-table { { source-address [ mask { mask | mask-length } ] | group-address [ mask { mask | mask-length } ] | incoming-interface { interface-type interface-number | register } } * | all }

清除组播路由表中的路由项

reset multicast [ all-instance | vpn-instance vpn-instance-name ] routing-table { { source-address [ mask { mask | mask-length } ] | group-address [ mask { mask | mask-length } ] | incoming-interface { interface-type interface-number | register } } * | all }

 

有关DF(Designated Forwarder,指定转发者)的详细介绍,请参见“IP组播配置指导”中的“PIM”。

 

l          执行reset命令将清除组播路由表或组播转发表中的信息,可能导致组播信息无法正常传输;

l          清除组播路由表中的路由项后,组播转发表中的相应表项也将随之删除;

l          清除组播转发表中的转发项后,组播路由表中的相应表项也将随之删除。

 

1.6  组播路由与转发典型配置举例

1.6.1  改变RPF路由配置举例

1. 组网需求

l              网络中运行PIM-DM,所有路由器都支持组播功能;

l              Router A、Router B和Router C之间运行OSPF协议;

l              通常情况下,Receiver能通过Router A—Router B这条与单播路径相同的路径接收来自Source的组播信息;

l              要求通过配置,使Receiver能通过Router A—Router C—Router B这条与单播路径不同的路径接收来自Source的组播信息。

2. 组网图

图1-5 改变RPF路由配置举例

 

3. 配置步骤

(1)        配置IP地址和单播路由协议

请按照图1-5配置各接口的IP地址和掩码,具体配置过程略。

配置PIM-DM域内的各路由器之间采用OSPF协议进行互连,确保PIM-DM域内部在网络层互通,并且各路由器之间能够借助单播路由协议实现动态路由更新,具体配置过程略。

(2)        使能IP组播路由,并使能PIM-DM和IGMP

# 在Router B上使能IP组播路由,在各接口上使能PIM-DM,并在主机侧接口Ethernet1/1上使能IGMP。

<RouterB> system-view

[RouterB] multicast routing-enable

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] igmp enable

[RouterB-Ethernet1/1] pim dm

[RouterB-Ethernet1/1] quit

[RouterB] interface ethernet 1/2

[RouterB-Ethernet1/2] pim dm

[RouterB-Ethernet1/2] quit

[RouterB] interface ethernet 1/3

[RouterB-Ethernet1/3] pim dm

[RouterB-Ethernet1/3] quit

# Router A上使能IP组播路由,并在各接口上使能PIM-DM

<RouterA> system-view

[RouterA] multicast routing-enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] pim dm

[RouterA-Ethernet1/1] quit

[RouterA] interface ethernet 1/2

[RouterA-Ethernet1/2] pim dm

[RouterA-Ethernet1/2] quit

[RouterA] interface ethernet 1/3

[RouterA-Ethernet1/3] pim dm

[RouterA-Ethernet1/3] quit

Router C上的配置与Router A相似,配置过程略。

# Router B上使用display multicast rpf-info命令查看到SourceRPF信息。

[RouterB] display multicast rpf-info 50.1.1.100

 RPF information about source 50.1.1.100:

     RPF interface: Ethernet1/3, RPF neighbor: 30.1.1.2

     Referenced route/mask: 50.1.1.0/24

     Referenced route type: igp

     Route selection rule: preference-preferred

     Load splitting rule: disable

Router B上当前的RPF路由来源于单播路由,RPF邻居是Router A。

(3)        配置组播静态路由

# 在Router B上配置组播静态路由,指定到Source的RPF邻居为Router C。

[RouterB] ip rpf-route-static 50.1.1.100 24 20.1.1.2

(4)        检验配置效果

# 在Router B上使用display multicast rpf-info命令查看到Source的RPF信息。

[RouterB] display multicast rpf-info 50.1.1.100

 RPF information about source 50.1.1.100:

     RPF interface: Ethernet1/2, RPF neighbor: 20.1.1.2

     Referenced route/mask: 50.1.1.0/24

     Referenced route type: multicast static

     Route selection rule: preference-preferred

     Load splitting rule: disable

与配置组播静态路由前相比,Router B上的RPF路由已经产生了变化,其来源变为组播静态路由,RPF邻居变为Router C。

1.6.2  衔接RPF路由配置举例

1. 组网需求

l              网络中运行PIM-DM,所有路由器都支持组播功能;

l              Router B和Router C之间运行OSPF协议,并与Router A单播路由隔离;

l              通常情况下,Receiver能接收来自OSPF域内Source 1的组播信息;

l              要求通过配置,使Receiver也可以接收来自OSPF域外Source 2的组播信息。

2. 组网图

图1-6 衔接RPF路由配置组网图

 

3. 配置步骤

(1)        配置IP地址和单播路由协议

请按照图1-6配置各接口的IP地址和掩码,具体配置过程略。

配置Router B和Router C之间采用OSPF协议进行互连,确保Router B和Router C之间在网络层互通,并且能够借助单播路由协议实现动态路由更新,具体配置过程略。

(2)        使能IP组播路由,并使能PIM-DM和IGMP

# 在Router C上使能IP组播路由,在各接口上使能PIM-DM,并在主机侧接口Ethernet1/1上使能IGMP。

<RouterC> system-view

[RouterC] multicast routing-enable

[RouterC] interface ethernet 1/1

[RouterC-Ethernet1/1] igmp enable

[RouterC-Ethernet1/1] pim dm

[RouterC-Ethernet1/1] quit

[RouterC] interface ethernet 1/2

[RouterC-Ethernet1/2] pim dm

[RouterC-Ethernet1/2] quit

# 在Router A上使能IP组播路由,并在各接口上使能PIM-DM。

<RouterA> system-view

[RouterA] multicast routing-enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] pim dm

[RouterA-Ethernet1/1] quit

[RouterA] interface ethernet 1/2

[RouterA-Ethernet1/2] pim dm

[RouterA-Ethernet1/2] quit

Router B上的配置与Router A相似,配置过程略。

# Router BRouter C上分别使用display multicast rpf-info命令查看到Source 2RPF信息。

[RouterB] display multicast rpf-info 50.1.1.100

[RouterC] display multicast rpf-info 50.1.1.100

没有显示信息输出,说明在Router B和Router C上都没有到Source 2的RPF路由。

(3)        配置组播静态路由

# 在Router B上配置组播静态路由,指定到Source 2的RPF邻居为Router A

[RouterB] ip rpf-route-static 50.1.1.100 24 30.1.1.2

# 在Router C上配置组播静态路由,指定到Source 2的RPF邻居为Router B。

[RouterC] ip rpf-route-static 50.1.1.100 24 20.1.1.2

(4)        检验配置效果

# 在Router B和Router C上分别使用display multicast rpf-info命令查看到Source 2的RPF信息。

[RouterB] display multicast rpf-info 50.1.1.100

 RPF information about source 50.1.1.100:

     RPF interface: Ethernet1/3, RPF neighbor: 30.1.1.2

     Referenced route/mask: 50.1.1.0/24

     Referenced route type: multicast static

     Route selection rule: preference-preferred

     Load splitting rule: disable

[RouterC] display multicast rpf-info 50.1.1.100

 RPF information about source 50.1.1.100:

     RPF interface: Ethernet1/2, RPF neighbor: 20.1.1.2

     Referenced route/mask: 50.1.1.0/24

     Referenced route type: multicast static

     Route selection rule: preference-preferred

     Load splitting rule: disable

与配置组播静态路由前相比,Router B和Router C上都有了到Source 2的RPF路由,且其均来源于组播静态路由。

1.6.3  利用GRE隧道实现组播转发配置举例

1. 组网需求

l              Router A和Router C支持组播功能并运行PIM-DM,但Router B不支持组播功能;

l              Router A、Router B和Router C之间运行OSPF协议;

l              要求通过配置,使Receiver能够接收来自Source的组播信息。

2. 组网图

图1-7 利用GRE隧道实现组播转发配置组网图

 

3. 配置步骤

(1)        配置IP地址

请按照图1-7配置各接口的IP地址和掩码,具体配置过程略。

(2)        配置GRE隧道

# 在Router A上创建接口Tunnel0,并为其配置IP地址和掩码。

<RouterA> system-view

[RouterA] interface tunnel 0

[RouterA-Tunnel0] ip address 50.1.1.1 24

# 配置Tunnel0接口采用GRE隧道模式,并为该接口指定源地址和目的地址。

[RouterA-Tunnel0] tunnel-protocol gre

[RouterA-Tunnel0] source 20.1.1.1

[RouterA-Tunnel0] destination 30.1.1.2

[RouterA-Tunnel0] quit

# 在Router C上创建接口Tunnel0,并为其配置IP地址和掩码。

<RouterC> system-view

[RouterC] interface tunnel 0

[RouterC-Tunnel0] ip address 50.1.1.2 24

# 配置Tunnel0接口采用GRE隧道模式,并为该接口指定源地址和目的地址。

[RouterC-Tunnel0] tunnel-protocol gre

[RouterC-Tunnel0] source 30.1.1.2

[RouterC-Tunnel0] destination 20.1.1.1

[RouterC-Tunnel0] quit

(3)        配置OSPF协议

# 在Router A上配置OSPF协议。

[RouterA] ospf 1

[RouterA-ospf-1] area 0

[RouterA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255

[RouterA-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[RouterA-ospf-1-area-0.0.0.0] network 50.1.1.0 0.0.0.255

[RouterA-ospf-1-area-0.0.0.0] quit

[RouterA-ospf-1] quit

# 在Router B上配置OSPF协议。

<RouterB> system-view

[RouterB] ospf 1

[RouterB-ospf-1] area 0

[RouterB-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[RouterB-ospf-1-area-0.0.0.0] quit

[RouterB-ospf-1] quit

# 在Router C上配置OSPF协议。

[RouterC] ospf 1

[RouterC-ospf-1] area 0

[RouterC-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] network 40.1.1.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] network 50.1.1.0 0.0.0.255

[RouterC-ospf-1-area-0.0.0.0] quit

[RouterC-ospf-1] quit

(4)        使能IP组播路由,并使能PIM-DM和IGMP

# 在Router A上使能IP组播路由,并在各接口上使能PIM-DM。

[RouterA] multicast routing-enable

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] pim dm

[RouterA-Ethernet1/1] quit

[RouterA] interface ethernet 1/2

[RouterA-Ethernet1/2] pim dm

[RouterA-Ethernet1/2] quit

[RouterA] interface tunnel 0

[RouterA-Tunnel0] pim dm

[RouterA-Tunnel0] quit

# Router C上使能IP组播路由,在各接口上使能PIM-DM,并在主机侧接口Ethernet1/1上使能IGMP

[RouterC] multicast routing-enable

[RouterC] interface ethernet 1/1

[RouterC-Ethernet1/1] igmp enable

[RouterC-Ethernet1/1] pim dm

[RouterC-Ethernet1/1] quit

[RouterC] interface ethernet 1/2

[RouterC-Ethernet1/2] pim dm

[RouterC-Ethernet1/2] quit

[RouterC] interface tunnel 0

[RouterC-Tunnel0] pim dm

[RouterC-Tunnel0] quit

(5)        配置组播静态路由

# 在Router C上配置组播静态路由,指定到Source的RPF邻居为Router A的Tunnel0接口。

[RouterC] ip rpf-route-static 10.1.1.0 24 50.1.1.1

(6)        检验配置效果

组播源向组播组225.1.1.1发送组播数据,接收者加入该组播组后能够收到组播源发来的组播数据。通过使用display pim routing-table命令可以查看路由器的PIM路由表信息。例如:

# 查看Router C上的PIM路由表信息。

[RouterC] display pim routing-table

 VPN-Instance: public net

 Total 1 (*, G) entry; 1 (S, G) entry

 

 (*, 225.1.1.1)

     Protocol: pim-dm, Flag: WC

     UpTime: 00:04:25

     Upstream interface: NULL

         Upstream neighbor: NULL

         RPF prime neighbor: NULL

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Ethernet1/1

             Protocol: igmp, UpTime: 00:04:25, Expires: never

 

 (10.1.1.100, 225.1.1.1)

     Protocol: pim-dm, Flag: ACT

     UpTime: 00:06:14

     Upstream interface: Tunnel0

         Upstream neighbor: 50.1.1.1

         RPF prime neighbor: 50.1.1.1

     Downstream interface(s) information:

     Total number of downstreams: 1

         1: Ethernet1/1

             Protocol: pim-dm, UpTime: 00:04:25, Expires: never

Router CRPF邻居为Router A,组播数据通过GRE隧道由直接Router A发往Router C

1.7  常见配置错误举例

1.7.1  组播静态路由失败

1. 故障现象

路由器没有配置动态路由协议,接口的物理状态与链路层协议状态都显示为up;但是组播静态路由失败。

2. 分析

l              如果没有正确配置或更新与当前网络情况相匹配的组播静态路由,则组播路由表中不存在此路由项以及组播静态路由的配置信息;

l              如果查询到有比组播静态路由更优的路由,也可能导致组播静态路由失败。

3. 处理过程

(1)        使用display multicast routing-table static命令在组播路由表中查看组播静态路由的信息,以确定是否正确配置了对应的路由并存在于组播路由表中;

(2)        检查组播静态路由下一跳接口的接口类型。若为非点到点接口,则配置组播静态路由时,出接口必须使用下一跳地址的形式配置;

(3)        检查组播静态路由是否匹配指定的路由协议。如果配置组播静态路由时指定了协议,则使用display ip routing-table命令检查该协议是否添加了相同的路由;

(4)        检查组播静态路由是否匹配指定的路由策略。如果配置组播静态路由时指定了路由策略,则使用display route-policy命令检查配置的路由策略。

1.7.2  组播数据无法到达接收者

1. 故障现象

组播数据可以到达一些路由器,但无法到达最后一跳路由器。

2. 分析

l              路由器在转发组播数据时,将收到的组播数据报文IP头的TTL值减1,重新计算校验和,然后向所有出接口转发。如果出接口上配置了multicast minimum-ttl命令,则组播数据IP头的TTL值必须大于配置的最小TTL值时才会转发组播数据,否则组播数据报文将会被丢弃;

l              通过在接口上使用multicast boundary命令可以设置组播转发边界,组播数据是无法跨越该边界的。

3. 处理过程

(1)        使用display pim routing-table命令查看各路由器上是否有(S,G)表项:如果有则表示收到了组播数据;否则表示没有收到组播数据。

(2)        使用display multicast minimum-ttl命令检查组播转发的最小TTL值。在接口上使用undo multicast minimum-ttl命令恢复缺省值,或者增加从组播源发出的组播数据报文的TTL值。

(3)        使用display multicast boundary命令来查看接口的组播边界信息。使用multicast boundary命令来更改组播转发边界。

(4)        若采用了PIM-SM,使用display current-configuration命令检查是否配置了BSR和RP。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!