选择区域语言: EN CN HK

06-三层技术-IP业务配置指导

12-GRE配置

本章节下载  (358.43 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Operation_Manual/H3C_MSR_CG-R2207(V1.11)/06/201212/768419_30005_0.htm

12-GRE配置


1 GRE配置

1.1  GRE简介

1.1.1  协议简介

GRE(Generic Routing Encapsulation,通用路由封装)协议是对某些网络层协议(如IP和IPX)的数据报文进行封装,使这些被封装的数据报文能够在另一个网络层协议(如IP)中传输。GRE是Tunnel(隧道)技术的一种,属于第三层隧道协议。

GRE隧道是一个虚拟的点到点的连接,为封装的数据报文提供了一条传输通路,GRE隧道的两端分别对数据报进行封装及解封装。

图1-1 X协议网络通过GRE隧道互连

 

下面以图1-1的网络为例说明X协议的报文穿越IP网络在GRE隧道中传输的过程:

1. 加封装过程

l              Device A连接Group 1的接口收到X协议报文后,首先交由X协议处理;

l              X协议检查报文头中的目的地址域来确定如何路由此包;

l              若报文的目的地址要经过Tunnel才能到达,则设备将此报文发给相应的Tunnel接口;

l              Tunnel接口收到此报文后进行GRE封装,再封装IP报文头后,设备根据此IP包的目的地址及路由表对报文进行转发,从相应的网络接口发送出去。

2. GRE封装后的报文格式

封装后的报文形式如图1-2所示:

图1-2 封装后的报文格式

 

举例来说,一个封装在IP Tunnel中的X协议报文的格式如下:

图1-3 IP Tunnel中传输报文的格式

 

需要封装和传输的数据报文,称之为净荷(Payload),净荷的协议类型为乘客协议(Passenger Protocol)。系统收到一个净荷后,首先使用封装协议(Encapsulation Protocol)对这个净荷进行GRE封装,即把乘客协议报文进行了“包装”,加上了一个GRE头部成为GRE报文;然后再把封装好的原始报文和GRE头部封装在IP报文中,这样就可完全由IP层负责此报文的前向转发(Forwarding)。通常把这个负责前向转发的IP协议称为传输协议(Delivery Protocol或者Transport Protocol)。

根据传输协议的不同,可以分为GRE over IPv4和GRE over IPv6两种隧道模式。

3. 解封装的过程

解封装过程和加封装的过程相反。

l              Device B从Tunnel接口收到IP报文,检查目的地址;

l              如果目的地是本路由器,且IP报文头中的协议号为47(表示封装的报文为GRE报文),则Device B剥掉此报文的IP报头,交给GRE协议处理(进行检验密钥、检查校验和及报文的序列号等);

l              GRE协议完成相应的处理后,剥掉GRE报头,再交由X协议对此数据报进行后续的转发处理。

GRE收发双方的加封装、解封装处理,以及由于封装造成的数据量增加,会导致使用GRE后设备的数据转发效率有一定程度的下降。

 

1.1.2  GRE的安全选项

为了提高GRE隧道的安全性,GRE还支持由用户选择设置Tunnel接口的识别关键字(或称密钥),和对隧道封装的报文进行端到端校验。

在RFC 1701中规定:

l              若GRE报文头中的Key标识位置1,则收发双方将进行通道识别关键字的验证,只有Tunnel两端设置的识别关键字完全一致时才能通过验证,否则将报文丢弃。

l              若GRE报文头中的Checksum标识位置1,则校验和有效。发送方将根据GRE头及Payload信息计算校验和,并将包含校验和的报文发送给对端。接收方对接收到的报文计算校验和,并与报文中的校验和比较,如果一致则对报文进行进一步处理,否则丢弃。

1.1.3  应用范围

GRE主要应用于以下几种环境:

1. 多协议的本地网通过单一协议的骨干网传输

图1-4 多协议本地网通过单一协议骨干网传输

 

图1-4中,Group 1和Group 2是运行Novell IPX协议的本地网,Team 1和Team 2是运行IP协议的本地网。通过在Device A和Device B之间采用GRE协议封装的隧道,Group 1和Group 2、Team 1和Team 2可以互不影响地进行通信。

2. 扩大了跳数受限协议(如RIP)的工作范围

图1-5 扩大网络工作范围

 

两台终端之间的跳数超过15,它们将无法通信。通过在网络中使用隧道可以隐藏一部分跳数,从而扩大网络的工作范围。

3. 将一些不能连续的子网连接起来,用于组建VPN

图1-6 Tunnel连接不连续子网

 

运行Novell IPX协议的两个子网Group 1和Group 2分别在不同的城市,通过使用隧道可以实现跨越广域网的VPN。

4. 与IPsec结合使用

图1-7 GRE-IPsec隧道应用

 

GRE可以和IPsec结合使用,即对于路由协议、语音、视频等数据先进行GRE封装,再对封装后的报文进行IPsec的加密处理,以提高数据在隧道中传输的安全性。

1.1.4  协议规范

与GRE相关的协议规范有:

l              RFC 1701:Generic Routing Encapsulation (GRE)

l              RFC 1702:Generic Routing Encapsulation over IPv4 networks

l              RFC 2784:Generic Routing Encapsulation (GRE)

1.2  配置GRE over IPv4隧道

1.2.1  配置准备

设备上存在已经配置IP地址、能够进行正常通讯的接口(如VLAN接口,Ethernet接口,Loopback接口等),该接口将作为Tunnel接口的源接口。

1.2.2  配置GRE over IPv4隧道

表1-1 配置GRE over IPv4隧道

操作

命令

说明

进入系统视图

system-view

-

创建一个Tunnel接口,并进入该Tunnel接口视图

interface tunnel interface-number

必选

缺省情况下,设备上无Tunnel接口

设置Tunnel接口的IPv4地址

ip address ip-address { mask | mask-length }

必选

缺省情况下,Tunnel接口上没有设置IPv4地址

配置隧道模式为GRE over IPv4

tunnel-protocol gre

可选

缺省情况下,隧道模式为GRE

在隧道的两端应配置相同的隧道模式,否则可能造成报文传输失败

设置Tunnel接口的源端地址或接口

source { ip-address | interface-type interface-number }

必选

缺省情况下,Tunnel接口上没有设置源端地址和接口

设置Tunnel接口的目的端地址

destination ip-address

必选

缺省情况下,Tunnel接口上没有设置目的端地址

使能GRE的keepalive功能,探测Tunnel接口状态,并配置keepalive报文发送周期及最大发送次数

keepalive [ seconds [ times ] ]

可选

缺省情况下,不启用GRE的keepalive功能

使能GRE报文校验和功能

gre checksum

可选

缺省情况下,未使能GRE报文校验和功能

设置GRE类型隧道接口的密钥

gre key key-number

可选

缺省情况下,没有设置GRE类型隧道接口的密钥

隧道两端要么设置相同的密钥,要么都不设置密钥

配置通过Tunnel转发报文的路由

配置的详细情况请参见“三层技术-IP路由配置指导”中的“静态路由”或其他路由协议配置

必选

在源端路由器和目的端路由器上都必须存在经过Tunnel转发报文的路由,这样需要进行GRE封装的报文才能正确转发。可以配置静态路由,也可以配置动态路由

退回系统视图

quit

-

配置丢弃含有IPv4兼容IPv6地址的IPv6报文

tunnel discard ipv4-compatible-packet

可选

缺省情况下,不会丢弃含有IPv4兼容IPv6地址的IPv6报文

 

l          Tunnel接口的详细介绍,及Tunnel接口下的更多配置命令,请参见“三层技术-IP业务配置指导”中的“隧道”。

l          interface tunneltunnel-protocolsourcedestinationtunnel discard ipv4-compatible-packet命令的详细介绍,请参见“三层技术-IP业务命令参考”中的“隧道”。

 

l          Tunnel的源端地址与目的端地址唯一标识了一个通道。Tunnel两端必须配置源端地址与目的端地址,且两端地址互为源地址和目的地址。

l          两个或两个以上使用同种封装协议的Tunnel接口不能配置完全相同的源地址和目的地址。

l          配置Tunnel接口的源端地址时,若采用配置源接口形式,则Tunnel的源地址取的是源接口的主IP地址。

l          隧道两端可以根据实际应用的需要决定配置校验和或禁止校验和。如果本端配置了校验和而对端没有配置,则本端将不会对接收到的报文进行校验和检查,但对发送的报文计算校验和;相反,如果本端没有配置校验和而对端已配置,则本端将对从对端发来的报文进行校验和检查,但对发送的报文不计算校验和。

l          配置通过Tunnel转发的路由时,可以手工配置一条静态路由,目的地址是未进行GRE封装的报文的目的地址,下一跳是对端Tunnel接口的地址。也可以在Tunnel接口上和与私网相连的路由器接口上分别使能动态路由协议,由动态路由协议来建立通过Tunnel转发的路由表项。

l          在Tunnel接口配置的静态路由的目的地址不能与Tunnel接口的地址在同一网段。

 

1.3  配置GRE over IPv6隧道

1.3.1  配置准备

设备上存在已经配置IP地址、能够进行正常通讯的接口(如VLAN接口,Ethernet接口,Loopback接口等),该接口将作为Tunnel接口的源接口。

1.3.2  配置GRE over IPv6隧道

表1-2 配置GRE over IPv6隧道

操作

命令

说明

进入系统视图

system-view

-

使能IPv6报文转发功能

ipv6

必选

缺省情况下,关闭IPv6报文转发功能

创建一个Tunnel接口,并进入该Tunnel接口视图

interface tunnel interface-number

必选

缺省情况下,设备上无Tunnel接口

设置Tunnel接口的IPv4地址

ip address ip-address { mask | mask-length }

必选

缺省情况下,Tunnel接口上没有设置IPv4地址

配置隧道模式为GRE over IPv6

tunnel-protocol gre ipv6

必选

在隧道的两端应配置相同的隧道模式,否则可能造成报文传输失败

设置Tunnel接口的源端地址或接口

source { ipv6-address | interface-type interface-number }

必选

缺省情况下,Tunnel接口上没有设置源端地址和接口

设置Tunnel接口的目的端地址

destination ipv6-address

必选

缺省情况下,Tunnel接口上没有设置目的端地址

使能GRE报文校验和功能

gre checksum

可选

缺省情况下,未使能GRE报文校验和功能

设置GRE类型隧道接口的密钥

gre key key-number

可选

缺省情况下,没有设置GRE类型隧道接口的密钥

隧道两端要么设置相同的密钥,要么都不设置密钥

退回系统视图

quit

-

配置丢弃含有IPv4兼容IPv6地址的IPv6报文

tunnel discard ipv4-compatible-packet

可选

缺省情况下,不会丢弃含有IPv4兼容IPv6地址的IPv6报文

配置通过Tunnel转发报文的路由

配置的详细情况请参见“三层技术-IP路由配置指导”中的“静态路由”或其他路由协议配置

必选

在源端路由器和目的端路由器上都必须存在经过Tunnel转发报文的路由,这样需要进行GRE封装的报文才能正确转发。可以配置静态路由,也可以配置动态路由

 

l          interface tunneltunnel-protocolsourcedestinationtunnel discard ipv4-compatible-packet命令的详细介绍,请参见“三层技术-IP业务命令参考”中的“隧道”。

l          Tunnel接口的详细介绍,及Tunnel接口下的更多配置命令,请参见“三层技术-IP业务配置指导”中的“隧道”。

 

l          以上各项Tunnel接口下进行的功能特性配置,在删除Tunnel接口后,该接口上的所有配置也将被删除。

l          Tunnel的源端地址与目的端地址唯一标识了一个通道。Tunnel两端必须配置源端地址与目的端地址,且两端地址互为源地址和目的地址。

l          两个或两个以上使用同种封装协议的Tunnel接口不能配置完全相同的源地址和目的地址。

l          配置Tunnel接口的源端地址时,若采用配置源接口形式,则Tunnel的源地址取的是源接口的主IP地址。

l          隧道两端可以根据实际应用的需要决定配置校验和或禁止校验和。如果本端配置了校验和而对端没有配置,则本端将不会对接收到的报文进行校验和检查,但对发送的报文计算校验和;相反,如果本端没有配置校验和而对端已配置,则本端将对从对端发来的报文进行校验和检查,但对发送的报文不计算校验和。

l          配置通过Tunnel转发的路由时,可以手工配置一条静态路由,目的地址是未进行GRE封装的报文的目的地址,下一跳是对端Tunnel接口的地址。也可以在Tunnel接口上和与私网相连的路由器接口上分别使能动态路由协议,由动态路由协议来建立通过Tunnel转发的路由表项。

l          在Tunnel接口配置的静态路由的目的地址不能与Tunnel接口的地址在同一网段。

 

1.4  GRE显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示配置后GRE的运行情况,通过查看显示信息验证配置的效果。

表1-3 GRE的显示和维护

操作

命令

显示Tunnel接口的相关信息

display interface [ tunnel ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

display interface tunnel number [ brief ] [ | { begin | exclude | include } regular-expression ]

显示Tunnel接口的IPv6相关信息

display ipv6 interface tunnel [ number ] [ verbose ] [ | { begin | exclude | include } regular-expression ]

 

display interface tunnel和display ipv6 interface tunnel命令的详细介绍,请参见“三层技术-IP业务命令参考”中的“隧道”。

 

1.5  GRE over IPv4典型配置举例

1.5.1  GRE over IPv4典型配置举例

1. 组网需求

路由器Router A和路由器Router B之间通过Internet相连。运行IP协议的私有网络的两个子网Group 1和Group 2,通过在两台路由器之间使用GRE建立隧道实现互联。

2. 组网图

图1-8 GRE over IPv4应用组网图

 

3. 配置步骤

在开始下面的配置之前,需确保Router A和Router B之间路由可达。

 

(1)        配置路由器Router A

# 配置接口Ethernet1/1。

<RouterA> system-view

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] ip address 10.1.1.1 255.255.255.0

[RouterA-Ethernet1/1] quit

# 配置接口Serial2/0(隧道的实际物理接口)。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 1.1.1.1 255.255.255.0

[RouterA-Serial2/0] quit

# 创建Tunnel0接口。

[RouterA] interface tunnel 0

# 配置Tunnel0接口的IP地址。

[RouterA-Tunnel0] ip address 10.1.2.1 255.255.255.0

# 配置Tunnel封装模式为GRE over IPv4隧道模式。

[RouterA-Tunnel0] tunnel-protocol gre

# 配置Tunnel0接口的源地址(Serial2/0的IP地址)。

[RouterA-Tunnel0] source 1.1.1.1

# 配置Tunnel0接口的目的地址(Router BSerial2/1IP地址)。

[RouterA-Tunnel0] destination 2.2.2.2

[RouterA-Tunnel0] quit

# 配置从Router A经过Tunnel0接口到Group 2的静态路由。

[RouterA] ip route-static 10.1.3.0 255.255.255.0 tunnel 0

(2)        配置路由器Router B

# 配置接口Ethernet1/1。

<RouterB> system-view

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ip address 10.1.3.1 255.255.255.0

[RouterB-Ethernet1/1] quit

# 配置接口Serial2/1(隧道的实际物理接口)。

[RouterB] interface serial 2/1

[RouterB-Serial2/1] ip address 2.2.2.2 255.255.255.0

[RouterB-Serial2/1] quit

# 创建Tunnel0接口。

[RouterB] interface tunnel 0

# 配置Tunnel0接口的IP地址。

[RouterB-Tunnel0] ip address 10.1.2.2 255.255.255.0

# 配置Tunnel封装模式为GRE over IPv4隧道模式。

[RouterB-Tunnel0] tunnel-protocol gre

# 配置Tunnel0接口的源地址(Serial2/1的IP地址)。

[RouterB-Tunnel0] source 2.2.2.2

# 配置Tunnel0接口的目的地址(Router A的Serial2/0的IP地址)。

[RouterB-Tunnel0] destination 1.1.1.1

[RouterB-Tunnel0] quit

# 配置从Router B经过Tunnel0接口到Group 1的静态路由。

[RouterB] ip route-static 10.1.1.0 255.255.255.0 tunnel 0

(3)        验证配置结果

# 完成以上配置后,分别查看Router ARouter BTunnel接口状态。

[RouterA] display interface tunnel 0

Tunnel0 current state: UP

Line protocol current state: UP

Description: Tunnel0 Interface

The Maximum Transmit Unit is 1476

Internet Address is 10.1.2.1/24 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source 1.1.1.1, destination 2.2.2.2

Tunnel keepalive disabled

Tunnel protocol/transport GRE/IP

    GRE key disabled

    Checksumming of GRE packets disabled

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  0 bytes/sec, 0 packets/sec

    10 packets input,  840 bytes

    0 input error

    10 packets output,  840 bytes

    0 output error

[RouterB] display interface tunnel 0

Tunnel0 current state: UP

Line protocol current state: UP

Description: Tunnel0 Interface

The Maximum Transmit Unit is 1476

Internet Address is 10.1.2.2/24 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source 2.2.2.2, destination 1.1.1.1

Tunnel keepalive disabled

Tunnel protocol/transport GRE/IP

    GRE key disabled

    Checksumming of GRE packets disabled

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  2 bytes/sec, 0 packets/sec

    Last 300 seconds output:  2 bytes/sec, 0 packets/sec

    10 packets input,  840 bytes

    0 input error

    10 packets output,  840 bytes

    0 output error

# 从Router B可以Ping通Router A上Ethernet1/1接口的地址。

[RouterB] ping 10.1.1.1

  PING 10.1.1.1: 56  data bytes, press CTRL_C to break

    Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=2 ms

    Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=2 ms

    Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=2 ms

    Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=2 ms

    Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=2 ms

 

  --- 10.1.1.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 2/2/2 ms

1.6  GRE over IPv6典型配置举例

1.6.1  GRE over IPv6典型配置举例

1. 组网需求

运行IP协议的两个子网Group 1和Group 2通过IPv6网络相连。通过在路由器Router A和路由器Router B之间建立GRE over IPv6隧道,实现两个子网穿越IPv6网络互联。

2. 组网图

图1-9 GRE over IPv6应用组网图

 

3. 配置步骤

在开始下面的配置之前,需确保Router A和Router B之间路由可达。

 

(1)        配置路由器Router A

<RouterA> system-view

# 使能IPv6。

[RouterA] ipv6

# 配置接口Ethernet1/1。

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] ip address 10.1.1.1 255.255.255.0

[RouterA-Ethernet1/1] quit

# 配置接口Serial2/0(隧道的实际物理接口)。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ipv6 address 2002::1:1 64

[RouterA-Serial2/0] quit

# 创建Tunnel0接口。

[RouterA] interface tunnel 0

# 配置Tunnel0接口的IP地址。

[RouterA-Tunnel0] ip address 10.1.2.1 255.255.255.0

# 配置Tunnel封装模式为GRE over IPv6隧道模式。

[RouterA-Tunnel0] tunnel-protocol gre ipv6

# 配置Tunnel0接口的源地址(Serial2/0的IP地址)。

[RouterA-Tunnel0] source 2002::1:1

# 配置Tunnel0接口的目的地址(Router BSerial2/1IP地址)。

[RouterA-Tunnel0] destination 2001::2:1

[RouterA-Tunnel0] quit

# 配置从Router A经过Tunnel0接口到Group 2的静态路由。

[RouterA] ip route-static 10.1.3.0 255.255.255.0 tunnel 0

(2)        配置路由器Router B

<RouterB> system-view

# 使能IPv6。

[RouterB] ipv6

# 配置接口Ethernet1/1。

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ip address 10.1.3.1 255.255.255.0

[RouterB-Ethernet1/1] quit

# 配置接口Serial2/1(隧道的实际物理接口)。

[RouterB] interface serial 2/1

[RouterB-Serial2/1] ipv6 address 2001::2:1 64

[RouterB-Serial2/1] quit

# 创建Tunnel0接口。

[RouterB] interface tunnel 0

# 配置Tunnel0接口的IP地址。

[RouterB-Tunnel0] ip address 10.1.2.2 255.255.255.0

# 配置Tunnel封装模式为GRE over IPv6隧道模式。

[RouterB-Tunnel0] tunnel-protocol gre ipv6

# 配置Tunnel0接口的源地址(Serial2/1的IP地址)。

[RouterB-Tunnel0] source 2001::2:1

# 配置Tunnel0接口的目的地址(Router A的Serial2/0的IP地址)。

[RouterB-Tunnel0] destination 2002::1:1

[RouterB-Tunnel0] quit

# 配置从Router B经过Tunnel0接口到Group 1的静态路由。

[RouterB] ip route-static 10.1.1.0 255.255.255.0 tunnel 0

(3)        验证配置结果

# 完成以上配置后,分别查看Router ARouter BTunnel接口状态。

[RouterA] display interface Tunnel 0

Tunnel0 current state: UP

Line protocol current state: UP

Description: Tunnel0 Interface

The Maximum Transmit Unit is 1456

Internet Address is 10.1.2.1/24 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source 2002::1:1, destination 2001::2:1

Tunnel protocol/transport GRE/IPv6

    GRE key disabled

    Checksumming of GRE packets disabled

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  0 bytes/sec, 0 packets/sec

    10 packets input,  840 bytes

    0 input error

    10 packets output,  840 bytes

    0 output error

[RouterB] display interface Tunnel 0

Tunnel0 current state: UP

Line protocol current state: UP

Description: Tunnel0 Interface

The Maximum Transmit Unit is 1456

Internet Address is 10.1.2.2/24 Primary

Encapsulation is TUNNEL, service-loopback-group ID not set.

Tunnel source 2001::2:1, destination 2002::1:1

Tunnel protocol/transport GRE/IPv6

    GRE key disabled

    Checksumming of GRE packets disabled

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters:  Never

    Last 300 seconds input:  0 bytes/sec, 0 packets/sec

    Last 300 seconds output:  0 bytes/sec, 0 packets/sec

    10 packets input,  840 bytes

    0 input error

    10 packets output,  840 bytes

    0 output error

# 从Router B可以Ping通Router A上Ethernet1/1接口的地址。

[RouterB] ping 10.1.1.1

  PING 10.1.1.1: 56  data bytes, press CTRL_C to break

    Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=3 ms

    Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=2 ms

    Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=2 ms

    Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=2 ms

    Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=3 ms

 

  --- 10.1.1.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 2/2/3 ms

1.7  常见配置错误举例

GRE的配置相对比较简单,但要注意配置的一致性,大部分的错误都可以通过使用调试命令debugging gredebugging tunnel定位。这里仅就一种错误进行分析,如图1-10所示。

图1-10 GRE排错示例

 

故障之一:Tunnel两端接口配置正确且Tunnel两端可以ping通,但Host A和Host B之间却无法ping通。

故障排除:可以按照如下步骤进行。

l              在任意视图下,在Router A和Router C分别执行display ip routing-table命令,观察在Router A是否有经过Tunnel0接口到10.2.0.0/16的路由;在Router C是否有经过Tunnel0接口到10.1.0.0/16的路由。

l              如果在上一步的输出中发现缺少相应的静态路由,在系统视图下使用ip route-static命令添加。以Router A为例,配置如下:

[RouterA] ip route-static 10.2.0.0 255.255.0.0 tunnel 0

 


不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!