选择区域语言: EN CN HK

04-二层技术-广域网接入配置指导

13-LAPB和X.25配置

本章节下载  (1.04 MB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Configure/Operation_Manual/H3C_MSR_CG-R2207(V1.11)/04/201212/768400_30005_0.htm

13-LAPB和X.25配置

  录

1 LAPB和X.25配置

1.1 LAPB和X.25协议简介

1.1.1 X.25协议

1.1.2 LAPB协议

1.1.3 虚电路

1.1.4 X.25交换功能

1.2 配置LAPB

1.2.1 LAPB协议参数介绍

1.2.2 配置LAPB

1.3 配置X.25接口

1.3.1 配置X.25接口基本参数

1.3.2 配置X.25接口附加参数

1.3.3 配置X.25子接口

1.4 配置X.25数据报传输

1.4.1 配置X.25数据报传输基本功能

1.4.2 配置X.25数据报传输的附加参数

1.5 配置X.25交换

1.5.1 配置X.25交换基本功能

1.5.2 配置X.25交换流量控制参数协商功能

1.6 配置X.25负载分担

1.7 配置X.25封闭用户群

1.8 配置X.25 PAD远程登录服务

1.8.1 X.25 PAD简介

1.8.2 配置X.25 PAD

1.9 配置XOT

1.9.1 XOT协议简介

1.9.2 配置XOT

1.10 配置X.25 Over FR

1.10.1 X.25 Over FR协议简介

1.10.2 配置X.25 Over FR的SVC应用

1.10.3 配置X.25 Over FR的PVC应用

1.11 配置X2T

1.11.1 X2T简介

1.11.2 配置X2T

1.12 LAPB和X.25显示和维护

1.13 LAPB典型配置举例

1.14 X.25典型配置举例

1.14.1 两台设备直连的X.25配置举例(一条地址映射)

1.14.2 两台设备直连的X.25配置举例(两条地址映射)

1.14.3 将设备接入到X.25公共分组网中配置举例

1.14.4 虚电路范围配置举例

1.14.5 通过X.25 PVC传输IP数据报配置举例

1.14.6 X.25子接口配置举例

1.14.7 XOT的SVC应用配置举例

1.14.8 XOT的PVC应用配置举例

1.14.9 X.25 Over FR的SVC应用配置举例

1.14.10 X.25 Over FR的PVC应用配置举例

1.14.11 X.25负载分担应用配置举例

1.14.12 X.25负载分担承载IP数据传输配置举例

1.14.13 TCP/IP头压缩协议应用配置举例

1.14.14 X.25 PAD应用配置举例

1.14.15 X2T SVC配置举例

1.14.16 X2T PVC配置举例

1.15 LAPB常见配置错误举例

1.15.1 相连双方的链路层协议为LAPB(或X.25),但协议一直为断开状态

1.15.2 相连双方的链路层协议X.25已处于UP状态,但ping不通对方

1.16 X.25常见配置错误举例

1.16.1 LAPB已经处于“连接(Connect)”状态,但是X.25协议却迟迟不能UP

1.16.2 X.25协议已经UP,但是却无法建立虚电路,即无法ping通

1.16.3 可以建立虚电路,但是在数据传输的过程中却频繁地复位或清除

1.16.4 配置永久虚电路的请求被拒绝

1.16.5 X.25 PAD常见配置错误举例

1.16.6 配置XOT的SVC应用后不能ping通

1.16.7 配置XOT的PVC应用后不能ping通

 


1 LAPB和X.25配置

MSR系列路由器各款型对于本节所描述的特性支持情况有所不同,详细差异信息如下:

MSR 900路由器不支持LAPB和X.25。

 

1.1  LAPB和X.25协议简介

1.1.1  X.25协议

X.25协议是DTE(Data Terminal Equipment,数据终端设备)和DCE(Data Circuit-terminating Equipment,数据电路终接设备)之间进行点到点交互的接口规程,它定义了从物理层到分组层一共三层的内容。

1974年,CCITT颁布了X.25的第一稿,它的最初文件取材于美国的Telenet、Tymnet和加拿大的Datapac分组交换网的经验和建议,之后进行了多次修改,增添了许多可选业务功能和设施。

通常情况下,DTE是指用户侧的主机或终端,DCE则是指同步调制解调器等设备。

DTE与DCE直接连接,DCE连接至分组交换机的某个端口,分组交换机之间建立若干连接,这样,便形成了DTE与DTE之间的通路。在一个X.25网络中,各实体之间的关系如图1-1所示。

图1-1 X.25网络模型

DTE数据终端设备

Data Terminal Equipment

DCE数据电路终结设备

Data Circuit-terminating Equipment

PSE分组交换设备

Packet Switching Equipment

PSN分组交换网

Packet Switching Network

 

按照OSI参考模型的结构,X.25协议定义了从物理层到分组层一共三层的内容。如图1-2所示。

图1-2 X.25协议层次示意图

 

l              第一层(物理层):定义了DTE与DCE之间进行连接时的物理电气特性

l              第二层(链路层):定义了DTE与DCE之间交互的帧的格式和规程,即平衡型链路接入规程LAPB(Link Access Procedure,Balanced)

l              第三层(分组层):描述了分组层所使用分组的格式,以及两个三层实体之间进行分组交换的规则

X.25第三层复用第二层在DTE/DCE间建立的链路,最终提供给用户若干条虚电路。

X.25各层之间分组与帧的关系如图1-3所示。

图1-3 X.25的分组与LAPB帧

 

1.1.2  LAPB协议

X.25的链路层协议LAPB定义了DTE与DCE之间交互的帧的格式和规程。从分层的观点来看,链路层好像是给DTE的分组层接口和DCE的分组层接口之间架设了一道桥梁。DTE的分组层和DCE的分组层之间可以通过这座桥梁不断传送分组。

链路层的主要功能如下:

l              在DTE和DCE之间有效地传输数据

l              确保接收器和发送器之间信息的同步

l              检测和纠正传输中产生的差错

l              识别并向高层协议报告规程性错误

l              向分组层通知链路层的状态

国际标准规定的X.25链路层协议LAPB,采用了HDLC(High-level Data Link Control,高级数据链路控制规程)的帧结构,并且是它的一个子集。它通过SABM(Set Asynchronous Balanced Mode,置异步平衡模式)命令要求建立链路。建立链路时只需要由两个设备中的任意一个设备发送SABM命令,另一设备发送UA(Unnumbered Acknowledge,无编号确认)响应即可以完成双向链路的建立。

虽然LAPB是作为X.25的第二层被定义的,但是,作为独立的链路层协议,它可以直接承载非X.25的上层协议进行数据传输。可以配置串口的链路层协议为LAPB,进行简单的本地数据传输。

1.1.3  虚电路

利用X.25,两台DTE可以通过现有的电话网络进行通信。为了进行一次通信,通信的一端必须首先呼叫另一端,请求在它们之间建立一个会话连接;被呼叫的一端可以根据自己的情况接收或拒绝这个连接请求。一旦这个连接建立,两端的设备可以全双工地进行信息传输,并且任何一端在任何时候均有权拆除这个连接。

X.25协议为两台DTE通信而建立的连接称为虚电路。电路交换中的物理电路是真实存在的,而虚电路只是在逻辑上存在,它为两个通信端点提供虚拟的信道。

虚电路分为PVC(Permanent Virtual Circuit,永久虚电路)和SVC(Switched Virtual Circuit,交换虚电路)两种。PVC多用于频繁的、流量稳定的数据传输,而SVC多用于突发性的数据传输。

一旦在一对DTE之间建立一条虚电路,这条虚电路便被赋予一个唯一的虚电路号。当一台DTE要向另一台DTE发送分组时,它便给这个分组标上号(虚电路号)交给DCE设备,DCE根据分组携带的虚电路号决定如何在交换网内部交换这个数据分组,使其正确到达目的地。

1.1.4  X.25交换功能

设备支持X.25交换功能,可以将设备当作一台小型X.25分组交换机使用,保护用户在X.25之上的投资。图1-4描述了LAPB、X.25、X.25交换三者之间的关系。

图1-4 LAPB、X.25与X.25交换关系

 

LAPB之上可以承载X.25协议也可直接承载IP(在两台设备直接相连,不通过X.25网的情况)。系统中还有一个X.25交换模块,这样设备就可作为一个小型的分组交换机来使用,不经过上层而直接将分组转发过去。

简单地说,在X.25网络中,正常情况下,设备作为DTE或DCE;如果使用X.25交换功能,则设备是作为PSE。

1.2  配置LAPB

1.2.1  LAPB协议参数介绍

1. LAPB帧编号方式

LAPB帧编号方式有两种:模8和模128。每个数据帧(I帧)均按顺序编号,编号可以从0到模数减1,序列号就在这整个模数的范围内循环。

模8是基本方式,所有的标准LAPB都支持,并且对于大多数链路来说都足够了。

新的配置需要在执行shutdownundo shutdown命令重启接口后才能生效。

2. LAPB窗口参数K

LAPB窗口参数K表示在任何规定时间内DTE或DCE待确认的按序编号的最大帧数。

3. LAPB参数N1

LAPB参数N1表示DCE或DTE希望从DTE或DCE接收的I帧的最大比特数,该值应该为最大传输单元(MTU)加上协议头的总字节数的8倍。

4. LAPB参数N2

LAPB参数N2表示DCE或DTE为成功地向DTE或DCE发送一个帧而进行的最大尝试次数。

5. LAPB系统定时器

LAPB有4个系统定时器T1、T2、T3、T4,其作用如下:

l              T1为发送计时器,当T1计时器到时时,DTE(或DCE)就启动重发。T1的值应大于发送一个帧到接收到对它作出应答的帧之间的最大时间。

l              T2为接收计时器,当T2计时器到时时,DTE(或DCE)必须发送证实帧,使得对方DCE(或DTE)的T1定时器超时之前能接收到证实帧(T1≥2*T2)。

l              T3为空闲通道计时器,当T3计时器到时时,DCE向分组层报告链路出现了长时间的空闲通道状态,T3应当大于DCE侧的计时器T1(T3>T1)。T3为0意味着该定时器未起作用。

l              T4为链路探测计时器,当T4计时器到时时,会检测在设置的超时时间内是否收到了对方的RR帧应答,以此来维持链路连接:如果收到应答,则发送一个RR探测帧启动新一轮检测;如果没有收到应答,则会尝试重发,当尝试次数超过LAPB参数N2后,则会发起链路重协商。由于要依赖T1定时器进行重发,所以T4定时器的值要大于T1。T4为0意味着该定时器未起作用。

1.2.2  配置LAPB

表1-1 配置LAPB

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置接口的链路层协议为LAPB

link-protocol lapb [ dce | dte ] [ ip | multi-protocol ]

必选

缺省情况下,接口的链路层协议为PPP。当接口的链路层协议为LAPB时,接口缺省工作在DTE方式,承载的上层协议为IP

配置LAPB帧编号方式(又称模数)

lapb modulo { 8 | 128 }

可选

缺省情况下,LAPB帧编号方式为模8

必须执行shutdownundo shutdown命令重启接口后,该配置才能生效

配置LAPB窗口参数K

lapb window-size k-value

可选

缺省情况下,窗口参数K值为7

配置LAPB参数N1

lapb max-frame n1-value

可选

N1的缺省值是根据当前生效的MTU、上层协议和模值来计算的

配置LAPB参数N2

lapb retry n2-value

可选

缺省情况下,LAPB参数N2值为10

配置LAPB系统定时器T1、T2、T3、T4

lapb timer { t1 t1-value | t2 t2-value | t3 t3-value | t4 t4-value }

可选

缺省情况下:

l      定时器T1的值为3000毫秒

l      定时器T2的值为1500毫秒

l      定时器T3的值为0秒

l      定时器T4的值为0秒

使能LAPB非请求响应监测功能

lapb pollremote

可选

缺省情况下,LAPB非请求响应监测功能处于关闭状态

使能该功能后,当链路收到F比特为1的非请求响应帧时,将触发链路重新协商

 

1.3  配置X.25接口

1.3.1  配置X.25接口基本参数

1. X.25接口基本参数介绍

(1)        X.121地址

如果使用设备的目的是为了X.25交换,那么可以忽略此任务;如果将设备接入X.25公共分组网,那么必须为接入的X.25接口按照接入服务提供商的要求来配置一个X.121地址。X.25采用《ITU-T建议X.121》中规定的地址格式,X.121地址由长度为1到15的一串阿拉伯数字组成。

(2)        X.25工作模式

设备所支持的X.25第三层可以工作在DTE模式,也可以工作在DCE模式,同时还可以指定数据报的格式,可选择的格式有IETF和非标准两种格式。

需要注意的是,一般来说,X.25公共分组交换网均要求设备作为DTE侧接入,而且要求IETF格式。所以,在此时应该选择X.25在DTE工作模式下的IETF格式。如果只是简单地将两台设备的一对串口背靠背直连进行数据传输,此时只要保证传输的两端分别为DTE和DCE,并且数据报格式一致即可。

(3)        虚电路范围

X.25协议可以将DTE/DCE之间的一条实际的物理链路复用,建立多条在逻辑上存在的虚连接,这种虚连接称为VC(Virtual Circuit,虚电路)或LC(Logic Channel,逻辑信道)。X.25可以建立的虚连接最多为4095条,编号从1~4095,这个可以用来区分每一条VC或LC的编号称为VCN(Virtual Circuit Number,虚电路号)或LCI(Logic Channel Identifier,逻辑信道号)。

严格地说,虚电路和逻辑信道是两个不同的概念,但是在用户侧,通常不对它们进行严格区分。

 

X.25协议中很重要的一部分内容就是如何管理这一共4095条虚电路。

所有的虚电路号被划分成四个区域,这四个区域分别是(按编号的升序排列):

l              A-永久虚电路区间

l              B-单向呼入信道区间

l              C-双向信道区间

l              D-单向呼出信道区间

通过X.25呼叫建立的虚电路,其编号一定在B、C、D三者其一之中;而配置的永久虚电路则只能在区间A中。

那么,这些信道是如何被分配的呢?根据《ITU-T 建议 X.25》,X.25在发起呼叫时,采用如下的空闲信道分配策略:

l              只有DCE可以使用“单向呼入信道区间”中的信道发起呼叫;

l              只有DTE可以使用“单向呼出信道区间”中的信道发起呼叫;

l              DCE、DTE均可使用“双向信道区间”中的信道发起呼叫;

l              DCE总是使用最低的可使用的逻辑信道;

l              DTE总是使用最高的可使用的逻辑信道。

有了以上这一套策略,就可以避免通信的某一侧独占所有的信道,并且将呼叫碰撞发生的可能性降低到了最小。

X.25协议使用六个参数来界定这四个区域,如图1-5所示。

图1-5 X.25信道区间划分

 

六个参数意义请参见表1-2

表1-2 X.25信道区间划分参数的含义

参数

意义

LIC

Lowest Incoming-only Channel,最低单向呼入信道号

HIC

Highest Incoming-only Channel,最高单向呼入信道号

LTC

Lowest Two-way Channel,最低双向信道号

HTC

Highest Two-way Channel,最高双向信道号

LOC

Lowest Outgoing-only Channel,最低单向呼出信道号

HOC

Highest Outgoing-only Channel,最高单向呼出信道号

 

每一个区间(永久虚电路区间除外)被两个参数定义,可以称其为该区间的上限和下限,只有同时满足如下条件的配置才被认为是正确的配置:

l              严格升序,即1≤lic≤hic<ltc≤htc<loc≤hoc≤4095;

l              若某个区间的上、下限其中之一为0,那么另一个也必须为0(上、下限均为0表示该区间被禁止使用)。

最后,还有以下几点需要注意:

l              在一个物理连接的两侧(即DTE、DCE之间),X.25的这六个参数必须保证对应相等,否则,很有可能导致因规程无法正常进行而数据传输失败;

l              配置的过程中,在保证升序的前提下,一定要注意各参数的缺省情况,根据实际情况进行判断,完成参数的正确配置;

l              新的配置在X.25协议已经协商通的状态下是不能立即生效的,需要执行shutdownundo shutdown命令重启接口后配置才能生效。

(4)        X.25分组编号模数

X.25支持模8和模128两种分组顺序编号方式,模8方式是缺省的编号方式。

X.25规程需要DTE、DCE两侧具有同样的分组顺序编号方式。新的配置在X.25协议已经协商通的状态下是不能立即生效的,需要执行shutdownundo shutdown命令重启接口后配置才能生效。

另外,X.25第3层的分组顺序编号方式与LAPB(X.25第2层)的帧顺序编号方式二者之间是有区别的。当将模128的编号方式使用于高吞吐率的DTE/DCE接口时,对于LAPB来说,它只影响到本地的DTE/DCE接口效率(称为点到点效率)的提高;但对于X.25第三层来说,这个影响则是端到端的,即使得通信的两台DTE设备之间的效率提高了。

(5)        流量控制参数(包括配置窗口尺寸及分组长度)

X.25协议是具有强流量控制能力的可靠传输协议,它具有这种能力的基础是“窗口尺寸”和“最大分组长度”。只有在正确的配置下,X.25的流量控制能力才是有效的和正确的,任何不当的配置都会引起“清除”或“复原”事件的发生。

大多数X.25公共分组网都采用《ITU-T X.25建议》中规定的缺省的窗口尺寸和最大分组长度,而设备中X.25的窗口与分组长度的缺省值与《ITU-T X.25建议》的规定保持一致,所以这两个参数(缺省窗口尺寸及缺省分组长度)如果没有接入服务提供商的特殊要求,不必再配置。

当配置了缺省窗口尺寸和缺省最大分组长度之后,对于需要呼叫过程才能建立的SVC来说,如果在呼叫过程中没有进行相关参数协商的话(关于呼叫中的参数协商,将在后面小节中介绍),SVC将采用这些缺省值;对于不需要呼叫过程就建立的PVC来说,如果在指定PVC时没有附加窗口或分组长度选项(有关PVC的配置,请参见后续小节),PVC也将采用此缺省值。

X.25发送端会根据最大分组长度对上层超长的数据报文进行分片,并在最后一片碎片分组里打上标记(M比特不置位);报文到了接收端后,X.25将所有这些碎片分组进行重组,并根据M比特标记来判别是否已经接收到一块完整的上层报文。所以,过小的最大分组长度会使设备耗费过多的资源在报文的分片与重组之上,从而降低效率。

最后,还有以下两点值得注意:

l              最大分组长度,LAPB N1参数与MTU的关系,这三者之间的关系应该是最大分组长度 < MTU*8 < LAPB的N1;

l              新的配置也需要在执行shutdownundo shutdown命令重启接口后才能生效。

2. 配置X.25接口基本参数

表1-3 配置X.25接口基本参数

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置接口的链路层协议为X.25

link-protocol x25 [ dce |dte ] [ ietf | nonstandard ]

必选

缺省情况下,接口的链路层协议为PPP。当接口使用X.25协议时,缺省工作方式为DTE IETF

配置接口的X.121地址

x25 x121-address x.121-address

可选

如果使用设备的目的是为了X.25交换,那么可以忽略此任务;如果将设备接入X.25公共分组网,那么必须为接入的X.25接口按照接入服务提供商的要求来配置一个X.121地址

配置X.25虚电路范围

x25 vc-range { bi-channel ltc htc [ out-channel loc hoc ] | in-channel lic hic [ bi-channel ltc htc ] [ out-channel loc hoc ] | out-channel loc hoc }

可选

缺省情况下,X.25虚电路双向信道区间的下限为1,上限为1024;X.25虚电路范围中单向呼入信道区间的上限和下限均为0;X.25虚电路范围中单向呼出信道区间的上限和下限均0

必须执行shutdownundo shutdown命令重启接口后,该配置才能生效

配置X.25接口的编号方式

x25 modulo { 8 | 128 }

可选

缺省情况下,X.25接口采用模8方式

必须执行shutdownundo shutdown命令重启接口后,该配置才能生效

配置X.25接口接收窗口和发送窗口的尺寸

x25 window-size input-window-size output-window-size

可选

缺省情况下,X.25接口接收和发送窗口的尺寸均为2

必须执行shutdownundo shutdown命令重启接口后,该配置才能生效

配置X.25接口最大接收分组长度和最大发送分组长度

x25 packet-size input-packet output-packet

可选

缺省情况下,X.25接口的最大接收和最大发送分组长度均为128字节

必须执行shutdownundo shutdown命令重启接口后,该配置才能生效

 

1.3.2  配置X.25接口附加参数

1. X.25接口附加参数介绍

在某些特殊的网络环境中,需要对X.25的一些附加的参数进行配置。本节介绍的任务就是针对这些附加参数配置的。

(1)        X.25第三层定时器时延

为了保证X.25规程的顺利进行,X.25协议定义了一系列的定时器,当X.25发出某个控制报文后,在相应定时器到时之前,如果还没有接收到对这个控制报文的响应,那么X.25协议将采取相应的措施来处理这一异常事件。这些定时器的名称和针对的规程如表1-4所示。

表1-4 X.25第三层定时器

规程名称

定时器名称

DTE侧

DCE侧

重新启动

T20

T10

呼叫

T21

T11

复原

T22

T12

清除

T23

T13

登记

T28

-

 

其中,T28为“发送登记请求”定时器,仅在DTE侧定义,用于向网络动态申请或停止可选业务功能,缺省值为300秒,不能修改。

(2)        与X.25地址有关的属性

当X.25通过呼叫建立SVC时,需要使用X.25地址,X.25地址采用的是《ITU-T建议X.121》中规定的X.121地址格式。X.121地址由长度为1~15的一串阿拉伯数字组成。与接口的X.121地址有关的一些属性如下所示:

l              接口别名

当一个X.25的呼叫被跨网转发时,不同的网络很有可能根据自己的需要将被叫地址做出一定改变,如添加前缀,去掉前缀等。在这样的情况下,对于到达X.25接口的一个呼叫,或许其(指该呼叫)目的地址与目的接口的X.121地址不一致(原因是该呼叫的目的地址在网络内部被做了改动),但是该接口仍然应该接受这个呼叫,这时就需要为该接口指定一个或多个别名(Alias)。

为了适应不同网络的需求,X.25定义了九种匹配方式及其相应的别名串的格式,如表1-5所示。

表1-5 别名匹配方式及匹配意义

匹配方式

匹配意义

举例说明

free

自由式匹配,别名串形如1234

如1234将与561234、1234567、956123478匹配成功,而与12354等匹配失败

free-ext

扩展型自由式匹配,别名串形如...1234..

如...1234.. 将与678123459匹配成功,而与68123459、67812345、6781234591等匹配失败

left

左对齐匹配方式,别名串形如$1234

如$1234将与1234567、12346790匹配成功,但与3123478、123784等匹配失败

left-ext

扩展型左对齐匹配方式,别名串形$1234 ...

如$1234 ... 将与1234679、1234872匹配成功,而与123468、12346890等匹配失败

right

右对齐匹配方式,别名串形如1234$

如1234$将与791234、6901234匹配成功,但与7912345、6212534匹配失败

right-ext

扩展型右对齐匹配方式,别名串形如....1234$

如....1234$将与79001234、86901234匹配成功,但与7912345、506212534匹配失败

strict

严格匹配方式,别名串形如$1234$

如$1234$只能与1234匹配成功

whole

全匹配方式,别名串形如........

如........将与所有长度为8的合法的X.121地址匹配成功

whole-ext

扩展型全匹配方式,别名串只能是*

如*将与所有合法的X.121地址匹配成功

 

l              与呼叫分组或呼叫接受分组中地址码组相关的属性

X.25协议规定,在呼叫分组中必须携带主叫DTE地址(源地址)和被叫DTE地址(目的地址)信息的集合,这个地址信息的集合称为地址码组。在呼叫接受分组中情况就有所不同了,有的网络要求二者(指主叫DTE地址和被叫DTE地址)都必须被携带,有的网络要求二者只能有其一被携带,还有的要求二者都不能被携带。为了适应这多种网络之间的差异,用户可以根据实际网络的需求来做出选择。

l              X.25缺省承载的上层协议

X.25的呼叫请求分组中,包括一个CUD字段(Call User Data,呼叫用户数据)。它指明了X.25协议所承载的上层协议的类型。当设备收到X.25呼叫时,它将检查分组中的CUD字段,当设备收到一个携带有无法识别的CUD字段的呼叫时,它会拒绝接收它。但是用户可以为设备的X.25指定一个缺省承载的上层协议,当设备的X.25接收到一个携带未知CUD的呼叫时,可以将其按照用户指定的缺省上层协议来对待。

(3)        添加/移除用户设施功能

添加/移除用户设施功能只能配置在主接口上:

l              添加用户设施功能仅对入报文有效,当从该接口接收到呼叫建立协商报文时,如果报文中已携带“窗口尺寸”和“最大分组长度”两个字段时,不做任何处理,如果报文中没有携带这两个字段,那么将这两个字段添加到报文中。

l              移除用户设施功能仅对出报文有效,当从该接口发送呼叫建立协商报文时,如果报文中没有携带“窗口尺寸”和“最大分组长度”两个字段,不做任何处理,如果报文中携带这两个字段,那么在发送报文之前将移除这两个字段。

2. 配置X.25接口附加参数

表1-6 配置X.25接口附加参数

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置重启定时器时延值

x25 timer tx0 seconds

可选

缺省情况下,DTE侧重启定时器时延为180秒,DCE侧重启定时器时延为60秒

配置呼叫请求(指示)发送定时器的时延值

x25 timer tx1 seconds

可选

缺省情况下,DTE侧呼叫请求发送定时器的时延为200秒,DCE侧呼叫指示发送定时器的时延为180秒

配置复位请求(指示)定时器的时延值

x25 timer tx2 seconds

可选

缺省情况下,DTE侧复位请求定时器的时延为180秒,DCE侧复位指示定时器的时延为60秒

配置清除请求(指示)发送定时器的时延值

x25 timer tx3 seconds

可选

缺省情况下,DTE侧清除请求发送定时器的时延为180秒,DCE侧清除指示发送定时器的时延为60秒

为接口指定一个别名

x25 alias-policy match-type alias-string

可选

缺省情况下,X.25接口没有别名

发起呼叫时,不携带被叫DTE的X.121地址信息

x25 ignore called-address

可选

缺省情况下,X.25在发起呼叫时携带被叫DTE的X.121地址

发起呼叫时,不携带主叫DTE的X.121地址信息

x25 ignore calling-address

可选

缺省情况下,X.25在发起呼叫时携带主叫DTE的X.121地址

发起呼叫接受分组时,携带被叫DTE地址信息

x25 response called-address

可选

缺省情况下,X.25在发送呼叫接受分组时不携带被叫DTE地址信息

发起呼叫接受分组时,携带主叫DTE地址信息

x25 response calling-address

可选

缺省情况下,X.25在发送呼叫接受分组时不携带主叫DTE地址信息

指定缺省承载的上层协议类型

x25 default-protocol protocol-type

可选

缺省情况下,没有指定缺省承载的上层协议

使能添加用户设施功能

x25 add-facility

可选

缺省情况下,添加用户设施功能处于关闭状态

使能移除用户设施功能

x25 remove-facility

可选

缺省情况下,移除用户设施功能处于关闭状态

 

1.3.3  配置X.25子接口

X.25子接口是一个虚拟接口,它有自己的协议地址和虚电路。

在一个物理接口上可以创建多个子接口,这样就可以用一个物理接口实现多个网络的互连。主接口下的所有子接口都和主接口共享一个X.121地址。

X.25的子接口又可以分为两种类型:

l              点到点(point-to-point)子接口:用于连接单个远端;

l              点到多点(point-to-multipoint)子接口:用于连接多个远端,这些远端都必须在同一个网段。

表1-7 配置X.25子接口

操作

命令

说明

进入系统视图

system-view

-

进入主接口的接口视图

interface serial interface-number

-

配置接口的封装协议为X.25协议

link-protocol x25

必选

退回系统视图

quit

-

创建X.25子接口

interface serial interface-number.subnumber [ p2mp | p2p ]

必选

缺省情况下,X.25子接口的类型为p2mp(point-to-multipoint)

 

当接口的链路层协议为LAPB、HDLC或者PPP时不能创建子接口。

 

1.4  配置X.25数据报传输

1.4.1  配置X.25数据报传输基本功能

1. X.25数据报传输基本功能介绍

最常用的X.25服务就是两台主机使用X.25协议,通过X.25分组交换网进行远程的数据传输。如图1-6,LAN 1和LAN 2相隔很远,但彼此之间需要信息交互,此时便可借助分布面积很广的X.25分组交换网达到这一目的。

图1-6 局域网通过X.25互连

 

在LAN 1和LAN 2之间互通信息,数据报使用的地址是彼此都理解的网际协议(IP)地址,可是在X.25内部使用的却是X.121地址,这就需要建立网际协议地址(如IP)与X.121地址之间的映射来解决这个问题;换句话说,正确地建立地址映射是使X.25正确地进行远程数据传送的前提与关键。本节的内容就是介绍如何创建地址映射。

用户既可以直接创建协议地址到X.121地址的映射,也可以通过创建永久虚电路来创建协议地址到X.121地址的映射。

(1)        创建协议地址到X.121地址的映射

对于一个X.25接口,首先它拥有自己的X.121地址,并且拥有自己的网际协议地址(如IP协议)。当X.25通过这个接口发起呼叫时,它在呼叫请求分组中携带的源地址(即主叫DTE地址)就是这个接口的X.121地址。

那么,从这个接口上发起的呼叫是如何决定呼叫目的地呢(也就是说,对于一个有着确定网际协议目的地址的数据报,如何确定其相应的X.121目的地址)?这个X.121目的地址是通过配置的地址映射找到的。对于一次呼叫的目的地来说,与呼叫发起的源一样,也具有自己的协议地址和X.121地址,此时,需要在源处建立关于目的地的协议地址和X.121地址的映射。通过这个映射,X.25便可以根据目的地的协议地址找到目的地的X.121地址,从而成功地发起呼叫。这就是为什么需要为X.25建立地址映射的原因。

对于每一个目的地,都需要创建一条这样的地址映射。

 

(2)        创建永久虚电路

对于数据流量大,数据流量稳定,通过租用专线连接的数据传输要求,可以为其创建永久虚电路。永久虚电路不需要经过呼叫过程,并且始终存在,而且在创建永久虚电路之前,不必先创建地址映射,因为在创建永久虚电路的同时,已经隐含地创建了一条地址映射。

2. 配置X.25数据报传输基本功能

表1-8 配置X.25数据报传输基本功能

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

创建一条到一个目的地的协议地址和X.121地址之间的映射

x25 map protocol-type protocol-address x121-address x.121-address [ option ]

必选

缺省情况下,系统没有任何地址映射

配置X.25虚电路范围

x25 vc-range { bi-channel ltc htc [ out-channel loc hoc ] | in-channel lic hic [ bi-channel ltc htc ] [ out-channel loc hoc ] | out-channel loc hoc }

创建PVC时必选

创建一条永久虚电路

x25 pvc pvc-number protocol-type protocol-address x121-address x.121-address [ option ]

必选

缺省情况下,系统没有创建永久虚电路

 

l          在创建一条PVC之前,需要通过x25 vc-range命令指定虚电路范围,这是因为缺省情况下,双向信道号范围为:LTC=1,HTC=1024,此时无法配置永久虚电路。

l          当创建一条永久虚电路时,如果不为该永久虚电路配置相应的属性,则它的流量控制参数与它所在的X.25接口的流量控制参数相同(一个X.25接口的流量控制参数是通过x25 packet-sizex25 window-size等命令配置的)。

 

1.4.2  配置X.25数据报传输的附加参数

X.25允许指定一些附加的特性,以此来提高性能或拓宽应用,其中包括《ITU-T建议X.25》中规定的一系列的可选的用户设施。

本节的内容就是介绍如何配置这些附加的特征,其中包括x25 mapx25 pvc两条命令中的选项。请用户根据实际需要、X.25网络的结构以及接入服务商可以提供的服务,选择并配置这些附加的特性。

表1-9 配置X.25数据报传输的附加参数

操作

命令

说明

配置SVC的最大空闲时间

请参见1.4.2  1. 配置SVC的最大空闲时间

可选

配置可以与同一条地址映射关联的SVC的最大条数

请参见1.4.2  2. 配置可以与同一条地址映射相关联的SVC数目的最大值

可选

配置分组的提前确认

请参见1.4.2  3. 配置分组的提前确认

可选

配置X.25用户设施

请参见1.4.2  4. 配置X.25用户设施

可选

配置虚电路队列长度

请参见1.4.2  5. 配置虚电路数据队列的长度

可选

配置通过X.25发送广播

请参见1.4.2  6. 配置通过X.25发送广播

可选

配置限制地址映射的使用

请参见1.4.2  7. 配置限制地址映射的使用

可选

 

1. 配置SVC的最大空闲时间

用户可以指定一个时间长度,如果在这段时间内SVC处于空闲状态(即没有数据包的交互),X.25将自动清除该SVC,为用户节省不必要的费用支出。当下一次需要传送数据包时,这条SVC又会被重新建立,所以不必担心这一特征的启用会使数据传输受损。

表1-10 配置SVC的最大空闲时间

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

为接口上所有的SVC指定最大空闲时间

x25 timer idle minutes

可选

缺省情况下,SVC的最大空闲时间为0分钟,表示不会自动清除SVC

为与某地址映射相关联的SVC指定最大空闲时间

x25 map protocol-type protocol-address x121-address x.121-address idle-timer minutes

可选

缺省情况下,系统没有创建任何地址映射;当创建了地址映射时,缺省情况下SVC的最大空闲时间为0分钟,表示不会自动清除SVC

 

2. 配置可以与同一条地址映射相关联的SVC数目的最大值

用户可以指定在同一条地址映射上能建立的虚电路的最大条数。在缺省的情况下,X.25一条地址映射只能与一条虚电路相关联。如果所需要传输的数据量很大,但是线路速率又较慢,这时可适当提高这个参数,减少数据的损失。X.25在一条地址映射上最多可以建立的虚电路的数目为8。

表1-11 指定可以与同一条地址映射相关联的SVC数目的最大值

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置接口上连接同一目的设备的SVC数目的最大值

x25 vc-per-map count

可选

缺省情况下,连接同一目的设备的SVC数目的最大值为1

配置某地址映射可以相关联的SVC数目的最大值

x25 map protocol-type protocol-address x121-address x.121-address  vc-per-map count

 

3. 配置分组的提前确认

按照X.25协议,接收方只有在接收窗口满了之后(即收到的分组个数与接收窗口的尺寸值相等)才向对方发送一次确认。但是,在某些X.25网络内由于延迟较长,将导致发送与接收的效率降低。因此,X.25允许指定一个值,每当收到的分组个数与该值相等时,就会向对端发送确认,从而提高收发的效率。这个值称为“receive-threshold”,它在0到接收窗口的尺寸值之间取值。如果它被设为1,那么将对每一个数据包确认;如果它被设为接收窗口的尺寸值,那么将在接收窗口满了之后才发送确认。在对响应速度要求较高的应用中,该功能尤其重要。

表1-12 配置分组的提前确认

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置X.25发出确认包之前可接收的最大分组个数

x25 receive-threshold count

可选

缺省情况下,X.25发出确认包之前可接收的最大分组个数为0,表示不进行提前确认

 

有关接收窗口的尺寸,请参见“1.3.1  1. (5)流量控制参数(包括配置窗口尺寸及分组长度)”一节的相关内容。

4. 配置X.25用户设施

在X.25协议中规定了各种用户设施(User Facility)的选项,用户可以选择这些用户设施并进行配置。可通过两种途径来修改这些配置:

l              基于X.25接口的配置(使用x25 call-facility命令)

l              基于地址映射的配置(使用x25 map命令)

基于X.25接口的配置会在每一个源于此X.25接口的呼叫中生效,而基于地址映射的配置只在源于此地址映射的呼叫中生效,如果同时配置了两者,后者的优先级比前者的优先级高。

(1)        配置基于X.25接口的X.25用户设施

表1-13 配置基于X.25接口的X.25用户设施

操作

命令

说明

进入系统视图

system-view

-

定义ROA(Recognized operating Agency)列表

x25 roa-list roa-name roa-id&<1-10>

可选

缺省情况下,不定义ROA列表

进入接口视图

interface interface-type interface-number

-

指定封闭用户群号

x25 call-facility closed-user-group number

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时进行最大分组长度协商

x25 call-facility packet-size input-packet output-packet

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时进行窗口尺寸协商

x25 call-facility window-size input-window-size output-window-size

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时请求反向计费

x25 call-facility reverse-charge-request

可选

缺省情况下,没有配置任何X.25用户设施

接受带有反向计费请求的呼叫

x25 reverse-charge-accept

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时请求进行吞吐量级的协商

x25 call-facility threshold in out

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时携带传输延迟请求

x25 call-facility send-delay milliseconds

可选

缺省情况下,没有配置任何X.25用户设施

指定ROA使用

x25 call-facility roa-list name

可选

缺省情况下,没有配置任何X.25用户设施

 

(2)        配置基于地址映射的X.25用户设施

表1-14 配置基于地址映射的X.25用户设施

操作

命令

说明

进入系统视图

system-view

-

定义ROA列表

x25 roa-list roa-name roa-id&<1-10>

可选

缺省情况下,不定义ROA列表

进入接口视图

interface interface-type interface-number

-

指定封闭用户群号

x25 map protocol-type protocol-address x121-address x.121-address closed-user-group number

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时进行最大分组长度协商

x25 map protocol-type protocol-address x121-address x.121-address packet-size input-packet output-packet

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时进行窗口尺寸协商

x25 map protocol-type protocol-address x121-address x.121-address window-size input-window-size output-window-size

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时请求反向计费

x25 map protocol-type  protocol-address x121-address x.121-address reverse-charge-request

可选

缺省情况下,没有配置任何X.25用户设施

接受带有反向计费请求的呼叫

x25 map protocol-type protocol-address x121-address x.121-address reverse-charge-accept

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时请求进行吞吐量级的协商

x25 map protocol-type protocol-address x121-address x.121-address threshold in out

可选

缺省情况下,没有配置任何X.25用户设施

发起呼叫时携带传输延迟请求

x25 map protocol-type protocol-address x121-address x.121-address send-delay milliseconds

可选

缺省情况下,没有配置任何X.25用户设施

指定ROA使用

x25 map protocol-type protocol-address x121-address x.121-address roa-list name

可选

缺省情况下,没有配置任何X.25用户设施

 

关于封闭用户群的配置,请参见“1.7  配置X.25封闭用户群”。

5. 配置虚电路数据队列的长度

可以为X.25指定虚电路的发送和接收队列的长度以适应不同的网络环境。队列的长度缺省为可以容纳200个分组,但是如果数据流量很大,或者X.25网络的传输速率较低,可以加大队列的长度,防止数据包的意外丢失。

表1-15 配置虚电路发送队列的长度

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

配置X.25虚电路队列长度

x25 queue-length queue-size

可选

缺省情况下,X.25虚电路的数据队列的长度为200

 

6. 配置通过X.25发送广播

一般来说,网际协议会在某些时刻发送一些广播型的数据报来达到一定的目的。在本身就是广播型的物理网络上(如Ethernet),很自然地需要支持这样的需求。但是对于X.25这种非广播型的网络,怎样才能达到广播的目的呢?

X.25可以让用户决定是否向一个目的地复制并发送一个广播数据报。这一点是很有用的,例如对基于广播的应用层路由协议,如果要在X.25网络上交互路由信息,则必须使X.25能发送广播数据报。

对于SVC和PVC,均可以指定是否在与其相关联的虚电路上发送广播数据报。

表1-16 配置通过X.25发送广播

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

允许向与该地址映射相关联的SVC的对端发送广播数据报

x25 map protocol-type protocol-address x121-address x.121-address broadcast

必选

允许向该PVC的对端发送广播数据报

x25 pvc pvc-number protocol-type protocol-address x121-address x.121-address broadcast

 

7. 配置限制地址映射的使用

X.25的呼叫与地址映射密切相关:在呼叫一个目的地之前,必须先在地址映射表中找到这个目的地;在接受一个呼叫之前,也需要在地址映射表中找到该呼叫的源。但是,在有些情况下,希望对于一部分地址映射,只能利用其呼出;而对另一部分地址映射,只能利用其接受呼入。

表1-17 限制地址映射的使用

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

禁止通过该条地址映射发起呼叫

x25 map protocol-type protocol-address x121-address x.121-address no-callout

必选

禁止通过该条地址映射接受呼叫

x25 map protocol-type protocol-address x121-address x.121-address no-callin

必选

 

1.5  配置X.25交换

1.5.1  配置X.25交换基本功能

一个分组网络是由许多节点按照一定的拓扑结构互相连接而成,分组从源到达目的之间要经过很多节点,其中每一个节点都需要有分组交换能力。

简单地说,X.25分组交换就是从一个X.25端口或Annex G DLCI接收分组,并根据分组中包含的有关目的地址的信息选择某一X.25端口或Annex G DLCI发送出去。在系统中引入X.25交换,就是为了使系统可以在分组层实现分组交换功能,设备可以当作一个小型的分组交换机来使用,如图1-7所示。

图1-7 X.25交换组网图

 

表1-18 配置X.25交换基本功能

操作

命令

说明

进入系统视图

system-view

-

使能X.25交换功能

x25 switching

必选

缺省情况下,禁止X.25交换功能

增加X.25交换路由

增加一条PVC路由

interface interface-type interface-number

两者必选其一

x25 vc-range { bi-channel ltc htc [ out-channel loc hoc ] | in-channel lic hic [ bi-channel ltc htc ] [ out-channel loc hoc ] | out-channel loc hoc }

x25 switch pvc pvc-number1 interface interface-type interface-number [ dlci dlci-number ] pvc pvc-number2 [ option ]

增加一条SVC路由

x25 switch svc [ -number ] x.121-address [ sub-dest destination-address | sub-source source-address ] * interface interface-type interface-number [ dlci dlci-number ]

 

允许/禁止X.25交换只影响呼叫的建立,并不影响已经建立的链路。

使能X.25交换后才可以进行交换路由的配置,如果已经配置了一些交换路由后再禁止交换(执行undo x25 switching),则:

l              对于SVC交换路由,执行display命令时不可见,对于PVC交换路由,执行display命令时可见;

l              在不重启的情况下,如果再执行x25 switching命令,则SVC路由会恢复,执行display命令时成为可见;

l              如果执行save命令并重启,则所有SVC路由、PVC路由都会丢失。

在创建一条PVC之前,需要通过x25 vc-range命令指定虚电路范围,这是因为缺省情况下,双向信道号范围为:LTC=1,HTC=1024,此时无法配置永久虚电路。

 

1.5.2  配置X.25交换流量控制参数协商功能

图1-8 X.25交换组网图

 

如图,Router A和Router C通过Router B进行通信,用户可以在Router B上配置Router A和Router C是否需要进行流量控制参数的协商。

l              如果配置通信双方需要进行流量控制参数的协商,那么,当Router B两端链路上的流量控制参数不一致时,通信的双方通过参数协商之后,将使用较小的参数。此后,当Router B收到M比特为1(表示后续还有分片报文)的报文时,将不做任何处理直接转发。

l              如果配置通信双方不需要进行流量控制参数的协商,那么,Router B两端的链路上的流控参数可以不一致。当Router B收到M比特为1的报文时,不会直接转发,而是将这些分片重新组合以后,再进行转发。需要注意的是,Router B向Router C转发报文时,可能需要对报文进行重新分片,是否需要分片取决于该链路的流量控制参数。

缺省情况下,通信双方需要进行流量控制参数的协商。

表1-19 配置X.25交换流量控制参数协商功能

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

使能X.25交换流量控制参数协商功能

x25 flowcontrol

必选

缺省情况下,X.25交换流量控制参数协商功能处于使能状态

 

1.6  配置X.25负载分担

1. X.25负载分担介绍

利用X.25协议中的搜索群(hunt group)特性,网络供应商可以在X.25分组交换网络上提供负载分担功能。X.25负载分担可以实现不同DTE之间或同一DTE不同链路之间的负载分担,从而可以保证大量用户访问同一地址时不会发生链路超载的情况。

X.25负载分担是由DCE提供的。为了在X.25网络上实现负载分担,需要经过以下过程:

l              在网络的远端DCE上,把一组DTE/DCE接口(同步串口或XOT通道)配置为一个搜索群,并为此搜索群分配一个X.121地址。

l              网络中其它设备要访问搜索群内的DTE时,需要呼叫这个搜索群地址。

l              远端DCE收到呼叫请求(Call Request)分组后,会根据不同的通道选择策略(round-robin或vc-number),从搜索群内选择一条线路并发送入呼叫(Incoming Call)分组。

l              不同的呼叫将会被分配到搜索群内的各个线路之上,从而实现了负载分担。

需要注意以下两点:

l              X.25搜索群只在虚电路的呼叫建立过程中动态地选择不同传输线路,一旦整条虚电路建立完毕,并进入数据传输阶段,它就不再起作用,数据将在已建立的虚电路上进行传输。

l              由于PVC在建立后就处于数据传输阶段,并没有呼叫建立和呼叫清除的过程,因此X.25负载分担对PVC不起作用,它只能够对SVC起作用。

在一个X.25搜索群内,所有DTE的地位是相同的,它们拥有相同的X.121地址。搜索群内的DTE可以按正常方式呼叫搜索群外其它的DTE。搜索群外的设备访问搜索群时,无法知道自己访问的是哪台机器,线路的选择是由配置了搜索群的DCE控制的。

搜索群内DTE的地址可以与搜索群地址相同,也可以与之不同。X.25搜索群支持源地址和目的地址的替换。利用目的地址替换功能,可以将搜索群内部DTE的地址隐藏起来,外部DTE知道的只是搜索群的地址,从而加强了搜索群内部网络的安全。利用源地址替换功能,可以将搜索群外部DTE的地址隐藏起来,内部DTE无法知道呼叫连接的源地址,只能知道替换后的源地址,从而保护了用户的隐私。

图1-9 X.25网络负载分担示意图

 

图1-9所示,Server A和Server B同时为用户提供相同的业务,它们被配置为一个名为HG 1的搜索群,其中Server A和Server B的地址均为9999,搜索群地址为8888。在设备Router A上启用目的地址替换功能,把对地址8888的呼叫转化为对地址9999的呼叫。当用户办理业务时,用户终端将向目的地址8888发出呼叫。各个终端的呼叫在设备Router A上被替换为对9999的呼叫,分别传输到Server A或Server B上。这样就在Server A、B之间实现了负载分担,减轻了单个服务器的压力。

X.25搜索群支持两种呼叫通道选择策略:round-robin方式和vc-number方式,但是一个搜索群只能使用一种通道选择策略。

l              round-robin方式对每一个呼叫请求采用循环选择的方法选择搜索群内的下一个接口或XOT通道。例如,在上图中,如果搜索群HG 1采用round-robin方式,则呼叫将会被轮流发送至Server A和Server B。

l              vc-number方式对每一个呼叫请求选择搜索群内拥有空闲逻辑通道最多的接口。例如,在上图中,如果搜索群HG 1采用vc-number方式,Server A和DCE之间线路的剩余逻辑通道为500条,Server B和DCE之间线路的剩余逻辑通道为300条。则前200个呼叫都将被发送至Server A,而在此之后的呼叫会被轮流发送至Server A和Server B。

X.25搜索群支持同步串口和XOT通道,它可以无区别地在同步串口和XOT通道之间选择可用的线路。但是,由于XOT通道无法计算逻辑通道数量,因此它不能被添加至采用vc-number选择策略的搜索群之内。

2. 配置X.25负载分担

X.25网络的负载分担是在DCE设备上配置的。

通常情况下,设备在X.25网络中被作为DTE设备使用,负载分担功能由网络供应商在分组交换机上提供,设备上不需要进行特殊的配置。

当设备被作为X.25交换机使用时,它作为X.25网络中的DCE设备为DTE设备提供负载分担功能,此时需要在设备上进行X.25负载分担的配置。

搜索群地址不需要单独配置,只需在源DTE上把目的地址设为搜索群地址即可。

 

表1-20 配置X.25负载分担

操作

命令

说明

进入系统视图

system-view

-

使能X.25交换功能

x25 switching

必选

缺省情况下,禁止X.25交换功能

创建X.25搜索群,进入搜索群视图

x25 hunt-group hunt-group-name { round-robin | vc-number }

必选

将接口或Annex G DLCI添加至搜索群

channel interface interface-type interface-number [ dlci dlci-number ]

必选

将XOT通道添加至搜索群

channel xot ip-address

退回系统视图

quit

-

增加一条转发地址为搜索群的X.25交换路由

x25 switch svc x.121-address [ sub-dest destination-address | sub-source source-address ] * hunt-group hunt-group-name [ xot-source interface-type interface-number ]

必选

缺省情况下,没有创建任何X.25交换路由

 

l          一个搜索群最多可以拥有10个同步串口或Annex G DLCI或XOT通道。

l          XOT通道不能被加入到采用vc-number通道选择策略的搜索群之中。

 

1.7  配置X.25封闭用户群

1. 封闭用户群功能介绍

封闭用户群(Closed User Group,CUG)是X.25提供的可选业务类型中的一个呼叫限制的业务,其主要作用是限制用户(DTE)发起呼叫和接收呼叫的能力。在同一个封闭用户群内的用户可以互相呼叫,而不在同一个封闭用户群内的用户之间的呼叫就会受到限制。这个功能使得一个集团能够在X.25公用数据通信网中形成一个专用的数据通信子网。

一个用户可以属于多个封闭用户群,当此用户呼叫某个封闭用户群的用户时,其能力协商报文中就携带此封闭用户群号码。用户也可以配置为不属于任何封闭用户群,此时其呼叫任何用户的能力协商报文中就不携带CUG信息。

当设备作为DCE设备时,实现了封闭用户群业务功能,如图1-10所示。

图1-10 设备实现CUG功能示意图

 

l          Call 1:从DTE发起呼叫,DCE收到呼叫请求,但在DCE上配置了CUG功能,禁止该呼出,所以呼叫被DCE拆除;

l          Call 2:DCE从网络收到一个呼叫请求,想和DTE建立连接,但在DCE上配置了CUG功能,禁止该呼入,所以呼叫被DCE拆除。

 

(1)        封闭用户群功能

配置封闭用户群功能首先必须使能封闭用户群功能。缺省情况下,封闭用户群功能是关闭的。

对封闭用户群可以配置一些抑制策略。使能封闭用户群功能后,对于所有呼叫(包括携带CUG设施的和不携带CUG设施的)都将被限制。但可以使用抑制策略对呼叫进行不同的处理。

抑制策略(suppress参数)有两类:一是抑制所有的呼入报文,即对呼入报文中所有携带CUG设施的呼叫都将删除CUG设施;二是只抑制优先映射规则的呼入报文,即只对匹配了优先映射的呼叫才删除其CUG配置,其它的呼叫携带的CUG则不被删除并且允许呼入。具体描述如下:

l              呼入接入策略,即当呼入报文中未携带有CUG设施时,允许其呼入;如果呼入报文中携带CUG设施,并且没有配置该CUG映射规则来允许其呼入,则该呼叫将被禁止。

l              呼出接入策略,即当呼出报文中未携带有CUG设施时,允许其呼出;如果呼出报文中携带CUG设施,并且没有配置该CUG映射规则来允许其呼出,则该呼叫将被禁止。

l              抑制所有呼叫中的CUG策略,即如果呼入报文中携带有CUG设施,则删除其中的CUG设施并进行呼叫处理。对呼出则不起作用。

l              只抑制优先映射的呼叫中的CUG策略,即如果呼入报文中携带有CUG设施并且该呼叫的映射限制规则是preferential,则删除其中的CUG设施并进行呼叫处理;当该呼叫的抑制规则不是preferential时,不删除其中的CUG设施但允许其呼叫。本参数对呼出不起作用。

该功能必须在工作在DCE端的X.25接口上配置。就是说在该串口封装X.25协议时必须指定其为DCE端。

 

(2)        封闭用户群映射及其抑制规则

封闭用户群映射是指设备在处理封闭用户群的呼叫时,从本地侧(DTE设备)到网络侧(X.25网络)CUG号的转换关系。例如,CUG号为10的DTE要呼叫网络中CUG号为20的DTE,设备处理此呼叫时,首先要查找映射表中是否存在此映射关系,如果有,则需要将呼叫报文中的CUG号改为20,并转发此呼叫报文;如果没有,则拒绝转发此呼叫报文。

配置封闭用户群映射时可以指定其限制规则。限制规则包括以下三种:

l              限制呼出

l              限制呼入

l              指定为优先规则

其中,指定为优先规则与抑制CUG策略相关。也就是,如果抑制策略配置为只抑制优先映射的呼叫中的CUG(参数suppress preferential,那么删除该映射的入呼叫报文中的CUG设施并进行呼叫处理。

该功能必须在工作在DCE端的X.25接口上配置。就是说在该串口封装X.25协议时必须指定其为DCE端。

 

2. 配置封闭用户群功能

表1-21 配置封闭用户群功能

操作

命令

说明

进入系统视图

system-view

-

进入接口视图

interface interface-type interface-number

-

启动CUG服务及其限制策略

x25 cug-service [ incoming-access  | outgoing-access | suppress { all | preferential } ] *

必选

缺省情况下,未启动CUG服务

配置本地侧CUG号与网络侧CUG号的映射,并定义其限制规则射

x25 local-cug local-cug-number network-cug network-cug-number [ no-incoming | no-outgoing | preferential ]*

必选

缺省情况下,不定义任何CUG映射

 

命令x25 cug-servicex25 local-cug只有工作在DCE端的X.25接口支持。也就是说,在该串口封装X.25协议时必须指定其为DCE端。

 

1.8  配置X.25 PAD远程登录服务

1.8.1  X.25 PAD简介

PAD(Packet Assembly/Disassembly Facility,分组汇集/拆卸设备)是X.25协议中特有的概念。

传统的X.25网络要求接入其中的终端都是X.25类型的,必须有相应的硬件和软件支持X.25规程,即所谓的分组终端。分组终端一定是有智能的终端,可是我们实际使用的许多终端为非X.25终端,并不具有智能(键盘、显示器、打印机等),或有智能但不支持X.25规程。这样,非X.25类型的终端无法通过X.25网络互相通信,甚至无法接入X.25网络。我们怎样使这些设备也能通过X.25网络进行通信呢?这正是X.25 PAD技术产生的背景。

X.25 PAD是连接X.25网络与非X.25终端的桥梁——它提供了这样一种机制,使得非X.25类型的终端可以通过其接入X.25网络。如图1-11所示,我们在不支持X.25规程的终端和X.25网络之间加入一种称为PAD的设备,使前者可以通过X.25网络与其它终端进行通信。

图1-11 PAD的接口功能

 

X.25 PAD的主要功能有:

l              提供X.25规程支持,用于与X.25网络的连接和通信。

l              提供非X.25规程支持,用于与非X.25终端的连接。

l              向非X.25终端提供通过X.25网络建立呼叫、进行数据传输和清除呼叫的能力。

l              向非X.25终端提供观察和修改接口参数的能力,以适应不同终端的要求。

因此,X.25 PAD设备实际上是一个规程转换器或者说是网络服务器。它向各种不同的终端提供服务,帮助它们进入X.25网络。

系统实现了X.25 PAD协议族中的X.29、X.3协议,并实现了基于X.29协议的Telnet应用,为用户提供异地配置设备的功能——如图1-12所示,当用户为了安全起见不能用基于IP协议的Telnet配置设备时,在Router A上可以通过X.25 PAD登录到远端Router B上进行配置。

图1-12 通过X.25 PAD登录远端设备

 

1.8.2  配置X.25 PAD

1. 发起X.25 PAD呼叫并登录远端

在通过X.25网络互连的设备上,可以使用pad命令向远端发起X.25 PAD呼叫,如果两端都支持X.25 PAD功能,则Server端将对呼叫进行验证(如果没有配置用户验证,则跳过验证这一步),验证成功后Client端就可以登录并配置Server端;在成功登录远端后,可退出登录并断开X.25 PAD连接。

若呼叫登录成功,则用户将在Client端进入Server端的配置界面。

pad命令本身以及与telnet命令可以嵌套使用,即:用户可以从一台设备发起X.25 PAD呼叫登录到另一台设备上,然后再从该设备发起X.25 PAD呼叫登录到第三台设备上;或者先Telnet到一台设备上,再从该设备发起X.25 PAD呼叫并登录到另一台设备上;或者先发起X.25 PAD呼叫登录到一台设备上,再Telnet到另一台设备上等等。建议嵌套使用的次数限制在3次以内,以保证正常传输。

quit命令也可与pad命令配合嵌套使用,即:用户通过多次使用telnet/pad命令从一台设备辗转登录到第三台乃至更多的设备上以后,可以通过多次使用quit命令依次退出被登录的设备直至退回到初始发起呼叫的那台设备上。

2. Invite Clear消息的响应时间

当X.25 PAD的Server端由于某种原因(如Client端发出退出请求或需要释放链路资源等)向Client端发清除链路消息Invite Clear后,Server端将等待Client端的回应;如果Client端没有在规定的时间里回应该消息,那么Server端将主动清除链路。

3. 配置X.25 PAD

表1-22 配置X.25 PAD

操作

命令

说明

进入系统视图

system-view

-

配置对Invite Clear消息的响应时间

x29 timer inviteclear-time seconds

可选

缺省情况下,响应时间为5秒

退回用户视图

quit

-

发起X.25 PAD呼叫并登录远端

pad x.121-address

必选

 

1.9  配置XOT

1.9.1  XOT协议简介

XOT(X.25 Over TCP)是一种把X.25报文承载在TCP上,实现两个X.25网通过IP网来互联的协议。实际应用环境如图1-13所示。

图1-13 XOT典型应用示意图

 

由于目前IP网络的应用越来越广泛,实际使用时需要通过IP网来承载X.25数据、实现X.25网络互联的情况也越来越多。传统的X.25通过LAPB协议为其提供可靠的数据传输链路。由于TCP具有差错重传、窗口流控等机制保证链路的可靠性,所以可被X.25协议所应用:XOT在两端的X.25网之间建立一个TCP隧道连接,X.25报文作为应用层的数据承载在TCP上,即TCP此时充当了X.25的“链路层”。可以把中间的Router B、Router C和IP网理解为一个大的“X.25交换机”,Router A发送的数据通过此“交换机”直接交换到了Router D。

结合图1-13,XOT的工作过程描述如下(以SVC为例):

l              Router A有数据传输时,首先发送一个呼叫请求分组,要求建立虚电路;

l              Router B收到此呼叫分组后,经判断是XOT应用,于是首先与Router C建立一条TCP连接,然后把X.25呼叫分组报文加上XOT报文头,封装在TCP报文里传输到Router C;

l              Router C去掉TCP和XOT报文头后,通过X.25本地交换,把呼叫请求分组传递给Router D;

l              Router D收到呼叫请求分组后,发出呼叫应答确认,并经Router C和Router B,最后发送到Router A;

l              Router A和Router D之间建立链路,进入数据传输状态。

建立并应用TCP连接的整个过程对Router A和Router D来说是透明的,它们并不知道是通过IP网还是X.25网来转发数据的。

系统中实现的XOT特性符合RFC1613标准,它有以下特性:

l              支持SVC应用。两端设备可以通过发送呼叫分组动态建立一条SVC,在没有数据传输时此虚电路会被自动清除。

l              支持PVC应用。两端设备配置了一条PVC后,直接进入数据传输状态,不用经过呼叫建立的过程,且如果没有数据传输此虚电路也不会动态删除。

l              支持TCP的Keepalive属性。如果没有配置Keepalive,即使线路中断,TCP连接仍然不会清除或者要经过长时间才会清除;而配置了Keepalive后,TCP定时检测链路的可用性,如果多次没有收到对端的应答则会主动清除TCP连接。

1.9.2  配置XOT

1. 配置XOT

表1-23 配置XOT

操作

命令

说明

进入系统视图

system-view

-

启动X.25交换

x25 switching

必选

缺省情况下,不启动X.25交换

由于XOT应用是X.25交换的扩展,所以必须先启动X.25交换

进入接口视图

interface interface-type interface-number

-

配置IP侧接口

ip address ip-address { mask | mask-length }

ip address unnumbered interface interface-type interface-number

必选

由于XOT应用是通过IP网来实现两端X.25网的互联,所以首先得保证IP网是畅通的

退回系统视图

quit

-

配置XOT路由,决定收到的X.25报文如何通过IP网转发

配置SVC XOT路由

x25 switch svc [ -numberx.121-address [ sub-dest destination-address | sub-source source-address ] * xot ip-address&<1-6> [ xot-option ]

两者必选其一

x25 switch svc [ -number ] x.121-address [ sub-dest destination-address | sub-source source-address ] * interface interface-type interface-number

配置PVC XOT路由

interface interface-type interface-number

x25 vc-range { bi-channel ltc htc [ out-channel loc hoc ] | in-channel lic hic [ bi-channel ltc htc ] [ out-channel loc hoc ] | out-channel loc hoc }

x25 xot pvc pvc-number1 ip-address interface interface-type interface-number pvc pvc-number2 [ xot-option | packet-size input-packet output-packet | window-size input-window-size output-window-size ] *

配置XOT的可选属性

请参见2. 配置XOT的可选属性

可选

 

l          在SVC方式下一定要配置X.25路由。

l          在创建一条PVC之前,需要通过x25 vc-range命令指定虚电路范围,这是因为缺省情况下,双向信道号范围为:LTC=1,HTC=1024,此时无法配置永久虚电路。

l          有关IP地址的配置请参见“三层技术-IP业务配置指导”中的“IP地址”。

 

2. 配置XOT的可选属性

TCP链路在建立后,即使链路中断,TCP也不会轻易清除。但是在配置了Keepalive属性后,设备会定期发送检测报文,检查链路的可用性;如果多次发送报文未得到确认后即认为链路故障,会主动清除TCP连接。

表1-24 配置XOT的可选属性

操作

命令

说明

进入系统视图

system-view

-

配置SVC Keepalive和source属性

x25 switch svc [ -number ] x.121-address [ sub-dest destination-address | sub-source source-address ] * xot ip-address&<1-6> [ xot-option ]

可选

配置PVC Keepalive和source属性

interface interface-type interface-number

-

x25 xot pvc pvc-number1 ip-address interface interface-type interface-number pvc pvc-number2 [ xot-option | packet-size input-packet output-packet | window-size input-window-size output-window-size ] *

可选

 

表1-25 xot-option选项说明

选项

意义

timer seconds

XOT连接的keepalive定时器的延时,定时器超时发送keepalive报文,以探测连接的可用性,取值范围为1秒~3600秒

retry times

发送keepalive的最大失败次数,失败次数超过times时,断开XOT连接,取值范围为3次~3600次

source interface-type interface-number

发起XOT连接的接口类型及接口号

 

1.10  配置X.25 Over FR

1.10.1  X.25 Over FR协议简介

X.25 Over FR是一种把X.25报文承载在FR上,实现两个X.25网络通过帧中继网络来互联的协议。实际应用环境如图1-14所示。

图1-14 X.25 Over FR典型应用示意图

 

1.10.2  配置X.25 Over FR的SVC应用

X.25 Over FR应用是X.25交换的扩展,所以必须先启动X.25交换。

表1-26 配置X.25 Over FR的SVC应用

操作

命令

说明

进入系统视图

system-view

-

启动X.25交换

x25 switching

必选

缺省情况下,不启动X.25交换

进入接口视图

interface interface-type interface-number

-

配置接口封装的链路层协议为帧中继

link-protocol fr [ ietf | nonstandard ]

必选

缺省情况下,接口的链路层协议为PPP

配置帧中继接口类型

fr interface-type { dce | dte | nni }

必选

缺省情况下,帧中继接口的类型为DTE

配置一条帧中继DLCI,并进入接口DLCI视图

fr dlci dlci-number

必选

把帧中继DLCI配置为Annex G DLCI

annexg { dce | dte }

必选

配置SVC路由

x25 switch svc [ -number ] x.121-address [ sub-dest destination-address | sub-source source-address ] * interface interface-type interface-number

必选

对于SVC来说,在收到对方报文后,必须通过本地的交换接口把报文发送出去,所以必须配置本地交换。通过该命令配置在SVC应用下到达本地设备的报文从哪个接口发送

配置SVC X.25 Over FR路由

x25 switch svc [ -number ] x.121-address [ sub-dest destination-address | sub-source source-address ] * interface interface-type interface-number dlci dlci-number

必选

 

1.10.3  配置X.25 Over FR的PVC应用

X.25 Over FR应用是X.25交换的扩展,所以必须先启动X.25交换。

表1-27 配置X.25 Over FR的PVC应用

操作

命令

说明

进入系统视图

system-view

-

启动X.25交换

x25 switching

必选

缺省情况下,不启动X.25交换

创建X.25 Template

x25 template { name }

必选

配置虚电路的范围

x25 vc-range { bi-channel ltc htc [ out-channel loc hoc ] | in-channel lic hic [ bi-channel ltc htc ] [ out-channel loc hoc ] | out-channel loc hoc }

必选

配置X.25 Template下的PVC交换路由

x25 switch pvc pvc-number1 interface interface-type interface-number [ dlci dlci-number ] pvc pvc-number2 [ option ]

必选

退回系统视图

quit

-

进入接口视图

interface interface-type interface-number

-

配置接口封装的链路层协议为帧中继

link-protocol fr [ ietf | nonstandard ]

必选

缺省情况下,接口的链路层协议为PPP

配置帧中继接口类型

fr interface-type { dce | dte | nni }

必选

缺省情况下,帧中继接口的类型为DTE

配置一条帧中继DLCI,并进入接口DLCI视图

fr dlci dlci-number

必选

把帧中继DLCI配置为Annex G DLCI

annexg { dce | dte }

必选

在帧中继Annex G DLCI上应用X.25 Template

x25-template name

必选

退回系统视图

quit

-

进入接口视图

interface interface-type interface-number

-

配置接口封装的链路层协议为X.25

link-protocol x25 [ dce |dte ] [ ietf | nonstandard ]

必选

缺省情况下,接口封装的链路层协议为PPP

配置一条PVC交换路由

x25 switch pvc pvc-number1 interface interface-type interface-number [ dlci dlci-number ] pvc pvc-number2 [ option ]

必选

 

1.11  配置X2T

1.11.1  X2T简介

X2T(X.25 to TCP switch)技术能够将X.25网络和TCP/IP网络连接起来,从而使X.25主机和IP主机可以互相访问。X2T的典型应用如图1-15所示。

图1-15 X2T典型组网图

 

对于X.25主机来说,IP主机有一个X.121地址相对应。当设备收到X.25呼叫请求分组时,它会检查分组中的目的X.121地址。根据此地址,设备在配置的X2T路由表中进行查找。如果发现了匹配的路由,设备会与X2T路由中相应的目的IP地址的主机建立一条TCP连接。TCP连接建立后,设备从X.25报文里提取纯数据通过TCP连接发送到IP主机侧。

对于IP主机来说,要访问X.25主机,只需通过设备IP网络侧接口的IP地址即可。当设备收到TCP连接建立请求时,它会检查TCP连接的目的IP地址和TCP端口号。根据此地址,设备在配置的X2T路由表中进行查找。发现了匹配的路由后,如果X.25主机和设备之间通过SVC连接,设备会与X2T路由中相应的目的X.121地址的主机建立一条X.25虚电路,虚电路建立后,设备从TCP报文里提取纯数据通过X.25虚电路发送到X.25主机侧;如果X.25主机和设备之间通过PVC连接,则设备直接将数据通过配置的X.25 PVC发送到X.25主机侧。

1.11.2  配置X2T

表1-28 配置X2T

操作

命令

说明

进入系统视图

system-view

-

启用X.25交换

x25 switching

必选

配置X.25网络侧接口

请参见1.3.1  配置X.25接口基本参数

必选

在配置X.25网络侧接口时,不必为其配置X.121地址

配置IP网络侧接口

关于IP侧网络接口的配置,请参见“三层技术-IP业务配置指导”的“IP地址”的相关章节

必选

配置X.25网络至IP网络的X2T转发路由

translate x25 x.121-address ip ip-address port port-number

必选

配置IP网络至X.25网络的X2T转发路由

当X.25主机和设备之间通过PVC连接时配置转发路由

translate ip ip-address port port-number pvc interface-type interface-number  pvc-number

两者必选其一

当X.25主机和设备之间通过SVC连接时,除了配置转发路由外,还需要配置X.25 SVC路由

translate ip ip-address port port-number x25 x.121-address

x25 switch svc [ -number ] x.121-address [ sub-dest destination-address ] [ sub-source source-address ] * interface interface-type interface-number [ dlci dlci-number ]

 

l          X2T配置映射表项时有规格限制,各个产品对其规格的限制可能不一样,缺省情况下,X2T配置映射表项数的最大值为100条,即可配置的translate iptranslate x25的命令总条数最大值为100条。

l          在配置translate ip命令时,对port端口号port-number的配置要注意,当配置一个IP地址使用一个端口号时,尽量使用102端口号;当配置一个IP地址使用多个端口号时,尽量不要使用知名的端口号(如:21、23等),建议使用1024~5000之间的端口号,以免造成网络故障。

 

1.12  LAPB和X.25显示和维护

在完成上述配置后,在任意视图下执行display命令可以显示LAPB和X.25配置后的运行情况,通过查看显示信息验证配置的效果。

在用户视图下执行reset命令可以清除LAPB和X.25的相关信息(除reset lapb statistics外,该命令需要在接口视图下执行)。

表1-29 LAPB和X.25显示和维护

操作

命令

显示X.25别名表

display x25 alias-policy [ interface interface-type interface-number ] [ | { begin | exclude | include } regular-expression ]

显示X.25地址映射表

display x25 map [ | { begin | exclude | include } regular-expression ]

显示CUG的配置

display x25 cug { local-cug [ local-cug-number ] | network-cug [ network-cug-number ] } [ | { begin | exclude | include } regular-expression ]

显示 X.25 PAD连接信息

display x25 pad [ pad-id ] [ | { begin | exclude | include } regular-expression ]

显示X.25交换路由表

display x25 switch-table svc { dynamic | static } [ | { begin | exclude | include } regular-expression ]

显示X.25交换永久虚电路路由表

display x25 switch-table pvc [ | { begin | exclude | include } regular-expression ]

显示X.25虚电路

display x25 vc [ lci-number ] [ | { begin | exclude | include } regular-expression ]

显示X.25 XOT连接信息

display x25 xot [ | { begin | exclude | include } regular-expression ]

显示X2T的动态交换路由表

display x25 x2t switch-table [ | { begin | exclude | include } regular-expression ]

显示X.25搜索群的状态信息

display x25 hunt-group-info [ hunt-group-name ] [ | { begin | exclude | include } regular-expression ]

清除接口上X.25协议的统计信息或X.25虚电路

reset x25 { counters interface interface-type interface-number | vc interface interface-type interface-number [ vc-number ] }

清除(复位)一条XOT连接

reset xot local local-ip-address local-port remote remote-ip-address remote-port

清除接口上的LAPB协议的统计信息

reset lapb statistics

 

1.13  LAPB典型配置举例

1. 组网需求

两台设备简单地背靠背串口直连,串口之间使用LAPB链路层协议并直接承载IP数据报进行传输。

2. 组网图

图1-16 LAPB典型配置组网图

 

3. 配置步骤

(1)        配置Router A

# 进入接口视图,并为该接口指定IP地址。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 10.1.1.2 255.0.0.0

# 配置接口的链路层协议为LAPB,并指定其工作在DTE方式。

[RouterA-Serial2/0] link-protocol lapb dte

# 配置LAPB的流量控制参数。

[RouterA-Serial2/0] lapb modulo 128

[RouterA-Serial2/0] lapb window-size 127

[RouterA-Serial2/0] shutdown

[RouterA-Serial2/0] undo shutdown

(2)        配置Router B

# 进入接口视图,并为该接口指定IP地址。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 10.1.1.1 255.0.0.0

# 配置接口的链路层协议为LAPB,并指定其工作在DCE方式。

[RouterB-Serial2/0] link-protocol lapb dce

# 配置LAPB的流量控制参数。

[RouterB-Serial2/0] lapb modulo 128

[RouterB-Serial2/0] lapb window-size 127

[RouterB-Serial2/0] shutdown

[RouterB-Serial2/0] undo shutdown

请注意,两台设备简单地背靠背连接,封装为LAPB协议,需要将两端的IP地址设为同一网段才可以实现互通;如果不是同一网段,还需要配置静态路由才可以实现互通;并且还要求两端的流量控制参数保持一致。

4. 验证配置结果

查看Router A的接口配置信息。

[RouterA-Serial2/0] display interface serial 2/0

Serial2/0 current state: UP

Line protocol current state: UP

Description: Serial2/0 Interface

The Maximum Transmit Unit is 1500, Hold timer is 10(sec)

Internet Address is 10.1.1.2/8 Primary

Link-protocol is LAPB

  LAPB DTE, module 128, window-size 127, max-frame 12032, retry 10

  Timer:  T1 3000, T2 1500, T3 0 , T4 0 (milliseconds),  IP-protocol

  state CONNECT, VS 6, VR 0, Remote VR 6

  IFRAME 0/6, RR 6/0, RNR 0/0, REJ 0/0

  FRMR 0/1, SABM 3/19, DM 0/1, UA 0/1

  DISC 0/0, invalid ns 0, invalid nr 0, link resets 0

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Physical layer is synchronous, Virtual baudrate is 64000 bps

Interface is DTE, Cable type is V24, Clock mode is DTECLK1

Last clearing of counters: Never

    Last 300 seconds input rate 2.26 bytes/sec, 18 bits/sec, 0.19 packets/sec

    Last 300 seconds output rate 2.54 bytes/sec, 20 bits/sec, 0.22 packets/sec

    Input: 627 packets, 7462 bytes

           0 broadcasts, 0 multicasts

           0 errors, 0 runts, 0 giants

           0 CRC, 0 align errors, 0 overruns

           0 dribbles, 0 aborts, 0 no buffers

           0 frame errors

    Output:633 packets, 7737 bytes

           0 errors, 0 underruns, 0 collisions

           0 deferred

    DCD=UP  DTR=UP  DSR=UP  RTS=UP  CTS=UP

 

查看Router B的接口配置信息。

[RouterB-Serial2/0] display interface serial 2/0

Serial2/0 current state: UP

Line protocol current state: UP

Description: Serial2/0 Interface

The Maximum Transmit Unit is 1500, Hold timer is 10(sec)

Internet Address is 10.1.1.1/8 Primary

Link-protocol is LAPB

  LAPB DCE, module 128, window-size 127, max-frame 12032, retry 10

  Timer:  T1 3000, T2 1500, T3 0 , T4 0 (milliseconds),  IP-protocol

  state CONNECT, VS 66, VR 112, Remote VR 66

  IFRAME 240/194, RR 1/44, RNR 0/0, REJ 0/0

  FRMR 1/0, SABM 0/3, DM 1/0, UA 1/0

  DISC 0/0, invalid ns 0, invalid nr 0, link resets 1

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Physical layer is synchronous, Baudrate is 64000 bps

Interface is DCE, Cable type is V24, Clock mode is DCECLK

Last clearing of counters: Never

    Last 70 seconds input rate 6.69 bytes/sec, 53 bits/sec, 0.10 packets/sec

    Last 70 seconds output rate 0.30 bytes/sec, 2 bits/sec, 0.10 packets/sec

    Input: 865 packets, 20440 bytes

           0 broadcasts, 0 multicasts

           0 errors, 0 runts, 0 giants

           0 CRC, 0 align errors, 0 overruns

           0 dribbles, 0 aborts, 0 no buffers

           0 frame errors

    Output:861 packets, 17678 bytes

           0 errors, 0 underruns, 0 collisions

           0 deferred

    DCD=UP  DTR=UP  DSR=UP  RTS=UP  CTS=UP

1.14  X.25典型配置举例

1.14.1  两台设备直连的X.25配置举例(一条地址映射)

1. 组网需求

如下图所示,将两台设备简单地背靠背连接,串口之间使用X.25链路层协议并承载IP数据报进行传输。Router A上的IP地址与同一X.121地址之间的地址映射只有一条。

2. 组网图

图1-17 两台设备直连的X.25配置举例(一条地址映射)组网图

 

3. 配置步骤

(1)        配置Router A

# 进入接口视图,并为该接口指定IP地址。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 202.38.60.1 255.255.255.0

# 配置接口的链路层协议为X.25,并指定其工作在DTE方式。

[RouterA-Serial2/0] link-protocol x25 dte

# 配置该接口的X.121地址。

[RouterA-Serial2/0] x25 x121-address 20112451

# 配置到对端的地址映射。

[RouterA-Serial2/0] x25 map ip 202.38.60.2 x121-address 20112452

# 配置该接口的最大接收及发送分组的长度和接收窗口及发送窗口的尺寸。

[RouterA-Serial2/0] x25 packet-size 1024 1024

[RouterA-Serial2/0] x25 window-size 5 5

[RouterA-Serial2/0] shutdown

[RouterA-Serial2/0] undo shutdown

(2)        配置Router B

# 进入接口视图,并为该接口指定IP地址。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 202.38.60.2 255.255.255.0

# 配置接口的链路层协议为X.25,并指定其工作在DCE方式。

[RouterB-Serial2/0] link-protocol x25 dce

# 配置该接口的X.121地址。

[RouterB-Serial2/0] x25 x121-address 20112452

# 配置到对端的地址映射。

[RouterB-Serial2/0] x25 map ip 202.38.60.1 x121-address 20112451

# 配置该接口的最大接收及发送分组的长度和接收窗口及发送窗口的尺寸。

[RouterB-Serial2/0] x25 packet-size 1024 1024

[RouterB-Serial2/0] x25 window-size 5 5

[RouterB-Serial2/0] shutdown

[RouterB-Serial2/0] undo shutdown

请注意,两台设备简单地背靠背连接,封装为X.25协议,两端的IP地址可以不属于同一网段,不需要配置静态路由就可以互通,因为x25 map会完成IP地址和X.121地址的映射。

4. 验证配置结果

因为本例中配置的是SVC,所以只有在双方有通信需求时,他们之间才能建立虚连接。

在Router A上ping Router B,模拟Router A与Router B通信。

[RouterA-Serial2/0] ping 202.38.60.2

  PING 202.38.60.2: 56  data bytes, press CTRL_C to break

    Reply from 202.38.60.2: bytes=56 Sequence=1 ttl=255 time=33 ms

    Reply from 202.38.60.2: bytes=56 Sequence=2 ttl=255 time=27 ms

    Reply from 202.38.60.2: bytes=56 Sequence=3 ttl=255 time=26 ms

    Reply from 202.38.60.2: bytes=56 Sequence=4 ttl=255 time=26 ms

    Reply from 202.38.60.2: bytes=56 Sequence=5 ttl=255 time=26 ms

 

  --- 202.38.60.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 26/27/33 ms

 

这样两台设备之间建立了虚连接,查看Router A的X.25地址映射表信息。

[RouterA-Serial2/0] display x25 map

  Interface: Serial2/0(protocol status is UP)

    ip 202.38.60.2  X.121 address:20112452

      Map-type: SVC_MAP  VC-number: 1

      Facility:

 

查看Router A的X.25虚电路信息。

[RouterA-Serial2/0] display x25 vc

Interface: Serial2/0

  SVC 1024

    State: P4(transmit)

    Map: ip 202.38.60.2 to 20112452

    Window size: input 5  output 5

    Packet Size: input 1024  output 1024

    Local PS: 5  Local PR: 5  Remote PS: 4  Remote PR: 5

    Local Busy: FALSE  Reset times: 0

    Input/Output:

      DATA 5/5  INTERRUPT 0/0

      RR 0/0  RNR 0/0  REJ 0/0

      Bytes 420/420

    Send Queue(Current/Max): 0/200

1.14.2  两台设备直连的X.25配置举例(两条地址映射)

1. 组网需求

如下图所示,将两台设备简单地背靠背连接,串口之间使用X.25链路层协议并承载IP数据报进行传输。Router A上的IP地址与同一X.121地址之间的地址映射有两条。

2. 组网图

图1-18 两台设备直连的X.25配置举例(两条地址映射)组网图

 

3. 配置步骤

(1)        配置Router A

# 进入接口视图,并为该接口指定IP地址

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 202.38.160.1 255.255.255.0

# 配置接口的链路层协议为X.25,并指定其工作在DTE方式。

[RouterA-Serial2/0] link-protocol x25 dte

# 配置该接口的X.121地址。

[RouterA-Serial2/0] x25 x121-address 20112451

# 配置到对端的地址映射。

[RouterA-Serial2/0] x25 map ip 202.38.161.2 x121-address 20112452

[RouterA-Serial2/0] x25 map ip 202.38.160.2 x121-address 20112452

# 配置该接口的最大接收及发送分组的长度和接收窗口及发送窗口的尺寸。

[RouterA-Serial2/0] x25 packet-size 1024 1024

[RouterA-Serial2/0] x25 window-size 5 5

[RouterA-Serial2/0] shutdown

[RouterA-Serial2/0] undo shutdown

(2)        配置Router B

# 进入接口视图,并为该接口指定IP地址。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 202.38.160.2 255.255.255.0

# 配置接口的链路层协议为X.25,并指定其工作在DCE方式。

[RouterB-Serial2/0] link-protocol x25 dce

# 配置该接口的X.121地址。

[RouterB-Serial2/0] x25 x121-address 20112452

# 配置到对端的地址映射。

[RouterB-Serial2/0] x25 map ip 202.38.160.1 x121-address 20112451

# 配置该接口的最大接收及发送分组的长度和接收窗口及发送窗口的尺寸。

[RouterB-Serial2/0] x25 packet-size 1024 1024

[RouterB-Serial2/0] x25 window-size 5 5

[RouterB-Serial2/0] shutdown

[RouterB-Serial2/0] undo shutdown

# 因为对端有两个以上的IP地址对应本端的X.121地址,并且对应本端IP地址的MAP不是第一条,在呼叫建立时,本端MAP上会创建两条虚电路,所以需要配置MAP上允许创建的虚电路最大条数为2。

[RouterB-Serial2/0] x25 vc-per-map 2

4. 验证配置结果

因为本例中配置的是SVC,所以只有在双方有通信需求时,他们之间才能建立虚连接。

在Router A上ping Router B,模拟Router A与Router B通信。

[RouterA-Serial2/0] ping 202.38.160.2

  PING 202.38.160.2: 56  data bytes, press CTRL_C to break

    Reply from 202.38.160.2: bytes=56 Sequence=1 ttl=255 time=33 ms

    Reply from 202.38.160.2: bytes=56 Sequence=2 ttl=255 time=26 ms

    Reply from 202.38.160.2: bytes=56 Sequence=3 ttl=255 time=27 ms

    Reply from 202.38.160.2: bytes=56 Sequence=4 ttl=255 time=26 ms

    Reply from 202.38.160.2: bytes=56 Sequence=5 ttl=255 time=26 ms

 

  --- 202.38.160.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 26/27/33 ms

 

这样两台设备之间建立了虚连接,查看Router A的X.25地址映射表信息。

[RouterA-Serial2/0] display x25 map

  Interface: Serial2/0(protocol status is UP)

    ip 202.38.160.2  X.121 address:20112452

      Map-type: SVC_MAP  VC-number: 1

      Facility:

    ip 202.38.161.2  X.121 address:20112452

      Map-type: SVC_MAP  VC-number: 0

      Facility:

 

查看Router A的X.25虚电路信息。

[RouterA-Serial2/0] display x25 vc

Interface: Serial2/0

  SVC 1024

    State: P4(transmit)

    Map: ip 202.38.160.2 to 20112452

    Window size: input 5  output 5

    Packet Size: input 1024  output 1024

    Local PS: 5  Local PR: 5  Remote PS: 4  Remote PR: 5

    Local Busy: FALSE  Reset times: 0

    Input/Output:

      DATA 5/5  INTERRUPT 0/0

      RR 0/0  RNR 0/0  REJ 0/0

      Bytes 420/420

    Send Queue(Current/Max): 0/200

1.14.3  将设备接入到X.25公共分组网中配置举例

1. 组网需求

如下图所示,Router A、B、C接入到同一个X.25网中互相通信。要求:

l              三台设备的接口Serial2/0的IP地址分别是168.173.24.1/24、168.173.24.2/24、168.173.24.3/24;

l              X.25网络分配给这三台设备的X.121地址分别是30561001、30561002、30561003;

l              X.25网支持的标准窗口尺寸为:接收窗口5和发送窗口5;

l              X.25网支持的标准最大分组长度为:最大接收分组长度512和最大发送分组长度512;

l              信道范围是:禁止使用永久虚电路区间、单向呼入信道区间和单向呼出信道区间,双向信道区间为[1,32]。

2. 组网图

图1-19 将设备接入X.25公共分组网组网图

 

3. 配置步骤

(1)        配置Router A

# 配置接口IP地址。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 168.173.24.1 255.255.255.0

# 接入到X.25公共分组网中,使设备做DTE侧。

[RouterA-Serial2/0] link-protocol x25 dte

[RouterA-Serial2/0] x25 x121-address 30561001

[RouterA-Serial2/0] x25 window-size 5 5

[RouterA-Serial2/0] x25 packet-size 512 512

[RouterA-Serial2/0] x25 vc-range bi-channel 1 32

[RouterA-Serial2/0] x25 map ip 168.173.24.2 x121-address 30561002

[RouterA-Serial2/0] x25 map ip 168.173.24.3 x121-address 30561003

[RouterA-Serial2/0] shutdown

[RouterA-Serial2/0] undo shutdown

(2)        配置Router B

# 配置接口IP地址。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 168.173.24.2 255.255.255.0

# 接入到X.25公共分组网中,使设备做DTE侧。

[RouterB-Serial2/0] link-protocol x25 dte

[RouterB-Serial2/0] x25 x121-address 30561002

[RouterB-Serial2/0] x25 window-size 5 5

[RouterB-Serial2/0] x25 packet-size 512 512

[RouterB-Serial2/0] x25 vc-range bi-channel 1 32

[RouterB-Serial2/0] x25 map ip 168.173.24.1 x121-address 30561001

[RouterB-Serial2/0] x25 map ip 168.173.24.3 x121-address 30561003

[RouterB-Serial2/0] shutdown

[RouterB-Serial2/0] undo shutdown

(3)        配置Router C

# 配置接口IP地址。

<RouterC> system-view

[RouterC] interface serial 2/0

[RouterC-Serial2/0] ip address 168.173.24.3 255.255.255.0

# 接入到X.25公共分组网中,使设备做DTE侧。

[RouterC-Serial2/0] link-protocol x25 dte

[RouterC-Serial2/0] x25 x121-address 30561003

[RouterC-Serial2/0] x25 window-size 5 5

[RouterC-Serial2/0] x25 packet-size 512 512

[RouterC-Serial2/0] x25 vc-range bi-channel 1 32

[RouterC-Serial2/0] x25 map ip 168.173.24.1 x121-address 30561001

[RouterC-Serial2/0] x25 map ip 168.173.24.2 x121-address 30561002

[RouterC-Serial2/0] shutdown

[RouterC-Serial2/0] undo shutdown

4. 验证配置结果

在Router A上分别ping Router B和Router C,可以ping通。

以Router A为例查看X.25地址映射表信息。

[RouterA-Serial2/0] display x25 map

  Interface: Serial2/0(protocol status is UP)

    ip 168.173.24.2  X.121 address:30561002

      Map-type: SVC_MAP  VC-number: 1

      Facility:

    ip 168.173.24.3  X.121 address:30561003

      Map-type: SVC_MAP  VC-number: 1

      Facility:

1.14.4  虚电路范围配置举例

1. 组网需求

设备Router的接口Serial2/0的链路层协议为X.25,虚电路范围是:永久虚电路区间为[1,8],单向呼入信道区间为[9,16],双向信道区间为[17,1024],单向呼出信道区间被禁止使用。

2. 配置步骤

<Router> system-view

[Router] interface serial 2/0

[Router-Serial2/0] link-protocol x25

[Router-Serial2/0] x25 vc-range in-channel 9 16 bi-channel 17 1024

[Router-Serial2/0] shutdown

[Router-Serial2/0] undo shutdown

3. 验证配置结果

查看接口Serial2/0的配置信息。

[Router-Serial2/0] display this

#

interface Serial2/0

 link-protocol x25

 x25 vc-range in-channel 9 16 bi-channel 17 1024

#

return

1.14.5  通过X.25 PVC传输IP数据报配置举例

1. 组网需求

l              X.25分组网允许的永久虚电路区间是[1,8],分配给Router A和Router B的永久虚电路号分别是3和4;

l              LAN 1和LAN 2的IP网络地址分别是202.38.165.0/24和196.25.231.0/24;

l              使用路由协议RIP在LAN 1和LAN 2之间交换路由信息,使得在不添加静态路由的情况下,Host A和Host B即可互相交换信息。

2. 组网图

图1-20 X.25 PVC承载IP数据报组网图

 

3. 配置步骤

(1)        配置Router A

# 配置Ethernet1/1。

<RouterA> system-view

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] ip address 202.38.165.1 255.255.255.0

[RouterA-Ethernet1/1] quit

# 配置Serial2/0。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] ip address 192.149.13.1 255.255.255.0

[RouterA-Serial2/0] link-protocol x25

[RouterA-Serial2/0] x25 x121-address 1004358901

[RouterA-Serial2/0] x25 vc-range bi-channel 9 1024

[RouterA-Serial2/0] x25 pvc 3 ip 192.149.13.2 x121-address 1004358902 broadcast packet-size 512 512 window-size 5 5

[RouterA-Serial2/0] shutdown

[RouterA-Serial2/0] undo shutdown

[RouterA-Serial2/0] quit

# 启动RIP协议。

[RouterA] rip

[RouterA-rip-1] network 192.0.0.0

[RouterA-rip-1] network 202.0.0.0

(2)        配置Router B

# 配置Ethernet1/1。

<RouterB> system-view

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ip address 196.25.231.1 255.255.255.0

[RouterB-Ethernet1/1] quit

# 配置Serial2/0。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] ip address 192.149.13.2 255.255.255.0

[Sysname-Serial2/0] link-protocol x25

[RouterB-Serial2/0] x25 x121-address 1004358902

[RouterB-Serial2/0] x25 vc-range bi-channel 9 1024

[RouterB-Serial2/0] x25 pvc 4 ip 192.149.13.1 x121-address 1004358901 broadcast packet-size 512 512 window-size 5 5

[RouterB-Serial2/0] shutdown

[RouterB-Serial2/0] undo shutdown

[RouterB-Serial2/0] quit

# 启动RIP协议。

[RouterB] rip

[RouterB-rip-1] network 192.0.0.0

[RouterB-rip-1] network 196.0.0.0

在以上的配置过程中,也许有一点会让人觉得不解,那就是为什么设备A和B的永久虚电路号不一样,一个是3,另一个是4?

要回答这个问题,必须先严格地区分“虚电路”和“逻辑信道”这两个概念。

l              虚电路指的是端到端的一条逻辑通路(即主叫DTE和被叫DTE之间)。

l              逻辑信道指的是直接连接的两台设备之间的逻辑通路(或许是DTE与DCE之间,或许是两台分组交换机的端口之间)。

一条虚电路是由若干段逻辑信道拼接而成,并且每一段逻辑信道具有独立的编号。这样,就可以联想设备A和B之间的虚电路如下图1-21所描述的情景(假设这条虚电路在网内经过了四个分组交换机)。

图1-21 由若干段逻辑信道组成的一条虚电路

 

所以,在上例中所说的“永久虚电路3”和“永久虚电路4”其实指的是设备与和它直接相连的交换机之间的逻辑信道号;但是,在这条虚电路的某一侧,完全可以用这个逻辑信道号来标识这条虚电路,而且不会引起误会。这就是在平常的叙述中不严格区分“虚电路”和“逻辑信道”这两个概念的原因。

4. 验证配置结果

在Router A上ping Router B,可以ping通。

查看Router A的X.25地址映射表信息。

[RouterA] display x25 map

  Interface: Serial2/0(protocol status is UP)

    ip 192.149.13.2  X.121 address:1004358902

      Map-type: PVC_MAP  VC-number: 1

      Facility:

        BROADCAST;

        PACKET_SIZE: I 512  O 512 ;

        WINDOW_SIZE: I 5  O 5 ;

1.14.6  X.25子接口配置举例

1. 组网需求

在一个物理接口上配置多个子接口与不同网段的多个对端相连。

图1-22所示,Router A上配置两个子接口,分别与Route B和Router C互连,Router D作为X.25交换机。通过配置实现Router A和Route B、Router A和Route C能够互相通信。

2. 组网图

图1-22 X.25子接口配置组网图

 

3. 配置步骤

(1)        配置Router A

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte

[RouterA-Serial2/0] x25 x121-address 100

[RouterA-Serial2/0] quit

# 创建子接口Serial2/0.1,配置子接口的IP地址以及到Router B的X.25映射。

[RouterA] interface serial 2/0.1

[RouterA-Serial2/0.1] ip address 10.1.1.2 255.255.0.0

[RouterA-Serial2/0.1] x25 map ip 10.1.1.1 x121-address 200

[RouterA-Serial2/0.1] quit

# 创建子接口Serial2/0.2,配置子接口的IP地址以及到Router C的X.25映射。

[RouterA] interface serial 2/0.2

[RouterA-Serial2/0.2] ip address 20.1.1.2 255.255.0.0

[RouterA-Serial2/0.2] x25 map ip 20.1.1.1 x121-address 300

[RouterA-Serial2/0.2] quit

(2)        配置Router B

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dte

[RouterB-Serial2/0] x25 x121-address 200

[RouterB-Serial2/0] x25 map ip 10.1.1.2 x121-address 100

[RouterB-Serial2/0] ip address 10.1.1.1 255.255.0.0

(3)        配置Router C

<RouterC> system-view

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol x25 dte

[RouterC-Serial2/0] x25 x121-address 300

[RouterC-Serial2/0] x25 map ip 20.1.1.2 x121-address 100

[RouterC-Serial2/0] ip address 20.1.1.1 255.255.0.0

(4)        配置Router D作为X.25交换机

<RouterD> system-view

[RouterD] interface serial 2/0

[RouterD-Serial2/0] link-protocol x25 dce

[RouterD-Serial2/0] quit

[RouterD] interface serial 2/1

[RouterD-Serial2/1] link-protocol x25 dce

[RouterD-Serial2/1] quit

[RouterD] interface serial 2/2

[RouterD-Serial2/2] link-protocol x25 dce

[RouterD-Serial2/2] quit

# 创建SVC交换路由,配置到指定X.121地址的报文从哪个接口发送出去。

[RouterD] x25 switching

[RouterD] x25 switch svc 100 interface serial 2/0

[RouterD] x25 switch svc 200 interface serial 2/1

[RouterD] x25 switch svc 300 interface serial 2/2

4. 验证配置结果

因为本例中配置的是SVC,所以只有在双方有通信需求时,他们之间才能建立虚连接。

在Router A上ping Router B,模拟Router A与Router B通信。

[RouterA] ping 10.1.1.1

  PING 10.1.1.1: 56  data bytes, press CTRL_C to break

    Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=64 ms

    Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=52 ms

    Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=53 ms

    Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=52 ms

    Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=52 ms

 

  --- 10.1.1.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 52/54/64 ms

 

这样两台设备之间建立了虚连接,查看Router A的X.25地址映射表信息。

[RouterA] display x25 map

  Interface: Serial2/0.2(protocol status is UP)

    ip 20.1.1.1  X.121 address:300

      Map-type: SVC_MAP  VC-number: 0

      Facility:

  Interface: Serial2/0.1(protocol status is UP)

    ip 10.1.1.1  X.121 address:200

      Map-type: SVC_MAP  VC-number: 0

      Facility:

 

查看Router A的X.25虚电路信息。

[RouterA] display x25 vc

Interface: Serial2/0.1

  SVC 1024

    State: P4(transmit)

    Map: ip 10.1.1.1 to 200

    Window size: input 2  output 2

    Packet Size: input 128  output 128

    Local PS: 5  Local PR: 5  Remote PS: 4  Remote PR: 5

    Local Busy: FALSE  Reset times: 0

    Input/Output:

      DATA 5/5  INTERRUPT 0/0

      RR 0/0  RNR 0/0  REJ 0/0

      Bytes 420/420

    Send Queue(Current/Max): 0/200

 

查看Router DX25交换路由表信息。

[RouterD] display x25 switch-table svc static

Number Destination    Substitute-src Substitute-dst CUD      SwitchTo(type/name)

1      100                                                   I/Serial2/0

2      200                                                   I/Serial2/1

3      300                                                   I/Serial2/2

Total of static svc is 3.

The item type of SwitchTo meaning:

  I: interface   H: hunt-group   T: xot

 

[RouterD] display x25 switch-table svc dynamic

  #1     (In: Serial2/0          - SVC1024) <--> (Out: Serial2/1          - SVC1   )

1.14.7  XOT的SVC应用配置举例

1. 组网需求

Router B和Router C通过以太网口相连,在它们之间建立TCP连接,Router A的接口Serial2/0与Router D的接口Serial2/0之间的X.25报文通过该TCP连接传送,配置SVC,实现XOT的SVC功能。

2. 组网图

图1-23 XOT的SVC应用典型配置组网图

 

3. 配置步骤

(1)        配置Router A

# 配置基本的X.25功能。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte ietf

[RouterA-Serial2/0] x25 x121-address 1

[RouterA-Serial2/0] x25 map ip 1.1.1.2 x121-address 2

[RouterA-Serial2/0] ip address 1.1.1.1 255.0.0.0

(2)        配置Router D

# 配置基本的X.25功能。

<RouterD> system-view

[RouterD] interface serial 2/0

[RouterD-Serial2/0] link-protocol x25 dte ietf

[RouterD-Serial2/0] x25 x121-address 2

[RouterD-Serial2/0] x25 map ip 1.1.1.1 x121-address 1

[RouterD-Serial2/0] ip address 1.1.1.2 255.0.0.0

(3)        配置Router B

# 启动X.25交换。

<RouterB> system-view

[RouterB] x25 switching

# 配置X.25本地交换,指定发往X.121地址1的报文从接口Serial2/0转发。

[RouterB] x25 switch svc 1 interface serial 2/0

# 配置XOT的交换,增加一条转发地址为XOT通道的X.25交换路由。

[RouterB] x25 switch svc 2 xot 10.1.1.2

# 配置Serial2/0。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dce ietf

[RouterB-Serial2/0] quit

# 配置接口Ethernet1/1。

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ip address 10.1.1.1 255.0.0.0

(4)        配置Router C

# 启动X.25交换。

<RouterC> system-view

[RouterC] x25 switching

# 配置X.25本地交换,指定发往X.121地址2的报文从接口Serial2/0转发。

[RouterC] x25 switch svc 2 interface serial 2/0

# 配置XOT的交换,增加一条转发地址为XOT通道的X.25交换路由。

[RouterC] x25 switch svc 1 xot 10.1.1.1

# 配置Serial2/0。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol x25 dce ietf

[RouterC-Serial2/0] quit

# 配置Ethernet1/1。

[RouterC] interface ethernet 1/1

[RouterC-Ethernet1/1] ip address 10.1.1.2 255.0.0.0

1.14.8  XOT的PVC应用配置举例

1. 组网需求

Router B和Router C通过以太网口相连,在它们之间建立TCP连接。Router A的接口Serial2/0与Router D的接口Serial2/0之间的X.25报文通过TCP连接传送,配置PVC,实现XOT的PVC功能。

2. 组网图

图1-24 XOT的PVC应用典型配置组网图

 

3. 配置步骤

(1)        配置Router A

# 配置基本的X.25功能。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte ietf

[RouterA-Serial2/0] x25 x121-address 1111

[RouterA-Serial2/0] x25 vc-range in-channel 10 20 bi-channel 30 1024

[RouterA-Serial2/0] x25 pvc 1 ip 1.1.1.2 x121-address 2222

[RouterA-Serial2/0] ip address 1.1.1.1 255.0.0.0

(2)        配置Router D

# 配置基本的X.25功能。

<RouterD> system-view

[RouterD] interface serial 2/0

[RouterD-Serial2/0] link-protocol x25 dte ietf

[RouterD-Serial2/0] x25 x121-address 2222

[RouterD-Serial2/0] x25 vc-range in-channel 10 20 bi-channel 30 1024

[RouterD-Serial2/0] x25 pvc 2 ip 1.1.1.1 x121-address 1111

[RouterD-Serial2/0] ip address 1.1.1.2 255.0.0.0

(3)        配置Router B

# 启动X.25交换。

<RouterB> system-view

[RouterB] x25 switching

# 配置Serial2/0,创建XOT路由。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dce ietf

[RouterB-Serial2/0] x25 vc-range in-channel 10 20 bi-channel 30 1024

[RouterB-Serial2/0] x25 xot pvc 1 10.1.1.2 interface serial 2/0 pvc 2

# 配置Ethernet1/1。

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ip address 10.1.1.1 255.0.0.0

(4)        配置Router C

# 启动X.25交换。

<RouterC> system-view

[RouterC] x25 switching

# 配置Serial2/0,创建XOT路由。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol x25 dce ietf

[RouterC-Serial2/0] x25 vc-range in-channel 10 20 bi-channel 30 1024

[RouterC-Serial2/0] x25 xot pvc 2 10.1.1.1 interface serial 2/0 pvc 1

# 配置Ethernet1/1

[RouterC] interface ethernet 1/1

[RouterC-Ethernet1/1] ip address 10.1.1.2 255.0.0.0

1.14.9  X.25 Over FR的SVC应用配置举例

1. 组网需求

Router A与Router B,Router C与Router D通过X.25相连,而Router B和Router C通过帧中继相连,通过在Router B和Router C上配置帧中继Annex G DLCI 100,实现两个X.25网络的互联,从而使Host A和Host B可以互相通信。

2. 组网图

图1-25 X.25 Over FR的SVC应用典型配置组网图

 

3. 配置步骤

(1)        配置Router A

# 配置基本的X.25功能。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte

[RouterA-Serial2/0] x25 x121-address 1

[RouterA-Serial2/0] x25 map ip 1.1.1.2 x121-address 2

[RouterA-Serial2/0] ip address 1.1.1.1 255.0.0.0

(2)        配置Router D

# 配置基本的X.25功能。

<RouterD> system-view

[RouterD] interface serial 2/0

[RouterD-Serial2/0] link-protocol x25 dte

[RouterD-Serial2/0] x25 x121-address 2

[RouterD-Serial2/0] x25 map ip 1.1.1.1 x121-address 1

[RouterD-Serial2/0] ip address 1.1.1.2 255.0.0.0

(3)        配置Router B

# 启动X.25交换。

<RouterB> system-view

[RouterB] x25 switching

# 配置X.25接口Serial2/0。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dce

# 配置帧中继接口Serial2/1

[RouterB] interface serial 2/1

[RouterB-Serial2/1] link-protocol fr

[RouterB-Serial2/1] fr interface-type dce

# 配置帧中继Annex G DLCI

[RouterB-Serial2/1] fr dlci 100

[RouterB-fr-dlci-Serial2/1-100] annexg dce

# 配置X.25本地交换。

[RouterB] x25 switch svc 1 interface serial 2/0

# 配置X.25 Over FR的交换。

[RouterB] x25 switch svc 2 interface serial 2/1 dlci 100

(4)        配置Router C

# 启动X.25交换。

<RouterC> system-view

[RouterC] x25 switching

# 配置X.25接口Serial2/0。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol x25 dce

# 配置帧中继接口Serial2/1

[RouterC] interface serial 2/1

[RouterC-Serial2/1] link-protocol fr

# 配置帧中继Annex G DLCI

[RouterC-Serial2/1] fr dlci 100

[RouterC-fr-dlci-Serial2/1-100] annexg dte

# 配置X.25本地交换。

[RouterC] x25 switch svc 2 interface serial 2/0

# 配置X.25 Over FR的交换。

[RouterC] x25 switch svc 1 interface serial 2/1 dlci 100

1.14.10  X.25 Over FR的PVC应用配置举例

1. 组网需求

Router A与Router B,Router C与Router D通过X.25相连,而Router B和Router C通过帧中继相连,通过在Router B和Router C上配置帧中继Annex G DLCI 100,实现两个X.25网络的互联,从而使Host A和Host B可以相互通信。

2. 组网图

图1-26 X.25 Over FR的PVC应用典型配置组网图

 

3. 配置步骤

(1)        配置Router A

# 配置基本的X.25功能。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte

[RouterA-Serial2/0] x25 x121-address 1

[RouterA-Serial2/0] x25 vc-range bi-channel 10 20

[RouterA-Serial2/0] x25 pvc 1 ip 1.1.1.2 x121-address 2

[RouterA-Serial2/0] ip address 1.1.1.1 255.255.255.0

(2)        配置Router D

# 配置基本的X.25功能。

<RouterD> system-view

[RouterD] interface serial 2/0

[RouterD-Serial2/0] link-protocol x25 dte

[RouterD-Serial2/0] x25 x121-address 2

[RouterD-Serial2/0] x25 vc-range bi-channel 10 20

[RouterD-Serial2/0] x25 pvc 1 ip 1.1.1.1 x121-address 1

[RouterD-Serial2/0] ip address 1.1.1.2 255.255.255.0

(3)        配置Router B

# 启动X.25交换。

<RouterB> system-view

[RouterB] x25 switching

# 配置X.25接口下的PVC交换路由。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dce

[RouterB-Serial2/0] x25 vc-range bi-channel 10 20

[RouterB-Serial2/0] x25 switch pvc 1 interface serial 2/1 dlci 100 pvc 1

# 配置X25模板。

[RouterB] x25 template switch

[RouterB-x25-switch] x25 vc-range bi-channel 10 20

# 配置x25模板下的交换路由

[RouterB-x25-switch] x25 switch pvc 1 interface serial 2/0 pvc 1

# 配置帧中继接口Serial2/1。

[RouterB] interface serial 2/1

[RouterB-Serial2/1] link-protocol fr

[RouterB-Serial2/1] fr interface-type dce

# 配置帧中继Annex G DLCI。

[RouterB-Serial2/1] fr dlci 100

[RouterB-fr-dlci-Serial2/1-100] annexg dce

# 在帧中继Annex G DLCI上应用x25模板。

[RouterB-fr-dlci-Serial2/1-100] x25-template switch

(4)        配置Router C

# 启动X.25交换。

<RouterC> system-view

[RouterC] x25 switching

# 配置X.25接口下的PVC交换路由。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol x25 dce

[RouterC-Serial2/0] x25 vc-range bi-channel 10 20

[RouterC-Serial2/0] x25 switch pvc 1 interface serial 2/1 dlci 100 pvc 1

# 配置X25模板。

[RouterC] x25 template switch

[RouterC-x25-switch] x25 vc-range bi-channel 10 20

# 配置x25模板下的交换路由

[RouterC-x25-switch] x25 switch pvc 1 interface serial 2/0 pvc 1

# 配置帧中继接口Serial2/1。

[RouterC] interface serial 2/1

[RouterC-Serial2/1] link-protocol fr

# 配置帧中继Annex G DLCI。

[RouterC-Serial2/1] fr dlci 100

[RouterC-fr-dlci-Serial2/1-100] annexg dte

# 在帧中继Annex G DLCI上应用X25模板。

[RouterC-fr-dlci-Serial2/1-100] x25-template switch

1.14.11  X.25负载分担应用配置举例

1. 组网需求

l              设备Router A作为X.25交换机,在其上配置X25搜索群,同时启用目的地址和源地址替换功能,使得X.25终端的呼叫能够被负载分担到设备Router B、Router C、Router E上,实现X.25网络上设备的负载分担。

l              设备Router D作为X.25交换机,实现XOT功能,连接设备Router A和Router E。

l              设备Router B、Router C、Router E为X25搜索群中的DTE,它们为X.25终端提供相同的服务。

l              Router B和Router A之间应用X.25协议,Router C和Router A之间应用帧中继协议,通过在DLCI上应用Annex G实现两台路由器的互通。

2. 组网图

图1-27 X.25负载分担应用配置组网图

 

3. 配置步骤

(1)        配置Router A

# 配置Serial2/0的链路层协议为X.25,并指定其工作在DCE方式。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dce

# 配置Serial2/2、Serial2/3和Serial2/4的链路层协议均为X.25,并工作在DCE方式(具体配置请参考Serial2/0)。

# 配置Serial2/1的链路层协议为帧中继,并指定其工作在DCE方式。

[RouterA] interface serial 2/1

[RouterA-Serial2/1] link-protocol fr

[RouterA-Serial2/1] fr interface-type dce

# 配置帧中继Annex G DLCI

[RouterA-Serial2/1] fr dlci 100

[RouterA-fr-dlci-Serial2/1-100] annexg dce

[RouterA-fr-dlci-Serial2/1-100] quit

[RouterA-Serial2/1] quit

# 配置Ethernet1/1。

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] ip address 10.1.1.1 255.255.255.0

[RouterA-Ethernet1/1] quit

# 启动X.25交换。

[RouterA] x25 switching

# 在创建X.25搜索群hg 1。

[RouterA] x25 hunt-group hg1 round-robin

# 将Serial2/2、Serial2/1及XOT通道添加到搜索群。

[RouterA-hg-hg1] channel interface serial 2/2

[RouterA-hg-hg1] channel interface serial 2/1 dlci 100

[RouterA-hg-hg1] channel xot 10.1.1.2

[RouterA-hg-hg1] quit

# 配置转发地址为搜索群hg 1的X.25交换路由,启用目的地址和源地址替换,将所有呼叫到搜索群地址2222的呼叫的源地址替换为3333,目的地址替换为8888。

[RouterA] x25 switch svc 2222 sub-dest 8888 sub-source 3333 hunt-group hg1

# 配置转发至X.25终端的X.25交换路由。

[RouterA] x25 switch svc 1111 interface serial 2/3

[RouterA] x25 switch svc 1112 interface serial 2/4

[RouterA] x25 switch svc 1113 interface serial 2/0

(2)        配置Router B

# 配置Serial2/0的链路层协议为X.25,并指定其工作在DTE方式。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dte

[RouterB-Serial2/0] x25 x121-address 8888

(3)        配置Router C

# 配置X25模板。

<RouterC> system-view

[RouterC] x25 template vofr

[RouterC-x25-vofr] x25 x121-address 8888

[RouterC-x25-vofr] quit

# 在Serial2/0配置帧中继协议。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol fr

# 配置帧中继Annex G DLCI。

[RouterC-Serial2/0] fr dlci 100

[RouterC-fr-dlci-Serial2/0-100] annexg dte

# 应用X.25模板到DLCI上。

[RouterC-fr-dlci-Serial2/0-100] x25-template vofr

(4)        配置Router E

# 配置Serial2/0的链路层协议为X.25,并指定其工作在DTE方式。

<RouterE> system-view

[RouterE] interface serial 2/0

[RouterE-Serial2/0] link-protocol x25 dte

[RouterE-Serial2/0] x25 x121-address 8888

(5)        配置Router D

# 启动X.25交换。

<RouterD> system-view

[RouterD] x25 switching

# 配置Serial2/0的链路层协议为X.25,并指定其工作在DCE方式。

[RouterD] interface serial 2/0

[RouterD-Serial2/0] link-protocol x25 dce

[RouterD-Serial2/0] quit

# 在Ethernet1/1配置IP地址。

[RouterD] interface ethernet 1/1

[RouterD-Ethernet1/1] ip address 10.1.1.2 255.255.255.0

[RouterD-Ethernet1/1] quit

# 配置转发地址为XOT通道的X.25交换路由。

[RouterD] x25 switch svc 3333 xot 10.1.1.1

# 配置转发至设备RouterE的X.25交换路由。

[RouterD] x25 switch svc 8888 interface serial 2/0

4. 验证配置结果

查看Router A的X.25 SVC交换路由表信息。

[RouterA] display x25 switch-table svc static

Number Destination    Substitute-src Substitute-dst CUD      SwitchTo(type/name)

1      2222           3333           8888                    H/hg1

2      1111                                                  I/Serial2/3

3      1112                                                  I/Serial2/4

4      1113                                                  I/Serial2/0

Total of static svc is 4.

The item type of SwitchTo meaning:

  I: interface   H: hunt-group   T: xot

从上述显示信息可以看出,到达目的地址为8888的报文在Router B、Router C和Router E上实现了负载分担。

1.14.12  X.25负载分担承载IP数据传输配置举例

1. 组网需求

处于不同地域的IP网络通过X.25分组交换网连接起来,用X.25网络承载IP数据。

由网络供应商提供X.25网络负载分担功能,在用户侧配合其进行配置,实现不同客户端访问服务器时的线路负载分担。

2. 组网图

图1-28 X.25负载分担承载IP数据传输配置组网图

 

3. 配置步骤

在本例中,负载分担的配置是由网络供应商在分组交换机上配置的,因此在设备上只需要进行普通的X.25配置。

需要说明的是,因为在Router C上存在着两条连接到同一对端的线路,所以必须在Serial2/1上配置一个虚拟IP地址和两条静态路由来“欺骗”设备。这样,Router C会认为存在着两条通向网段10.1.1.0的路由,从而实现了负载分担。

(1)        配置Router A

# 配置Ethernet1/1。

<RouterA> system-view

[RouterA] interface ethernet 1/1

[RouterA-Ethernet1/1] ip address 10.1.1.1 255.255.255.0

[RouterA-Ethernet1/1] quit

# 配置Serial2/0。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte

[RouterA-Serial2/0] x25 x121-address 1111

[RouterA-Serial2/0] ip address 1.1.1.1 255.255.255.0

[RouterA-Serial2/0] x25 map ip 1.1.1.3 x121-address 3333

[RouterA-Serial2/0] x25 vc-per-map 2

# 配置静态路由到Router C。

[RouterA] ip route-static 10.3.1.0 24 1.1.1.3

(2)        配置Router B

# 配置Ethernet1/1。

<RouterB> system-view

[RouterB] interface ethernet 1/1

[RouterB-Ethernet1/1] ip address 10.2.1.1 255.255.255.0

[RouterB-Ethernet1/1] quit

# 配置Serial2/0。

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dte

[RouterB-Serial2/0] x25 x121-address 2222

[RouterB-Serial2/0] ip address 1.1.1.2 255.255.255.0

[RouterB-Serial2/0] x25 map ip 1.1.1.3 x121-address 3333

[RouterB-Serial2/0] x25 vc-per-map 2

# 配置静态路由到Router C。

[RouterB] ip route-static 10.3.1.0 24 1.1.1.3

(3)        配置Router C

# 配置Ethernet1/1。

<RouterC> system-view

[RouterC] interface ethernet 1/1

[RouterC-Ethernet1/1] ip address 10.3.1.1 255.255.255.0

[RouterC-Ethernet1/1] quit

# 配置Serial2/0。

[RouterC] interface serial 2/0

[RouterC-Serial2/0] link-protocol x25 dte

[RouterC-Serial2/0] x25 x121-address 3333

[RouterC-Serial2/0] ip address 1.1.1.3 255.255.255.0

[RouterC-Serial2/0] x25 map ip 1.1.1.1 x121-address 1111

[RouterC-Serial2/0] x25 map ip 2.1.1.1 x121-address 1111

[RouterC-Serial2/0] x25 map ip 1.1.1.2 x121-address 2222

[RouterC-Serial2/0] x25 map ip 2.1.1.2 x121-address 2222

# 配置Serial2/1。

[RouterC] interface serial 2/1

[RouterC-Serial2/1] link-protocol x25 dte

[RouterC-Serial2/1] x25 x121-address 3333

[RouterC-Serial2/1] ip address 2.1.1.3 255.255.255.0

[RouterC-Serial2/1] x25 map ip 1.1.1.1 x121-address 1111

[RouterC-Serial2/1] x25 map ip 2.1.1.1 x121-address 1111

[RouterC-Serial2/1] x25 map ip 1.1.1.2 x121-address 2222

[RouterC-Serial2/1] x25 map ip 2.1.1.2 x121-address 2222

# 配置到Router A和Router B的静态路由。

[RouterC] ip route-static 10.1.1.0 24 1.1.1.1

[RouterC] ip route-static 10.1.1.0 24 2.1.1.1

[RouterC] ip route-static 10.2.1.0 24 1.1.1.2

[RouterC] ip route-static 10.2.1.0 24 2.1.1.2

4. 验证配置结果

查看Router C的X25地址映射表信息。

[RouterC] display x25 map

  Interface: Serial2/1(protocol status is UP)

    ip 1.1.1.1  X.121 address:1111

      Map-type: SVC_MAP  VC-number: 0

      Facility:

    ip 2.1.1.1  X.121 address:1111

      Map-type: SVC_MAP  VC-number: 0

      Facility:

    ip 1.1.1.2  X.121 address:2222

      Map-type: SVC_MAP  VC-number: 0

      Facility:

    ip 2.1.1.2  X.121 address:2222

      Map-type: SVC_MAP  VC-number: 0

      Facility:

  Interface: Serial2/0(protocol status is UP)

    ip 1.1.1.1  X.121 address:1111

      Map-type: SVC_MAP  VC-number: 0

      Facility:

    ip 2.1.1.1  X.121 address:1111

      Map-type: SVC_MAP  VC-number: 0

      Facility:

    ip 1.1.1.2  X.121 address:2222

      Map-type: SVC_MAP  VC-number: 0

      Facility:

    ip 2.1.1.2  X.121 address:2222

      Map-type: SVC_MAP  VC-number: 0

      Facility:

1.14.13  TCP/IP头压缩协议应用配置举例

1. 组网需求

将两台设备简单地背靠背连接。

2. 组网图

图1-29 TCP/IP头压缩协议应用配置组网图

 

3. 配置步骤

(1)        配置Router A

# 配置Serial2/0的链路层协议为X.25,工作在DTE模式。

<RouterA> system-view

[RouterA] interface serial 2/0

[RouterA-serial2/0] link-protocol x25 dte ietf

# 为该接口指定X.121地址。

[RouterA-serial2/0] x25 x121-address 1001

# 为该接口指定IP地址。

[RouterA-serial2/0] ip address 16.16.16.1 255.255.0.0

# 配置支持TCP/IP头压缩。

[RouterA-serial2/0] x25 map compressedtcp 16.16.16.2 x121-address 1002

(2)        配置Router B

# 配置Serial2/0的链路层协议为X.25,工作在DCE模式。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-serial2/0] link-protocol x25 dce ietf

# 为该接口指定X.121地址。

[RouterB-serial2/0] x25 x121-address 1002

# 为该接口指定IP地址。

[RouterB-serial2/0] ip address 16.16.16.2 255.255.0.0

# 配置支持TCP/IP头压缩。

[RouterB-serial2/0] x25 map compressedtcp 16.16.16.1 x121-address 1001

4. 验证配置结果

配置完成后,执行ping命令,可以看到两端可以互相ping通。

[RouterA-serial2/0] ping 16.16.16.2

  PING 16.16.16.2: 56  data bytes, press CTRL_C to break

    Reply from 16.16.16.2: bytes=56 Sequence=1 ttl=255 time=36 ms

    Reply from 16.16.16.2: bytes=56 Sequence=2 ttl=255 time=26 ms

    Reply from 16.16.16.2: bytes=56 Sequence=3 ttl=255 time=26 ms

    Reply from 16.16.16.2: bytes=56 Sequence=4 ttl=255 time=26 ms

    Reply from 16.16.16.2: bytes=56 Sequence=5 ttl=255 time=26 ms

 

  --- 16.16.16.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 26/28/36 ms

1.14.14  X.25 PAD应用配置举例

1. 组网需求

如下图所示,将两台设备通过X.25网络连接。Router B向Router A发起呼叫后能够登录并可以配置Router A。

2. 组网图

图1-30 X.25 PAD应用配置组网图

 

3. 配置步骤

(1)        配置Router A

# 添加PAD用户。

<RouterA> system-view

[RouterA] local-user pad1

[RouterA-luser-pad1] password simple pad1

[RouterA-luser-pad1] service-type pad

[Sysname-luser-pad1] quit

# 配置User-interface的验证方式及协议类型。

[RouterA] user-interface vty 0 4

[RouterA-ui-vty0-4] authentication-mode scheme

[RouterA-ui-vty0-4] protocol inbound pad

[RouterA-ui-vty0-4] quit

# 配置域用户x25使用本地认证方案。

[RouterA] domain x25

[RouterA-isp-x25] authentication ppp local

[RouterA-isp-x25] quit

# 配置Serial2/0的链路层协议为X.25,并指定其工作在DTE方式 。

[RouterA] interface serial 2/0

[RouterA-Serial2/0] link-protocol x25 dte

# 指定该接口的X.121地址

[RouterA-Serial2/0] x25 x121-address 1

(2)        配置Router B

# 配置Serial2/0的链路层协议为X.25,并指定其工作在DCE方式。

<RouterB> system-view

[RouterB] interface serial 2/0

[RouterB-Serial2/0] link-protocol x25 dce

# 指定该接口的X.121地址。

[RouterB-Serial2/0] x25 x121-address 2

[RouterB-Serial2/0] quit

[RouterB] quit

# Router A发起X.25 PAD呼叫。

<RouterB> pad 1

  Calling 1 ...      OK

******************************************************************************

* Copyright (c) 2004-2010 Hangzhou H3C Tech. Co., Ltd. All rights reserved.  *

* Without the owner's prior written consent,                                 *

* no decompiling or reverse-engineering shall be allowed.                    *

******************************************************************************

Login authentication

Username:pad1

Password:    <——此处输入密码pad1

1.14.15  X2T SVC配置举例

1. 组网需求

设备Router将X.25网络和IP网络链接起来,其中X.25终端和设备通过SVC进行通信,在设备上使用X2T技术,从而使X.25终端可以和IP主机进行通信。

2. 组网图

图1-31 X2T SVC应用组网图

 

3. 配置步骤

# 启动X.25交换。

<Router> system-view

[Router] x25 switching

# 配置Router的X.25网络侧接口Serial2/0。

[Router] interface serial 2/0

[Router-Serial2/0] link-protocol x25 dce

[Router-Serial2/0] x25 x121-address 1111

[Router-Serial2/0] quit

# 配置Router的IP网络侧接口Ethernet1/1。

[Router] interface ethernet 1/1

[Router-Ethernet1/1] ip address 10.1.1.1 255.255.255.0

[Router-Ethernet1/1] quit

# 配置X.25路由。

[Router] x25 switch svc 2222 interface serial 2/0

# 配置X2T路由。

[Router] translate ip 10.1.1.1 port 102 x25 2222

[Router] translate x25 1111 ip 10.1.1.2 port 102

1.14.16  X2T PVC配置举例

1. 组网需求

设备将X.25网络和IP网络链接起来,其中X.25终端和设备通过PVC进行通信,在设备上使用X2T技术,从而使IP主机可以和X.25终端进行通信。

2. 组网图

图1-32 X2T PVC应用组网图

 

3. 配置步骤

# 启动X.25交换。

<Router> system-view

[Router] x25 switching

# 配置Router的X.25网络侧接口Serial2/0。

[Router] interface serial 2/0

[Router-Serial2/0] link-protocol x25 dce

[Router-Serial2/0] x25 vc-range in-channel 10 20 bi-channel 30 1024

[Router-Serial2/0] quit

# 配置RouterIP网络侧接口Ethernet1/1

[Router] interface ethernet 1/1

[Router-Ethernet1/1] ip address 10.1.1.1 255.255.255.0

[Router-Ethernet1/1] quit

# 配置X2T路由。

[Router] translate ip 10.1.1.1 port 102 pvc serial2/0 1

1.15  LAPB常见配置错误举例

1.15.1  相连双方的链路层协议为LAPB(或X.25),但协议一直为断开状态

1. 故障现象

相连双方的链路层协议为LAPB(或X.25),但协议一直为断开状态。

2. 故障分析

导致此现象出现的原因是,相连的双方工作在同一工作方式下(DTE或DCE)。

3. 故障排除

打开调试开关,如果发现一端发送SABM帧,而另一端发送FRMR帧,循环不断,则该现象是因为双方工作在同一工作方式下(DTE或DCE),改变其中一端的工作方式即可。

1.15.2  相连双方的链路层协议X.25已处于UP状态,但ping不通对方

1. 故障现象

相连双方的链路层协议X.25已处于UP状态,但ping不通对方。

2. 故障分析

一端的帧最大比特数可能配置过小。

3. 故障排除

打开调试开关,如果发现一端将接收的帧抛弃,未向上传送到分组层,则说明该端的帧最大比特数可能配置过小,修改配置即可。

1.16  X.25常见配置错误举例

假设X.25的第二层(LAPB)的连接完全正确。

1.16.1  LAPB已经处于“连接(Connect)”状态,但是X.25协议却迟迟不能UP

1. 故障现象

LAPB已经处于“连接(Connect)”状态,但是X.25协议却迟迟不能UP。

2. 故障分析

导致此现象出现的原因是,一个连接的两侧工作在同一工作方式下(DTE或DCE)。

3. 故障排除

修改一端接口的工作方式,保证一端工作在DTE模式,另一端工作在DCE模式。

1.16.2  X.25协议已经UP,但是却无法建立虚电路,即无法ping通

1. 故障现象

X.25协议已经UP,但是却无法建立虚电路,即无法ping通。

2. 故障分析

这种情况有可能是下列原因之一造成的:

l              未配置本地X.121地址

l              未配置到对端的地址映射

l              未配置对端X.121地址

l              未配置对端到本地的地址映射

l              信道范围不正确

l              携带了网络不允许的设施选项

3. 故障排除

可以按照如下步骤进行:

l              如果地址配置不正确,只要修改为正确的配置即可;

l              对于后两个原因,应该向网络管理部门咨询正确的信道范围和允许的设施选项。

1.16.3  可以建立虚电路,但是在数据传输的过程中却频繁地复位或清除

1. 故障现象

可以建立虚电路,但是在数据传输的过程中却频繁地复位或清除。

2. 故障分析

造成这种现象的原因很有可能是流量控制参数配置有误。

3. 故障排除

可以按照如下步骤进行:

l              如果是背靠背直接相连,请检查本地的发送窗口、接收窗口和对端的接收窗口、发送窗口是否匹配。

l              如果是接入到公共分组网内,请向网络管理部门咨询正确的流量控制参数。

1.16.4  配置永久虚电路的请求被拒绝

1. 故障现象

配置永久虚电路的请求被拒绝。

2. 故障分析

造成这种现象的原因很有可能是虚电路范围配置有误。如果永久虚电路信道区间是被禁止的,设备的X.25会拒绝配置永久虚电路的请求。这时,只要开启永久虚电路信道区间即可。

3. 故障排除

可以按照如下步骤进行:

l              通过命令x25 vc-range开启永久虚电路信道区间。

l              在配置x25 vc-range后执行shutdownundo shutdown命令使配置生效。

1.16.5  X.25 PAD常见配置错误举例

1. 故障现象

向远端发起X.25 PAD呼叫,却无法登录成功,系统提示目的地址不可达。

2. 故障排除

可以按照如下步骤进行:

l              首先确认想要建立X.25 PAD呼叫的两端通过X.25网络相连接并且此网络物理连接正常;连接使用的串口上都封装了X.25协议,并且一端工作在DTE模式,另一端工作在DCE模式,采用的报文封装类型相同(ietf或者nonstandard);并且都支持X.25 PAD协议。

l              如果上述条件都满足,接下来必须确认Server端接收X.25 PAD呼叫的串口已经指定了X.121地址,并且Client端正确呼叫了此地址。

如果上述条件也满足,则请检查在Client端是否配置了交换属性(即在系统视图下使用了x25 switching命令)却没有配置到达Server端的路由。如果是这样,Client端自然无法PAD到Server端。但是,并非一定要求Client端配置好路由才能PAD到Server上,因为如果Client不配置交换属性,则X.25 PAD将选取默认路由进行呼叫。所以请确认Client端没有配置交换属性或者在配置了交换属性的同时也配置了到达Server端的路由。

1.16.6  配置XOT的SVC应用后不能ping通

1. 故障现象

配置XOT的SVC应用后不能ping通。

2. 故障分析

造成这种现象的原因很多,可能是接口的物理和协议状态没有UP,也可能是SVC配置或XOT的配置有误。

3. 故障排除

可以按照如下步骤进行:

l              首先检查接口的物理和协议状态是否为UP。

l              如果接口状态为DOWN,查看物理连接和底层配置是否正确。

l              如果接口没有问题,接下来检查SVC的配置是否正确。

l              如果SVC配置也没问题,请再检查XOT的配置是否正确。

1.16.7  配置XOT的PVC应用后不能ping通

1. 故障现象

配置XOT的PVC应用后不能ping通。

2. 故障分析

造成这种现象的原因很多,可能是接口的物理和协议状态没有UP,也可能是PVC配置或XOT的配置有误。

3. 故障排除

可以按照如下步骤进行:

l              可以首先检查接口的物理和协议状态是否为UP。

l              如果接口状态为DOWN,查看物理连接和底层配置是否正确。

l              如果接口没有问题,接下来检查PVC的配置是否正确。

l              如果PVC配置也没问题,请再检查XOT的配置是否正确。

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!