国家 / 地区

03-二层技术-以太网交换命令参考

02-VLAN命令

本章节下载  (234.14 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Command/Command_Manual/H3C_MSR_CR-Release_2104(V1.10)/03/201011/698406_30005_0.htm

02-VLAN命令


1 VLAN配置命令

1.1  VLAN配置命令

1.1.1  description

【命令】

description text

undo description

【视图】

VLAN视图/VLAN接口视图

【缺省级别】

2:系统级

【参数】

text:描述VLAN或VLAN接口的描述字符串,可支持的描述字符包括英文可以包含标准字符(区分大小写的字母、数字)、英文特殊字符、空格、以及符合unicode编码规范的其他文字和符号。VLAN和VLAN接口的描述字符串的取值范围分别为:

l              VLAN的描述信息为1~32个字符的字符串。

l              VLAN接口的描述信息为1~80个字符的字符串。

l    一个英文字符占用一个字符长度,一个unicode编码的字符占用两个字符长度,用户可以在描述字符串中混合输入英文字符和unicode字符,但字符串总长度不能超过规定的长度范围。

l    如果用户在设置描述字符时需要使用unicode编码的某种文字或符号,则必须具有相应的输入法软件,并使用支持该字符的远程登录软件登录到设备上进行配置。

l    一个unicode编码的字符占用两个字符长度,所以当所配置的描述信息长度达到或超过终端软件最大列宽时,终端软件会进行自动换行,此时可能导致unicode字符被截断,终端软件会在换行处之后显示乱码。

 

【描述】

description命令用来设定当前VLAN或VLAN接口的描述信息。undo description命令用来恢复缺省情况。

缺省情况下,VLAN的描述信息为该VLAN的VLAN ID,如“VLAN 0001”,VLAN接口的描述信息为该VLAN接口的接口名,如“Vlan-interface1 Interface”。

当设备上配置的VLAN较多时,用户可以根据功能或者连接情况为VLAN或VLAN接口设置特定的描述信息,以便记忆和管理VLAN或VLAN接口。

【举例】

# 将VLAN 2的描述信息配置为sales-private。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] description sales-private

# 将VLAN接口2的描述信息配置为linktoPC56。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] description linktoPC56

1.1.2  display interface vlan-interface

【命令】

display interface vlan-interface [ vlan-interface-id ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-interface-id:VLAN接口的编号。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display interface vlan-interface命令用来显示VLAN接口的相关信息。

如果指定了vlan-interface-id,则显示指定VLAN接口的信息;如果不指定,将显示已创建的所有VLAN接口的信息。

相关配置可参考命令reset counters interface vlan-interface

【举例】

# 显示VLAN-interface 2的相关信息。

<Sysname> display interface vlan-interface 2

Vlan-interface2 current state: DOWN

Line protocol current state: DOWN

Description: Vlan-interface2 Interface

The Maximum Transmit Unit is 1500

Internet protocol processing : disabled

IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 000f-e249-8050

IPv6 Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 000f-e249-8050

Last clearing of counters:  Never

     Last 300 seconds input:  0 bytes/sec 0 packets/sec

     Last 300 seconds output:  0 bytes/sec 0 packets/sec

     0 packets input, 0 bytes, 0 drops

     0 packets output, 0 bytes, 0 drops

表1-1 display interface vlan-interface命令显示信息描述表

字段

描述

Vlan-interface2 current state

VLAN接口的物理状态,状态可能为:

l      DOWN ( Administratively ):表示该VLAN接口已经通过shutdown命令被关闭,即管理状态为关闭

l      DOWN:表示该VLAN接口的管理状态为开启,但物理状态为关闭,即该接口对应的VLAN内没有处于up状态的物理端口(可能因为没有物理连线或者线路故障)

l      UP:该端口的管理状态和物理状态均为开启

Line protocol current state

VLAN接口的链路层协议状态,状态可能为:

l      DOWN:该VLAN接口的协议状态为关闭,通常是因为没有配置IP地址

l      UP:该VLAN接口的协议状态为开启

Description

VLAN接口的字符串描述

The Maximum Transmit Unit

VLAN接口允许通过的最大传输单元(MTU)

Internet protocol processing : disabled

该接口还不具有处理IP报文的能力(当没有为该接口配置IP地址时会显示该信息)

Internet Address is 192.168.1.54/24 Primary

该接口的主IP地址为192.168.1.54/24(只有为该接口配置主IP地址后才会显示该信息)

Internet Address is 6.4.4.4/24 Sub

该接口的从IP地址为6.4.4.4/24(只有为该接口配置从IP地址后才会显示该信息)

IP Packet Frame Type

IPv4发送帧格式

Hardware address

VLAN接口对应的MAC地址

IPv6 Packet Frame Type

IPv6发送帧格式

Last clearing of counters

最近一次使用reset counts interface vlan-interface命令清除接口下的统计信息的时间(如果从设备启动一直没有执行reset counts interface vlan-interface命令清除过该接口下的统计信息,则显示Nerver)

Last 300 seconds input:  0 bytes/sec 0 packets/sec

Last 300 seconds output:  0 bytes/sec 0 packets/sec

当前接口最近300秒内输入(input)和输出(output)报文的平均速率(单位为bps和pps)

0 packets input, 0 bytes, 0 drops

接口输入的报文总数(分别以包和字节为单位进行了统计),输入报文中丢弃的报文数

0 packets output, 0 bytes, 0 drops

接口输出的报文总数(分别以包和字节为单位进行了统计),输出报文中丢弃的报文数

 

1.1.3  display vlan

【命令】

display vlan [ vlan-id1 [ to vlan-id2 ] | all | dynamic | reserved | static ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

vlan-id1:显示指定VLAN的信息。vlan-id1为指定VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:显示ID在指定范围内的VLAN的信息。vlan-id1vlan-id2为指定VLAN的编号,取值范围为1~4094。

all:显示除保留VLAN外的其它VLAN的信息。

dynamic:显示系统动态创建的VLAN的数量和编号。动态VLAN是指通过GVRP协议生成或通过Radius服务器下发的VLAN。

reserved:显示系统保留VLAN的信息。保留VLAN是设备根据功能实现的需要预留的VLAN。保留VLAN由协议模块来指定,为协议模块服务,用户不能对保留VLAN进行任何操作。

static:显示系统静态创建的VLAN的数量和VLAN编号。静态VLAN是指通过命令行手工创建的VLAN。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display vlan命令用来显示VLAN的相关信息。

相关配置可参考命令vlan

【举例】

# 显示VLAN2的信息。

<Sysname> display vlan 2

 VLAN ID: 2

 VLAN Type: static

 Route interface: not configured

 Description: VLAN 0002

 Name: VLAN 0002

Tagged   Ports: none

 Untagged Ports: 

    Ethernet1/1  Ethernet1/2  Ethernet1/3

# 显示VLAN3的信息。

<Sysname> display vlan 3

 VLAN ID: 3

 VLAN Type: static

 Route Interface: configured

 IP Address: 1.1.1.1

 Subnet Mask: 255.255.255.0

 Description: VLAN 0003

 Name: VLAN 0003

 Tagged   Ports: none

 Untagged Ports: none

表1-2 display vlan命令显示信息描述表

字段

解释

VLAN ID

VLAN的编号

VLAN Type

VLAN的类型:static表示静态VLAN;dynamic表示动态VLAN

Route interface

设备上是否创建了对应的VLAN接口:not configured(没有创建)/configured(创建了)

Description

VLAN的描述信息

Name

VLAN的名称

IP Address

VLAN接口的主用IP地址(如果VLAN接口没有配置IP地址,则不显示该字段),如果VLAN接口上还配置了从IP地址,可以使用display interface vlan-interface或者在VLAN接口视图下使用display this命令查看

Subnet Mask

VLAN接口的主用IP地址的子网掩码(如果VLAN接口没有配置IP地址,则不显示该字段)

Tagged Ports

标识该VLAN报文从哪些端口发送时需要携带Tag标记

Untagged Ports

标识该VLAN报文从哪些端口发送时不需要携带Tag标记

 

1.1.4  interface vlan-interface

【命令】

interface vlan-interface vlan-interface-id

undo interface vlan-interface vlan-interface-id

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-interface-id:VLAN接口的编号,取值范围为1~4094。

【描述】

interface vlan-interface命令用来进入指定的VLAN接口视图。如果该VLAN接口不存在,则先创建该接口,再进入该VLAN接口视图。undo interface vlan-interface命令用来删除指定的VLAN接口。

需要注意的是,在创建VLAN接口之前,对应的VLAN必须已经创建。否则,将不能创建指定的VLAN接口。

用户可以在VLAN接口视图下使用ip address命令配置IP地址,使得交换机具有三层路由功能。

相关配置可参考命令display interface vlan-interface

【举例】

# 创建VLAN接口2。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2]

1.1.5  ip address

【命令】

ip address ip-address { mask | mask-length } [ sub ]

undo ip address [ ip-address { mask | mask-length } [ sub ] ]

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

ip-address:VLAN接口的IP地址,为点分十进制格式。

mask:子网掩码,为点分十进制格式。

mask-length:子网掩码长度,即子网掩码中“1”的个数,取值范围为0~32。

sub:表示该地址为VLAN接口的从IP地址。

【描述】

ip address命令用来给VLAN接口指定IP地址和掩码。undo ip address命令用来删除VLAN接口的IP地址和掩码。

缺省情况下,没有配置VLAN接口的IP地址。

一般情况下,一个接口配置一个IP地址即可,但为了使设备的一个VLAN可以与多个子网相连,VLAN接口可以配置多个IP地址,其中一个为主IP地址,其余为从IP地址,可配置的IP地址总数为512个。主从地址的配置关系为:

l              当配置主IP地址时,如果接口上已经有主IP地址,则原主IP地址被新配置的地址取代。

l              undo ip address命令不带任何参数表示删除该接口的所有IP地址。

l              undo ip address ip-address { mask | mask-length }表示删除主IP地址。

l              undo ip address ip-address { mask | mask-length } sub表示删除从IP地址。

l              在删除主IP地址之前必须先删除从IP地址。

相关配置可参考“三层技术-IP业务命令参考/IP地址”中的命令display ip interface

【举例】

# 指定VLAN接口1的IP地址为1.1.0.1,子网掩码为255.255.255.0。

<Sysname> system-view

[Sysname] interface vlan-interface 1

[Sysname-Vlan-interface1] ip address 1.1.0.1 255.255.255.0

1.1.6  name

【命令】

name text

undo name

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

text:VLAN名称,为1~32个字符的描述信息(可以包含特殊字符及空格)。

【描述】

name命令用来指定当前VLAN的名称。当交换机上配置了802.1X或MAC地址认证功能后,可以通过Radius服务器来对认证通过的端口下发VLAN。某些服务器可以向交换机发送需要下发的VLAN编号或者VLAN名称,当VLAN数量很多的时候,使用名称可以更明确的定位VLAN。undo name命令用来恢复当前VLAN名称的缺省值。

缺省情况下,VLAN的名称为该VLAN的VLAN ID,如“VLAN 0001”。

【举例】

# 指定VLAN 2的名称为“test vlan”。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] name test vlan

1.1.7  mac-address

【命令】

mac-address mac-address

undo mac-address

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

mac-address:MAC地址,形式为H-H-H。

【描述】

mac-address命令用来配置VLAN接口的MAC地址。undo mac-address命令用来恢复缺省情况。

缺省情况下,VLAN接口的MAC地址与设备型号有关,请以设备的实际情况为准。

VLAN接口是一种需要手工创建和删除的逻辑接口,在创建时它会借用设备上某个物理端口的MAC地址作为自己的MAC地址,这样,所有的VLAN接口都共用一个MAC地址。

【举例】

# 配置VLAN接口11的MAC地址为0001-0001-0001。

<Sysname> system-view

[Sysname] interface vlan-interface 11

[Sysname-Vlan-interface11] mac-address 1-1-1

1.1.8  reset counters interface vlan-interface

【命令】

reset counters interface vlan-interface [ vlan-interface-id ]

【视图】

用户视图

【缺省级别】

2:系统级

【参数】

vlan-interface-id:VLAN接口的编号。

【描述】

reset counters interface vlan-interface命令用来清除VLAN接口的统计信息。

在某些情况下,需要统计一定时间内某接口的流量,这就需要在统计开始前清除该接口原有的统计信息,重新进行统计。

l              如果不指定vlan-interface-id,则清除所有VLAN接口的统计信息;

l              如果指定vlan-interface-id,则清除指定VLAN接口的统计信息。

相关配置可参考命令display interface vlan-interface

【举例】

# 清除VLAN接口2的统计信息。

<Sysname> reset counters interface vlan-interface 2

1.1.9  shutdown

【命令】

shutdown

undo shutdown

【视图】

VLAN接口视图

【缺省级别】

2:系统级

【参数】

【描述】

shutdown命令用来关闭VLAN接口。undo shutdown命令用来打开VLAN接口。

缺省情况下,当VLAN接口下所有以太网端口状态为down时,VLAN接口为down状态,即关闭状态;当VLAN接口下有一个或一个以上的以太网端口处于up状态,则VLAN接口处于up状态。

当VLAN接口的相关参数及协议配置好之后,可以使用undo shutdown命令启动接口;或者当VLAN接口出现故障时,可以用shutdown命令将接口先关闭,然后再用undo shutdown命令打开接口,这样有可能使接口恢复正常。

关闭和打开VLAN接口对于属于这个VLAN的任何一个以太网端口本身都不起作用,以太网端口的状态不随VLAN接口状态的改变而改变。

【举例】

# 关闭VLAN接口后再启动VLAN接口。

<Sysname> system-view

[Sysname] interface vlan-interface 2

[Sysname-Vlan-interface2] shutdown

[Sysname-Vlan-interface2] undo shutdown

1.1.10  vlan

【命令】

vlan { vlan-id1 [ to vlan-id2 ] | all }

undo vlan { vlan-id1 [ to vlan-id2 ] | all }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

vlan-id1:VLAN的编号,取值范围为1~4094。

vlan-id1 to vlan-id2:指定VLAN的编号范围。vlan-id1vlan-id2为VLAN的编号,取值范围为1~4094。

all:除保留VLAN外的其它VLAN,当设备允许创建的最大VLAN数小于4094时,不支持该参数。

【描述】

l              vlan vlan-id命令用来创建VLAN并进入VLAN视图。如果指定的VLAN已创建,则该命令直接用来进入该VLAN的视图。

l              vlan vlan-id1 to vlan-id2命令用来批量创建vlan-id1vlan-id2之间的所有VLAN,保留VLAN除外。

l              undo vlan命令用来删除VLAN。

需要注意的是:

l              VLAN1为系统缺省VLAN,用户不能创建和删除。

l              保留VLAN是系统为实现特定功能预留的VLAN,用户也不能手工创建和删除。

l              协议保留的VLAN、Voice VLAN、管理VLAN、动态学习到的VLAN,不能使用undo vlan命令直接删除。只有将相关配置删除之后,才能删除VLAN。

相关配置可参考命令display vlan

【举例】

# 进入VLAN2的视图。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2]

# 批量创建VLAN4~VLAN100。

<Sysname> system-view

[Sysname] vlan 4 to 100

Please wait............. Done.

1.2  基于端口的VLAN配置命令

1.2.1  display port

【命令】

display port { hybrid | trunk } [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

hybrid:显示系统当前存在的Hybrid端口。

trunk:显示系统当前存在的Trunk端口。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display port命令用来显示设备上当前存在的Hybrid或Trunk端口。显示的信息包括端口对应的端口名、缺省VLAN ID和允许通过的VLAN ID号。

【举例】

# 显示当前系统存在的Hybrid端口。

<Sysname> display port hybrid

Interface            PVID  VLAN passing

Eth1/4               100   Tagged:  1000, 1002, 1500, 1600-1611, 2000,

                                    2555-2558, 3000, 4000

                           Untagged:1, 10, 15, 18, 20-30, 44, 55, 67, 100,

                                    150-160, 200, 255, 286, 300-302

# 显示当前系统存在的Trunk端口。

<Sysname> display port trunk

Interface            PVID  VLAN passing

Eth1/8               2     1-4, 6-100, 145, 177, 189-200, 244, 289, 400,

                           555, 600-611, 1000, 2006-2008

表1-3 display port命令显示信息描述表

字段

描述

Interface

接口名称

PVID

该端口的缺省VLAN ID

VLAN passing

表示哪些VLAN的报文允许通过该端口

Tagged

表示哪些VLAN的报文通过该端口时必须携带VLAN Tag

Untagged

表示哪些VLAN的报文通过该端口时必须去掉VLAN Tag

 

1.2.2  port

【命令】

port interface-list

undo port interface-list

【视图】

VLAN视图

【缺省级别】

2:系统级

【参数】

interface-list:以太网接口列表,表示方式为interface-list = { interface-type interface-number [ to interface-type interface-number ] }&<1-10>。其中interface-type interface-number为端口类型和端口号。&<1-10>表示前面的参数最多可以输入10次。

【描述】

port命令用来向当前VLAN中添加一个或一组Access端口。undo port命令用来从当前VLAN中删除一个或一组Access端口。

缺省情况下,系统将所有端口都加入到VLAN1。

需要注意的是:

l              该命令只对Access端口有效。

l              设备上的所有端口的缺省链路类型都是Access类型,但用户可以自行切换端口类型,具体配置可参考命令port link-type

l              不支持二层聚合接口添加到当前VLAN。

相关配置可参考命令display vlan

【举例】

# 向VLAN2中加入从Ethernet1/1到Ethernet1/3的以太网端口。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] port ethernet 1/1 to ethernet 1/3

1.2.3  port access vlan

【命令】

port access vlan vlan-id

undo port access vlan

【视图】

以太网接口视图/以太网子接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定的VLAN编号,取值范围为1~4094。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

【描述】

port access vlan命令用来将当前Access端口加入到指定的VLAN中。undo port access vlan命令用来恢复缺省情况。

缺省情况下,所有Access端口均属于且只属于VLAN1。

l              在以太网接口视图下执行该命令,则该配置只对当前端口生效;

l              在端口组视图下执行该命令,则该配置将对端口组中的所有端口生效(端口组的相关内容请参见“接口管理配置指导”中的“以太网接口”);

l              在二层聚合接口视图下执行该命令,则该配置将对二层聚合接口以及相应的所有成员端口生效。在配置过程中,如果某个成员端口配置失败,系统会自动跳过该成员端口继续配置其它成员端口;如果二层聚合接口配置失败,则不会再配置成员端口(二层聚合接口的相关内容请参见“二层技术-以太网交换配置指导”中的“链路聚合”);

【举例】

# 将Ethernet1/1端口加入到VLAN3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] port access vlan 3

# 将二层聚合接口1以及其对应的成员端口加入到VLAN3中。

<Sysname> system-view

[Sysname] vlan 3

[Sysname-vlan3] quit

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port access vlan 3

1.2.4  port hybrid pvid

【命令】

port hybrid pvid vlan vlan-id

undo port hybrid pvid

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省的VLAN ID,取值范围为1~4094。

【描述】

port hybrid pvid命令用来设置Hybrid端口的缺省VLAN ID。undo port hybrid pvid命令用来恢复缺省情况。

缺省情况下,Hybrid端口的缺省VLAN为VLAN1。

对Hybrid端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即可以使用已经不存在的VLAN作为缺省VLAN。

l              在以太网接口视图下执行该命令,则该配置只对当前端口生效;

l              在端口组视图下执行该命令,则该配置将对端口组中的所有端口生效(端口组的相关内容请参见“二层技术-以太网交换配置指导”中的“以太网接口”);

l              在二层聚合接口视图下执行该命令,则该配置将对二层聚合接口以及相应的所有成员端口生效。在配置过程中,如果某个成员端口配置失败,系统会自动跳过该成员端口继续配置其它成员端口;如果二层聚合接口配置失败,则不会再配置成员端口(二层聚合接口的相关内容请参见“二层技术-以太网交换配置指导”中的“链路聚合”);

需要注意的是:

l              建议本机Hybrid端口的缺省VLAN和相连的对端交换机的Hybrid端口的缺省VLAN保持一致。

l              配置缺省VLAN后,必须使用port hybrid vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

相关配置可参考命令port link-typeport hybrid vlan

【举例】

# 将端口Ethernet1/1(Hybrid类型)的缺省VLAN设为100。

<Sysname> system-view

[Sysname] vlan 100

[Sysname-vlan100] quit

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] port link-type hybrid tagged 100

[Sysname-Ethernet1/1] port hybrid pvid vlan 100

# 将二层聚合接口1(Hybrid类型)以及其对应的成员端口的缺省VLAN设为100。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port hybrid pvid vlan 100

1.2.5  port hybrid vlan

【命令】

port hybrid vlan vlan-id-list { tagged | untagged }

undo port hybrid vlan vlan-id-list

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id-list:VLAN列表,Hybrid端口要加入的VLAN的范围。表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }&<1-10>,vlan-id取值范围为1~4094,&<1-10>表示前面的参数最多可以重复输入10次。该VLAN必须是设备上已创建的VLAN,否则,该命令执行失败。

tagged:该端口在转发指定的VLAN报文时将保留VLAN Tag。

untagged:该端口在转发指定的VLAN报文时将去掉VLAN Tag。

【描述】

port hybrid vlan命令用来允许指定的VLAN通过当前Hybrid端口。undo port hybrid vlan命令用来取消指定的VLAN通过当前Hybrid端口。

缺省情况下,Hybrid端口只允许VLAN1的报文以untagged方式通过,即VLAN1的报文从该端口发送出去后不携带VLAN Tag。

Hybrid端口允许多个VLAN通过。如果多次使用port hybrid vlan命令,那么Hybrid端口上允许通过的VLAN是这些vlan-id-list的合集。

l              在以太网接口视图下执行该命令,则该配置只对当前端口生效;

l              在端口组视图下执行该命令,则该配置将对端口组中的所有端口生效(端口组的相关内容请参见“接口管理配置指导”中的“以太网接口”);

l              在二层聚合接口视图下执行该命令,则该配置将对二层聚合接口以及相应的所有成员端口生效。在配置过程中,如果某个成员端口配置失败,系统会自动跳过该成员端口继续配置其它成员端口;如果二层聚合接口配置失败,则不会再配置成员端口(二层聚合接口的相关内容请参见“二层技术-以太网交换配置指导”中的“链路聚合”);

相关配置可参考命令port link-type

【举例】

# 配置端口Ethernet1/1(Hybrid类型)允许VLAN2、VLAN4、VLAN50~VLAN100通过(假设指定的VLAN都已经创建),并且发送这些VLAN的报文时保留VLAN标签。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] port link-type hybrid

[Sysname-Ethernet1/1] port hybrid vlan 2 4 50 to 100 tagged

# 配置端口组2内的Hybrid端口允许VLAN2通过,并且发送这些VLAN的报文时不带VLAN标签。

<Sysname> system-view

[Sysname] vlan 2

[Sysname-vlan2] quit

[Sysname] port-group manual 2

[Sysname-port-group-manual-2] group-member ethernet 1/1 to ethernet 1/6

[Sysname-port-group-manual-2] port link-type hybrid

[Sysname-port-group-manual-2] port hybrid vlan 2 untagged

 Configuring Ethernet1/1... Done.

 Configuring Ethernet1/2... Done.

 Configuring Ethernet1/3... Done.

 Configuring Ethernet1/4... Done.

 Configuring Ethernet1/5... Done.

 Configuring Ethernet1/6... Done.

# 将二层聚合接口1(Hybrid类型)以及其对应的成员端口允许VLAN 2通过,并且发送这些VLAN的报文时不带标签。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

[Sysname-Bridge-Aggregation1] port hybrid vlan 2 untagged

 Please wait... Done.

 Configuring Ethernet1/2... Done.

 Configuring Ethernet1/3... Done.

Ethernet1/2和Ethernet1/3是二层聚合接口1对应的成员端口。

1.2.6  port link-type

【命令】

port link-type { access | hybrid | trunk }

undo port link-type

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

access:设置端口的链路类型为Access类型。

hybrid:设置端口的链路类型为Hybrid类型。

trunk:设置端口的链路类型为Trunk类型。

【描述】

port link-type命令用来设置端口的链路类型。undo port link-type命令用来恢复缺省情况。

缺省情况下,所有端口的链路类型均为Access类型。

l              在以太网接口视图下执行该命令,则该配置只对当前端口生效;

l              在端口组视图下执行该命令,则该配置将对端口组中的所有端口生效(端口组的相关内容请参见“接口管理配置指导”中的“以太网接口”);

l              在二层聚合接口视图下执行该命令,则该配置将对二层聚合接口以及相应的所有成员端口生效。在配置过程中,如果某个成员端口配置失败,系统会自动跳过该成员端口继续配置其它成员端口;如果二层聚合接口配置失败,则不会再配置成员端口(二层聚合接口的相关内容请参见“二层技术-以太网交换配置指导”中的“链路聚合”);

需要注意的是,当使用port link-type { access | hybrid | trunk }命令修改接口的链路类型后,该接口下的loopback-detection action配置会自动恢复到缺省情况。(loopback-detection action的详细介绍请参见“接口管理命令参考”中的“以太网接口”)

Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为其它类型端口。

 

【举例】

# 将以太网端口Ethernet1/1设置为Trunk类型端口。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] port link-type trunk

# 将手工端口组group1内的所有端口都设置为Hybrid端口。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group manual group1] group-member ethernet 1/1

[Sysname-port-group manual group1] group-member ethernet 1/2

[Sysname-port-group manual group1] port link-type hybrid

# 将二层聚合接口1以及其对应的成员端口的链路类型设置为Hybrid。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port link-type hybrid

1.2.7  port trunk permit vlan

【命令】

port trunk permit vlan { vlan-id-list | all }

undo port trunk permit vlan { vlan-id-list | all }

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id-list:VLAN列表,为Trunk端口加入的VLAN的范围,表示方式为vlan-id-list = { vlan-id1 [ to vlan-id2 ] }& <1-10>,vlan-id取值范围为1~4094,&<1-10>表示前面的参数最多可以重复输入10次。

all:表示允许所有VLAN通过该Trunk端口,该参数通常只用于GVRP的配置。在没有配置GVRP的情况下,建议用户不要使用port trunk permit all命令,以防止未授权VLAN的用户通过该端口访问受限资源。

【描述】

port trunk permit vlan命令用来允许指定的VLAN通过当前Trunk端口。undo port trunk permit vlan命令用来取消指定的VLAN通过当前Trunk端口。

缺省情况下,Trunk端口只允许VLAN1的报文通过。

Trunk端口可以允许多个VLAN通过。如果多次使用port trunk permit vlan命令,那么Trunk端口上允许通过的VLAN是这些vlan-id-list的集合。

Trunk端口发送出去的报文,只有缺省VLAN的报文不带VLAN Tag,其他VLAN的报文均会保留VLAN Tag。

l              在以太网接口视图下执行该命令,则该配置只对当前端口生效;

l              在端口组视图下执行该命令,则该配置将对端口组中的所有端口生效(端口组的相关内容请参见“接口管理配置指导”中的“以太网接口”);

l              在二层聚合接口视图下执行该命令,则该配置将对二层聚合接口以及相应的所有成员端口生效。在配置过程中,如果某个成员端口配置失败,系统会自动跳过该成员端口继续配置其它成员端口;如果二层聚合接口配置失败,则不会再配置成员端口(二层聚合接口的相关内容请参见“二层技术-以太网交换配置指导”中的“链路聚合”);

相关配置可参考命令port link-type

【举例】

# 配置端口Ethernet1/1(Trunk类型)允许VLAN 2、4、50~100通过。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] port link-type trunk

[Sysname-Ethernet1/1] port trunk permit vlan 2 4 50 to 100

Please wait........... Done.

# 将二层聚合接口1(Trunk类型)允许VLAN 2通过(聚合接口1对应的聚合组1内没有成员端口)。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port trunk permit vlan 2

Please wait... Done.

# 将二层聚合接口1(Trunk类型)允许VLAN 13和15通过(聚合接口1对应的聚合组1内有成员端口Ethernet1/2和Ethernet1/3,Ethernet1/2的链路类型为Access,Ethernet1/3的链路类型为Trunk)。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port trunk permit vlan 13 15

 Please wait... Done.

 Error: Failed to configure on interface Ethernet1/2! This port is not a Trunk port!

 Configuring Ethernet1/3... Done.

以上显示信息中:“Please wait... Done”表明二层聚合接口1配置成功;“Error: Failed to configure on interface Ethernet1/2! This port is not a Trunk port!”表明成员端口Ethernet1/2配置失败,因为链路类型不是Trunk;“Configuring Ethernet1/3... Done” 表明成员端口Ethernet1/3配置成功。

1.2.8  port trunk pvid

【命令】

port trunk pvid vlan vlan-id

undo port trunk pvid

【视图】

以太网接口视图/端口组视图/二层聚合接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定接口的缺省VLAN ID,取值范围为1~4094。

【描述】

port trunk pvid命令用来设置Trunk端口的缺省VLAN ID。undo port trunk pvid命令用来恢复缺省情况。

缺省情况下,Trunk端口的缺省VLAN为VLAN1。

对Trunk端口,执行undo vlan命令删除端口的缺省VLAN后,端口的缺省VLAN配置不会改变,即使用已经不存在的VLAN作为缺省VLAN。

l              在以太网接口视图下执行该命令,则该配置只对当前端口生效;

l              在端口组视图下执行该命令,则该配置将对端口组中的所有端口生效(端口组的相关内容请参见“接口管理配置指导”中的“以太网接口”);

l              在二层聚合接口视图下执行该命令,则该配置将对二层聚合接口以及相应的所有成员端口生效。在配置过程中,如果某个成员端口配置失败,系统会自动跳过该成员端口继续配置其它成员端口;如果二层聚合接口配置失败,则不会再配置成员端口(二层聚合接口的相关内容请参见“二层技术-以太网交换配置指导”中的“链路聚合”);

需要注意的是:

l              本端设备Trunk端口的缺省VLAN ID和相连的对端设备的Trunk端口的缺省VLAN ID必须一致,否则报文将不能正确传输。

l              配置缺省VLAN后,必须使用port trunk permit vlan命令配置允许缺省VLAN的报文通过,出接口才能转发缺省VLAN的报文。

相关配置可参考命令port link-typeport trunk permit vlan

【举例】

# 将接口Ethernet1/1(Trunk类型)的缺省VLAN设置为100。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] port link-type trunk

[Sysname-Ethernet1/1] port trunk pvid vlan 100

# 将二层聚合接口1(Trunk类型)的缺省VLAN设置为100(聚合接口1对应的聚合组1内没有成员端口)。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port trunk pvid vlan 100

# 将二层聚合接口1(Trunk类型)的缺省VLAN设置为100(聚合接口1对应的聚合组1内有成员端口Ethernet1/2和Ethernet1/3,Ethernet1/2的链路类型为Access,Ethernet1/3的链路类型为Trunk)。

<Sysname> system-view

[Sysname] interface bridge-aggregation 1

[Sysname-Bridge-Aggregation1] port trunk pvid vlan 100

 Error: Failed to configure on interface Ethernet1/2! This port is not a Trunk port!

以上显示信息表明二层聚合接口1和成员端口Ethernet1/3配置成功;成员端口Ethernet1/2配置失败,因为链路类型不是Trunk。

2 Voice VLAN配置命令

2.1  Voice VLAN配置命令

2.1.1  display voice vlan oui

【命令】

display voice vlan oui [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display voice vlan oui命令用来显示Voice VLAN当前支持的OUI地址、OUI地址掩码和描述信息。

相关配置可参考命令voice vlan mac-address

通常意义下,OUI地址指的是MAC地址的前24位(二进制),是IEEE为不同设备供应商分配的一个全球唯一的标识符。本文中的OUI有别于通常意义的OUI地址,它是设备判断收到的报文是否为语音报文的依据,是voice vlan mac-address命令中的mac-addressoui-mask参数相与的结果。

 

【举例】

# 显示Voice VLAN的OUI地址、OUI地址掩码和描述信息。

<Sysname> display voice vlan oui

Oui Address     Mask            Description

0001-e300-0000  ffff-ff00-0000  Siemens phone

0003-6b00-0000  ffff-ff00-0000  Cisco phone

0004-0d00-0000  ffff-ff00-0000  Avaya phone

00d0-1e00-0000  ffff-ff00-0000  Pingtel phone

0060-b900-0000  ffff-ff00-0000  Philips/NEC phone

00e0-7500-0000  ffff-ff00-0000  Polycom phone

00e0-bb00-0000  ffff-ff00-0000  3com phone

表2-1 display voice vlan oui命令显示信息描述表

字段

描述

Oui Address

设备当前允许通过的OUI地址

Mask

设备当前允许通过的OUI地址的掩码

Description

设备当前允许通过的OUI地址的描述

 

2.1.2  display voice vlan state

【命令】

display voice vlan state [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1~256个字符的字符串,区分大小写。

【描述】

display voice vlan state命令用来显示Voice VLAN的配置信息。

相关配置可参考命令voice vlan enable、voice vlan qosvoice vlan qos trust

【举例】

# 显示Voice VLAN的配置信息。

<Sysname> display voice vlan state

 Maximum of Voice VLANs: 16

 Current Voice VLANs: 2

 Voice VLAN security mode: Security

 Voice VLAN aging time: 1440 minutes

 Voice VLAN enabled port and its mode:

 PORT                        VLAN        MODE

 -----------------------------------------------

 Ethernet1/1                 2           AUTO

 Ethernet1/2                 3           AUTO

表2-2 display voice vlan state命令显示信息描述表

字段

描述

Voice VLAN system capacity

系统支持Voice VLAN的最大数量

Current Voice VLAN Count

已创建Voice VLAN的数量

Voice VLAN security mode

Voice VLAN的安全模式的开启状态:Security表示当前使用的是安全模式;Normal表示当前使用的是普通模式

Voice VLAN aging time

Voice VLAN的老化时间

Current voice vlan enabled port and its mode

当前使能了Voice VLAN的端口及其工作模式

PORT

当前使能了Voice VLAN的端口编号

VLAN

端口使能的Voice VLAN ID

MODE

端口Voice VLAN的工作模式:MANUAL表示手工模式;AUTO表示自动模式

 

2.1.3  voice vlan aging

【命令】

voice vlan aging minutes

undo voice vlan aging

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

minutes:Voice VLAN的老化时间,取值范围为5~43200,单位为分钟。

【描述】

voice vlan aging命令用来设置Voice VLAN的老化时间。undo voice vlan aging命令用来恢复缺省情况。

缺省情况下,Voice VLAN的老化时间为1440分钟。

在自动模式下,系统会根据收到的语音报文的源MAC地址,来决定是否把该报文的入端口加入Voice VLAN。在将入端口加入Voice VLAN后,系统会同时启动老化定时器。经过老化时间后,如果设备没有从该端口收到任何语音报文,老化时间到达后系统会自动把该端口从Voice VLAN中删除。该老化时间只对Voice VLAN工作在自动模式的端口有效,对Voice VLAN工作在手工模式的端口无效。

相关配置可参考命令display voice vlan state

【举例】

# 将Voice VLAN的老化时间配置为100分钟。

<Sysname> system-view

[Sysname] voice vlan aging 100

2.1.4  voice vlan enable

【命令】

voice vlan vlan-id enable

undo voice vlan enable

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

vlan-id:指定Voice VLAN编号,取值范围为2~4094。

【描述】

voice vlan vlan-id enable命令用来使能以太网接口的Voice VLAN功能。undo voice vlan enable命令用来关闭以太网接口的Voice VLAN功能。

缺省情况下,接口没有使能Voice VLAN功能。

需要注意的是,当端口的Voice VLAN工作在自动模式时,只有Trunk或者Hybrid类型接口支持使能Voice VLAN功能。

【举例】

# 使能端口Ethernet1/1的Voice VLAN功能。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] voice vlan 2 enable

2.1.5  voice vlan mac-address

【命令】

voice vlan mac-address mac-address mask oui-mask [ description text ]

undo voice vlan mac-address oui

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

mac-address:语音报文的源MAC地址,格式为H-H-H,如:1234-1234-1234。

mask oui-mask:OUI地址的有效长度,用掩码表示,格式为H-H-H。由连续的1和连续的0组成,表示OUI地址的匹配长度。如:FFFF-0000-0000,如果要过滤某个设备厂商的语音设备,可以设置为FFFF-FF00-0000。

description text:OUI地址的描述字符串,长度为1~30,区分大小写。

oui:指定要删除的OUI地址,格式为H-H-H,如1234-1200-0000。OUI地址不能是广播地址或者组播地址,也不能是全0或全1的地址。OUI地址是mac-addressoui-mask参数相与的结果。可以通过display voice vlan oui命令查看当前系统支持的OUI地址的信息。

【描述】

voice vlan mac-address命令用来设置允许指定OUI地址的报文通过Voice VLAN。undo voice vlan mac-address命令用来取消指定OUI地址的报文通过Voice VLAN。

系统最多支持配置16个OUI地址。

缺省情况下,系统已配置有OUI地址,如表2-3所示。该地址可以手工删除,删除之后也可再次手工添加。

表2-3 缺省的OUI地址

序号

OUI

描述

1

0001-e300-0000

Siemens phone

2

0003-6b00-0000

Cisco phone

3

0004-0d00-0000

Avaya phone

4

00d0-1e00-0000

Pingtel phone

5

0060-b900-0000

Philips/NEC phone

6

00e0-7500-0000

Polycom phone

7

00e0-bb00-0000

3com phone

 

相关配置可参考命令display voice vlan oui

【举例】

# 设置允许来自IP电话PhoneA(MAC地址为1234-1234-1234)的语音流通过Voice VLAN。

<Sysname> system-view

[Sysname] voice vlan mac-address 1234-1234-1234 mask ffff-ff00-0000 description PhoneA

2.1.6  voice vlan mode auto

【命令】

voice vlan mode auto

undo voice vlan mode auto

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

voice vlan mode auto命令用来配置端口的Voice VLAN的工作模式为自动模式。undo voice vlan mode auto命令用来配置端口的Voice VLAN的工作模式为手工模式。

缺省情况下,端口的Voice VLAN的工作模式为自动模式。

各个端口Voice VLAN的工作模式相互独立,不同的端口可以设置成不同的模式。

需要注意的是,当端口使能了Voice VLAN并工作在手工模式时,必须手工将端口加入Voice VLAN,才能保证Voice VLAN功能生效。

【举例】

# 将端口Ethernet1/1的Voice VLAN的工作模式设置为手工模式。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] undo voice vlan mode auto

2.1.7  voice vlan security enable

【命令】

voice vlan security enable

undo voice vlan security enable

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

【描述】

voice vlan security enable命令用来使能Voice VLAN的安全模式。undo voice vlan security enable命令用来关闭Voice VLAN的安全模式。

在安全模式下,Voice VLAN中只能有语音流量。用户设置Voice VLAN为安全模式以后,该VLAN的报文都经过过滤,设备会根据报文的源MAC地址是否匹配OUI地址来过滤所有非语音流量,增加安全性保证语音流的优先级,保证通话质量。在普通模式下,Voice VLAN中允许有业务流量和语音流量并存。

缺省情况下,Voice VLAN工作在安全模式。

【举例】

# 关闭Voice VLAN的安全模式。

<Sysname> system-view

[Sysname] undo voice vlan security enable

 

不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!