选择区域语言: EN CN HK

02-接口管理命令参考

01-以太网接口命令

本章节下载  (352.69 KB)

docurl=/cn/Service/Document_Software/Document_Center/Routers/Catalog/MSR/MSR_50/Command/Command_Manual/H3C_MSR_CR-R2207(V1.11)/02/201107/719982_30005_0.htm

01-以太网接口命令


1 以太网接口配置命令

1.1  以太网接口和子接口通用配置命令

1.1.1  bandwidth

【命令】

bandwidth bandwidth-value

undo bandwidth

【视图】

以太网接口视图/以太网子接口视图

【缺省级别】

2:系统级

【参数】

bandwidth-value:表示接口的期望带宽,取值范围为14294967295,单位为kbps

【描述】

bandwidth命令用来设置接口的期望带宽。undo bandwidth命令用来恢复缺省值。

接口的期望带宽可以通过第三方软件查询MIB节点ifspeed的值来获取。

期望带宽供网管监控接口带宽使用,不会对接口实际带宽造成影响。

【举例】

# 设置接口的期望带宽为10000kbps

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] bandwidth 10000

1.1.2  combo enable

【命令】

combo enable { copper | fiber }

【视图】

以太网接口视图(该接口必须是Combo接口)

【缺省级别】

2:系统级

【参数】

copper:表示该Combo接口的电口被激活,使用双绞线连接。

fiber:表示该Combo接口的光口被激活,使用光纤连接。

【描述】

combo enable命令用来激活Combo接口。

缺省情况下,电口被激活。

Combo接口是一个逻辑接口,一个Combo接口对应设备面板上一个电口和一个光口。电口与其对应的光口是光电复用关系,两者不能同时工作(当激活其中的一个接口时,另一个接口就自动处于禁用状态),用户可根据组网需求选择使用电口或光口。

MSR 50路由器、SIC-1GEC模块和XMIM-16FSW/XMIM-24FSW模块的千兆以太网Combo口,当Combo接口的光口被激活时,插拔光模块后偶尔会出现接口Link指示灯被错误点亮的情况。通过将接口shutdown,然后再undo shutdown的操作可以修正此错误。

 

【举例】

# 指定GigabitEthernet1/1端口的电口被激活,使用双绞线连接。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/1

[Sysname-GigabitEthernet1/1] combo enable copper

# 指定GigabitEthernet1/1端口的光口被激活,使用光纤连接。

<Sysname> system-view

[Sysname] interface gigabitethernet 1/1

[Sysname-GigabitEthernet1/1] combo enable fiber

1.1.3  default

【命令】

default

【视图】

以太网接口视图/以太网子接口视图

【缺省级别】

2:系统级

【参数】

【描述】

default命令用来恢复当前接口的缺省配置。

【举例】

# 将以太网接口Ethernet1/1恢复为缺省配置。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] default

This command will restore the default settings. Continue? [Y/N]:y

# 将以太网子接口Ethernet1/1.1恢复为缺省配置。

<Sysname> system-view

[Sysname] interface ethernet 1/1.1

[Sysname-Ethernet1/1.1] default

This command will restore the default settings. Continue? [Y/N]:y

1.1.4  description

【命令】

description text

undo description

【视图】

以太网接口视图/以太网子接口视图

【缺省级别】

2:系统级

【参数】

text:表示接口的描述内容,为180个字符的字符串,可以包含字母(区分大小写)、数字、特殊字符(包括~ ! @ # $ % ^ & * ( ) - _ + = { } [ ] | \ : ; " ' < > , . /)、空格以及符合unicode编码规范的其它文字和符号。

l          一个英文字符占用一个字符长度,一个unicode编码的字符占用两个字符长度,用户可以在描述字符串中混合输入英文字符和unicode字符,但字符串总长度不能超过规定的长度范围。

l          如果用户在设置描述字符时需要使用unicode编码的某种文字或符号,则必须具有相应的输入法软件,并使用支持该字符的远程登录软件登录到设备上进行配置。

l          一个unicode编码的字符占用两个字符长度,所以当所配置的描述信息长度达到或超过终端软件最大列宽时,终端软件会进行自动换行,此时可能导致unicode字符被截断,终端软件会在换行处之后显示乱码。

 

【描述】

description命令用来设置当前接口的描述信息。undo description命令用来恢复缺省情况。

缺省情况下,接口的描述信息为“接口名 Interface”,比如:Ethernet1/1 Interface

相关配置可参考命令display interface

【举例】

# 设置以太网接口Ethernet1/1的描述信息为“lanswitch-interface”。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] description lanswitch-interface

# 设置以太网子接口Ethernet1/1.1的描述信息为“l2-subinterface1/1.1”。

<Sysname> system-view

[Sysname] interface ethernet 1/1.1

[Sysname-Ethernet1/1.1] description l2-subinterface1/1.1

1.1.5  display interface

【命令】

display interface [ interface-type ] [ brief [ down ] ] [ | { begin | exclude | include } regular-expression ]

display interface interface-type { interface-number | interface-number.subnumber } [ brief ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

interface-type:指定接口的接口类型。

interface-number:指定接口的接口编号。

interface-number.subnumber:指定逻辑子接口编号。其中interface-number为主接口编号;subnumber为子接口编号,取值范围为14094

brief:显示接口的概要信息。不指定该参数时,将显示接口的详细信息。

down:显示当前状态为down的接口的信息以及down的原因。不指定该参数时,将不会根据接口状态来过滤显示信息。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1256个字符的字符串,区分大小写。

【描述】

display interface命令用来显示以太网接口的相关信息。

l              如果不指定interface-type,则显示所有接口的信息;

l              如果指定interface-type不指定interface-numberinterface-number.subnumber,则显示所有该类型接口的信息。

相关配置可参考命令interface

【举例】

# 查看三层以太网接口Ethernet1/1的运行状态和相关信息。

<Sysname> display interface ethernet 1/1

Ethernet1/1 current state: UP

Line protocol current state: UP

Description: Ethernet1/1 Interface

The Maximum Transmit Unit is 1500

Internet protocol processing : disabled

IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 0000-000f-0005

IPv6 Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 0000-000f-0005

Media type is twisted pair, loopback not set, promiscuous mode not set

100Mb/s, Full-duplex, link type is autonegotiation

Output flow-control is disabled, input flow-control is disabled

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

Last clearing of counters: Never

    Last 300 seconds input rate 0.00 bytes/sec, 0 bits/sec, 0.00 packets/sec

    Last 300 seconds output rate 0.00 bytes/sec, 0 bits/sec, 0.00 packets/sec

    Input: 1 packets, 60 bytes, 1 buffers

           1 broadcasts, 0 multicasts, 0 pauses

           0 errors, 0 runts, 0 giants

           0 crc, 0 align errors, 0 overruns

           0 dribbles, 0 drops, 0 no buffers

    Output:0 packets, 0 bytes, 0 buffers

           0 broadcasts, 0 multicasts, 0 pauses

           0 errors, 0 underruns, 0 collisions

           0 deferred, 0 lost carriers

# 查看三层以太网接口Ethernet1/1的运行状态和相关信息,只显示接口名和流量信息。

<Sysname> display interface ethernet 1/1 | include current state:|bytes

Ethernet1/1 current state: DOWN ( Administratively )

Line protocol current state: DOWN

    Last 300 seconds input rate 0.00 bytes/sec, 0 bits/sec, 0.00 packets/sec

    Last 300 seconds output rate 0.00 bytes/sec, 0 bits/sec, 0.00 packets/sec

    Input: 0 packets, 0 bytes, 0 buffers

    Output:0 packets, 0 bytes, 0 buffers

表1-1 display interface(三层模式)命令显示信息描述表

字段

描述

Ethernet1/1 current state

接口的物理状态,状态可能为:

l      DOWN ( Administratively ):表示该接口已经通过shutdown命令被关闭,即管理状态为关闭

l      DOWN ( Link-Aggregation interface down ):表示当前接口物理上处于未连通状态,原因为该接口所属的聚合接口被手工关闭了(即聚合接口下配置了shutdown命令)

l      DOWN:表示该接口的管理状态为开启,但物理状态为关闭(可能因为没有物理连线或者线路故障)

l      UP:该端口的管理状态和物理状态均为开启

Line protocol current state

接口的链路层状态。当接口的物理状态为DOWN时,该状态也显示为DOWN;当接口的物理状态为UP时,该状态也显示为UP

Description

接口的描述信息

The Maximum Transmit Unit

接口的最大传输单元

Internet protocol processing

IP报文的处理,disabled表示不能处理IP报文。在接口下配置IP地址后,该字段将变为:Internet Address is

IP Packet Frame TypeHardware Address

IP报文发送帧格式,硬件地址

IPv6 Packet Frame TypeHardware Address

IPv6报文发送帧格式,硬件地址

Media type is

接口使用的物理介质(twisted pair表示双绞线;optical fiber表示光纤)

loopback not set

没有配置环回测试功能(如果接口上配置了loopback external或者loopback internal,则会显示loopback is set

promiscuous mode not set

当前接口处于非混杂模式(该显示信息由promiscuous命令决定)

100Mb/s, Full-duplex, link type is autonegotiation

接口的速率,双工模式以及链路类型

Output queue (Urgent queue : Size/Length/Discards)

输出队列(紧急队列中当前的消息数/最大可容纳的消息数/已丢弃的消息数)

Output queue (Protocol queue : Size/Length/Discards)

输出队列(协议队列中当前的消息数/最大可容纳的消息数/已丢弃的消息数)

Output queue (FIFO queuing : Size/Length/Discards)

输出队列(先进先出队列中当前的消息数/最大可容纳的消息数/已丢弃的消息数)

Last clearing of counters

最近一次使用reset counts interface命令清除接口下的统计信息的时间(如果从设备启动一直没有执行reset counts interface命令清除过该接口下的统计信息,则显示Never

Last 300 seconds input rate

最近300秒钟的平均输入速率:bytes/sec表示平均每秒输入的字节数,bits/sec表示平均每秒输入的比特数,packets/sec表示平均每秒输入的包数

Last 300 seconds output rate

最近300秒钟的平均输出速率:bytes/sec表示平均每秒输出的字节数,bits/sec表示平均每秒输出的比特数,packets/sec表示平均每秒输出的包数

Input

输入报文

Output

输出报文

 

# 查看三层以太网子接口Ethernet1/1.1的运行状态和相关信息。

<Sysname> display interface ethernet 1/1.1

Ethernet1/1.1 current state: UP

Line protocol current state: UP

Description: Ethernet1/1.1 Interface

The Maximum Transmit Unit is 1500

Internet protocol processing : disabled

IP Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 0000-000f-0006

IPv6 Packet Frame Type: PKTFMT_ETHNT_2,  Hardware Address: 0000-000f-0006

Output queue : (Urgent queuing : Size/Length/Discards)  0/100/0                

Output queue : (Protocol queuing : Size/Length/Discards)  0/500/0              

Output queue : (FIFO queuing : Size/Length/Discards)  0/75/0

 Last clearing of counters:  Never

    0 packets input, 0 bytes, 0 drops

    0 packets output, 0 bytes, 0 drops

表1-2 display interface(三层子接口模式)命令显示信息描述表

字段

描述

Ethernet1/1.1 current state

接口的物理状态,状态可能为:

l      DOWN ( Administratively ):表示该接口已经通过shutdown命令被关闭,即管理状态为关闭

l      DOWN ( Link-Aggregation interface down ):表示当前接口物理上处于未连通状态,原因为该接口所属的聚合接口被手工关闭了(即聚合接口下配置了shutdown命令)

l      DOWN:表示该接口的管理状态为开启,但物理状态为关闭(可能因为没有物理连线或者线路故障)

l      UP:该端口的管理状态和物理状态均为开启

Line protocol current state

接口的链路层状态。当接口的物理状态为DOWN时,该状态也显示为DOWN;当接口的物理状态为UP时,该状态也显示为UP

Description

接口的描述信息

The Maximum Transmit Unit

接口的最大传输单元

Internet protocol processing

IP报文的处理,disabled表示不能处理IP报文。在接口下配置IP地址后,该字段将变为:Internet Address is

IP Packet Frame TypeHardware Address

IP报文发送帧格式,硬件地址

IPv6 Packet Frame TypeHardware Address

IPv6报文发送帧格式,硬件地址

Output queue (Urgent queue : Size/Length/Discards)

输出队列(紧急队列中当前的消息数/最大可容纳的消息数/已丢弃的消息数)

Output queue (Protocol queue : Size/Length/Discards)

输出队列(协议队列中当前的消息数/最大可容纳的消息数/已丢弃的消息数)

Output queue (FIFO queuing : Size/Length/Discards)

输出队列(先进先出队列中当前的消息数/最大可容纳的消息数/已丢弃的消息数)

Last clearing of counters

最近一次使用reset counts interface命令清除接口下的统计信息的时间(如果从设备启动一直没有执行reset counts interface命令清除过该接口下的统计信息,则显示Never

 

# 查看二层以太网接口Ethernet1/1的运行状态和相关信息。

<Sysname> display interface ethernet 1/1

 Ehernet1/1 current state: UP

 IP Packet Frame Type: PKTFMT_ETHNT_2, Hardware Address: 0000-000f-0007

 Description: Ethernet1/1 Interface

 Loopback is not set

 Media type is twisted pair, port hardware type is 100_BASE_TX

 100Mbps-speed mode, full-duplex mode

 Link speed type is autonegotiation, link duplex type is autonegotiation

 Flow-control is not enabled

 The Maximum Frame Length is 1536

 Broadcast MAX-ratio: 100%

 Multicast MAX-ratio: 100%

 PVID: 999

 Mdi type: auto

 Port link-type: access

  Tagged   VLAN ID : none

  Untagged VLAN ID : 999

 Port priority: 0

 Last clearing of counters:  Never

 Last 300 seconds input:  0 packets/sec 74 bytes/sec 0%

 Last 300 seconds output:  0 packets/sec 12 bytes/sec 0%

 Input (total):  21322 packets, 1748554 bytes

          - unicasts, - broadcasts, - multicasts, - pauses

 Input (normal):  21322 packets, - bytes

          1268 unicasts, 7560 broadcasts, 12494 multicasts, 0 pauses

 Input:  0 input errors, 0 runts, 0 giants, - throttles

          0 CRC, - frame, - overruns, - aborts

          - ignored, - parity errors

 Output (total): 1502 packets, 138924 bytes

          - unicasts, 2 broadcasts, 406 multicasts, 0 pauses

 Output (normal): - packets, - bytes

          1094 unicasts, - broadcasts, - multicasts, - pauses

 Output: 3 output errors, - underruns, - buffer failures

          - aborts, 1 deferred, 2 collisions, 0 late collisions

          - lost carrier, - no carrier

表1-3 display interface(二层模式)命令显示信息描述表

字段

描述

Ethernet1/1 current state

以太网端口当前物理状态,状态可能取值请参见1-4

IP Packet Frame Type

以太网帧格式

Hardware address

接口硬件地址

Description

描述信息

Loopback is not set

接口环回没有设置

100Mbps-speed mode

接口速率为100Mbps (如果显示为Unknown-speed mode则表示接口速率处于自协商状态,但因为接口没有插入电缆,所以速率未知)

full-duplex mode

双工模式为全双工(如果显示为link duplex type is force link,则表示接口的双工模式是固定的,不能通过命令行修改)

Link speed type is autonegotiation

接口速率是通过自协商确定的

link duplex type is autonegotiation

链路双工类型是通过自协商确定的

Flow-control is not enabled

没有使能流量控制功能

The Maximum Frame Length

接口允许通过的最大以太网帧长度

Broadcast MAX-ratio

广播风暴抑制比(允许通过的广播报文占用接口流量的百分比的最大值)

Unicast MAX-ratio

未知单播风暴抑制比(允许通过的未知单播报文占用接口流量的百分比的最大值)

Multicast MAX-ratio

组播风暴抑制比(允许通过的组播报文占用接口流量的百分比的最大值)

Allow jumbo frame to pass

接口允许长帧通过

PVID

接口缺省VLAN ID

Mdi type

网线类型

Port link-type

接口链路类型(有accesstrunkhybrid三种)

Tagged   VLAN ID

标识在该端口有哪些VLAN的报文需要打Tag标记

Untagged VLAN ID

标识在该端口有哪些VLAN的报文不需要打Tag标记

Port priority

接口优先级

Last clearing of counters:  Never

最近一次使用reset counts interface命令清除接口下的统计信息的时间(如果从设备启动一直没有执行reset counts interface命令清除过该接口下的统计信息,则显示Never

Last 300 seconds input:  0 packets/sec 0 bytes/sec

 Last 300 seconds output:  0 packets/sec 0 bytes/sec

端口在最近300秒接收和转发报文的平均速率,单位分别为数据包/秒和字节/

Input (total):  21322 packets, 1748554 bytes

          - unicasts, - broadcasts, - multicasts, - pauses

端口接收报文的统计值,包括正常报文、异常报文和正常PAUSE帧的报文数、字节数

端口接收的单播报文、广播报文、组播报文和PAUSE帧的数量

Input (normal):  21322 packets, - bytes

          1268 unicasts, 7560 broadcasts, 12494 multicasts, 0 pauses

端口接收的正常报文的统计值,包括正常报文和正常PAUSE帧的报文数、字节数

端口接收的正常单播报文、广播报文、组播报文和PAUSE帧的数量

input errors

各种接收错误的总数

runts

接收到的超小帧的数量

超小帧是指长度小于64字节、格式正确且包含有效的CRC字段的帧

giants

接收到的超大帧的数量

超大帧是指有效长度大于端口允许通过最大报文长度的帧:

l      对于禁止长帧通过的以太网端口,超大帧是指有效长度大于1536字节(不带VLAN Tag)或大于1540字节(带VLAN Tag报文)的帧

l      对于允许长帧通过的以太网端口,超大帧是指有效长度大于指定最大长帧长度的帧

 - throttles

端口出现throttles的次数

当缓存或CPU过载时,设备将端口关闭情况称为throttle

CRC

接收到的CRC校验错误、长度正常的帧的数量

frame

接收到的CRC校验错误、且长度不是整字节数的帧的数量

 - overruns

当端口的接收速率超过接收队列的处理能力时,导致报文被丢弃

aborts

接收到的非法报文总数,非法报文包括:

l      报文碎片:长度小于64字节(长度可以为整数或非整数)且CRC校验错误的帧

l      jabber帧:有效长度大于端口允许通过的最大报文长度,且CRC校验错误的帧(长度可以为整字节数或非整字节数)。如对于禁止长帧通过的以太网端口,jabber帧是指大于1518(不带VLAN Tag)或1522(带VLAN Tag)字节,且CRC校验错误的帧;对于允许长帧通过的以太网端口,jabber帧是指有效长度大于指定最大长帧长度,且CRC校验错误的帧

l      符号错误帧:报文中至少包含1个错误的符号

l      操作码未知帧:报文是MAC控制帧,但不是Pause

l      长度错误帧:报文中802.3长度字段与报文实际长度(461500字节)不匹配

ignored

由于端口接收缓冲区不足等原因而丢弃的报文数量

- parity errors

接收到的奇偶校验错误的帧的数量

Output (total): 1502 packets, 138924 bytes

          - unicasts, 2 broadcasts, 406 multicasts, 0 pauses

端口发送报文的统计值,包括正常报文、异常报文和正常PAUSE帧的报文数、字节数

端口发送的单播报文、广播报文、组播报文和PAUSE帧的数量

Output (normal): - packets, - bytes

          1094 unicasts, - broadcasts, - multicasts, - pauses 

端口发送的正常报文的统计值,包括正常报文和正常PAUSE帧的报文数、字节数

端口发送的正常单播报文、广播报文、组播报文和PAUSE帧的数量

output errors

各种发送错误的报文总数

 - underruns

当端口的发送速率超过了发送队列的处理能力,导致报文被丢弃,是一种非常少见的硬件异常

 - buffer failures

由于端口发送缓冲区不足而丢弃的报文数量

aborts

发送失败的报文总数,即报文已经开始发送,但由于各种原因(如冲突)而导致发送失败

deferred

延迟报文的数量,延迟报文是指发送前检测到冲突而被延迟发送的报文

collisions

冲突帧的数量,冲突帧是指在发送过程中检测到冲突的而停止发送的报文

late collisions

延迟冲突帧的数量,延迟冲突帧是指帧的前512 bits已经被发送,由于检测到冲突,该帧被延迟发送

lost carrier

载波丢失,一般适用于串行WAN接口,发送过程中,每丢失一个载波,此计数器加一

 - no carrier

无载波,一般适用于串行WAN接口,当试图发送帧时,如果没有载波出现,此计数器加一

 

显示信息中的“-”表示不支持该统计项。

 

表1-4 二层以太网接口物理状态描述表

字段

描述

UP

当前接口物理上处于连通状态

DOWN

当前接口物理上处于未连通状态,原因为没有物理连接(可能没有插网线或者网线故障)

DOWN ( Administratively )

当前接口物理上处于未连通状态,原因为本链路被手工关闭了(接口下配置了shutdown命令),需要执行undo shutdown命令才能恢复真实的物理状态

DOWN ( Link-Aggregation interface down )

当前接口物理上处于未连通状态,原因为该接口所在的聚合接口被手工关闭了(聚合接口下配置了shutdown命令)

DOWN ( OAM connection failure )

当前接口物理上处于未连通状态,原因为OAM连接失败(可能连接建立失败或者已经建立的连接被断开了)

DOWN ( DLDP connection failure )

当前接口物理上处于未连通状态,原因为DLDP连接失败(可能连接建立失败或者已经建立的连接被断开了)

DOWN ( Loopback detection-protected )

当前接口物理上处于未连通状态,原因为监测到环路,接口被强制关闭了

DOWN ( BPDU-protected )

当前接口物理上处于未连通状态,原因为该接口在BPDU guard功能的作用下被关闭了

DOWN ( Monitor-Link uplink down )

当前接口物理上处于未连通状态,原因为同一个Monitor Link组里的上行端口DOWN导致本接口DOWN

 

# 显示所有接口的概要信息。

<Sysname> display interface brief

The brief information of interface(s) under route mode:

Link: ADM - administratively down; Stby - standby

Protocol: (s) - spoofing

Interface            Link Protocol Main IP         Description

Aux0                 DOWN DOWN     --

Dia1                 UP   UP(s)    --

Eth0/0               UP   UP       10.1.1.2        Link to CoreRouter

Eth0/1               Stby DOWN     --

Loop0                UP   UP(s)    2.2.2.9

NULL0                UP   UP(s)    --

Vlan1                UP   DOWN     --

Vlan999              UP   UP       192.168.1.42

 

The brief information of interface(s) under bridge mode:

Link: ADM - administratively down

Speed or Duplex: (a)/A - auto; H - half; F - full

Type: A - access; T - trunk; H - hybrid

Interface            Link Speed   Duplex Type PVID Description

Eth0/2               DOWN auto    A      A    1

Eth0/3               UP   100M(a) F(a)   A    1

Eth0/4               DOWN auto    A      A    1

Eth0/5               DOWN auto    A      A    1

Eth0/6               UP   100M(a) F(a)   A    1

Eth0/7               DOWN auto    A      A    1

Eth0/8               UP   100M(a) F(a)   A    1

Eth0/9               UP   100M(a) F(a)   A    999

# 显示接口信息中以字符串“(s)”开始的行以及以后所有行。

<Sysname> display interface brief | begin (s)

The brief information of interface(s) under route mode:

Link: ADM - administratively down

Protocol: (s) - spoofing

Interface            Link Protocol Main IP         Description

Dia1                 UP   UP(s)    --

Eth0/0               UP   UP       10.1.1.2        Link to CoreRouter

Eth0/1               Stby DOWN     --

Loop0                UP   UP(s)    2.2.2.9

NULL0                UP   UP(s)    --

Vlan1                UP   DOWN     --

Vlan999              UP   UP       192.168.1.42

使用begin参数进行过滤的时候,只会在三层接口列表或者二层接口列表中进行搜索。如果regular-expression出现在三层接口列表中,则只会显示三层接口列表中包含regular-expression的行以及以后所有行,不会显示二层接口列表中的行。

# 显示处于UP状态的所有接口的概要信息。

<Sysname> display interface brief | include UP

The brief information of interface(s) under route mode:

Link: ADM - administratively down

Protocol: (s) - spoofing

Interface            Link Protocol Main IP         Description

Dia1                 UP   UP(s)    --

Eth0/0               UP   UP       10.1.1.2        Link to CoreRouter

Loop0                UP   UP(s)    2.2.2.9

NULL0                UP   UP(s)    --

Vlan1                UP   DOWN     --

Vlan999              UP   UP       192.168.1.42

 

The brief information of interface(s) under bridge mode:

Link: ADM - administratively down

Speed or Duplex: (a)/A - auto; H - half; F - full

Type: A - access; T - trunk; H - hybrid

Interface            Link Speed   Duplex Type PVID Description

Eth0/3               UP   100M(a) F(a)   A    1

Eth0/6               UP   100M(a) F(a)   A    1

Eth0/8               UP   100M(a) F(a)   A    1

Eth0/9               UP   100M(a) F(a)   A    999

# 显示设备上除以太网接口外的所有其他类型接口的概要信息。

<Sysname> display interface brief | exclude Eth

The brief information of interface(s) under route mode:

Link: ADM - administratively down

Protocol: (s) - spoofing

Interface            Link Protocol Main IP         Description

Aux0                 DOWN DOWN     --

Cellular0/0          DOWN DOWN     --

Dia1                 UP   UP(s)    --

Loop0                UP   UP(s)    2.2.2.9

NULL0                UP   UP(s)    --

Vlan1                UP   DOWN     --

Vlan999              UP   UP       192.168.1.42

# 显示当前状态为DOWN的接口的信息以及DOWN的原因。

<Sysname> display interface brief down

The brief information of interface(s) under bridge mode:

Link: ADM - administratively down; Stby - standby

Interface            Link Cause

Eth6/4/0             DOWN Not connected

Eth6/4/1             DOWN OAM connection failure

Eth6/4/2             DOWN Not connected

Eth6/4/3             DOWN Not connected

Eth6/4/4             DOWN Not connected

Eth6/4/5             DOWN Not connected

Eth6/4/6             DOWN Not connected

Eth6/4/7             DOWN Not connected

表1-5 display interface brief命令显示信息描述

字段

描述

The brief information of interface(s) under route mode:

三层模式下(route)的接口的概要信息,即三层接口的概要信息

Link: ADM - administratively down; Stby - standby

如果某接口的Link属性值为“ADM”,则表示该接口被管理员手工关闭了,需要在该接口下执行undo shutdown命令才能恢复端口本身的物理状态

如果某接口的Link属性值为“Stby”,则表示该接口是一个备份接口,使用display standby state命令可以查看该备份接口对应的主接口

Protocol: (s) - spoofing

如果某接口的Protocol属性值中带有“(s)”字符串,则表示该接口的网络层协议状态显示是UP的,但实际可能没有对应的链路,或者所对应的链路不是永久存在而是按需建立。通常NULLLoopback接口等会具有该属性

Interface

接口名称缩写

Link

接口物理连接状态,取值可能为:

l      UP:表示本链路物理上是连通的

l      DOWN:表示本链路物理上不通的

l      ADM:表示本链路被手工关闭了,需要执行undo shutdown命令才能恢复真实的物理状态

l      Stby:表示该接口是一个备份接口

Protocol

接口协议连接状态,可以为UPDOWN或者UP(s)

Main IP

接口主IP地址

Description

接口的描述信息(如果描述信息较多,无法在一行中完全显示时,此处只显示部分描述信息。可使用不带brief参数的display interface命令来显示完整的描述信息)

The brief information of interface(s) under bridge mode:

二层模式下(bridge)的接口概要信息,即二层接口的概要信息

Speed or Duplex: (a)/A - auto; H - half; F - full

如果某接口的Speed属性值为“(a)”,则表示该接口的速率是通过自动协商获取的

如果某接口的Duplex属性值为“(a)”或者“A”,则表示该接口的Duplex属性是通过自动协商获取的;取值为“H”则表示为半双工;取值为“F”则表示为全双工

Type: A - access; T - trunk; H - hybrid

接口的链路类型:

l      A:表示Access链路类型

l      H:表示Hybrid链路类型

l      T:表示Trunk链路类型

Speed

接口的速率,单位为bps

Duplex

接口的双工模式,取值可能为:

l      A:表示双工模式由自动协商结果决定

l      F:表示全双工

l      F(a):表示自由协商的结果为全双工

l      H:表示半双工

l      H(a):表示自由协商的结果为半双工

Type

链路类型,取值可能为:

l      A:表示Access链路类型

l      H:表示Hybrid链路类型

l      T:表示Trunk链路类型

PVID

接口的缺省VLAN ID

Cause

接口物理连接状态为DOWN的原因,可能原因请参见1-6

 

表1-6 接口物理连接状态为down的原因列表

字段

描述

Not connected

没有物理连接(可能没有插网线或者网线故障)

Administratively

本链路被手工关闭了(配置了shutdown命令),需要执行undo shutdown命令才能恢复真实的物理状态

Link-Aggregation interface down

该接口所在的聚合接口被手工关闭了(配置了shutdown命令)

OAM connection failure

OAM连接失败(可能连接建立失败或者已经建立的连接被断开了)

DLDP connection failure

DLDP连接失败(可能连接建立失败或者已经建立的连接被断开了)

Loopback detection-protected

因为监测到环路,接口被强制关闭了

BPDU-protected

该接口在BPDU guard功能的作用下被关闭了

Monitor-Link uplink down

同一个Monitor Link组里的上行端口DOWN导致本接口DOWN

 

1.1.6  duplex

【命令】

duplex { auto | full | half }

undo duplex

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

auto:接口处于自协商状态。

full:接口处于全双工状态。

half:接口处于半双工状态。Combo口中的光口和10GE接口不支持配置该参数。

【描述】

duplex命令用来设置以太网接口的双工模式。undo duplex命令用来将接口的双工模式恢复为缺省状态。

缺省情况下,10GE接口的双工模式为full(全双工)状态,其他以太网接口的双工模式为auto(自协商)状态[맄ːˈːˠː˸ː1] 

相关配置可参考命令speed

【举例】

# 将以太网接口Ethernet1/1接口设置为全双工状态。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] duplex full

1.1.7  flow-control

【命令】

flow-control

undo flow-control

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

flow-control命令用来开启以太网接口的流量控制功能。undo flow-control命令用来关闭以太网接口流量控制功能。

缺省情况下,以太网接口的流量控制功能处于关闭状态。

配置flow-control命令后,设备具有发送和接收流量控制报文的能力:当本端发生拥塞时,设备会向对端发送流量控制报文;当本端收到对端的流量控制报文后,会停止报文发送。

只有本端和对端设备都开启了流量控制功能,才能实现对本端以太网接口的流量控制。

 

【举例】

# 开启以太网接口Ethernet1/1的流量控制功能。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] flow-control

1.1.8  interface

【命令】

interface interface-type { interface-number | interface-number.subnumber }

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

interface-type:指定接口的接口类型。

interface-number:指定接口的接口编号。

interface-number.subnumber:指定逻辑子接口编号。其中interface-number为主接口编号;subnumber为子接口编号,取值范围为14094

【描述】

interface命令用来进入相应接口或子接口视图。在进入子接口视图之前,如果指定的子接口不存在,则先创建子接口,再进入该子接口的视图。

【举例】

# 进入二层以太网接口Ethernet1/1视图。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1]

# 进入三层以太网接口Ethernet2/0视图。

<Sysname> system-view

[Sysname] interface ethernet 2/0

[Sysname-Ethernet2/0]

# 创建三层以太网子接口Ethernet2/0.1并进入该子接口的视图。

<Sysname> system-view

[Sysname] interface ethernet 2/0.1

[Sysname-Ethernet2/0.1]

1.1.9  link-delay

【命令】

link-delay delay-time

undo link-delay

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

delay-time:取值为0,单位为秒,即不对接口物理连接状态的变化进行抑制。

【描述】

link-delay命令用来设置以太网接口物理连接状态抑制时间。undo link-delay命令用来恢复缺省情况。

缺省情况下,以太网接口物理连接状态抑制时间为5

MSR系列路由器各款型对于本节所描述的命令及参数的支持情况有所不同,详细差异信息如下:

命令

MSR 900

MSR 20-1X

MSR 20

MSR 30

MSR 50

link-delay

No

No

No

Yes(仅三层以太网GE接口支持)

Yes(仅三层以太网GE接口支持)

 

本命令对自然关闭状态(down)下的端口有效,对手工关闭状态(使用shutdown命令)下的端口无效。

 

【举例】

# 设置以太网接口物理连接状态抑制时间为0秒,即不抑制。

<Sysname> system-view

[Sysname] interface gigabitethernet 0/1

[Sysname-GigabitEthernet0/1] link-delay 0

1.1.10  loopback

【命令】

loopback { external | internal }

undo loopback

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

external以太网接口对外环回测试功能。

internal以太网接口对内环回测试功能。

【描述】

loopback命令用来开启以太网接口环回测试功能。undo loopback命令用来关闭以太网接口环回测试功能。

缺省情况下,以太网接口环回测试功能处于关闭状态。

l          在进行某些特殊功能测试时,例如初步定位以太网故障时,需要开启以太网接口环回测试功能。

l          以太网接口开启环回测试功能时将工作在全双工状态;关闭环回测试功能后恢复原有配置。

 

【举例】

# 配置以太网接口Ethernet1/1进行对内环回测试。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] loopback internal

1.1.11  port link-mode

【命令】

port link-mode { bridge | route }

undo port link-mode

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

bridge工作在二层模式。

route工作在三层模式。

【描述】

port link-mode命令用来切换以太网接口的链路模式。undo port link-mode命令用来恢复缺省情况。

基于接口板的硬件构造,设备上的某些接口只能作为二层以太网接口;某些接口只能作为三层以太网接口;某些接口则比较灵活,其链路模式可以通过命令行设置:如果将其链路模式设置为二层模式(bridge),则作为一个二层以太网接口使用,如果将其链路模式设置为三层模式(route),则作为一个三层以太网接口使用。

相关配置可参考命令port link-mode interface-list

以太网接口的链路模式切换后,该以太网接口下的所有配置都将恢复到新模式下的缺省配置。

 

【举例】

# 使接口Ethernet1/1工作在二层模式。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] display this

#

interface Ethernet1/1

 port link-mode route

#

Return

以上显示信息表明接口Ethernet1/1当前工作在三层模式。

[Sysname-Ethernet1/1] port link-mode bridge

[Sysname-Ethernet1/1] display this

#

interface Ethernet1/1

 port link-mode bridge

#

Return

以上显示信息表明,接口Ethernet1/1的链路模式已经修改为二层模式了。

display this命令用来查看当前视图下生效的配置。

 

1.1.12  port link-mode interface-list

【命令】

port link-mode { bridge | route } interface-list

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

bridge工作在二层模式。

route工作在三层模式。

interface-list以太网接口列表表示两个以太网接口。

【描述】

port link-mode interface-list命令用来切换以太网接口的链路模式。

基于接口板的硬件构造,设备上的某些接口只能作为二层以太网接口;某些接口只能作为三层以太网接口;某些接口在比较灵活,其链路模式可以通过命令行设置:如果将其链路模式设置为二层模式(bridge),则作为一个二层以太网接口使用,如果将其链路模式设置为三层模式(route),则作为一个三层以太网接口使用。

在系统视图下配置port link-mode interface-list命令和在以太网接口视图下port link-mode命令效果相同。port link-mode interface-list命令通常用来一次切换两个以太网接口的链路模式,port link-mode命令一次只能配置一个接口。

l          以太网接口的链路模式切换后,该以太网接口下的所有配置都将恢复到新模式下的缺省配置。

l          以太网接口的链路模式既可以在系统视图下配置也可以在以太网接口视图下配置。当两种视图下配置的链路模式不同时,最新的配置生效。

 

【举例】

# 设置Ethernet1/1Ethernet1/2为二层端口。

<Sysname> system-view

[Sysname] port link-mode bridge ethernet 1/1 to ethernet 1/2

# 设置Ethernet1/1Ethernet1/2为三层端口。

<Sysname> system-view

[Sysname] port link-mode route ethernet 1/1 to ethernet 1/2

1.1.13  reset counters interface

【命令】

reset counters interface [ interface-type [ interface-number | interface-number.subnumber ] ]

【视图】

用户视图

【缺省级别】

2:系统级

【参数】

interface-type:指定接口的接口类型。

interface-number:指定接口的接口编号。

interface-number.subnumber:指定逻辑子接口。其中interface-number为主接口编号;subnumber为子接口编号,取值范围为14094

【描述】

reset counters interface命令用来清除以太网接口的统计信息。

在某些情况下,需要统计一定时间内某接口的流量,这就需要在统计开始前清除该接口原有的统计信息,重新进行统计。

l              如果不指定interface-typeinterface-number,则清除所有接口的统计信息;

l              如果指定interface-type而不指定interface-number,则清除所有该类型以太网接口的统计信息;

l              如果同时指定interface-typeinterface-number,则清除指定以太网接口的统计信息。

【举例】

# 清除以太网接口Ethernet1/1的统计信息。

<Sysname> reset counters interface ethernet 1/1

# 清除以太网子接口Ethernet1/1.1的统计信息。

<Sysname> reset counters interface ethernet 1/1.1

1.1.14  shutdown

【命令】

shutdown

undo shutdown

【视图】

以太网接口视图/以太网子接口视图/端口组视图

【缺省级别】

2:系统级

【参数】

【描述】

shutdown命令用来关闭当前接口。undo shutdown命令用来打开当前接口。

缺省情况下,以太网接口和子接口均处于开启状态。

在某些特殊情况下(比如切换了接口的速率或双工模式等),接口相关配置不能立即生效,需要关闭和激活接口后,才能生效。

需要注意的是:对于Combo接口,某一时刻最多只能有一个接口处于激活(active)状态,收发报文。当激活光口(执行undo shutdown命令)后,电口会自动关闭变为inactive状态,此时,光口可用;反之亦然。

【举例】

# 先关闭以太网接口Ethernet1/1,再打开该接口。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] shutdown

[Sysname-Ethernet1/1] undo shutdown

# 先关闭以太网子接口Ethernet1/1.1,再打开该接口。

<Sysname> system-view

[Sysname] interface ethernet 1/1.1

[Sysname-Ethernet1/1.1] shutdown

[Sysname-Ethernet1/1.1] undo shutdown

# 关闭端口组group1内的所有成员端口。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group-manual-group1] shutdown

1.1.15  speed

【命令】

speed { 10 | 100 | 1000 | auto }

undo speed

【视图】

以太网接口视图

【缺省级别】

2:系统级

【参数】

10:表示接口速率为10MbpsCombo口中的光口不支持配置该参数。

100:表示接口速率为100MbpsCombo口中的光口不支持配置该参数。

1000:表示接口速率为1000Mbps。本参数的支持情况与接口板的型号有关,请以接口板的实际情况为准。

auto:表示接口速率处于自协商状态。

【描述】

speed命令用来设置以太网接口的速率。undo speed命令用来恢复以太网接口的速率为缺省情况。

本命令的缺省情况为auto

需要注意的是:

l              对于以太网电口来说,使用speed命令设置端口速率,目的是使其与对端进行速率匹配;

l              对于光口来说,使用speed命令设置端口速率,目的是使其与可插拔光模块进行速率匹配。

相关配置可参考命令duplex

【举例】

# 将以太网接口Ethernet1/1的速率设置为100Mbps

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] speed 100

1.2  二层以太网接口配置命令

1.2.1  broadcast-suppression

【命令】

broadcast-suppression { ratio | pps max-pps }

undo broadcast-suppression

【视图】

二层以太网接口视图/端口组视图

【缺省级别】

2:系统级

【参数】

ratio:指定以太网接口允许通过的最大广播流量占该接口传输能力的百分比,数值越小,允许通过的广播流量也越小。

l              当设备支持线性抑制方式时,取值范围为1100

l              当设备支持非线性抑制方式时,取值范围为5100

pps max-pps:指定以太网接口每秒允许转发的最大广播包数,单位为ppspackets per second,每秒转发的报文数),取值范围为1148810。目前只支持设置为如下值:190、380、760、1488、2976、5952、11904。

l              当设备指定pps参数并且抑制粒度大于1时,则设置参数必须不小于抑制粒度值,且为抑制粒度的整数倍。端口下配置的抑制值可能与实际生效抑制值不一致,实际生效抑制值可通过display interface命令查看;

l              当设备没有指定pps参数,或者抑制粒度等于1时,则设置参数必须不小于1,端口配置抑制值即为实际生效的抑制值。

【描述】

broadcast-suppression命令用来在接口下设置广播风暴抑制比。undo broadcast-suppression命令用来恢复缺省情况。

缺省情况下,所有接口不对广播流量进行抑制。

在以太网接口视图下执行该命令,则该配置只在当前接口下生效;在端口组视图下执行该命令,则该配置将在端口组中的所有端口下生效。

需要注意的是,本命令设置的是接口允许通过的最大广播报文流量。当接口上的广播流量超过用户设置的值后,系统将丢弃超出广播流量限制的报文,从而使接口广播流量所占的比例降低到限定的范围,保证网络业务的正常运行。

如果在以太网接口视图或端口组视图下多次配置不同的抑制比数值时,最新的配置生效。

 

【举例】

# 在以太网接口Ethernet1/1上,最多允许相当于该接口传输能力20%的广播报文通过,对超出该范围的广播报文进行抑制。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] broadcast-suppression 20

# 在手工端口组“group1”内的所有端口上,最多允许相当于每个端口传输能力20%的广播报文通过,对超出该范围的广播报文进行抑制。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group-manual-group1] group-member ethernet 2/0

[Sysname-port-group-manual-group1] group-member ethernet 2/1

[Sysname-port-group-manual-group1] broadcast-suppression 20

1.2.2  display loopback-detection

【命令】

display loopback-detection [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1256个字符的字符串,区分大小写。

【描述】

display loopback-detection命令用来显示端口环回监测功能的开启情况和相关信息。

如果已经开启端口环回监测功能,还会显示定时监测的时间间隔和目前被环回的端口信息。

【举例】

# 显示端口环回监测功能的开启情况。

<Sysname> display loopback-detection

 Loopback detection is running.

 Detection interval is 30 seconds.

 No port is detected with loopback.

表1-7 display loopback-detection命令显示信息描述表

字段

描述

Loopback detection is running.

系统环回监测功能处于开启状态

Detection interval is 30 seconds.

监测时间间隔为30

No port is detected with loopback.

目前没有端口被环回

 

1.2.3  display port-group manual

【命令】

display port-group manual [ all | name port-group-name ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

2:系统级

【参数】

all:所有手工端口组。

name port-group-name:指定手工端口组的名称,为132个字符的字符串。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1256个字符的字符串,区分大小写。

【描述】

display port-group manual命令用来显示手工端口组的信息。

l              如果指定参数port-group-name,显示指定手工端口组的详细信息,包括名称和手工端口组中的以太网接口;

l              如果指定参数all,显示所有手工端口组的详细信息,包括名称和手工端口组中的以太网接口;

l              如没有指定参数,则显示所有端口组的名称。

【举例】

# 显示所有手工端口组的名称。

<Sysname> display port-group manual

The following manual port group exist(s):

group1                                    group2

# 显示所有手工端口组的详细信息。

<Sysname> display port-group manual all

Member of group1:

    Ethernet1/3            Ethernet1/4            Ethernet1/5

    Ethernet1/6            Ethernet1/7            Ethernet2/0

    Ethernet2/1

 

Member of group2:

None

# 显示手工端口组group1的详细信息。

<Sysname> display port-group manual name group1

Member of group1:

    Ethernet1/3            Ethernet1/4            Ethernet1/5

    Ethernet1/6            Ethernet1/7            Ethernet2/0

表1-8 display port-group manual命令显示信息描述表

字段

描述

Member of group

手工端口组的成员

 

1.2.4  display counters

【命令】

display counters { inbound | outbound } interface [ interface-type ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

inbound表示输入报文的流量统计信息。

outbound表示输出报文的流量统计信息。

interface-type:统计的接口类型。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1256个字符的字符串,区分大小写。

【描述】

display counters命令用来显示接口的报文流量统计信息。

l              若指定接口类型,则显示该类型下所有接口的报文流量统计信息。

l              若不指定接口类型,则显示所有可统计的接口类型下所有接口的报文流量统计信息。

【举例】

# 显示GigabitEthernet类型接口的输入流量统计信息。

<Sysname> display counters inbound interface gigabitethernet

Interface            Total(pkts)    Broadcast(pkts)    Multicast(pkts) Err(pkts)

GE1/1                        100                100                  0         0

GE1/2                          0                  0                  0         0

GE1/3                   Overflow           Overflow           Overflow  Overflow

GE1/4                          0                  0                  0         0

 

 Overflow: more than 14 decimal digits(7 digits for column "Err").

       --: not supported.

表1-9 display counters命令显示信息描述表

字段

描述

Interface

接口名称缩写

Total(pkts)

接口接收或发送报文的总数(单位为包)

Broadcast(pkts)

接口接收或发送广播报文的总数(单位为包)。RPR物理端口不对广播报文单独进行统计,而是与组播报文一起都按照组播报文进行统计

Multicast(pkts)

接口接收或发送组播报文的总数(单位为包)。RPR物理端口不对广播报文单独进行统计,而是与组播报文一起都按照组播报文进行统计

Err(pkts)

接口接收或发送错误报文的总数(单位为包)

Overflow: more than 14 decimal digits(7 digits for column "Err").

当某个统计信息的值为Overflow时,表示该项数据的长度超过了显示范围:

l      对于Err项,Overflow表示数据的长度超过了7位十进制数

l      对于其它项,Overflow表示数据的长度超过了14位十进制数

--: not supported.

显示信息中的“--”字符串表示设备不支持该项数据的统计

 

1.2.5  display counters rate

【命令】

display counters rate { inbound | outbound } interface [ interface-type ] [ | { begin | exclude | include } regular-expression ]

【视图】

任意视图

【缺省级别】

1:监控级

【参数】

inbound表示输入报文的流量统计信息。

outbound表示输出报文的流量统计信息。

interface-type:统计的接口类型。

|:使用正则表达式对显示信息进行过滤。有关正则表达式的详细介绍,请参见“基础配置指导”中的“CLI”。

begin:从包含指定正则表达式的行开始显示。

exclude:只显示不包含指定正则表达式的行。

include:只显示包含指定正则表达式的行。

regular-expression:表示正则表达式,为1256个字符的字符串,区分大小写。

【描述】

display counters rate命令用来显示最近一个抽样间隔内处于up状态的接口的报文速率统计信息。

l              若指定接口类型,则显示该类型下所有处于up状态接口的报文速率统计信息。

l              若不指定接口类型,则显示所有可统计的接口类型中所有处于up状态接口的报文速率统计信息。

关于抽样间隔的长度,对于支持系统视图下flow-interval命令的设备,可以通过flow-interval命令来设置,缺省抽样时间间隔为300秒。

相关配置可参考命令flow-interval

【举例】

# 显示GigabitEthernet类型接口的报文输入速率统计信息。

<Sysname> display counters rate inbound interface gigabitethernet

Interface           Total(pkts/sec)   Broadcast(pkts/sec)   Multicast(pkts/sec)

GE1/1                           200                   100                   100

GE1/2                           300                   200                   100

GE1/3                           300                   200                   100

 

 Overflow: more than 14 decimal digits.

       --: not supported.

表1-10 display counters rate命令显示信息描述表

字段

描述

Interface

接口名称缩写

Total(pkts/sec)

在抽样间隔内,接口接收或发送总报文的平均速率(单位为包/秒)

Broadcast(pkts/sec)

在抽样间隔内,接口接收或发送广播报文的平均速率(单位为包/秒)。RPR物理端口不对广播报文单独进行统计,而是与组播报文一起都按照组播报文进行统计

Multicast(pkts/sec)

在抽样间隔内,接口接收或发送组播报文的平均速率(单位为包/秒)。RPR物理端口不对广播报文单独进行统计,而是与组播报文一起都按照组播报文进行统计

Overflow: more than 14 decimal digits.

当某个统计信息的值为Overflow时,表示该项数据的长度超过了14位十进制数

--: not supported.

--”字符串表示设备不支持该项数据的统计

 

1.2.6  flow-interval

【命令】

flow-interval interval

undo flow-interval

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

interval:接口统计信息的时间间隔值,取值范围为5300,单位为秒,步长为5(即取值必须为5的整数倍),缺省值为300

【描述】

flow-interval命令用来配置接口统计报文信息的时间间隔。undo flow-interval命令用来恢复接口统计报文信息的时间间隔缺省值。

在系统视图下执行该命令,配置的是设备上所有端口统计报文信息的时间间隔。

【举例】

# 设置系统的统计信息时间间隔为100秒。

<Sysname> system-view

[Sysname] flow-interval 100

1.2.7  group-member

【命令】

group-member interface-list

undo group-member interface-list

【视图】

端口组视图

【缺省级别】

2:系统级

【参数】

interface-list:以太网接口列表,表示多个以太网接口。表示方式为interface-list=interface-type interface-number [ to interface-type interface-number ]&<1-10>interface-type interface-number为以太网接口类型及接口编号。&<1-10>表示前面的参数最多可以重复输入10次。

【描述】

group-member命令用来添加以太网接口到指定手工端口组中。undo group-member命令用来删除手工端口组中的指定以太网接口。

缺省情况下,手工端口组中无以太网接口。

如果使用group-member interface-type interface-start-number to interface-type interface-end-number命令形式一次将多个端口加入到指定手工端口组中时,要求本次加入的所有接口都在同一块接口板上,interface-type相同,并且interface-end-number必须大于interface-start-number

【举例】

# 添加以太网接口Ethernet1/1到手工端口组group1中。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group-manual-group1] group-member ethernet 1/1

1.2.8  jumboframe enable

【命令】

jumboframe enable [ value ]

undo jumboframe enable

【视图】

二层以太网接口视图/端口组视图

【缺省级别】

2:系统级

【参数】

value:以太网接口上允许通过的长帧的最大长度值。

【描述】

jumboframe enable命令用来允许指定长度的长帧通过相应的以太网接口。undo jumboframe enable命令用来禁止长帧通过相应的以太网接口。

缺省情况下,设备允许指定长度的长帧通过所有的二层以太网接口。

用户可以通过端口下(以太网接口视图或端口组视图下)的配置方式设置允许指定长度的长帧通过以太网接口:

l              在以太网接口视图下执行该命令,则该配置只在当前端口下生效;

l              在端口组视图下执行该命令,则该配置将在端口组中的所有端口下生效。

【举例】

# 允许长帧通过手工端口组group1下的所有以太网接口。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group-manual-group1] group-member ethernet 2/0

[Sysname-port-group-manual-group1] jumboframe enable

# 允许长帧通过以太网接口Ethernet1/1

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] jumboframe enable

1.2.9  loopback-detection control enable

【命令】

loopback-detection control enable

undo loopback-detection control enable

【视图】

二层以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

loopback-detection control enable命令用来开启Trunk端口或Hybrid端口的环回监测受控功能。undo loopback-detection control enable命令用来恢复缺省情况。

缺省情况下,Trunk端口和Hybrid端口的环回监测受控功能均处于关闭状态。

l              当环回监测受控功能开启时,如果系统发现端口被环回,则根据环回监测动作对该端口进行相应的操作,并发送Trap信息。

l              当环回监测受控功能关闭时,如果系统发现端口被环回,则只向终端上报Trap信息,该端口仍处于正常工作状态。

需要注意的是,因为Access端口的环回监测受控功能默认处于开启状态,所以该命令对Access端口无效。

【举例】

# 开启Trunk端口Ethernet1/1的环回监测受控功能。

<Sysname> system-view

[Sysname] loopback-detection enable

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] port link-type trunk

[Sysname-Ethernet1/1] loopback-detection enable

[Sysname-Ethernet1/1] loopback-detection control enable

1.2.10  loopback-detection enable

【命令】

loopback-detection enable

undo loopback-detection enable

【视图】

系统视图/二层以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

loopback-detection enable命令用来开启全局或指定端口的环回监测功能。undo loopback-detection enable命令用来关闭全局或指定端口的环回监测功能。

缺省情况下,Access端口、Trunk端口和Hybrid端口环回监测功能均处于关闭状态。

l              对于Access端口,如果系统发现端口被环回监测,则根据环回监测动作对该端口进行相应的操作,并向终端上报Trap信息,同时删除该端口对应的MAC地址转发表项;

l              对于Trunk端口或Hybrid端口,如果系统发现端口被环回监测,则只向终端上报Trap信息。当端口的环回监测受控功能也同时开启时,系统根据环回监测动作对该端口进行相应的操作,并向终端上报Trap信息,同时删除该端口对应的MAC地址转发表项。

相关配置可参考命令loopback-detection control enable

l          只有在系统视图下和指定接口视图下均配置了loopback-detection enable命令后,该端口的环回监测功能才能启动。

l          当在系统视图下配置undo loopback-detection enable后,所有端口的环回监测功能均被关闭。

 

【举例】

# 开启以太网接口Ethernet1/1环回监测功能。

<Sysname> system-view

[Sysname] loopback-detection enable

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] loopback-detection enable

1.2.11  loopback-detection interval-time

【命令】

loopback-detection interval-time time

undo loopback-detection interval-time

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

time:端口环回监测的时间间隔,取值范围为5300,单位为秒。

【描述】

loopback-detection interval-time命令用来设置端口环回监测的时间间隔。undo loopback-detection interval-time命令用来恢复该时间间隔为缺省值。

缺省情况下,端口环回监测的时间间隔为30秒。

相关配置可参考命令display loopback-detection

【举例】

# 设置端口环回监测的时间间隔为10秒。

<Sysname> system-view

[Sysname] loopback-detection interval-time 10

1.2.12  loopback-detection per-vlan enable

【命令】

loopback-detection per-vlan enable

undo loopback-detection per-vlan enable

【视图】

二层以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

loopback-detection per-vlan enable命令用来配置系统在当前Trunk端口或Hybrid端口所属的所有VLAN内进行环回监测。undo loopback-detection per-vlan enable命令用来配置系统只在Trunk端口或Hybrid端口所属的缺省VLAN内进行环回监测。

缺省情况下,系统只在Trunk端口或Hybrid端口所属的缺省VLAN内进行环回监测。

需要注意的是,loopback-detection per-vlan enable命令对Access端口无效。

【举例】

# 配置系统在Trunk端口Ethernet1/1所属的所有VLAN内进行环回监测。

<Sysname> system-view

[Sysname] loopback-detection enable

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] loopback-detection enable

[Sysname-Ethernet1/1] port link-type trunk

[Sysname-Ethernet1/1] loopback-detection per-vlan enable

1.2.13  mdi

【命令】

mdi { across | auto | normal }

undo mdi

【视图】

二层以太网接口视图

【缺省级别】

2:系统级

【参数】

across:指定MDI模式为across

auto:指定MDI模式为auto

normal:指定MDI模式为normal

【描述】

mdi命令用来设置以太网接口的MDI模式。undo mdi命令用来恢复缺省情况。

缺省情况下,以太网接口的MDI模式为auto,即通过协商来决定物理引脚的角色(发送报文或接收报文)。

光接口不支持本命令。

 

【举例】

# 设置以太网接口Ethernet1/1MDI模式为across

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] mdi across

1.2.14  multicast-suppression

【命令】

multicast-suppression { ratio | pps max-pps }

undo multicast-suppression

【视图】

二层以太网接口视图/端口组视图

【缺省级别】

2:系统级

【参数】

ratio:指定以太网接口允许通过的最大组播流量占该接口传输能力的百分比。取值范围为1100。数值越小,则允许通过的组播流量也越小。

pps max-pps:指定以太网接口每秒最多通过的组播包包数,取值范围为1148810,单位为pps。目前只支持设置为如下值:190、380、760、1488、2976、5952、11904。

l              当设备指定pps参数并且抑制粒度大于1时,则设置参数必须不小于抑制粒度值,且为抑制粒度的整数倍。端口下配置的抑制值可能与实际生效抑制值不一致,实际生效抑制值可通过display interface命令查看。

l              当设备没有指定pps参数,或者抑制粒度等于1时,则设置参数必须不小于1,端口配置抑制值即为实际生效的抑制值。

【描述】

multicast-suppression命令用来在接口下设置组播风暴流量抑制比。undo multicast-suppression命令用来恢复缺省情况。

缺省情况下,所有接口不对组播流量进行抑制。

在以太网接口视图下执行该命令,则该配置只在当前接口下生效;在端口组视图下执行该命令,则该配置将在端口组中的所有端口下生效。

需要注意的是,本命令设置的是接口允许通过的最大组播报文流量。当接口上的组播流量超过用户设置的值后,系统将丢弃超出组播流量限制的报文,从而使接口组播流量所占的比例降低到限定的范围,保证网络业务的正常运行。

l          在设备同时支持全局和接口下配置的情况下,当全局和接口下都配置了抑制比,则接口对组播报文的处理会根据这两个限制去判断,最先达到的限制生效。

l          如果在以太网接口视图或端口组视图下多次配置不同的抑制比数值时,最新的配置生效。

【举例】

# 在以太网接口Ethernet1/1上,最多允许相当于该接口传输能力20%的组播报文通过,对超出该范围的组播报文进行抑制。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] multicast-suppression 20

# 在手工端口组group1内的所有端口上,最多允许相当于每个端口传输能力20%的组播报文通过,对超出该范围的组播报文进行抑制。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group-manual-group1] group-member ethernet 2/0

[Sysname-port-group-manual-group1] group-member ethernet 2/1

[Sysname-port-group-manual-group1] multicast-suppression 20

1.2.15  port-group manual

【命令】

port-group manual port-group-name

undo port-group manual port-group-name

【视图】

系统视图

【缺省级别】

2:系统级

【参数】

port-group-name:指定手工端口组的名称,为132个字符的字符串。

【描述】

port-group manual命令用来进入一个手工端口组视图。如果该手工端口组不存在,则先完成端口组的创建,再进入该端口组的视图。undo port-group manual命令用来删除已经创建的指定手工端口组。

缺省情况下,无手工端口组。

【举例】

# 创建手工端口组group1

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group-manual-group1]

1.2.16  unicast-suppression

【命令】

unicast-suppression { ratio | pps max-pps}

undo unicast-suppression

【视图】

二层以太网接口视图/端口组视图

【缺省级别】

2:系统级

【参数】

ratio:指定以太网接口最大未知单播流量占该接口传输能力百分比。取值范围为1100。数值越小,则允许通过的未知单播流量也越小。

pps max-pps:指定以太网接口每秒最多通过的未知单播包包数,取值范围为1148810,单位为pps

l              当设备指定pps参数并且抑制粒度大于1时,则设置参数必须不小于抑制粒度值,且为抑制粒度的整数倍。端口下配置的抑制值可能与实际生效抑制值不一致,实际生效抑制值可通过display interface命令查看。

l              当设备没有指定pps参数,或者抑制粒度等于1时,则设置参数必须不小于1,端口配置抑制值即为实际生效的抑制值。

【描述】

unicast-suppression命令用来在接口下设置未知单播风暴抑制比。undo unicast-suppression命令用来恢复缺省情况。

缺省情况下,所有接口不对未知单播流量进行抑制。

在以太网接口视图下执行该命令,则该配置只在当前接口下生效;在端口组视图下执行该命令,则该配置将在端口组中的所有端口下生效。

需要注意的是,本命令设置的是接口允许通过的最大未知单播报文流量。当接口上的未知单播流量超过用户设置的值后,系统将丢弃超出未知单播流量限制的报文,从而使接口未知单播流量所占的比例降低到限定的范围,保证网络业务的正常运行。

l          在设备同时支持全局和接口下配置的情况下,当全局和接口下都配置了抑制比,则接口对未知单播报文的处理会根据这两个限制去判断,最先达到的限制生效。

l          如果在以太网接口视图或端口组视图下多次配置不同的抑制比数值时,最新的配置生效。

 

【举例】

# 在以太网接口Ethernet1/1上,最多允许相当于该接口传输能力20%的未知单播报文通过,对超出该范围的未知单播报文进行抑制。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] unicast-suppression 20

# 在手工端口组group1内的所有端口上,最多允许相当于每个端口传输能力20%的未知单播报文通过,对超出该范围的未知单播报文进行抑制。

<Sysname> system-view

[Sysname] port-group manual group1

[Sysname-port-group-manual-group1] group-member ethernet 2/0

[Sysname-port-group-manual-group1] group-member ethernet 2/1

[Sysname-port-group-manual-group1] unicast-suppression 20

1.2.17  virtual-cable-test

【命令】

virtual-cable-test

【视图】

二层以太网接口视图

【缺省级别】

2:系统级

【参数】

【描述】

virtual-cable-test命令用来对以太网接口连接电缆进行一次检测,并显示检测的结果。

需要注意的是:

l              当电缆状态为正常时,显示信息中的长度是指该电缆的总长度;

l              当电缆状态非正常时,显示信息中的长度是指从本接口到异常位置的长度。

l          光类型接口不支本命令。

l          在以太网接口上执行该操作会使得已经up的链路自动updown一次。

l          检测结果仅供参考,检测到的长度最大可能存在的误差为5米,如果显示值为“-”,则表示不支持该项参数的检测。

 

MSR系列路由器各款型对于本节所描述的命令及参数的支持情况有所不同,详细差异信息如下:

命令

MSR 900

MSR 20-1X

MSR 20

MSR 30

MSR 50

virtual-cable-test

Yes(仅二层固定以太网交换接口支持)

Yes(仅二层固定以太网交换接口支持)

Yes(仅二层固定以太网交换接口支持)

Yes(仅安装了XMIM-FSW模块的款型支持)

No

 

【举例】

# 开启系统对以太网电口连接电缆的检测功能。

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] virtual-cable-test

Cable status: normal, 1 metres

Pair Impedance mismatch: -

Pair skew: - ns

Pair swap: -

Pair polarity: -

Insertion loss: - db

Return loss: - db

Near-end crosstalk: - db

表1-11 virtual-cable-test命令显示信息描述表

字段

描述

Cable status

电缆状态包括normal正常abnormal异常abnormal(open)异常开路abnormal(short)异常短路failure检测失败

Pair Impedance mismatch

线对阻抗失配(取值为yes时表示阻抗匹配,为no时表示阻抗不匹配)

Pair skew

线对不对称

Pair swap

线对交换

Pair polarity

是否极性交换

Insertion loss

插入信号衰减

Return loss

返回信号衰减

Near-end crosstalk

近端串扰

 

1.3  三层以太网接口和子接口配置命令

1.3.1  mac-address

【命令】

mac-address mac-address

undo mac-address

【视图】

三层以太网接口视图/三层以太网子接口视图

【缺省级别】

2:系统级

【参数】

mac-addressMAC地址,形式为H-H-H

【描述】

mac-address命令用来配置三层以太网接口/子接口的MAC地址。undo mac-address命令用来恢复缺省情况。

缺省情况下,三层以太网接口的MAC地址可以通过display interface命令查看。

需要注意的是:

l              配置三层以太网子接口MAC地址时,子接口与主接口MAC地址不可使用同一地址。

l              子接口MAC地址配置,不建议使用VRRP协议保留MAC地址段。

【举例】

# 配置三层以太网接口的MAC地址为0001-0001-0001

<Sysname> system-view

[Sysname] interface ethernet 1/1

[Sysname-Ethernet1/1] mac-address 1-1-1

1.3.2  mtu

【命令】

mtu size

undo mtu

【视图】

三层以太网接口视图/三层以太网子接口视图

【缺省级别】

2:系统级

【参数】

size:以太网接口或子接口允许通过的MTUMaximum Transmission Unit,最大传输单元)的大小,取值范围取决于接口的类型,单位为字节。

【描述】

mtu命令用来设置以太网接口或子接口的MTU值。undo mtu命令用来恢复MTU的缺省值。

缺省情况下,以太网接口和子接口的MTU值均为1500字节。

由于QoS队列长度的限制(如FIFO队列的缺省长度为75),MTU太小会造成分片太多,从而被QoS队列丢弃。此时,可适当增大MTU值或QoS队列的长度。以太网接口视图下的命令qos fifo queue-length可以改变QoS队列长度(具体配置请参见“ACLQoS命令参考”中的“拥塞管理”)。

 

【举例】

# 设置三层以太网接口Ethernet2/0的最大传输单元为1430Bytes

<Sysname> system-view

[Sysname] interface ethernet 2/0

[Sysname-Ethernet2/0] mtu 1430

# 设置三层以太网子接口Ethernet2/0.1的最大传输单元为1400Bytes

<Sysname> system-view

[Sysname] interface ethernet 2/0.1

[Sysname-Ethernet2/0.1] mtu 1400

1.3.3  promiscuous

【命令】

promiscuous

undo promiscuous

【视图】

三层以太网接口视图

【参数】

【描述】

promiscuous命令用来将以太网接口设为混杂模式。undo promiscuous命令用来取消以太网接口混杂模式。

缺省情况下,以太网接口为非混杂模式。

当以太网接口被配置为混杂模式后将不再进行MAC地址过滤,接收所有正确的以太网报文。该模式主要用于网络监听功能。

【举例】

# 将以太网接口Ethernet2/0设置为混杂模式。

<Sysname> system-view

[Sysname] interface ethernet 2/0

[Sysname-Ethernet2/0] promiscuous

1.3.4  qmtoken

【命令】

qmtoken number

undo qmtoken

【视图】

三层以太网接口视图

【缺省级别】

2:系统级

【参数】

number:三层以太接口发送令牌的个数,必须是2的幂,取值范围41024,缺省值为512

【描述】

qmtoken命令用于配置三层以太接口发送令牌的个数。undo qmtoken命令用于恢复接口发送令牌个数的缺省值。

当接口支持时,修改令牌个数会引发接口down/up一次。

MSR系列路由器各款型对于本节所描述的命令及参数的支持情况有所不同,详细差异信息如下:

命令

MSR 900

MSR 20-1X

MSR 20

MSR 30

MSR 50

qmtoken

No

Yes

MSR 20-12不支持

Yes

Yes

Yes

 

命令

参数

MSR 20-1X

MSR 20

MSR 30

MSR 50

qmtoken

number

取值范围是41024,缺省值为512

取值范围是41024,缺省值为512

取值范围是41024,缺省值为512

 

MSR 30-11缺省值为1024

取值范围是41024,缺省值为512

 

【举例】

# 配置GigabitEthernet0/0接口发送令牌的个数为8

<Sysname> system-view

[Sysname] interface GigabitEthernet 0/0

[Sysname-GigabitEthernet0/0] qmtoken 8


不同款型规格的资料略有差异, 详细信息请向具体销售和400咨询。H3C保留在没有任何通知或提示的情况下对资料内容进行修改的权利!