选择区域语言: EN CN HK

RIP在BGP MPLS VPN 中应用典型配置指导

手册下载

BGP/MPLS VPN

典型基本配置指导

Hangzhou H3C Technologies Co., Ltd.

杭州华三通信技术有限公司

All rights reserved

版权所有  侵权必究


 

1   特性介绍................................................................................................................................. 1

2   特性的优点............................................................................................................................. 1

3   使用指南................................................................................................................................. 2

3.1    使用场合......................................................................................................................... 2

3.2    配置步骤......................................................................................................................... 2

3.2.1   配置PE................................................................................................................. 2

3.2.2   配置CE................................................................................................................. 5

3.2.3   配置P................................................................................................................... 5

3.3    注意事项......................................................................................................................... 6

3.4    举例................................................................................................................................ 6

3.4.1   组网需求............................................................................................................... 6

3.4.2   组网图.................................................................................................................. 6

3.4.3   配置..................................................................................................................... 7

3.4.4   验证结果............................................................................................................. 14

3.4.5   故障排除............................................................................................................. 16

4   关键命令............................................................................................................................... 17

4.1    mpls lsr-id...................................................................................................................... 17

4.2    mpls.............................................................................................................................. 18

4.3    mpls ldp........................................................................................................................ 18

5   相关资料............................................................................................................................... 19

5.1    相关协议和标准.............................................................................................................. 19

5.2    其它相关资料................................................................................................................. 19

 


关键词:BGPMPLSVPN

    要:本文简单描述BGP/MPLS VPN的特点,详细描述了路由器上配置BGP/MPLS VPN的基本方法和详细步骤,给出了一种BGP/MPLS VPN基本的配置案例。

缩略语:

缩略语

英文全名

中文解释

MPLS

Multiprotocol Label Switching

多协议标签交换

VPN

Virtual Private Network

虚拟私有网

BGP

Border Gateway Protocol

边界网关协议

PE

Provider Edge

运营商边缘

P

Provider

运营商网络

CE

Customer Edge

用户网络边缘

LSP

Label Switched Path

标签交换路径

LDP

Ldp DIstributIion Protocol

标签分发协议

 

1         特性介绍

MPLS是多协议标签交换的简称,它用短而定长的标签来封装网络层分组。MPLS最初是为提高路由器的转发速度而提出一个协议,但是,它的用途已不仅仅局限于此,而是广泛地应用于流量工程、VPNQoS等方面。

MPLSVPN的实现提供了一种简单、灵活、高效的隧道机制,在VPN的不同站点(site)之间建立LSP,用来传递VPN报文。每个站点将到达自己的路由发送给骨干网,这些路由在骨干网中加上标签以及VPN的成员信息进行分布。

BGP/MPLS VPN是利用BGP为信令协议在运营商骨干网上传播VPN的私网路由信息,用MPLS为转发通道运行私网流量。

BGP/MPLS VPN提供与通过IP Tunnel组成的点到点面向连接的VPN相同的安全等级。VPN的安全通过如下措施保障:

l       在骨干网中,分离VPN的数据流;

l       在运营商骨干网边缘,确保从用户接收到的报文进入正确的VPN

2         特性的优点

MPLSVPN中的应用,使一个运营商的网络可以同时支撑多个不同客户的IP VPN,在每一个客户看来都是一个专门的私有网络,并且易于管理、扩充性好、同基于点到点面向连接的VPN具有相同安全级别、具有QoS保障及可实现任意节点互连。

3         使用指南

3.1        使用场合

在运营商的网络上同时支持多个客户的私网业务,并且客户端有可能进行网络扩充。

3.2        配置步骤

MPLS VPN模型中,包含三个组成部分:CEPEP

l       CECustomer Edge)设备:是用户网络边缘设备,有接口直接与服务提供商相连,可以是路由器或是交换机等。CE“感知”不到VPN的存在。

l       PEProvider Edge)路由器:即运营商边缘路由器,是运营商网络的边缘设备,与用户的CE直接相连。MPLS网络中,对VPN的所有处理都发生在PE路由器上。

l       PProvider)路由器:运营商网络中的骨干路由器,不和CE直接相连。P路由器需要支持MPLS能力。

CEPE的划分主要是从运营商与用户的管理范围来划分的,CEPE是两者管理范围的边界。

3.2.1       配置PE

1.     MPLS基本能力配置

MPLS基本能力配置包括:

1)    配置MPLSLSR ID
2)    全局使能MPLS以及MPLS LDP
3)    在所使用的接口视图下使能MPLS以及MPLS LDP能力

1     MPLS基本能力配置

视图

命令

说明

系统视图

mpls lsr-id ip-address

配置MPLSLSR ID(必须为32位的loopback口地址)

系统视图

mpls

全局使能MPLS

系统视图

mpls ldp

全局使能MPLS LDP

P设备相连的接口视图

mpls

接口使能MPLS

P设备相连的接口视图

mpls ldp enable

接口使能MPLS LDP

 

2.     定义VPN实例

1)    创建并进入VPN实例视图
2)    配置VPN-instanceRD
3)    路由标识RDVPN创建路由和转发表,并指定缺省的路由标识。将RD添加到一个特定的IPv4前缀的开始,使之成为全局唯一的VPN IPv4前缀。
4)    配置vpn-instancevpn-target属性
5)    VPN-target用来控制VPN路由信息的发布,该属性是BGP的扩展团体属性。

2     定义VPN实例

视图

命令

说明

系统视图

ip vpn-instance vpn-instance-name

创建并进入VPN实例视图

VPN实例视图

route-distinguisher route-distinguisher

配置VPN-instanceRD

VPN实例视图

vpn-target vpn-target-extcommunity [ import-extcommunity | export-extcommunity | both ]

vpn-instance创建vpn-target扩展团体

 

3.     配置PECE间进行路由交换

PECE间的常用的路由交换方式有RIPOSPFEBGP

1)    PE上配置RIP多实例
2)    PECE之间配置RIP时,需要在PE上指定RIP实例的运行环境。使用该命令进入路由实例的配置视图,并在此视图下配置RIP路由实例的引入、发布等,然后配置RIP多实例引入IBGP路由。

3     PE上配置RIP多实例的命令

视图

命令

说明

CE设备相连的接口视图

ip binding vpn-instance  vpn-instance-name

接口绑定在vpn-instance-name

CE设备相连的接口视图

ip address ip-address net-mask

配置地址

系统视图

rip

进入RIP视图

RIP视图

ip vpn-instance vpn-instance-name

创建RIP多实例

RIP多实例视图

network network-address

发布与CE相连路由

RIP多实例视图

import-route direct

发布直连路由

 

3)    PE上配置OSPF多实例
4)        PECE之间配置OSPF时,需要在PE上指定OSPF实例的运行进程。使用该命令进入路由实例的配置视图,并在此视图下配置OSPF路由实例的引入、发布等,然后配置OSPF多实例引入IBGP路由。

4     PE上配置OSPF多实例的命令

视图

命令

说明

CE设备相连的接口视图

ip binding vpn-instance  vpn-instance-name

接口绑定在vpn-instance-name

CE设备相连的接口视图

ip address  ip-address net-mask

配置地址

系统视图

ospf 1 vpn-instance vpn-instance-name

创建OSPF多实例

ospf多实例视图

area area-id 

进入OSPF

ospf多实例域视图

network ip-address wildcard

发布与CE相连路由

ospf多实例视图

import-route direct

发布直连路由

 

5)    PE上配置EBGP

PECE之间运行EBGP,应在MP-BGPVPN-instance视图下,为每个VPN配置邻居,并引入CEIGP路由。

5     PE上配置BGP多实例的命令

视图

命令

说明

CE设备相连的接口视图

ip binding vpn-instance  vpn-instance-name

接口绑定在vpn-instance-name

CE设备相连的接口视图

ip address ip-address net-mask

配置地址

系统视图

bgp as-number

进入BGP视图

BGP视图

ipv4-family vpn-instance vpn-instance-name

创建BGP多实例

BGP多实例视图

group group-name external

创建BGP多实例下的组

BGP多实例视图

peer peer-address group group -name as as-number

把相连的CE设备的地址放到组里,as-numberCE设备所在的AS

BGP多实例视图

import-route direct

发布直连路由

 

4.     配置PE-PE间进行路由交换

1)    PE上配置MP-IBGP协议,使得PE之间能够交互VPN-IPv4路由。

6     PE上配置MP-IBGP协议的命令

视图

命令

说明

系统视图

bgp as-number

进入BGP视图

BGP视图

group group-name internal

创建组

BGP视图

peer peer-address group group -name

peer-address为对端PELSR-ID

BGP视图

peer group-name connect-interface LoopBack interface-number

指定BGP会话使用的TCP连接接口为loopback

BGP视图

ipv4-family vpnv4

进入MBGPvpnv4视图

BGP VPNV4视图

peer group-name enable

VPNV4下使能组

BGP VPNV4视图

peer peer-address group group-name

把对端在VPNV4激活

 

3.2.2       配置CE

CE路由器作为用户端设备,仅需要做一些基本的配置,使之能够实现与PE设备进行路由信息的交换。目前常用的路由交换方式有RIPOSPFEBGP等。

1)    CE上配置RIP

如选择RIP作为CE-PE间的路由交换方式,则应在CE上配置RIP,并可以根据需要引入直连路由、静态路由及其他IGP路由,发布给PE。具体的配置请参考《Comware V3 操作手册》。

2)    CE上配置OSPF

如选择OSPF作为CE-PE间的路由交换方式,则应在CE上配置OSPF,并可以根据需要引入直连路由、静态路由及其他IGP路由,发布给PE。具体的配置请参考《Comware V3 操作手册》。

3)    CE上配置EBGP

如选择BGP作为CE-PE间的路由交换方式,则应在CE上配置EBGP对等体,并可以根据需要引入直连路由、静态路由及其他IGP路由,发布给PE。具体的配置请参考《Comware V3 操作手册》。

3.2.3       配置P

P路由器不需要维护VPN路由,但需要保证公网的连通性,并配合PE建立LSP,故需要如下配置:

第一步:配置MPLS基本能力,并在PPE相连的各接口上使能LDP,以转发MPLS报文。

第二步:在PPE相连的各接口上启动IGP路由协议,如RIPOSPF等并引入直连路由,也可以直接配置静态路由,实现PE内部的互通。具体的配置请参考《Comware V3 操作手册》。

3.3        注意事项

当配置BGP/MPLS VPN时,必须注意以下事项:

1)    使能MPLS的路由器必须配置掩码为32位的Loopback地址作为mpls lsr-id
2)    PE之间的BGP需要使能VPNV4能力。

3.4        举例

3.4.1       组网需求

本例使用一个通用组网,使用的路由器为H3C系列化路由器,RTARTBRTC需要支持MPLS 能力,RTKRTNRTGRTH为一般的中低端路由器。

3.4.2       组网图

1        BGP/MPLS VPN典型基本配置组网

图中,RTAAR4640RTBAR4680RTCAR4680RTKAR2840RTNAR2880RTGAR2811RTHAR2880

RTARTCPE设备;RTBP设备;RTKRTACE设备,RTARTK之间应用OSPF多实例;RTNRTACE设备,RTARTN之间应用BGP多实例;RTGRTCCE设备,RTCRTG之间应用RIP多实例;RTHRTCCE设备,RTCRTH之间应用BGP多实例。

3.4.3       配置

1.     使用的版本

<H3C>display version

 Copyright Notice:

 All rights reserved (Jul 12 2005).

 Without the owner's prior written consent, no decompiling

 nor reverse-engineering shall be allowed.

 H3C Comware Platform Software

 Comware software, Version 3.40, Release RT-0012

 Copyright (c) 2004-2006 Hangzhou H3C Tech. Co.,Ltd. All rights reserved

.

H3C AR46-40 uptime is 0 week, 0 day, 2 hours, 22 minutes

 

 Rpu's version information:

 Router AR46-40 with 1 PowerPC 750 Processor

 256M     bytes SDRAM

 32M      bytes FLASH

 512K     bytes NVRAM

 Pcb      Version : RTM1RPUA.2

 RPE Logic Version : RPE3.4

 SBG Logic Version : 012

 Small BootROM  Version :  3.07

 Big BootROM  Version :  5.12

 Config Register points to FLASH

 

  [SLOT 0] AUX0     (Hardware)A.2, (Driver)1.0, (Cpld)3.4

  [SLOT 0] ETH0     (Hardware)A.2, (Driver)1.0, (Cpld)3.4

  [SLOT 0] ETH1     (Hardware)A.2, (Driver)1.0, (Cpld)3.4

  [SLOT 1] CPOS(E)  (Hardware)2.0, (Driver)1.0, (Cpld)1.0

  [SLOT 2] 2E1-F    (Hardware)1.0, (Driver)1.0, (Cpld)1.0

  [SLOT 3] 2SAE     (Hardware)0.1, (Driver)1.0, (Cpld)2.0

<H3C> vrbd

Routing Platform Software

Version AR46-40 8040V300R003B02D014 (ComwareV300R002B13D004), RELEASE SOFTWARE

Compiled Jul 12 2005 19:01:59 by Houming

2.     配置路由器RTA

当前视图

配置命令

简单说明

[H3C]

ip vpn-instance  vpna

创建一个VPN-Instance-vpna

[H3C-vpn-vpna]

route-distinguisher 100:100

配置vpnaRD

[H3C-vpn-vpna]

vpn-target 100:100

配置vpnaRoute-target

[H3C-vpn-vpna]

quit

退回系统视图

[H3C]

ip vpn-instance  vpnb

创建一个VPN-Instance-vpnb

[H3C-vpn-vpnb]

route-distinguisher 100:200

配置vpnbRD

[H3C-vpn-vpnb]

vpn-target 100:200

配置vpnbRoute-target

[H3C-vpn-vpnb]

quit

退回系统视图

[H3C]

interface LoopBack 9

设置LoopBack 9

[H3C-LoopBack9] 

ip address 60.40.1.2 255.255.255.255

配置一个地址用于作为mpls lsr-id32位的loopback

[H3C-LoopBack9] 

quit

退回系统视图

[H3C]

mpls lsr-id 60.40.1.2

配置mpls lsr-id

[H3C]

mpls

系统下使能mpls

[H3C-mpls]

mpls ldp

系统下使能mpls ldp

[H3C]

interface s2/0/0

进入与RTB相连的接口

[H3C-Serial2/0/0]

ip address 12.1.1.1 255.255.255.0

配置IP地址

[H3C-Serial2/0/0]

mpls

接口下使能mpls

[H3C-Serial2/0/0]

mpls ldp enable

接口下使能mpls ldp

[H3C-Serial2/0/0]

quit

退回系统视图

[H3C]

interface Ethernet4/0/0

进入连接用户RTK的接口视图

[H3C-Ethernet4/0/0]

ip binding vpn-instance vpna

指定当前接口绑定到vpna

[H3C-Ethernet4/0/0]

ip address 8.1.1.1 255.255.255.0

配置IP地址

[H3C-Ethernet4/0/0]

quit

退回系统视图

[H3C]

interface Ethernet4/0/1

进入连接用户RTN的接口视图

[H3C-Ethernet4/0/1]

ip binding vpn-instance vpnb

指定当前接口绑定到vpnb

[H3C-Ethernet4/0/1]

ip address 9.1.1.1 255.255.255.0

配置IP地址

[H3C-Ethernet4/0/1]

quit

退回系统视图

[H3C]

ospf 100

创建ospf100进程

[H3C-ospf-100]

area 0 

进入area0

[H3C-ospf-100-area-0.0.0.0]

network 12.1.1.0 0.0.0.255

发布与RTB的直联路由

[H3C-ospf-100-area-0.0.0.0]

network 60.40.1.2 0.0.0.0

发布loopback 9的地址

[H3C-ospf-100-area-0.0.0.0]

quit

退出area0

[H3C-ospf-100]

quit

退回系统视图

[H3C]

ospf 200 vpn-instance vpna

创建ospf vpna的多实例进程200

[H3C-ospf-200]

area 0

进入area0

[H3C-ospf-200-area-0.0.0.0]

network 8.1.1.0 0.0.0.255

发布与RTK的直联路由

[H3C-ospf-200-area-0.0.0.0]

quit

退出area0

[H3C-ospf-200]

import-route bgp  

引入bgp路由

[H3C-ospf-200]

quit

退回系统视图

[H3C]

bgp 100

进入BGP视图,AS号为100

[H3C-bgp]

group in100 internal

配置一个名为in100ASgroup

[H3C-bgp]

peer 46.80.1.2 group in100

46.80.1.2RTCmpls lsr-id)放在in100

[H3C-bgp]

peer in100 connect-interface LoopBack9

指明与in100建立邻居采用的是loopback9

[H3C-bgp]

ipv4-family vpnv4

进入vpnv4视图

[H3C-bgp-af-vpn]

peer in100 enable

vpnv4中使能in100

[H3C-bgp-af-vpn]

peer 46.80.1.2 group in100

vpnv4中使能46.80.1.2

[H3C-bgp-af-vpn]

quit

退出vpnv4视图

[H3C-bgp]

ipv4-family vpn-instance vpna

创建vpnabgp多实例视图

[H3C-bgp-af-vpn-instance] 

import-route ospf 200

引入发布ospf 200的路由

[H3C-bgp-af-vpn-instance] 

import-route ospf-ase 200

引入发布ospf 200的五类路由

[H3C-bgp-af-vpn-instance] 

import-route direct

引入发布直连路由

[H3C-bgp-af-vpn-instance] 

quit

退出vpna多实例视图

[H3C-bgp]

ipv4-family vpn-instance vpnb

创建vpnbbgp多实例视图

[H3C-bgp-af-vpn-instance]

group ex200 external

创建vpnb多实例的ASgroup ex200

[H3C-bgp-af-vpn-instance]

peer 9.1.1.2 group ex200 as-number 200

RTN的直联地址放到组ex200

[H3C-bgp-af-vpn-instance]

import-route direct 

引入发布直连路由

[H3C-bgp-af-vpn-instance]

quit

退出vpnb多实例视图

[H3C-bgp]

quit

退出bgp视图

 

3.     配置路由器RTB

当前视图

配置命令

简单说明

[H3C]

interface LoopBack 9

设置LoopBack 9

[H3C-LoopBack9] 

ip address 46.80.1.1 255.255.255.255

配置一个地址用于作为mpls lsr-id32位的loopback

[H3C-LoopBack9] 

quit

退回系统视图

[H3C]

mpls lsr-id 46.80.1.1

配置mpls lsr-id

[H3C]

mpls

系统下使能mpls

[H3C-mpls]

mpls ldp

系统下使能mpls ldp

[H3C]

interface s2/0/0

进入与RTA相连的接口

[H3C-Serial2/0/0]

ip address 12.1.1.2 255.255.255.0

配置IP地址

[H3C-Serial2/0/0]

mpls

接口下使能mpls

[H3C-Serial2/0/0]

mpls ldp enable

接口下使能mpls ldp

[H3C-Serial2/0/0]

quit

退回系统视图

[H3C]

interface s2/0/1

进入与RTC相连的接口

[H3C-Serial2/0/1]

ip address 11.1.1.2 255.255.255.0

配置IP地址

[H3C-Serial2/0/1]

mpls

接口下使能mpls

[H3C-Serial2/0/1]

mpls ldp enable

接口下使能mpls ldp

[H3C-Serial2/0/1]

quit

退回系统视图

[H3C]

ospf 100

 

[H3C-ospf-100]

area 0 

进入area0

[H3C-ospf-100-area-0.0.0.0]

network 12.1.1.0 0.0.0.255

发布与RTA的直联路由

[H3C-ospf-100-area-0.0.0.0]

network 11.1.1.0 0.0.0.255

发布与RTC直联的路由

[H3C-ospf-100-area-0.0.0.0]

network 46.80.1.1  0.0.0.0

发布loopback 9的地址

[H3C-ospf-100-area-0.0.0.0]

quit

退出area0

[H3C-ospf-100]

quit

退回系统视图

 

4.     配置路由器RTC

当前视图

配置命令

简单说明

[H3C]

ip vpn-instance  vpna

创建一个VPN-Instance-vpna

[H3C-vpn-vpna]

route-distinguisher 100:100

配置vpnaRD

[H3C-vpn-vpna]

vpn-target 100:100

配置vpnaRoute-target

[H3C-vpn-vpna]

quit

退回系统视图

[H3C]

ip vpn-instance  vpnb

创建一个VPN-Instance-vpnb

[H3C-vpn-vpnb]

route-distinguisher 100:200

配置vpnbRD

[H3C-vpn-vpnb]

vpn-target 100:200

配置vpnbRoute-target

[H3C-vpn-vpnb]

quit

退回系统视图

[H3C]

interface  LoopBack 9

设置LoopBack 9

[H3C-LoopBack9] 

ip address 46.80.1.2 255.255.255.255

配置一个地址用于作为mpls lsr-id32位的loopback

[H3C-LoopBack9] 

quit

退回系统视图

[H3C]

mpls lsr-id 46.80.1.2

配置mpls lsr-id

[H3C]

mpls

系统下使能mpls

[H3C-mpls]

mpls ldp

系统下使能mpls ldp

[H3C]

Interface s2/0/1

进入与RTB相连的接口

[H3C-Serial2/0/1]

ip address 11.1.1.1 255.255.255.0

配置IP地址

[H3C-Serial2/0/1]

mpls

接口下使能mpls

[H3C-Serial2/0/1]

mpls ldp enable

接口下使能mpls ldp

[H3C-Serial2/0/1]

quit

退回系统视图

[H3C]

interface Ethernet4/0/0

进入连接用户RTH的接口视图

[H3C-Ethernet4/0/0]

ip binding vpn-instance vpna

指定当前接口绑定到vpna

[H3C-Ethernet4/0/0]

ip address 15.1.1.1 255.255.255.0

配置IP地址

[H3C-Ethernet4/0/0]

quit

退回系统视图

[H3C]

interface Serial2/0/3

进入连接用户RTG的接口视图

[H3C-Serial2/0/3]

ip binding vpn-instance vpnb

指定当前接口绑定到vpnb

[H3C-Serial2/0/3]

ip address 16.1.1.1 255.255.255.0

配置IP地址

[H3C-Serial2/0/3]

rip version  2 broadcast

使能rip version  2

[H3C-Serial2/0/3]

quit

退回系统视图

[H3C]

ospf 100

创建ospf100进程

[H3C-ospf-100]

area 0 

进入area0

[H3C-ospf-100-area-0.0.0.0]

network 11.1.1.0 0.0.0.255

发布与RTB直联的路由

[H3C-ospf-100-area-0.0.0.0]

network 46.80.1.2 0.0.0.0

发布loopback的地址

[H3C-ospf-100-area-0.0.0.0]

quit

退出area0

[H3C-ospf-100]

quit

退回系统视图

[H3C]

rip

进入RIP视图

[H3C-rip]

ipv4-family vpn-instance vpnb 

创建RIP的多实例进程

[H3C-rip-af-vpn-instance]

undo summary

取消聚合

[H3C-rip-af-vpn-instance]

network 16.0.0.0

发布与RTG相连的地址

[H3C-rip-af-vpn-instance]

import-route direct

发布直连的地址

[H3C-rip-af-vpn-instance]

import-route bgp

发布BGP路由

[H3C-rip-af-vpn-instance]

quit

退出RIP的多实例进程

[H3C-rip]

quit

退出RIP

[H3C]

bgp 100

进入BGP视图,AS号为100

[H3C-bgp]

group in100 internal

配置一个名为in100ASgroup

[H3C-bgp]

peer 60.40.1.2 group in100

60.40.1.2RTAmpls lsr-id)放在in100

[H3C-bgp]

peer in100 connect-interface LoopBack9

指明与in100建立邻居采用的是loopback9

[H3C-bgp]

ipv4-family vpnv4

进入vpnv4视图

[H3C-bgp-af-vpn]

peer in100 enable

vpnv4中使能in100

[H3C-bgp-af-vpn]

peer 60.40.1.2 group in100

vpnv4中使能60.40.1.2

[H3C-bgp-af-vpn]

quit

退出vpnv4视图

[H3C-bgp]

ipv4-family vpn-instance vpna

创建vpnabgp多实例视图

[H3C-bgp-af-vpn-instance]

group ex300 external

创建vpna多实例的ASgroup ex300

[H3C-bgp-af-vpn-instance]

peer 15.1.1.2 group ex200 as-number 200

RTH的直联地址放到组ex200

[H3C-bgp-af-vpn-instance]

import-route direct 

引入发布直连路由

[H3C-bgp-af-vpn-instance]

quit

退出vpna多实例视图

[H3C-bgp]

ipv4-family vpn-instance vpnb

创建vpnbbgp多实例视图

[H3C-bgp-af-vpn-instance] 

import-route rip

引入发布rip多实例的路由

[H3C-bgp-af-vpn-instance] 

import-route direct

引入发布直连路由

[H3C-bgp-af-vpn-instance] 

quit

退出vpnb多实例视图

[H3C-bgp]

quit

退出bgp视图

 

5.     配置路由器RTK

当前视图

配置命令

简单说明

[H3C]

interface Ethernet0/1

进入连接RTA的接口视图

[H3C-Ethernet0/1]

ip address 8.1.1.2 255.255.255.0

配置IP地址

[H3C-Ethernet0/1]

quit

退回系统视图

[H3C]

ospf 100

创建ospf100进程

[H3C-ospf-100]

area 0 

进入area0

[H3C-ospf-100-area-0.0.0.0]

network 8.1.1.0 0.0.0.255

发布与RTA直联路由

[H3C-ospf-100-area-0.0.0.0]

quit

退出area0

[H3C-ospf-100]

import direct

发布直联路由

[H3C-ospf-100]

quit

退回系统视图

[H3C]

interface LoopBack 10

设置LoopBack 10,用于验证配置结果

[H3C-LoopBack10] 

ip address 52.32.1.2 255.255.0.0

 

[H3C-LoopBack10] 

quit

 

 

6.     配置路由器RTN

当前视图

配置命令

简单说明

[H3C]

interface Ethernet4/1

进入连接RTA的接口视图

[H3C-Ethernet4/1]

ip address 9.1.1.2 255.255.255.0

配置IP地址

[H3C-Ethernet4/1]

quit

退回系统视图

[H3C]

bgp 200

进入BGP视图

[H3C-bgp]

group ex100 external

配置一个名为ex100ASgroup

[H3C-bgp]

peer 9.1.1.1 group ex100 as-number 100

9.1.1.1(与RTA的直联地址)放在ex100

[H3C-bgp]

import direct

发布直联路由

[H3C-bgp]

quit

退回系统视图

[H3C]

interface LoopBack 10

设置LoopBack 10,用于验证配置结果

[H3C-LoopBack10] 

ip address 56.82.1.2 255.255.0.0

配置IP地址

[H3C-LoopBack10] 

quit

退出视图

 

7.     配置路由器RTH

当前视图

配置命令

简单说明

[H3C]

interface Ethernet4/0

进入连接RTC的接口视图

[H3C-Ethernet4/0]

ip address 15.1.1.2 255.255.255.0

配置IP地址

[H3C-Ethernet4/0]

quit

退回系统视图

[H3C]

bgp 300

进入BGP视图

[H3C-bgp]

group ex100 external

配置一个名为ex100ASgroup

[H3C-bgp]

peer 15.1.1.1 group ex100 as-number 100

15.1.1.1(与RTC的直联地址)放在ex100

[H3C-bgp]

import direct

发布直联路由

[H3C-bgp]

quit

退回系统视图

[H3C]

interface LoopBack 10

设置LoopBack 10,用于验证配置结果

[H3C-LoopBack10] 

ip address 56.82.1.1 255.255.0.0

配置IP地址

[H3C-LoopBack10] 

quit

退回系统视图

[H3C]

 

 

 

8.     配置路由器RTG

当前视图

配置命令

简单说明

[H3C]

interface Serial1/1

进入连接RTC的接口视图

[H3C-Serial1/1]

ip address 16.1.1.2 255.255.255.0

配置IP地址

[H3C-Serial1/1]

rip version 2 broadcast

配置rip version 2

[H3C-Serial1/1]

quit

退回系统视图

[H3C]

rip

进入RIP视图

[H3C-rip]

no summary

取消聚合

[H3C-rip]

network 16.0.0.0

发布与RTC的直联路由

[H3C-rip]

import direct

发布直联路由

[H3C-rip]

quit

退回系统视图

[H3C]

interface LoopBack 10

设置LoopBack 10,用于验证配置结果

[H3C-LoopBack10] 

ip address 28.11.1.1 255.255.0.0

配置IP地址

[H3C-LoopBack10] 

quit

退回系统视图

3.4.4       验证结果

1.     RTA/RTC查看PE之间的BGP连接,已经Established,并具有vpnv4能力

[RTA-bgp]display bgp peer verbose

Peer: 46.80.1.2+2364    Local: 60.40.1.2+179

         Type: Internal

         State: Established      Flags: <>

         Expiring Time: 00:02:49

         Last State: OpenConfirm Last Event: RecvKeepAlive

         Last Error: None

         Options: <>

         Peer Version: 4 Peer ID: 172.31.32.53   Local ID: 172.31.32.56

         Active Holdtime: 180s, Keepalive: 60s

         Group Bit: 0    Send state: in sync

         Last traffic (seconds): Received 11     Sent 12 Checked 12

         Input messages: Total 1         Updates 0       Octets 534

         Output messages: Total 2        Updates 0       Octets 64

         Peer capabilities:

           Route refresh: advertised and received

           Ipv4-family Unicast: advertised and received

           Ipv4-family VPNv4: advertised and received

2.     查看PEP之间的MPLS LDP 是否正常建立sessionOperational

[RTB]display mpls ldp session

Displaying information about all sessions:

   Local LDP ID: 46.80.1.1:0;   Peer LDP ID: 60.40.1.2:0

   TCP Connection: 46.80.1.1 <- 60.40.1.2

   Session State: Operational

   Session Role: Passive

   Session existed time: 3 hours 26 minutes 41 seconds

   Basic Hello Packets Sent/Received: 3144/3105

   KeepAlive Packets Sent/Received: 517/517

   Negotiated Keepalive hold time: 60   Peer PV Limit: 0

   LDP Basic Discovery Source((A) means active):

   Serial2/0/0(A)

 

   Local LDP ID: 46.80.1.1:0;   Peer LDP ID: 46.80.1.2:0

   TCP Connection: 46.80.1.1 <- 46.80.1.2

   Session State: Operational

   Session Role: Passive

   Session existed time: 3 minutes 9 seconds

   Basic Hello Packets Sent/Received: 2419/48

   KeepAlive Packets Sent/Received: 8/8

   Negotiated Keepalive hold time: 60   Peer PV Limit: 0

   LDP Basic Discovery Source((A) means active):

   Serial2/0/1(A)                 

3.     查看PECE之间 是否分别正常建立OSPFBGPRIP多实例的连接

[RTK]display ospf peer

                 OSPF Process 100 with Router ID 150.1.1.1

                                Neighbors

  Area 0.0.0.0 interface 8.1.1.2(Ethernet0/1)'s neighbor(s)

  RouterID: 8.1.1.1         Address: 8.1.1.1

        State: Full  Mode: Nbr is Slave  Priority: 1

        DR: 8.1.1.1  BDR: 8.1.1.2

        Dead timer expires in 36s

        Neighbor has been up for 02:55:44

 

<RTN>display bgp peer

Peer       AS-num Ver Queued-Tx  Msg-Rx    Msg-Tx    Up/Down    State

---------------------------------------------------------------------------

9.1.1.1    100    4   0          174       174       02:51:48   Established

<RTG>display rip

  RIP is running

  public net

    Checkzero is on         Default cost : 1

    Summary is on           Preference : 100

    Validate-source-address is on

    Traffic-share-across-interface is off

    Period update timer : 30

    Timeout timer : 180

    Garbage-collection timer : 120

    No peer router

    Network :

    16.0.0.0

    Import-route direct  cost : 1  

[RTH]display bgp peer

Peer        AS-num Ver Queued-Tx   Msg-Rx    Msg-Tx  Up/Down    State

---------------------------------------------------------------------------

15.1.1.1    100    4    0          167      167      02:45:05   Established

4.     查看客户A-RTK的路由正确出现在客户A-RTH上,客户A-RTH的路由正确出现在客户A-RTK上, PING包,包可互通

[RTK] display ip routing-table

 Routing Table: public net

Destination/Mask   Protocol Pre  Cost        Nexthop         Interface

8.1.1.0/24         DIRECT   0    0           8.1.1.2         Ethernet0/1

8.1.1.2/32         DIRECT   0    0           127.0.0.1       InLoopBack0

15.1.1.0/24        O_ASE    150  1           8.1.1.1         Ethernet0/1

56.82.0.0/16       O_ASE    150  1           8.1.1.1         Ethernet0/1

……………

<RTK>ping 56.82.1.1

  PING 56.82.1.1: 56  data bytes, press CTRL_C to break

    Reply from 56.82.1.1: bytes=56 Sequence=1 ttl=255 time=1 ms

    Reply from 56.82.1.1: bytes=56 Sequence=2 ttl=255 time=1 ms

    Reply from 56.82.1.1: bytes=56 Sequence=3 ttl=255 time=1 ms

    Reply from 56.82.1.1: bytes=56 Sequence=4 ttl=255 time=1 ms

    Reply from 56.82.1.1: bytes=56 Sequence=5 ttl=255 time=1 ms

  --- 56.82.1.1 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

    round-trip min/avg/max = 1/1/1 ms     

 [RTH]display ip routing-table

 Routing Table: public net

Destination/Mask   Protocol Pre  Cost        Nexthop         Interface

8.1.1.0/24         BGP      256  0           15.1.1.1        Serial1/1

15.1.1.0/24        DIRECT   0    0           15.1.1.2        Serial1/1

15.1.1.2/32        DIRECT   0    0           127.0.0.1       InLoopBack0

52.32.0.0/16       BGP      256  0           15.1.1.1        Serial1/1

 <RTH>ping 52.32.1.2

  PING 52.32.1.2: 56  data bytes, press CTRL_C to break

    Reply from 52.32.1.2: bytes=56 Sequence=1 ttl=255 time=1 ms

    Reply from 52.32.1.2: bytes=56 Sequence=2 ttl=255 time=1 ms

    Reply from 52.32.1.2: bytes=56 Sequence=3 ttl=255 time=2 ms

    Reply from 52.32.1.2: bytes=56 Sequence=4 ttl=255 time=1 ms

    Reply from 52.32.1.2: bytes=56 Sequence=5 ttl=255 time=1 ms

  --- 52.32.1.2 ping statistics ---

    5 packet(s) transmitted

    5 packet(s) received

    0.00% packet loss

round-trip min/avg/max = 1/1/2 ms            

同理,查看客户B- RTN的路由是否正确出现在客户B-RTG上,客户B-RTG的路由是否正确出现在客户B-RTN上, PING包,包可互通。

5.     客户ARTK/RTH看不到来自客户B-RTN/RTG的路由,客户BRTN/RTG看不到来自客户A-RTK/RTH的路由。

#察看没有来自非本客户端的路由。

[H3C]display ip routing-table

正常的情况下没有来自非本客户端的路由。

3.4.5       故障排除

1.     接口使能MPLS LDP协议后,PEP不能与对端建立会话

原因:用display ip routing查看路由表,如果本机得不到对方的LSR ID的路由,就不能建立TCP连接,会话就不可能建立。

解决方法:建立会话时默认的传输地址是MPLS LSR ID,本机必须将LSR ID的路由(为32位掩码的loopback地址)发布出去,同时,要学到对端的LSR ID的路由。

2.     PE之间的BGP邻居不能正常的建立

原因1:没有用于建立BGP邻居的对端loopback接口的路由。

解决方法:根据3.4.4中各IGP查看邻居关系的命令,查看PEP之间IGP邻居是否正常建立,IGP协议是否已经将loopback接口的路由发布。

原因2:建立BGP邻居时,没有指明用于建立邻居的接口是loopback口。

解决方法:BGP视图下需要配置peer group connect-interface loopback *

4         关键命令

4.1        mpls lsr-id

【命令】

mpls lsr-id ip-address

【视图】

系统视图

【参数】

ip-addressLSRID,形如IP地址,用来标识一个LSR

【描述】

mpls lsr-id命令用来配置LSRID

缺省情况下,LSR没有ID号。

要求LSR-ID的地址是本机的接口地址,且这个地址全网内路由可达,一般情况下建议使用loopback接口的地址。

使用这个命令配置LSRID号,是配置其它MPLS命令的前提。

相关配置可参考命令display mpls interface

【举例】

# 配置该LSRID202.17.41.246

[H3C] mpls lsr-id 202.17.41.246

% Mpls lsr-id changed.

4.2        mpls

【命令】

mpls

【视图】

系统视图、接口视图、虚拟接口视图

【参数】

【描述】

在系统视图下,mpls命令用来在全局下启动MPLS功能并进入MPLS视图。

在接口视图下,mpls命令用来使能接口的MPLS能力。

缺省情况下,不进入该视图。

执行该命令之后,用户会进入MPLS视图。只有在进入MPLS视图以后才可以配置MPLS的其它命令。

需首先配置mpls lsr-id,才可以进入MPLS视图。

【举例】

# 系统视图下进入MPLS视图。

[H3C]mpls

[H3C-mpls]

# 接口视图下执行MPLS

[H3C-Ethernet0/0/0]mpls

% Info: MPLS in the interface is starting, please wait...OK 

4.3        mpls ldp

【命令】

mpls ldp

【视图】

系统视图

【参数】

【描述】

mpls ldp命令用来使能LDP协议。

缺省情况下,LDP协议未启动。

使能LDP前需要首先使能MPLS,并且配置LSR ID

相关配置可参考命令mpls lsr-id

【举例】

# 使能LDP协议。

[H3C]mpls ldp

5         相关资料

5.1        相关协议和标准

7     相关协议与标准

标准号

标题

RFC2547

BGP/MPLS VPNs

RFC 3031

Multiprotocol Label Switching Architecture

RFC 3036

LDP Specification

RFC 1771

A Border Gateway Protocol 4 (BGP-4)

RFC 2283

Multiprotocol Extensions for BGP-4

 

5.2        其它相关资料

Comware V3 操作手册》

Comware V3 命令手册》