国家 / 地区

H3C ER系列路由器商业营销平台微信认证 典型配置举例-6W103

手册下载

H3C ER系列路由器商业营销平台微信认证

典型配置举例

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Copyright © 2019 新华三技术有限公司 版权所有,保留一切权利。

非经本公司书面许可,任何单位和个人不得擅自摘抄、复制本文档内容的部分或全部,并不得以任何形式传播。

除新华三技术有限公司的商标外,本手册中出现的其它公司的商标、产品标识及商品名称,由各自权利人拥有。

本文档中的信息可能变动,恕不另行通知。



简介

本文档介绍了与ER系列路由器商业营销平台微信认证有关的典型配置指导。商业营销平台适用于商铺、酒店等不同应用场景。

配置前提

本文档不严格与具体软、硬件版本对应,如果使用过程中与产品实际情况有差异,请以设备实际情况为准。

本文档中的配置均是在实验室环境下进行的配置和验证,配置前设备的所有参数均采用出厂时的缺省配置。如果您已经对设备进行了配置,为了保证配置效果,请确认现有配置和以下举例中的配置不冲突。

本文档假设您已了解商业营销平台特性。

商业营销平台主要应用于商铺、酒店、车展以及咖啡厅等,本章主要介绍商铺应用以及酒店应用场景下的典型配置案例。其他应用场景和这两种情况类似,不再赘述。

商铺应用典型配置举例

3.1  组网需求

该组网运用云WiFi功能,实现推送广告、吸收微信粉丝、保留部分用户信息数据、用户在线认证等功能。适用于大部分环境,如商铺、车展、咖啡厅等。

1所示,RouterER系列路由器,提供云WiFi功能;SwitchS2626-PWR交换机,为AP提供PoE供电;无线终端通过AP获取到路由器分配的地址,其中Host AHost B获取到VLAN101的网段地址10.1.1.X/24Host C获取到VLAN102的网段地址10.1.2.X/24。并且Host AHost BHost C通过微信认证后可以正常上网。

图1 ER 系列商业营销平台微信认证组网图

 

3.2  配置思路

请根据当前环境需求确认是否需要多个AP。若环境只需要一个AP,可以使用ER3108GWERG2-1350WERG2-450WERG2-1200W或者ER2100n设备代替1组网中的ER RouterSwitchAP组成的环境,该两款设备自带无线信号。

3.3  配置注意事项

本环境配置需要对商业营销平台、ER路由器和S2626-PWR交换机一同配置,S2626-PWRA20为组合AP环境。

3.4  配置步骤

3.4.1  配置ER路由器

(1)       2所示,新建VLAN101VLAN102,其中默认VLAN1用于非认证用户网络,VLAN101VLAN102用于微信认证用户网络。

页面向导:接口管理→VLAN设置→VLAN设置

图2 配置VLAN虚接口

 

(2)       3所示,将LAN 1口配置为允许所有VLAN通过。

页面向导:接口管理→VLAN设置→Trunk口设置

图3 配置Trunk

 

(3)       4所示,新增VLAN101VLAN102DHCP地址池。VLAN101地址范围为10.1.1.210.1.1.255VLAN102地址范围为10.1.2.210.1.2.255

页面向导:接口管理→DHCP设置→DHCP设置

图4 配置VLAN虚接口的地址池

 

(4)       5所示,将ER Router注册并绑定到平台上,如何注册和绑定请点击右上角帮助。将VLAN101VLAN102接口绑定,被绑定的接口为启用云WiFi的接口。

页面向导:云WiFi→云WiFi设置→云WiFi

图5 WiFi配置

 

3.4.2  配置交换机

# S2626-PWR交换机的接口上做如下配置。

[SwitchA] vlan 101 to 102

 Please wait... Done.

[SwitchA] interface Ethernet1/0/1

[SwitchA-Ethernet1/0/1] port access vlan 101

[SwitchA-Ethernet1/0/1] interface Ethernet1/0/2

[SwitchA-Ethernet1/0/2] port access vlan 102          

[SwitchA-Ethernet1/0/2] Interface Ethernet1/0/3

[SwitchA-Ethernet1/0/3] port access vlan 101

[SwitchA] interface GigabitEthernet 1/0/25

[SwitchA-GigabitEthernet1/0/25] port link-type trunk

Please wait... Done.

[SwitchA-GigabitEthernet1/0/25] port trunk permit vlan all

3.4.3  配置商业营销平台

(1)       设置微信认证

本例以新华三绿洲平台公众号为例进行说明。如6所示,将得到的公众号开发者ID配置在AppID栏,公众号开发者密钥配置在AppSecret栏。

需要注意的是:

·            需要开启微信开发者权限。

·            需要开通微信扫一扫功能插件。

·            建议通过微信认证。

页面向导:商业营销平台→系统设置→微信公众号设置

图6 公众号配置

 

(2)       设置微信认证配置和模板。

7所示,用户可根据自身喜好自主设计认证模板。该页面中SSID名称和SSID密码为必须配置项,且需要与AP上的配置一致,才能保证“微信扫一扫”能够正确处理。点击下载,生成“微信扫一扫”二维码,如8所示。

页面向导:商业营销平台→认证设置→微信设置

图7 公众号微信认证配置

 

图8 生成“微信扫一扫”二维码

 

(3)       设置微信认证方式

免认证为广告认证,微信认证需要通过微信平台实现。具体使用何种认证可自行选择。

页面向导:商业营销平台→认证设置→模式设置

图9 公众号微信认证模式

 

3.5  验证配置

(1)       手机微信扫描二维码完成认证上网,以下为一系列微信认证的流程

a.   手机扫描二维码,弹出上网认证页面,如图10中①所示,点击“立即连接”按钮

b.   页面将跳转到手机WLAN设置页面,如图10中②所示,连接商铺Wi-Fi

c.   图10中③所示,弹出“正在连接”页面

d.   跳转到“Wi-Fi连接成功”页面,点击“完成”或关注公众号完成认证上网流程,如图10中④所示

图10 认证上网

 

说明

苹果手机和Android手机认证上网过程稍有不同,请以实际效果为准。

 

(2)       从访客信息中可以查看到用户已上线,且用户IP地址和MAC地址正确。

页面向导:商业营销平台商铺账号→访客管理→访客列表

图11 访客信息

 

酒店应用典型配置举例

4.1  组网需求

12所示,该组网适用于酒店的环境,实现无线用户需要认证,有线用户不需要认证,且根据无线用户与有线用户的网段不同,区分该用户所处位置。RouterER路由器,提供云WiFi配置功能且对AP进行管理;Switch A为汇聚层交换机,提供交换功能;Switch BSwitch CPoE交换机,为A20供电。将VLAN100在云WiFi页面进行绑定操作。

图12 ER系列商业营销平台微信认证组网图

 

4.2  配置思路

当无线用户获取到的IP地址为ER路由器分配时,用户才能够正常使用云WiFi业务提供的免认证和二次无感免认证等功能,所以ER路由器需要提供全局地址池服务。因为下属无线用户群需要跨网段获取,所以ER路由器需要配置一条路由表项,通过交换机的DHCP Relay功能,将全局地址池分配至指定用户群。

4.3  配置注意事项

本环境配置需要对商业营销平台、ER路由器、AP、汇聚层交换机和PoE交换机一同配置。

4.4  配置步骤

4.4.1  配置ER路由器

(1)       13所示,新增VLAN2VLAN3VLAN100,其中VLAN1VLAN2VLAN3用于非认证用户网络,即普通的有线用户。VLAN100用于微信认证用户网络,即普通的无线用户,IP地址为192.168.100.1VLAN1VLAN2VLAN3用于不认证的用户网路,IP地址分别为192.168.1.1/24192.168.2.1/24192.168.3.1/24。新建VLAN3999,该VLAN用于管理AP(如果环境中无我司AP设备,请忽略),IP地址配置为1.1.1.1/30

页面向导:接口管理→VLAN设置→VLAN设置

图13 配置VLAN虚接口

 

(2)       14所示,将LAN口配置对应的VLANLAN 1Switch A对接,配置LAN 1允许所有VLAN通过。

页面向导:接口管理→VLAN设置→Trunk口设置

图14 配置Trunk

 

(3)       15所示,新增VLAN2VLAN3DHCP地址池;新增Global1Global2的全局地址池。配置VLAN100DHCP地址池(必选项,全局地址池需要绑定对应的VLAN接口)。全局地址池如16所示,对应的网段为10.1.1.X10.1.2.X,地址池区间为3254,网关为10.1.X.2DNS192.168.100.1,即VLAN100的地址。

页面向导:接口管理→DHCP设置→DHCP设置

图15 配置VLAN虚接口的地址池和全局地址池

 

图16 配置全局地址池

 

(4)       17所示,将设备注册并绑定到平台上,如何注册和绑定请点击右上角帮助,将VLAN100接口绑定。

页面向导:云WiFi→云WiFi设置→云WiFi

图17 WiFi配置

 

(5)       18所示,配置一条静态路由表项,目的地址为10.0.0.0,掩码为255.0.0.0,下一跳地址为192.168.100.2,出接口为VLAN100

页面向导:高级设置→路由设置→静态路由

图18 静态路由配置

 

(6)       以下为AP配置项,用于对AP进行批量管理。如19所示,启用AP管理功能,设置AP管理使用VLANVLAN3999

页面向导:AP管理→AP管理设置

图19 配置AP管理设置

 

20所示,在配置模板管理中修改AP配置模板。双击无线模板,弹出SSID配置页面,如21所示,修改SSID名称、启用高级设置、配置桥接VLANVLAN101

页面向导:AP管理→配置管理→配置模板管理

图20 AP配置模板管理

 

页面向导:AP管理→配置管理→配置模板管理

图21 SSID配置

 

通过双击在线AP列表中的AP,弹出AP配置模板页面,如22所示,将配置模板同步到该AP

页面向导:AP管理→在线AP管理→在线AP列表

图22 AP配置模板选择

 

4.4.2  配置交换机

(1)       配置Switch A

# 设置交换机上的接口。

[SwitchA] vlan 100

[SwitchA-vlan100] interface vlan100

[SwitchA-Vlan-interface3] ip address 192.168.100.2 24

[SwitchA] vlan 101 to 102

 Please wait... Done.

[SwitchA] vlan 1 to 3

 Please wait... Done.

[SwitchA] interface vlan 101

[SwitchA-Vlan-interface101] ip address 10.1.1.2 24

[SwitchA-Vlan-interface101] interface vlan 102

[SwitchA-Vlan-interface102] ip address 10.1.2.2 24

[SwitchA-Vlan-interface102] interface vlan 103

[SwitchA] interface GigabitEthernet 1/0/25

[SwitchA-GigabitEthernet1/0/25] port link-type trunk

Please wait... Done.

[SwitchA-GigabitEthernet1/0/25] port trunk permit vlan1 to 3 100

[SwitchA-GigabitEthernet1/0/25] port trunk pvidvlan 100

[SwitchA-GigabitEthernet1/0/25] quit

[SwitchA] interface Ethernet1/0/1

[SwitchA-Ethernet1/0/1] port link-type trunk

Please wait... Done.

[SwitchA-Ethernet1/0/1] port trunk permit vlan1 to 2 101

[SwitchA-Ethernet1/0/1] interface Ethernet1/0/2

[SwitchA-Ethernet1/0/2] port link-type trunk

Please wait... Done.

[SwitchA-Ethernet1/0/2] port trunk permit vlan3 102

# 设置DHCP Relay环境。

[SwitchA] dhcp relay server-group 0ip 192.168.100.1

[SwitchA] interface range Vlan-interface 101 to Vlan-interface 102

[SwitchA-if-range] dhcp relay server-select 0

[SwitchA-if-range] dhcp select relay

# 设置默认路由。

[SwitchA] ip route-static 0.0.0.0 0 Vlan-interface 100 192.168.100.1

(2)       配置Switch B

# 设置交换机上的接口。

[SwitchB] vlan 101 to 102

 Please wait... Done.

[SwitchB] interface Ethernet1/0/1

[SwitchB-Ethernet1/0/1] port link-type trunk

Please wait... Done.

[SwitchB-Ethernet1/0/1] port trunk permit vlan all

[SwitchB-Ethernet1/0/1] port trunk pvidvlan 1

[SwitchB-Ethernet1/0/1] interface Ethernet1/0/2

[SwitchB-Ethernet1/0/2] port link-type trunk

Please wait... Done.

[SwitchB-Ethernet1/0/2] port trunk permit vlan all

[SwitchB-Ethernet1/0/2] port trunk pvidvlan 2

[SwitchB-Ethernet1/0/2] quit

[SwitchB] interface GigabitEthernet 1/0/25

[SwitchB-GigabitEthernet1/0/25] port link-type trunk

Please wait... Done.

[SwitchB-GigabitEthernet1/0/25] port trunk permit vlan all

(3)       配置Switch C

Switch B配置相似,略。

4.4.3  配置商业营销平台

(1)       设置微信认证

本例以新华三绿洲平台公众号为例进行说明。如23所示,将得到的公众号开发者ID配置在AppID栏,公众号开发者密钥配置在AppSecret栏。

需要注意的是:

·            需要开启微信开发者权限。

·            需要开通微信扫一扫功能插件。

·            建议通过微信认证。

页面向导:商业营销平台→系统设置→微信公众号设置

图23 公众号配置

 

(2)       设置微信认证配置和模板。

默认的微信店铺设置模板如24所示,用户可根据自身喜好自主设计认证模板。该页面中SSID名称和SSID密码为必须配置项,且需要与AP上的配置一致,才能保证“微信扫一扫”能够正确处理。点击下载,生成“微信扫一扫”二维码,如25所示。

页面向导:商业营销平台→认证设置→微信设置

图24 公众号微信认证配置

 

图25 生成“微信扫一扫”二维码

 

(3)       设置微信认证方式

免认证为广告认证,微信认证需要通过微信平台实现。具体使用何种认证可自行选择。

页面向导:商业营销平台→认证设置→模式设置

图26 公众号微信认证模式

 

4.5  验证配置

(1)       手机微信扫描二维码完成认证上网,以下为一系列微信认证的流程

a.   手机扫描二维码,弹出上网认证页面,如图27中①所示,点击“立即连接”按钮

b.   页面将跳转到手机WLAN设置页面,如图27中②所示,连接酒店Wi-Fi

c.   图27中③所示,弹出“正在连接”页面

d.   跳转到“Wi-Fi连接成功”页面,点击“完成”或关注公众号完成认证上网流程,如图27中④所示。

图27 认证上网

 

说明

苹果手机和Android手机认证上网过程稍有不同,请以实际效果为准。

 

(2)       从访客信息中可以查看到用户已上线,且用户IP地址和MAC地址正确。

页面向导:商业营销平台商铺账号→访客管理→访客列表

图28 访客信息